FreshPorts -- The Place For Ports If you buy from Amazon USA, please support us by using this link.
Follow us
Blog
Twitter

I am looking for an LTO tape library. Do you have one to spare?
non port: head/Mk/bsd.wx.mk
SVNWeb

Number of commits found: 27

Mon, 24 Mar 2014
[ 15:53 bapt ] Original commit 
349022 Mk/bsd.wx.mk
349022 graphics/wxsvg/Makefile
349022 multimedia/dvdstyler/Makefile
Convert wxsvg to use wxGTK 3.0
Remove the component part from bsd.wx.mk as only dvdstyler uses it
Make dvdstyle use wxGTK 3.0
[ 14:09 bapt ] Original commit 
349003 Mk/bsd.wx.mk
wxGTK 2.9 was a development version now that wxGTK 3.0 is out remove it
[ 13:30 bapt ] Original commit 
348997 Mk/bsd.wx.mk
wxGTK 2.6 is EOLed upstream, all ports have switch to at least wxGTK 2.8
[ 09:45 bapt ] Original commit 
348927 Mk/bsd.wx.mk
Use modern LIB_DEPENDS
Wed, 22 Jan 2014
[ 13:46 gahr ] Original commit 
340709 Mk/bsd.wx.mk
340709 x11-toolkits/Makefile
340709 x11-toolkits/wxgtk30
340709 x11-toolkits/wxgtk30/Makefile
340709 x11-toolkits/wxgtk30/distinfo
340709 x11-toolkits/wxgtk30/files
340709 x11-toolkits/wxgtk30/files/patch-Makefile.in
340709 x11-toolkits/wxgtk30/files/patch-configure
340709 x11-toolkits/wxgtk30/files/patch-src-common-translation.cpp
340709 x11-toolkits/wxgtk30/files/patch-utils-wxrc-Makefile.in

(Only the first 10 of 12 ports in this commit are shown above. View all ports for this commit)
New port: x11-toolkits/wxgtk30 -- Series 3.0 of the wxWidgets toolkit

PR:		181329 (based on)
Submitted by:	Rainer Hurling <rhurlin@gwdg.de>
Thu, 19 Sep 2013
[ 09:58 gahr ] Original commit 
327608 Mk/bsd.wx.mk
- Revert file erroneously included in my previous commit

Reported by:	bapt
[ 09:49 gahr ] Original commit 
327607 Mk/Uses/tcl.mk
327607 Mk/Uses/tk.mk
327607 Mk/bsd.default-versions.mk
327607 Mk/bsd.sanity.mk
327607 Mk/bsd.wx.mk
- Implement USES+=tcl and USES+=tk
- Use bsd.default-versions.mk to specify the default Tcl/Tk version (8.6)
- Add warnings about the now deprecated use of USE_TCL, USE_TK, ...

  Notes:

  * USES+=tcl and USES+=tk take the following optional arguments

    - either a version in the form of XY or XY+, or 'wrapper' to depend on
      lang/tcl-wrapper or x11-toolkits/tk-wrapper

    - either 'build' (bring in build depend) or 'run' (bring in run depend)

  * it is an error to specify both 'tcl' and 'tk' in USES.

  * The functionality currently implemented via INVALID_TCL_VER and
    INVALID_TK_VER is not yet available.

Approved by:	bapt (portmgr)
Fri, 26 Oct 2012
[ 06:23 bapt ] Original commit 
306418 MOVED
306418 Mk/bsd.wx.mk
306418 x11-toolkits/Makefile
306418 x11-toolkits/py-wxPython24
306418 x11-toolkits/wxgtk24
306418 x11-toolkits/wxgtk24-contrib
306418 x11-toolkits/wxgtk24-docs
Not supported upstream anymore, consider using more recent versions

Approved by:	fjoe (maintainer)
Feature safe:	yes
Wed, 23 May 2012
[ 08:17 miwi ] Original commit 
1.36 Mk/bsd.apache.mk
1.42 Mk/bsd.autotools.mk
1.14 Mk/bsd.cmake.mk
1.11 Mk/bsd.commands.mk
1.75 Mk/bsd.database.mk
1.4 Mk/bsd.destdir.mk
1.64 Mk/bsd.gcc.mk
1.58 Mk/bsd.gecko.mk
1.174 Mk/bsd.gnome.mk
1.52 Mk/bsd.gstreamer.mk

(Only the first 10 of 33 ports in this commit are shown above. View all ports for this commit)
- Remove emacs mode, -*- mode: ...; -*- [1]
- Comments for BUILD_ and RUN_DEPENDS fail to mention alternate means to specify
dependencie [2]
- Fix make reinstall [3]
- Trivial comment change for PORTDATA [4]

PR:             151954 [1]
                161314 [2]
                167085 [3]
                167465 [4]
Submitted by:   Anonymous <swell.k@gmail.com> [1]
                dougb@ and Chris Rees <utisoft@gmail.com> [2]
                Garrett Cooper <yanegomi@gmail.com> [3]
                "Bryan Drewery" <bryan@shatow.net> [4]
Tested via:     phw
Sun, 11 Dec 2011
[ 18:49 pav ] Original commit 
1.18 Mk/bsd.wx.mk
- Add support for wx 2.9 while not making it default

PR:             ports/163006
Submitted by:   fjoe
Feature safe:   yes
Sun, 4 Dec 2011
[ 18:26 pav ] Original commit 
1.17 Mk/bsd.wx.mk
- Revert addition of 2.9 temporarily, individual ports need to be fixed for
  compatibility first

Feature safe:   yes
Fri, 2 Dec 2011
[ 08:18 pav ] Original commit 
1.16 Mk/bsd.wx.mk
- Add support for wx 2.9
- Reassign to a new maintainer

PR:             ports/163006
Submitted by:   fjoe
Feature safe:   yes
Sun, 15 Aug 2010
[ 19:39 nox ] Original commit 
1.15 Mk/bsd.wx.mk
1.21 graphics/wxsvg/Makefile
1.6 graphics/wxsvg/distinfo
1.2 graphics/wxsvg/files/patch-configure.in
1.4 graphics/wxsvg/pkg-plist
1.36 multimedia/dvdstyler/Makefile
1.12 multimedia/dvdstyler/distinfo
1.14 multimedia/dvdstyler/pkg-plist
- Update graphics/wxsvg to 1.0.5 and wx 2.8 which thus needs an Mk/bsd.wx.mk
  change.
- Update multimedia/dvdstyler to 1.8.1 which seems to be the only port in
  the tree using wxsvg.

Approved by:    kwm (for -multimedia), portmgr (pav, for Mk/bsd.wx.mk)
Sat, 13 Jun 2009
[ 16:35 erwin ] Original commit 
1.14 Mk/bsd.wx.mk
Remove wxmozilla option as it depends on a port that expired in January.
Sat, 19 Apr 2008
[ 17:56 miwi ] Original commit 
1.3 Mk/bsd.efl.mk
1.46 Mk/bsd.gnustep.mk
1.76 Mk/bsd.kde.mk
1.2 Mk/bsd.ocaml.mk
1.10 Mk/bsd.scons.mk
1.13 Mk/bsd.wx.mk
1.7 Mk/bsd.xorg.mk
1.64 accessibility/at-spi/Makefile
1.43 accessibility/dasher/Makefile
1.65 accessibility/gail/Makefile

(Only the first 10 of 2842 ports in this commit are shown above. View all ports for this commit)
- Remove unneeded dependency from gtk12/gtk20 [1]
- Remove USE_XLIB/USE_X_PREFIX/USE_XPM in favor of USE_XORG
- Remove X11BASE support in favor of LOCALBASE or PREFIX
- Use USE_LDCONFIG instead of INSTALLS_SHLIB
- Remove unneeded USE_GCC 3.4+

Thanks to all Helpers:
        Dmitry Marakasov, Chess Griffin, beech@, dinoex, rafan, gahr,
        ehaupt, nox, itetcu, flz, pav

PR:             116263
Tested on:      pointyhat
Approved by:    portmgr (pav)
Fri, 19 Oct 2007
[ 02:21 alepulver ] Original commit 
1.12 Mk/bsd.wx.mk
- Remove Unicode checks for FreeBSD < 5.x (unsupported).

PR:             ports/116891
Submitted by:   edwin
Sat, 29 Sep 2007
[ 17:54 alepulver ] Original commit 
1.18822 /CVSROOT/modules
1.11 Mk/bsd.wx.mk
1.468 x11-toolkits/Makefile
1.8 x11-toolkits/py-wxPython28-common/Makefile
1.6 x11-toolkits/py-wxPython28-common/pkg-plist
1.3 x11-toolkits/py-wxPython28-unicode/Makefile
1.65 x11-toolkits/py-wxPython28/Makefile
1.21 x11-toolkits/py-wxPython28/distinfo
1.24 x11-toolkits/py-wxPython28/pkg-plist
- Complete repocopy of x11-toolkits/py-wxPython28,
  x11-toolkits/py-wxPython28-common and x11-toolkits/py-wxPython28-unicode,
  applying the corresponding patches.
- Add PYDISTUTILS_NOEGGINFO to fix plist issues [1].
- Integrate with bsd.wx.mk: the noticeable difference is that ports using
  USE_WX=2.6+ and WX_COMPS=python will be built from now on with wxWidgets
  2.8, which was previously restricted for these ports because of the lack of
  the "python" component for version 2.6 [1].

PR:             ports/115349, ports/115350, ports/115351
Submitted by:   Neal Nelson <neal@nelson.name>
Reworked by:    alepulver (myself) [1]
Thu, 4 Jan 2007
[ 13:02 alepulver ] Original commit 
1.10 Mk/bsd.wx.mk
- Fix WANT_WX (broken since autodetection commit).

Reported by:    Mike Harding <mvh@ix.netcom.com>
Mon, 1 Jan 2007
[ 16:39 alepulver ] Original commit 
1.9 Mk/bsd.wx.mk
- Change WxWidgets to wxWidgets to match real application name.

Reported by:    pav
[ 01:04 alepulver ] Original commit 
1.8 Mk/bsd.wx.mk
- Remove _WX_ILLEGAL_VERS_* and introduce a new way of handling it.
- Do not add invalid dependencies in addition to setting IGNORE.
Sun, 31 Dec 2006
[ 17:57 alepulver ] Original commit 
1.7 Mk/bsd.wx.mk
- Fix autodetection.

Reported by:    pav
[ 14:27 pav ] Original commit 
1.6 Mk/bsd.wx.mk
- Re-add _WX_ILLEGAL_VERS_* handling removed in previous commit
[ 04:34 alepulver ] Original commit 
1.5 Mk/bsd.wx.mk
- Update comments for 2.8 version (section about available components).
- Add autodetection of installed versions to use if the user/port has not
  expressed any preference (done using own WANT_WX framework by itself).
- Remove _WX_ILLEGAL_VERS_* added in the last update to 2.8. The reason is
  that each port should choose the version it can use, that includes taking
  into account available components (also this brings much more chicken and
  egg problems so the code could get really messy).
- Correctly indent the first .for loop to initialize component information.
Sun, 3 Dec 2006
[ 18:04 pav ] Original commit 
1.4 Mk/bsd.wx.mk
- Skip versions for which requested component is not available. Fixes ports
  that define

  USE_WX=       2.4+
  WX_COMPS=     python
[ 15:24 fjoe ] Original commit 
1.3 Mk/bsd.wx.mk
- Add support for wxgtk2 2.8.
- Fix path to wxsvg.
Mon, 13 Nov 2006
[ 21:15 alepulver ] Original commit 
1.2 Mk/bsd.wx.mk
- Some comment fixes.
- Change dependency type separator from "_" to ":".
- Add WX_PREMK, WANT_UNICODE, WITHOUT_UNICODE, WXRC_CMD.
- Fix dependencies when using multiple components.
Wed, 5 Jul 2006
[ 02:13 linimon ] Original commit 
1.1 Mk/bsd.wx.mk
Add common code to support for WxWidgets based ports.

PR:             ports/89398
Submitted by:   alepulver

Number of commits found: 27

Login
User Login
Create account

Servers and bandwidth provided by
New York Internet, SuperNews, and RootBSD

This site
What is FreshPorts?
About the authors
FAQ
How big is it?
The latest upgrade!
Privacy
Forums
Blog
Contact

Search
Enter Keywords:
 
more...

Latest Vulnerabilities
chromiumAug 26
fileAug 21
py-djangoAug 21
py-django-develAug 21
py-django14Aug 21
py-django15Aug 21
php53Aug 18
phpmyadminAug 17
chromiumAug 13
serfAug 11
subversionAug 11
subversion17Aug 11
nginxAug 09
nginx-develAug 09
mingw32-opensslAug 06

6 vulnerabilities affecting 9 ports have been reported in the past 14 days

* - modified, not new

All vulnerabilities


Ports
Home
Categories
Deleted ports
Sanity Test Failures
Newsfeeds


Statistics
Graphs
NEW Graphs (Javascript)
Traffic

Calculated hourly:
Port count 24511
Broken 218
Deprecated 727
Ignore 562
Forbidden 36
Restricted 261
No CDROM 101
Vulnerable 23
Expired 1
Set to expire 717
Interactive 0
new 24 hours 8
new 48 hours10
new 7 days59
new fortnight98
new month259

Servers and bandwidth provided by
New York Internet, SuperNews, and RootBSD
Valid HTML, CSS, and RSS.
Copyright © 2000-2014 Dan Langille. All rights reserved.