FreshPorts -- The Place For Ports If you buy from Amazon USA, please support us by using this link.
Follow us
Blog
Twitter

Port details
ems-flasher Utility to flash ROM images to the EMS USB 64mb flash cart
0.03_6 comms on this many watch lists=1 search for ports that depend on this port Find issues related to this port Report an issue related to this port
Maintainer: root@cooltrainer.org search for ports maintained by this maintainer
Port Added: 22 Apr 2012 08:43:40
License: MIT
ems-flasher is software for flashing the EMS Gameboy USB 64 MBit cart.

WWW: http://lacklustre.net/redmine/projects/ems-flash/
SVNWeb : Homepage : PortsMon : pkg-plist

To install the port: cd /usr/ports/comms/ems-flasher/ && make install clean
To add the package: pkg install ems-flasher

PKGNAME: ems-flasher

distinfo:

SHA256 (ems-flasher-0.03.tgz) = d77723a3956e00a9b8af9a3545ed2c55cd2653d65137e91b38523f7805316786
SIZE (ems-flasher-0.03.tgz) = 7135


NOTE: FreshPorts displays only information on required and default dependencies. Optional dependencies are not covered.

Build dependencies:
  1. gmake : devel/gmake
  2. gcc6 : lang/gcc6
  3. as : devel/binutils
Runtime dependencies:
  1. gcc6 : lang/gcc6
There are no ports dependent upon this port

Configuration Options
     No options to configure

USES:
gmake tar:tgz

Master Sites:
  1. http://lacklustre.net/projects/ems-flasher/
  2. https://cooltrainer.org/freebsd-ports/ems-flasher/

Number of commits found: 11

Commit History - (may be incomplete: see SVNWeb link above for full details)
DateByDescription
10 Sep 2017 20:55:39
Original commit files touched by this commit  0.03_6
Revision:449591
gerald search for other commits by this committer
Bump PORTREVISION for ports depending on the canonical version of GCC
(via Mk/bsd.default-versions.mk and lang/gcc) which has moved from
GCC 5.4 to GCC 6.4 under most circumstances.

This includes ports
 - with USE_GCC=yes or USE_GCC=any,
 - with USES=fortran,
 - using Mk/bsd.octave.mk which in turn features USES=fortran, and
 - with USES=compiler specifying openmp, nestedfct, c++11-lib, c++11-lang,
   c++14-lang, c++0x, c11, or gcc-c++11-lib.

PR:		219275
01 Apr 2017 15:23:32
Original commit files touched by this commit  0.03_5
Revision:437439
gerald search for other commits by this committer
Bump PORTREVISIONs for ports depending on the canonical version of GCC and
lang/gcc which have moved from GCC 4.9.4 to GCC 5.4 (at least under some
circumstances such as versions of FreeBSD or platforms).

This includes ports
 - with USE_GCC=yes or USE_GCC=any,
 - with USES=fortran,
 - using using Mk/bsd.octave.mk which in turn has USES=fortran, and
 - with USES=compiler specifying openmp, nestedfct, c++11-lib, c++14-lang,
   c++11-lang, c++0x, c11, or gcc-c++11-lib.

PR:		216707
20 Nov 2016 09:38:09
Original commit files touched by this commit  0.03_4
Revision:426566
gerald search for other commits by this committer
Bump PORTREVISIONS for ports depending on the canonical version of GCC and
lang/gcc which have moved from GCC 4.8.5 to GCC 4.9.4 (at least under some
circumstances such as versions of FreeBSD or platforms).

In particular that is ports with USE_GCC=yes, USE_GCC=any, or one of
gcc-c++11-lib, openmp, nestedfct, c++11-lib as well as c++14-lang,
c++11-lang, c++0x, c11 requested via USES=compiler.
10 Sep 2014 20:50:37
Original commit files touched by this commit  0.03_3
Revision:367888
gerald search for other commits by this committer
Update the default version of GCC in the Ports Collection from GCC 4.7.4
to GCC 4.8.3.

Part II, Bump PORTREVISIONs.

PR:		192025
Tested by:	antoine (-exp runs)
Approved by:	portmgr (implicit)
11 May 2014 22:37:12
Original commit files touched by this commit  0.03_2
Revision:353741
bapt search for other commits by this committer
From PR:
Stage support,
Update master site

From me:
Convert to USES=tgz
Remove check for unsupported FreeBSD version

PR:		ports/189640
Submitted by:	Nicole Reid <root@cooltrainer.org>
13 Mar 2014 08:18:39
Original commit files touched by this commit  0.03_2
Revision:348047
miwi search for other commits by this committer
- Convert USE_GMAKE/USE_BZIP2 to USES
10 Mar 2014 20:55:22
Original commit files touched by this commit  0.03_2
Revision:347809
gerald search for other commits by this committer
Update the default version of GCC used in the Ports Collection from
GCC 4.6.4 to GCC 4.7.3.  This entails updating the lang/gcc port as
well as changing the default in Mk/bsd.default-versions.mk.

Part II, Bump PORTREVISIONs.

PR:		182136
Supported by:	Christoph Moench-Tegeder <cmt@burggraben.net> (fixing many ports)
Tested by:	bdrewery (two -exp runs)
26 Oct 2013 00:52:36
Original commit files touched by this commit  0.03_1
Revision:331644
gerald search for other commits by this committer
Update to libmpc version 1.0.1 which brings the following fixes:

 - Switched to automake 1.11.6, see CVE-2012-3386.
 - #14669: Fixed extraction of CC from gmp.h.
 - Fixed case of intermediate zero real or imaginary part in mpc_fma,
   found by hydra with GMP_CHECK_RANDOMIZE=1346362345.

This is on top of the following changes from version 1.0

 - Licence change towards LGPLv3+ for the code and GFDLv1.3+ (with no
   invariant sections) for the documentation.
 - 100% of all lines are covered by tests
 - Renamed functions
   . mpc_mul_2exp to mpc_mul_2ui
   . mpc_div_2exp to mpc_div_2ui
(Only the first 15 lines of the commit message are shown above View all of this commit message)
20 Sep 2013 16:03:29
Original commit files touched by this commit  0.03
Revision:327714
bapt search for other commits by this committer
Add NO_STAGE all over the place in preparation for the staging support (cat:
comms)
17 Aug 2013 16:27:24
Original commit files touched by this commit  0.03
Revision:324851
gerald search for other commits by this committer
Replace USE_GCC=4.6+ and USE_GCC=4.4+ by USE_GCC=yes.

Right now this is a noop in the former case and a noop in the latter
case unless lang/gcc44 has been installed explicitly.

This puts a bit more emphasis on standardizing on a canonical version
"current" GCC and makes it easier to update that canonical version
by changing the default in Mk/bsd.gcc.mk and updating the lang/gcc port.

That is, USE_GCC=yes means "use a decent/modern version of GCC" without
having to worry about details.

Approved by:	portmgr (bdrewery)
22 Apr 2012 08:43:12
Original commit files touched by this commit  0.03
pawel search for other commits by this committer
ems-flasher is software for flashing the EMS Gameboy USB 64 MBit cart.

WWW: http://lacklustre.net/redmine/projects/ems-flash/

PR:             ports/166915
Submitted by:   Nicole Reid <root@cooltrainer.org>

Number of commits found: 11

Login
User Login
Create account

Servers and bandwidth provided by
New York Internet, SuperNews, and RootBSD

This site
What is FreshPorts?
About the authors
Issues
FAQ
How big is it?
The latest upgrade!
Privacy
Forums
Blog
Contact

Search
Enter Keywords:
 
more...

Latest Vulnerabilities
arjOct 19
cactiOct 19
mariadb100-serverOct 19
mariadb101-serverOct 19
mariadb102-serverOct 19
mariadb55-serverOct 19
mysql55-serverOct 19
mysql56-serverOct 19
mysql57-serverOct 19
percona55-serverOct 19
percona56-serverOct 19
percona57-serverOct 19
krb5Oct 18
krb5-113Oct 18
krb5-114Oct 18

22 vulnerabilities affecting 93 ports have been reported in the past 14 days

* - modified, not new

All vulnerabilities


Ports
Home
Categories
Deleted ports
Sanity Test Failures
Newsfeeds

Statistics
Graphs
NEW Graphs (Javascript)
Traffic

Calculated hourly:
Port count 31600
Broken 154
Deprecated 76
Ignore 423
Forbidden 0
Restricted 175
No CDROM 78
Vulnerable 58
Expired 16
Set to expire 69
Interactive 0
new 24 hours 2
new 48 hours10
new 7 days22
new fortnight46
new month104

Servers and bandwidth provided by
New York Internet, SuperNews, and RootBSD
Valid HTML, CSS, and RSS.
Copyright © 2000-2017 Dan Langille. All rights reserved.