FreshPorts -- The Place For Ports If you buy from Amazon USA, please support us by using this link.
Follow us
Blog
Twitter

I am looking for an LTO tape library. Do you have one to spare?
Port details
postgresql81-server 8.1.23 databases Deleted on this many watch lists=43 search for ports that depend on this port This port version is marked as vulnerable.
Deprecated DEPRECATED: EOL see http://wiki.postgresql.org/wiki/PostgreSQL_Release_Support_Policy
Expired This port expired on: 2011-04-02
The most advanced open-source database available anywhere
Was Maintained by: girgen@FreeBSD.org search for ports maintained by this maintainer
Port Added: 28 Sep 2005 23:17:43
License: not specified in port


PostgreSQL is a sophisticated Object-Relational DBMS, supporting
almost all SQL constructs, including subselects, transactions, and
user-defined types and functions. It is the most advanced open-source
database available anywhere. Commercial Support is also available.

The original Postgres code was the effort of many graduate students, 
undergraduate students, and staff programmers working under the direction of 
Professor Michael Stonebraker at the University of California, Berkeley. In 
1995, Andrew Yu and Jolly Chen took on the task of converting the DBMS query 
language to SQL and created a new database system which came to known as 
Postgres95. Many others contributed to the porting, testing, debugging and 
enhancement of the Postgres95 code. As the code improved, and 1995 faded into 
memory, PostgreSQL was born.

PostgreSQL development is presently being performed by a team of Internet 
developers who are now responsible for all current and future development. The 
development team coordinator is Marc G. Fournier (scrappy@PostgreSQL.ORG). 
Support is available from the PostgreSQL developer/user community through the 
support mailing list (questions@PostgreSQL.ORG).

PostgreSQL is free and the complete source is available.

WWW: http://www.postgresql.org/
SVNWeb : Main Web Site : Distfiles Availability : PortsMon

NOTE: FreshPorts displays only required dependencies information. Optional dependencies are not covered.

Required To Build:
  1. devel/gmake
Required Libraries:
  1. devel/gettext
  2. databases/postgresql81-client
There are no ports dependent upon this port

No installation instructions: this port has been deleted.

The package name of this deleted port was: postgresql81-server


Configuration Options
===> The following configuration options are available for postgresql-server-8.1.23:
     NLS=on (default) "Use internationalized messages"
     PAM=off (default) "Build with PAM support (server only)"
     MIT_KRB5=off (default) "Build with MIT's kerberos support"
     HEIMDAL_KRB5=off (default) "Builds with Heimdal kerberos support"
     OPTIMIZED_CFLAGS=off (default) "Builds with compiler optimizations (-O3)"
     TESTS=off (default) "Allows the use of a "check" target (server)"
     DEBUG=off (default) "Builds with debugging symbols"
     ICU=off (default) "Use ICU for unicode collation (server)"
     HIER=off (default) "Builds with query hierarchy (server)"
     INTDATE=off (default) "Builds with 64-bit date/time type (server)"
===> Use 'make config' to modify these settings

Master Sites:
  1. ftp://ftp.FreeBSD.org/pub/FreeBSD/ports/distfiles/postgresql/
  2. ftp://ftp.at.postgresql.org/db/www.postgresql.org/pub/source/v8.1.23/
  3. ftp://ftp.be.postgresql.org/postgresql/source/v8.1.23/
  4. ftp://ftp.de.postgresql.org/mirror/postgresql/source/v8.1.23/
  5. ftp://ftp.ee.postgresql.org/mirrors/postgresql/source/v8.1.23/
  6. ftp://ftp.gr.postgresql.org/pub/databases/postgresql/source/v8.1.23/
  7. ftp://ftp.ie.postgresql.org/mirrors/ftp.postgresql.org/pub/source/v8.1.23/
  8. ftp://ftp.lv.postgresql.org/pub/postgresql/source/v8.1.23/
  9. ftp://ftp.postgresql.org/pub/source/v8.1.23/
  10. ftp://ftp.se.postgresql.org/pub/databases/relational/postgresql/source/v8.1.23/
  11. ftp://ftp10.us.postgresql.org/pub/postgresql/source/v8.1.23/
  12. ftp://ftp2.cz.postgresql.org/pub/postgresql/source/v8.1.23/
  13. ftp://ftp2.it.postgresql.org/mirrors/postgres/source/v8.1.23/
  14. ftp://ftp2.nl.postgresql.org/mirror/postgresql/source/v8.1.23/
  15. ftp://ftp2.ru.postgresql.org/pub/databases/postgresql/source/v8.1.23/
  16. ftp://ftp3.de.postgresql.org/pub/Mirrors/ftp.postgresql.org/source/v8.1.23/
  17. ftp://ftp3.ru.postgresql.org/pub/mirror/postgresql/pub/source/v8.1.23/
  18. ftp://ftp3.tw.postgresql.org/pub/postgresql/source/v8.1.23/
  19. ftp://ftp5.es.postgresql.org/mirror/postgresql/source/v8.1.23/
  20. ftp://ftp6.pl.postgresql.org/pub/postgresql/source/v8.1.23/
  21. ftp://ftp6.ro.postgresql.org/pub/mirrors/ftp.postgresql.org/source/v8.1.23/
  22. ftp://ftp7.pl.postgresql.org/pub/mirror/ftp.postgresql.org/source/v8.1.23/
  23. ftp://ftp9.us.postgresql.org/pub/mirrors/postgresql/source/v8.1.23/
  24. http://ftp2.jp.postgresql.org/pub/postgresql/source/v8.1.23/
  25. http://ring.nict.go.jp/archives/misc/db/postgresql/source/v8.1.23/
  26. http://ring.riken.jp/archives/misc/db/postgresql/source/v8.1.23/
Port Moves
  • port deleted on 2011-04-04
    REASON: Has expired: EOL; see http://wiki.postgresql.org/wiki/PostgreSQL_Release_Support_Policy

Number of commits found: 61

Commit History - (may be incomplete: see SVNWeb link above for full details)
DateByDescription
04 Apr 2011 17:12:43
Original commit files touched by this commit  8.1.23
 This port version is marked as vulnerable.
rene search for other commits by this committer
Garbage collect expired ports
2011-04-01 accessibility/linux-f8-atk: End of Life since Jan 7, 2009
2011-04-01 archivers/linux-f8-ucl: End of Life since Jan 7, 2009
2011-04-01 archivers/linux-f8-upx: End of Life since Jan 7, 2009
2011-04-01 audio/linux-f8-alsa-lib: End of Life since Jan 7, 2009
2011-04-01 audio/linux-f8-arts: End of Life since Jan 7, 2009
2011-04-01 audio/linux-f8-esound: End of Life since Jan 7, 2009
2011-04-01 audio/linux-f8-freealut: End of Life since Jan 7, 2009
2011-04-01 audio/linux-f8-libaudiofile: End of Life since Jan 7, 2009
2011-04-01 audio/linux-f8-libogg: End of Life since Jan 7, 2009
2011-04-01 audio/linux-f8-libvorbis: End of Life since Jan 7, 2009
2011-04-01 audio/linux-f8-mikmod: End of Life since Jan 7, 2009
2011-04-01 audio/linux-f8-nas-libs: End of Life since Jan 7, 2009
2011-04-01 audio/linux-f8-openal: End of Life since Jan 7, 2009
2011-04-01 audio/linux-f8-sdl_mixer: End of Life since Jan 7, 2009
(Only the first 15 lines of the commit message are shown above View all of this commit message)
01 Feb 2011 14:56:28
Original commit files touched by this commit  8.1.23
 This port version is marked as vulnerable.
girgen search for other commits by this committer
Expire old versions of PostgreSQL @ 2011-04-02

PR:             ports/153312, ports/153313, ports/153314
Feature safe:   yes
Approved by:    portmgr
30 Jan 2011 07:41:49
Original commit files touched by this commit  8.1.23
 This port version is marked as vulnerable.
az search for other commits by this committer
Fix @dirrmtry since it already filter stderr and return true.

PR:             ports/153892
Submitted by:   az@
Approved by:    maintainer (timeout)
Feature safe:   yes
31 Dec 2010 09:52:27
Original commit files touched by this commit  8.1.23
 This port version is marked as vulnerable.
mm search for other commits by this committer
- Update to 8.1.23
- fix ICU build

PR:             ports/153245
Approved by:    maintainer (timeout)
04 Dec 2010 07:34:27
Original commit files touched by this commit  8.1.22_1
 This port version is marked as vulnerable.
ade search for other commits by this committer
Sync to new bsd.autotools.mk
21 Nov 2010 23:48:49
Original commit files touched by this commit  8.1.22_1
 This port version is marked as vulnerable.
rene search for other commits by this committer
- Fix optional dependency on security/heimdal
- Bump PORTREVISION
PR:             ports/152029
Submitted by:   Joerg Pulz [Joerg.Pulz frm2.tum.de]
Approved by:    Ryan Steinmetz <rpsfa@rit.edu> (maintainer of net/freeradius*)
                girgen (maintainer of databases/postgresql*-server,
                        14 day timeout)
16 Oct 2010 11:52:47
Original commit files touched by this commit  8.1.22
 This port version is marked as vulnerable.
ade search for other commits by this committer
Punt autoconf267->autoconf268
07 Oct 2010 06:58:10
Original commit files touched by this commit  8.1.22
 This port version is marked as vulnerable.
girgen search for other commits by this committer
Update all PostgreSQL ports to latest versions.

Also, try to break the previous 1:1 relation between FreeBSD system and
PostgreSQL versions installed. Use different PREFIX:es to install
different versions on the same system.

PR: ports/132402, ports/145002, ports/146657
15 Sep 2010 18:35:24
Original commit files touched by this commit  8.1.21_2
 This port version is marked as vulnerable.
ade search for other commits by this committer
Autotools update.   Read ports/UPDATING 20100915 for details.

Approved by:    portmgr (for Mk/bsd.port.mk part)
Tested by:      Multiple -exp runs
13 Jun 2010 08:40:06
Original commit files touched by this commit  8.1.21_1
 This port version is marked as vulnerable.
erwin search for other commits by this committer
BROKEN should not be quoted.
No functional change.
31 May 2010 02:01:56
Original commit files touched by this commit  8.1.21_1
 This port version is marked as vulnerable.
ade search for other commits by this committer
Bounce PORTREVISION for gettext-related ports.  Have fun, ya'll.
20 May 2010 15:43:39
Original commit files touched by this commit  8.1.21
 This port version is marked as vulnerable.
girgen search for other commits by this committer
Update all PostgreSQL ports to latest version.

Remove postgresql-contrib in favour for postgresqlNN-contrib.
This way we will get packages built, which is nice.

Security:       CVE-2010-1169
Security:       CVE-2010-1170

The PostgreSQL Project today released minor versions updating all active
branches of the PostgreSQL object-relational database system, including
versions 8.4.4, 8.3.11, 8.2.17, 8.1.21, 8.0.25, and 7.4.29. This release
fixes moderate-risk security issues with PL/perl and PL/tcl, as well as
a data corruption issue with standby databases.  Users of any of these
three features should update their PostgreSQL installations immediately.
(Only the first 15 lines of the commit message are shown above View all of this commit message)
27 Mar 2010 00:15:24
Original commit files touched by this commit  8.1.17_1
 This port version is marked as vulnerable.
dougb search for other commits by this committer
Begin the process of deprecating sysutils/rc_subr by
s#. %%RC_SUBR%%#. /etc/rc.subr#
04 Jan 2010 20:37:30
Original commit files touched by this commit  8.1.17_1
 This port version is marked as vulnerable.
ale search for other commits by this committer
PTHREAD_[CFLAGS|LDFLAGS] are already set in CONFIGURE_ENV.

Approved by:    portmgr and maintainer timeout (1 month)
04 Jan 2010 20:29:37
Original commit files touched by this commit  8.1.17_1
 This port version is marked as vulnerable.
ale search for other commits by this committer
Don't link unneeded PTHREAD_LIBS. This fixes php extensions and apache modules.

Approved by:    portmgr and maintainer timeout (1 month)
15 Jul 2009 16:56:10
Original commit files touched by this commit  8.1.17
 This port version is marked as vulnerable.
dougb search for other commits by this committer
Fix a few "bad example" problems in the rc.d scripts that have been
propogated by copy and paste.

1. Primarily the "empty variable" default assignment, which is mostly
${name}_flags="", but fix a few others as well.
2. Where they are not already documented, add the existence of the _flags
(or other deleted empties) option to the comments, and in some cases add
comments from scratch.
3. Replace things that look like:
prefix=%%PREFIX%%
command=${prefix}/sbin/foo
to just use %%PREFIX%%. In many cases the $prefix variable is only used
once, and in some cases it is not used at all.
4. In a few cases remove ${name}_flags from command_args
5. Remove a long-stale comment about putting the port's rc.d script in
/etc/rc.d (which is no longer necessary).

No PORTREVISION bumps because all of these changes are noops.
18 Mar 2009 15:13:39
Original commit files touched by this commit  8.1.17
 This port version is marked as vulnerable.
girgen search for other commits by this committer
Update PostgreSQL to latest versions.

The PostgreSQL Project today released minor versions updating all active
branches of the PostgreSQL object-relational database system, including
versions 8.3.7, 8.2.13, 8.1.17, 8.0.21 and 7.4.25. This release fixes a denial
of service issue with encoding conversion, and all users should update their
installations at the next reasonable opportunity.

There are 12 other minor fixes contained in these update releases, including
fixes for xpath() functions in version 8.3. See the release notes for full
details.

URL: http://www.postgresql.org/docs/8.3/static/release-8-3-7.html
URL: http://www.postgresql.org/docs/8.2/static/release-8-2-13.html
URL: http://www.postgresql.org/docs/8.1/static/release.html#RELEASE-8-1-17
URL: http://www.postgresql.org/docs/8.0/static/release.html#RELEASE-8-0-21
URL: http://www.postgresql.org/docs/7.4/static/release.html#RELEASE-7-4-24
10 Feb 2009 11:59:15
Original commit files touched by this commit  8.1.16
 This port version is marked as vulnerable.
girgen search for other commits by this committer
Update PostgreSQL to latest versions.

URL: http://www.postgresql.org/about/news.1055

The PostgreSQL Project today released
updates to all active branches of the
PostgreSQL object-relational database
system, including versions 8.3.6,
8.2.12, 8.1.16, 8.0.20 and 7.4.24. These
updates include two serious fixes, for
autovacuum crashes in version 8.1 and
GiST indexing data loss in 8.3, and
those two versions should be updated as
soon as possible.
(Only the first 15 lines of the commit message are shown above View all of this commit message)
07 Nov 2008 19:29:56
Original commit files touched by this commit  8.1.15
 This port version is marked as vulnerable.
girgen search for other commits by this committer
Update PostgreSQL to latest version , 8.1.15
07 Nov 2008 09:49:49
Original commit files touched by this commit  8.1.14
 This port version is marked as vulnerable.
girgen search for other commits by this committer
Update PostgreSQL to latest versions.

http://www.postgresql.org/docs/current/static/release-8-3-5.html
http://www.postgresql.org/docs/current/static/release-8-2-11.html
http://www.postgresql.org/docs/current/static/release-8-1-15.html
http://www.postgresql.org/docs/current/static/release-8-0-19.html
http://www.postgresql.org/docs/current/static/release-7-4-23.html

Note that the GiST problem mentioned does not apply to users of
the FreeBSD port, since the previous version of PostgreSQL never
reached the ports tree, due to the freeze of the tree pending the
FreeBSD 7.1 update.

PR:     121848, 124713
01 Sep 2008 11:59:12
Original commit files touched by this commit  8.1.13
 This port version is marked as vulnerable.
girgen search for other commits by this committer
Fix missed commit when updating ICU patch to chase update of autoconf 2.61 ->
2.62
28 Aug 2008 15:15:28
Original commit files touched by this commit  8.1.13
 This port version is marked as vulnerable.
girgen search for other commits by this committer
Update ICU patch to chase update of autoconf 2.61 -> 2.62

PR:             ports/126773
Submitted by:   Robert Schulze
20 Aug 2008 00:57:32
Original commit files touched by this commit  8.1.13
 This port version is marked as vulnerable.
ade search for other commits by this committer
Conversion from (now defunct) autoconf-2.61 to autoconf-2.62

Tested by:      exp build run (erwin)
12 Jun 2008 23:46:07
Original commit files touched by this commit  8.1.13
 This port version is marked as vulnerable.
girgen search for other commits by this committer
Updates of the PostgreSQL ports

Updates for all maintained versions of PostgreSQL are available today:
8.3.3, 8.2.9, 8.1.13, 8.0.17 and 7.4.21.  These releases fix more than
two dozen minor issues reported and patched over the last few months.
All PostgreSQL users should plan to update at their earliest
convenience. People in affected time zones, in particular, should
upgrade as soon as possible.

Release Notes:
        http://www.postgresql.org/docs/8.3/static/release.html

Also, fix umask error in periodic script [1].

PR:             ports/124457 [1]
Submitted by:   Alexandre Perrin
06 Jun 2008 13:17:10
Original commit files touched by this commit  8.1.11_1
 This port version is marked as vulnerable.
edwin search for other commits by this committer
Bump portrevision due to upgrade of devel/gettext.

The affected ports are the ones with gettext as a run-dependency
according to ports/INDEX-7 (5007 of them) and the ones with USE_GETTEXT
in Makefile (29 of them).

PR:             ports/124340
Submitted by:   edwin@
Approved by:    portmgr (pav)
25 Mar 2008 04:37:01
Original commit files touched by this commit  8.1.11
 This port version is marked as vulnerable.
edwin search for other commits by this committer
Fix SIZE line for pg-8111-icu-xx-2008-02-19.diff.gz
20 Mar 2008 09:37:21
Original commit files touched by this commit  8.1.11
 This port version is marked as vulnerable.
pav search for other commits by this committer
- Remove USE_GETOPT_LONG which is a no-op since March 200
19 Feb 2008 21:38:42
Original commit files touched by this commit  8.1.11
 This port version is marked as vulnerable.
girgen search for other commits by this committer
Chase ICU version 3.8
HIER patch's web site has disappeared. Put the patches on freefall
until I can get hold of the author.
18 Jan 2008 23:22:09
Original commit files touched by this commit  8.1.11
 This port version is marked as vulnerable.
linimon search for other commits by this committer
Workaround for sparc64-6: set USE_GCC=4.2+.

The packages for 6.3R on sparc64 were actually built using this.

Hat:            portmgr
08 Jan 2008 12:32:10
Original commit files touched by this commit  8.1.11
 This port version is marked as vulnerable.
girgen search for other commits by this committer
Fix bad ICU patch file
07 Jan 2008 13:51:57
Original commit files touched by this commit  8.1.11
 This port version is marked as vulnerable.
girgen search for other commits by this committer
Update all PostgreSQL ports to latest versions.

This includes a bunch of security fixes: CVE-2007-6067, CVE-2007-4772,
CVE-2007-6601, CVE-2007-6600 and CVE-2007-4769.

Security: http://www.postgresql.org/about/news.905
17 Oct 2007 10:13:01
Original commit files touched by this commit  8.1.10_2
 This port version is marked as vulnerable.
ade search for other commits by this committer
Migration from bison 1.x to 2.x

PR:             117086
Tested by:      -exp runs
04 Oct 2007 00:21:24
Original commit files touched by this commit  8.1.10_1
 This port version is marked as vulnerable.
edwin search for other commits by this committer
Remove always-false/true conditions based on OSVERSION 500000
30 Sep 2007 04:47:37
Original commit files touched by this commit  8.1.10_1
 This port version is marked as vulnerable.
linimon search for other commits by this committer
Switch autoconf dependencies from 2.53 or 2.59 to 2.61.

PR:             ports/116639
Submitted by:   aDe
17 Sep 2007 16:45:01
Original commit files touched by this commit  8.1.10
 This port version is marked as vulnerable.
girgen search for other commits by this committer
Update PostgreSQL ports to the latest patch releases.

PR: ports/104075
19 May 2007 20:32:57
Original commit files touched by this commit  8.1.9_1
 This port version is marked as vulnerable.
flz search for other commits by this committer
- Welcome X.org 7.2 \o/.
- Set X11BASE to ${LOCALBASE} for recent ${OSVERSION}.
- Bump PORTREVISION for ports intalling files in ${X11BASE}.
23 Apr 2007 16:10:54
Original commit files touched by this commit  8.1.9
 This port version is marked as vulnerable.
girgen search for other commits by this committer
Update PostgreSQL to 7.3.19, 7.4.17, 8.0.13, 8.1.9 and 8.2.4 respectively:

 The PostgreSQL Global Development Group has released updated versions
 for PostgreSQL 8.2 and all back versions to patch a privilege
 escalation exploit in SECURITY DEFINER functions.  All users of this
 feature are urged to update to the latest minor version and follow
 instructions on securing these functions as soon as possible.  This
 minor release also contains other fixes, so all users should plan to
 deploy it.

 Once you have updated, additional steps are required to secure your
 database against the exploit.  Please read the release notes at
 http://www.postgresql.org/docs/8.2/static/release.html and the
 TechDocs article at http://www.postgresql.org/docs/techdocs.77 on how
 to lock down your security definer functions, if you use them.
(Only the first 15 lines of the commit message are shown above View all of this commit message)
18 Mar 2007 16:23:18
Original commit files touched by this commit  8.1.8
 This port version is marked as vulnerable.
nork search for other commits by this committer
Respect PTHREAD_CFLAGS/PTHREAD_LIBS.

Approved by:    maintainer timeout (1 month)
07 Feb 2007 09:51:48
Original commit files touched by this commit  8.1.8
 This port version is marked as vulnerable.
girgen search for other commits by this committer
Update PostgreSQL 8.x to 8.0.12, 8.1.8 and 8.2.3 respectively:

  The recent security release (8.0.11, 8.1.7, 8.2.2) has been withdrawn.
  It contained an issue which causes error with custom data types, type
  constraints and expression indexes. These upgrades fix the problem.
05 Feb 2007 15:41:36
Original commit files touched by this commit  8.1.7
 This port version is marked as vulnerable.
girgen search for other commits by this committer
Update PostgreSQL with, amongst other things, two security fixes:

  A vulnerability allows suppressing the normal checks that a SQL
  function returns the data type it's declared to do. These errors can
  easily be exploited to cause a backend crash, and in principle might
  be used to read database content that the user should not be able to
  access. [CVE-2007-0555]

  A vulnerability involving changing the data type of a table column
  can easily be exploited to cause a backend crash, and in principle
  might be used to read database content that the user should not be
  able to access. [CVE-2007-0556]

The release includes a set of other fixes as well. Please see the
release information at
http://www.postgresql.org/docs/8.1/static/release.html#RELEASE-8-1-7

Security: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-0555
Security: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-0556
09 Jan 2007 16:29:35
Original commit files touched by this commit  8.1.6
 This port version is marked as vulnerable.
girgen search for other commits by this committer
Update postgresql to 8.2.1, 8.1.6, 8.0.10, 7.4.15 and 7.3.17.

Release notes:
http://www.postgresql.org/docs/7.3/static/release.html#RELEASE-7-3-17
http://www.postgresql.org/docs/7.4/static/release.html#RELEASE-7-4-15
http://www.postgresql.org/docs/8.0/static/release.html#RELEASE-8-0-10
http://www.postgresql.org/docs/8.1/static/release.html#RELEASE-8-1-6
http://www.postgresql.org/docs/8.2/static/release-8-2-1.html

The server-side utilities of postgresql (initdb, initlocation,
ipcclean, pg_controldata, pg_ctl, pg_id and pg_resetxlog) are now
installed by the respective postgresql*-server port (previously they
where installed with the client). If you update the client, you should
also update the server to make sure you are not left without the
server-side tools. Do something like:

    portupgrade postgresql-client postgresql-server
08 Nov 2006 17:07:53
Original commit files touched by this commit  8.1.5
 This port version is marked as vulnerable.
girgen search for other commits by this committer
Update PostgreSQL to latest versions: 8.1.5, 8.0.9, 7.4.14 and 7.3.16.

Release notes:
8.1.5  http://www.postgresql.org/docs/8.1/static/release.html#RELEASE-8-1-5
8.0.9  http://www.postgresql.org/docs/8.0/static/release.html#RELEASE-8-0-9
7.4.14 http://www.postgresql.org/docs/7.4/static/release.html#RELEASE-7-4-14
7.3.16 http://www.postgresql.org/docs/7.3/static/release.html#RELEASE-7-3-16

Change name of the rc script from '010.pgsql.sh' to 'postgresql'

Add optional hierachy patch added for 7.4 and 8.1 ports.

Chase heimdal libs update [reported by several]

For 8.1+ the port enables autovacuum in ~pgsql/postgresql.conf when
running initdb

Cleanup the ports, moving pkg-message-* to files/pkg-message-*.in and
files/pgsql.sh.tmpl to files/postgresql.in. [ports/97767]

PR: ports/97767, submitted by delphij@FreeBSD.org
27 Sep 2006 12:58:54
Original commit files touched by this commit  8.1.4_1
 This port version is marked as vulnerable.
girgen search for other commits by this committer
The update to handle different versions of ICU was not sufficient.
Update the patches to handle ICU version 3.6 and fall back to 3.4.
21 Sep 2006 16:32:49
Original commit files touched by this commit  8.1.4_1
 This port version is marked as vulnerable.
girgen search for other commits by this committer
Fix bad file name to the ICU patch.

Pointed out by: Penty Wenngren <penty.wenngren@dgc.se>
Pointy hat to:  me
20 Sep 2006 09:00:40
Original commit files touched by this commit  8.1.4_1
 This port version is marked as vulnerable.
girgen search for other commits by this committer
Update the patch to be more agnostic with regards to the version of icu.
It now links with icu-3.6 as well as the earlier versions.
26 Jun 2006 22:24:10
Original commit files touched by this commit  8.1.4_1
 This port version is marked as vulnerable.
sobomax search for other commits by this committer
There is no point in setting mode of rc.d file to be 554, set it to 555.
Otherwise there could be problems with the service not starting up in the
case when owner of the file has been changed.
23 May 2006 21:18:58
Original commit files touched by this commit  8.1.4
 This port version is marked as vulnerable.
girgen search for other commits by this committer
Update all PostgreSQL to fix a security flaw

The PostgreSQL Global Development Group today released versions 8.1.4, 8.0.8,
7.4.13 and 7.3.15. This is an urgent update to close a security hole which
can permit a SQL injection attack on some applications running PostgreSQL.

Users are urged to apply the update as soon as reasonably possible. Since the
update affects client functionality, most driver projects will be updating
this week as well.

Because the security issue involved is complex, we have added a section in
Techdocs to explain it: http://www.postgresql.org/docs/techdocs.52. Please
read this first before applying the updates.

Also, fix rc_subr startup problems on FreeBSD-7.x.

Security:       http://www.postgresql.org/docs/techdocs.50
PR:             ports/95154
20 Feb 2006 20:47:50
Original commit files touched by this commit  8.1.3
 This port version is marked as vulnerable.
dougb search for other commits by this committer
Remove the FreeBSD KEYWORD from all rc.d scripts where it appears.
We have not checked for this KEYWORD for a long time now, so this
is a complete noop, and thus no PORTREVISION bump. Removing it at
this point is mostly for pedantic reasons, and partly to avoid
perpetuating this anachronism by copy and paste to future scripts.
17 Feb 2006 20:12:14
Original commit files touched by this commit  8.1.3
 This port version is marked as vulnerable.
girgen search for other commits by this committer
Minor release 8.1.3 patches security issue
Release Note:
http://www.postgresql.org/docs/8.1/static/release.html#RELEASE-8-1-3

PR:             ports/93440
Submitted by:   Hirohisa Yamaguchi <umq@ueo.co.jp>
30 Jan 2006 09:38:49
Original commit files touched by this commit  8.1.2
 This port version is marked as vulnerable.
edwin search for other commits by this committer
Add missing ) around SIZE statements.
22 Jan 2006 05:52:28
Original commit files touched by this commit  8.1.2
 This port version is marked as vulnerable.
edwin search for other commits by this committer
eplace ugly "@unexec rmdir %D... 2>/dev/null || true" with @dirrmtry

Approved by:    krion@
PR:             ports/88711 (related)
09 Jan 2006 17:30:38
Original commit files touched by this commit  8.1.2
 This port version is marked as vulnerable.
girgen search for other commits by this committer
Update postgresql with latest patch release.

A critical fix repairs an error in ReadBuffer that can cause data loss
due to overwriting recently-added pages.  This applies to the 8.1 and
8.0 branches on all platforms.

Note that this update might require a reindex of textual columns under
certain conditions; please see UPDATING.

Other fixes included are:
-- Character string locale comparison bug. This may require a REINDEX
    on text column indexes in some locales, such as Hungarian.
-- Prevent accidental changes of locale by plperl
-- Two fixes for Japanese encodings
-- Two fixes for COPY CSV
-- Fixes for functions returning RECORD
-- Fixes to autovacuum, dblink and pgcrypto
07 Jan 2006 00:14:42
Original commit files touched by this commit  8.1.1_1
 This port version is marked as vulnerable.
ade search for other commits by this committer
Add 'config' to the list of directories installed by postgresql81-client,
so as to fully install everything needed for pgxs to work correctly.

Approved by:    maintainer
25 Dec 2005 20:01:42
Original commit files touched by this commit  8.1.1_1
 This port version is marked as vulnerable.
girgen search for other commits by this committer
Handle a change in rc.subr. nowadays, "faststart" is used instead of
"start" when booting, since there's no need waste time checking for
running processes when the OS is starting up.

Bumping portrevision.

PR:             90884
Submitted by:   Victor Snezhko <snezhko@indorsoft.ru>
22 Dec 2005 20:13:30
Original commit files touched by this commit  8.1.1
 This port version is marked as vulnerable.
girgen search for other commits by this committer
Update postgresql to 8.1.1

Submitted by:   Hirohisa Yamaguchi <umq@ueo.co.jp>
PR:             90443
15 Nov 2005 06:52:12
Original commit files touched by this commit  8.1.0
 This port version is marked as vulnerable.
ade search for other commits by this committer
Mass-conversion to the USE_AUTOTOOLS New World Order.  The code present
in bsd.autotools.mk essentially makes this a no-op given that all the
old variables set a USE_AUTOTOOLS_COMPAT variable, which is parsed in
exactly the same way as USE_AUTOTOOLS itself.

Moreover, USE_AUTOTOOLS has already been extensively tested by the GNOME
team -- all GNOME 2.12.x ports use it.

Preliminary documentation can be found at:
        http://people.FreeBSD.org/~ade/autotools.txt

which is in the process of being SGMLized before introduction into the
Porters Handbook.

Light blue touch-paper.  Run.
14 Nov 2005 23:59:26
Original commit files touched by this commit  8.1.0
 This port version is marked as vulnerable.
girgen search for other commits by this committer
Let postgresql (libpq.so) only link with the Kerberos implementations
installed from ports. The base heimdal distribution installs libraries
that have no depenency information. While this is quite correct, it
means that each library that links with libpq.so must also know if
libpq.so is linked with libkrb.so et al. Problem is, there's no good
way to get this information (pg_config has a --libs option starting at
version 8.1) and all ports using postgresql must be changed to make it
possible to link with a libpq.so that was configured to use the
Kerberos implementation installed in /usr by default. Hence, we
require one of the ports (heimdal or krb5) if postgresql is to be
linked with Kerberos. At least for now, until we can fix this in some
better way.

Also, if MIT Kerberos (security/krb5) is installed, users should
ideally remove the base heimdal installation so linkers will not pick
it up in preference to the krb5 libs (base heimdal has higher version
numbers than krb5 port).

PR: 80869, 88098, 85178
11 Nov 2005 16:05:25
Original commit files touched by this commit  8.1.0
 This port version is marked as vulnerable.
girgen search for other commits by this committer
Fix UNIQUENAME

Pointed out by: Vivek Khera <vivek@khera.org>
11 Nov 2005 02:09:36
Original commit files touched by this commit  8.1.0
 This port version is marked as vulnerable.
girgen search for other commits by this committer
Don't break the port for ppl who have old configs that includes the
HIER option.

Pointed out by: Reko Turja <reko.turja@liukuma.net>
10 Nov 2005 02:23:38
Original commit files touched by this commit  8.1.0
 This port version is marked as vulnerable.
girgen search for other commits by this committer
Welcome to PostgreSQL 8.1.

The new release includes performance improvements and advanced SQL
features which will support bigger data warehouses, higher-volume
transaction processing, and more complex distributed enterprise
software.

Major new features in this release include:

      Roles:
           PostgreSQL now supports database roles, which simplify the
           management of large numbers of users with complex
           overlapping database rights.

      IN/OUT Parameters:
(Only the first 15 lines of the commit message are shown above View all of this commit message)
28 Sep 2005 23:12:18
Original commit files touched by this commit  8.0.3
 This port version is marked as vulnerable.
girgen search for other commits by this committer
Mark as work-in-progress

Number of commits found: 61

Login
User Login
Create account

Servers and bandwidth provided by
New York Internet, SuperNews, and RootBSD

This site
What is FreshPorts?
About the authors
FAQ
How big is it?
The latest upgrade!
Privacy
Forums
Blog
Contact

Search
Enter Keywords:
 
more...

Latest Vulnerabilities
bugzilla40*Apr 18
bugzilla40*Apr 18
bugzilla42*Apr 18
bugzilla42*Apr 18
bugzilla44*Apr 18
bugzilla44*Apr 18
curlApr 11
dbus-glibApr 11
libaudiofileApr 11
linux-f10-curlApr 11
linux-f10-dbus-glibApr 11
linux-f10-libaudiofileApr 11
linux-f10-nas-libsApr 11
linux-f10-openldapApr 11
mingw32-openssl*Apr 11

13 vulnerabilities affecting 18 ports have been reported in the past 14 days

* - modified, not new

All vulnerabilities


Ports
Home
Categories
Deleted ports
Sanity Test Failures
Newsfeeds


Statistics
Graphs
NEW Graphs (Javascript)
Traffic

Calculated hourly:
Port count 24365
Broken 174
Deprecated 86
Ignore 528
Forbidden 6
Restricted 263
No CDROM 108
Vulnerable 29
Expired 8
Set to expire 73
Interactive 22
new 24 hours 5
new 48 hours8
new 7 days19
new fortnight40
new month146

Servers and bandwidth provided by
New York Internet, SuperNews, and RootBSD
Valid HTML, CSS, and RSS.
Copyright © 2000-2014 Dan Langille. All rights reserved.