FreshPorts -- The Place For Ports If you buy from Amazon USA, please support us by using this link.
Follow us
Blog
Twitter

non port: head/databases/postgresql90-server/files/502.pgsql.in
SVNWeb

Number of commits found: 4

Fri, 1 Jul 2016
[ 17:45 matthew ] Original commit   Revision:417899
417899 MOVED
417899 Mk/Uses/pgsql.mk
417899 Mk/bsd.default-versions.mk
417899 databases/Makefile
417899 databases/postgresql90-client/Makefile
417899 databases/postgresql90-pgtcl/Makefile
417899 databases/postgresql90-plperl/Makefile
417899 databases/postgresql90-plpython/Makefile
417899 databases/postgresql90-plpython/pkg-descr
417899 databases/postgresql90-server/Makefile

(Only the first 10 of 47 ports in this commit are shown above. View all ports for this commit)
Delete the now expired postgresql90 ports.  Upstream support for
postgresql-9.0.x was declared EoL in September 2015.

Summary:
Remove 9.0 from the list of postgresql versions available in ports

Disconnect postgresql90 ports from the build

Remove postgresql90-pgtcl port

Remove postgresql90-client port

Move the master postgreslXY-plperl makefile to postgresql95-plperl/Makefile.

Adjust include lines in other postgresqlXY-plperl ports
(Only the first 15 lines of the commit message are shown above View all of this commit message)
Sat, 13 Feb 2016
[ 22:42 girgen ] Original commit   Revision:408835
408835 databases/postgresql90-server/files/502.pgsql.in
408835 databases/postgresql91-server/Makefile
408835 databases/postgresql91-server/distinfo
408835 databases/postgresql91-server/files/502.pgsql.in
408835 databases/postgresql91-server/pkg-plist-client
408835 databases/postgresql92-server/Makefile
408835 databases/postgresql92-server/distinfo
408835 databases/postgresql92-server/files/502.pgsql.in
408835 databases/postgresql92-server/pkg-plist-client
408835 databases/postgresql93-server/Makefile

(Only the first 10 of 22 ports in this commit are shown above. View all ports for this commit)
Update PostgreSQL to latest versions.

Security Fixes for Regular Expressions, PL/Java

This release closes security hole CVE-2016-0773, an issue with regular
expression (regex) parsing. Prior code allowed users to pass in expressions
which included out-of-range Unicode characters, triggering a backend crash.
This issue is critical for PostgreSQL systems with untrusted users or which
generate regexes based on user input.

The update also fixes CVE-2016-0766, a privilege escalation issue for users of
PL/Java.  Certain custom configuration settings (GUCS) for PL/Java will now be
modifiable only by the database superuser

URL:		http://www.postgresql.org/about/news/1644/
Security:	CVE-2016-0773, CVE-2016-0766
Wed, 20 Apr 2011
[ 15:30 girgen ] Original commit 
1.216 databases/postgresql90-server/Makefile
1.2 databases/postgresql90-server/files/502.pgsql.in
Fix typo in 502.pgsql script

PR: 156515
Mon, 18 Apr 2011
[ 23:34 girgen ] Original commit 
1.197 databases/postgresql82-server/Makefile
1.69 databases/postgresql82-server/distinfo
1.2 databases/postgresql82-server/files/pkg-message-client.in
1.20 databases/postgresql82-server/pkg-plist-server
1.210 databases/postgresql83-server/Makefile
1.78 databases/postgresql83-server/distinfo
1.3 databases/postgresql83-server/files/pkg-message-client.in
1.27 databases/postgresql83-server/pkg-plist-server
1.221 databases/postgresql84-server/Makefile
1.81 databases/postgresql84-server/distinfo

(Only the first 10 of 27 ports in this commit are shown above. View all ports for this commit)
Update PostgreSQL to 9.0.4, 8.4.8, 8.3.15 and 8.2.21.

This update contains a critical fix to the pg_upgrade utility
which prevents significant downtime issues. Do not use
pg_upgrade without installing this update first.

The issue with pg_upgrade and the fix are detailed on the PostgreSQL
wiki: http://wiki.postgresql.org/wiki/20110408pg_upgrade_fix
Users who have already used pg_upgrade should run the database repair
script given on that page on their databases as soon as possible.

See the release notes for each version at
http://www.postgresql.org/docs/current/static/release.html for a full
list of changes with details.

Allow the username of the postgresql user to configurable for 8.4 and 9.0.
Largely inspired by the work of Jason Helfman [153668, 153136].

Change PGUSER knob to PG_USER not to clash with PGUSER environment.

PR: 153668, 153136, 155493, 155137

Number of commits found: 4

Login
User Login
Create account

Servers and bandwidth provided by
New York Internet, SuperNews, and RootBSD

This site
What is FreshPorts?
About the authors
Issues
FAQ
How big is it?
The latest upgrade!
Privacy
Forums
Blog
Contact

Search
Enter Keywords:
 
more...

Latest Vulnerabilities
eogAug 22
p5-PathTools*Aug 22
p5-XSLoader*Aug 22
perl5-devel*Aug 22
perl5-devel*Aug 22
perl5-devel*Aug 22
perl5.18*Aug 22
perl5.18*Aug 22
perl5.18*Aug 22
perl5.20*Aug 22
perl5.20*Aug 22
perl5.20*Aug 22
perl5.20*Aug 22
perl5.22*Aug 22
perl5.22*Aug 22

57 vulnerabilities affecting 92 ports have been reported in the past 14 days

* - modified, not new

All vulnerabilities


Ports
Home
Categories
Deleted ports
Sanity Test Failures
Newsfeeds

Statistics
Graphs
NEW Graphs (Javascript)
Traffic

Calculated hourly:
Port count 26178
Broken 93
Deprecated 144
Ignore 362
Forbidden 0
Restricted 199
No CDROM 83
Vulnerable 65
Expired 16
Set to expire 130
Interactive 0
new 24 hours 2
new 48 hours16
new 7 days27
new fortnight45
new month117

Servers and bandwidth provided by
New York Internet, SuperNews, and RootBSD
Valid HTML, CSS, and RSS.
Copyright © 2000-2014 Dan Langille. All rights reserved.