FreshPorts -- The Place For Ports If you buy from Amazon USA, please support us by using this link.
Follow us
Blog
Twitter

Please give me your LTO-4 or better tape library and I'll put it to good use.
Port details
love08 Open-source 2D game engine
0.8.0_3 devel on this many watch lists=0 search for ports that depend on this port Find issues related to this port Report an issue related to this port
Maintainer: amdmi3@FreeBSD.org search for ports maintained by this maintainer
Port Added: 10 Jun 2014 11:35:26
Also Listed In: games
License: not specified in port
LOVE is an open-source 2D game engine which uses the versatile Lua
scripting language to create dynamic gaming experiences. It relies
on OpenGL graphics and the SDL interface library to allow for
cross-platform implementation and is an all-encompassing gaming
environment for the development and enjoyment of 2D games.

WWW: http://www.love2d.org/
SVNWeb : Homepage : Distfiles Availability : PortsMon

NOTE: FreshPorts displays only information on required and default dependencies. Optional dependencies are not covered.

Build dependencies:
  1. shared_ptr.hpp : devel/boost-libs
  2. sdl-config : devel/sdl12
  3. gmake : devel/gmake
  4. libGL>0 : graphics/libGL
  5. glproto.pc : x11/glproto
  6. dri2proto.pc : x11/dri2proto
  7. glproto.pc : x11/glproto
  8. dri2proto.pc : x11/dri2proto
Runtime dependencies:
  1. libGL>0 : graphics/libGL
Library dependencies:
  1. libIL.so : graphics/devil
  2. libmodplug.so : audio/libmodplug
  3. libmpg123.so : audio/mpg123
  4. libvorbisfile.so : audio/libvorbis
  5. libphysfs.so : devel/physfs
  6. libfreetype.so : print/freetype2
  7. libSDL.so : devel/sdl12
  8. libSDL_mixer.so : audio/sdl_mixer
  9. libopenal.so.1 : audio/openal-soft
  10. liblua-5.1.so : lang/lua51
  11. libGLU.so : graphics/libGLU
There are no ports dependent upon this port

To install the port: cd /usr/ports/devel/love08/ && make install clean
To add the package: pkg install devel/love08


Configuration Options
===> The following configuration options are available for love08-0.8.0_3:
     DOCS=on: Build and/or install documentation
===> Use 'make config' to modify these settings

USES:
gmake openal dos2unix lua:51

Master Sites:
  1. http://cdn.bitbucket.org/rude/love/downloads/
  2. http://distcache.FreeBSD.org/ports-distfiles/
  3. http://mirror.amdmi3.ru/distfiles/

Number of commits found: 5

Commit History - (may be incomplete: see SVNWeb link above for full details)
DateByDescription
23 Aug 2015 22:21:28
Original commit files touched by this commit  0.8.0_3
Revision:395136
amdmi3 search for other commits by this committer
- Switch to options helpers
08 Dec 2014 16:48:41
Original commit files touched by this commit  0.8.0_3
Revision:374303
tijl search for other commits by this committer
Replace USES=libtool:oldver with USES=libtool or USES=libtool:keepla in
the 32 ports that still use it.  Bump PORTREVISION on their dependent
ports except the ones that depend on these:

audio/libogg
audio/libvorbis
devel/pcre
ftp/curl
graphics/jpeg
graphics/libart_lgpl
graphics/tiff
textproc/expat2
textproc/libxslt

In these cases the same trick as in the recent gettext update is used.
(Only the first 15 lines of the commit message are shown above View all of this commit message)
10 Sep 2014 20:50:37
Original commit files touched by this commit  0.8.0_2
Revision:367888
gerald search for other commits by this committer
Update the default version of GCC in the Ports Collection from GCC 4.7.4
to GCC 4.8.3.

Part II, Bump PORTREVISIONs.

PR:		192025
Tested by:	antoine (-exp runs)
Approved by:	portmgr (implicit)
15 Aug 2014 20:37:33
Original commit files touched by this commit  0.8.0_1
Revision:365038
mandree search for other commits by this committer
Upgrade OpenEXR and ilmbase to 2.2.0.

GCC 4.2 in FreeBSD 8.X/9.X base is now too old to compile OpenEXR, so
GCC-based systems will upgrade to the default ports compiler (GCC 4.7
currently.)

Add two patches to OpenEXR to permit building it in a live system with
the older OpenEXR version installed. Bug report filed to upstream Github
at https://github.com/openexr/openexr/issues/130

Couple OpenEXR more tightly to ilmbase and require its exact .so
version.

Add UPDATING note, and bump PORTREVISION of all dependent ports.

Proto-STAGE hugin-devel, and mark it IGNORE because hugin is newer.

Approved by:	portmgr (implicit for bumping PORTREVISION on unstaged ports)
10 Jun 2014 11:35:21
Original commit files touched by this commit  0.8.0
Revision:357295
amdmi3 search for other commits by this committer
Preserve devel/love 0.8.0 as devel/love08 before updating it to 0.9.1.

Compatibility is not maintained between love 0.x branches, so separate port is
needed to run applications written for love 0.8. Currently there's at least one
such application known: mari0 - cross between Super Mario Bros and Valve's
Portal.

Number of commits found: 5

Login
User Login
Create account

Servers and bandwidth provided by
New York Internet, SuperNews, and RootBSD

This site
What is FreshPorts?
About the authors
FAQ
How big is it?
The latest upgrade!
Privacy
Forums
Blog
Contact

Search
Enter Keywords:
 
more...

Latest Vulnerabilities
avidemuxSep 01
ffmpegSep 01
ffmpegSep 01
gstreamer1-libavSep 01
gstreamer1-libavSep 01
handbrakeSep 01
handbrakeSep 01
kodiSep 01
libavSep 01
libavSep 01
mencoderSep 01
mplayerSep 01
mythtvSep 01
mythtvSep 01
mythtv-frontendSep 01

27 vulnerabilities affecting 66 ports have been reported in the past 14 days

* - modified, not new

All vulnerabilities


Ports
Home
Categories
Deleted ports
Sanity Test Failures
Newsfeeds

Statistics
Graphs
NEW Graphs (Javascript)
Traffic

Calculated hourly:
Port count 25197
Broken 194
Deprecated 42
Ignore 498
Forbidden 1
Restricted 205
No CDROM 94
Vulnerable 45
Expired 10
Set to expire 26
Interactive 0
new 24 hours 4
new 48 hours16
new 7 days23
new fortnight99
new month213

Servers and bandwidth provided by
New York Internet, SuperNews, and RootBSD
Valid HTML, CSS, and RSS.
Copyright © 2000-2014 Dan Langille. All rights reserved.