FreshPorts -- The Place For Ports If you buy from Amazon USA, please support us by using this link.
Follow us
Blog
Twitter

I am looking for an LTO tape library. Do you have one to spare?
Port details
pyside Python bindings for the Qt applications and UI framework
1.2.2_1 devel on this many watch lists=0 search for ports that depend on this port
Maintained by: python@FreeBSD.org search for ports maintained by this maintainer
Port Added: 18 Dec 2011 22:12:21
License: LGPL21


PySide is Python library to create cross-platform graphical user interfaces
by providing access to the underlying Qt framework. PySide and its complete
generation toolchain is available under LGPL license. This allows developers
to create Qt and Qt Quick applications in Python programming language at no
cost.

WWW: http://qt-project.org/wiki/PySide
SVNWeb : Main Web Site : Distfiles Availability : PortsMon

NOTE: FreshPorts displays only information on required and default dependencies. Optional dependencies are not covered.

Required To Build:
  1. devel/cmake
  2. lang/python27
  3. lang/python2
  4. x11-toolkits/qt4-declarative
  5. devel/qt4-designer
  6. x11-toolkits/qt4-gui
  7. devel/qt4-help
  8. devel/qt4-moc
  9. multimedia/qt4-multimedia
  10. net/qt4-network
  11. graphics/qt4-opengl
  12. multimedia/phonon
  13. devel/qmake4
  14. devel/qt4-rcc
  15. devel/qt4-script
  16. devel/qt4-scripttools
  17. graphics/qt4-svg
  18. devel/qt4-uic
  19. www/webkit-qt4
Required To Run:
  1. lang/python27
  2. lang/python2
  3. x11-toolkits/qt4-declarative
  4. devel/qt4-designer
  5. x11-toolkits/qt4-gui
  6. devel/qt4-help
  7. multimedia/qt4-multimedia
  8. net/qt4-network
  9. graphics/qt4-opengl
  10. multimedia/phonon
  11. devel/qt4-script
  12. devel/qt4-scripttools
  13. graphics/qt4-svg
  14. www/webkit-qt4
Required Libraries:
  1. devel/apiextractor
  2. devel/generatorrunner
  3. devel/shiboken

This port is required by:

for Build for Run * - deleted ports are only shown under the This port is required by section. It was harder to do for the Required section. Perhaps later...

To install the port: cd /usr/ports/devel/pyside/ && make install clean
To add the package: pkg install devel/pyside


Configuration Options
     No options to configure

Master Sites:
  1. http://distcache.FreeBSD.org/ports-distfiles/
  2. https://download.qt-project.org/official_releases/pyside/

Number of commits found: 17

Commit History - (may be incomplete: see SVNWeb link above for full details)
DateByDescription
20 Oct 2014 16:04:14
Original commit files touched by this commit  1.2.2_1
Revision:371280
mva search for other commits by this committer
- Convert ports of devel/ to USES=python

Approved by:	portmgr (implicit)
10 Sep 2014 20:50:37
Original commit files touched by this commit  1.2.2_1
Revision:367888
gerald search for other commits by this committer
Update the default version of GCC in the Ports Collection from GCC 4.7.4
to GCC 4.8.3.

Part II, Bump PORTREVISIONs.

PR:		192025
Tested by:	antoine (-exp runs)
Approved by:	portmgr (implicit)
05 Jul 2014 15:19:33
Original commit files touched by this commit  1.2.2
Revision:360763
wg search for other commits by this committer
devel/pyside: update to 1.2.2

- Support stage
- Change maintainership to python@
04 Jul 2014 12:06:07
Original commit files touched by this commit  1.1.1_1
Revision:360604
bapt search for other commits by this committer
Resetting maintainership on ports that have not been staged and without any
pending PR (related to stage)

With hat:	portmgr
18 Feb 2014 14:31:33
Original commit files touched by this commit  1.1.1_1
Revision:344898
makc search for other commits by this committer
- Bump PORTREVISION after KDE4_PREFIX change
21 Jan 2014 23:40:23
Original commit files touched by this commit  1.1.1
Revision:340674
bapt search for other commits by this committer
Fix properties on pkg-plist
13 Jan 2014 21:00:04
Original commit files touched by this commit  1.1.1
Revision:339634
rene search for other commits by this committer
Python cleanup:
- USE_PYTHON* = 2.X -> USE_PYTHON* = 2
- USE_PYTHON* = 2.X+ -> USE_PYTHON* = yes
Reviewed by:	python (mva, rm)
Approved by:	portmgr-lurkers (mat)
14 Nov 2013 14:11:18
Original commit files touched by this commit  1.1.1
Revision:333757
nivit search for other commits by this committer
- Change (temporarily) MASTER_SITES, because dist files
  of v. 1.1.1 are no longer available  [1]
- Use new syntax in LIB_DEPENDS

Reported by:	Kostas Koukopoulos and Qi Zhao Mao Lu Qu Xiang Ge Li La  (via
private email)  [1]
20 Sep 2013 17:13:47
Original commit files touched by this commit  1.1.1
Revision:327724
bapt search for other commits by this committer
Add NO_STAGE all over the place in preparation for the staging support (cat:
devel part 3)
22 Mar 2013 20:06:15
Original commit files touched by this commit  1.1.1
Revision:314960
makc search for other commits by this committer
- convert USE_CMAKE to USES
- while here clean up some ports from CMAKE_VERBOSE, which is intended
  for users

Approved by:	portmgr (miwi)
07 Mar 2013 14:10:26
Original commit files touched by this commit  1.1.1
Revision:313589
nivit search for other commits by this committer
- Re-enable color output during the building phase

Suggested by:	makc
03 Aug 2012 21:13:51
Original commit files touched by this commit  1.1.1
nivit search for other commits by this committer
- Update to 1.1.1
- Add devel/generatorrunner to LIB_DEPENDS  [1]
- Set MANUAL_PACKAGE_BUILD, because PySide
  requires x11-toolkits/qt4-gui with QGTKSTYLE
- Disable color output of cmake
- Set USE_PYTHON to -2.7
- Add a post-fetch target, checking that QT4_OPTIONS
  has the value QGTKSTYLE

Pointed out by:	pointhat (via beat)  [1]
06 Jun 2012 06:44:38
Original commit files touched by this commit  1.1.0_1
miwi search for other commits by this committer
- Convert USE_QT_VER=4 and QT_COMPONETS to USE_QT4

Review by:      bapt, David Naylor (kde team)
01 Jun 2012 05:26:28
Original commit files touched by this commit  1.1.0_1
dinoex search for other commits by this committer
- update png to 1.5.10
21 May 2012 10:04:49
Original commit files touched by this commit  1.1.0
miwi search for other commits by this committer
- Correct the QT versions number

Reported by:    phw
25 Jan 2012 17:36:52
Original commit files touched by this commit  1.1.0
nivit search for other commits by this committer
- Update to 1.1.0
- Remove nivi.interfree.it from MASTER_SITES
18 Dec 2011 22:03:04
Original commit files touched by this commit  1.0.9
nivit search for other commits by this committer
PySide is Python library to create cross-platform graphical user interfaces
by providing access to the underlying Qt framework. PySide and its complete
generation toolchain is available under LGPL license. This allows developers
to create Qt and Qt Quick applications in Python programming language at no
cost.

WWW:    http://pyside.org/

Number of commits found: 17

Login
User Login
Create account

Servers and bandwidth provided by
New York Internet, SuperNews, and RootBSD

This site
What is FreshPorts?
About the authors
FAQ
How big is it?
The latest upgrade!
Privacy
Forums
Blog
Contact

Search
Enter Keywords:
 
more...

Latest Vulnerabilities
libpurpleOct 24
pidginOct 24
phpmyadminOct 22
asterisk11Oct 21
libxml2Oct 18
drupal7Oct 16
firefox*Oct 16
firefox-esr*Oct 16
libxul*Oct 16
linux-firefox*Oct 16
linux-seamonkey*Oct 16
linux-thunderbird*Oct 16
seamonkey*Oct 16
thunderbird*Oct 16
linux-c6-opensslOct 15

7 vulnerabilities affecting 29 ports have been reported in the past 14 days

* - modified, not new

All vulnerabilities


Ports
Home
Categories
Deleted ports
Sanity Test Failures
Newsfeeds


Statistics
Graphs
NEW Graphs (Javascript)
Traffic

Calculated hourly:
Port count 24268
Broken 99
Deprecated 31
Ignore 356
Forbidden 2
Restricted 205
No CDROM 93
Vulnerable 18
Expired 0
Set to expire 27
Interactive 0
new 24 hours 2
new 48 hours5
new 7 days22
new fortnight41
new month174

Servers and bandwidth provided by
New York Internet, SuperNews, and RootBSD
Valid HTML, CSS, and RSS.
Copyright © 2000-2014 Dan Langille. All rights reserved.