FreshPorts -- The Place For Ports If you buy from Amazon USA, please support us by using this link.
Follow us
Blog
Twitter

Please give me your LTO-4 or better tape library and I'll put it to good use.
Port details
ruby-pcsc-lite Ruby extension for the UNIX PC/SC Lite API (MUSCLE)
0.8_1 devel Deleted on this many watch lists=0 search for ports that depend on this port Find issues related to this port Report an issue related to this port
Broken BROKEN: "Does not compile with new pcsc-lite. Port will be updated soon."
Deprecated DEPRECATED: "Does not compile with new pcsc-lite. Port will be updated soon."
Expired This port expired on: 2006-12-01
Ignore IGNORE: is marked as broken: "Does not compile with new pcsc-lite. Port will be updated soon."
Maintainer: toni@soth.at search for ports maintained by this maintainer
Port Added: 12 Jan 2002 15:29:58
Also Listed In: ruby
License: not specified in port
Ruby extension for the UNIX PC/SC Lite API (MUSCLE).

Author:	Toni Andjelkovic <toni@soth.at>
WWW:	http://soth.at/PCSC-ruby/
SVNWeb : Homepage : Distfiles Availability : PortsMon

NOTE: FreshPorts displays only information on required and default dependencies. Optional dependencies are not covered.

Build dependencies:
  1. ruby18 : lang/ruby18
Runtime dependencies:
  1. ruby18 : lang/ruby18
Library dependencies:
  1. pcsclite.1 : devel/pcsc-lite
There are no ports dependent upon this port

No installation instructions: this port has been deleted.

The package name of this deleted port was: ruby18-pcsc-lite


Configuration Options
     No options to configure

Master Sites:
  1. ftp://ftp.FreeBSD.org/pub/FreeBSD/ports/distfiles/ruby/
  2. http://soth.at/PCSC-ruby/

Number of commits found: 14

Commit History - (may be incomplete: see SVNWeb link above for full details)
DateByDescription
14 Dec 2006 07:46:19
Original commit files touched by this commit  0.8_1
vd search for other commits by this committer
Remove expired leaf port:
2006-12-01 devel/ruby-pcsc-lite: Does not compile with new pcsc-lite. Port is
broken since 2005/04/20.
02 Sep 2006 16:51:10
Original commit files touched by this commit  0.8_1
kris search for other commits by this committer
Schedule these broken ports for termination on 2006-12-01
22 Jan 2006 11:02:41
Original commit files touched by this commit  0.8_1
edwin search for other commits by this committer
SHA256ify (manually updated and checked)

Approved by: krion@
20 Apr 2005 12:42:06
Original commit files touched by this commit  0.8_1
arved search for other commits by this committer
pcsc-lite:
- Upgrade to 1.2.9.b.7
- Use libtool15
- make hier(7)-compliant by moving the pcsc/drivers to lib/pcsc/drivers
- Compile with USB support per default. Use WITHOUT_USB to disable usb
  support
- Chase libusb shared library version (Forgotten by leeym)

Based on:       PR 76068
Reviewed by:    maintainer, sem (earlier patch)

ifd-devkit:
- Chase pcsclite sharedlibrary version

ifd-gempc410:
(Only the first 15 lines of the commit message are shown above View all of this commit message)
25 Feb 2005 00:17:28
Original commit files touched by this commit  0.8_1
mezz search for other commits by this committer
Disable threads again; it has caused the more troubles. This time, it has
${PTHREAD_CFLAGS} and ${PTHREAD_LIBS} include in the build to kill the
headache of old '_r' and can't run with something like ruby-opengl, ruby-sdl,
ruby-gtk2 and etc on FreeBSD 4.x or older 5.x. With this commit should solve
those issues. It is recommend you to rebuild any apps that depend on
lang/ruby18, so see the UPDATING for detail.

Remove the 'BROKEN' on the other ports that knu has added them few weeks ago.
Some of them have been tested, so if one of them is still broke then please
let us know and one of us will re-add the 'BROKEN'.

This changes was worked by lofi and me. lofi did everything on FreeBSD 4.x
and I did others. lofi, thanks for help!

Tested by:      many people
Tested on:      i386 (FreeBSD 4.x, 5.x and 6.x), amd64 (FreeBSD 5.x and 6.x),
                and sparc64 (FreeBSD 5.x and 6.x)
Not test on:    ia64 and alpha
Approved by:    portmgr (kris)
05 Feb 2005 04:59:26
Original commit files touched by this commit  0.8_1
knu search for other commits by this committer
The slippery pthread support for systems prior to 502102 has been
dropped and the lang/ruby16_r and lang/ruby18_r ports have been
removed, since no one seems to appreciate the partially working
solution.

Good news is that the pthread support of lang/ruby18 is now enabled by
default for newer systems, which means the ruby interpreter is linked
with libpthread.  This will allow threaded extension libraries to run
and work properly on those systems.

The --march=cputype flag is disabled because it gets ruby to
malfunction and fail to build.  I don't know if the problem is in
libpthread or in gcc.

(It really makes me wonder if they had actually tested before asking
me to do this somewhat risky change ;-)
18 Mar 2004 02:27:55
Original commit files touched by this commit  0.8
trevor search for other commits by this committer
Add size data.

Approved by:    maintainers
25 Feb 2004 05:56:47
Original commit files touched by this commit  0.8
linimon search for other commits by this committer
Update to 1.8: test with pcsc-lite-1.2.0; remove advertising clause from
license; minor cleanup.

PR:             ports/63205
Submittec by:   Toni Andjelkovic <toni@soth.at> (maintainer)
28 Jul 2003 07:46:11
Original commit files touched by this commit  0.7
krion search for other commits by this committer
- Fix breakage on sparc64
- Update to 0.7

PR:             54965
Submitted by:   maintainer
Approved by:    fjoe (mentor) (implicit)
21 Feb 2003 06:33:46
Original commit files touched by this commit  0.6
knu search for other commits by this committer
De-pkg-comment the ruby ports that are not maintainered by ports committers.
06 Oct 2002 21:05:34
Original commit files touched by this commit  0.6
knu search for other commits by this committer
Use RUBY_MOD*.
13 Sep 2002 11:43:03
Original commit files touched by this commit  0.6
knu search for other commits by this committer
Update MASTER_SITES.
23 Jul 2002 21:15:37
Original commit files touched by this commit  0.6
knu search for other commits by this committer
Update to 0.6.

PR:             ports/38898
Submitted by:   Toni Andjelkovic <toni@soth.at> (MAINTAINER)
12 Jan 2002 18:29:58
files touched by this commit
knu search for other commits by this committer
Add ruby-pcsc-lite, Ruby extension for the UNIX PC/SC Lite API   (MUSCLE).    

Number of commits found: 14

Login
User Login
Create account

Servers and bandwidth provided by
New York Internet, SuperNews, and RootBSD

This site
What is FreshPorts?
About the authors
FAQ
How big is it?
The latest upgrade!
Privacy
Forums
Blog
Contact

Search
Enter Keywords:
 
more...

Latest Vulnerabilities
cross-binutilsMar 24
jenkinsMar 24
jenkins-ltsMar 24
libressl*Mar 24
linux-c6-openssl*Mar 24
mingw32-openssl*Mar 24
mingw64-binutilsMar 24
openssl*Mar 24
firefoxMar 22
firefox-esrMar 22
libxulMar 22
linux-firefoxMar 22
linux-seamonkeyMar 22
seamonkeyMar 22
sympaMar 13

5 vulnerabilities affecting 24 ports have been reported in the past 14 days

* - modified, not new

All vulnerabilities


Ports
Home
Categories
Deleted ports
Sanity Test Failures
Newsfeeds

Statistics
Graphs
NEW Graphs (Javascript)
Traffic

Calculated hourly:
Port count 24720
Broken 101
Deprecated 143
Ignore 390
Forbidden 3
Restricted 203
No CDROM 94
Vulnerable 21
Expired 1
Set to expire 136
Interactive 0
new 24 hours 8
new 48 hours14
new 7 days28
new fortnight43
new month127

Servers and bandwidth provided by
New York Internet, SuperNews, and RootBSD
Valid HTML, CSS, and RSS.
Copyright © 2000-2014 Dan Langille. All rights reserved.