FreshPorts -- The Place For Ports If you buy from Amazon USA, please support us by using this link.
Follow us
Blog
Twitter

I am looking for an LTO tape library. Do you have one to spare?
Port details
koffice-kde3 1.6.3_18,2 editors Deleted on this many watch lists=128 search for ports that depend on this port This port version is marked as vulnerable.
Broken BROKEN: Does not compile
Expired This port expired on: 2011-11-30
Ignore IGNORE: is marked as broken: Does not compile
Office Suite for KDE3

There is no maintainer for this port.
Any concerns regarding this port should be directed to the FreeBSD Ports mailing list via ports@FreeBSD.org search for ports maintained by this maintainer
Port Added: 21 Apr 2002 23:49:35
Also Listed In: kde ipv6
License: not specified in port


This is the office suite for KDE3 that includes KWord, KSpread, KPresenter,
KChart, and so forth.

WWW: http://www.koffice.org/
SVNWeb : Main Web Site : Distfiles Availability : PortsMon

NOTE: FreshPorts displays only information on required and default dependencies. Optional dependencies are not covered.

Required To Build:
  1. databases/postgresql-libpqxx
  2. lang/python27
  3. lang/ruby18
  4. x11-toolkits/qt33
  5. devel/gmake
  6. devel/libtool
  7. devel/pkg-config
Required To Run:
  1. databases/postgresql-libpqxx
  2. lang/python27
  3. lang/ruby18
  4. x11-toolkits/qt33
  5. devel/pkg-config
Required Libraries:
  1. graphics/GraphicsMagick
  2. graphics/libart_lgpl
  3. textproc/aspell
  4. graphics/libexif
  5. x11-fonts/fontconfig
  6. print/freetype2
  7. graphics/lcms
  8. print/libpaper
  9. textproc/libwpd08
  10. textproc/wv2
  11. x11/kdelibs3
  12. databases/mysql41-client
  13. databases/postgresql83-client
  14. textproc/libxml2
  15. textproc/libxslt
There are no ports dependent upon this port

No installation instructions: this port has been deleted.

The package name of this deleted port was: koffice


Configuration Options
     No options to configure

Master Sites:
  1. ftp://carroll.aset.psu.edu/pub/kde/stable/koffice-1.6.3/src/
  2. ftp://fr2.rpmfind.net/linux/KDE/stable/koffice-1.6.3/src/
  3. ftp://ftp-stud.fht-esslingen.de/pub/Mirrors/ftp.kde.org/pub/kde/stable/koffice-1.6.3/src/
  4. ftp://ftp.FreeBSD.org/pub/FreeBSD/ports/distfiles/KDE/koffice/
  5. ftp://ftp.belnet.be/packages/kde/stable/koffice-1.6.3/src/
  6. ftp://ftp.cronyx.ru/pub/mirror/kde/stable/koffice-1.6.3/src/
  7. ftp://ftp.esat.net/mirrors/ftp.kde.org/pub/kde/stable/koffice-1.6.3/src/
  8. ftp://ftp.fi.muni.cz/pub/kde/stable/koffice-1.6.3/src/
  9. ftp://ftp.fu-berlin.de/pub/unix/X11/gui/kde/stable/koffice-1.6.3/src/
  10. ftp://ftp.funet.fi/pub/mirrors/ftp.kde.org/pub/kde/stable/koffice-1.6.3/src/
  11. ftp://ftp.gtlib.cc.gatech.edu/pub/kde/stable/koffice-1.6.3/src/
  12. ftp://ftp.gwdg.de/pub/x11/kde/stable/koffice-1.6.3/src/
  13. ftp://ftp.heanet.ie/mirrors/ftp.kde.org/stable/koffice-1.6.3/src/
  14. ftp://ftp.iasi.roedu.net/pub/mirrors/ftp.kde.org/stable/koffice-1.6.3/src/
  15. ftp://ftp.informatik.hu-berlin.de/pub/Mirrors/ftp.kde.org/stable/koffice-1.6.3/src/
  16. ftp://ftp.kddlabs.co.jp/pub/X11/kde/stable/koffice-1.6.3/src/
  17. ftp://ftp.kde.org/pub/kde/stable/koffice-1.6.3/src/
  18. ftp://ftp.lip6.fr/pub/X11/kde/stable/koffice-1.6.3/src/
  19. ftp://ftp.mirrorservice.org/sites/ftp.kde.org/pub/kde/stable/koffice-1.6.3/src/
  20. ftp://ftp.na.kde.org/pub/kde/stable/koffice-1.6.3/src/
  21. ftp://ftp.ntua.gr/pub/X11/kde/stable/koffice-1.6.3/src/
  22. ftp://ftp.oregonstate.edu/pub/kde/stable/koffice-1.6.3/src/
  23. ftp://ftp.rhnet.is/pub/kde/stable/koffice-1.6.3/src/
  24. ftp://ftp.rz.uni-wuerzburg.de/pub/unix/kde/stable/koffice-1.6.3/src/
  25. ftp://ftp.sayclub.com/pub/X/KDE/stable/koffice-1.6.3/src/
  26. ftp://ftp.solnet.ch/mirror/KDE/stable/koffice-1.6.3/src/
  27. ftp://ftp.sunet.se/pub/X11/kde/stable/koffice-1.6.3/src/
  28. ftp://ftp.tuniv.szczecin.pl/pub/kde/stable/koffice-1.6.3/src/
  29. ftp://ftp.unina.it/pub/Linux/kde/stable/koffice-1.6.3/src/
  30. ftp://ftp.ussg.iu.edu/pub/kde/stable/koffice-1.6.3/src/
  31. ftp://ftp.xcp.kiev.ua/ftp.kde.org/stable/koffice-1.6.3/src/
  32. ftp://ftp.yz.yamagata-u.ac.jp/pub/X11/wm/kde/stable/koffice-1.6.3/src/
  33. ftp://gd.tuwien.ac.at/kde/stable/koffice-1.6.3/src/
  34. ftp://kde.mirrors.tds.net/pub/kde/stable/koffice-1.6.3/src/
  35. ftp://kde.paralax.org/stable/koffice-1.6.3/src/
  36. ftp://mirror.pacific.net.au/kde/stable/koffice-1.6.3/src/
  37. ftp://mirrors.dotsrc.org/kde/stable/koffice-1.6.3/src/
  38. ftp://sunsite.icm.edu.pl/pub/unix/kde/stable/koffice-1.6.3/src/
  39. ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/kde/stable/koffice-1.6.3/src/
  40. http://fr2.rpmfind.net/linux/KDE/stable/koffice-1.6.3/src/
  41. http://ftp-stud.fht-esslingen.de/Mirrors/ftp.kde.org/pub/kde/stable/koffice-1.6.3/src/
  42. http://ftp.belnet.be/packages/kde/stable/koffice-1.6.3/src/
  43. http://ftp.esat.net/mirrors/ftp.kde.org/pub/kde/stable/koffice-1.6.3/src/
  44. http://ftp.fi.muni.cz/pub/kde/stable/koffice-1.6.3/src/
  45. http://ftp.funet.fi/pub/mirrors/ftp.kde.org/pub/kde/stable/koffice-1.6.3/src/
  46. http://ftp.gtlib.cc.gatech.edu/pub/kde/stable/koffice-1.6.3/src/
  47. http://ftp.gwdg.de/pub/x11/kde/stable/koffice-1.6.3/src/
  48. http://ftp.heanet.ie/mirrors/ftp.kde.org/stable/koffice-1.6.3/src/
  49. http://ftp.kddlabs.co.jp/pub/X11/kde/stable/koffice-1.6.3/src/
  50. http://ftp.ntua.gr/pub/X11/kde/stable/koffice-1.6.3/src/
  51. http://ftp.rhnet.is/pub/kde/stable/koffice-1.6.3/src/
  52. http://ftp.sayclub.com/pub/X/KDE/stable/koffice-1.6.3/src/
  53. http://ftp.scarlet.be/pub/kde/stable/koffice-1.6.3/src/
  54. http://ftp.sunet.se/pub/X11/kde/stable/koffice-1.6.3/src/
  55. http://ftp.tuniv.szczecin.pl/pub/kde/stable/koffice-1.6.3/src/
  56. http://ftp.twaren.net/Unix/X/KDE/stable/koffice-1.6.3/src/
  57. http://ftp.unina.it/pub/Linux/kde/stable/koffice-1.6.3/src/
  58. http://ftp.ussg.iu.edu/kde/stable/koffice-1.6.3/src/
  59. http://ftp.yz.yamagata-u.ac.jp/pub/X11/wm/kde/stable/koffice-1.6.3/src/
  60. http://gd.tuwien.ac.at/kde/stable/koffice-1.6.3/src/
  61. http://kambing.vlsm.org/kde/stable/koffice-1.6.3/src/
  62. http://kde.cs.nctu.edu.tw/stable/koffice-1.6.3/src/
  63. http://kde.mirrors.tds.net/pub/kde/stable/koffice-1.6.3/src/
  64. http://mirror.cc.columbia.edu/pub/software/kde/stable/koffice-1.6.3/src/
  65. http://mirror.pacific.net.au/kde/stable/koffice-1.6.3/src/
  66. http://mirrors.dotsrc.org/kde/stable/koffice-1.6.3/src/
  67. http://mirrors.evolva.ro/kdeftp/stable/koffice-1.6.3/src/
  68. http://mirrors.isc.org/pub/kde/stable/koffice-1.6.3/src/
  69. http://ring.nict.go.jp/archives/X/kde/stable/koffice-1.6.3/src/
  70. http://sunsite.icm.edu.pl/pub/unix/kde/stable/koffice-1.6.3/src/
  71. http://www-ftp.lip6.fr/pub/X11/kde/stable/koffice-1.6.3/src/
  72. http://www.mirrorservice.org/sites/ftp.kde.org/pub/kde/stable/koffice-1.6.3/src/
Port Moves
  • port deleted on 2011-12-28
    REASON: Has expired

Number of commits found: 112 (showing only 100 on this page)

1 | 2  »  

Commit History - (may be incomplete: see SVNWeb link above for full details)
DateByDescription
28 Dec 2011 17:49:04
Original commit files touched by this commit  1.6.3_18,2
 This port version is marked as vulnerable.
rene search for other commits by this committer
Remove expired, unmaintained ports:
2011-11-30 textproc/skribe
2011-11-30 emulators/wahcade
2011-11-30 databases/keximdb: Depends on editors/koffice-kde3, which is
scheduled for deletion
2011-11-30 editors/koffice-kde3
2011-11-30 net/keepalived: Depends on net/ipvs, which is scheduled for deletion
2011-11-30 net/ipvs: Designed for FreeBSD 5.x, which is no longer supported
2011-11-30 databases/fireprofile
2011-12-01 audio/gnowavcut: Abandonware
2011-12-01 mail/demime: No upstream development since 2007
2011-12-03 x11/wmmsg: No more public distfiles
2011-12-03 x11-toolkits/libgtkeditor: No more supported upstream, not depend on
anymore.
2011-12-03 misc/demoniac: No more upstream, no more public distfiles
2011-12-03 cad/gtkwave: No more public distfiles, no more upstream
2011-12-07 databases/clip: No develop anymore for long
2011-12-09 x11-toolkits/gtkextra: no longer supported upstream, no more depend
on
01 Nov 2011 22:10:30
Original commit files touched by this commit  1.6.3_18,2
 This port version is marked as vulnerable.
dougb search for other commits by this committer
Schedule net/ipvs and editors/koffice-kde3, and the ports that depend
on them, for deletion 2011-11-30
31 Oct 2011 09:53:19
Original commit files touched by this commit  1.6.3_18,2
 This port version is marked as vulnerable.
kwm search for other commits by this committer
Update poppler to 0.18.0.

The qt3 bindings are removed upstream.
The glib library lost the last gdk-pixbuf code. And rename it from
-gtk to -glib.

Thanks to:      pav for a exp-runs
                bapt for double checking the libreoffice ports
24 Oct 2011 09:11:38
Original commit files touched by this commit  1.6.3_18,2
 This port version is marked as vulnerable.
dougb search for other commits by this committer
The vast majority of pkg-descr files had the following format when they
had both lines:

Author: ...
WWW: ....

So standardize on that, and move them to the end of the file when necessary.

Also fix some more whitespace, and remove more "signature tags" of varying
forms, like -- name, etc.

s/AUTHOR/Author/

A few other various formatting issues
18 Sep 2011 10:41:22
Original commit files touched by this commit  1.6.3_18,2
 This port version is marked as vulnerable.
pav search for other commits by this committer
- Mark BROKEN: does not compile
  pqxxdriver.cpp: In member function 'virtual QString
KexiDB::pqxxSqlDriver::escapeString(const QString&) const':
  pqxxdriver.cpp:137: error: 'sqlesc' is not a member of 'pqxx'

Reported by:    pointyhat
23 Aug 2011 18:36:21
Original commit files touched by this commit  1.6.3_18,2
 This port version is marked as vulnerable.
kwm search for other commits by this committer
Chase poppler shlib bumps.
06 Aug 2011 07:45:24
Original commit files touched by this commit  1.6.3_17,2
 This port version is marked as vulnerable.
swills search for other commits by this committer
- Fix build with Ruby 1.9
07 Jul 2011 17:21:58
Original commit files touched by this commit  1.6.3_17,2
 This port version is marked as vulnerable.
makc search for other commits by this committer
Reset maintainership de jure. In fact KDE 3 has not been maintained by our team
for a long time, not to mention upstream.

Discussed a while ago among the KDE/FreeBSD team.
20 Mar 2011 12:54:45
Original commit files touched by this commit  1.6.3_17,2
 This port version is marked as vulnerable.
miwi search for other commits by this committer
- Get Rid MD5 support
19 Mar 2011 13:15:34
Original commit files touched by this commit  1.6.3_17,2
 This port version is marked as vulnerable.
ale search for other commits by this committer
Bump PORTREVISION for ports linking to default libmysqlclient.
04 Mar 2011 02:11:55
Original commit files touched by this commit  1.6.3_16,2
 This port version is marked as vulnerable.
wen search for other commits by this committer
- Bump PORTREVISION to chase the update of libexif
03 Jan 2011 11:51:29
Original commit files touched by this commit  1.6.3_15,2
 This port version is marked as vulnerable.
fluffy search for other commits by this committer
- Update graphics/libwpg to 0.2.0 release
- Update textproc/libwpd to 0.9.0 release
- Add graphics/libwpg01 and textproc/libwpd08 as support libraries only
- Take maintainership of textproc/libwpd[08]    [1]
- Chase dependencies in related ports
- Describe updating procedure in UPDATING

Approved by:    Mikhail Teterin (maintainer) via mail [1]
04 Dec 2010 07:34:27
Original commit files touched by this commit  1.6.3_14,2
 This port version is marked as vulnerable.
ade search for other commits by this committer
Sync to new bsd.autotools.mk
20 Nov 2010 15:38:09
Original commit files touched by this commit  1.6.3_14,2
 This port version is marked as vulnerable.
kwm search for other commits by this committer
Chase poppler update.
01 Apr 2010 16:25:59
Original commit files touched by this commit  1.6.3_13,2
 This port version is marked as vulnerable.
dinoex search for other commits by this committer
- fix build for png-1.4.1
28 Mar 2010 06:47:48
Original commit files touched by this commit  1.6.3_13,2
 This port version is marked as vulnerable.
dinoex search for other commits by this committer
- update to 1.4.1
Reviewed by:    exp8 run on pointyhat
Supported by:   miwi
05 Feb 2010 11:46:55
Original commit files touched by this commit  1.6.3_12,2
 This port version is marked as vulnerable.
dinoex search for other commits by this committer
- update to jpeg-8
29 Nov 2009 07:24:11
Original commit files touched by this commit  1.6.3_11,2
 This port version is marked as vulnerable.
fluffy search for other commits by this committer
- Update twxtproc/wv2 to latest release, 0.4.2
- Chase wv2 core change for koffice-kde3

Approved by:    tabthorpe (co-mentor)
19 Sep 2009 11:32:39
Original commit files touched by this commit  1.6.3_10,2
 This port version is marked as vulnerable.
fluffy search for other commits by this committer
- Chase wv2 update

Approved by:    miwi (mentor)
Feature safe:   yes
02 Aug 2009 19:36:34
Original commit files touched by this commit  1.6.3_9,2
 This port version is marked as vulnerable.
mezz search for other commits by this committer
-Repocopy devel/libtool15 -> libtool22 and libltdl15 -> libltdl22.
-Update libtool and libltdl to 2.2.6a.
-Remove devel/libtool15 and devel/libltdl15.
-Fix ports build with libtool22/libltdl22.
-Bump ports that depend on libltdl22 due to shared library version change.
-Explain what to do update in the UPDATING.

It has been tested with GNOME2, XFCE4, KDE3, KDE4 and other many wm/desktop
and applications in the runtime.

With help:      marcus and kwm
Pointyhat-exp:  a few times by pav
Tested by:      pgollucci, "Romain Tartière" <romain@blogreen.org>, and
                a few MarcusCom CVS users. Also, I might have missed a few.
Repocopy by:    marcus
Approved by:    portmgr
31 Jul 2009 13:57:52
Original commit files touched by this commit  1.6.3_9,2
 This port version is marked as vulnerable.
dinoex search for other commits by this committer
- bump all port that indirectly depends on libjpeg and have not yet been bumped
or updated
Requested by:   edwin
19 May 2009 22:07:31
Original commit files touched by this commit  1.6.3_8,2
 This port version is marked as vulnerable.
makc search for other commits by this committer
Fix build with python26
17 May 2009 16:18:21
Original commit files touched by this commit  1.6.3_8,2
 This port version is marked as vulnerable.
makc search for other commits by this committer
Mark as MAKE_JOBS_UNSAFE, it fails at random on poityhat.

Reported by:    pav
17 May 2009 13:04:04
Original commit files touched by this commit  1.6.3_8,2
 This port version is marked as vulnerable.
miwi search for other commits by this committer
- Chase textporc/wv2 shlib bump
25 Apr 2009 17:00:05
Original commit files touched by this commit  1.6.3_7,2
 This port version is marked as vulnerable.
makc search for other commits by this committer
Minor cleanups,
Mark MAKE_JOBS_SAFE.
05 Jan 2009 19:44:02
Original commit files touched by this commit  1.6.3_7,2
 This port version is marked as vulnerable.
pav search for other commits by this committer
- Remove conditional checks for FreeBSD 5.x and older
15 Aug 2008 09:25:28
Original commit files touched by this commit  1.6.3_7,2
 This port version is marked as vulnerable.
miwi search for other commits by this committer
- Fix build when ImageMagic and GraphicsMagic installed is.

        One solution proposed on the ports mailing list was to uninstall
        the ImageMagick port, rebuild editors/koffice-kde3 and then reinstall
        ImageMagick, while this works it is unacceptable to have to uninstall
        a port to get another port to build. The correct solution is to patch
        the source configure script to skip the detection of ImageMagick when
        GraphicsMagick is installed.

PR:             125526
Submitted by:   Scot W. Hetzel" <swhetzel@gmaill.com>
01 Jul 2008 16:36:20
Original commit files touched by this commit  1.6.3_6,2
 This port version is marked as vulnerable.
mezz search for other commits by this committer
Even thought if poppler-qt doesn't has shared library version change, but these
ports also linking to poppler. The poppler is the one that has shared library
version change. Therefore, bump the PORTREVISION.

Reported by:    Jan Henrik Sylvester <me@janh.de>
28 Jun 2008 01:06:55
Original commit files touched by this commit  1.6.3_5,2
 This port version is marked as vulnerable.
beech search for other commits by this committer
- Unbreak after downgrading GraphicsMagick
26 Jun 2008 07:56:24
Original commit files touched by this commit  1.6.3_5,2
 This port version is marked as vulnerable.
itetcu search for other commits by this committer
Mark broken because it doesn't build with GraphicsMagick v.1.2.3 and newer.
http://bugs.kde.org/show_bug.cgi?id=161770

Submitted by:   Jan Henrik Sylvester <me@janh.de>
25 Jun 2008 08:36:12
Original commit files touched by this commit  1.6.3_5,2
 This port version is marked as vulnerable.
beech search for other commits by this committer
- Bump poirtrevision after GraphicsMagick update
06 Jun 2008 13:25:59
Original commit files touched by this commit  1.6.3_4,2
 This port version is marked as vulnerable.
edwin search for other commits by this committer
Bump portrevision due to upgrade of devel/gettext.

The affected ports are the ones with gettext as a run-dependency
according to ports/INDEX-7 (5007 of them) and the ones with USE_GETTEXT
in Makefile (29 of them).

PR:             ports/124340
Submitted by:   edwin@
Approved by:    portmgr (pav)
08 Nov 2007 17:19:53
Original commit files touched by this commit  1.6.3_3,2
 This port version is marked as vulnerable.
lofi search for other commits by this committer
Forced commit to note the previous commits' were in response to the
advisories published as:

Security: CVE-2007-4352/5392/5493
Approved by: portmgr
08 Nov 2007 17:17:45
Original commit files touched by this commit  1.6.3_3,2
 This port version is marked as vulnerable.
lofi search for other commits by this committer
Fix multiple vulnerabilities from imported xpdf code in KOffice and
kdegraphics

Approved by:    portmgr (mcl)
29 Oct 2007 23:48:18
Original commit files touched by this commit  1.6.3_2,2
 This port version is marked as vulnerable.
lofi search for other commits by this committer
Update to KDE 3.5.8
30 Jul 2007 21:59:28
Original commit files touched by this commit  1.6.3_2,2
 This port version is marked as vulnerable.
lofi search for other commits by this committer
Fix buffer overflow vulnerability in xpdf code.

Security:       http://www.kde.org/info/security/advisory-20070730-1.txt
Security:       CVE-2007-3387
16 Jul 2007 18:33:49
Original commit files touched by this commit  1.6.3_1,2
 This port version is marked as vulnerable.
stas search for other commits by this committer
- Bump up portrevisions on GraphicsMagick dependent ports to get rid of
  changed ABI.
04 Jul 2007 10:25:00
Original commit files touched by this commit  1.6.3,2
 This port version is marked as vulnerable.
lofi search for other commits by this committer
Update to KDE 3.5.7 / KOffice 1.6.3
28 May 2007 16:12:06
Original commit files touched by this commit  1.6.2_3,2
 This port version is marked as vulnerable.
lofi search for other commits by this committer
Forced commit to note that the last commit (which, while correct, went into
the wrong repository, hence the somewhat lackluster commit message) fixes
a build error on 7-CURRENT/amd64.

Error reporty by: marcus
Patch obtained from: KDE SVN
28 May 2007 16:00:17
Original commit files touched by this commit  1.6.2_3,2
 This port version is marked as vulnerable.
lofi search for other commits by this committer
Fix koffice on current/amd64
27 May 2007 15:25:39
Original commit files touched by this commit  1.6.2_3,2
 This port version is marked as vulnerable.
pav search for other commits by this committer
- Chase libexif update
25 May 2007 12:07:17
Original commit files touched by this commit  1.6.2_2,2
 This port version is marked as vulnerable.
pav search for other commits by this committer
- Chase libexif update
19 May 2007 20:32:57
Original commit files touched by this commit  1.6.2_1,2
 This port version is marked as vulnerable.
flz search for other commits by this committer
- Welcome X.org 7.2 \o/.
- Set X11BASE to ${LOCALBASE} for recent ${OSVERSION}.
- Bump PORTREVISION for ports intalling files in ${X11BASE}.
13 Mar 2007 19:10:49
Original commit files touched by this commit  1.6.2,2
 This port version is marked as vulnerable.
lofi search for other commits by this committer
Update to KDE 3.5.6 / KOffice 1.6.2
15 Feb 2007 10:23:36
Original commit files touched by this commit  1.6.1_1,2
 This port version is marked as vulnerable.
lofi search for other commits by this committer
Stop-gap patch to make koffice build with libpqxx 2.6.9.

Submitted by: Maxim Samsonov
18 Jan 2007 10:22:23
Original commit files touched by this commit  1.6.1_1,2
 This port version is marked as vulnerable.
lofi search for other commits by this committer
Patch denial of service vulnerability in PDF parser.

Security: CVE-2007-0104
19 Dec 2006 21:19:54
Original commit files touched by this commit  1.6.1,2
 This port version is marked as vulnerable.
lofi search for other commits by this committer
Update to KDE 3.5.5 / KOffice 1.6.1

Approved by:    portmgr
12 Sep 2006 23:26:52
Original commit files touched by this commit  1.5.2,2
 This port version is marked as vulnerable.
lofi search for other commits by this committer
KDE 3.5.4 / KOffice 1.5.2
05 Jun 2006 19:24:26
Original commit files touched by this commit  1.5.1,2
 This port version is marked as vulnerable.
lofi search for other commits by this committer
Update to KDE 3.5.3
28 May 2006 13:37:06
Original commit files touched by this commit  1.5.1,2
 This port version is marked as vulnerable.
pav search for other commits by this committer
- Renamed port graphics/libart_lgpl2 -> graphics/libart_lgpl
27 May 2006 10:26:19
Original commit files touched by this commit  1.5.1,2
 This port version is marked as vulnerable.
lofi search for other commits by this committer
Update to KOffice 1.5.1
24 May 2006 14:21:45
Original commit files touched by this commit  1.5.0
 This port version is marked as vulnerable.
mnag search for other commits by this committer
- Change dependencies reflecting update in graphics/ImageMagick
- Bump PORTREVISION
29 Apr 2006 15:36:44
Original commit files touched by this commit  1.5.0,1
 This port version is marked as vulnerable.
lofi search for other commits by this committer
Update to KOffice 1.5.0

Approved by:    portmgr (kris)
cVS:    arabic/koffice-i18n/distinfo arabic/koffice-i18n/pkg-descr
23 Feb 2006 10:40:45
Original commit files touched by this commit  1.4.2_3,1
 This port version is marked as vulnerable.
ade search for other commits by this committer
Conversion to a single libtool environment.

Approved by:    portmgr (kris)
22 Jan 2006 08:34:46
Original commit files touched by this commit  1.4.2_2,1
 This port version is marked as vulnerable.
edwin search for other commits by this committer
SHA256ify

Approved by:    krion@
08 Dec 2005 03:29:36
Original commit files touched by this commit  1.4.2_2,1
 This port version is marked as vulnerable.
lofi search for other commits by this committer
Patch security issues in imported xpdf code.

Security: CAN-2005-3193
Security: http://www.kde.org/info/security/advisory-20051207-1.txt
Security: kpdf, the KDE pdf viewer and KOffice' pdf filter share code with
          xpdf. xpdf contains multiple integer overflow vulnerabilities that
          allow specially crafted pdf files, when opened, to overflow a heap
          allocated buffer and execute arbitrary code.
25 Nov 2005 19:36:50
Original commit files touched by this commit  1.4.2_1,1
 This port version is marked as vulnerable.
lofi search for other commits by this committer
Fix KDE Bug 111372 / FreeBSD PR 89479
05 Nov 2005 13:56:34
Original commit files touched by this commit  1.4.2,1
 This port version is marked as vulnerable.
lofi search for other commits by this committer
Fix the PREFIX-safeness fix.
05 Nov 2005 11:19:58
Original commit files touched by this commit  1.4.2,1
 This port version is marked as vulnerable.
lofi search for other commits by this committer
Update to KDE 3.4.3 / KOffice 1.4.2
05 Nov 2005 02:51:21
Original commit files touched by this commit  1.4.1_1,1
 This port version is marked as vulnerable.
lofi search for other commits by this committer
Make PREFIX-safe.
11 Oct 2005 13:29:08
Original commit files touched by this commit  1.4.1_1,1
 This port version is marked as vulnerable.
lofi search for other commits by this committer
Fix a security vulnerability in the RTF importer of KWord.

Security: CAN-2005-2971
Security: CESA-2005-005
Security: http://www.kde.org/info/security/advisory-20051011-1.txt
Security: Opening specially crafted RTF files in KWord can cause
          execution of abitrary code.
04 Oct 2005 11:21:18
Original commit files touched by this commit  1.4.1,1
 This port version is marked as vulnerable.
lofi search for other commits by this committer
Fix bogus ui files in preparation for Qt 3.3.5
22 Aug 2005 09:44:23
Original commit files touched by this commit  1.4.1,1
 This port version is marked as vulnerable.
girgen search for other commits by this committer
Don't depend on libpq directly, instead use the USE_PGSQL knob

Approved by: portmgr
03 Aug 2005 23:15:40
Original commit files touched by this commit  1.4.1,1
 This port version is marked as vulnerable.
lofi search for other commits by this committer
Don't try to invoke autoheader during build stage.

Approved by: portmgr (krion)
01 Aug 2005 10:46:03
Original commit files touched by this commit  1.4.1,1
 This port version is marked as vulnerable.
lofi search for other commits by this committer
Remove obsolete patch.
31 Jul 2005 22:46:35
Original commit files touched by this commit  1.4.1,1
 This port version is marked as vulnerable.
lofi search for other commits by this committer
Update to KDE 3.4.2 / KOffice 1.4.1
10 Jul 2005 17:45:56
Original commit files touched by this commit  1.4.0a_1,1
 This port version is marked as vulnerable.
lofi search for other commits by this committer
Various bugfixes from the KOffice-1.4.x branch.

Submitted by: Raphael Langerhorst <raphael-langerhorst@gmx.at>
05 Jul 2005 20:55:18
Original commit files touched by this commit  1.4.0a,1
 This port version is marked as vulnerable.
lofi search for other commits by this committer
Update to KOffice 1.4.0a.

Note that 'a' does *not* stand for 'alpha', but denotes a short-notice
bugfix release made after KOffice 1.4.0.
26 Jun 2005 15:38:58
Original commit files touched by this commit  1.3.5_2
 This port version is marked as vulnerable.
lofi search for other commits by this committer
Update to KDE 3.4.1
04 Apr 2005 14:06:47
Original commit files touched by this commit  1.3.5_2,1
 This port version is marked as vulnerable.
lofi search for other commits by this committer
Remove dependency on wordnet.
20 Mar 2005 18:17:56
Original commit files touched by this commit  1.3.5_2,1
 This port version is marked as vulnerable.
lofi search for other commits by this committer
Update to KDE 3.4
23 Feb 2005 16:07:13
Original commit files touched by this commit  1.3.5_2,1
 This port version is marked as vulnerable.
lofi search for other commits by this committer
Add patch for KDE bug 95553.

Obtained from: mi / KDE CVS
20 Jan 2005 23:22:58
Original commit files touched by this commit  1.3.5_2,1
 This port version is marked as vulnerable.
lofi search for other commits by this committer
Fix yet another buffer overflow in imported xpdf sources.

References:

http://www.koffice.org/security/advisory-20050120-1.txt

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2005-0064
http://www.idefense.com/application/poi/display?id=186&type=vulnerabilities
24 Dec 2004 16:23:13
Original commit files touched by this commit  1.3.5_1,1
 This port version is marked as vulnerable.
markus search for other commits by this committer
Patch vulnerability in imported xpdf code. Bump PORTREVISION.

References:

http://koffice.kde.org/releases/1.3.5-release.php
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2004-1125
http://www.idefense.com/application/poi/display?id=172&type=vulnerabilities

Notified by:    josef
13 Dec 2004 19:53:56
Original commit files touched by this commit  1.3.5,1
 This port version is marked as vulnerable.
lofi search for other commits by this committer
Update to KOffice 1.3.5
08 Nov 2004 00:35:13
Original commit files touched by this commit  1.3.4,1
 This port version is marked as vulnerable.
lofi search for other commits by this committer
Forced commit to note that KOffice was updated to version 1.3.4
08 Nov 2004 00:34:12
Original commit files touched by this commit  1.3.4,1
 This port version is marked as vulnerable.
lofi search for other commits by this committer
Update to KDE 3.3.1
24 Oct 2004 15:07:42
Original commit files touched by this commit  1.3.2_1,1
 This port version is marked as vulnerable.
lofi search for other commits by this committer
Fix vulnerabilities in imported xpdf code.

http://www.kde.org/info/security/advisory-20041021-1.txt
30 Aug 2004 19:55:42
Original commit files touched by this commit  1.3.2,1
 This port version is marked as vulnerable.
lofi search for other commits by this committer
Update to KDE 3.3
11 Aug 2004 01:27:37
Original commit files touched by this commit  1.3.2,1
 This port version is marked as vulnerable.
lofi search for other commits by this committer
Factor out all but one of the build switches of the KDE main module ports
into separate ports. The OPTIONS will remain as of yet and trigger dependencies
now, for easy transition.

Update KOffice to version 1.3.2.

Add patches to fix a number of issues, including:

- fix kxkb on Xorg
- fix kdemultimedia WITH_MPEGLIB (now mpeglib_artsplug) compilation on gcc 3.4.2
  with optimizations greater than -O

Add security related patches and entries to portaudit.txt.
09 Jun 2004 16:58:31
Original commit files touched by this commit  1.3.1,1
 This port version is marked as vulnerable.
lofi search for other commits by this committer
Update to version 3.2.3
23 May 2004 14:14:34
Original commit files touched by this commit  1.3.1,1
 This port version is marked as vulnerable.
lofi search for other commits by this committer
Whoops, that's what you get for not testing properly.

Pointy hat to: me
22 May 2004 22:15:11
Original commit files touched by this commit  1.3.1,1
 This port version is marked as vulnerable.
lofi search for other commits by this committer
Enable dependency on wv2 (and therefore MS Word import) unconditionally.
06 May 2004 10:20:36
Original commit files touched by this commit  1.3.1,1
 This port version is marked as vulnerable.
lofi search for other commits by this committer
Update to version 1.3.1
20 Apr 2004 09:08:07
Original commit files touched by this commit  1.3,1
 This port version is marked as vulnerable.
lofi search for other commits by this committer
Update to KDE 3.2.2
04 Apr 2004 06:59:01
Original commit files touched by this commit  1.3,1
 This port version is marked as vulnerable.
lofi search for other commits by this committer
Convert to OPTIONS.
30 Mar 2004 19:20:23
Original commit files touched by this commit  1.3,1
 This port version is marked as vulnerable.
krion search for other commits by this committer
- Use USE_ICONV knob

Approved by:    portmgr
22 Mar 2004 14:56:47
Original commit files touched by this commit  1.3,1
 This port version is marked as vulnerable.
arved search for other commits by this committer
Don't add -fPIC to CFLAGS on amd64 and ia64.
The original problem seems to be fixed in koffice 1.3

Tested on:      amd64
18 Mar 2004 01:32:19
Original commit files touched by this commit  1.3,1
 This port version is marked as vulnerable.
lofi search for other commits by this committer
SIZEify.
09 Mar 2004 19:41:12
Original commit files touched by this commit  1.3,1
 This port version is marked as vulnerable.
lofi search for other commits by this committer
Update to KDE 3.2.1 / QT 3.3.1

Important changes:
==================

KDE:

- Audio/arts does not install artswrapper anymore, instead it is provided by
  audio/artswrapper. See UPDATING.

- misc/kdeaddons3 is now a metaport with

        editors/kate-plugins
        editors/vimpart
        games/atlantikdesigner
(Only the first 15 lines of the commit message are shown above View all of this commit message)
05 Feb 2004 21:02:38
Original commit files touched by this commit  1.3,1
 This port version is marked as vulnerable.
lofi search for other commits by this committer
Remove pkg-plist.
05 Feb 2004 01:23:10
Original commit files touched by this commit  1.3,1
 This port version is marked as vulnerable.
lofi search for other commits by this committer
Update to KDE 3.2.0

Important changes:
==================

- Kmail and knode have been moved from kdenetwork to kdepim. This
  means you will have to install kdepim if you want to continue using
  kmail or knode. This is to ease integration with korganizer, in
  the new 'Kontact' application.

- The arabic translations for KDE and KOffice have been moved from
  misc to the arabic category.

- There is a new module called kdeaccessibility in the accessibility
  category.  It contains a few utilities for disabled users like a
  magnification lens and a text-to-speech frontend.

- In KDM, you need to select the 'CUSTOM' session profile in order
  to have your .xsession executed. This is particularly important if
  you're using the aegypten tools
  (http://freebsd.kde.org/howtos/aegypten-kmail.php).

- We have started making more parts of the ports optional. In kdepim,
  both Kandy and KPilot can be turned off with ports-knobs. This
  process will continue in the 3.2 series.
04 Feb 2004 05:21:48
Original commit files touched by this commit  1.2.1_2,1
 This port version is marked as vulnerable.
marcus search for other commits by this committer
Bump PORTREVISION on all ports that depend on gettext to aid with upgrading.

(Part 2)
26 Nov 2003 10:35:19
Original commit files touched by this commit  1.2.1_1,1
 This port version is marked as vulnerable.
arved search for other commits by this committer
Add -fPIC to CFLAGS on IA64 and AMD64.
Fixes build (tested on pluto2).

Reported by:    kris
17 Nov 2003 12:29:10
Original commit files touched by this commit  1.2.1_1,1
 This port version is marked as vulnerable.
trevor search for other commits by this committer
USE_REINPLACE need be defined only when REINPLACE_CMD is used.
03 Oct 2003 22:34:44
Original commit files touched by this commit  1.2.1_1,1
 This port version is marked as vulnerable.
will search for other commits by this committer
Fix the -pthread problem in case the option gets removed again.  This
patch involved patching the core auto* routines in KDE to accept the
PTHREAD_* variables in the environment, with fallbacks.  We decided the
easiest way to implement this in ports was to generate configure instead
of risking incorrect generation at port configure time.

Said patch has already been committed to HEAD in KDE and as such will be
removed with the 3.2 upgrade once it is released.

Ports using Makefile.kde that shouldn't be using them (i.e. non-KDE
modules) have this support commented out due to lack of patch.

Helped out:     Adriaan de Groot <adridg@cs.kun.nl>
                Lauri Watts <lauri@kde.org>
                Andy Fawcett <andy@athame.co.uk>
29 Jul 2003 04:26:22
Original commit files touched by this commit  1.2.1_1,1
 This port version is marked as vulnerable.
lofi search for other commits by this committer
Update KDE to the latest official release, KDE 3.1.3

Official KDE 3.1.3 announcement:
http://www.kde.org/announcements/announce-3.1.3.php

(may not work until a few hours after this commit - we jumped the gun a little
 in order to have the update in place at the time the security notifications for
 KDE 3.1.2 will be released together with the announcement of KDE 3.1.3).

Changelog from 3.1.2 to 3.1.3 release:
http://www.kde.org/announcements/changelogs/changelog3_1_2to3_1_3.php

Thanks and credits need to go to the whole KDE-FreeBSD team, as well
as everyone on kde@freebsd.org for providing feedback, reporting bugs
and just using the KDE ports.

Approved by: will (real mentor asleep)
22 Apr 2003 17:18:12
Original commit files touched by this commit  1.2.1_1,1
 This port version is marked as vulnerable.
arved search for other commits by this committer
Add official bugfix patch that fixes two kword crahes, when closing the
"Insert Special Character" dialog and when updating the Table Of Contents.

PR:             49020
Submitted by:   mi, Michael Nottebrock
07 Mar 2003 06:00:45
Original commit files touched by this commit  1.2.1,1
 This port version is marked as vulnerable.
ade search for other commits by this committer
Clear moonlight beckons.
Requiem mors pacem pkg-comment,
And be calm ports tree.

E Nomini Patri, E Fili, E Spiritu Sancti.
02 Jan 2003 13:59:16
Original commit files touched by this commit  1.2.1,1
 This port version is marked as vulnerable.
alane search for other commits by this committer
Update to 1.2.1.

Number of commits found: 112 (showing only 100 on this page)

1 | 2  »  

Login
User Login
Create account

Servers and bandwidth provided by
New York Internet, SuperNews, and RootBSD

This site
What is FreshPorts?
About the authors
FAQ
How big is it?
The latest upgrade!
Privacy
Forums
Blog
Contact

Search
Enter Keywords:
 
more...

Latest Vulnerabilities
asterisk11Oct 21
libxml2Oct 18
drupal7Oct 16
firefox*Oct 16
firefox-esr*Oct 16
libxul*Oct 16
linux-firefox*Oct 16
linux-seamonkey*Oct 16
linux-thunderbird*Oct 16
seamonkey*Oct 16
thunderbird*Oct 16
linux-c6-opensslOct 15
mingw32-opensslOct 15
opensslOct 15
foreman-proxyOct 09

7 vulnerabilities affecting 29 ports have been reported in the past 14 days

* - modified, not new

All vulnerabilities


Ports
Home
Categories
Deleted ports
Sanity Test Failures
Newsfeeds


Statistics
Graphs
NEW Graphs (Javascript)
Traffic

Calculated hourly:
Port count 24262
Broken 100
Deprecated 30
Ignore 357
Forbidden 2
Restricted 205
No CDROM 93
Vulnerable 19
Expired 0
Set to expire 26
Interactive 0
new 24 hours 2
new 48 hours5
new 7 days27
new fortnight48
new month243

Servers and bandwidth provided by
New York Internet, SuperNews, and RootBSD
Valid HTML, CSS, and RSS.
Copyright © 2000-2014 Dan Langille. All rights reserved.