FreshPorts -- The Place For Ports If you buy from Amazon USA, please support us by using this link.
Follow us
Blog
Twitter

Please give me your LTO-4 or better tape library and I'll put it to good use.
Port details
openoffice-4 Integrated wordprocessor/dbase/spreadsheet/drawing/chart/browser
4.1.1_9 editors on this many watch lists=10 search for ports that depend on this port An older version of this port was marked as vulnerable. Find issues related to this port Report an issue related to this port
Maintainer: office@FreeBSD.org search for ports maintained by this maintainer
Port Added: 26 Aug 2013 04:19:31
Also Listed In: java
License: APACHE20
Apache OpenOffice is an Open Source, community-developed, multi-platform
office productivity suite. It includes the key desktop applications,
such as a word processor, spreadsheet, presentation manager, and drawing
program, with a user interface and feature set similar to other
office suites.

Components include:
  * A universal word processing application for creating business
    letters, extensive text documents, professional layouts, and HTML
    documents.
  * A sophisticated application for performing advanced spreadsheet
    functions, such as analyzing figures, creating lists, and viewing data.
  * A tool for creating effective eye-catching presentations.
  * A vector-oriented draw module that enables the creation of 3D
    illustrations

WWW: http://openoffice.apache.org/
SVNWeb : Homepage : Distfiles Availability : PortsMon

NOTE: FreshPorts displays only information on required and default dependencies. Optional dependencies are not covered.

Build dependencies:
  1. p5-Archive-Zip>=0 : archivers/p5-Archive-Zip
  2. p5-libwww>=0 : www/p5-libwww
  3. p5-XML-Parser>=0 : textproc/p5-XML-Parser
  4. unzip : archivers/unzip
  5. zip : archivers/zip
  6. ant : devel/apache-ant
  7. dmake : devel/dmake
  8. epm : devel/epm
  9. gperf : devel/gperf
  10. imake : devel/imake
  11. gpatch : devel/patch
  12. vigra-config : graphics/vigra
  13. commons-httpclient.jar : java/jakarta-commons-httpclient
  14. commons-lang.jar : java/jakarta-commons-lang
  15. junit.jar : java/junit
  16. bsh.jar : lang/bsh
  17. bash : shells/bash
  18. lucene-core-3.6.2.jar : textproc/lucene
  19. p5-libwww>=0 : www/p5-libwww
  20. java : java/openjdk7
  21. autoconf-2.69 : devel/autoconf
  22. autoheader-2.69 : devel/autoconf
  23. autoreconf-2.69 : devel/autoconf
  24. aclocal-1.15 : devel/automake
  25. automake-1.15 : devel/automake
  26. bison : devel/bison
  27. update-desktop-database : devel/desktop-file-utils
  28. gmake : devel/gmake
  29. pkgconf : devel/pkgconf
  30. python2.7 : lang/python27
  31. gcc48 : lang/gcc
  32. as : devel/binutils
  33. libGL>0 : graphics/libGL
  34. glproto.pc : x11/glproto
  35. dri2proto.pc : x11/dri2proto
  36. glproto.pc : x11/glproto
  37. dri2proto.pc : x11/dri2proto
  38. x11.pc : x11/libX11
  39. ice.pc : x11/libICE
  40. xaw7.pc : x11-toolkits/libXaw
  41. xau.pc : x11/libXau
  42. xext.pc : x11/libXext
  43. xrender.pc : x11/libXrender
  44. xrandr.pc : x11/libXrandr
  45. xi.pc : x11/libXi
  46. xt.pc : x11-toolkits/libXt
  47. xcursor.pc : x11/libXcursor
  48. xdamage.pc : x11/libXdamage
  49. xcomposite.pc : x11/libXcomposite
  50. xfixes.pc : x11/libXfixes
  51. gstreamer-plugins>=0.10.0 : multimedia/gstreamer-plugins
  52. gnome-mime-data-2.0.pc : misc/gnome-mime-data
  53. intltool-extract : textproc/intltool
  54. perl5.20.2 : lang/perl5.20
Runtime dependencies:
  1. index.theme : misc/hicolor-icon-theme
  2. commons-httpclient.jar : java/jakarta-commons-httpclient
  3. bsh.jar : lang/bsh
  4. Arimo-Bold.ttf : x11-fonts/croscorefonts-fonts-ttf
  5. update-desktop-database : devel/desktop-file-utils
  6. python2.7 : lang/python27
  7. gcc48 : lang/gcc
  8. libGL>0 : graphics/libGL
  9. x11.pc : x11/libX11
  10. ice.pc : x11/libICE
  11. xaw7.pc : x11-toolkits/libXaw
  12. xau.pc : x11/libXau
  13. xext.pc : x11/libXext
  14. xrender.pc : x11/libXrender
  15. xrandr.pc : x11/libXrandr
  16. xi.pc : x11/libXi
  17. xt.pc : x11-toolkits/libXt
  18. xcursor.pc : x11/libXcursor
  19. xdamage.pc : x11/libXdamage
  20. xcomposite.pc : x11/libXcomposite
  21. xfixes.pc : x11/libXfixes
  22. gstreamer-plugins>=0.10.0 : multimedia/gstreamer-plugins
  23. gnome-mime-data-2.0.pc : misc/gnome-mime-data
Library dependencies:
  1. libapr-1.so : devel/apr1
  2. libcurl.so : ftp/curl
  3. libcairo.so : graphics/cairo
  4. libjpeg.so : graphics/jpeg
  5. libpng.so : graphics/png
  6. libpoppler-glib.so : graphics/poppler-glib
  7. libCoinMP.so : math/coinmp
  8. libfreetype.so : print/freetype2
  9. libnss3.so : security/nss
  10. libexpat.so : textproc/expat2
  11. libhunspell-1.3.so : textproc/hunspell
  12. libhyphen.so : textproc/hyphen
  13. libtextcat.so : textproc/libtextcat
  14. libmythes-1.2.so : textproc/mythes
  15. librdf.so : textproc/redland
  16. libserf-1.so : www/serf
  17. libcups.so : print/cups-client
  18. libdbus-glib-1.so : devel/dbus-glib
  19. libGLU.so : graphics/libGLU
  20. libatk-1.0.so : accessibility/atk
  21. libgconf-2.so : devel/gconf2
  22. libglib-2.0.so : devel/glib20
  23. libgnomevfs-2.so : devel/gnome-vfs
  24. libgtk-x11-2.0.so : x11-toolkits/gtk20
  25. libIDL-2.so : devel/libIDL
  26. libxml2.so : textproc/libxml2
  27. libxslt.so : textproc/libxslt
  28. libORBit-2.so : devel/ORBit2
  29. libpango-1.0.so : x11-toolkits/pango
There are no ports dependent upon this port

To install the port: cd /usr/ports/editors/openoffice-4/ && make install clean
To add the package: pkg install editors/openoffice-4


Configuration Options
===> The following configuration options are available for apache-openoffice-4.1.1_9:
     CCACHE=off: Mimimize compile time of C/C++ programs
     CUPS=on: CUPS printing system support
     GNOME=on: GConf + screensaver presentation control via DBUS
     GNOMEVFS=on: GNOME Virtual File System
     MMEDIA=on: Multimedia backend for impress
===> Use 'make config' to modify these settings

USES:
autoreconf:autoconf bison compiler cpe desktop-file-utils  gmake perl5 pkgconfig python tar:bzip2

Master Sites:
  1. ftp://ftp.forthnet.gr/pub/www/apache/openoffice/4.1.1/source/
  2. ftp://ftp.heanet.ie/mirrors/www.apache.org/dist/openoffice/4.1.1/source/
  3. ftp://ftp.sunet.se/pub/www/servers/apache/dist/openoffice/4.1.1/source/
  4. ftp://mir1.ovh.net/ftp.apache.org/dist/openoffice/4.1.1/source/
  5. ftp://xenia.sote.hu/pub/mirrors/www.apache.org/openoffice/4.1.1/source/
  6. http://apache.mirror.uber.com.au/openoffice/4.1.1/source/
  7. http://apache.spd.co.il/openoffice/4.1.1/source/
  8. http://archive.apache.org/dist/openoffice/4.1.1/source/
  9. http://distcache.FreeBSD.org/ports-distfiles/openoffice/
  10. http://ftp-stud.fht-esslingen.de/pub/Mirrors/ftp.apache.org/dist/openoffice/4.1.1/source/
  11. http://ftp.mirrorservice.org/sites/ftp.apache.org/openoffice/4.1.1/source/
  12. http://ftp.twaren.net/Unix/Web/apache/openoffice/4.1.1/source/
  13. http://mirrors.ircam.fr/pub/apache/openoffice/4.1.1/source/
  14. http://www.apache.org/dist/openoffice/4.1.1/source/
Port Moves
  • port moved here from editors/openoffice-3 on 2014-02-07
    REASON: OpenOffice 3 is not supported anymore

Number of commits found: 37

Commit History - (may be incomplete: see SVNWeb link above for full details)
DateByDescription
14 May 2015 23:07:18
Original commit files touched by this commit  4.1.1_9
Revision:386368
truckman search for other commits by this committer
Do not attempt to override the intent of DISABLE_MAKE_JOBS, which
does not succeed in any case.

The do-build target does not need to use bash, or even an extra
level of shell.

There are two levels of parallelism in the openoffice build framework.
Split MAKE_JOBS_NUMBER between the two levels instead of potentially
running MAKE_JOBS_NUMBER^2 compilations in parallel.

PR:		199930
Approved by:	mat (mentor, implicit)
08 May 2015 15:58:39
Original commit files touched by this commit  4.1.1_9
Revision:385792
truckman search for other commits by this committer
Add a patch to fix the HWP filter vulnerability documented in
CVE-2015-1774 and
<http://www.openoffice.org/security/cves/CVE-2015-1774.html>

Approved by:	mat (mentor)
MFH:		2015Q2
Security:	b13af778-f4fc-11e4-a95d-ac9e174be3af
Differential Revision:	https://reviews.freebsd.org/D2478
05 May 2015 20:38:34
Original commit files touched by this commit  4.1.1_8
Revision:385489 This port version is marked as vulnerable.
truckman search for other commits by this committer
Unbreak editors/openoffice-* build when GCONF and GNOMEVFS are disabled

There is a missing dependency on devel/dbus-glib that causes the
openoffice build to fail when the GCONF and GNOMEVFS options are
disabled. When these options are enabled, one of the dependencies
added by these options brings along dbus-glib so the default build
succeeds.

There is a configure knob to control whether or not dbus-glib is
used, so follow the lead of the libreoffice port and rename the
GCONF option to GNOME and bundle both Gconf and DBUS handling under
the GNOME option.

Borrow the MMEDIA option from the libreoffice port and use that to
control the using of gstreamer.
(Only the first 15 lines of the commit message are shown above View all of this commit message)
30 Mar 2015 17:57:49
Original commit files touched by this commit  4.1.1_8
Revision:382699 This port version is marked as vulnerable.
sunpoet search for other commits by this committer
- Add CPE information

PR:		199029
Submitted by:	shun <shun.fbsd.pr@dropcut.net>
27 Mar 2015 20:22:37
Original commit files touched by this commit  4.1.1_8
Revision:382435 This port version is marked as vulnerable.
truckman search for other commits by this committer
Update openoffice-4 with applicable changes in openoffice-devel r382334:

 * Work around broken build on FreeBSD 11.0-CURRENT i386, which appears
   to be a code generation bug in clang 3.6 when using -Os optimization.

 * Use the dictionaries already installed by ports.

 * Update patch-*.mk patches to versions that were imported upstream.
   They are tuned for clang to use as is, with only some minor
   additional tweaks needed for gcc.

 * Wordsmith pkg-message.

 * Some Makefile cleanups.

Differential Revision:	https://reviews.freebsd.org/D2151
Reviewed by:	pfg
Approved by:	mat (mentor)
21 Mar 2015 23:05:21
Original commit files touched by this commit  4.1.1_7
Revision:381876  Sanity Test Failure This port version is marked as vulnerable.
bapt search for other commits by this committer
Make fonts repecting XDG

Xorg is now looking in ${LOCALBASE}/share/fonts by default
Xorg now accepts symlinks in etc/X11/fontpath.d (as decribed in Xserver(1))
Large cleanup on lots of font ports
All fonts are now properly dynamically generating fonts.dir and fonts.scale
instead of sometime overwriting existing ones)
All fonts are generating fontconfig's cache
Improve consistency in fonts ports
17 Mar 2015 15:04:44
Original commit files touched by this commit  4.1.1_7
Revision:381494 This port version is marked as vulnerable.
truckman search for other commits by this committer
Unbreak editors/openoffice-4 and editors/openoffice-devel on systems
where clang is the base compiler.  The issue was that these ports
would only successfully build with gcc and libstdc++, so they
specified USE_GCC=yes, but they linked to other C++ ports that were
compiled with clang, which brought in libc++.  The conflict between
libstdc++ and libc++ caused the application to crash whenever an
operation that popped up a dialog box was attempted.  Thanks to
dim@ for helping me track this down.  The fix is to patch various
bits of the openoffice souce to allow it to be built with clang
on systems where the C++ dependencies are also compiled with clang. [1]

Add a CUPS option so that CUPS can be disabled [2].

Register print/cups-client as a LIB_DEPENDS when CUPS is enabled.
(Only the first 15 lines of the commit message are shown above View all of this commit message)
25 Feb 2015 06:01:58
Original commit files touched by this commit  4.1.1_6
Revision:379876 This port version is marked as vulnerable.
truckman search for other commits by this committer
Fix build breakage when libreoffice is installed.

The problem is that libreoffice installs its own copy of unopkg in
${PREFIX}/bin and that the openoffice build attempts to use this copy
of unopkg instead of the openoffice version which is in subdirectory
of ${WRKSRC}.

The reason is that the openoffice build expects to find its own copy
of unopkg by depending on having "." in its $PATH, but its $PATH has
${PREFIX}/bin before ".". Openoffice attempts to do the right thing
by first constructing $PATH by prepending "." and a small number of
other directories where it stashes executables used during the build
to the value of $PATH that it inherits from the environment. Things
go wrong when it tries to add the paths for ${CC}, perl, and java
to $PATH. If $PATH has /usr/bin before ${PREFIX}/bin, the openoffice
(Only the first 15 lines of the commit message are shown above View all of this commit message)
15 Feb 2015 22:30:46
Original commit files touched by this commit  4.1.1_6
Revision:379055 This port version is marked as vulnerable.
truckman search for other commits by this committer
Switch back to USE_GCC=yes.

Work around this bug <https://gcc.gnu.org/bugzilla/show_bug.cgi?id=65009>
in g++49 -Os optimzation by using -O0 optimization if we are compiling
with g++49.

Differential Revision:	https://reviews.freebsd.org/D1792
Approved by:	mat (mentor)
13 Feb 2015 01:01:35
Original commit files touched by this commit  4.1.1_6
Revision:378905 This port version is marked as vulnerable.
brd search for other commits by this committer
math/coinmp: Update to 1.8.0

PR:		197554
Submitted by:	Carlos Jacobo Puga Medina <cpm@fbsd.es> (maintainer)
Approved by:	zi
03 Feb 2015 12:28:24
Original commit files touched by this commit  4.1.1_5
Revision:378348 This port version is marked as vulnerable.
kwm search for other commits by this committer
Update poppler to 0.30.0 [1].

Make sure we use openjpeg1 in poppler, while openjpeg2 support
was added there still bugs in openjpeg2 that need to be fixed.
Add patches to inkscape for API changes in poppler 0.29.0 [2].

PR:		196599 [1]
Submitted by:	olivierd@ [1]
Exp-run by:	antoine@
Obtained from:	upstream [2]
21 Jan 2015 09:03:10
Original commit files touched by this commit  4.1.1_4
Revision:377578 This port version is marked as vulnerable.
truckman search for other commits by this committer
Unbreak languagepack target (package-rename and ure targets are still
broken).

plist fixes:
  * Don't add @dirrm to generated plist
  * Don't add a blank line to generated plist
  * Don't truncate ${TMPPLIST} (from mat@)
  * Don't add @dirrm to generated plist
  * Add @dir for empty directories

Makefile diff reduction vs. upcoming openoffice-devel update.

Differential Revision:	https://reviews.freebsd.org/D1561
Approved by:	mat (mentor)
19 Jan 2015 17:45:18
Original commit files touched by this commit  4.1.1_4
Revision:377444 This port version is marked as vulnerable.
truckman search for other commits by this committer
The sdk and package-canonical targets were suffering from bit rot.
Unbreak. [1]

The port build fails with gcc 4.9, convert to USE_GCC=4.8. [2]

Differential Revision:	https://reviews.freebsd.org/D1557
Submitted by:	pfg [1]
Submitted by:	gerald [2]
Reviewed by:	pfg
Approved by:	mat (mentor)
19 Jan 2015 00:57:31
Original commit files touched by this commit  4.1.1_4
Revision:377375 This port version is marked as vulnerable.
truckman search for other commits by this committer
The editors/openoffice-4 port currently depends on textproc/saxon-devel and
relies on features that are only present in this version of saxon.  The
recent update to math/scilab added a dependency to textproc/saxon-he, and
it requires features that are only present in this version.  Unfortunately
saxon-devel and saxon-he conflict because they both want to install
/usr/local/share/java/classes/saxon9-xqj.jar, which means that openoffice-4
and scilab can't both be installed on the same machine.  Avoid this problem
by tweaking openoffice-4 use a private copy of saxon.  This requires a
new version of the ext_sources tarball.

Bump PORTREVISION so that users pick up the updated port.

Modernize MASTER_SITES syntax and update MASTER_SITE for unowinreg.dll.

Update comment to take de facto mainternship.

PR:		193776
Differential Revision:	https://reviews.freebsd.org/D1553
Reviewed by:	bapt, pfg
Approved by:	mat (mentor)
25 Dec 2014 20:54:43
Original commit files touched by this commit  4.1.1_3
Revision:375598 This port version is marked as vulnerable.
bapt search for other commits by this committer
Bump portrevision after png update
25 Nov 2014 12:55:54
Original commit files touched by this commit  4.1.1_2
Revision:373404 This port version is marked as vulnerable.
makc search for other commits by this committer
Bump PORTREVISION after graphics/poppler update to 0.26.3
10 Sep 2014 20:50:37
Original commit files touched by this commit  4.1.1_1
Revision:367888 This port version is marked as vulnerable.
gerald search for other commits by this committer
Update the default version of GCC in the Ports Collection from GCC 4.7.4
to GCC 4.8.3.

Part II, Bump PORTREVISIONs.

PR:		192025
Tested by:	antoine (-exp runs)
Approved by:	portmgr (implicit)
26 Aug 2014 22:48:21
Original commit files touched by this commit  4.1.1
Revision:366281 This port version is marked as vulnerable.
truckman search for other commits by this committer
Apache OpenOffice 4.1.1 has been officially released.

Release announcement:

Announcing Apache OpenOffice 4.1.1

21 August 2014 - The Apache OpenOffice project is pleased to announce
the immediate availability of OpenOffice 4.1.1. You can download
it from our website.

Apache OpenOffice 4.1.1 is a micro update with many useful and
critical bugfixes including 2 security relevant fixes (details will
come separately).

Bugfixes include:
(Only the first 15 lines of the commit message are shown above View all of this commit message)
25 Aug 2014 23:21:55
Original commit files touched by this commit  4.1.0
Revision:366163 This port version is marked as vulnerable.
truckman search for other commits by this committer
Remove the --with-system-graphite configure option to unbreak
editors/openoffice-4 on FreeBSD 10.0 and 11.0.  The cause of the
breakage is that on systems with clang as the default compiler,
graphics/silgraphite is built with clang and linked to libc++.so.1,
while openoffice is built with gcc from ports and linked to libstdc++.
This combination causes the resulting executables to go boom.

Add a source makefile patch to unbreak the --with-system-jpeg option
and enable this option.  The problem is that without this patch the
build tries to link to the openjdk version of libjpeg instead of
the version installed by graphics/jpeg.

The --with-system-mythes options also works, so enable it as well.

Adjust LIB_DEPENDS for these changes.  Also make the graphics/png
(Only the first 15 lines of the commit message are shown above View all of this commit message)
12 Jun 2014 09:17:33
Original commit files touched by this commit  4.0.1_4
Revision:357574 This port version is marked as vulnerable.
tijl search for other commits by this committer
Bump PORTREVISION on everything that depends on devel/apr1 due to the
library version change.

Approved by:	portmgr (implicit)
16 Apr 2014 18:28:50
Original commit files touched by this commit  4.0.1_3
Revision:351411 This port version is marked as vulnerable.
zeising search for other commits by this committer
The FreeBSD x11@ and graphics team proudly presents
a zeising, kwm production, with help from dumbbell, bdrewery:

NEW XORG ON FREEBSD 9-STABLE AND 10-STABLE

This update switches over to use the new xorg stack by default on FreeBSD 9
and 10 stable, on osversions where vt(9) is available.
It is still possible to use the old stack by specifying WITHOUT_NEW_XORG in
/etc/make.conf .
FreeBSD 8-STABLE and released versions of FreeBSD still use
the old version.
A package repository with binary packages for new xorg will
be available soon.

This patch also contains updates of libxcb and related ports, pixman, as well
(Only the first 15 lines of the commit message are shown above View all of this commit message)
30 Mar 2014 21:26:27
Original commit files touched by this commit  4.0.1_2
Revision:349680 This port version is marked as vulnerable.
bapt search for other commits by this committer
Create mime and icon directory inside the stage directory

Reported by:	Norbert Augenstein <lists@augenstein.net>, pfg
26 Mar 2014 08:11:08
Original commit files touched by this commit  4.0.1_2
Revision:349232 This port version is marked as vulnerable.
bapt search for other commits by this committer
Support stage
07 Feb 2014 11:44:09
Original commit files touched by this commit  4.0.1_2
Revision:343214 This port version is marked as vulnerable.
bapt search for other commits by this committer
Chase boost and icu bump
While here convert some LIB_DEPENDS
22 Jan 2014 05:44:33
Original commit files touched by this commit  4.0.1_1
Revision:340680 This port version is marked as vulnerable.
maho search for other commits by this committer
Fix build

PR:		185401
Submitted by:	 	Jan Henrik Sylvester <me@janh.de>
30 Dec 2013 20:55:19
Original commit files touched by this commit  4.0.1_1
Revision:338168 This port version is marked as vulnerable.
ohauer search for other commits by this committer
- rename AL2 to APACHE20 in Mk/bsd.licenses.db.mk
- svn move Templates/Licenses/AL2 Templates/Licenses/APACHE20
- add APACHE10 and APACHE11 to Mk/bsd.licenses.db.mk
- add entry in UPDATING
- bulk change all ports AL2 => APACHE20

- math/openfst/pkg-plist: remove share/licenses/openfst-1.3.4

PR:		ports/184785
Submitted by:	ohauer
Reviewed by:	tabthorpe
Approved by:	portmgr (tabthorpe@)
27 Dec 2013 16:54:22
Original commit files touched by this commit  4.0.1_1
Revision:337749 This port version is marked as vulnerable.
kwm search for other commits by this committer
Update poppler to 0.24.4.

Update comment.
Use new LIB_DEPENDS syntax, use USES=pathfix.
Stagify.

Bump portrevision of all affected ports, and Update poppler* LIB_DEPENDS to
new syntax.
22 Oct 2013 13:57:35
Original commit files touched by this commit  4.0.1
Revision:331271 This port version is marked as vulnerable.
amdmi3 search for other commits by this committer
- Remove manual creation and removal of share/applications, as it's now in the
mtree (categories starting with [bce])

Approved by:	portmgr (bdrewery)
03 Oct 2013 00:50:13
Original commit files touched by this commit  4.0.1
Revision:329134 This port version is marked as vulnerable.
maho search for other commits by this committer
update to 4.0.1
20 Sep 2013 16:36:24
Original commit files touched by this commit  4.0.0
Revision:327720 This port version is marked as vulnerable.
bapt search for other commits by this committer
Add NO_STAGE all over the place in preparation for the staging support (cat:
editors)
18 Sep 2013 08:38:20
Original commit files touched by this commit  4.0.0
Revision:327535 This port version is marked as vulnerable.
bapt search for other commits by this committer
Add an explicit dependency on pkgconf
12 Sep 2013 06:39:10
Original commit files touched by this commit  4.0.0
Revision:327037 This port version is marked as vulnerable.
maho search for other commits by this committer
Unbreake by reroll of ext packages. Actually
former archive misses some tarballs, and I added to
avoid fetching while compiling.
31 Aug 2013 02:00:00
Original commit files touched by this commit  4.0.0
Revision:325766 This port version is marked as vulnerable.
bdrewery search for other commits by this committer
- Mark BROKEN, fails checksum
30 Aug 2013 12:47:05
Original commit files touched by this commit  4.0.0
Revision:325675 This port version is marked as vulnerable.
bdrewery search for other commits by this committer
- Fix with bmake
28 Aug 2013 00:28:07
Original commit files touched by this commit  4.0.0
Revision:325496 This port version is marked as vulnerable.
maho search for other commits by this committer
bsd.port.options.mk, needs to be placed before bsd.port.pre.mk.

Submitted by:	jgh@
27 Aug 2013 06:27:25
Original commit files touched by this commit  4.0.0
Revision:325429 This port version is marked as vulnerable.
maho search for other commits by this committer
convert to USES, and adoption of optionsNG styling, add CCACHE as configurable
option

PR:		181574
Submitted by:	jgh@
26 Aug 2013 04:19:17
Original commit files touched by this commit  4.0.0
Revision:325370 This port version is marked as vulnerable.
maho search for other commits by this committer
Update (branching) Apache OpenOffice port to 4.0.0.

Number of commits found: 37

Login
User Login
Create account

Servers and bandwidth provided by
New York Internet, SuperNews, and RootBSD

This site
What is FreshPorts?
About the authors
FAQ
How big is it?
The latest upgrade!
Privacy
Forums
Blog
Contact

Search
Enter Keywords:
 
more...

Latest Vulnerabilities
proxychains-ngMay 29
krb5May 28
krb5-112May 28
tsharkMay 28
tshark-liteMay 28
wiresharkMay 28
wireshark-liteMay 28
curlMay 26
curlMay 26
cassandraMay 24
cassandra2May 24
py-saltMay 24
davmailMay 23
dnsmasqMay 23
dnsmasq-develMay 23

22 vulnerabilities affecting 39 ports have been reported in the past 14 days

* - modified, not new

All vulnerabilities


Ports
Home
Categories
Deleted ports
Sanity Test Failures
Newsfeeds

Statistics
Graphs
NEW Graphs (Javascript)
Traffic

Calculated hourly:
Port count 24833
Broken 231
Deprecated 70
Ignore 499
Forbidden 1
Restricted 204
No CDROM 95
Vulnerable 21
Expired 9
Set to expire 59
Interactive 0
new 24 hours 8
new 48 hours13
new 7 days46
new fortnight77
new month167

Servers and bandwidth provided by
New York Internet, SuperNews, and RootBSD
Valid HTML, CSS, and RSS.
Copyright © 2000-2014 Dan Langille. All rights reserved.