FreshPorts -- The Place For Ports If you buy from Amazon USA, please support us by using this link.
Follow us
Blog
Twitter

Port details
openoffice-devel Integrated wordprocessor/dbase/spreadsheet/drawing/chart/browser (developer version)
4.2.1753426_1,4 editors on this many watch lists=18 search for ports that depend on this port An older version of this port was marked as vulnerable. Find issues related to this port Report an issue related to this port
Maintainer: office@FreeBSD.org search for ports maintained by this maintainer
Port Added: 11 Mar 2002 22:22:30
Also Listed In: java
License: APACHE20 ADOBE BSD3CLAUSE BSD4CLAUSE BSL ICU MIT MPL PSFL TWAIN W3C
Apache OpenOffice is an Open Source, community-developed, multi-platform
office productivity suite. It includes the key desktop applications,
such as a word processor, spreadsheet, presentation manager, and drawing
program, with a user interface and feature set similar to other
office suites.

Components include:
  * A universal word processing application for creating business
    letters, extensive text documents, professional layouts, and HTML
    documents.
  * A sophisticated application for performing advanced spreadsheet
    functions, such as analyzing figures, creating lists, and viewing data.
  * A tool for creating effective eye-catching presentations.
  * A vector-oriented draw module that enables the creation of 3D
    illustrations

WWW: http://openoffice.apache.org/
SVNWeb : Homepage : PortsMon

To install the port: cd /usr/ports/editors/openoffice-devel/ && make install clean
To add the package: pkg install apache-openoffice-devel

PKGNAME: apache-openoffice-devel

distinfo:

TIMESTAMP = 1466695719
SHA256 (openoffice/apache-openoffice-r1753426-src.tar.xz) = 1091e0e34cb47cc5686984b46cf8091a55bd75f522b6439a3f2869b3a2ebc79a
SIZE (openoffice/apache-openoffice-r1753426-src.tar.xz) = 215069876
SHA256 (openoffice/unowinreg.dll) = f563e522922133db9340b0306711c2d8767cc3481dd9e7d9b0d059906d12653c
SIZE (openoffice/unowinreg.dll) = 6144
SHA256 (openoffice/ApacheOpenOffice.ext_sources.4.x.x.20150707.tar.gz) = 966a8333c83a18ddd84401389006d6e0b52b8175924b808b54b88211669985fa
SIZE (openoffice/ApacheOpenOffice.ext_sources.4.x.x.20150707.tar.gz) = 28957004


NOTE: FreshPorts displays only information on required and default dependencies. Optional dependencies are not covered.

Build dependencies:
  1. p5-Archive-Zip>=0 : archivers/p5-Archive-Zip
  2. p5-libwww>=0 : www/p5-libwww
  3. p5-XML-Parser>=0 : textproc/p5-XML-Parser
  4. unzip : archivers/unzip
  5. zip : archivers/zip
  6. ant : devel/apache-ant
  7. shared_ptr.hpp : devel/boost-libs
  8. dmake : devel/dmake
  9. epm : devel/epm
  10. gperf : devel/gperf
  11. imake : devel/imake
  12. gpatch : devel/patch
  13. sane.h : graphics/sane-backends
  14. vigra-config : graphics/vigra
  15. commons-httpclient.jar : java/jakarta-commons-httpclient
  16. commons-lang.jar : java/jakarta-commons-lang
  17. junit.jar : java/junit
  18. bsh.jar : lang/bsh
  19. bash : shells/bash
  20. lucene-core-3.6.2.jar : textproc/lucene
  21. p5-libwww>=0 : www/p5-libwww
  22. java : java/openjdk8
  23. autoconf-2.69 : devel/autoconf
  24. autoheader-2.69 : devel/autoconf
  25. autoreconf-2.69 : devel/autoconf
  26. aclocal-1.15 : devel/automake
  27. automake-1.15 : devel/automake
  28. bison : devel/bison
  29. update-desktop-database : devel/desktop-file-utils
  30. gmake : devel/gmake
  31. pkgconf>=0.9.10 : devel/pkgconf
  32. python2.7 : lang/python27
  33. update-mime-database : misc/shared-mime-info
  34. gnome-mime-data-2.0.pc : misc/gnome-mime-data
  35. gtk-update-icon-cache : graphics/gtk-update-icon-cache
  36. libGL>0 : graphics/libGL
  37. glproto.pc : x11/glproto
  38. dri2proto.pc : x11/dri2proto
  39. glproto.pc : x11/glproto
  40. dri2proto.pc : x11/dri2proto
  41. ice.pc : x11/libICE
  42. sm.pc : x11/libSM
  43. x11.pc : x11/libX11
  44. xau.pc : x11/libXau
  45. xaw7.pc : x11-toolkits/libXaw
  46. xcomposite.pc : x11/libXcomposite
  47. xcursor.pc : x11/libXcursor
  48. xdamage.pc : x11/libXdamage
  49. xext.pc : x11/libXext
  50. xfixes.pc : x11/libXfixes
  51. xi.pc : x11/libXi
  52. xinerama.pc : x11/libXinerama
  53. xrandr.pc : x11/libXrandr
  54. xrender.pc : x11/libXrender
  55. xt.pc : x11-toolkits/libXt
  56. gstreamer-plugins>=0.10.0 : multimedia/gstreamer-plugins
  57. perl5>=5.20<5.21 : lang/perl5.20
Runtime dependencies:
  1. index.theme : misc/hicolor-icon-theme
  2. commons-httpclient.jar : java/jakarta-commons-httpclient
  3. bsh.jar : lang/bsh
  4. Caladea-Bold.ttf : x11-fonts/crosextrafonts-caladea-ttf
  5. Carlito-Bold.ttf : x11-fonts/crosextrafonts-carlito-ttf
  6. Arimo-Bold.ttf : x11-fonts/croscorefonts-fonts-ttf
  7. java : java/openjdk8
  8. update-desktop-database : devel/desktop-file-utils
  9. python2.7 : lang/python27
  10. update-mime-database : misc/shared-mime-info
  11. gnome-mime-data-2.0.pc : misc/gnome-mime-data
  12. gtk-update-icon-cache : graphics/gtk-update-icon-cache
  13. libGL>0 : graphics/libGL
  14. ice.pc : x11/libICE
  15. sm.pc : x11/libSM
  16. x11.pc : x11/libX11
  17. xau.pc : x11/libXau
  18. xaw7.pc : x11-toolkits/libXaw
  19. xcomposite.pc : x11/libXcomposite
  20. xcursor.pc : x11/libXcursor
  21. xdamage.pc : x11/libXdamage
  22. xext.pc : x11/libXext
  23. xfixes.pc : x11/libXfixes
  24. xi.pc : x11/libXi
  25. xinerama.pc : x11/libXinerama
  26. xrandr.pc : x11/libXrandr
  27. xrender.pc : x11/libXrender
  28. xt.pc : x11-toolkits/libXt
  29. gstreamer-plugins>=0.10.0 : multimedia/gstreamer-plugins
Library dependencies:
  1. libapr-1.so : devel/apr1
  2. libnspr4.so : devel/nspr
  3. libcurl.so : ftp/curl
  4. libcairo.so : graphics/cairo
  5. libpng.so : graphics/png
  6. libpoppler-glib.so : graphics/poppler-glib
  7. libgraphite.so : graphics/silgraphite
  8. libCoinMP.so : math/coinmp
  9. libfreetype.so : print/freetype2
  10. libnss3.so : security/nss
  11. libexpat.so : textproc/expat2
  12. libhunspell-1.3.so : textproc/hunspell
  13. libhyphen.so : textproc/hyphen
  14. libtextcat.so : textproc/libtextcat
  15. libmythes-1.2.so : textproc/mythes
  16. librdf.so : textproc/redland
  17. libserf-1.so : www/serf
  18. libfontconfig.so : x11-fonts/fontconfig
  19. libcups.so : print/cups
  20. libdbus-1.so : devel/dbus
  21. libdbus-glib-1.so : devel/dbus-glib
  22. libgstreamer-0.10.so : multimedia/gstreamer
  23. libpoppler.so : graphics/poppler
  24. libintl.so : devel/gettext-runtime
  25. libiconv.so : converters/libiconv
  26. libjpeg.so : graphics/jpeg-turbo
  27. libatk-1.0.so : accessibility/atk
  28. libgconf-2.so : devel/gconf2
  29. libgdk_pixbuf-2.0.so : graphics/gdk-pixbuf2
  30. libglib-2.0.so : devel/glib20
  31. libgnomevfs-2.so : devel/gnome-vfs
  32. libgtk-x11-2.0.so : x11-toolkits/gtk20
  33. libIDL-2.so : devel/libIDL
  34. libxml2.so : textproc/libxml2
  35. libxslt.so : textproc/libxslt
  36. libORBit-2.so : devel/ORBit2
  37. libpango-1.0.so : x11-toolkits/pango
  38. libGLU.so : graphics/libGLU
There are no ports dependent upon this port

Configuration Options
===> The following configuration options are available for apache-openoffice-devel-4.2.1753426_1,4:
     CCACHE=off: Mimimize compile time of C/C++ programs
     CUPS=on: CUPS printing system support
     GNOME=on: GConf + screensaver presentation control via DBUS
     GNOMEVFS=on: GNOME Virtual File System
     MMEDIA=on: Multimedia backend for impress
     PDFIMPORT=on: Build and install PDF import extension
     SDK=off: Build and install software development kit
     WIKI_PUBLISHER=on: Build and install Wiki Publisher extension
===> Use 'make config' to modify these settings

USES:
autoreconf:autoconf bison compiler:c++11-lib cpe  desktop-file-utils  gettext-runtime gmake iconv jpeg perl5 pkgconfig python  shared-mime-info ssl tar:xz gnome

Master Sites:
  1. https://dist.apache.org/repos/dist/dev/openoffice/4.2.0--r1753426/source/
Notes from UPDATING
These upgrade notes are taken from /usr/ports/UPDATING
  • 2015-03-17
    Affects: users of editors/openoffice-4 and editors/openoffice-devel
    Author: truckman@FreeBSD.org
    Reason: 
      Contrary to what is stated in pkg-message, openoffice-4 and
      openoffice-devel have stored user settings in ~/.openoffice.org-devel/4
      since r325370 (2013-08-25). This update expects user settings to reside
      in the more standard ~/.openoffice.org/4.
    
      To preserve your user settings, rename or copy them from
      ~/.openoffice.org-devel/4 to ~/.openoffice.org/4. when installing this
      update to apache-openoffice-4.1.1_7 or
      apache-openoffice-devel-4.2.1652526_2,3.
    
    
Port Moves

Number of commits found: 267 (showing only 100 on this page)

1 | 2 | 3  »  

Commit History - (may be incomplete: see SVNWeb link above for full details)
DateByDescription
05 Sep 2016 20:02:03
Original commit files touched by this commit  4.2.1753426_1,4
Revision:421390
olivierd search for other commits by this committer
Chase update of Poppler after revision r421386
21 Jul 2016 18:13:46
Original commit files touched by this commit  4.2.1753426,4
Revision:418886
truckman search for other commits by this committer
Upgrade to upstream svn revision r1753426, which includes the fix for
CVE-2016-1513.

Regenerate distinfo to add TIMESTAMP.

MFH:		2016Q3
Security:	72f71e26-4f69-11e6-ac37-ac9e174be3af
12 Jul 2016 03:24:20
Original commit files touched by this commit  4.2.1749607_2,4
Revision:418412 This port version is marked as vulnerable.
truckman search for other commits by this committer
Add missing dependencies reported by stage-qa:
        USE_XORG+=      sm xinerama

        devel/dbus (when GNOME option is enabled)

        multimedia/gstreamer (when MMEDIA option is enabled)

        graphics/poppler (-devel only, when PDFIMPORT option is enabled)

Add USES=ssl since this OpenOffice does use OpenSSL.  The base and ports
versions of OpenSSL are both known to work.  It is unknown if LibreSSL
works because the dependency ftp/curl does not currently build with
LibreSSL.

Replace one remaining path to a .jar file with ${JAVALIBDIR} in
CONFIGURE_ARGS.

Replace an absolute symlink with a relative one.

Re-align \ line continuation characters in *_DEPENDS after removal of
${PORTSDIR} from dependencies, and make a few other whitespace cleanups.

MFH:		2016Q3
23 Jun 2016 15:29:57
Original commit files touched by this commit  4.2.1749607_1,4
Revision:417378 This port version is marked as vulnerable.
truckman search for other commits by this committer
Upgrade to upstream svn revision 1749607.

This fixes the build problem with libc++ 3.8.0, so
patch-vcl_source_glyphs_graphite__layout.cxx is no longer needed.
26 May 2016 06:01:49
Original commit files touched by this commit  4.2.1735889_1,4
Revision:415875 This port version is marked as vulnerable.
truckman search for other commits by this committer
Fix build of openoffice-4 and openoffice-devel with libc++ 3.8.0.

Openffice defines its own overloaded variant of round(), which is
only different in return type from the 'real' round() from <math.h>,
so it is ambiguous (in the C++ lookup sense).  Fix this by renaming
the custom round() to round_(), and using a define to minimize
needed changes in the code.

PR:		209588
Submitted by:	dim
01 May 2016 04:44:14
Original commit files touched by this commit  4.2.1735889_1,4
Revision:414382 This port version is marked as vulnerable.
truckman search for other commits by this committer
Pet portlint - use a tab (not space) after a variable name
30 Apr 2016 19:04:32
Original commit files touched by this commit  4.2.1735889_1,4
Revision:414357 This port version is marked as vulnerable.
truckman search for other commits by this committer
Revert the part of the change in r408688 that allowed the PDF Import
extension to build with boost 1.60, which should have been reverted
in r411540.  The fix implemented upstream does not require linking
with any boost libraries, so return boost to always just being
a build dependency.

Update TARGET_ORDER_OVERRIDE to for the changes to Uses/gnome.mk
in r413768.

Don't bother trying to create ${STAGEDIR}${DESKTOPDIR} since it
is already handled by mtree.
01 Apr 2016 14:00:57
Original commit files touched by this commit  4.2.1735889,4
Revision:412346 This port version is marked as vulnerable.
mat search for other commits by this committer
Remove ${PORTSDIR}/ from dependencies, categories d, e, f, and g.

With hat:	portmgr
Sponsored by:	Absolight
21 Mar 2016 05:53:01
Original commit files touched by this commit  4.2.1735889,4
Revision:411540 This port version is marked as vulnerable.
truckman search for other commits by this committer
Upgrade to upstream svn revision r1735889.  This contains the
CLOSESOCKET_DOESNT_WAKE_UP_ACCEPT pipe fix [1].  It also contains
a slightly different fix for building with boost 1.60, so delete
patch-sdext_source_pdfimport_makefile.mk, which is no longer needed.

Delay running gnome-post-install until the plist has been generated by
post-install so that the icons are detected and gtk-update-icon-cache
gets run when the package is installed. [2]

Add missing USES=shared-mime-info.

PR:		207301 [1]
PR:		208026 [2]
11 Mar 2016 11:53:42
Original commit files touched by this commit  4.2.1727463_3,4
Revision:410825 This port version is marked as vulnerable.
tijl search for other commits by this committer
Combine print/cups-base, print/cups-client and print/cups-image into
print/cups and update it to 2.1.3.  Also remove print/cups-pstoraster,
improve print/cups-filters, print/foomatic-* and update print/hplip to
3.16.2.

Long description:

First some background.  When you hand a file to cups it sets up a chain of
filter programs that converts the file to something a printer understands.
Each filter has a cost associated with it and cups tries to find the
cheapest chain.  Costs used to be configured in such a way that files were
first converted to PostScript.  This could then be manipulated further (e.g.
putting multiple pages on one sheet) before finally being sent to a
PostScript printer or another filter like pstoraster which produces a raster
format understood by non-PostScript printer drivers.  Nowadays most filters
(Only the first 15 lines of the commit message are shown above View all of this commit message)
11 Feb 2016 15:40:53
Original commit files touched by this commit  4.2.1727463_2,4
Revision:408688 This port version is marked as vulnerable.
truckman search for other commits by this committer
Unbreak PDF Import extension when building with modern boost.  Similar
to the patch by amdmi3, link the extension with -lboost_system, but
only do this in the --with-system-boost case.  Doing this unconditionally
would break building with the bundled boost because only the boost headers
are available and the boost libraries are not built.  This is still a bit
pessimal because -lboost_system may be used when it is not strictly
necessary (when the system boost is old), but it is likely that this is
only relevant to FreeBSD and we are in the process of upgrading boost.
This fix should be acceptable upstream.

Re-enable the PDF Import extension by default.

When the PDF Import extension is enabled, promote boost from BUILD_DEPENDS
to LIB_DEPENDS.

Tested with PDFIMPORT both on and off.  Also tested with PDFIMPORT on,
--with-system-boost disabled, and boost removed from *_DEPENDS.

PR:		207073, 199601
10 Feb 2016 00:47:21
Original commit files touched by this commit  4.2.1727463_1,4
Revision:408611 This port version is marked as vulnerable.
truckman search for other commits by this committer
Disable PDF import plugin to unbreak build with modern boost.

A proper fix that can be upstreamed will take a bit longer.

PR:		199601
30 Jan 2016 21:26:57
Original commit files touched by this commit  4.2.1727463,4
Revision:407553 This port version is marked as vulnerable.
truckman search for other commits by this committer
Upgrade to upstream svn revision 1727463.  This fixes the upstream
bug <https://bz.apache.org/ooo/show_bug.cgi?id=125431>,
"The Password is incorrect. The file cannot be opened."

PR:		206234
21 Jan 2016 19:40:10
Original commit files touched by this commit  4.2.1712473_2,4
Revision:406872 This port version is marked as vulnerable.
kwm search for other commits by this committer
Update poppler to 0.40.0. [1]

Add patches to py-poppler [2] and rubygem-poppler [3] to fix the build
of these ports with poppler 0.39+.

PR:		206293 [1]
Submitted by:	olivierd@ [1]
Obtained from:	ubuntu [2], rubygem-poppler upstream [3]
02 Jan 2016 20:58:43
Original commit files touched by this commit  4.2.1712473_1,4
Revision:405096 This port version is marked as vulnerable.
truckman search for other commits by this committer
Correct the Icon entry in the .desktop files so that the icons are
visible in the menu.

PR:		205758
13 Nov 2015 04:13:34
Original commit files touched by this commit  4.2.1712473,4
Revision:401475 This port version is marked as vulnerable.
truckman search for other commits by this committer
Now that we are no longer avoiding certain versions of clang, convert to
USES=compiler:c++11-lib instead of trying to emulate it.
06 Nov 2015 15:50:39
Original commit files touched by this commit  4.2.1712473,4
Revision:400938 This port version is marked as vulnerable.
truckman search for other commits by this committer
Switch back to tracking the upstream trunk instead of OpenOffice 4.1.2
release candidates.  Upgrade to SVN revision r1712473.

Add an option to build and install the PDF Import extension and enable
it by default.

Patch the extensions.lst file so that it points to the locations
of the extension files rather than passing that information as
a configure option.  Add a patch to enable enable the use of file://
in extensions.lst for local integrated extensions as is documented in
the comments in this file.

Nuke the patches that have been committed upstream.

Don't try to run the create_tree.sh script with "sh -c" since this
script is not marked executable.

MFH:		2015Q4
24 Oct 2015 01:00:29
Original commit files touched by this commit  4.1.1709696,4
Revision:400085 This port version is marked as vulnerable.
truckman search for other commits by this committer
Upgrade to OpenOffice 4.1.2-RC3.

Explicity set $JAVA_HOME in startup wrapper to the OpenJDK version used
for the build to avoid any potential issues with relying on javavmwrapper
parsing bsd.java.mk to determine this at runtime.

Fix an botch in the FreeBSD-specific $LD_LIBRARY_PATH code in the
startup wrapper.

Java is needed at runtime, so flag it as a runtime dependency.

Add an option to build and install the SDK and disable it by default.
The port has been building it all along, but not installing it.  We
save only a small amount of time by not building it, but we save about
70 MB of space when the port is installed.
(Only the first 15 lines of the commit message are shown above View all of this commit message)
18 Oct 2015 08:20:07
Original commit files touched by this commit  4.1.1707648_2,4
Revision:399606 This port version is marked as vulnerable.
truckman search for other commits by this committer
Patch the source with r1697228, r1697237, r1697247, r1697306, and
r1697312 from upstream trunk (with a few tweaks to compensate for
some other upstream changes not included here) to unbreak the build
with OpenJDK8.

Revert r399537 to unmark broken.

PR:		199591 (openjdk8 by default exp-run)
17 Oct 2015 13:20:39
Original commit files touched by this commit  4.1.1707648_1,4
Revision:399537 This port version is marked as vulnerable.
swills search for other commits by this committer
editors/openoffice-devel: mark broken with OpenJDK8
14 Oct 2015 17:09:50
Original commit files touched by this commit  4.1.1707648_1,4
Revision:399282 This port version is marked as vulnerable.
truckman search for other commits by this committer
Upgrade to OpenOffice 4.1.2-RC2.
09 Oct 2015 20:59:28
Original commit files touched by this commit  4.1.1705575_1,4
Revision:398959 This port version is marked as vulnerable.
truckman search for other commits by this committer
Fix an intermittent build failure by adding a missing dependency to the
port's build framework.  This change has been committed to the upstream
trunk.
08 Oct 2015 01:09:39
Original commit files touched by this commit  4.1.1705575_1,4
Revision:398790 This port version is marked as vulnerable.
truckman search for other commits by this committer
Temporarily downgrade the openoffice-devel port from the upstream trunk
branch to 4.1.2-RC1 in order to give the latter wider exposure before
4.1.2 is released.

Add this missing missing bits of patch-i114430 that were committed
to trunk upstream but that are not in 4.1.2-RC1.

Removing --enable-symbols=small from CONFIGURE_ARGS allows us to avoid
the need to use ${STRIP_CMD}.
26 Sep 2015 07:40:48
Original commit files touched by this commit  4.2.1704217_1,3
Revision:397932 This port version is marked as vulnerable.
truckman search for other commits by this committer
Add Caladea and Carlito fonts.  They are metrically equivalent to some
Microsoft fonts and the proper definitions within OpenOffice have been
added so that they are recognized as such. [1]

The Linux ports handle the mapping from the printeradmin command to the
spadmin executable in the shell wrapper.  Do the same in the FreeBSD
port rather than munging the printeradmin.desktop file.  Retain the
spadmin link to the wrapper for backwards compatability.

The setofficelang command went away a long time ago.  Remove it from
the shell wrapper and remove the link.

Exec the OpenOffice executables from the wrapper so that the shell for
the wrapper doesn't hang around as an extra process until OpenOffice
terminates.

Nuke an extraneous shell continuation in the Makefile.

Suggested by:	pfg [1]
24 Sep 2015 21:06:30
Original commit files touched by this commit  4.2.1704217,3
Revision:397760 This port version is marked as vulnerable.
truckman search for other commits by this committer
Update to svn revsion r1704217.

Fix a regression in directory permissions and add a missing directory used
for shared extensions.  This combination of issues could cause incomplete
cleanup on pkg removal if OpenOffice had been run by a user in the wheel
group.

Add a note about the location of the Wiki Publisher extension to
pkg-message.
16 Sep 2015 03:03:46
Original commit files touched by this commit  4.2.1697984_2,3
Revision:397038 This port version is marked as vulnerable.
truckman search for other commits by this committer
Update the comment about the clang 3.6 and clang 3.7 code generation
bug with the upstream bug ID.

More do-install target optimization:

  * Use the tar -s option to modify the path names when unpacking
    the install archive into the staging directory rather than
    unpacking, repacking, and unpacking again

  * Pass --with-unix-wrapper to configure and patch a makefile
    to get the desired Exec and Icon entries in the .desktop
    files instead of patching them after they have been staged.
    The Icon entries do not need to specify the .png suffix.

  * Streamline the usage of ${STRIP_CMD}
(Only the first 15 lines of the commit message are shown above View all of this commit message)
10 Sep 2015 00:26:28
Original commit files touched by this commit  4.2.1697984_1,3
Revision:396544 This port version is marked as vulnerable.
truckman search for other commits by this committer
Unbreak wrapper script so that if a particular application is
specified but without specifying a document, that application is
started instead of presenting the user with the generic startup
window and requiring him to pick the document type (running
openoffice-*-scalc should open to a new spreadsheet, etc.)

Building with clang 3.7 is reported to have the same failure mode
as clang 3.6, so use the same optimization tweak as a workaround.

Various cleanups to do-install:

  * The paths ${PREFIX}/${INSTALLATION_BASEDIR} and
    ${PREFIX}/${INSTALLATION_BASEDIR}/${AOODIR}, and
    ${PREFIX}/${INSTALLATION_BASEDIR}/${AOODIR}/share/xdg are
    frequently used, so create a few variables to hold those paths
(Only the first 15 lines of the commit message are shown above View all of this commit message)
07 Sep 2015 06:22:49
Original commit files touched by this commit  4.2.1697984,3
Revision:396247 This port version is marked as vulnerable.
truckman search for other commits by this committer
Sort USE_XORG
31 Aug 2015 07:54:43
Original commit files touched by this commit  4.2.1697984,3
Revision:395652 This port version is marked as vulnerable.
truckman search for other commits by this committer
Upgrade to upstream svn revision r1697984.

Nuke patch-clang34 because it has been incorporated upstream.

Replace the default images in the opening splash window and the
Help->About window with FreeBSD-branded versions that also mark
this as a developer snapshot.  Thanks to pfg for suggesting this
and reviewing the new images.
17 Aug 2015 14:20:41
Original commit files touched by this commit  4.2.1694132,3
Revision:394508 This port version is marked as vulnerable.
mat search for other commits by this committer
Remove UNIQUENAME and LATEST_LINK.

UNIQUENAME was never unique, it was only used by USE_LDCONFIG and now,
we won't have conflicts there.

Use PKGBASE instead of LATEST_LINK in PKGLATESTFILE, the *only* consumer
is pkg-devel, and it works just fine without LATEST_LINK as pkg-devel
has the correct PKGNAME anyway.

Now that UNIQUENAME is gone, OPTIONSFILE is too. (it's been called
OPTIONS_FILE now.)

Reviewed by:	antoine, bapt
Exp-run by:	antoine
Sponsored by:	Absolight
Differential Revision:	https://reviews.freebsd.org/D3336
06 Aug 2015 22:40:01
Original commit files touched by this commit  4.2.1694132,3
Revision:393676 This port version is marked as vulnerable.
truckman search for other commits by this committer
Update to SVN revision 1694132, which contains some changes to aid
building with gcc from ports on FreeBSD.  Remove the REINPLACE_CMD
patches in the ports Makefile and $FBSD_LDFLAGS from do-build that
are no longer needed for building with gcc in the general case.

Add a patch to disable optimization when compiling one source file
with base clang 3.4 on FreeBSD 10 amd64 to avoid tripping on a compiler
code generation bug.  This allows us to build with base clang on
FreeBSD 10 amd64 instead of using the clang35 port.

Fine tune compiler optimization flags when using clang 3.6 on FreeBSD 11
i386 or gcc 4.9 instead of totally disabling optimization.  Unbreak
the build with gcc 4.9 on amd64.

A few Makefile cleanups without functional change:

  * Combine two .if ${ARCH} == amd64 sections of Makefile

  * Merge the pre-configure target into post-extract

  * Simplify the code in the do-build target

Approved by:	mat (mentor, implicit)
02 Aug 2015 16:06:17
Original commit files touched by this commit  4.2.1689959_2,3
Revision:393431 This port version is marked as vulnerable.
kwm search for other commits by this committer
Update poppler to 0.34.0. [1]

Chase all users of shlib version change of libpoppler.so.

PR:		201477 [1]
Submitted by:	olivierd@ [1]
13 Jul 2015 21:03:26
Original commit files touched by this commit  4.2.1689959_1,3
Revision:391960 This port version is marked as vulnerable.
truckman search for other commits by this committer
Upgrade to upstream SVN revision 1689959.

patch-jpeg and patch-nss have been upstreamed and are no longer needed.

patch-i118574 no longer seems necessary for a clean build.

Regnerate patch-i114430 with make makepatch.

Always build using boost from ports instead of the bundled boost, updating
the BUILD_DEPENDS with the header that configure looks for.

Add missing LIB_DEPENDS that are brought in by other dependencies, but are
directly linked as requested by pkgconfig/*.pc.

Build using sane and xrender headers from ports instead of bundled headers.
(Only the first 15 lines of the commit message are shown above View all of this commit message)
28 Jun 2015 15:20:05
Original commit files touched by this commit  4.2.1677314_1,3
Revision:390787 This port version is marked as vulnerable.
antoine search for other commits by this committer
MAKE_JOBS_SAFE=yes is a nop since july 2013
22 Jun 2015 18:33:22
Original commit files touched by this commit  4.2.1677314_1,3
Revision:390310 This port version is marked as vulnerable.
antoine search for other commits by this committer
Convert to USES=jpeg
14 May 2015 23:07:18
Original commit files touched by this commit  4.2.1677314_1,3
Revision:386368 This port version is marked as vulnerable.
truckman search for other commits by this committer
Do not attempt to override the intent of DISABLE_MAKE_JOBS, which
does not succeed in any case.

The do-build target does not need to use bash, or even an extra
level of shell.

There are two levels of parallelism in the openoffice build framework.
Split MAKE_JOBS_NUMBER between the two levels instead of potentially
running MAKE_JOBS_NUMBER^2 compilations in parallel.

PR:		199930
Approved by:	mat (mentor, implicit)
08 May 2015 16:04:21
Original commit files touched by this commit  4.2.1677314_1,3
Revision:385793 This port version is marked as vulnerable.
truckman search for other commits by this committer
Resurrect the part of patch-i114430 that was not accepted upstream.

Submitted by:	pfg
Approved by:	mat (mentor, implicit)
MFH:		2015Q2
08 May 2015 00:07:14
Original commit files touched by this commit  4.2.1677314,3
Revision:385717 This port version is marked as vulnerable.
truckman search for other commits by this committer
Upgrade to svn revision r1677314, fixing the HWP filter
vulnerability documented in CVE-2015-1774 and
<http://www.openoffice.org/security/cves/CVE-2015-1774.html>

Differential Revision:	https://reviews.freebsd.org/D2470
Submitted by:	pi
Reviewed by:	pi, pfg
Approved by:	mat (mentor)
MFH:		2015Q2
Security:	b13af778-f4fc-11e4-a95d-ac9e174be3af
05 May 2015 20:38:34
Original commit files touched by this commit  4.2.1667428,3
Revision:385489 This port version is marked as vulnerable.
truckman search for other commits by this committer
Unbreak editors/openoffice-* build when GCONF and GNOMEVFS are disabled

There is a missing dependency on devel/dbus-glib that causes the
openoffice build to fail when the GCONF and GNOMEVFS options are
disabled. When these options are enabled, one of the dependencies
added by these options brings along dbus-glib so the default build
succeeds.

There is a configure knob to control whether or not dbus-glib is
used, so follow the lead of the libreoffice port and rename the
GCONF option to GNOME and bundle both Gconf and DBUS handling under
the GNOME option.

Borrow the MMEDIA option from the libreoffice port and use that to
control the using of gstreamer.
(Only the first 15 lines of the commit message are shown above View all of this commit message)
30 Mar 2015 17:58:42
Original commit files touched by this commit  4.2.1667428,3
Revision:382700 This port version is marked as vulnerable.
sunpoet search for other commits by this committer
- Add CPE information

PR:		199030
Submitted by:	shun <shun.fbsd.pr@dropcut.net>
26 Mar 2015 18:03:55
Original commit files touched by this commit  4.2.1667428,3
Revision:382334 This port version is marked as vulnerable.
truckman search for other commits by this committer
Upgrade to apache-openoffice SVN revision 1667428.

Word around broken build on FreeBSD 11.0-CURRENT i386, which appears
to be a code generation bug in clang 3.6 when using -Os optimization.

Build using the ports version of graphics/silgraphite instead of
building an internal copy.

When building with clang, use the ports version of devel/boost-libs
instead of an internal copy.

Use the dictionaries already installed by ports.

Update the patch-bridges and patch-*.mk patches to versions that
will be sent upstream.  The latter are tuned for clang to use as
(Only the first 15 lines of the commit message are shown above View all of this commit message)
21 Mar 2015 23:05:21
Original commit files touched by this commit  4.2.1652526_2,3
Revision:381876  Sanity Test Failure This port version is marked as vulnerable.
bapt search for other commits by this committer
Make fonts repecting XDG

Xorg is now looking in ${LOCALBASE}/share/fonts by default
Xorg now accepts symlinks in etc/X11/fontpath.d (as decribed in Xserver(1))
Large cleanup on lots of font ports
All fonts are now properly dynamically generating fonts.dir and fonts.scale
instead of sometime overwriting existing ones)
All fonts are generating fontconfig's cache
Improve consistency in fonts ports
17 Mar 2015 15:04:44
Original commit files touched by this commit  4.2.1652526_2,3
Revision:381494 This port version is marked as vulnerable.
truckman search for other commits by this committer
Unbreak editors/openoffice-4 and editors/openoffice-devel on systems
where clang is the base compiler.  The issue was that these ports
would only successfully build with gcc and libstdc++, so they
specified USE_GCC=yes, but they linked to other C++ ports that were
compiled with clang, which brought in libc++.  The conflict between
libstdc++ and libc++ caused the application to crash whenever an
operation that popped up a dialog box was attempted.  Thanks to
dim@ for helping me track this down.  The fix is to patch various
bits of the openoffice souce to allow it to be built with clang
on systems where the C++ dependencies are also compiled with clang. [1]

Add a CUPS option so that CUPS can be disabled [2].

Register print/cups-client as a LIB_DEPENDS when CUPS is enabled.
(Only the first 15 lines of the commit message are shown above View all of this commit message)
25 Feb 2015 05:58:57
Original commit files touched by this commit  4.2.1652526_1,3
Revision:379875 This port version is marked as vulnerable.
truckman search for other commits by this committer
Undo an unintended Makefile change that slipped in.

Approved by:	mat (mentor)
25 Feb 2015 05:55:10
Original commit files touched by this commit  4.2.1652526_1,3
Revision:379874 This port version is marked as vulnerable.
truckman search for other commits by this committer
Fix build breakage when libreoffice is installed.

The problem is that libreoffice installs its own copy of unopkg in
${PREFIX}/bin and that the openoffice build attempts to use this copy
of unopkg instead of the openoffice version which is in subdirectory
of ${WRKSRC}.

The reason is that the openoffice build expects to find its own copy
of unopkg by depending on having "." in its $PATH, but its $PATH has
${PREFIX}/bin before ".". Openoffice attempts to do the right thing
by first constructing $PATH by prepending "." and a small number of
other directories where it stashes executables used during the build
to the value of $PATH that it inherits from the environment. Things
go wrong when it tries to add the paths for ${CC}, perl, and java
to $PATH. If $PATH has /usr/bin before ${PREFIX}/bin, the openoffice
(Only the first 15 lines of the commit message are shown above View all of this commit message)
17 Feb 2015 01:26:17
Original commit files touched by this commit  4.2.1652526_1,3
Revision:379132 This port version is marked as vulnerable.
truckman search for other commits by this committer
Switch back to USE_GCC=yes.

Work around this bug <https://gcc.gnu.org/bugzilla/show_bug.cgi?id=65009>
in g++49 -Os optimzation by using -O0 optimization if we are compiling
with g++49.

Differential Revision:	https://reviews.freebsd.org/D1607
Reviewed by:	pfg
Approved by:	mat (mentor)
13 Feb 2015 01:01:35
Original commit files touched by this commit  4.2.1652526_1,3
Revision:378905 This port version is marked as vulnerable.
brd search for other commits by this committer
math/coinmp: Update to 1.8.0

PR:		197554
Submitted by:	Carlos Jacobo Puga Medina <cpm@fbsd.es> (maintainer)
Approved by:	zi
03 Feb 2015 12:28:24
Original commit files touched by this commit  4.2.1652526,3
Revision:378348 This port version is marked as vulnerable.
kwm search for other commits by this committer
Update poppler to 0.30.0 [1].

Make sure we use openjpeg1 in poppler, while openjpeg2 support
was added there still bugs in openjpeg2 that need to be fixed.
Add patches to inkscape for API changes in poppler 0.29.0 [2].

PR:		196599 [1]
Submitted by:	olivierd@ [1]
Exp-run by:	antoine@
Obtained from:	upstream [2]
21 Jan 2015 22:57:35
Original commit files touched by this commit  4.2.1652526,2
Revision:377630 This port version is marked as vulnerable.
truckman search for other commits by this committer
Unbreak fetch.

Differential Revision:	https://reviews.freebsd.org/D1578
Reviewed by:	pfg
Approved by:	mat (mentor)
21 Jan 2015 19:50:33
Original commit files touched by this commit  4.2.1652526,2
Revision:377624 This port version is marked as vulnerable.
antoine search for other commits by this committer
Fix duplicate pkgnames
21 Jan 2015 17:40:58
Original commit files touched by this commit  4.2.1652526,2
Revision:377620 This port version is marked as vulnerable.
truckman search for other commits by this committer
Update to SVN revision 1652526.

Resynchronize to openoffice-4 including:

  * portlint fixes

  * fix all but one stage-qa warning

  * add source makefile patch to unbreak --with-system-jpeg

  * add the --with-system-hyphen, --with-system-nss, --with-system-jpeg,
    and --with-system-mythes configure options

  * remove the --with-system-saxon option to allow coexistance with
    math/scilab
(Only the first 15 lines of the commit message are shown above View all of this commit message)
25 Nov 2014 12:55:54
Original commit files touched by this commit  4.1.1560773_5,2
Revision:373404 This port version is marked as vulnerable.
makc search for other commits by this committer
Bump PORTREVISION after graphics/poppler update to 0.26.3
19 Oct 2014 15:43:33
Original commit files touched by this commit  4.1.1560773_4,2
Revision:371188 This port version is marked as vulnerable.
mva search for other commits by this committer
- Convert ports from dns/, editors/ and emulators/ to new
  USES=python

Approved by:	portmgr (implicit)
10 Sep 2014 20:50:37
Original commit files touched by this commit  4.1.1560773_4,2
Revision:367888 This port version is marked as vulnerable.
gerald search for other commits by this committer
Update the default version of GCC in the Ports Collection from GCC 4.7.4
to GCC 4.8.3.

Part II, Bump PORTREVISIONs.

PR:		192025
Tested by:	antoine (-exp runs)
Approved by:	portmgr (implicit)
12 Jun 2014 09:17:33
Original commit files touched by this commit  4.1.1560773_3,2
Revision:357574 This port version is marked as vulnerable.
tijl search for other commits by this committer
Bump PORTREVISION on everything that depends on devel/apr1 due to the
library version change.

Approved by:	portmgr (implicit)
16 Apr 2014 18:28:50
Original commit files touched by this commit  4.1.1560773_2,2
Revision:351411 This port version is marked as vulnerable.
zeising search for other commits by this committer
The FreeBSD x11@ and graphics team proudly presents
a zeising, kwm production, with help from dumbbell, bdrewery:

NEW XORG ON FREEBSD 9-STABLE AND 10-STABLE

This update switches over to use the new xorg stack by default on FreeBSD 9
and 10 stable, on osversions where vt(9) is available.
It is still possible to use the old stack by specifying WITHOUT_NEW_XORG in
/etc/make.conf .
FreeBSD 8-STABLE and released versions of FreeBSD still use
the old version.
A package repository with binary packages for new xorg will
be available soon.

This patch also contains updates of libxcb and related ports, pixman, as well
(Only the first 15 lines of the commit message are shown above View all of this commit message)
05 Apr 2014 17:31:20
Original commit files touched by this commit  4.1.1560773_1,2
Revision:350251 This port version is marked as vulnerable.
antoine search for other commits by this committer
Possibly unbreak

Reported by:	pkg-fallout
With hat:	portmgr
26 Mar 2014 13:07:07
Original commit files touched by this commit  4.1.1560773_1,2
Revision:349248 This port version is marked as vulnerable.
bapt search for other commits by this committer
Remove a line that is already done by USES=desktop-file-utils
Forgotten during stagification
26 Mar 2014 08:17:14
Original commit files touched by this commit  4.1.1560773_1,2
Revision:349233 This port version is marked as vulnerable.
bapt search for other commits by this committer
Support stage
10 Mar 2014 20:55:22
Original commit files touched by this commit  4.1.1560773_1,2
Revision:347809 This port version is marked as vulnerable.
gerald search for other commits by this committer
Update the default version of GCC used in the Ports Collection from
GCC 4.6.4 to GCC 4.7.3.  This entails updating the lang/gcc port as
well as changing the default in Mk/bsd.default-versions.mk.

Part II, Bump PORTREVISIONs.

PR:		182136
Supported by:	Christoph Moench-Tegeder <cmt@burggraben.net> (fixing many ports)
Tested by:	bdrewery (two -exp runs)
07 Feb 2014 11:44:09
Original commit files touched by this commit  4.1.1560773,2
Revision:343214 This port version is marked as vulnerable.
bapt search for other commits by this committer
Chase boost and icu bump
While here convert some LIB_DEPENDS
05 Feb 2014 04:17:28
Original commit files touched by this commit  4.1.1560773,1
Revision:342631 This port version is marked as vulnerable.
maho search for other commits by this committer
Update to a better patch for cosmetic reason.
05 Feb 2014 01:41:26
Original commit files touched by this commit  4.1.1560773,1
Revision:342619 This port version is marked as vulnerable.
maho search for other commits by this committer
remove unnecessary file
05 Feb 2014 00:42:29
Original commit files touched by this commit  4.1.1560773,1
Revision:342617 This port version is marked as vulnerable.
maho search for other commits by this committer
Update to 1560773

https://cwiki.apache.org/confluence/display/OOOUSERS/Development+Snapshot+Builds
Now we set USE_GCC to avoid gcc 4.2.1 (along with FBSD9) bug.
03 Feb 2014 11:31:18
Original commit files touched by this commit  4.0.1543006_1,1
Revision:342426 This port version is marked as vulnerable.
maho search for other commits by this committer
Now we use system nss.
27 Jan 2014 07:32:02
Original commit files touched by this commit  4.0.1543006,1
Revision:341334 This port version is marked as vulnerable.
maho search for other commits by this committer
Update to svn 1543006

Suggested by: pfg@
30 Dec 2013 20:55:19
Original commit files touched by this commit  4.0.1517723_2,1
Revision:338168 This port version is marked as vulnerable.
ohauer search for other commits by this committer
- rename AL2 to APACHE20 in Mk/bsd.licenses.db.mk
- svn move Templates/Licenses/AL2 Templates/Licenses/APACHE20
- add APACHE10 and APACHE11 to Mk/bsd.licenses.db.mk
- add entry in UPDATING
- bulk change all ports AL2 => APACHE20

- math/openfst/pkg-plist: remove share/licenses/openfst-1.3.4

PR:		ports/184785
Submitted by:	ohauer
Reviewed by:	tabthorpe
Approved by:	portmgr (tabthorpe@)
27 Dec 2013 16:54:22
Original commit files touched by this commit  4.0.1517723_2,1
Revision:337749 This port version is marked as vulnerable.
kwm search for other commits by this committer
Update poppler to 0.24.4.

Update comment.
Use new LIB_DEPENDS syntax, use USES=pathfix.
Stagify.

Bump portrevision of all affected ports, and Update poppler* LIB_DEPENDS to
new syntax.
22 Oct 2013 13:57:35
Original commit files touched by this commit  4.0.1517723,1
Revision:331271 This port version is marked as vulnerable.
amdmi3 search for other commits by this committer
- Remove manual creation and removal of share/applications, as it's now in the
mtree (categories starting with [bce])

Approved by:	portmgr (bdrewery)
07 Oct 2013 12:23:06
Original commit files touched by this commit  4.0.1517723,1
Revision:329696 This port version is marked as vulnerable.
bapt search for other commits by this committer
Fix pkgname collision
20 Sep 2013 16:36:24
Original commit files touched by this commit  4.0.1517723,1
Revision:327720 This port version is marked as vulnerable.
bapt search for other commits by this committer
Add NO_STAGE all over the place in preparation for the staging support (cat:
editors)
18 Sep 2013 08:38:20
Original commit files touched by this commit  4.0.1517723,1
Revision:327535 This port version is marked as vulnerable.
bapt search for other commits by this committer
Add an explicit dependency on pkgconf
30 Aug 2013 07:24:07
Original commit files touched by this commit  4.0.1517723,1
Revision:325663 This port version is marked as vulnerable.
maho search for other commits by this committer
Fix mismatched {}

PR:		181667
Submitted by:	Katsuyuki Miyoshi <katsu@miyoshi.matsuyama.ehime.jp>
28 Aug 2013 00:29:47
Original commit files touched by this commit  4.0.1517723,1
Revision:325497 This port version is marked as vulnerable.
maho search for other commits by this committer
bsd.port.options.mk, needs to be placed before bsd.port.pre.mk.

Submitted by:	jgh@
27 Aug 2013 03:36:50
Original commit files touched by this commit  4.0.1517723,1
Revision:325427 This port version is marked as vulnerable.
maho search for other commits by this committer
update to svn 1517723.
some cleanups [1].

PR:		181574
14 Aug 2013 22:35:54
Original commit files touched by this commit  4.0.1479753_2
Revision:324744  Sanity Test Failure This port version is marked as vulnerable.
ak search for other commits by this committer
- Remove MAKE_JOBS_SAFE variable

Approved by:	portmgr (bdrewery)
05 Aug 2013 15:55:37
Original commit files touched by this commit  4.0.1479753_2,1
Revision:324278 This port version is marked as vulnerable.
wg search for other commits by this committer
editors/openoffice-*: bump PORTREVISION

- CoinMP has been updated

Submitted by:	Pedro Giffuni <giffunip tutopia.com>
04 Aug 2013 12:47:44
Original commit files touched by this commit  4.0.1479753_1,1
Revision:324225 This port version is marked as vulnerable.
az search for other commits by this committer
- Convert to new perl framework

Approved by:	bapt@ (office@)
11 Jul 2013 16:26:27
Original commit files touched by this commit  4.0.1479753_1,1
Revision:322783 This port version is marked as vulnerable.
sunpoet search for other commits by this committer
- Update to 7.31.0
- Bump PORTREVISION for ftp/curl shlib change
- Add TEST_DEPENDS
- Convert to new options framework
- Adjust options:
  - Add COOKIES
  - Add CYASSL, NSS, POLARSSL, THREADED_RESOLVER, TLS_SRP [1]
  - Add GSSAPI and SPNEGO [2]
  - Remove KERBEROS4
  - Rename LIBIDN to IDN
  - Remove TRACKMEMORY [1]
- Sort option handler
- Add SLAVEDIRS: ftp/curl-hiphop
- Cosmetic change
- Cleanup Makefile header
- While I'm here, fix typo (PORTREVSION) in x11-wm/ede/Makefile

Changes:	http://curl.haxx.se/changes.html
PR:		ports/172325 (-exp run), ports/177369 (based on) [1]
Submitted by:	Hirohisa Yamaguchi <umq@ueo.co.jp> [1], hrs (via email) [2]
Exp run by:	miwi
08 May 2013 09:36:52
Original commit files touched by this commit  4.0.1479753,1
Revision:317648 This port version is marked as vulnerable.
maho search for other commits by this committer
Update to svn 1479753
17 Apr 2013 02:40:54
Original commit files touched by this commit  4.0.1466687,1
Revision:315923 This port version is marked as vulnerable.
maho search for other commits by this committer
update to svn 1466687.

Feature safe: yes
21 Mar 2013 06:55:25
Original commit files touched by this commit  4.0.1457623,1
Revision:314812 This port version is marked as vulnerable.
maho search for other commits by this committer
Rename openoffice-3-devel to openoffice-devel, as the version
number currently doesn't have significant meaning.
08 Nov 2003 01:47:27
Original commit files touched by this commit  1.1.0_1
 This port version is marked as vulnerable.
maho search for other commits by this committer
Repocopy has been done for openoffice,
so rename from:
editors/openoffice
editors/openoffice-devel
to
editors/openoffice-1.0
editors/openoffice-1.1

Acknowledgment to: nork
03 Oct 2003 00:09:07
Original commit files touched by this commit  1.1.0_1
 This port version is marked as vulnerable.
maho search for other commits by this committer
(1) omit RC4 in pkg-message
(2) PORTREVERSION -> PORTREVISION

Pointed out by: FUJIMOTO Kou <fujimoto@j.dendai.ac.jp> (1)
Pointy hat to:  myself (2)
02 Oct 2003 06:45:23
Original commit files touched by this commit  1.1.0
 This port version is marked as vulnerable.
maho search for other commits by this committer
a) add several patches made by Takashi Ono (JCA signed person)
   1) To enable handling of MS Word for Windows 95/6.0 CJK Version
      patch-word6+95-cjkhandling
      http://www.openoffice.org/issues/show_bug.cgi?id=17498
      (target milestone 1.1.1, resolved and fixed)

   2) Patch to enable rtf filter handle local language files
      patch-rtfcjk
      http://www.openoffice.org/issues/show_bug.cgi?id=17503
      (target milestone 2.0, verified and fixed)

   3) rtf writing enhancement for CJK
      patch-wrtrtf
      http://www.openoffice.org/issues/show_bug.cgi?id=20264
      (not confirmed yet)

   4) read first section attribute correctly for
      MS Word for Windows 95/6.0
      patch-topsection
     
http://ja.openoffice.org/servlets/ProjectDownloadList?action=download&dlID=312
      (IZ is not raized)

b) bump portrevision
02 Oct 2003 02:07:15
Original commit files touched by this commit  1.1.0
 This port version is marked as vulnerable.
maho search for other commits by this committer
Update to 1.1.0 official release
(archive is exactly same as 1.1rc5b)
01 Oct 2003 07:52:09
Original commit files touched by this commit  1.1rc5_1
 This port version is marked as vulnerable.
maho search for other commits by this committer
1) update to 1.1rc5b.
2) too small so I treated this update as bump portrevision
01 Oct 2003 05:53:01
Original commit files touched by this commit  1.1rc5
 This port version is marked as vulnerable.
maho search for other commits by this committer
Localized helpcontents have been changed from 1.0 to 1.1, and
unfortunately, both helpcontents have same names and located
at different place. there's (AFAIK) no way to make one more deeper
subdirectory at DISTDIR, so I splitted /usr/ports/distfiles/openoffice to
/usr/ports/distfiles/openoffice1.0, /usr/ports/distfiles/openoffice1.1.
25 Sep 2003 22:43:58
Original commit files touched by this commit  1.1rc5
 This port version is marked as vulnerable.
mbr search for other commits by this committer
The relative path bug has been fixed. Execute soffice again
with absolute path.

This makes relative paths working again for specified documents
in the argument list.
25 Sep 2003 22:29:30
Original commit files touched by this commit  1.1rc5
 This port version is marked as vulnerable.
mbr search for other commits by this committer
Upgrade to 1.1rc5 snapshot. Fix a remaining error in the startup
script.
25 Sep 2003 22:28:01
Original commit files touched by this commit  1.1RC4
 This port version is marked as vulnerable.
mbr search for other commits by this committer
Directly get OOHOME from .sversionrc. Add several checks for
the various installation steps.
21 Sep 2003 07:04:53
Original commit files touched by this commit  1.1RC4
 This port version is marked as vulnerable.
mbr search for other commits by this committer
Fix minor install problem: s/openoffice/openoffice-wrapper/

Submitted by:   Lars Bungum <lars@bungum.no>
Approved by:    marcus (portsmgr)
17 Sep 2003 04:06:29
Original commit files touched by this commit  1.1RC4
 This port version is marked as vulnerable.
mbr search for other commits by this committer
Make it easier for people, move a big chunk of the startup
wrapper out into a script included by soffice.sh. This way
there aren't any traps at first startup time and people
hopefully don't ask the same questions anymore.

At the same time, make more substitutions, also in oo_setup.resp.

Approved by:    marcus (portsmgr)
16 Sep 2003 06:50:17
Original commit files touched by this commit  1.1RC4
 This port version is marked as vulnerable.
mbr search for other commits by this committer
Remove a dash in the pathname.

Approved by:    marcus (portsmgr)
16 Sep 2003 04:26:34
Original commit files touched by this commit  1.1RC4
 This port version is marked as vulnerable.
mbr search for other commits by this committer
Fix post-install target, remove a dash.

Approved by:    marcus (portsmgr)
14 Sep 2003 21:52:25
Original commit files touched by this commit  1.1RC4
 This port version is marked as vulnerable.
mbr search for other commits by this committer
Make OO1.1RC working. Many thanks to kan for the debugging session
at the dev summit !

Approved by:    joe (portsmgr)
09 Sep 2003 12:39:05
Original commit files touched by this commit  645
 This port version is marked as vulnerable.
mbr search for other commits by this committer
Back out parts of rev. 1.95.

The framebuffer hack is still needed. Without it, we cannot
install openoffice-devel on bento at all, neither on my build
machines.
09 Sep 2003 12:27:02
Original commit files touched by this commit  645
 This port version is marked as vulnerable.
mbr search for other commits by this committer
The install-path has been changed from OpenOffice.org-644
to OpenOffice.org-645.
08 Sep 2003 22:11:03
Original commit files touched by this commit  645
 This port version is marked as vulnerable.
mbr search for other commits by this committer
libXft.a is not available. Do not link static for now.
08 Sep 2003 15:36:05
Original commit files touched by this commit  645
 This port version is marked as vulnerable.
mbr search for other commits by this committer
Add gcc port dependency.

Number of commits found: 267 (showing only 100 on this page)

1 | 2 | 3  »  

Login
User Login
Create account

Servers and bandwidth provided by
New York Internet, SuperNews, and RootBSD

This site
What is FreshPorts?
About the authors
Issues
FAQ
How big is it?
The latest upgrade!
Privacy
Forums
Blog
Contact

Search
Enter Keywords:
 
more...

Latest Vulnerabilities
opensslSep 26
openssl-develSep 26
openssl*Sep 23
openssl-devel*Sep 23
irssi*Sep 22
irssi*Sep 22
firefoxSep 20
firefox*Sep 20
firefox-esrSep 20
firefox-esr*Sep 20
libxulSep 20
libxul*Sep 20
linux-firefoxSep 20
linux-firefox*Sep 20
linux-seamonkeySep 20

13 vulnerabilities affecting 37 ports have been reported in the past 14 days

* - modified, not new

All vulnerabilities


Ports
Home
Categories
Deleted ports
Sanity Test Failures
Newsfeeds

Statistics
Graphs
NEW Graphs (Javascript)
Traffic

Calculated hourly:
Port count 26274
Broken 375
Deprecated 218
Ignore 639
Forbidden 0
Restricted 199
No CDROM 83
Vulnerable 61
Expired 14
Set to expire 204
Interactive 0
new 24 hours 4
new 48 hours10
new 7 days32
new fortnight60
new month114

Servers and bandwidth provided by
New York Internet, SuperNews, and RootBSD
Valid HTML, CSS, and RSS.
Copyright © 2000-2014 Dan Langille. All rights reserved.