FreshPorts -- The Place For Ports If you buy from Amazon USA, please support us by using this link.
Follow us
Blog
Twitter

Port details
atril-lite MATE multi-format document viewer
1.18.1_1 graphics on this many watch lists=0 search for ports that depend on this port An older version of this port was marked as vulnerable. Find issues related to this port Report an issue related to this port
Maintainer: gnome@FreeBSD.org search for ports maintained by this maintainer
Port Added: 15 Jul 2015 07:47:27
Also Listed In: print mate
License: GPLv2
Atril is a document viewer for multiple document formats including PDF and
Postscript.  The goal of Atril is to replace document viewers such as ggv and
gpdf with a single, simple application.

This lite version doesn't have depend on MATE libraries. Such as caja.

WWW: http://mate-desktop.org/
SVNWeb : Homepage : PortsMon : pkg-plist

To install the port: cd /usr/ports/graphics/atril-lite/ && make install clean
To add the package: pkg install atril-lite

PKGNAME: atril-lite

distinfo:

TIMESTAMP = 1503851121
SHA256 (mate/atril-1.18.1.tar.xz) = 8504c0164faf9a0763118d444007dd2bc655dd0dcd0c6ecfff163080b61883f2
SIZE (mate/atril-1.18.1.tar.xz) = 1695280


Master port: graphics/atril

NOTE: FreshPorts displays only information on required and default dependencies. Optional dependencies are not covered.

Build dependencies:
  1. itstool : textproc/itstool
  2. update-desktop-database : devel/desktop-file-utils
  3. msgfmt : devel/gettext-tools
  4. gmake : devel/gmake
  5. pkgconf>=1.3.0_1 : devel/pkgconf
  6. gtk-update-icon-cache : graphics/gtk-update-icon-cache
  7. intltool-extract : textproc/intltool
  8. index.theme : x11-themes/mate-icon-theme
  9. ice.pc : x11/libICE
  10. sm.pc : x11/libSM
  11. x11.pc : x11/libX11
Runtime dependencies:
  1. update-desktop-database : devel/desktop-file-utils
  2. gtk-update-icon-cache : graphics/gtk-update-icon-cache
  3. index.theme : x11-themes/mate-icon-theme
  4. ice.pc : x11/libICE
  5. sm.pc : x11/libSM
  6. x11.pc : x11/libX11
Library dependencies:
  1. libpoppler-glib.so : graphics/poppler-glib
  2. libsoup-2.4.so : devel/libsoup
  3. libfontconfig.so : x11-fonts/fontconfig
  4. libfreetype.so : print/freetype2
  5. libtiff.so : graphics/tiff
  6. libspectre.so : print/libspectre
  7. libdjvulibre.so : graphics/djvulibre
  8. libwebkit2gtk-4.0.so : www/webkit2-gtk3
  9. libsecret-1.so : security/libsecret
  10. libgxps.so : graphics/libgxps
  11. libintl.so : devel/gettext-runtime
  12. libarchive.so.13 : archivers/libarchive
  13. libatk-1.0.so : accessibility/atk
  14. libcairo.so : graphics/cairo
  15. libgdk_pixbuf-2.0.so : graphics/gdk-pixbuf2
  16. libglib-2.0.so : devel/glib20
  17. libintl.so : devel/gettext-runtime
  18. libgtk-3.so : x11-toolkits/gtk30
  19. libxml2.so : textproc/libxml2
  20. libpango-1.0.so : x11-toolkits/pango
There are no ports dependent upon this port

Configuration Options
===> The following configuration options are available for atril-lite-1.18.1_1:
     COMICS=on: Comic book archives support
     DJVU=on: DJVU support
     DVI=off: DVI viewer support
     EPUB=on: Epub support
     KEYRING=on: Keyring support
     T1LIB=off: T1LIB for TYPE1 fonts to DVI (Enables DVI)
     XPS=on: XPS support
===> Use 'make config' to modify these settings

USES:
desktop-file-utils gettext gmake libarchive libtool pathfix  pkgconfig tar:xz gnome mate

Master Sites:
  1. http://pub.mate-desktop.org/releases/1.18/

Number of commits found: 18

Commit History - (may be incomplete: see SVNWeb link above for full details)
This is a slave port. You may also want to view the commits to the master port: graphics/atril
DateByDescription
14 Oct 2017 20:51:48
Original commit files touched by this commit  1.18.1_1
Revision:452089
kwm search for other commits by this committer
Minor MATE 1.18 update.

Apart from version updates, the highlights are:
 * fix orphaned file issues in atril/atril-lite.
 * Add licenses where required.
 * make sure the mime xml gets installed in mate-control-center.
 * regen the m-c-c patch, with make makepatch.
06 Sep 2017 18:34:45
Original commit files touched by this commit  1.18.1
Revision:449354
truckman search for other commits by this committer
Upgrade graphics/atril and graphics/atril-lite to version 1.18.1 to
fix CVE-2017-1000083.

Fix portlint warnings.

PR:		221867
Submitted by:	rkoberman@gmail.com
MFH:		2017Q3
Security:	01a197ca-67f1-11e7-a266-28924a333806
24 Aug 2017 15:49:34
Original commit files touched by this commit  1.18.0_1
Revision:448690 This port version is marked as vulnerable.
swills search for other commits by this committer
Add missed PORTREVISION bumps after recent poppler update
04 Jul 2017 11:44:30
Original commit files touched by this commit  1.18.0
Revision:445014 This port version is marked as vulnerable.
kwm search for other commits by this committer
Update the mate desktop to 1.18.

* The MATE DE is now GTK+3 based
* mate-calc has come back.
* New USE_MATE=mixer macro

* Add license
* Review dependancies
* Swich to USES=localbase
* atril/eom options reworked into option helper

Thanks to Eric Turgeon for submitting the bulk of this MATE update.

Obtained from:	gnome devel repo
07 Jan 2017 10:42:51
Original commit files touched by this commit  1.12.2_2
Revision:430778 This port version is marked as vulnerable.
olivierd search for other commits by this committer
Chase update of graphics/poppler (and slaves ports) in revision r430777
05 Sep 2016 20:02:03
Original commit files touched by this commit  1.12.2_1
Revision:421390 This port version is marked as vulnerable.
olivierd search for other commits by this committer
Chase update of Poppler after revision r421386
25 Jan 2016 12:31:21
Original commit files touched by this commit  1.12.2
Revision:407209 This port version is marked as vulnerable.
kwm search for other commits by this committer
Update the MATE DE to 1.12.

* Still build MATE against gtk+ 2 due to gtk+ 3 support not ready
  for prime time.
* Fix loading of a number of applets. We rename a number of applets
  but didn't change the "config" files the "add applet to panel" dialog
  uses. [1]
* Unbreak the creation of new notes with the stickynotes applet [2]

PR:		205391 [1], 200349 [2]
Obtained from:	GNOME devel repo
24 Jan 2016 14:46:38
Original commit files touched by this commit  1.10.2_2
Revision:407131 This port version is marked as vulnerable.
kwm search for other commits by this committer
Enable DJVU support in evince[-lite] by default.

While here do the same for atril[-lite].

PR:		203710
Submitted by:	vas@mpeks.tomsk.su
22 Jan 2016 17:20:28
Original commit files touched by this commit  1.10.2_1
Revision:406938 This port version is marked as vulnerable.
kwm search for other commits by this committer
Bump Libreoffice, evince-lite and atril-lite for the poppler update.
04 Sep 2015 09:44:10
Original commit files touched by this commit  1.10.2
Revision:396068 This port version is marked as vulnerable.
kwm search for other commits by this committer
Update atril to 1.10.2.
02 Aug 2015 16:06:17
Original commit files touched by this commit  1.10.1_5
Revision:393431 This port version is marked as vulnerable.
kwm search for other commits by this committer
Update poppler to 0.34.0. [1]

Chase all users of shlib version change of libpoppler.so.

PR:		201477 [1]
Submitted by:	olivierd@ [1]
02 Aug 2015 15:03:20
Original commit files touched by this commit  1.10.1_4
Revision:393429 This port version is marked as vulnerable.
tijl search for other commits by this committer
By default libtool replaces -export-symbols <file> with -retain-symbols-file
<file> on ELF systems, but this doesn't really do what -export-symbols is
meant to do.  On GNU ELF systems it converts <file> to a simple version
script first and then uses -version-script instead of -retain-symbols-file.
Let USES=libtool patch libtool scripts to do this on all systems with GNU
ld(1).

Bump PORTREVISION on all ports where the build log contains -export-symbols.

audio/calf: This port builds a module that now exports only one function,
but it also builds a number of executables that link to this module and
expect to see other functions.  Because it's already a bit dodgy to link to
a module (libtool warns about this) let the module continue to export only
one function and instead build an ordinary library from the same source that
the executables can link to.  Fix a number of other issues in the same
(Only the first 15 lines of the commit message are shown above View all of this commit message)
29 Jul 2015 16:11:36
Original commit files touched by this commit  1.10.1_3
Revision:393164 This port version is marked as vulnerable.
kwm search for other commits by this committer
Add patch from upstream that makes mate-desktop support optional. And
disable this for atril-lite.

PR:		201967
Submitted by:	Matthieu Volat <mazhe@alkumuna.eu>
28 Jul 2015 13:07:33
Original commit files touched by this commit  1.10.1_2
Revision:393072 This port version is marked as vulnerable.
kwm search for other commits by this committer
Bump portrevision of atril-lite for plist fixes.

Submitted by:	antoine@
28 Jul 2015 12:57:08
Original commit files touched by this commit  1.10.1_1
Revision:393070 This port version is marked as vulnerable.
kwm search for other commits by this committer
* Unbreak the configure on 9.x. There is no zlib.pc file in base.
* Atril-lite needs mate-desktop
* Keyring support switch in configure was changed to
  --with-keyring instead of --enable-keyring.
* Update atril-lite plist

Submitted by:	pkg-fallout
16 Jul 2015 11:37:27
Original commit files touched by this commit  1.8.1_1
Revision:392291 This port version is marked as vulnerable.
kwm search for other commits by this committer
* mate-desktop is not needed for atril-lite [1]
* Disable introspection for now (again). Introspection isn't build
  correct in the 1.8 series. This has been fixed in atril 1.10.

PR:		201610 (based on) [1]
Submitted by:	Matthieu Volat <mazhe@alkumuna.eu> [1]
15 Jul 2015 07:50:10
Original commit files touched by this commit  1.8.1
Revision:392123 This port version is marked as vulnerable.
kwm search for other commits by this committer
Add a lite version of atril.

PR:		197197
Submitted by:	Matthieu Volat <mazhe@alkumuna.eu>
15 Jul 2015 07:47:14
Original commit files touched by this commit  1.8.1_4
Revision:392122 This port version is marked as vulnerable.
kwm search for other commits by this committer
svn cp.

Number of commits found: 18

Login
User Login
Create account

Servers and bandwidth provided by
New York Internet, SuperNews, and RootBSD

This site
What is FreshPorts?
About the authors
Issues
FAQ
How big is it?
The latest upgrade!
Privacy
Forums
Blog
Contact

Search
Enter Keywords:
 
more...

Latest Vulnerabilities
mariadb100-serverOct 19
mariadb101-serverOct 19
mariadb102-serverOct 19
mariadb55-serverOct 19
mysql55-serverOct 19
mysql56-serverOct 19
mysql57-serverOct 19
percona55-serverOct 19
percona56-serverOct 19
percona57-serverOct 19
krb5Oct 18
krb5-113Oct 18
krb5-114Oct 18
krb5-115Oct 18
linux-flashplayerOct 17

21 vulnerabilities affecting 94 ports have been reported in the past 14 days

* - modified, not new

All vulnerabilities


Ports
Home
Categories
Deleted ports
Sanity Test Failures
Newsfeeds

Statistics
Graphs
NEW Graphs (Javascript)
Traffic

Calculated hourly:
Port count 31586
Broken 153
Deprecated 64
Ignore 422
Forbidden 0
Restricted 175
No CDROM 78
Vulnerable 61
Expired 20
Set to expire 57
Interactive 0
new 24 hours 1
new 48 hours3
new 7 days27
new fortnight38
new month218

Servers and bandwidth provided by
New York Internet, SuperNews, and RootBSD
Valid HTML, CSS, and RSS.
Copyright © 2000-2017 Dan Langille. All rights reserved.