FreshPorts -- The Place For Ports If you buy from Amazon USA, please support us by using this link.
Follow us
Blog
Twitter

I am looking for an LTO tape library. Do you have one to spare?
Port details
poppler-qt4 0.24.5_1 graphics on this many watch lists=11 search for ports that depend on this port
Qt4 bindings to poppler
Maintained by: gnome@FreeBSD.org search for ports maintained by this maintainer
Port Added: 03 Jul 2007 11:20:45
Also Listed In: print
License: GPLv2


Poppler is a fork of the xpdf PDF viewer developed by Derek Noonburg
of Glyph and Cog, LLC.  It provides PDF rendering functionality as a
shared library, and uses modern components from Freedesktop.org such as
fontconfig and cairo to take advantage of modern UNIX desktops.

WWW: http://poppler.freedesktop.org/
SVNWeb : Main Web Site : Distfiles Availability : PortsMon
Master port: graphics/poppler

NOTE: FreshPorts displays only information on required and default dependencies. Optional dependencies are not covered.

Required To Build:
  1. devel/gmake
  2. devel/pkgconf
  3. devel/qt4-corelib
  4. x11-toolkits/qt4-gui
  5. devel/qt4-moc
  6. devel/qt4-testlib
  7. textproc/qt4-xml
Required To Run:
  1. graphics/poppler-data
  2. devel/qt4-corelib
  3. x11-toolkits/qt4-gui
  4. devel/qt4-testlib
  5. textproc/qt4-xml
Required Libraries:
  1. graphics/jpeg
  2. x11-fonts/fontconfig
  3. graphics/lcms2
  4. graphics/poppler
  5. textproc/libxml2

This port is required by:

for Libraries * - deleted ports are only shown under the This port is required by section. It was harder to do for the Required section. Perhaps later...

To install the port: cd /usr/ports/graphics/poppler-qt4/ && make install clean
To add the package: pkg install graphics/poppler-qt4


Configuration Options
     No options to configure

Master Sites:
  1. http://distcache.FreeBSD.org/ports-distfiles/
  2. http://poppler.freedesktop.org/
Notes from UPDATING
These upgrade notes are taken from /usr/ports/UPDATING
  • 2008-06-30
    Affects: users of graphics/cairo, graphics/poppler*, and future users of www/firefox3
    Author: FreeBSD GNOME Team <gnome@FreeBSD.org>
    Reason: 
      The poppler* ports have been updated to 0.8.3 and the shared libraries
      have changed.  Firefox 3.0 has been added to the tree as www/firefox3.
      These changes require that all dependent ports be updated.  You can do
      this in one of two ways:
    
    	# portmaster pixman
    	# portmaster \*cairo\*
    	# portmaster -r poppler-0
    
      or:
    
    	# pkgdb -Ff
    	# portupgrade pixman\* \*cairo\*
    	# portupgrade -r poppler-0.\*
    
    

Number of commits found: 24

Commit History - (may be incomplete: see SVNWeb link above for full details)
DateByDescription
23 Apr 2014 13:25:17
Original commit files touched by this commit  0.24.5_1
Revision:351936
tijl search for other commits by this committer
When linking a library libA with a library libB using libtool, if libB.la
exists, libtool will add all libraries libB.la refers to (dependency_libs
field) to the linker command line and store them in the dependency_libs
field of libA.la.  So everything that subsequently links with libA will also
link to these extra libraries.  This causes too much overlinking.

This commit modifies Mk/Uses/libtool.mk so it empties the dependency_libs
field in .la libraries during staging.  However, because .la libraries have
very limited use when dependency_libs is empty it makes sense to completely
remove them during staging.

So with this commit USES=libtool is modified to remove .la libraries and a
new form (USES=libtool:keepla) is introduced in case they need to be kept
(dependency_libs is still emptied).
(Only the first 15 lines of the commit message are shown above View all of this commit message)
22 Feb 2014 23:46:21
Original commit files touched by this commit  0.24.5
Revision:345682
kwm search for other commits by this committer
Update to 0.24.5 (missed in r345681).

Switch to USES=libtool
27 Dec 2013 16:54:22
Original commit files touched by this commit  0.24.4
Revision:337749
kwm search for other commits by this committer
Update poppler to 0.24.4.

Update comment.
Use new LIB_DEPENDS syntax, use USES=pathfix.
Stagify.

Bump portrevision of all affected ports, and Update poppler* LIB_DEPENDS to
new syntax.
20 Sep 2013 18:35:46
Original commit files touched by this commit  0.22.2
Revision:327733
bapt search for other commits by this committer
Add NO_STAGE all over the place in preparation for the staging support (cat:
graphics)
21 Mar 2013 05:27:16
Original commit files touched by this commit  0.22.2
Revision:314805
mezz search for other commits by this committer
- Update poppler to 0.22.2.
- Bump the rest ports that depend on the poppler and poppler-qt because of
  shared library version have been changed.
- Add a note in the UPDATING for require to rebuild all ports that depend
  on poppler.

Submitted by:	kwm (poppler* part)
01 Jun 2012 05:26:28
Original commit files touched by this commit  0.18.4_1
dinoex search for other commits by this committer
- update png to 1.5.10
20 Nov 2010 15:37:08
Original commit files touched by this commit  0.14.5
kwm search for other commits by this committer
Presenting GNOME 2.32.1 for FreeBSD. The offical release notes for this
release can be found at http://library.gnome.org/misc/release-notes/2.32/

This will be the last release of the GNOME 2.x series, mainly a bugfix and
bridge release to the first release of the GNOME 3.x series.

This release features commits by avl, marcus, mezz and myself.

The FreeBSD GNOME Team would like to thank the following contributors and
testers for there help with this release:

Zane C.B. <vvelox@vvelox.net>
romain@
Olaf Seibert <O.Seibert@cs.ru.nl>
DomiX
(Only the first 15 lines of the commit message are shown above View all of this commit message)
10 May 2010 21:19:08
Original commit files touched by this commit  0.12.4
kwm search for other commits by this committer
Presenting GNOME 2.30.1 for FreeBSD. The offical release notes for this
release can be found at http://library.gnome.org/misc/release-notes/2.30/ .

This release brings initial PackageKit support, Upower (replaces power
management part of hal), cuse4bsd integration with HAL and cheese, and a
faster Evolution.

Sadly GNOME 2.30.x will be the last release with FreeBSD 6.X support. This
will also be the last of the 2.x releases. The next release will be the
highly-anticipated GNOME 3.0 which will bring with it a new UI experience.

Currently, there are a few bugs with GNOME 2.30 that may be of note for our
users. Be sure to consult the UPGRADING note or the 2.30 upgrade FAQ at
http://www.freebsd.org/gnome/docs/faq230.html for specific upgrading
instructions, and the up-to-date list of known issues.
(Only the first 15 lines of the commit message are shown above View all of this commit message)
28 Mar 2010 06:47:48
Original commit files touched by this commit  0.12.3_2
dinoex search for other commits by this committer
- update to 1.4.1
Reviewed by:    exp8 run on pointyhat
Supported by:   miwi
05 Feb 2010 11:46:55
Original commit files touched by this commit  0.12.3_1
dinoex search for other commits by this committer
- update to jpeg-8
28 Nov 2009 20:06:37
Original commit files touched by this commit  0.12.2
marcus search for other commits by this committer
Presenting GNOME 2.28.1 for FreeBSD.  The official release notes for this
release can be found at http://library.gnome.org/misc/release-notes/2.28/ .
Officially, this is mostly a polishing release in preparation for GNOME 3.0
due in about a year.

On the FreeBSD front, though, a lot went into this release.  Major thanks
goes to kwm and avl who did a lot of the porting work for this release.
In particular, kwm brought in Evolution MAPI support for better Microsoft
Exchange integration.  Avl made sure that the new gobject introspection
repository ports were nicely compartmentalized so that large dependencies
aren't brought in wholesale.

But, every GNOME team member (ahze, avl, bland, kwm, mezz, and myself)
contributed to this release.
(Only the first 15 lines of the commit message are shown above View all of this commit message)
31 Jul 2009 13:57:52
Original commit files touched by this commit  0.10.6_1
dinoex search for other commits by this committer
- bump all port that indirectly depends on libjpeg and have not yet been bumped
or updated
Requested by:   edwin
18 Apr 2009 18:20:07
Original commit files touched by this commit  0.10.6
marcus search for other commits by this committer
Update to 0.10.6 to fix a set of vulnerabilities documented in
http://secunia.com/advisories/34746/ .

"Some vulnerabilities have been reported in Poppler which can be
exploited by malicious people to potentially compromise an
application using the library."

PR:             133838
Submitted by:   Mark Foster <mark@foster.cc>
Approved by:    portmgr (implicit)
10 Apr 2009 05:56:28
Original commit files touched by this commit  0.10.5_1
marcus search for other commits by this committer
Presenting GNOME 2.26 for FreeBSD.  See
http://library.gnome.org/misc/release-notes/2.26/ for a list of what's new.
On the FreeBSD front, we introduced a port of libxul 1.9 as an alternative
for Firefox 2.0 as a Gecko provider.  Almost all of the Gecko consumers
can make use of this provider by setting:

WITH_GECKO=libxul

The GNOME 2.26 port was done by ahze, kwm, marcus, and mezz with
contributions by Joseph S. Atkinson, Peter Wemm, Eric L. Chen,
Martin Matuska, Craig Butler, and Pawel Worach.
04 Aug 2008 02:28:01
Original commit files touched by this commit  0.8.5
mezz search for other commits by this committer
Update to 0.8.5.
03 Jul 2008 16:13:44
Original commit files touched by this commit  0.8.4_1
mezz search for other commits by this committer
- Add jpeg dependency, bump the PORTREVISION on poppler, poppler-qt4 and
  poppler-utils.
- Add --disable-gdk and --disable-gtk-test if it's not poppler-gtk.
- Minor clean up related w/ whitespace.
02 Jul 2008 19:59:23
Original commit files touched by this commit  0.8.4
mezz search for other commits by this committer
Update to 0.8.4.
30 Jun 2008 20:16:22
Original commit files touched by this commit  0.8.3_1
mezz search for other commits by this committer
First all, ahze did most of work. Thanks ahze! Last week or so, I am just
merely pick up and help him. Thanks to many testers in both private and
mailing list emails for report a few of build and dependencies problems.
Also, thanks to marcus and Chess Griffin for test in their tinderboxes.

x11/pixman: Update to 0.10.0
-------------------------------------------------------
Firefox 3 needs it. Orignal, the shared library was bumped and ahze has
added a new feature in our USE_GNOME=ltverhack by can control the number
of shared library. To control the number of shared library, add the
ltverhack:N. Right now pixman has USE_GNOME=ltverhack:9 to make it stays
same at libpixman-1.so.9. If anyone want to use ltverhack:N in one of your
port, you need to make sure the ABI doesn't change to use it..
-------------------------------------------------------
(Only the first 15 lines of the commit message are shown above View all of this commit message)
06 Jun 2008 13:35:04
Original commit files touched by this commit  0.6.4_1
edwin search for other commits by this committer
Bump portrevision due to upgrade of devel/gettext.

The affected ports are the ones with gettext as a run-dependency
according to ports/INDEX-7 (5007 of them) and the ones with USE_GETTEXT
in Makefile (29 of them).

PR:             ports/124340
Submitted by:   edwin@
Approved by:    portmgr (pav)
11 Sep 2007 03:59:13
Original commit files touched by this commit  0.6
marcus search for other commits by this committer
Update to 0.6.
28 Aug 2007 00:57:24
Original commit files touched by this commit  0.5.91
marcus search for other commits by this committer
Update to 0.5.91.
25 Jul 2007 14:35:31
Original commit files touched by this commit  0.5.9_2
ahze search for other commits by this committer
Install poppler-qt4.pc for poppler-qt4

PR:             ports/114773
Reported by:    Sven Gaerner
13 Jul 2007 13:54:42
Original commit files touched by this commit  0.5.9_1
ahze search for other commits by this committer
Don't link to libpoppler from graphics/poppler since it doesn't contain required
Arthur backend. Instead build libpoppler with poppler-qt4

PR:             ports/114551
Reported by:            Sven Gaerner <sgaerner@gmx.net>
03 Jul 2007 11:18:46
Original commit files touched by this commit  0.5.9
ahze search for other commits by this committer
Add poppler-qt4

Qt4 bindings to poppler

Number of commits found: 24

Login
User Login
Create account

Servers and bandwidth provided by
New York Internet, SuperNews, and RootBSD

This site
What is FreshPorts?
About the authors
FAQ
How big is it?
The latest upgrade!
Privacy
Forums
Blog
Contact

Search
Enter Keywords:
 
more...

Latest Vulnerabilities
firefoxJul 23
firefox-develJul 23
firefox-esrJul 23
firefox10Jul 23
firefox15Jul 23
firefox3Jul 23
firefox3-develJul 23
firefox35Jul 23
firefox36Jul 23
linux-firefoxJul 23
linux-thunderbirdJul 23
nssJul 23
thunderbirdJul 23
thunderbird-esrJul 23
thunderbird3Jul 23

9 vulnerabilities affecting 26 ports have been reported in the past 14 days

* - modified, not new

All vulnerabilities


Ports
Home
Categories
Deleted ports
Sanity Test Failures
Newsfeeds


Statistics
Graphs
NEW Graphs (Javascript)
Traffic

Calculated hourly:
Port count 24426
Broken 194
Deprecated 792
Ignore 529
Forbidden 16
Restricted 263
No CDROM 102
Vulnerable 27
Expired 21
Set to expire 779
Interactive 13
new 24 hours 3
new 48 hours4
new 7 days19
new fortnight48
new month104

Servers and bandwidth provided by
New York Internet, SuperNews, and RootBSD
Valid HTML, CSS, and RSS.
Copyright © 2000-2014 Dan Langille. All rights reserved.