FreshPorts -- The Place For Ports If you buy from Amazon USA, please support us by using this link.
Follow us
Blog
Twitter

I am looking for an LTO tape library. Do you have one to spare?
Port details
jdk14 1.4.2p8_19 java Deleted on this many watch lists=146 search for ports that depend on this port This port version is marked as vulnerable.
Broken BROKEN: Does not compile with GCC 4.2
Deprecated DEPRECATED: does not build on FreeBSD 7.x or newer
Expired This port expired on: 2011-04-17
Ignore IGNORE: is marked as broken: Does not compile with GCC 4.2
Restricted RESTRICTED: "Redistribution of pre-compiled binaries is not permitted"
NO CDROM NO CDROM: "Redistribution of pre-compiled binaries is not permitted"
Java Development Kit 1.4.2
Was Maintained by: glewis@FreeBSD.org search for ports maintained by this maintainer
Port Added: 06 Mar 2003 23:19:15
Also Listed In: devel
License: not specified in port


This is the latest patchset from the Java 2 FreeBSD porting project.  This 
port allows you to easily build a native JDK1.4.2 for FreeBSD.

Please note that due to the current Sun licensing policy the resulting binaries
can't be distributed and you are only permitted to use/hack it personally.
Due to the same reasons you have to manually fetch the source code and patchset
for FreeBSD.

WWW: http://www.freebsd.org/java/
     http://www.eyesbeyond.com/freebsddom/java/index.html
     http://www.sun.com/software/communitysource/java2/
SVNWeb : Main Web Site : Distfiles Availability : PortsMon

NOTE: FreshPorts displays only information on required and default dependencies. Optional dependencies are not covered.

Required To Build:
  1. devel/m4
  2. archivers/zip
  3. devel/nspr
  4. x11-toolkits/open-motif
  5. java/linux-sun-jdk14
  6. devel/gmake
  7. x11/libX11
  8. x11/libXext
  9. x11/libXi
  10. x11-toolkits/libXmu
  11. x11/libXp
  12. x11-toolkits/libXt
  13. x11/libXtst
Required To Run:
  1. java/javavmwrapper
  2. x11-fonts/urwfonts
  3. x11/libX11
  4. x11/libXext
  5. x11/libXi
  6. x11-toolkits/libXmu
  7. x11/libXp
  8. x11-toolkits/libXt
  9. x11/libXtst
There are no ports dependent upon this port

No installation instructions: this port has been deleted.

The package name of this deleted port was: jdk14


Configuration Options
===> The following configuration options are available for jdk-1.4.2p8_19:     DEBUG=off (default) "Enable debugging support"     IPV6=off (default) "Enable IPv6 support"     POLICY=off (default) "Install the Unlimited Strength Policy Files"     TZUPDATE=on (default) "Update the time zone data"     WEB=on (default) "Enable the browser plugin and Java Web Start"     JAIL=off (default) "Port is being built within a jail"===> Use 'make config' to modify these settings

Master Sites:
  1. ftp://ftp.FreeBSD.org/pub/FreeBSD/ports/distfiles/
Port Moves
  • port deleted on 2011-06-28
    REASON: Has expired: does not build on FreeBSD 7.x or newer

Number of commits found: 102 (showing only 100 on this page)

1 | 2  »  

Commit History - (may be incomplete: see SVNWeb link above for full details)
DateByDescription
28 Jun 2011 18:57:19
Original commit files touched by this commit  1.4.2p8_19
 This port version is marked as vulnerable.
rene search for other commits by this committer
Remove expired port:
2011-04-17 java/jdk14: does not build on FreeBSD 7.x or newer
02 May 2011 12:44:53
Original commit files touched by this commit  1.4.2p8_19
 This port version is marked as vulnerable.
makc search for other commits by this committer
Bump PORTREVISION after open-mofit update
20 Mar 2011 12:54:45
Original commit files touched by this commit  1.4.2p8_18
 This port version is marked as vulnerable.
miwi search for other commits by this committer
- Get Rid MD5 support
17 Mar 2011 11:08:44
Original commit files touched by this commit  1.4.2p8_18
 This port version is marked as vulnerable.
pav search for other commits by this committer
- Mark ports that have been broken for six month or more, or never compiled on
  7.X and up, for removal in one month
12 Feb 2010 19:01:23
Original commit files touched by this commit  1.4.2p8_18
 This port version is marked as vulnerable.
glewis search for other commits by this committer
. Update to tzupdater 1.3.25.

PR:             143083
Submitted by:   Sunpoet Po-Chuan Hsieh <sunpoet@sunpoet.net>
09 Nov 2009 03:04:04
Original commit files touched by this commit  1.4.2p8_17
 This port version is marked as vulnerable.
glewis search for other commits by this committer
. Update to tzupdater 1.3.21.
06 Sep 2009 01:15:33
Original commit files touched by this commit  1.4.2p8_16
 This port version is marked as vulnerable.
glewis search for other commits by this committer
. Update to tzupdater 1.3.18.
21 May 2009 20:46:11
Original commit files touched by this commit  1.4.2p8_15
 This port version is marked as vulnerable.
glewis search for other commits by this committer
. Update to tzupdater 1.3.15.
27 Mar 2009 03:15:24
Original commit files touched by this commit  1.4.2p8_14
 This port version is marked as vulnerable.
glewis search for other commits by this committer
. Update to tzupdater 1.3.12.
03 Nov 2008 14:38:26
Original commit files touched by this commit  1.4.2p8_13
 This port version is marked as vulnerable.
glewis search for other commits by this committer
. Update to tzupdater 1.3.9-2008g.
13 Jul 2008 18:18:44
Original commit files touched by this commit  1.4.2p8_12
 This port version is marked as vulnerable.
glewis search for other commits by this committer
. Update to tzupdater 1.3.6.

PR:             125469
Submitted by:   Wayne Sierke <ws@au.dyndns.ws>
06 May 2008 06:05:39
Original commit files touched by this commit  1.4.2p8_11
 This port version is marked as vulnerable.
glewis search for other commits by this committer
. Update to tzupdater 1.3.5.  This patch is based on that submitted in the
  PR but also fixes the path to tzupdater and bumps PORTREVISION.

PR:             123189
Submitted by:   Greg Larkin
25 Apr 2008 23:15:14
Original commit files touched by this commit  1.4.2p8_10
 This port version is marked as vulnerable.
miwi search for other commits by this committer
- Fix patch reject after xorg cleanup

Submitted by:   pointyhat via pav
19 Apr 2008 17:56:05
Original commit files touched by this commit  1.4.2p8_10
  Sanity Test Failure This port version is marked as vulnerable.
miwi search for other commits by this committer
- Remove unneeded dependency from gtk12/gtk20 [1]
- Remove USE_XLIB/USE_X_PREFIX/USE_XPM in favor of USE_XORG
- Remove X11BASE support in favor of LOCALBASE or PREFIX
- Use USE_LDCONFIG instead of INSTALLS_SHLIB
- Remove unneeded USE_GCC 3.4+

Thanks to all Helpers:
        Dmitry Marakasov, Chess Griffin, beech@, dinoex, rafan, gahr,
        ehaupt, nox, itetcu, flz, pav

PR:             116263
Tested on:      pointyhat
Approved by:    portmgr (pav)
13 Jan 2008 04:48:37
Original commit files touched by this commit  1.4.2p8_10
 This port version is marked as vulnerable.
glewis search for other commits by this committer
. Update to tzupdater 1.3.3.
15 Nov 2007 17:44:57
Original commit files touched by this commit  1.4.2p8_9
 This port version is marked as vulnerable.
glewis search for other commits by this committer
. Update to tzupdater 1.3.0 to fix the default build (the previous version
  of tzupdater is no longer available).

Approved by:    portmgr (linimon)
11 Oct 2007 02:18:15
Original commit files touched by this commit  1.4.2p8_8
 This port version is marked as vulnerable.
glewis search for other commits by this committer
. Explicitly pull in X dependencies instead of depending on the open-motif
  dependency to implicitly pull in the X libraries we need.

Requested by:   linimon
07 Sep 2007 06:42:55
Original commit files touched by this commit  1.4.2p8_8
 This port version is marked as vulnerable.
glewis search for other commits by this committer
. Update to tzupdater 1.2.2.
02 Sep 2007 06:00:00
Original commit files touched by this commit  1.4.2p8_7
 This port version is marked as vulnerable.
glewis search for other commits by this committer
. Mark this as BROKEN for gcc 4.2.  The HotSpot C++ code needs some work
  to be made gcc 4.2 compliant.
06 Jun 2007 15:54:28
Original commit files touched by this commit  1.4.2p8_7
 This port version is marked as vulnerable.
glewis search for other commits by this committer
. More respect for ${CC}, ${CXX} and ${CPP}.

Submitted by:   truckman@
03 Jun 2007 00:42:33
Original commit files touched by this commit  1.4.2p8_7
 This port version is marked as vulnerable.
glewis search for other commits by this committer
. Update to tzupdater 1.2.1.

PR:     113248
22 May 2007 16:21:27
Original commit files touched by this commit  1.4.2p8_6
 This port version is marked as vulnerable.
glewis search for other commits by this committer
. Make it so we include Xm/XmIm.h rather than defining our own prototype.
  Fixes a build error due to the prototype being defined not matching
  the actual function.

Approved by:    portmgr (pav)
19 May 2007 20:32:57
Original commit files touched by this commit  1.4.2p8_6
 This port version is marked as vulnerable.
flz search for other commits by this committer
- Welcome X.org 7.2 \o/.
- Set X11BASE to ${LOCALBASE} for recent ${OSVERSION}.
- Bump PORTREVISION for ports intalling files in ${X11BASE}.
08 Mar 2007 05:18:45
Original commit files touched by this commit  1.4.2p8_5
 This port version is marked as vulnerable.
glewis search for other commits by this committer
. Add JAIL as an option, the Makefile already supported it as an
  environment variable.

PR:             110049
07 Mar 2007 16:30:42
Original commit files touched by this commit  1.4.2p8_5
 This port version is marked as vulnerable.
glewis search for other commits by this committer
. Update to tzupdater 1.1.0-2007c.
. Clean up old zoneinfo files after tzupdater has run.
26 Feb 2007 00:21:36
Original commit files touched by this commit  1.4.2p8_5
 This port version is marked as vulnerable.
glewis search for other commits by this committer
. Add a TZUPDATE option, defaulting to on, which will update the time zone
  data for the JDK using Sun's tzupdater. [1]
. Some simplification of the convoluted logic around telling the user
  which files to download.  In particular, don't care if we've already
  told them to download a file.
. Bump PORTREVISION since many North American users will need to pick up
  the time zone changes.

Collaboration with:     Tim Zingelman <zingelman@fnal.gov> [1]
08 Dec 2006 22:36:16
Original commit files touched by this commit  1.4.2p8_4
 This port version is marked as vulnerable.
glewis search for other commits by this committer
. Replace some hardwired /usr/X11R6 instances with X11BASE. [1]
. Small Makefile restructure to keep related variables in one place.
. Trim the ancient bootstrapping options.
. Add ipv6 to CATEGORIES if its enabled. [2]

PR:             106129 [2]
Submitted by:   Janos Mohacsi <janos.mohacsi@bsd.hu> [2]
Pointed out by: pointyhat (via kris) [1]
09 Oct 2006 16:35:29
Original commit files touched by this commit  1.4.2p8_4
 This port version is marked as vulnerable.
glewis search for other commits by this committer
. The IPV6_ONLY option is unnecessary as IPV6_V6ONLY is defined in
  /usr/include/netinet6/in6.h.

Submitted by:   ume@
08 Oct 2006 19:22:19
Original commit files touched by this commit  1.4.2p8_4
 This port version is marked as vulnerable.
glewis search for other commits by this committer
. Add support for installing the JCE policy files. [1]
. OPTIONify. [1]
. Add a knob for IPV6_V6ONLY.
. Bump PORTREVISION.

PR:             103920
Submitted by:   lioux@
08 Oct 2006 19:20:28
Original commit files touched by this commit  1.4.2p8_3
 This port version is marked as vulnerable.
glewis search for other commits by this committer
. Add a patch to support IPv6 only operation.
  (Makefile knob to follow)

PR:             92620
Submitted by:   ume@
08 Oct 2006 19:14:41
Original commit files touched by this commit  1.4.2p8_3
 This port version is marked as vulnerable.
glewis search for other commits by this committer
. Use a mutex to make the resolver functions thread safe on FreeBSD 4.x
  (they are already thread safe on FreeBSD 5+).

Submitted by:   Arne Juul <arnej@europe.yahoo-inc.com>
09 May 2006 00:18:07
Original commit files touched by this commit  1.4.2p8_3
 This port version is marked as vulnerable.
edwin search for other commits by this committer
Remove USE_REINPLACE from categories starting with a J
31 Mar 2006 08:47:17
Original commit files touched by this commit  1.4.2p8_3
 This port version is marked as vulnerable.
linimon search for other commits by this committer
Reassign these ports from inactive maintainer to glewis, who has been doing
most of the work over the past year.

Hat:    portmgr
12 Feb 2006 00:28:23
Original commit files touched by this commit  1.4.2p8_3
 This port version is marked as vulnerable.
glewis search for other commits by this committer
. Link with the system libz instead of building the our own internal
  copy.  This should have the following effects:

  . Fix problems experienced by programmes that dynamically create their
    own copy of the JVM and are linked against the system's zlib (e.g.,
    eclipse).
  . Reduce the potential for zlib based security problems
    affecting the JDK.

  This is similar to the patch in the PR, but was actually backported from
  the patches for the jdk15 port, so its a touch different.

PR:             92459
20 Jan 2006 16:39:05
Original commit files touched by this commit  1.4.2p8_2
 This port version is marked as vulnerable.
glewis search for other commits by this committer
. Update to patchset 8.
07 Jan 2006 09:33:41
Original commit files touched by this commit  1.4.2p7_2
 This port version is marked as vulnerable.
dinoex search for other commits by this committer
- fix build in JAILS
failed to build the jdk14 port in a jail under FreeBSD 5.4
FreeBSD 4.11 works.

The problem is that mount don't list the linprocfs,
and this make the selfcheck fail.

maintainer emailed:
So  6 Nov 2005 11:21:20 CET

Approved by:    (maintainer timeout)
14 Dec 2005 16:52:32
Original commit files touched by this commit  1.4.2p7_2
 This port version is marked as vulnerable.
glewis search for other commits by this committer
. Tell the user all the files they will need up front, instead of telling
  lies about what they have and prompting them one file at a time.  This
  is a slight rewording of the submitted patch.

PR:             84644
Submitted by:   fenner
25 Nov 2005 03:39:42
Original commit files touched by this commit  1.4.2p7_2
 This port version is marked as vulnerable.
glewis search for other commits by this committer
. Make pkg-install install a symbolic link for the browser plugin if a
  valid one doesn't currently exist.
. Add a pkg-deinstall which removes the symbolic link if this port owns it.
. Produce pkg-install and pkg-deinstall with SUB_FILES and SUB_LIST rather
  than manually using ${SED} ourselves.

Approved by:    maintainer timeout
23 Nov 2005 16:50:01
Original commit files touched by this commit  1.4.2p7_2
 This port version is marked as vulnerable.
glewis search for other commits by this committer
. Add SHA256.
13 Oct 2005 15:09:11
Original commit files touched by this commit  1.4.2p7_2
 This port version is marked as vulnerable.
glewis search for other commits by this committer
. Fix javaws.
. Bump PORTREVISION.

PR:             81176
Submitted by:   "Thomas M. Hermann" <__tmh@yahoo.com>
03 Sep 2005 21:13:49
Original commit files touched by this commit  1.4.2p7_1
 This port version is marked as vulnerable.
glewis search for other commits by this committer
. Use ${PTHREAD_LIBS} when compiling the testos programme rather than
  inventing our own version.

Approved by:    phantom (maintainer)
11 May 2005 21:18:40
Original commit files touched by this commit  1.4.2p7_1
 This port version is marked as vulnerable.
glewis search for other commits by this committer
. Ensure that when files are extracted that their fully resolved path lies
  in or below the current working directory.  Fixes a security problem with
  jar(1).

  This fix may change to be compatible with whatever fix Sun applies when
  they release a fixed version of 1.5.
. Bump PORTREVISION for this fix.

Approved by:    maintainer timeout
Security: http://vuxml.FreeBSD.org/18e5428f-ae7c-11d9-837d-000e0c2e438a.html
18 Apr 2005 17:56:04
Original commit files touched by this commit  1.4.2p7
 This port version is marked as vulnerable.
glewis search for other commits by this committer
. Fix various problems with time zone handling including:
  . /etc/localtime is a symlink.
  . /etc/localtime contains a time zone not recognised by the JDK.

Submitted by:   Kurt Miller <truk@optonline.net>
30 Mar 2005 15:45:52
Original commit files touched by this commit  1.4.2p7
 This port version is marked as vulnerable.
glewis search for other commits by this committer
. Unbreak the packing list by adding explicit PLIST_FILES/PLIST_DIRS for
  files that are generated by the post-install script (which runs after
  the dynamic packing list has been generated).

Approved by:    portmgr (krion), phantom (maintainer)
18 Feb 2005 17:21:52
Original commit files touched by this commit  1.4.2p7
 This port version is marked as vulnerable.
glewis search for other commits by this committer
. Move the invocation of unregistervm to the top of the packing list.
  This ensures that this command is run before the files in the package
  are deleted (which is necessary for it to correctly delete the symbolic
  links created by registervm).

Approved by:    phantom (maintainer)
31 Jan 2005 16:47:37
Original commit files touched by this commit  1.4.2p7
 This port version is marked as vulnerable.
phantom search for other commits by this committer
Add support for picking up of motif includes and libraries via newly
added open-motif-jdk port.  It's controlled via WITH_OPENMOTIF_JDK
knob and currently disabled by default (it still requires additional
testing and checking)
29 Jan 2005 12:19:15
Original commit files touched by this commit  1.4.2p7
 This port version is marked as vulnerable.
phantom search for other commits by this committer
Unbreak plist generation
14 Jan 2005 15:53:08
Original commit files touched by this commit  1.4.2p7
 This port version is marked as vulnerable.
phantom search for other commits by this committer
Remove unused file
14 Jan 2005 15:50:22
Original commit files touched by this commit  1.4.2p7
 This port version is marked as vulnerable.
phantom search for other commits by this committer
Autogenerate PLIST while installing
12 Jan 2005 23:14:38
Original commit files touched by this commit  1.4.2p7
 This port version is marked as vulnerable.
phantom search for other commits by this committer
Do not remove /usr/local/share/doc/java on uninstall.

Submitted by:   pointyhat via kris
17 Dec 2004 07:09:00
Original commit files touched by this commit  1.4.2p7
 This port version is marked as vulnerable.
glewis search for other commits by this committer
. Avoid a problem where, without linprocfs mounted, the first line of
  a generated file will be overwritten with a warning, causing the
  build to fail.  There is a check for linprocfs in pre-build, but it
  seems as though this problem can somehow trigger anyway, based on
  semi-regular reports to the mailing lists.

PR:             74999
Approved by:    phantom
17 Dec 2004 07:02:51
Original commit files touched by this commit  1.4.2p7
 This port version is marked as vulnerable.
glewis search for other commits by this committer
. Update to patchset 7.
. Fix a permissions problem with the plugins directory.

Approved by:    phantom (maintainer)
03 Dec 2004 19:53:44
Original commit files touched by this commit  1.4.2p6_7
 This port version is marked as vulnerable.
glewis search for other commits by this committer
. Backport parts of the 1.5 plugin to address plugin vulnerabilities.
. Bump PORTVERSION.

Submitted by:   Kurt Miller <truk@optonline.net>
24 Nov 2004 15:16:39
Original commit files touched by this commit  1.4.2p6_6
 This port version is marked as vulnerable.
glewis search for other commits by this committer
. Mark FORBIDDEN when building with the browser plugin due to the
  vulnerabilities discussed in:

  http://sunsolve.sun.com/search/document.do?assetkey=1-26-57591-1
  http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2004-1029
02 Nov 2004 05:24:05
Original commit files touched by this commit  1.4.2p6_6
 This port version is marked as vulnerable.
glewis search for other commits by this committer
. Take into account that pthread_mutex_trylock() can return EDEADLK as
  well as EBUSY with libkse on FreeBSD 5.x.

Inspired by:    green
20 Oct 2004 23:22:56
Original commit files touched by this commit  1.4.2p6_6
 This port version is marked as vulnerable.
green search for other commits by this committer
The BSD patchset for the Sun JDK modeled its thread behavior mostly after
existing the Solaris base, and similarly to what happened with NSPR, made
a bad assumption on undefined behavior.  This broke locking in various
places in Java, for example, causing the the debugging support to be
totally broken.  It is worth someone who knows the Java codebase taking
a look to see what other things could have been broken by this on
FreeBSD 5.x+.

The assumption is that pthread_mutex_trylock(3) on a default-type
mutex will fail with EBUSY.  This assumption is wrong for our
libpthread, which returns EDEADLK if the owner thread is trying to
acquire the mutex again with trylock.  The behavior of performing a
locking operation on a self-locked default-type mutex is explicitly
undefined for pthread_mutex_lock(3).
(Only the first 15 lines of the commit message are shown above View all of this commit message)
16 Oct 2004 17:17:09
Original commit files touched by this commit  1.4.2p6_5
 This port version is marked as vulnerable.
glewis search for other commits by this committer
. Bump PORTREVISION for the recent fixes.
16 Oct 2004 17:16:40
Original commit files touched by this commit  1.4.2p6_4
 This port version is marked as vulnerable.
glewis search for other commits by this committer
. Fix the Server VM for gcc 3.4 part 2/2.
  The HotSpot code (ab)uses named enums as ints in a number of places.
  The problem with this is that according the the C++ spec, the compiler
  (essentially) only needs to use an integral type wide enough to hold
  the values defined in the enum.  Earlier versions of gcc appear to have
  just used an int whether they could have got away with a narrower type
  or not, hence the code worked as expected.  gcc 3.4 now appears to
  implement this part of the spec, so using an enum blindly as an int
  causes various problems due to overflow.

  In this case the enum, Bytecodes::Code, appears to be a genuine enum,
  its just assumed to be wide enough to hold an arbitrary int in various
  places in the code.  The correct fix would be to track down all those
  places in the code and fix them.  Since there are quite a lot of these
  places and 5.3 is close to release for now we just add a value to the
  enum set to INT_MAX, forcing the compiler to use at least an int for the
  type.

Sleuth work, discussion and code suggestions:   peadar
16 Oct 2004 17:12:22
Original commit files touched by this commit  1.4.2p6_4
 This port version is marked as vulnerable.
glewis search for other commits by this committer
. Fix the Server VM for gcc 3.4 part 1/2.
  The HotSpot code (ab)uses named enums as ints in a number of places.
  The problem with this is that according the the C++ spec, the compiler
  (essentially) only needs to use an integral type wide enough to hold
  the values defined in the enum.  Earlier versions of gcc appear to have
  just used an int whether they could have got away with a narrower type
  or not, hence the code worked as expected.  gcc 3.4 now appears to
  implement this part of the spec, so using an enum blindly as an int
  causes various problems due to overflow.

  This case is particularly bogus since the enums are merely to define
  a named integral type within a class (VMReg::Name doesn't even have
  any values enumerated in the declaration).  So, convert these two
  enums to simply be typedef'ed ints.

Sleuth work, discussion and code suggestions:   peadar
16 Oct 2004 17:00:28
Original commit files touched by this commit  1.4.2p6_4
 This port version is marked as vulnerable.
glewis search for other commits by this committer
. In the ReadChunk() function, change an assert() to be a "test for a
  condition and return NULL".  Take account of the NULL in the
  appropriate place (which is somewhat worrisome in itself since
  ReadChunk() has always had the possibility of returning NULL).
  This makes loading a font file a little more resilient to specially
  crafted font data which can be used, for example, by an applet to
  crash the browser plugin by triggering the assert().  Such an applet
  was mentioned on Bugtraq:

  http://www.securityfocus.com/archive/1/367331/2004-06-26/2004-07-02/0

  and can be found at

  http://www.illegalaccess.org/cms/?q=node/view/9

  This change stops the browser plugin from crashing.
. Fix some warnings regarding formats in debugging printf's.
16 Oct 2004 16:58:12
Original commit files touched by this commit  1.4.2p6_4
 This port version is marked as vulnerable.
glewis search for other commits by this committer
. At least on FreeBSD, O_SYNC and O_DSYNC aren't both defined
  (for FreeBSD 4.x neither are defined and for FreeBSD 5.x
  O_DSYNC isn't defined).  This caused them to be defined to
  some bogus values.  In particular, O_SYNC would be defined
  as 0x800, which is O_EXCL (at least on FreeBSD 4.x).  The
  result being that the RandomAccessFile class would fail to
  open an existing file if you specified "s" as part of the mode.
  Fix this by defining O_SYNC and O_DSYNC to O_FSYNC if they
  aren't defined.
02 Sep 2004 02:58:38
Original commit files touched by this commit  1.4.2p6_4
 This port version is marked as vulnerable.
glewis search for other commits by this committer
. Assume (un)registervm is in LOCALBASE _not_ PREFIX.
. Call unregistervm with the VM we registered, not the comment associated
  with it (as comments should be optional).
18 Aug 2004 07:06:03
Original commit files touched by this commit  1.4.2p6_4
 This port version is marked as vulnerable.
glewis search for other commits by this committer
. The changes to make in -CURRENT to use MAKEFLAGS make us unable to
  override the MAKEFLAGS ARCH value in the main HotSpot Makefile.  Fix
  this by passing in a blank MAKEFLAGS up front so there is nothing to
  (try to) override.

Submitted by:   truckman
Requested by:   kris
12 Aug 2004 21:54:01
Original commit files touched by this commit  1.4.2p6_4
 This port version is marked as vulnerable.
glewis search for other commits by this committer
. Fix the build for gcc 3.4.

PR:             69853
Submitted by:   Jake Hamby <jhamby@anobject.com>
Approved by:    phantom (maintainer)
20 Mar 2004 13:13:18
Original commit files touched by this commit  1.4.2p6_4
 This port version is marked as vulnerable.
phantom search for other commits by this committer
SIZEfy
05 Mar 2004 13:43:41
Original commit files touched by this commit  1.4.2p6_4
 This port version is marked as vulnerable.
phantom search for other commits by this committer
. Set LATEST_LINK [1]

. Fix rare NULL pointer de-reference bug in plugin code [2]

. Use better chinese fonts [3]

. Bump PORTREVISION

Requested by:   kris [1]
Submitted by:   Georg-W. Koltermann <gwk@rahn-koltermann.de> [2],
                Clive Lin <clive@tongi.org> [3]
04 Feb 2004 05:21:48
Original commit files touched by this commit  1.4.2p6_3
 This port version is marked as vulnerable.
marcus search for other commits by this committer
Bump PORTREVISION on all ports that depend on gettext to aid with upgrading.

(Part 2)
28 Jan 2004 14:00:27
Original commit files touched by this commit  1.4.2p6_2
 This port version is marked as vulnerable.
phantom search for other commits by this committer
1. Switch 5.x version of jdk14 back to libc_r as default threading library.
   We switched FreeBSD-5.x port to libkse as default threading library before
   releasing of patchset 6, but users who has most of stuff linked against
   libc_r and attempted to use jdk linked against libkse got into local hell
   of threading libraries mix.  So, rollback to libc_r by default and add
   PTHREAD_LIBS support for this port.

   IMPORTANT: In order to use libkse as threading library for jdk14 you
   have to use rtld's libmap feature or recompile your ports stuff (like
   mozilla) with libkse.

   NOTE: libkse still has issues with java debug support, so if you're going
   to use debuging (JVMDI) stuff - leave with libc_r for now.

2. Disable IPv6 support by default.  Unfortunatelly due to security reasons
(Only the first 15 lines of the commit message are shown above View all of this commit message)
28 Jan 2004 13:55:24
Original commit files touched by this commit  1.4.2p6_1
 This port version is marked as vulnerable.
phantom search for other commits by this committer
Update license to most recent SCSL license version.
23 Jan 2004 05:28:50
Original commit files touched by this commit  1.4.2p6_1
 This port version is marked as vulnerable.
trevor search for other commits by this committer
Use LS macro.
22 Jan 2004 12:18:43
Original commit files touched by this commit  1.4.2p6_1
 This port version is marked as vulnerable.
trevor search for other commits by this committer
Use the CPIO macro defined in bsd.port.mk.
22 Jan 2004 11:06:02
Original commit files touched by this commit  1.4.2p6_1
 This port version is marked as vulnerable.
trevor search for other commits by this committer
Use the SORT macro from bsd.port.mk.
17 Jan 2004 07:11:12
Original commit files touched by this commit  1.4.2p6_1
 This port version is marked as vulnerable.
glewis search for other commits by this committer
. Check the return value of stat(2) when trying to read the javaws
  configuration file and behave appropriately if its -1.  Fixes a SEGV
  caused by ignoring the return value and just carrying on.
. Bump PORTREVISION.

PR:             61392
14 Jan 2004 21:21:53
Original commit files touched by this commit  1.4.2p6
 This port version is marked as vulnerable.
glewis search for other commits by this committer
. Update to 1.4.2 patchset 6.
. Install the cacerts file from Sun's 1.4.2_03 release to avoid some
  problems associated with expired root certificates described in:

  http://sunsolve.sun.com/pub-cgi/retrieve.pl?doc=fsalert%2F57436

Hopefully not objected to by:   phantom
16 Dec 2003 06:50:59
Original commit files touched by this commit  1.4.2p5
 This port version is marked as vulnerable.
phantom search for other commits by this committer
Don't use patch release number while setting up BUILD_DEPENDS for
linux-sun-jdk.
17 Nov 2003 12:29:10
Original commit files touched by this commit  1.4.2p5
 This port version is marked as vulnerable.
trevor search for other commits by this committer
USE_REINPLACE need be defined only when REINPLACE_CMD is used.
12 Nov 2003 14:11:39
Original commit files touched by this commit  1.4.2p5
 This port version is marked as vulnerable.
phantom search for other commits by this committer
Fix path to patched file.

Reported by:    Nelis Lamprecht <nelis@brabys.co.za>
12 Nov 2003 12:38:03
Original commit files touched by this commit  1.4.2p5
 This port version is marked as vulnerable.
phantom search for other commits by this committer
Fix bootstrap jdk detection process, so it work in case if no valid jdk
installed.  Previously BUILD_DEPENDS was not set correctly.

Add all possible choices for 1.4.1/1.4.2 JDKs while auto-detecting.
12 Nov 2003 12:13:36
Original commit files touched by this commit  1.4.2p5
 This port version is marked as vulnerable.
phantom search for other commits by this committer
Add patch to fix build problems on 5.x system reported by many people.
It was last minute change and since this tool (unpack) is not used while
building jdk14 port, I did not paid enough attention to test this change
at -CURRENT system.  Sorry.
11 Nov 2003 16:16:20
Original commit files touched by this commit  1.4.2p5
 This port version is marked as vulnerable.
phantom search for other commits by this committer
Update to 1.4.2p5.

Important changes since last patchset:

. jdk14 port is now JDK 1.4.2 based!
. JavaWS distributing with jdk
. Runway problem fixed (fork() is no more problem for java apps)
. Sound support updated
. IPv6 support overhauled
. Drag'n'Drop support fixed (require open-motif mods)

As for now there's no more outstanding issues with this port!

FreeBSD port is also got a important of changes:

. optimized setup is now default (to get debuging bins/libs use WITH_DEBUG)

. bootstrap jdk autodetection.  If WITH_LINUX_BOOTSTRAP is not set, then
  it checks all known to work JDKs installed.  If nothing found, forces
  to install of linux-sun-jdk14

. Because of above change there's no NATIVE_BOOTSTRAP option anymore.  If
  native jdk14 is installed, it will be used by default.
10 Nov 2003 12:18:05
Original commit files touched by this commit  1.4.1p4_1
 This port version is marked as vulnerable.
phantom search for other commits by this committer
Don't redefine ECHO_MSG to echo explicitly.  It b0rked IGNORE messages.

PR:             java/58902
Reported by:    Linh Pham <question@closedsrc.org>
29 Oct 2003 08:20:59
Original commit files touched by this commit  1.4.1p4_1
 This port version is marked as vulnerable.
phantom search for other commits by this committer
. Add fix for "runaway process" problem.  It should fix of stalled
  processes problem for people who use Runtime.getRuntime.exec() method
  and related things.  Least five people reported that this patch fixed
  problem for them.

  IMPORTANT: I'd also suggested to all jdk14 users who runs FreeBSD 4.x
  and use libc_r at FreeBSD 5.x to upgrade.

. Stop removing "src.zip" from installation bundle.  Since -p4 it builds
  correctly and there's no reason to forbit people to use it.

. Bump PORTREVISION.
21 Oct 2003 00:10:05
Original commit files touched by this commit  1.4.1p4
 This port version is marked as vulnerable.
glewis search for other commits by this committer
. Sort PTHREAD_FILES.
. Add j2se/ext/plugin/build/solaris/GNUmakefile to PTHREAD_FILES.  Should
  fix plugin compilation on -CURRENT.  Mea culpa.

PR:             58269
Submitted by:   Scott Dodson <sdodson@sdodson.com>
13 Oct 2003 20:57:50
Original commit files touched by this commit  1.4.1p4
 This port version is marked as vulnerable.
glewis search for other commits by this committer
. Add a missing BUILD_DEPENDS on NSPR so the plugin builds.

Forgotten by:   glewis
13 Oct 2003 03:31:42
Original commit files touched by this commit  1.4.1p4
 This port version is marked as vulnerable.
glewis search for other commits by this committer
. Override PKGINSTALL to place it in WRKDIR, which is writeable, rather
  than PORTSDIR, which may not be.

Submitted by:   kris
11 Oct 2003 05:16:50
Original commit files touched by this commit  1.4.1p4
 This port version is marked as vulnerable.
glewis search for other commits by this committer
. Update to 1.4.1p4.
. Use ${PTHREAD_LIBS} rather than -pthread or -lc_r.
. Install system preferences to avoid annoying and constant error messages.

Approved by:    phantom (the update, anyway)
11 Oct 2003 05:13:11
Original commit files touched by this commit  1.4.1p3_3
 This port version is marked as vulnerable.
glewis search for other commits by this committer
. Unset -Werror when compiling the NIO stuff.  GCC 3.3.1 tends to generate
  warnings that 2.95 doesn't and breaks the build on -CURRENT.
01 Oct 2003 16:14:20
Original commit files touched by this commit  1.4.1p3_3
 This port version is marked as vulnerable.
glewis search for other commits by this committer
. Sync with the change to linux-sun-jdk14 (it now installs in
  /usr/local/linux-sun-jdk1.4.2) so this port will bootstrap.
08 Sep 2003 08:55:20
Original commit files touched by this commit  1.4.1p3_3
 This port version is marked as vulnerable.
phantom search for other commits by this committer
Update linux jdk location after recent linux-sun-jdk update to 1.4.2_01
04 Aug 2003 08:53:42
Original commit files touched by this commit  1.4.1p3_3
 This port version is marked as vulnerable.
phantom search for other commits by this committer
Warn users about requirement of having linprocfs mounted in order to
start native JDK port build.  linprocfs mounted become pre-requisite of
build after Linux SUN JDK port was updated to 1.4.2.

Add run-time (pre-build) check for linprocfs mounted as well.

Bump space requirements note about disk space required for build of
whole JDK 1.4.1 port and package to more appropriate value (as reported
by many people).
21 Jul 2003 07:31:05
Original commit files touched by this commit  1.4.1p3_3
 This port version is marked as vulnerable.
znerd search for other commits by this committer
Now expects bootstrap JDK in ${LOCALBASE}/linux-sun-jdk1.4.2.

Approved by:    MAINTAINER
08 May 2003 23:53:06
Original commit files touched by this commit  1.4.1p3_3
 This port version is marked as vulnerable.
phantom search for other commits by this committer
Unbreak package build after recent Greg's commit (which changed
include/bsd -> include/freebsd in sources, but not reflected
this change in pkg-plist)

Reported by:    Holger Kipp <Holger.Kipp@alogis.com>,
                Kunihiro Arai <kunihiro-arai@seagreen.ocn.ne.jp>
02 May 2003 15:49:02
Original commit files touched by this commit  1.4.1p3_3
 This port version is marked as vulnerable.
glewis search for other commits by this committer
. Add $FreeBSD$
. Put the MD JNI headers in include/freebsd _not_ include/bsd.  This
  brings the 1.4 port in line with 1.1, 1.2 and 1.3, and arguably inline
  with Solaris and Linux.

Not-objected-to by:     phantom
13 Mar 2003 21:43:36
Original commit files touched by this commit  1.4.1p3_2
 This port version is marked as vulnerable.
phantom search for other commits by this committer
Add runtime test to check of required libc_r functionality.  I.e. warn
people about requirement of libc_r updates as early as possible.

Bump PORTREVISION

Approved by:    portmgr (kris) (implicitly)
13 Mar 2003 11:24:43
Original commit files touched by this commit  1.4.1p3_1
 This port version is marked as vulnerable.
phantom search for other commits by this committer
Add notice about amount of disk space required
13 Mar 2003 11:17:04
Original commit files touched by this commit  1.4.1p3_1
 This port version is marked as vulnerable.
phantom search for other commits by this committer
Correct pkg-plist

Submitted by:   olgeni, glewis
13 Mar 2003 11:15:24
Original commit files touched by this commit  1.4.1p3_1
 This port version is marked as vulnerable.
phantom search for other commits by this committer
Make sure that demo/jfc/SwingSet2/resources does not exists (it should not,
but sometimes leaves in)
13 Mar 2003 11:13:16
Original commit files touched by this commit  1.4.1p3_1
 This port version is marked as vulnerable.
phantom search for other commits by this committer
Fix build on 5.0-RELEASE
11 Mar 2003 08:55:41
Original commit files touched by this commit  1.4.1p3_1
 This port version is marked as vulnerable.
phantom search for other commits by this committer
Bump PORTREVISION
11 Mar 2003 08:54:30
Original commit files touched by this commit  1.4.1p3
 This port version is marked as vulnerable.
phantom search for other commits by this committer
Since we have problems with running debuging binaries on some machines
(old K6 and some SMP machines) don't use javah_g in build process.

Reported by:    many people

Number of commits found: 102 (showing only 100 on this page)

1 | 2  »  

Login
User Login
Create account

Servers and bandwidth provided by
New York Internet, SuperNews, and RootBSD

This site
What is FreshPorts?
About the authors
FAQ
How big is it?
The latest upgrade!
Privacy
Forums
Blog
Contact

Search
Enter Keywords:
 
more...

Latest Vulnerabilities
asterisk11Sep 18
squidSep 18
squid33Sep 18
dbusSep 17
nginxSep 16
nginx-develSep 16
phpmyadminSep 13
ossec-hids-clientSep 11
ossec-hids-localSep 11
ossec-hids-serverSep 11
chromiumSep 09
trafficserverSep 05
apache22*Sep 03
apache22-event-mpm*Sep 03
apache22-itk-mpm*Sep 03

8 vulnerabilities affecting 19 ports have been reported in the past 14 days

* - modified, not new

All vulnerabilities


Ports
Home
Categories
Deleted ports
Sanity Test Failures
Newsfeeds


Statistics
Graphs
NEW Graphs (Javascript)
Traffic

Calculated hourly:
Port count 24131
Broken 116
Deprecated 46
Ignore 370
Forbidden 3
Restricted 205
No CDROM 94
Vulnerable 20
Expired 1
Set to expire 41
Interactive 0
new 24 hours 0
new 48 hours72
new 7 days92
new fortnight140
new month295

Servers and bandwidth provided by
New York Internet, SuperNews, and RootBSD
Valid HTML, CSS, and RSS.
Copyright © 2000-2014 Dan Langille. All rights reserved.