FreshPorts -- The Place For Ports If you buy from Amazon USA, please support us by using this link.
Follow us
Blog
Twitter

non port: head/lang/gnatdroid-sysroot/distinfo
SVNWeb

Number of commits found: 5

Wed, 16 Mar 2016
[ 14:36 marino ] Original commit   Revision:411236
411236 lang/gnatdroid-armv7/Makefile
411236 lang/gnatdroid-armv7/pkg-descr
411236 lang/gnatdroid-armv7/pkg-plist
411236 lang/gnatdroid-sysroot-x86/Makefile
411236 lang/gnatdroid-sysroot-x86/distinfo
411236 lang/gnatdroid-sysroot-x86/pkg-descr
411236 lang/gnatdroid-sysroot/Makefile
411236 lang/gnatdroid-sysroot/distinfo
411236 lang/gnatdroid-sysroot/pkg-descr
411236 lang/gnatdroid-x86/pkg-descr
Rebase gnatdroid to gcc6-aux (6.0), add support for MARSHMELLOW

The gnatdroid cross-compilers (*BSD => Android) were the last two users
of gcc-aux (gcc 4.9 Ada compiler).  They are now based on gcc6-aux.

The Android NDK release 11 just came out with support for Android API 23
(Marshmellow) so now gnatdroid supports it.  I removed API 8 and 9
(Froyo and Gingerbread) from gnatdroid-armv7.  Froyo currently is installed
on less than 0.1% of Android devices, and Gingerbread is dropping under 2%
soon.  Many sysroot distfiles were re-rolled to gain required headers, so
a distfiles subdirectory was added as well.
Mon, 19 Oct 2015
[ 19:42 marino ] Original commit   Revision:399716
399716 lang/gcc-aux/Makefile.version
399716 lang/gcc-aux/files/patch-libstdc++-v3_config_os_bionic_ctype__base.h
399716 lang/gnatdroid-armv7/Makefile
399716 lang/gnatdroid-binutils/Makefile
399716 lang/gnatdroid-sysroot/Makefile
399716 lang/gnatdroid-sysroot/distinfo
399716 lang/gnatdroid-sysroot/files/extra-21-stat.h
399716 lang/gnatdroid-sysroot/files/extra-stat.h
399716 lang/gnatdroid-sysroot/files/patch-stat.h
399716 lang/gnatdroid-sysroot/pkg-descr
gnatdroid-sysroot: Add Android API Level 21 (Lollipop)

The latest Android Native Development Kit (NDK) has API Level 21
in it (but not 20, nor 22 or the latest Level 23).  Add this option
to gnatdroid's sysroot port, and change the default API from Jelly Bean 1
(Level 16) to Kitkat (Level 19).

Bump gnatdroid's binutils and gnatdroid itself as a consequence of this
default change.  A new patch had to be added to lang/gcc-aux to handle
the CTYPE changes which haven't made to GCC yet.

Gnatdroid has been testing for building on all API's but not for
functionality beyond Level 16 due to lack of hardware.  I may soon
install an Android emulator to see if that will suffice.
Thu, 10 Apr 2014
[ 00:34 marino ] Original commit   Revision:350752
350752 lang/gnatdroid-armv5/Makefile
350752 lang/gnatdroid-armv5/files/acats.diff
350752 lang/gnatdroid-armv5/pkg-plist
350752 lang/gnatdroid-armv7/Makefile
350752 lang/gnatdroid-armv7/files/acats.diff
350752 lang/gnatdroid-armv7/pkg-plist
350752 lang/gnatdroid-binutils/Makefile
350752 lang/gnatdroid-sysroot/Makefile
350752 lang/gnatdroid-sysroot/distinfo
350752 lang/gnatdroid-sysroot/pkg-plist
lang/gnatdroid-*: Support multiple API, base on gcc-aux (gcc 4.9)

This represents major changes with gnatdroid.

The sysroot is no longer API 9 or 19, but a choice of API 8, 9, 15,
16, 17, 18, or 19.  The prefix is not androidX but just "android".
The binutils port had to be adjusted due to the prefix change.

Finally, gnatdroid-armv(5,7) was substancially reworked to use
gcc-aux (4.9) instead of gcc47-aux (4.7).  This means the new ARM
unwinder is in use (zero cost exceptions).  Only 6 ACATS tests are
failing, they are related to the missing stack check capability.

Future work will speed up ACATS remote device testing and hopefully
enable gnat.dg testing too.
Sun, 6 Apr 2014
[ 11:32 marino ] Original commit   Revision:350350
350350 lang/gnatdroid-armv5/Makefile
350350 lang/gnatdroid-armv5/files/pkg-message.in
350350 lang/gnatdroid-armv5/pkg-descr
350350 lang/gnatdroid-armv5/pkg-plist
350350 lang/gnatdroid-armv7/Makefile
350350 lang/gnatdroid-armv7/files/pkg-message.in
350350 lang/gnatdroid-armv7/pkg-descr
350350 lang/gnatdroid-armv7/pkg-plist
350350 lang/gnatdroid-binutils/Makefile
350350 lang/gnatdroid-binutils/pkg-plist

(Only the first 10 of 14 ports in this commit are shown above. View all ports for this commit)
lang/gnatdroid-*: Update sysroot to Android API level 9 -> level 19

This is the first of two steps to update the gnatdroid ARM cross-
compilers.  The sysroot was 10 versions behind the current API level
of 19.  The latest API level drops ARMv5 support, but the API is
backwards compatible, so if applications restrict themselves to
level 18 features, then ARMv5 should still be usable.

The next step is to base the cross compilers on GCC 4.9 instead of the
GCC 4.7-based gcc47-aux port.
Mon, 5 Sep 2011
[ 12:53 culot ] Original commit 
1.740 lang/Makefile
1.1 lang/gnatdroid-sysroot/Makefile
1.1 lang/gnatdroid-sysroot/distinfo
1.1 lang/gnatdroid-sysroot/files/patch-stat.h
1.1 lang/gnatdroid-sysroot/pkg-descr
1.1 lang/gnatdroid-sysroot/pkg-plist
This package is used by lang/gnatdroid to install the system root of
Android 2.3 (API Level 9) of the ARM architecture. The ARM cross-tools
are built using these files, which in turn is required for the GNAT
FreeBSD->ARM cross-compiler that is gnatdroid.

WWW: http://www.dragonlace.net

PR:             ports/160423
Submitted by:   John Marino <freebsdml@marino.st>

Number of commits found: 5

Login
User Login
Create account

Servers and bandwidth provided by
New York Internet, SuperNews, and RootBSD

This site
What is FreshPorts?
About the authors
Issues
FAQ
How big is it?
The latest upgrade!
Privacy
Forums
Blog
Contact

Search
Enter Keywords:
 
more...

Latest Vulnerabilities
bind9-develSep 28
bind910Sep 28
bind911Sep 28
bind99Sep 28
libresslSep 26
libressl-develSep 26
opensslSep 26
openssl-develSep 26
openssl*Sep 23
openssl-devel*Sep 23
irssi*Sep 22
irssi*Sep 22
firefoxSep 20
firefox*Sep 20
firefox-esrSep 20

11 vulnerabilities affecting 36 ports have been reported in the past 14 days

* - modified, not new

All vulnerabilities


Ports
Home
Categories
Deleted ports
Sanity Test Failures
Newsfeeds

Statistics
Graphs
NEW Graphs (Javascript)
Traffic

Calculated hourly:
Port count 26278
Broken 375
Deprecated 218
Ignore 639
Forbidden 0
Restricted 199
No CDROM 83
Vulnerable 61
Expired 14
Set to expire 204
Interactive 0
new 24 hours 5
new 48 hours15
new 7 days34
new fortnight66
new month122

Servers and bandwidth provided by
New York Internet, SuperNews, and RootBSD
Valid HTML, CSS, and RSS.
Copyright © 2000-2014 Dan Langille. All rights reserved.