FreshPorts -- The Place For Ports If you buy from Amazon USA, please support us by using this link.
Follow us
Blog
Twitter

Port details
php5 PHP Scripting Language
5.4.45 lang on this many watch lists=384 search for ports that depend on this port An older version of this port was marked as vulnerable. Find issues related to this port Report an issue related to this port
Deprecated DEPRECATED: PHP 5.4 is End of Life http://php.net/supported-versions.php
Expired This port expired on: 2016-01-15
Maintainer: ale@FreeBSD.org search for ports maintained by this maintainer
Port Added: 16 Jul 2003 11:00:27
Also Listed In: devel www
License: PHP301
PHP, which stands for "PHP: Hypertext Preprocessor" is a widely-used Open
Source general-purpose scripting language that is especially suited for
Web development and can be embedded into HTML.  Its syntax draws upon C,
Java, and Perl, and is easy to learn.  The main goal of the language is to
allow web developers to write dynamically generated webpages quickly, but
you can do much more with PHP.

WWW: http://www.php.net/
SVNWeb : Homepage : Distfiles Availability : PortsMon

To install the port: cd /usr/ports/lang/php5/ && make install clean
To add the package: pkg install php5

PKGNAME: php5


Slave ports
  1. archivers/php5-bz2
  2. archivers/php5-phar
  3. archivers/php5-zip
  4. archivers/php5-zlib
  5. converters/php5-iconv
  6. converters/php5-mbstring
  7. converters/php5-recode
  8. databases/php5-dba
  9. databases/php5-interbase
  10. databases/php5-mssql
  11. databases/php5-mysql
  12. databases/php5-mysqli
  13. databases/php5-odbc
  14. databases/php5-pdo
  15. databases/php5-pdo_dblib
  16. databases/php5-pdo_firebird
  17. databases/php5-pdo_mysql
  18. databases/php5-pdo_odbc
  19. databases/php5-pdo_pgsql
  20. databases/php5-pdo_sqlite
  21. databases/php5-pgsql
  22. databases/php5-sqlite3
  23. databases/php5-sybase_ct
  24. devel/php5-gettext
  25. devel/php5-json
  26. devel/php5-pcntl
  27. devel/php5-readline
  28. devel/php5-shmop
  29. devel/php5-sysvmsg
  30. devel/php5-sysvsem
  31. devel/php5-sysvshm
  32. devel/php5-tokenizer
  33. ftp/php5-curl
  34. ftp/php5-ftp
  35. graphics/php5-exif
  36. graphics/php5-gd
  37. mail/php5-imap
  38. math/php5-bcmath
  39. math/php5-gmp
  40. misc/php5-calendar
  41. net/php5-ldap
  42. net/php5-soap
  43. net/php5-sockets
  44. net/php5-xmlrpc
  45. net-mgmt/php5-snmp
  46. security/php5-filter
  47. security/php5-hash
  48. security/php5-mcrypt
  49. security/php5-openssl
  50. sysutils/php5-fileinfo
  51. sysutils/php5-posix
  52. textproc/php5-ctype
  53. textproc/php5-dom
  54. textproc/php5-pspell
  55. textproc/php5-simplexml
  56. textproc/php5-wddx
  57. textproc/php5-xml
  58. textproc/php5-xmlreader
  59. textproc/php5-xmlwriter
  60. textproc/php5-xsl
  61. www/mod_php5
  62. www/php5-session
  63. www/php5-tidy

NOTE: FreshPorts displays only information on required and default dependencies. Optional dependencies are not covered.

Build dependencies:
  1. autoconf-2.69 : devel/autoconf
Library dependencies:
  1. libpcre.so : devel/pcre
  2. libxml2.so : textproc/libxml2

This port is required by:

for Build
  1. archivers/php5-bz2
  2. archivers/php5-phar
  3. archivers/php5-zip
  4. archivers/php5-zlib
  5. chinese/php5-cconv*
  6. converters/igbinary*
  7. converters/php5-iconv
  8. converters/php5-mbstring
  9. converters/php5-recode
  10. databases/pecl-yac*
  11. databases/php-sqlrelay*
  12. databases/php4-rrdtool*
  13. databases/php5-dba
  14. databases/php5-interbase
  15. databases/php5-mssql
  16. databases/php5-mysql
  17. databases/php5-mysqli
  18. databases/php5-odbc
  19. databases/php5-pdo
  20. databases/php5-pdo_dblib
  21. databases/php5-pdo_firebird
  22. databases/php5-pdo_mysql
  23. databases/php5-pdo_odbc
  24. databases/php5-pdo_pgsql
  25. databases/php5-pdo_sqlite
  26. databases/php5-pgsql
  27. databases/php5-redis*
  28. databases/php5-sqlite*
  29. databases/php5-sqlite3
  30. databases/php5-sybase_ct
  31. databases/xapian-bindings10*
  32. devel/php5-gettext
  33. devel/php5-json
  34. devel/php5-pcntl
  35. devel/php5-readline
  36. devel/php5-shmop
  37. devel/php5-sysvmsg
  38. devel/php5-sysvsem
  39. devel/php5-sysvshm
  40. devel/php5-tokenizer
  41. devel/simpletest*
  42. ftp/php5-curl
  43. ftp/php5-ftp
  44. graphics/php5-exif
  45. graphics/php5-gd
  46. graphics/php5-swfed*
  47. lang/php5-extensions
  48. mail/php5-imap
  49. math/php5-bcmath
  50. math/php5-gmp
  51. misc/php5-calendar
  52. net/php5-ldap
  53. net/php5-soap
  54. net/php5-sockets
  55. net/php5-xmlrpc
  56. net-mgmt/php5-snmp
  57. security/php5-filter
  58. security/php5-hash
  59. security/php5-mcrypt
  60. security/php5-openssl
  61. sysutils/php5-fileinfo
  62. sysutils/php5-posix
  63. textproc/php5-ctype
  64. textproc/php5-dom
  65. textproc/php5-pspell
  66. textproc/php5-simplexml
  67. textproc/php5-wddx
  68. textproc/php5-xml
  69. textproc/php5-xmlreader
  70. textproc/php5-xmlwriter
  71. textproc/php5-xsl
  72. textproc/xaira*
  73. www/pecl-zendopcache
  74. www/pecl-zendoptimizerplus*
  75. www/php5-session
  76. www/php5-tidy
for Run
  1. archivers/php5-bz2
  2. archivers/php5-phar
  3. archivers/php5-zip
  4. archivers/php5-zlib
  5. chinese/php5-cconv*
  6. converters/igbinary*
  7. converters/php5-iconv
  8. converters/php5-mbstring
  9. converters/php5-recode
  10. databases/mywwwatcher*
  11. databases/pear-Doctrine12*
  12. databases/pear-MDB2_Driver_ibase*
  13. databases/pecl-yac*
  14. databases/php-sqlrelay*
  15. databases/php4-rrdtool*
  16. databases/php5-creole*
  17. databases/php5-dba
  18. databases/php5-interbase
  19. databases/php5-mssql
  20. databases/php5-mysql
  21. databases/php5-mysqli
  22. databases/php5-odbc
  23. databases/php5-pdo
  24. databases/php5-pdo_dblib
  25. databases/php5-pdo_firebird
  26. databases/php5-pdo_mysql
  27. databases/php5-pdo_odbc
  28. databases/php5-pdo_pgsql
  29. databases/php5-pdo_sqlite
  30. databases/php5-pgsql
  31. databases/php5-propel*
  32. databases/php5-redis*
  33. databases/php5-sqlite*
  34. databases/php5-sqlite3
  35. databases/php5-sybase_ct
  36. databases/phpmyadmin35*
  37. databases/xapian-bindings10*
  38. deskutils/fengoffice*
  39. deskutils/horde4-kronolith*
  40. deskutils/horde4-mnemo*
  41. deskutils/horde4-nag*
  42. deskutils/phpgroupware*
  43. deskutils/phprojekt*
  44. devel/horde4-content*
  45. devel/horde4-timeobjects*
  46. devel/horde4-whups*
  47. devel/pear-PHPUnit2*
  48. devel/php5-gettext
  49. devel/php5-json
  50. devel/php5-pcntl
  51. devel/php5-phing*
  52. devel/php5-readline
  53. devel/php5-shmop
  54. devel/php5-sysvmsg
  55. devel/php5-sysvsem
  56. devel/php5-sysvshm
  57. devel/php5-tokenizer
  58. devel/simpletest*
  59. dns/poweradmin*
  60. editors/gphpedit*
  61. ftp/horde4-gollem*
  62. ftp/php5-curl
  63. ftp/php5-ftp
  64. games/hlstats*
  65. graphics/php5-chartdirector*
  66. graphics/php5-exif
  67. graphics/php5-gd
  68. graphics/php5-swfed*
  69. lang/php5-extensions
  70. mail/horde-dimp*
  71. mail/horde-forwards*
  72. mail/horde-mimp*
  73. mail/horde-vacation*
  74. mail/horde3-dimp*
  75. mail/horde3-forwards*
  76. mail/horde3-imp*
  77. mail/horde3-ingo*
  78. mail/horde3-mimp*
  79. mail/horde3-turba*
  80. mail/horde3-vacation*
  81. mail/horde4-ingo*
  82. mail/horde4-turba*
  83. mail/ilohamail*
  84. mail/ilohamail-devel*
  85. mail/php5-imap
  86. mail/squirrelmail-calendar_sql_backend-plugin*
  87. mail/squirreloutlook*
  88. mail/uebimiau*
  89. math/php5-bcmath
  90. math/php5-gmp
  91. math/rkward*
  92. misc/callid*
  93. misc/php5-calendar
  94. net/php5-ldap
  95. net/php5-soap
  96. net/php5-sockets
  97. net/php5-xmlrpc
  98. net-im/msn-proxy*
  99. net-mgmt/better-cacti-templates*
  100. net-mgmt/fruity*
  101. net-mgmt/ipacco*
  102. net-mgmt/nagios-devel*
  103. net-mgmt/netams-front*
  104. net-mgmt/php5-snmp
  105. net-mgmt/zabbix-frontend*
  106. net-p2p/vhcp*
  107. print/phppdflib*
  108. security/php-Auth_OpenID*
  109. security/php-Auth_OpenID2*
  110. security/php5-filter
  111. security/php5-hash
  112. security/php5-mcrypt
  113. security/php5-openssl
  114. security/snortsms*
  115. sysutils/dtc*
  116. sysutils/loganalyzer*
  117. sysutils/php5-fileinfo
  118. sysutils/php5-posix
  119. sysutils/syscp*
  120. textproc/php5-ctype
  121. textproc/php5-dom
  122. textproc/php5-pspell
  123. textproc/php5-simplexml
  124. textproc/php5-wddx
  125. textproc/php5-xml
  126. textproc/php5-xmlreader
  127. textproc/php5-xmlwriter
  128. textproc/php5-xsl
  129. textproc/simplehtmldom*
  130. www/ajaxplorer*
  131. www/autoindex*
  132. www/autoindex2*
  133. www/cakephp11*
  134. www/cakephp12*
  135. www/cakephp13*
  136. www/cakephp2*
  137. www/cakephp21*
  138. www/cakephp22*
  139. www/cakephp23*
  140. www/clickheat*
  141. www/codeigniter17*
  142. www/docebo*
  143. www/dokeos*
  144. www/dwoo*
  145. www/eyeos*
  146. www/fluxcms*
  147. www/fusionpbx*
  148. www/gallery*
  149. www/horde3-base*
  150. www/horde4-ansel*
  151. www/horde4-base*
  152. www/horde4-passwd*
  153. www/horde4-wicked*
  154. www/ilias3*
  155. www/jawstats*
  156. www/joomla*
  157. www/lifetype*
  158. www/mambo*
  159. www/mawstats*
  160. www/mediawiki*
  161. www/mediawiki116*
  162. www/mediawiki118*
  163. www/mediawiki120*
  164. www/mediawiki121*
  165. www/mediawiki122*
  166. www/mod_php5
  167. www/moodle*
  168. www/moodle2*
  169. www/moodle22*
  170. www/moodle23*
  171. www/moodle24*
  172. www/moodle25*
  173. www/moodle26*
  174. www/notftp*
  175. www/ojs2*
  176. www/openx*
  177. www/pecl-zendopcache
  178. www/pecl-zendoptimizerplus*
  179. www/php5-session
  180. www/php5-tidy
  181. www/phpgedview*
  182. www/phpscheduleit*
  183. www/phpsysinfo-dev*
  184. www/pivot-weblog*
  185. www/prado*
  186. www/siteatschool*
  187. www/smarty*
  188. www/twig-php*
  189. www/typo344*
  190. www/typo345*
  191. www/typo346*
  192. www/typo347*
  193. www/vtiger*
  194. www/wacko*
  195. www/webcalendar*
  196. www/webcalendar-devel*
* - deleted ports are only shown under the This port is required by section. It was harder to do for the Required section. Perhaps later...
Configuration Options
===> The following configuration options are available for php5-5.4.45:
     CLI=on: Build CLI version
     CGI=on: Build CGI version
     FPM=on: Build FPM version
     EMBED=off: Build embedded library
     DEBUG=off: Enable debug
     DTRACE=off: Enable DTrace support
     IPV6=on: Enable ipv6 support
     MAILHEAD=off: Enable mail header patch
     LINKTHR=on: Link thread lib (for threaded extensions)
     ZTS=off: Force Zend Thread Safety (ZTS) build
===> Use 'make config' to modify these settings

USES:
tar:bzip2 cpe

Master Sites:
  1. http://br.php.net/distributions/
  2. http://cn.php.net/distributions/
  3. http://de.php.net/distributions/
  4. http://distcache.FreeBSD.org/ports-distfiles/
  5. http://dk1.php.net/distributions/
  6. http://es.php.net/distributions/
  7. http://fr.php.net/distributions/
  8. http://gr.php.net/distributions/
  9. http://it.php.net/distributions/
  10. http://jp.php.net/distributions/
  11. http://se.php.net/distributions/
  12. http://uk3.php.net/distributions/
  13. http://us2.php.net/distributions/
Notes from UPDATING
These upgrade notes are taken from /usr/ports/UPDATING
  • 2014-02-11
    Affects: users of lang/php* database/postgresql* database/mysql* www/apache*
    Author: mat@FreeBSD.org
    Reason: 
      The default versions of lang/php*, databases/postgresql*,
      databases/mysql* and www/apache* have been changed to support the
      new DEFAULT_VERSIONS variable.
    
      DEFAULT_APACHE_VER, DEFAULT_MYSQL_VER, DEFAULT_PGSQL_VER,
      DEFAULT_FPC_VER and DEFAULT_PHP_VER are now deprecated.  You can use
      the new DEFAULT_VERSIONS variable like this:
    
      DEFAULT_VERSIONS=php=5.5 mysql=5.6 apache=2.4
    
    
  • 2012-05-16
    Affects: users of lang/php5
    Author: ale@FreeBSD.org
    Reason: 
      PHP has been updated to 5.4. Suhosin patch has been disabled until the
      new version will be released (soon). Suhosing extension will take more
      time. LINKTHR option is now enabled by default, be sure to flag it if
      you are updating using an old saved configuration. sqlite2 extension
      has been permanently removed.
      If you want to remain at PHP 5.3, a new port (lang/php53) has been
      created for such purpose.
    
    
  • 2010-04-09
    Affects: users of lang/php5
    Author: ale@FreeBSD.org
    Reason: 
      As of PHP 5.3, a few extensions were removed from or included into the core
      PHP5 package.  Follow the steps below to update your installation.
    
      1) Delete the following packages (if installed):
    
         - php5-dbase
         - php5-ncurses
         - php5-pcre
         - php5-spl
         - php5-ming
         - php5-mhash
    
      2) Rebuild lang/php5 and all ports that depend on it.
    
    
  • 2008-12-11
    Affects: users of lang/php5
    Author: pav@FreeBSD.org, itetcu@FreeBSD.org, ale@FreeBSD.org
    Reason: 
      As of PHP 5.2.7, pcre extension is distributed with the core PHP5 package,
      and not as a standalone module anymore.  Follow the steps below to update
      your installation.
    
      Portupgrade users:
    
    	pkg_delete -f php5-pcre-5.2.6
    	pkgdb -F
    	portupgrade as usual
    
      Portmaster users:
    
    	pkg_delete -f php5-pcre\*
    	portmaster php5
    
      If you are using pecl ports you might need to force an update on them:
    
    	portupgrade -f pecl\*
      or
    	portmaster pecl
    
      If you have the pecl hash, json and/or zip extensions you need to replace
      them with the PHP5 bundled ones, e.g.:
    
    	portmaster/portupgrade -o archivers/php5-zip archivers/pecl-zip
    	portmaster/portupgrade -o devel/php5-json devel/pecl-json
    	portmaster/portupgrade -o security/php5-hash security/pecl-hash
    
      If you build your INDEX locally and you tried to build it after the PHP
      update commit, you need to rebuild it _after_ you updated lang/php5:
    
    	cd /usr/ports && make index
    
      or (if you use ports-mgmt/p5-FreeBSD-Portindex):
    
    	cd /usr/ports && cache-init && portindex -o `make -V INDEXFILE`
    
    
Port Moves
  • port moved here from devel/php5-pcre on 2010-04-09
    REASON: Bundled in core php

  • port moved here from devel/php5-spl on 2010-04-09
    REASON: Bundled in core php

Number of commits found: 347 (showing only 100 on this page)

1 | 2 | 3 | 4  »  

Commit History - (may be incomplete: see SVNWeb link above for full details)
DateByDescription
10 Jan 2016 16:47:31
Original commit files touched by this commit  5.4.45
Revision:405723
bapt search for other commits by this committer
Finish conversion to USES=sqlite
10 Jan 2016 16:46:22
Original commit files touched by this commit  5.4.45
Revision:405722
bapt search for other commits by this committer
Finish conversion to USES=firebird
10 Jan 2016 16:44:24
Original commit files touched by this commit  5.4.45
Revision:405721
bapt search for other commits by this committer
Convert categories m* and m* to USES=sqlite and USES=firebird
15 Dec 2015 14:53:35
Original commit files touched by this commit  5.4.45
Revision:403784
ale search for other commits by this committer
Switch to onigurum5 port and bump PORTREVISION.
15 Oct 2015 14:55:14
Original commit files touched by this commit  5.4.45
Revision:399346  Sanity Test Failure
mat search for other commits by this committer
Drop 8 support.

With hat:	portmgr
Sponsored by:	Absolight
Differential Revision:	https://reviews.freebsd.org/D3694
14 Oct 2015 20:50:59
Original commit files touched by this commit  5.4.45
Revision:399296
feld search for other commits by this committer
lang/php5: Move DEPRECATED and EXPIRATION_DATE so slave ports will pick
it up too.
14 Oct 2015 20:04:44
Original commit files touched by this commit  5.4.45
Revision:399292
feld search for other commits by this committer
lang/php5 mark as deprecated

PHP 5.4 has reached End of Life status

PR:		203552
10 Sep 2015 16:27:19
Original commit files touched by this commit  5.4.45
Revision:396579
feld search for other commits by this committer
lang/php5: Update to 5.4.45

PR:		202906
Approved by:	ports-secteam (with hat)
Security:	CVE-2015-6834
Security:	CVE-2015-6835
Security:	CVE-2015-6836
Security:	CVE-2015-6837
Security:	CVE-2015-6838
Security:	3d675519-5654-11e5-9ad8-14dae9d210b8
17 Aug 2015 14:20:41
Original commit files touched by this commit  5.4.44
Revision:394508 This port version is marked as vulnerable.
mat search for other commits by this committer
Remove UNIQUENAME and LATEST_LINK.

UNIQUENAME was never unique, it was only used by USE_LDCONFIG and now,
we won't have conflicts there.

Use PKGBASE instead of LATEST_LINK in PKGLATESTFILE, the *only* consumer
is pkg-devel, and it works just fine without LATEST_LINK as pkg-devel
has the correct PKGNAME anyway.

Now that UNIQUENAME is gone, OPTIONSFILE is too. (it's been called
OPTIONS_FILE now.)

Reviewed by:	antoine, bapt
Exp-run by:	antoine
Sponsored by:	Absolight
Differential Revision:	https://reviews.freebsd.org/D3336
15 Aug 2015 08:37:26
Original commit files touched by this commit  5.4.44
Revision:394290 This port version is marked as vulnerable.
ale search for other commits by this committer
Update to 5.4.44 release.
11 Jul 2015 12:13:06
Original commit files touched by this commit  5.4.43
Revision:391736 This port version is marked as vulnerable.
ale search for other commits by this committer
Update to 5.4.43 release.
22 Jun 2015 18:33:22
Original commit files touched by this commit  5.4.42
Revision:390310 This port version is marked as vulnerable.
antoine search for other commits by this committer
Convert to USES=jpeg
14 Jun 2015 20:23:10
Original commit files touched by this commit  5.4.42
Revision:389655 This port version is marked as vulnerable.
ale search for other commits by this committer
Update PHP ports:

- php5 to 5.4.42
- php55 to 5.5.26
- php56 to 5.6.10
24 May 2015 20:30:32
Original commit files touched by this commit  5.4.41
Revision:387331 This port version is marked as vulnerable.
ale search for other commits by this committer
Update to 5.4.41 release.
14 May 2015 10:15:09
Original commit files touched by this commit  5.4.40
Revision:386312 This port version is marked as vulnerable.
mat search for other commits by this committer
MASTER_SITES cleanup.

- Replace ${MASTER_SITE_FOO} with FOO.
- Merge MASTER_SITE_SUBDIR into MASTER_SITES when possible. (This means 99.9%
  of the time.)
- Remove occurrences of MASTER_SITE_LOCAL when no subdirectory was present and
  no hint of what it should be was present.
- Fix some logic.
- And generally, make things more simple and easy to understand.

While there, add magic values to the FESTIVAL, GENTOO, GIMP, GNUPG, QT and
SAMBA macros.

Also, replace some EXTRACT_SUFX occurences with USES=tar:*.

Checked by:	make fetch-urlall-list
With hat:	portmgr
Sponsored by:	Absolight
02 May 2015 19:08:44
Original commit files touched by this commit  5.4.40
Revision:385208 This port version is marked as vulnerable.
sbruno search for other commits by this committer
Disable FPM on mips/mips64 due to lack of ASM implementations for these
architectures.

PR:	197128
26 Apr 2015 06:51:55
Original commit files touched by this commit  5.4.40
Revision:384756 This port version is marked as vulnerable.
delphij search for other commits by this committer
Security update to 5.4.40.

Submitted by:	Bernard Spil <spil.oss gmail com> with changes.
MFH:		2015Q2
01 Apr 2015 08:39:15
Original commit files touched by this commit  5.4.39
Revision:382896 This port version is marked as vulnerable.
ale search for other commits by this committer
Update to 5.4.39 release.
25 Mar 2015 12:58:34
Original commit files touched by this commit  5.4.38
Revision:382211 This port version is marked as vulnerable.
marino search for other commits by this committer
lang category: Remove $PTHREAD_LIBS

Note: ecl did not pass check-plist (pre-existing), PR 198897 submitted.

approved by:	PTHREAD blanket
20 Feb 2015 13:56:12
Original commit files touched by this commit  5.4.38
Revision:379433 This port version is marked as vulnerable.
ale search for other commits by this committer
Switch default PHP version to 5.6.x.

- Update PHP 5.4 to 5.4.38 release
- Update PHP 5.5 to 5.5.22 release
- Update PHP 5.6 to 5.6.6 release

PR:		195604
Approved by:	portmgr
23 Jan 2015 12:15:14
Original commit files touched by this commit  5.4.37
Revision:377732 This port version is marked as vulnerable.
ale search for other commits by this committer
Update to 5.4.37 release.
19 Jan 2015 10:32:23
Original commit files touched by this commit  5.4.36
Revision:377396 This port version is marked as vulnerable.
ale search for other commits by this committer
Allow to link imap extension with newer panda-cclient library.

PR:		195973
Submitted by:	thierry
29 Dec 2014 09:59:57
Original commit files touched by this commit  5.4.36
Revision:375781 This port version is marked as vulnerable.
ale search for other commits by this committer
Update to 5.4.36 release and drop broken fpm-ipv6 patch.
If you need it, update to php 5.6 (that will be the default one soon) or 5.5.
25 Dec 2014 20:54:43
Original commit files touched by this commit  5.4.35
Revision:375598 This port version is marked as vulnerable.
bapt search for other commits by this committer
Bump portrevision after png update
25 Dec 2014 19:04:27
Original commit files touched by this commit  5.4.35
Revision:375594 This port version is marked as vulnerable.
antoine search for other commits by this committer
Change libpng15.so to libpng.so in LIB_DEPENDS to prepare the upgrade
27 Nov 2014 09:41:18
Original commit files touched by this commit  5.4.35
Revision:373474 This port version is marked as vulnerable.
ale search for other commits by this committer
Fix build into jails with DTRACE enabled.

PR:		190662
Submitted by:	Martin Vahi <martin.vahi@softf1.com>
22 Nov 2014 20:40:09
Original commit files touched by this commit  5.4.35
Revision:373100  Sanity Test Failure This port version is marked as vulnerable.
crees search for other commits by this committer
Finally retire USE_PGSQL
14 Nov 2014 17:02:03
Original commit files touched by this commit  5.4.35
Revision:372562 This port version is marked as vulnerable.
ale search for other commits by this committer
Update to 5.4.35 release.
17 Oct 2014 21:14:13
Original commit files touched by this commit  5.4.34
Revision:371078 This port version is marked as vulnerable.
ale search for other commits by this committer
Update to 5.4.34 release.
27 Sep 2014 08:31:58
Original commit files touched by this commit  5.4.33_1
Revision:369379 This port version is marked as vulnerable.
riggs search for other commits by this committer
Modernise databases/freetds port
- Retire databases/freetds-msdblib port
  (no longer needed, recently updated upstream version has necessary compat
   option which is now enabled in the freetds port)
- Fix LIB_DEPENDS in dependent ports
- Bump PORTREVISION in freetds and dependent ports

PR:		193850
Submitted by:	5u623l20@gmail.com (maintainer)
18 Sep 2014 19:49:26
Original commit files touched by this commit  5.4.33
Revision:368513 This port version is marked as vulnerable.
ale search for other commits by this committer
Fix build on 8.x and 9.x.
18 Sep 2014 14:07:05
Original commit files touched by this commit  5.4.33
Revision:368463 This port version is marked as vulnerable.
ale search for other commits by this committer
Update to 5.4.33 release.
17 Sep 2014 18:38:19
Original commit files touched by this commit  5.4.32
Revision:368411 This port version is marked as vulnerable.
antoine search for other commits by this committer
Php extensions are built from the same source tarball as php and should
have the same CPE identifier

Discussed with:	des@
With hat:	portmgr
17 Sep 2014 07:38:16
Original commit files touched by this commit  5.4.32
Revision:368356 This port version is marked as vulnerable.
tijl search for other commits by this committer
Replace USE_AUTOTOOLS=libltdl with an ordinary LIB_DEPENDS in all ports.
There are only 60 such ports so there doesn't need to be a separate
keyword or USES for this.

Approved by:	portmgr (bapt)
04 Sep 2014 14:24:26
Original commit files touched by this commit  5.4.32
Revision:367268 This port version is marked as vulnerable.
ale search for other commits by this committer
Import PHP 5.6 branch!
29 Aug 2014 10:21:52
Original commit files touched by this commit  5.4.32
Revision:366491 This port version is marked as vulnerable.
tijl search for other commits by this committer
Fix dependencies on libtidy

Reported by:	amdmi3
27 Aug 2014 12:20:41
Original commit files touched by this commit  5.4.32
Revision:366314 This port version is marked as vulnerable.
ale search for other commits by this committer
Update to 5.4.32 release.
21 Aug 2014 22:50:30
Original commit files touched by this commit  5.4.31_1
Revision:365599 This port version is marked as vulnerable.
mandree search for other commits by this committer
Berkeley DB cleanup, remove versions 4.0 ... 4.7.
- Mk/bsd.database.mk rewrite, new default to db5.
- db6 is eligible by default only if installed on the system.
- Bump PORTREVISION of all ports that directly depend on BerkeleyDB or
  where USE_BDB is found in the port's directory
- Patch a few ports such that they will pick up or work with newer
  versions.
- Add UPDATING entry
- Drive-by format fix for pks
- Drop BerkeleyDB option from mail/popular for now, requires more work.
- Exp-run logs linked from the PR below.
- Ports that do not build (IGNORE, BROKEN, etc.) have pro-forma changes
  for new Berkeley DB, but are untested.

NOTE: please read UPDATING and the Wiki page before proceeding!

Announcement:	http://lists.freebsd.org/pipermail/freebsd-ports-announce/2014-August/000090.html
Wiki reference:	https://wiki.freebsd.org/Ports/BerkeleyDBCleanup
PR:		192690
Approved by:	portmgr (implicit, PORTREVISION bump on unstaged ports)
04 Aug 2014 15:03:44
Original commit files touched by this commit  5.4.31
Revision:364014 This port version is marked as vulnerable.
ale search for other commits by this committer
Update to 5.4.31 release.
31 Jul 2014 13:16:29
Original commit files touched by this commit  5.4.30
Revision:363587 This port version is marked as vulnerable.
antoine search for other commits by this committer
Unbreak php5-readline on head (uncovered by removal of readline dep from pcre)
29 Jul 2014 17:12:50
Original commit files touched by this commit  5.4.30
Revision:363362 This port version is marked as vulnerable.
adamw search for other commits by this committer
Rename all patches that contain '::' as a path separator, and use
'__' instead.
07 Jul 2014 09:23:06
Original commit files touched by this commit  5.4.30
Revision:361043 This port version is marked as vulnerable.
ale search for other commits by this committer
- Update to 5.4.30 release
- Add extra patch to enable ipv6 support in fpm [1]

PR:		190190 [1]
Submitted by:	melvyn@magemana.nl
11 Jun 2014 14:50:00
Original commit files touched by this commit  5.4.29
Revision:357486 This port version is marked as vulnerable.
tijl search for other commits by this committer
Support LIBS like LDFLAGS.

- Add LIBS="${LIBS}" to MAKE_ENV and CONFIGURE_ENV.
- Add an option helper for LIBS.
- Adjust all ports that already use LIBS.  Also remove references to
  PTHREAD_CFLAGS and PTHREAD_LIBS while here.
- Some ports did not support having a LIBS environment variable and
  required additional patches.

Somewhat simplified a linker command line looks like:

${CC} ${src_LDFLAGS} ${LDFLAGS} ${src_LIBS} ${LIBS}

where src_LDFLAGS and src_LIBS are controlled by upstream and LDFLAGS and
LIBS can be controlled by us.  If possible -L and -l flags need to be
(Only the first 15 lines of the commit message are shown above View all of this commit message)
04 Jun 2014 16:54:43
Original commit files touched by this commit  5.4.29
Revision:356520 This port version is marked as vulnerable.
des search for other commits by this committer
Add CPE information.

With hat:	ports-secteam
03 Jun 2014 12:17:52
Original commit files touched by this commit  5.4.29
Revision:356332 This port version is marked as vulnerable.
ale search for other commits by this committer
Update to 5.4.29 release.
19 May 2014 15:41:29
Original commit files touched by this commit  5.4.28
Revision:354544 This port version is marked as vulnerable.
ale search for other commits by this committer
Improve pkg-message for mod_php5.

Submitted by:	POINSOT Julien <poinsot.julien@gmail.com>
15 May 2014 08:08:23
Original commit files touched by this commit  5.4.28
Revision:354103 This port version is marked as vulnerable.
ale search for other commits by this committer
Fix build of xmlrpc extension.
14 May 2014 10:20:08
Original commit files touched by this commit  5.4.28
Revision:354035 This port version is marked as vulnerable.
ale search for other commits by this committer
Fix builds of a few extensions.
05 May 2014 16:24:01
Original commit files touched by this commit  5.4.28
Revision:353029 This port version is marked as vulnerable.
bapt search for other commits by this committer
Fix unixODBC vs libiodbc conflicts

Always rely on unixODBC each time a port is looking for libodbc.so
Remove odbc compat from libiodbc
This allows to install both kde and gnome at the same time

While here:
- Convert libiodbc to USES=libtool
- Convert a bunch of libiodbc dependencies to USES=libtool
- Chase libiodbc.so shlib change
- Stagify some ports
- Convert some ports to USES=pgsql

Discussed with:	rakuco (kde)
With hat:	portmgr
02 May 2014 06:18:30
Original commit files touched by this commit  5.4.28
Revision:352773 This port version is marked as vulnerable.
ale search for other commits by this committer
Update to 5.4.28 release.
16 Apr 2014 18:28:50
Original commit files touched by this commit  5.4.27_1
Revision:351411 This port version is marked as vulnerable.
zeising search for other commits by this committer
The FreeBSD x11@ and graphics team proudly presents
a zeising, kwm production, with help from dumbbell, bdrewery:

NEW XORG ON FREEBSD 9-STABLE AND 10-STABLE

This update switches over to use the new xorg stack by default on FreeBSD 9
and 10 stable, on osversions where vt(9) is available.
It is still possible to use the old stack by specifying WITHOUT_NEW_XORG in
/etc/make.conf .
FreeBSD 8-STABLE and released versions of FreeBSD still use
the old version.
A package repository with binary packages for new xorg will
be available soon.

This patch also contains updates of libxcb and related ports, pixman, as well
(Only the first 15 lines of the commit message are shown above View all of this commit message)
09 Apr 2014 07:58:44
Original commit files touched by this commit  5.4.27
Revision:350670 This port version is marked as vulnerable.
ale search for other commits by this committer
Now that mod_php is a separate port, allow to deselect all SAPIs.

PR:		ports/188386
Submitted by:	Joel Parker <rootrider@shellfront.org>
08 Apr 2014 15:15:31
Original commit files touched by this commit  5.4.27
Revision:350622 This port version is marked as vulnerable.
ale search for other commits by this committer
Force users to update their options file if APACHE was selected.
04 Apr 2014 11:08:17
Original commit files touched by this commit  5.4.27
Revision:350095 This port version is marked as vulnerable.
ale search for other commits by this committer
Update to 5.4.27 release.
31 Mar 2014 14:25:49
Original commit files touched by this commit  5.4.26
Revision:349756 This port version is marked as vulnerable.
ale search for other commits by this committer
Replace DEFAULT_VERSIONS with PHP_DEFAULT.
31 Mar 2014 11:03:13
Original commit files touched by this commit  5.4.26
Revision:349728 This port version is marked as vulnerable.
ale search for other commits by this committer
No-op, use DEFAULT_VERSIONS.

PR:		ports/188061
Submitted by:	Spil <spil.oss@gmail.com>
27 Mar 2014 16:09:37
Original commit files touched by this commit  5.4.26
Revision:349342 This port version is marked as vulnerable.
ale search for other commits by this committer
Welcome the new mod_php ports, in order to have default packages for
Apache PHP modules.

Submitted by:	marcus
Reworked by:	ale (me)
Requested by:	many, too many
07 Mar 2014 12:07:20
Original commit files touched by this commit  5.4.26
Revision:347378 This port version is marked as vulnerable.
ale search for other commits by this committer
Update to 5.4.26 release.
09 Feb 2014 08:39:00
Original commit files touched by this commit  5.4.25
Revision:343435 This port version is marked as vulnerable.
ale search for other commits by this committer
- Update to 5.4.25 release [1]
- Enable FPM by default [2]
- Add support to override configure flags [3]

To users requesting mod_php package, please read this:
https://wiki.apache.org/httpd/PHP-FPM

PR:		ports/186564 [1], ports/185437 [2], ports/186536 [3]
Submitted by:	Rustem Alimov <rustem.alimov@gmail.com> [1],
		Ilya Bakulin <webmaster@kibab.com> [2],
		Reinier Schoof <reinier@skoef.nl> [3]
29 Jan 2014 20:41:28
Original commit files touched by this commit  5.4.24
Revision:341778 This port version is marked as vulnerable.
tijl search for other commits by this committer
Allow the use of //TRANSLIT and //IGNORE with PHP iconv.

PR:		ports/184596
Tested by:	grembo
Approved by:	ale (maintainer)
28 Jan 2014 16:39:17
Original commit files touched by this commit  5.4.24
Revision:341620 This port version is marked as vulnerable.
ale search for other commits by this committer
Fix plist.

PR:		ports/186182
Submitted by:	Dmitry Marakasov <amdmi3@amdmi3.ru>
21 Jan 2014 17:09:31
Original commit files touched by this commit  5.4.24
Revision:340623 This port version is marked as vulnerable.
ale search for other commits by this committer
Update to 5.4.24 release.
27 Dec 2013 10:24:43
Original commit files touched by this commit  5.4.23
Revision:337692 This port version is marked as vulnerable.
ale search for other commits by this committer
Fix build of ldap module when sasl is enabled and LOCALBASE is not /usr/local.

PR:		ports/185151
Submitted by:	Erick Turnquist <jhujhiti@adjectivism.org>
24 Dec 2013 21:22:22
Original commit files touched by this commit  5.4.23
Revision:337385 This port version is marked as vulnerable.
kwm search for other commits by this committer
Update freetype to 2.5.2.

Remove patch to add -I/usr/local/include in freetype-config --cflags. If
ports need extra headers they should look for them, and not get them via
a side-effect.

Freetype had a header resuffle in 2.5.1, patch ports to use the new header
style.

Thanks go to bdrewery for the two exp-runs and rakuco for helping me with
some troublesome cmake ports.

PR:		ports/184587
14 Dec 2013 12:45:41
Original commit files touched by this commit  5.4.23
Revision:336439 This port version is marked as vulnerable.
ale search for other commits by this committer
Update to 5.4.23 release and refresh patches.
18 Oct 2013 12:37:45
Original commit files touched by this commit  5.4.21
Revision:330741 This port version is marked as vulnerable.
ale search for other commits by this committer
Fix installation of mod_php.
18 Oct 2013 11:07:38
Original commit files touched by this commit  5.4.21
Revision:330736 This port version is marked as vulnerable.
ale search for other commits by this committer
Mark broken when APACHE is enabled until a fix is committed.
18 Oct 2013 10:04:27
Original commit files touched by this commit  5.4.21
Revision:330735 This port version is marked as vulnerable.
ale search for other commits by this committer
Update to 5.4.21 release and STAGify.
27 Sep 2013 14:12:51
Original commit files touched by this commit  5.4.20
Revision:328470 This port version is marked as vulnerable.
ale search for other commits by this committer
Update to 5.4.20 release.

PR:		ports/182292
Submitted by:	Rustem Alimov <rustem.alimov@gmail.com>
20 Sep 2013 19:53:10
Original commit files touched by this commit  5.4.19
Revision:327741 This port version is marked as vulnerable.
bapt search for other commits by this committer
Add NO_STAGE all over the place in preparation for the staging support (cat:
lang)
13 Sep 2013 21:31:48
Original commit files touched by this commit  5.4.19
Revision:327187 This port version is marked as vulnerable.
marino search for other commits by this committer
lang/php5*: Fix spl/simplexml modules (4 ports)

The simplexml module uses spl which uses pcre (php53,54,55).  For php52,
the fix is applied directly to spl.  In any case, the bundled PCRE is not
used, so it needs to be able to find the external pcre library and related
headers.  Unfortunately, there is no include for ${LOCALBASE}/include
directory.  This commit adds to fix simplexml (or spl) module build.

Approved by:	portmgr (bapt)
12 Sep 2013 16:55:27
Original commit files touched by this commit  5.4.19
Revision:327089 This port version is marked as vulnerable.
bapt search for other commits by this committer
The simplexml extension needs pkgconfig
04 Sep 2013 18:06:08
Original commit files touched by this commit  5.4.19
Revision:326307 This port version is marked as vulnerable.
madpilot search for other commits by this committer
- Make ports use the libc provided iconv implementation on 10-CURRENT
  after r254273
- Fix a bunch of ports to properly work after this
- Mark converters/libiconv as IGNORE for systems with iconv in libc

Reviewed by:	bapt
Approved by:	portmgr (bapt)
Discussed with:	bapt, bsam (who both contributed ideas and code)
27 Aug 2013 15:10:38
Original commit files touched by this commit  5.4.19
Revision:325458 This port version is marked as vulnerable.
ale search for other commits by this committer
Update to 5.4.19 release.
14 Aug 2013 22:35:54
Original commit files touched by this commit  5.4.17
Revision:324744  Sanity Test Failure This port version is marked as vulnerable.
ak search for other commits by this committer
- Remove MAKE_JOBS_SAFE variable

Approved by:	portmgr (bdrewery)
12 Aug 2013 12:54:12
Original commit files touched by this commit  5.4.17
Revision:324626 This port version is marked as vulnerable.
ale search for other commits by this committer
Add an OPTION to force ZTS build.

PR:		ports/180125
Submitted by:	r4721@tormail.org
16 Jul 2013 06:47:02
Original commit files touched by this commit  5.4.17
Revision:323097 This port version is marked as vulnerable.
ale search for other commits by this committer
Update to 5.4.17 release.

PR:		ports/180527
Submitted by:	Rustem Alimov <rustem.alimov@gmail.com>
07 Jun 2013 23:49:53
Original commit files touched by this commit  5.4.16
Revision:320229 This port version is marked as vulnerable.
flo search for other commits by this committer
Update to 5.4.16

Approved by:	ports-secteam (remko, delphij)
Security:	59e7163c-cf84-11e2-907b-0025905a4770
13 May 2013 08:22:08
Original commit files touched by this commit  5.4.15
Revision:318005 This port version is marked as vulnerable.
ale search for other commits by this committer
Update to 5.4.15 release.

PR:		ports/178556
Submitted by:	Rustem Alimov <rustem.alimov@gmail.com>
04 May 2013 22:48:04
Original commit files touched by this commit  5.4.14
Revision:317389 This port version is marked as vulnerable.
flo search for other commits by this committer
Fix installation of ports that rely on cp -n for installing files. r245960
changed cp to exit with a non-zero exit code if the file exists and is not
overwritten thus causing ports to fail installing when e.g. trying to cp
.default -> .conf files that already exist.

We just ignore the error and continue, as we used to.

Reported by:	jaset
Approved by:	portmgr (bapt)
02 May 2013 06:23:49
Original commit files touched by this commit  5.4.14
Revision:317073 This port version is marked as vulnerable.
jgh search for other commits by this committer
- adoption of USES for gettext

Approved by:	portmgr (bapt@)
29 Apr 2013 08:57:13
Original commit files touched by this commit  5.4.14
Revision:316786 This port version is marked as vulnerable.
bapt search for other commits by this committer
Rely on bsdtar to autodetermine the format of the distfiles when possible

For a while now bsdtar is able to autotermine compression and archive format.
Let's then use tar directly instead of piping to tar.

Now USE_BZIP2 and USE_XZ only set EXTRACT_SUFX to the right format
27 Apr 2013 22:09:15
Original commit files touched by this commit  5.4.14
Revision:316695 This port version is marked as vulnerable.
bapt search for other commits by this committer
Convert the last USE_ICONV to USES=iconv
23 Apr 2013 08:14:18
Original commit files touched by this commit  5.4.14
Revision:316320 This port version is marked as vulnerable.
ale search for other commits by this committer
Update to 5.4.14 release.

PR:		ports/177787, ports/177825
Submitted by:	Rustem Alimov <rustem.alimov@gmail.com>,
		Svyatoslav Lempert <svyatoslav.lempert@gmail.com>
20 Mar 2013 08:15:38
Original commit files touched by this commit  5.4.13
Revision:314716 This port version is marked as vulnerable.
ale search for other commits by this committer
Update to 5.4.13 release.

PR:		ports/177082
Submitted by:	Rustem Alimov <rustem.alimov@gmail.com>
12 Mar 2013 10:33:05
Original commit files touched by this commit  5.4.12
Revision:313958 This port version is marked as vulnerable.
ale search for other commits by this committer
Suhosin will never reappear, remove commented out code.
Fix plist when CLI is not selected [1].

Submitted by:	Gergely CZUCZY <gergely.czuczy@harmless.hu> [1]
25 Feb 2013 10:30:40
Original commit files touched by this commit  5.4.12
Revision:312912 This port version is marked as vulnerable.
ale search for other commits by this committer
Update to 5.4.12 release.
22 Jan 2013 08:20:05
Original commit files touched by this commit  5.4.11
Revision:310812 This port version is marked as vulnerable.
ale search for other commits by this committer
Update to 5.4.11 release.
20 Dec 2012 21:15:05
Original commit files touched by this commit  5.4.10
Revision:309326 This port version is marked as vulnerable.
ale search for other commits by this committer
Update to 5.4.10 release.
10 Dec 2012 19:11:12
Original commit files touched by this commit  5.4.9_1
Revision:308630  Sanity Test Failure This port version is marked as vulnerable.
mm search for other commits by this committer
Update PCRE to 8.32
Introduces the UTF-32 library pcre32
Bump PORTREVISION in dependent ports
10 Dec 2012 14:46:08
Original commit files touched by this commit  5.4.9
Revision:308607 This port version is marked as vulnerable.
ale search for other commits by this committer
Update to 5.4.9 release.
09 Oct 2012 07:32:44
Original commit files touched by this commit  5.4.7
Revision:305571 This port version is marked as vulnerable.
ale search for other commits by this committer
Fix typo in MYSQLND_DESC.

Submitted by:	riccardo@torrini.org
04 Oct 2012 10:00:00
Original commit files touched by this commit  5.4.7
Revision:305246 This port version is marked as vulnerable.
ale search for other commits by this committer
Update to 5.4.7 release.
23 Aug 2012 14:54:49
Original commit files touched by this commit  5.4.6
 This port version is marked as vulnerable.
ale search for other commits by this committer
Update to 5.4.6 release.
18 Aug 2012 14:29:11
Original commit files touched by this commit  5.4.5
 This port version is marked as vulnerable.
ohauer search for other commits by this committer
- remove www/apache20 and devel/apr0
- s/USE_APACHE= 20+/USE_APACHE= 22+/
- unify s/YES/yes/
- cleanup APACHE_VERSION <= 22 usage
- add entry to MOVED

with hat apache@
23 Jul 2012 23:18:19
Original commit files touched by this commit  5.4.5
 This port version is marked as vulnerable.
delphij search for other commits by this committer
Update to 5.4.5.

Security:	bdab0acd-d4cd-11e1-8a1c-14dae9ebcf89
With hat:	secteam
19 Jun 2012 07:44:31
Original commit files touched by this commit  5.4.4
 This port version is marked as vulnerable.
ale search for other commits by this committer
Update to 5.4.4 release and switch to OptionsNG.
01 Jun 2012 05:26:28
Original commit files touched by this commit  5.4.3
 This port version is marked as vulnerable.
dinoex search for other commits by this committer
- update png to 1.5.10
16 May 2012 07:36:13
Original commit files touched by this commit  5.4.3
 This port version is marked as vulnerable.
ale search for other commits by this committer
Update to 5.4.3 release:
- add support for embedded php library
- add support for dtrace

Re-organize bsd.php.mk:
 - add WANT_PHP_EMD
 - fix handling of WANT_PHP_*
 - remove php4 extensions

From UPDATING:
  Suhosin patch has been disabled until the
  new version will be released (soon). Suhosing extension will take more
  time. LINKTHR option is now enabled by default, be sure to flag it if
  you are updating using an old saved configuration. sqlite2 extension
  has been permanently removed.
  If you want to remain at PHP 5.3, a new port (lang/php53) will be
  committed soon.
09 May 2012 05:43:32
Original commit files touched by this commit  5.3.13
 This port version is marked as vulnerable.
ale search for other commits by this committer
Update to 5.3.13 release:
- Fix PHP-CGI query string parameter vulnerability, CVE-2012-1823.
- Improve fix for PHP-CGI query string parameter vulnerability, CVE-2012-2311.

Number of commits found: 347 (showing only 100 on this page)

1 | 2 | 3 | 4  »  

Login
User Login
Create account

Servers and bandwidth provided by
New York Internet, SuperNews, and RootBSD

This site
What is FreshPorts?
About the authors
FAQ
How big is it?
The latest upgrade!
Privacy
Forums
Blog
Contact

Search
Enter Keywords:
 
more...

Latest Vulnerabilities
ffmpegFeb 06
mencoderFeb 06
mplayerFeb 06
ldb*Feb 05
samba36*Feb 05
samba4*Feb 05
samba41*Feb 05
samba42*Feb 05
samba43*Feb 05
shotwellFeb 05
asterisk11Feb 04
asterisk13Feb 04
py-rsaFeb 04
webkit-gtk2Feb 04
webkit-gtk3Feb 04

28 vulnerabilities affecting 78 ports have been reported in the past 14 days

* - modified, not new

All vulnerabilities


Ports
Home
Categories
Deleted ports
Sanity Test Failures
Newsfeeds

Statistics
Graphs
NEW Graphs (Javascript)
Traffic

Calculated hourly:
Port count 25698
Broken 360
Deprecated 146
Ignore 633
Forbidden 0
Restricted 206
No CDROM 87
Vulnerable 57
Expired 69
Set to expire 127
Interactive 0
new 24 hours 4
new 48 hours7
new 7 days29
new fortnight60
new month152

Servers and bandwidth provided by
New York Internet, SuperNews, and RootBSD
Valid HTML, CSS, and RSS.
Copyright © 2000-2014 Dan Langille. All rights reserved.