FreshPorts -- The Place For Ports If you buy from Amazon USA, please support us by using this link.
Follow us
Blog
Twitter

Please give me your LTO-4 or better tape library and I'll put it to good use.
Port details
thunderbird Mozilla Thunderbird is standalone mail and news that stands above
38.1.0 mail on this many watch lists=139 search for ports that depend on this port An older version of this port was marked as vulnerable. Find issues related to this port Report an issue related to this port
Maintainer: gecko@FreeBSD.org search for ports maintained by this maintainer
Port Added: 14 Feb 2004 22:47:35
Also Listed In: news net-im ipv6
License: not specified in port
Mozilla Thunderbird is a redesign of the Mozilla mail component with the goal
of becoming a cross-platform stand alone mail application using the XUL
user interface language.  See the Mozilla Thunderbird project page for
more details.

WWW: http://www.mozilla.com/thunderbird/
SVNWeb : Homepage : Distfiles Availability : PortsMon

NOTE: FreshPorts displays only information on required and default dependencies. Optional dependencies are not covered.

Build dependencies:
  1. nspr>=4.10.8 : devel/nspr
  2. nss>=3.19.2 : security/nss
  3. libevent2>=2.0.21_2 : devel/libevent2
  4. cairo>=1.12.16_1,2 : graphics/cairo
  5. soundtouch>=1.8.0 : audio/soundtouch
  6. harfbuzz>=0.9.34 : print/harfbuzz
  7. graphite2>=1.2.4 : graphics/graphite2
  8. libvorbis>=1.3.5 : audio/libvorbis
  9. opus>=1.1 : audio/opus
  10. libvpx>=1.3.0 : multimedia/libvpx
  11. sqlite3>=3.8.9 : databases/sqlite3
  12. py27-sqlite3>0 : databases/py-sqlite3
  13. v4l_compat>0 : multimedia/v4l_compat
  14. autoconf-2.13 : devel/autoconf213
  15. zip : archivers/zip
  16. unzip : archivers/unzip
  17. libnotify>0 : devel/libnotify
  18. gmake : devel/gmake
  19. pkgconf : devel/pkgconf
  20. python2.7 : lang/python27
  21. update-desktop-database : devel/desktop-file-utils
  22. libGL>0 : graphics/libGL
  23. glproto.pc : x11/glproto
  24. dri2proto.pc : x11/dri2proto
  25. xext.pc : x11/libXext
  26. xrender.pc : x11/libXrender
  27. xt.pc : x11-toolkits/libXt
  28. intltool-extract : textproc/intltool
  29. perl5.20.2 : lang/perl5.20
Runtime dependencies:
  1. libcanberra>0 : audio/libcanberra
  2. libasound_module_pcm_oss.so : audio/alsa-plugins
  3. update-desktop-database : devel/desktop-file-utils
  4. alsa-lib>=1.0.27.2_1 : audio/alsa-lib
  5. gpg : security/gnupg
  6. libGL>0 : graphics/libGL
  7. xext.pc : x11/libXext
  8. xrender.pc : x11/libXrender
  9. xt.pc : x11-toolkits/libXt
Library dependencies:
  1. libv4l2.so : multimedia/libv4l
  2. libcairo.so : graphics/cairo
  3. libevent.so : devel/libevent2
  4. libffi.so : devel/libffi
  5. libgraphite2.so : graphics/graphite2
  6. libharfbuzz.so : print/harfbuzz
  7. libhunspell-1.3.so : textproc/hunspell
  8. libicui18n.so : devel/icu
  9. libnspr4.so : devel/nspr
  10. libnss3.so : security/nss
  11. libpng.so : graphics/png
  12. libpixman-1.so : x11/pixman
  13. libSoundTouch.so : audio/soundtouch
  14. libsqlite3.so : databases/sqlite3
  15. libvorbis.so : audio/libvorbis
  16. libvpx.so : multimedia/libvpx
  17. libdbus-glib-1.so : devel/dbus-glib
  18. libstartup-notification-1.so : x11/startup-notification
  19. libasound.so : audio/alsa-lib
  20. libiconv.so : converters/libiconv
  21. libjpeg.so : graphics/jpeg
  22. libatk-1.0.so : accessibility/atk
  23. libglib-2.0.so : devel/glib20
  24. libgtk-x11-2.0.so : x11-toolkits/gtk20
  25. libpango-1.0.so : x11-toolkits/pango

This port is required by:

for Build for Run * - deleted ports are only shown under the This port is required by section. It was harder to do for the Required section. Perhaps later...

To install the port: cd /usr/ports/mail/thunderbird/ && make install clean
To add the package: pkg install mail/thunderbird


Configuration Options
===> The following configuration options are available for thunderbird-38.1.0:
     CANBERRA=on: Sound theme alerts
     DBUS=on: D-Bus IPC system support
     DEBUG=off: Build with debugging support
     DTRACE=off: Build with DTrace probes
     ENIGMAIL=on: Enigmail extension
     GCONF=off: GConf configuration backend support
     GIO=on: Use GIO for file I/O
     GNOMEUI=off: libgnomeui support module
     GSTREAMER=off: Multimedia support via GStreamer
     LIBPROXY=off: Proxy support via libproxy
     LIGHTNING=on: Calendar extension
     LOGGING=on: Additional log messages
     OPTIMIZED_CFLAGS=on: Use extra compiler optimizations
     PGO=off: Use Profile-Guided Optimization
     PROFILE=off: Build with profiling support
     TEST=off: Build and/or run tests
====> Options available for the multi AUDIO: you have to choose at least one of them
     ALSA=on: ALSA audio architecture support
     PULSEAUDIO=off: PulseAudio sound server support
===> Use 'make config' to modify these settings

USES:
dos2unix tar:bzip2 qmake:_env cpe compiler:c++11-lang gmake iconv perl5 pkgconfig  python:2.7,build desktop-file-utils        jpeg        

Master Sites:
  1. ftp://ftp.mozilla.org/pub/mozilla.org/thunderbird/candidates/38.1.0-candidates/build1/source/
  2. ftp://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/38.1.0/source/
  3. http://distcache.FreeBSD.org/ports-distfiles/
  4. http://ftp.mozilla.org/pub/mozilla.org/thunderbird/candidates/38.1.0-candidates/build1/source/
  5. http://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/38.1.0/source/
  6. http://releases.mozilla.org/pub/mozilla.org/thunderbird/candidates/38.1.0-candidates/build1/source/
  7. http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/38.1.0/source/
  8. https://ftp.mozilla.org/pub/mozilla.org/thunderbird/candidates/38.1.0-candidates/build1/source/
  9. https://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/38.1.0/source/
Notes from UPDATING
These upgrade notes are taken from /usr/ports/UPDATING
  • 2012-07-26
    Affects: users of www/firefox, www/seamonkey, mail/thunderbird, www/libxul
    Author: gecko@FreeBSD.org
    Reason: 
      Gecko ports were switched to use system libraries. Some of them
      must be built with certain options set (default).
    
      - graphics/png has to be installed with APNG option
    
      - databases/sqlite3 has to be installed with SECURE_DELETE, THREADSAFE,
        FTS3, UNLOCK_NOTIFY options
    
    
  • 2012-04-18
    Affects: users of www/firefox and mail/thunderbird
    Author: gecko@FreeBSD.org
    Reason: 
      Firefox and Thunderbird have been updated to 11.0. If you want to
      stay with the Extended Support Release please use the new -esr
      ports.
    
      Firefox:
      # portupgrade -o www/firefox-esr www/firefox
      # portupgrade -o www/firefox-esr-i18n www/firefox-i18n (if installed)
      or
      # portmaster -o www/firefox-esr www/firefox
      # portmaster -o www/firefox-esr-i18n www/firefox-i18n (if installed)
    
      Thunderbird:
      # portupgrade -o mail/thunderbird-esr mail/thunderbird
      # portupgrade -o mail/thunderbird-esr-i18n \
        mail/thunderbird-i18n (if installed)
      or
      # portmaster -o mail/thunderbird-esr mail/thunderbird
      # portmaster -o mail/thunderbird-esr-i18n \
        mail/thunderbird-i18n (if installed)
    
    
  • 2011-10-19
    Affects: users of mail/thunderbird or www/seamonkey with lightning
             plugin installed.
    Author: gecko@FreeBSD.org
    Reason: 
      To get an up to date version of lightning you should use the new
      LIGHTNING option in mail/thunderbird or www/seamonkey. This option
      is not enabled by default so you have to run "make config" prior
      to the build. The old deskutils/lightning-thunderbird and
      deskutils/lightning ports should no longer be used and will be
      removed very soon.
    
      Like other XPIs ports, lightning now registers itself as a global
      extension and doesn't create the XPI to be installed manually.
      Upgrading users should remove lightning from their profile before
      installing Thunderbird or SeaMonkey the first time with the new
      LIGHTNING option enabled.
    
    
  • 2011-06-30
    Affects: users of mail/thunderbird
    Author: gecko@FreeBSD.org
    Reason: 
      The mail/thunderbird port has been updated to 5.0. If you want to stay with
      Thunderbird 3.1 please run:
    
      # portupgrade -o mail/thunderbird3 mail/thunderbird
      # portupgrade -o mail/thunderbird3-i18n mail/thunderbird-i18n (if installed)
        or
      # portmaster -o mail/thunderbird3 mail/thunderbird
      # portmaster -o mail/thunderbird3-i18n mail/thunderbird-i18n (if installed)
    
      Do not select the OPTIMIZED_CFLAGS option on a system with less then
      2 GB of RAM otherwise you will run out of memory during the build.
    
      Please make sure all your addons are compatible with Thunderbird 5.0 and
      backup your ~/.thunderbird directory prior to the first launch of Thunderbird
      5.0.
    
    
Port Moves

Number of commits found: 238 (showing only 100 on this page)

«  1 | 2 | 3  »  

Commit History - (may be incomplete: see SVNWeb link above for full details)
DateByDescription
23 Aug 2011 18:39:19
Original commit files touched by this commit  6.0_1
 This port version is marked as vulnerable.
kwm search for other commits by this committer
Chase libnotify, libproxy and webkit-gtk2 shlib changes, and fix build where
needed.
18 Aug 2011 12:47:26
Original commit files touched by this commit  6.0
 This port version is marked as vulnerable.
ale search for other commits by this committer
Remove empty patch.
18 Aug 2011 12:40:31
Original commit files touched by this commit  6.0
 This port version is marked as vulnerable.
ale search for other commits by this committer
Allow lightning xpi to be installed on current tb version.

Submitted by:   Jimmie James <jimmiejaz@gmail.com>
18 Aug 2011 10:01:59
Original commit files touched by this commit  6.0
 This port version is marked as vulnerable.
ale search for other commits by this committer
Port generalization.

Approved by:    flo
16 Aug 2011 18:23:05
Original commit files touched by this commit  6.0
 This port version is marked as vulnerable.
flo search for other commits by this committer
update to 6.0

Security:      
http://www.vuxml.org/freebsd/834591a9-c82f-11e0-897d-6c626dd55a41.html
15 Jul 2011 22:20:11
Original commit files touched by this commit  5.0
 This port version is marked as vulnerable.
flo search for other commits by this committer
- require cairo>=1.10.2_1,1 to catch build failuers early

The cairo dependancy is usually added by bsd.gecko.mk, but for thunderbird 5 we
need a spcific version.
04 Jul 2011 21:27:06
Original commit files touched by this commit  5.0
 This port version is marked as vulnerable.
flo search for other commits by this committer
add an option to build the lightning (calendar) extension

Submitted by:   mi (original version)
30 Jun 2011 18:19:48
Original commit files touched by this commit  5.0
 This port version is marked as vulnerable.
flo search for other commits by this committer
update thunderbird to 5.0
21 Jun 2011 20:38:00
Original commit files touched by this commit  3.1.11
 This port version is marked as vulnerable.
flo search for other commits by this committer
- update to 3.1.11

Seccurity:     
http://www.vuxml.org/freebsd/dfe40cff-9c3f-11e0-9bec-6c626dd55a41.html
29 Apr 2011 06:37:41
Original commit files touched by this commit  3.1.10
 This port version is marked as vulnerable.
flo search for other commits by this committer
- update to 3.1.10

Security:      
http://www.vuxml.org/freebsd/04b7d46c-7226-11e0-813a-6c626dd55a41.html
15 Mar 2011 14:12:33
Original commit files touched by this commit  3.1.9
 This port version is marked as vulnerable.
decke search for other commits by this committer
- Fix Thunderbird startscript when LOCALBASE is set

Submitted by:   Kris Moore <kris@pcbsd.org>
04 Mar 2011 23:26:27
Original commit files touched by this commit  3.1.9
 This port version is marked as vulnerable.
beat search for other commits by this committer
- Update to 3.1.9
01 Mar 2011 22:27:20
Original commit files touched by this commit  3.1.8
 This port version is marked as vulnerable.
beat search for other commits by this committer
- Update to 3.1.8
- Add support for powerpc64 [1]

Submitted by:   andreast@ [1]
10 Dec 2010 14:51:59
Original commit files touched by this commit  3.1.7
 This port version is marked as vulnerable.
beat search for other commits by this committer
- Update to 3.1.7
- Drop MD5 checksum
- Replace CONFLICTS with CONFLICTS_INSTALL

Security:      
http://www.vuxml.org/freebsd/1d8ff4a2-0445-11e0-8e32-000f20797ede.html
04 Dec 2010 07:34:27
Original commit files touched by this commit  3.1.6
 This port version is marked as vulnerable.
ade search for other commits by this committer
Sync to new bsd.autotools.mk
28 Oct 2010 15:42:25
Original commit files touched by this commit  3.1.6
 This port version is marked as vulnerable.
beat search for other commits by this committer
- Update to 3.1.6

Security:      
http://www.vuxml.org/freebsd/c223b00d-e272-11df-8e32-000f20797ede.html
20 Oct 2010 17:01:29
Original commit files touched by this commit  3.1.5
 This port version is marked as vulnerable.
beat search for other commits by this committer
- Update to 3.1.5
- Unbreak with recent versions of GCC [1]

Submitted by:   Andriy Gapon <avg AT icyb.net.ua> [1]
Security:      
http://www.vuxml.org/freebsd/c4f067b9-dc4a-11df-8e32-000f20797ede.html
17 Sep 2010 10:18:06
Original commit files touched by this commit  3.1.4
 This port version is marked as vulnerable.
beat search for other commits by this committer
- Update to 3.1.4
08 Sep 2010 08:14:06
Original commit files touched by this commit  3.1.3
 This port version is marked as vulnerable.
beat search for other commits by this committer
- Update to 3.1.3

Security:      
http://www.vuxml.org/freebsd/4a21ce2c-bb13-11df-8e32-000f20797ede.html
06 Aug 2010 09:11:58
Original commit files touched by this commit  3.1.2
 This port version is marked as vulnerable.
beat search for other commits by this committer
- Update to 3.1.2
03 Aug 2010 20:55:29
Original commit files touched by this commit  3.1.1
 This port version is marked as vulnerable.
beat search for other commits by this committer
- Update to 3.1.1

Thanks to:      Andreas Tobler <andreast-list AT fgznet.ch>
23 Jun 2010 08:13:35
Original commit files touched by this commit  2.0.0.24_1
 This port version is marked as vulnerable.
beat search for other commits by this committer
- Mark DEPRECATED: Upstream support dropped. Please consider using
  mail/thunderbird3 instead.

Feature safe:   yes
28 Mar 2010 13:19:06
Original commit files touched by this commit  2.0.0.24_1
 This port version is marked as vulnerable.
dinoex search for other commits by this committer
- fix build for png-1.4.1
28 Mar 2010 06:47:48
Original commit files touched by this commit  2.0.0.24_1
 This port version is marked as vulnerable.
dinoex search for other commits by this committer
- update to 1.4.1
Reviewed by:    exp8 run on pointyhat
Supported by:   miwi
19 Mar 2010 09:32:29
Original commit files touched by this commit  2.0.0.24
 This port version is marked as vulnerable.
beat search for other commits by this committer
- Update to 2.0.0.24
05 Feb 2010 11:46:55
Original commit files touched by this commit  2.0.0.23_2
 This port version is marked as vulnerable.
dinoex search for other commits by this committer
- update to jpeg-8
14 Dec 2009 15:38:28
Original commit files touched by this commit  2.0.0.23_1
 This port version is marked as vulnerable.
beat search for other commits by this committer
- Add CONFLICT with Thunderbird 3
26 Nov 2009 08:30:19
Original commit files touched by this commit  2.0.0.23_1
 This port version is marked as vulnerable.
beat search for other commits by this committer
- Add ftp to MOZ_PROTOCOLS. This allows to define a calendar file located
  on a ftp server in xpi-lightning.
- Bump PORTREVISION.
28 Sep 2009 21:10:21
Original commit files touched by this commit  2.0.0.23
 This port version is marked as vulnerable.
beat search for other commits by this committer
- Add powerpc support

Submitted by:   Andreas Tobler <andreast-list AT fgznet.ch>
With hat:       gecko
Feature safe:   yes
22 Aug 2009 11:52:00
Original commit files touched by this commit  2.0.0.23
 This port version is marked as vulnerable.
beat search for other commits by this committer
- Update to 2.0.0.23

Security:       http://www.mozilla.org/security/announce/2009/mfsa2009-42.html
With hat:       gecko
23 Jul 2009 07:46:43
Original commit files touched by this commit  2.0.0.22_1
 This port version is marked as vulnerable.
ale search for other commits by this committer
Add amd64 as recognized platform.

As secondary consequence, enigmail will correctly build on amd64.

Approved by:    silence on gecko@ and gnome@
Tested by:      Paul Dokas <dokas@oitsec.umn.edu>,
                Lapo Luchini <lapo@lapo.it>
23 Jun 2009 20:58:51
Original commit files touched by this commit  2.0.0.22
 This port version is marked as vulnerable.
beat search for other commits by this committer
- Update to 2.0.0.22

Submitted by:   Florian Smeets (via freebsd-gecko SVN)
Security:      
http://www.vuxml.org/freebsd/da185955-5738-11de-b857-000f20797ede.html
With hat:       gecko
04 May 2009 19:23:44
Original commit files touched by this commit  2.0.0.21_1
 This port version is marked as vulnerable.
miwi search for other commits by this committer
- Give Maintainership up to the Gecko Gang (gecko@)
12 Apr 2009 19:27:13
Original commit files touched by this commit  2.0.0.21_1
 This port version is marked as vulnerable.
miwi search for other commits by this committer
Take maintainership. The first of two steps is to take all
Gecko Stuff from the Gnome team. I'd like to say thanks a lot for
all the work in the past years.
04 Apr 2009 11:47:00
Original commit files touched by this commit  2.0.0.21_1
  Sanity Test Failure This port version is marked as vulnerable.
marius search for other commits by this committer
Resurrect www/mozilla/Makefile.common rev. 1.30 and associated changes,
which got lost with the switch to bsd.gecko.mk:
Work around the miscompilation/mislinkage problem of the sCanonicalVTable
hacks in the XPCOM string code on sparc64 by omitting the code in question
and bump PORTREVISIONs accordingly.

Approved by:    marcus
20 Mar 2009 21:11:09
Original commit files touched by this commit  2.0.0.21
 This port version is marked as vulnerable.
miwi search for other commits by this committer
- Update to 2.0.0.21

Approved by:    pav
Security:      
http://www.mozilla.org/security/known-vulnerabilities/thunderbird20.html#thunderbird2.0.0.21
               
http://www.vuxml.org/freebsd/8b491182-f842-11dd-94d9-0030843d3802.html
10 Jan 2009 02:45:46
Original commit files touched by this commit  2.0.0.19_1
 This port version is marked as vulnerable.
mezz search for other commits by this committer
Add a new framework for browser plugins, USE_WEBPLUGINS. It is for which foo
plugins support one of web browsers and can take care of plist (depend on how
you use it) at the same time. I have written a complete document and even show
how it works in the www/firefox/Makefile.webplugins so be sure to read in
there. If there is anything that isn't clear in the document, please feel free
to ask and I will try my best to improvement it.

FYI: GNOME 2.24 depends on this, so it's coming.

BTW: It's based on www/linux-mplayer-plugin/Makefile.npapi with heavy modified.

Approved by:    portmgr
02 Jan 2009 21:15:05
Original commit files touched by this commit  2.0.0.19
 This port version is marked as vulnerable.
mezz search for other commits by this committer
Update to 2.0.0.19.

PR:             ports/130112
Submitted by:   Beat Gatzi <beat@chruetertee.ch>
Security:      
http://www.mozilla.org/security/known-vulnerabilities/thunderbird20.html#thunderbird2.0.0.19
23 Nov 2008 16:06:53
Original commit files touched by this commit  2.0.0.18
 This port version is marked as vulnerable.
miwi search for other commits by this committer
- Update to 2.0.0.18

PR:             129089
Submitted by:   Gary Palmer <freebsd-gnats@in-addr.com>
Approved by:    portmgr (pav)
Security:      
http://www.vuxml.org/freebsd/f29fea8f-b19f-11dd-a55e-00163e000016.html
26 Sep 2008 23:35:37
Original commit files touched by this commit  2.0.0.17
 This port version is marked as vulnerable.
miwi search for other commits by this committer
- Update to 2.0.0.17

Approved by:    portmgr (marcus)
Security:      
http://www.vuxml.org/freebsd/2273879e-8a2f-11dd-a6fe-0030843d3802.html
25 Jul 2008 22:01:53
Original commit files touched by this commit  2.0.0.16
 This port version is marked as vulnerable.
mezz search for other commits by this committer
Update to 2.0.0.16.

Security:      
http://www.mozilla.org/security/known-vulnerabilities/thunderbird20.html#thunderbird2.0.0.16
25 Jul 2008 14:34:52
Original commit files touched by this commit  2.0.0.14_1
 This port version is marked as vulnerable.
pav search for other commits by this committer
- Remove USE_GCC where it can be satisfied with base compiler on following
  FreeBSD versions: 5.3 and up, 6.x, 7.x, 8-CURRENT
06 Jun 2008 13:43:09
Original commit files touched by this commit  2.0.0.14_1
 This port version is marked as vulnerable.
edwin search for other commits by this committer
Bump portrevision due to upgrade of devel/gettext.

The affected ports are the ones with gettext as a run-dependency
according to ports/INDEX-7 (5007 of them) and the ones with USE_GETTEXT
in Makefile (29 of them).

PR:             ports/124340
Submitted by:   edwin@
Approved by:    portmgr (pav)
02 May 2008 22:54:22
Original commit files touched by this commit  2.0.0.14
 This port version is marked as vulnerable.
delphij search for other commits by this committer
Update to 2.0.0.14.

Approved by:    maintainer (marcus/mezz at -gnome@)
22 Apr 2008 05:32:58
Original commit files touched by this commit  2.0.0.12_3
 This port version is marked as vulnerable.
delphij search for other commits by this committer
Mask FP_X_DNML not only on i386, but also on amd64.  This fixes mysterious
crashes of thunderbird with SIGFPE, one of symptom of it is that this
prevents enigmail-thunderbird from being able to be used on recent FreeBSD
versions with thunderbird.

PR:             ports/122975
Approved by:    maintainer (marcus as gnome@)
19 Apr 2008 17:56:05
Original commit files touched by this commit  2.0.0.12_2
  Sanity Test Failure This port version is marked as vulnerable.
miwi search for other commits by this committer
- Remove unneeded dependency from gtk12/gtk20 [1]
- Remove USE_XLIB/USE_X_PREFIX/USE_XPM in favor of USE_XORG
- Remove X11BASE support in favor of LOCALBASE or PREFIX
- Use USE_LDCONFIG instead of INSTALLS_SHLIB
- Remove unneeded USE_GCC 3.4+

Thanks to all Helpers:
        Dmitry Marakasov, Chess Griffin, beech@, dinoex, rafan, gahr,
        ehaupt, nox, itetcu, flz, pav

PR:             116263
Tested on:      pointyhat
Approved by:    portmgr (pav)
09 Mar 2008 23:04:40
Original commit files touched by this commit  2.0.0.12_1
 This port version is marked as vulnerable.
mezz search for other commits by this committer
Fix the the rss and gmail accounts show up in the "new account" dialog, bump
the PORTREVISION.

Submitted by:   sajd (FreeNode/#freebsd-gnome)
28 Feb 2008 23:35:57
Original commit files touched by this commit  2.0.0.12
 This port version is marked as vulnerable.
mezz search for other commits by this committer
Update to 2.0.0.12.

PR:             ports/121189
Submitted by:   gpalmer
Security:       - MFSA 2008-12 Heap buffer overflow in external MIME bodies
                - MFSA 2008-07 Possible information disclosure in BMP decoder
                - MFSA 2008-05 Directory traversal via chrome: URI
                - MFSA 2008-03 Privilege escalation, XSS, Remote Code Execution
                - MFSA 2008-01 Crashes with evidence of memory corruption
                  (rv:1.8.1.12)
28 Feb 2008 04:40:05
Original commit files touched by this commit  2.0.0.9_2
 This port version is marked as vulnerable.
mezz search for other commits by this committer
- Add "--with-default-mozilla-five-home=${PREFIX}/lib/${MOZILLA}" to fix other
  applications in the runtime. Some applications required to have set
  MOZILLA_FIVE_HOME or/and LD_LIBRARY_PATH to make it works in the runtime. Now,
  it's no longer need to set these variables, which this flag takes care of it.
  The MOZILLA_FIVE_HOME still works with this flag if someone need to use
  different one. I have learned about this flag from RPM, Debian, Gentoo ebuild
  and other packages.
- Add two extensions, auth[1] and transformiix[2].

Have been tested in MC CVS since Dec.

PR:             ports/117734 [1]
Submitted by:   Nathan Whitehorn <nathanw@uchicago.edu> [1]
Reported by:    Juan Pablo Roig <juan.roig@globant.com> [2]
21 Jan 2008 22:19:53
Original commit files touched by this commit  2.0.0.9_1
 This port version is marked as vulnerable.
marius search for other commits by this committer
Work around the miscompilation/mislinkage problem of the sCanonicalVTable
hacks in the XPCOM string code on sparc64 by omitting the code in question
and bump PORTREVISIONs accordingly.

Approved by:    marcus
15 Nov 2007 17:34:06
Original commit files touched by this commit  2.0.0.9
 This port version is marked as vulnerable.
ahze search for other commits by this committer
update to 2.0.0.9

Approved by:    portmgr (marcus)
31 Oct 2007 04:33:21
Original commit files touched by this commit  2.0.0.6_1
 This port version is marked as vulnerable.
mezz search for other commits by this committer
Fix the crash with GTK+ 2.12.x, depend on what theme user is using. Bump the
PORTREVISION.

Reported by:    several in freebsd-gnome@
Tested by:      kan
Obtained from:  https://bugzilla.mozilla.org/show_bug.cgi?id=389801
Approved by:    portmgr (marcus)
07 Oct 2007 05:45:04
Original commit files touched by this commit  2.0.0.6
 This port version is marked as vulnerable.
linimon search for other commits by this committer
Set USE_PERL5/WANT_PERL as appropriate, for ports that either depend on
perl unconditonally, or conditionally.  To be able to conditionalize the
inclusion of bsd.perl.mk, they now need to be defined before the inclusion
of bsd.port.pre.mk.

Hat:            portmgr
02 Aug 2007 18:08:20
Original commit files touched by this commit  2.0.0.6
 This port version is marked as vulnerable.
delphij search for other commits by this committer
Update to 2.0.0.6.

PR:                     ports/115149
"Please commit":        ahze
30 Jul 2007 06:53:02
Original commit files touched by this commit  2.0.0.5
 This port version is marked as vulnerable.
marcus search for other commits by this committer
Fix use of expr in the configure script.

PR:             112823
20 Jul 2007 18:45:56
Original commit files touched by this commit  2.0.0.5
 This port version is marked as vulnerable.
ahze search for other commits by this committer
Update to 2.0.0.5
15 Jun 2007 03:03:16
Original commit files touched by this commit  2.0.0.4
 This port version is marked as vulnerable.
ahze search for other commits by this committer
Update to 2.0.0.4
20 May 2007 16:28:26
Original commit files touched by this commit  2.0.0.0_1
 This port version is marked as vulnerable.
marcus search for other commits by this committer
Remove one remaining instance of X11BASE to fix the build when OpenLDAP
is installed.

Reported by:    Tim Bishop <tim-lists@bishnet.net>
Approved by:    portmgr (implicit)
19 May 2007 20:32:57
Original commit files touched by this commit  2.0.0.0_1
 This port version is marked as vulnerable.
flz search for other commits by this committer
- Welcome X.org 7.2 \o/.
- Set X11BASE to ${LOCALBASE} for recent ${OSVERSION}.
- Bump PORTREVISION for ports intalling files in ${X11BASE}.
20 Apr 2007 17:35:26
Original commit files touched by this commit  2.0.0.0
 This port version is marked as vulnerable.
ahze search for other commits by this committer
- Update to 2.0.0.0

Release Notes:  http://mozilla.com/thunderbird/2.0.0.0/releasenotes/
19 Mar 2007 03:06:16
Original commit files touched by this commit  1.5.0.10
 This port version is marked as vulnerable.
ahze search for other commits by this committer
Fix build with upcoming nss updates
05 Mar 2007 21:50:24
Original commit files touched by this commit  1.5.0.10
 This port version is marked as vulnerable.
ahze search for other commits by this committer
Update to 1.5.0.10
18 Jan 2007 22:37:11
Original commit files touched by this commit  1.5.0.9_1
 This port version is marked as vulnerable.
mezz search for other commits by this committer
Fix the gtk2 dnd implementation broken, see more details in the bugzilla. This
patch[1] was created by Matthias Clasen <mclasen@redhat.com>. This bug was
started to reproduce with least 2.10.7 version of gtk2.

PR:             ports/107689
Reported by:    a few users
Bugzilla:       https://bugzilla.mozilla.org/show_bug.cgi?id=355248
                https://bugzilla.mozilla.org/show_bug.cgi?id=367203 [1]
                http://bugzilla.gnome.org/show_bug.cgi?id=394525
21 Dec 2006 08:20:43
Original commit files touched by this commit  1.5.0.9
 This port version is marked as vulnerable.
mezz search for other commits by this committer
The ipv6 is supported in these ports, so add ipv6 category.

PR:             ports/106892 and ports/106894
Submitted by:   Janos Mohacsi <janos.mohacsi@bsd.hu>
20 Dec 2006 21:37:44
Original commit files touched by this commit  1.5.0.9
 This port version is marked as vulnerable.
ahze search for other commits by this committer
Update to 1.5.0.9

Release notes:  http://www.mozilla.com/en-US/thunderbird/releases/1.5.0.9.html
15 Dec 2006 20:57:41
Original commit files touched by this commit  1.5.0.8_1
 This port version is marked as vulnerable.
marcus search for other commits by this committer
Fix a double-free while performing print operations which could trigger a
segmentation fault if malloc debugging was enabled.

Reported by:    dougb
18 Nov 2006 17:04:28
Original commit files touched by this commit  1.5.0.8
 This port version is marked as vulnerable.
ahze search for other commits by this committer
Mark CONFLICTS with mail/lightning
10 Nov 2006 00:51:55
Original commit files touched by this commit  1.5.0.8
 This port version is marked as vulnerable.
ahze search for other commits by this committer
Update to 1.5.0.8
14 Oct 2006 08:54:54
Original commit files touched by this commit  1.5.0.7_1
 This port version is marked as vulnerable.
marcus search for other commits by this committer
Chase the GNOME X11BASE to LOCALBASE move, and fix the build with the
new freetype2 where needed.

Submitted by:   mezz, ahze, pav, and many others
Approved by:    portmgr (implicit, kris)
14 Sep 2006 13:48:31
Original commit files touched by this commit  1.5.0.7
 This port version is marked as vulnerable.
ahze search for other commits by this committer
- Update to 1.5.0.7
29 Jul 2006 03:57:38
Original commit files touched by this commit  1.5.0.5
 This port version is marked as vulnerable.
ahze search for other commits by this committer
- Update to 1.5.0.5
05 Jul 2006 22:12:13
Original commit files touched by this commit  1.5.0.4
 This port version is marked as vulnerable.
ahze search for other commits by this committer
- Welcome back sparc64 on kern.osreldate>=601101
04 Jun 2006 18:50:09
Original commit files touched by this commit  1.5.0.4
 This port version is marked as vulnerable.
ahze search for other commits by this committer
- Update to 1.5.0.4

Release notes:  http://www.mozilla.com/thunderbird/releases/1.5.0.4.html
22 Apr 2006 21:45:05
Original commit files touched by this commit  1.5.0.2
 This port version is marked as vulnerable.
marcus search for other commits by this committer
Update to 1.5.0.2.
29 Mar 2006 18:29:45
Original commit files touched by this commit  1.5_2
 This port version is marked as vulnerable.
ahze search for other commits by this committer
- Convert all gecko pkg-[de]install scripts into a generic
  pkg-[de]install script
- Always use pkg-install to create missing dir's [1]

Requested by:   marcus [1]
23 Feb 2006 06:23:52
Original commit files touched by this commit  1.5
 This port version is marked as vulnerable.
marcus search for other commits by this committer
Mark IGNORE on sparc64 due to core dump.
01 Feb 2006 17:42:43
Original commit files touched by this commit  1.5
 This port version is marked as vulnerable.
marcus search for other commits by this committer
Add an empty OPTIONS declaration to enable additional OPTIONS that are added
after bsd.port.pre.mk is included.

PR:             92106
Submitted by:   jacula modyun <jacula@gmail.com>
12 Jan 2006 05:54:32
Original commit files touched by this commit  1.5
 This port version is marked as vulnerable.
ahze search for other commits by this committer
- Update thunderbird to 1.5 [1]
- Remove thunderbird-devel
- Remove thunderbird from supported geckos for 4.x

Release notes:  http://www.mozilla.com/thunderbird/releases/1.5.html
08 Jan 2006 19:44:30
Original commit files touched by this commit  1.0.7_6
 This port version is marked as vulnerable.
marcus search for other commits by this committer
Mark not for ia64 since regchrome (and the application itself) dumps core.

Reported by:    pointyhat via kris
18 Dec 2005 23:39:27
Original commit files touched by this commit  1.0.7_6
 This port version is marked as vulnerable.
marcus search for other commits by this committer
Fix packaging by forcing the isp files into the plist.

Reported by:    pointyhat via kris
03 Dec 2005 21:09:56
Original commit files touched by this commit  1.0.7_5
 This port version is marked as vulnerable.
marcus search for other commits by this committer
* Re-enable movemail and RSS support [1]
* Remove a line that is no longer needed

PR:             89871 [1]
02 Dec 2005 05:30:01
Original commit files touched by this commit  1.0.7_4
 This port version is marked as vulnerable.
mezz search for other commits by this committer
Fix all those ports to find libnssckbi.so in the correct place to allow those
SSL certificates work again. Somehow, this patch was lost in the big change,
so bring it back. Bump PORTREVISION on all of those ports.

PR:             ports/89796
Reported by:    Christoph Moench-Tegeder <cmt@burggraben.net>
30 Nov 2005 23:52:27
Original commit files touched by this commit  1.0.7_3
 This port version is marked as vulnerable.
ahze search for other commits by this committer
- Fix typo in CONFLICTS

Submitted by:   yattaran@gmail.com
30 Nov 2005 07:02:59
Original commit files touched by this commit  1.0.7_3
 This port version is marked as vulnerable.
ahze search for other commits by this committer
- Update WWW
29 Nov 2005 21:12:29
Original commit files touched by this commit  1.0.7_3
 This port version is marked as vulnerable.
ahze search for other commits by this committer
- Update firefox to 1.5
- Add Makefile.common
  o A new build/install system for gecko ports, Makefile.common
    includes many generic routines and common tasks.
  o Fix ld-run-path in all gecko's by using -Wl,-rpath,${moz_libdir}
    thus removing the need to have a startup script for ports that
    depend on gecko. [2]
  o Use system libm, nss, nspr in all gecko ports

- Add bsd.gecko.mk
  o This is the predecessor to WITH_MOZILLA=[mozilla|firefox|...]
    with a more robust way of detecting a gecko a end user wishs to
    use.
  o bsd.gecko.mk abstracts the selection of gecko-based backends. It
    allows users and porters to support any available gecko backend
(Only the first 15 lines of the commit message are shown above View all of this commit message)
23 Nov 2005 22:41:05
Original commit files touched by this commit  1.0.7_1
 This port version is marked as vulnerable.
pav search for other commits by this committer
- Add SHA256 checksums
05 Nov 2005 05:22:06
Original commit files touched by this commit  1.0.7_1
 This port version is marked as vulnerable.
marcus search for other commits by this committer
Bump PORTREVISION to chase the glib20 shared library update.
30 Sep 2005 05:35:28
Original commit files touched by this commit  1.0.7
 This port version is marked as vulnerable.
marcus search for other commits by this committer
Update to 1.0.7.

Security:       See
http://www.mozilla.org/projects/security/known-vulnerabilities.html for security
bugs fixed in this release.
23 Sep 2005 20:42:37
Original commit files touched by this commit  1.0.6_3
 This port version is marked as vulnerable.
mezz search for other commits by this committer
- Fix the sed for libesd and kill the major version of library
  (libesd.so.2 -> libesd.so). [1]
- Update Java plugins by remove old and correct Java 1.5 plugin path. [2]
- Bump the PORTREVISION.

PR:             ports/86430 [1]
Submitted by:   Mark Hobden <markhobden@gmail.com> [1]
                glewis [2]
07 Sep 2005 07:27:45
Original commit files touched by this commit  1.0.6_2
 This port version is marked as vulnerable.
mezz search for other commits by this committer
- Fix the plist. [1]
- Fix the build to actually enable iconv, without it caused locale garbled in
  some places. I accidented remove iconv hack in the big change. Oops!
- Bump the PORTREVISION.

Reported by:    krismail [1], Junji Nakanishi <nakanishi@daemonfreaks.com>
Sharp eye:      marcus (he found that I lost iconv hack)
28 Aug 2005 08:00:01
Original commit files touched by this commit  1.0.6_1
 This port version is marked as vulnerable.
mezz search for other commits by this committer
- Repo copy a lot of changes from www/firefox/Makefile. The best part is that
  before it would install in the strange place like this.

        ${X11BASE}/lib/thunderbird/include/thunderbird-1.0.6

  Now it will install in the correct place like firefox:

        ${X11BASE}/include/thunderbird

  Also, get *.pc and idl files install.
- Didn't copy following from www/firefox/Makefile:
        * plugins stuff, because it's known cause the stability problem like
          crash.
        * EXTRA_SCRIPTS=${PORTNAME}.rb, thunderbird doesn't need it.
- Make portlint happier.
(Only the first 15 lines of the commit message are shown above View all of this commit message)
21 Jul 2005 07:26:46
Original commit files touched by this commit  1.0.6
 This port version is marked as vulnerable.
ahze search for other commits by this committer
- Update to 1.0.6
14 Jul 2005 04:53:06
Original commit files touched by this commit  1.0.5
 This port version is marked as vulnerable.
marcus search for other commits by this committer
Update to 1.0.5.  This is primarily a security and stability fix release.

Security:       See
http://www.mozilla.org/projects/security/known-vulnerabilities.html for a list
of vulnerabilities fixed in 1.0.5
08 Jul 2005 05:22:31
Original commit files touched by this commit  1.0.2_1
 This port version is marked as vulnerable.
marcus search for other commits by this committer
Correct the GNOME menu icon location.  I'm not bumping PORTREVISION as this
only affects GNOME users, and is a small change for such a long compilation.

PR:             80937
Submitted by:   NIIMI Satoshi <sa2c@sa2c.net>
27 Apr 2005 11:33:51
Original commit files touched by this commit  1.0.2_1
 This port version is marked as vulnerable.
ahze search for other commits by this committer
- Add missing quite to fix install

Reported by:    verm@darkbeer.org
26 Apr 2005 19:30:55
Original commit files touched by this commit  1.0.2_1
 This port version is marked as vulnerable.
ahze search for other commits by this committer
- Install .desktop file in share/applications instead of
  share/gnome/applications so we can remove the gnomehier
  dependency so non-gnome users don't have to install a bunch
  of un-needed gnome directories.
- Remove WITH_MENU option from mozilla[-devel], .desktop file
  will always be installed now.
14 Apr 2005 00:29:49
Original commit files touched by this commit  1.0.2_1
 This port version is marked as vulnerable.
ahze search for other commits by this committer
- Remove mng support, it has never worked
25 Mar 2005 05:53:04
Original commit files touched by this commit  1.0.2_1
 This port version is marked as vulnerable.
marcus search for other commits by this committer
* Update to 1.0.2 to fix security issues (see
  http://www.vuxml.org/freebsd/7d2aac52-9c6b-11d9-99a7-000a95bc6fae.html for
  more details)
* Cleanup home directories to make migration easier [1]
* Add an improved startup script [1]
* Support GConf for external protocol handlers

PR:             75837 [1]
Submitted by:   Jose M Rodriguez (freebsd) <josemi@freebsd.jazztel.es> [1]
Approved by:    portmgr (implicit)
12 Mar 2005 10:54:27
Original commit files touched by this commit  1.0_2
 This port version is marked as vulnerable.
marcus search for other commits by this committer
Bump PORTREVISION to chase the glib20 shared lib version change.
10 Mar 2005 00:43:23
Original commit files touched by this commit  1.0_1
 This port version is marked as vulnerable.
marcus search for other commits by this committer
Update freetype2 to 2.1.9, and patch Mozilla and friends accordingly.
Note: since 2.1.9 is ABI compatible with 2.1.7, no recompilation is
necessary.

PR:             78385
Submitted by:   lesi

Number of commits found: 238 (showing only 100 on this page)

«  1 | 2 | 3  »  

Login
User Login
Create account

Servers and bandwidth provided by
New York Internet, SuperNews, and RootBSD

This site
What is FreshPorts?
About the authors
FAQ
How big is it?
The latest upgrade!
Privacy
Forums
Blog
Contact

Search
Enter Keywords:
 
more...

Latest Vulnerabilities
bind910Jul 28
bind99Jul 28
logstashJul 27
openssh-portableJul 27
chromiumJul 25
wordpress*Jul 24
wordpress*Jul 24
wordpress*Jul 24
wordpress*Jul 24
wordpress-zh_TW*Jul 24
libidnJul 23
opensaml2Jul 23
shibboleth2-spJul 23
soxJul 23
soxJul 23

32 vulnerabilities affecting 83 ports have been reported in the past 14 days

* - modified, not new

All vulnerabilities


Ports
Home
Categories
Deleted ports
Sanity Test Failures
Newsfeeds

Statistics
Graphs
NEW Graphs (Javascript)
Traffic

Calculated hourly:
Port count 25083
Broken 202
Deprecated 105
Ignore 499
Forbidden 1
Restricted 204
No CDROM 94
Vulnerable 48
Expired 0
Set to expire 93
Interactive 0
new 24 hours 8
new 48 hours15
new 7 days37
new fortnight82
new month200

Servers and bandwidth provided by
New York Internet, SuperNews, and RootBSD
Valid HTML, CSS, and RSS.
Copyright © 2000-2014 Dan Langille. All rights reserved.