FreshPorts -- The Place For Ports If you buy from Amazon USA, please support us by using this link.
Follow us
Blog
Twitter

I am looking for an LTO tape library. Do you have one to spare?
Port details
rubygem-xmpp4r 0.5_1 net-im Deleted on this many watch lists=0 search for ports that depend on this port
Broken BROKEN: does not work with ruby 1.9
Deprecated DEPRECATED: Does not work with Ruby 1.9
Expired This port expired on: 2013-10-10
Ignore IGNORE: is marked as broken: does not work with ruby 1.9
XMPP/Jabber library for Ruby
Was Maintained by: miwi@FreeBSD.org search for ports maintained by this maintainer
Port Added: 20 Mar 2009 23:46:29
Also Listed In: ruby rubygems
License: not specified in port
XMPP4R is an XMPP/Jabber library for Ruby.

Features:
* Fully object-oriented (well, it's Ruby ;)
* Aims at being XMPP compliant
* Threaded and non-threaded mode
* Well unit-tested and documented code
* Uses well-known and well-tested software like REXML
* Very easy to extend
* Released under Ruby's license, which is compatible with the GNU GPL

WWW: http://home.gna.org/xmpp4r/
SVNWeb : Main Web Site : Distfiles Availability : PortsMon

NOTE: FreshPorts displays only information on required and default dependencies. Optional dependencies are not covered.

Required To Build:
  1. devel/ruby-gems
  2. lang/ruby19
Required To Run:
  1. devel/ruby-gems
  2. lang/ruby19
There are no ports dependent upon this port

No installation instructions: this port has been deleted.

The package name of this deleted port was: rubygem-xmpp4r


Configuration Options
     No options to configure

Master Sites:
  1. ftp://ftp.FreeBSD.org/pub/FreeBSD/ports/distfiles/rubygem/
  2. http://production.cf.rubygems.org/gems/
  3. http://production.s3.rubygems.org/gems/
Port Moves
  • port deleted on 2013-10-11
    REASON: Has expired: Does not work with Ruby 1.9
  • port moved here from net-im/ruby-xmpp4r on 2009-03-21
    REASON: Renamed

Number of commits found: 14

Commit History - (may be incomplete: see SVNWeb link above for full details)
DateByDescription
11 Oct 2013 05:34:29
Original commit files touched by this commit  0.5_1
Revision:330056
tabthorpe search for other commits by this committer
2013-10-10 audio/ruby-vorbisfile: Does not work with Ruby 1.9
2013-10-10 audio/ruby-xmms: Does not work with Ruby 1.9
2013-10-10 databases/ruby-interbase: Does not work with Ruby 1.9
2013-10-10 databases/ruby-bdb1: Does not work with Ruby 1.9
2013-10-10 devel/ruby-fam: Does not work with Ruby 1.9
2013-10-10 devel/ruby-rcov: Does not work with Ruby 1.9
2013-10-10 devel/ruby-rudl: Does not work with Ruby 1.9
2013-10-10 devel/ruby-gemfinder: Does not work with Ruby 1.9
2013-10-10 devel/ruby-sysvipc: Does not work with Ruby 1.9
2013-10-10 devel/rubygem-sdl: Does not work with Ruby 1.9
2013-10-10 devel/rubygem-ncurses: Does not work with Ruby 1.9
2013-10-10 devel/rubygem-parsetree: Does not work with Ruby 1.9
2013-10-10 devel/ruby-sexp: Does not work with Ruby 1.9
2013-10-10 devel/rubygem-getopt-declare: Does not work with Ruby 1.9
2013-10-10 devel/ruby-slang: Does not work with Ruby 1.9
(Only the first 15 lines of the commit message are shown above View all of this commit message)
26 Sep 2013 21:13:59
Original commit files touched by this commit  0.5_1
Revision:328414
tabthorpe search for other commits by this committer
- Change EXPIRATION_DATE to 2013-10-10, to match removal of lang/ruby18

Discussed with:	swills
20 Sep 2013 22:13:35
Original commit files touched by this commit  0.5_1
Revision:327756
bapt search for other commits by this committer
Add NO_STAGE all over the place in preparation for the staging support (cat:
net-im)
03 Mar 2013 01:43:03
Original commit files touched by this commit  0.5_1
Revision:313317
swills search for other commits by this committer
- Fix EXPIRATION date, we are in 2013, not 2012

Pointyhat to:	swills
Reported by:	bapt
02 Mar 2013 21:01:59
Original commit files touched by this commit  0.5_1
Revision:313298
swills search for other commits by this committer
- Deprecate ports which don't work with Ruby 1.9
- Set expiration to 2 months to give plenty of time to fix them to anyone who
  may be interested (patching rubygem- ports is possible now)
- Trim headers while here

With Hat:	ruby@
20 Dec 2011 23:03:12
Original commit files touched by this commit  0.5_1
pgollucci search for other commits by this committer
- Standardize the BROKEN= message for ruby 1.9 for rubgems so tb/ph can tag it

With Hat:       ruby@
04 Jul 2011 17:46:12
Original commit files touched by this commit  0.5_1
swills search for other commits by this committer
- Mark as broken with Ruby 1.9

Approved by:    portmgr
20 Mar 2011 12:54:45
Original commit files touched by this commit  0.5_1
miwi search for other commits by this committer
- Get Rid MD5 support
13 Sep 2010 23:33:44
Original commit files touched by this commit  0.5_1
pgollucci search for other commits by this committer
- Add missing rubygem virtual categories
02 Jun 2010 08:31:53
Original commit files touched by this commit  0.5_1
miwi search for other commits by this committer
- Use RG macro

PR:             147045
29 Aug 2009 09:22:23
Original commit files touched by this commit  0.5_1
miwi search for other commits by this committer
- Update MASTER_SITES
- Fix examples
13 Jul 2009 22:19:22
Original commit files touched by this commit  0.5
miwi search for other commits by this committer
- Update to 0.5
20 Mar 2009 23:49:42
Original commit files touched by this commit  0.4
miwi search for other commits by this committer
- Update to 0.4
- Take maintainership
- Disconnect/Connect ruby-xmpp4r/rubygem-xmpp4r

PR:             131757
Submitted by:   Wen Heping <wenheping@gmail.com>
20 Mar 2009 23:46:09
Original commit files touched by this commit  0.3.2
miwi search for other commits by this committer
- Force commit to note:
                repocopy net-im/ruby-xmpp4r --> net-im/rubygem-xmpp4r

Repocopy by:    marcus

Number of commits found: 14

Login
User Login
Create account

Servers and bandwidth provided by
New York Internet, SuperNews, and RootBSD

This site
What is FreshPorts?
About the authors
FAQ
How big is it?
The latest upgrade!
Privacy
Forums
Blog
Contact

Search
Enter Keywords:
 
more...

Latest Vulnerabilities
ntpDec 20
ntp-develDec 20
gitDec 19
otrsDec 16
mod_dav_svnDec 15
subversionDec 15
subversion16Dec 15
subversion17Dec 15
nvidia-driverDec 14
nvidia-driver-173Dec 14
nvidia-driver-304Dec 14
asterisk11Dec 11
bind99Dec 11
xorg-serverDec 10
unboundDec 09

10 vulnerabilities affecting 27 ports have been reported in the past 14 days

* - modified, not new

All vulnerabilities


Ports
Home
Categories
Deleted ports
Sanity Test Failures
Newsfeeds

Statistics
Graphs
NEW Graphs (Javascript)
Traffic

Calculated hourly:
Port count 24434
Broken 144
Deprecated 70
Ignore 397
Forbidden 2
Restricted 207
No CDROM 93
Vulnerable 19
Expired 0
Set to expire 65
Interactive 0
new 24 hours 3
new 48 hours3
new 7 days25
new fortnight41
new month137

Servers and bandwidth provided by
New York Internet, SuperNews, and RootBSD
Valid HTML, CSS, and RSS.
Copyright © 2000-2014 Dan Langille. All rights reserved.