FreshPorts -- The Place For Ports If you buy from Amazon USA, please support us by using this link.
Follow us
Blog
Twitter

Port details
libvncserver Provide an easy API to a custom vnc server
0.9.10_1 net on this many watch lists=18 search for ports that depend on this port An older version of this port was marked as vulnerable. Find issues related to this port Report an issue related to this port

There is no maintainer for this port.
Any concerns regarding this port should be directed to the FreeBSD Ports mailing list via ports@FreeBSD.org search for ports maintained by this maintainer
Port Added: 09 Feb 2004 02:56:30
Also Listed In: devel
License: GPLv2
LibVNCServer is ripped out of Xvnc to provide an easy API to write one's own
vnc server.

WWW: http://libvnc.github.io/
SVNWeb : Homepage : PortsMon

To install the port: cd /usr/ports/net/libvncserver/ && make install clean
To add the package: pkg install libvncserver

PKGNAME: libvncserver

distinfo:

TIMESTAMP = 1466709748
SHA256 (LibVNC-libvncserver-LibVNCServer-0.9.10_GH0.tar.gz) = ed10819a5bfbf269969f97f075939cc38273cc1b6d28bccfb0999fba489411f7
SIZE (LibVNC-libvncserver-LibVNCServer-0.9.10_GH0.tar.gz) = 1415191


NOTE: FreshPorts displays only information on required and default dependencies. Optional dependencies are not covered.

Build dependencies:
  1. autoconf-2.69 : devel/autoconf
  2. autoheader-2.69 : devel/autoconf
  3. autoreconf-2.69 : devel/autoconf
  4. aclocal-1.15 : devel/automake
  5. automake-1.15 : devel/automake
  6. libtoolize : devel/libtool
  7. pkgconf>=0.9.10 : devel/pkgconf
Library dependencies:
  1. libpng.so : graphics/png
  2. libjpeg.so : graphics/jpeg-turbo

This port is required by:

for Libraries * - deleted ports are only shown under the This port is required by section. It was harder to do for the Required section. Perhaps later...
Configuration Options
===> The following configuration options are available for libvncserver-0.9.10_1:
     GCRYPT=off: libgcrypt support
     IPV6=on: IPv6 protocol support
     VAAPI=off: VAAPI (GPU video acceleration) support
====> SSL protocol support: you have to select exactly one of them
     GNUTLS=off: SSL/TLS support via GnuTLS
     OPENSSL=on: SSL/TLS support via OpenSSL
===> Use 'make config' to modify these settings

USES:
autoreconf jpeg libtool pathfix pkgconfig ssl

Master Sites:
  1. https://codeload.github.com/LibVNC/libvncserver/tar.gz/LibVNCServer-0.9.10?dummy=/

Number of commits found: 56

Commit History - (may be incomplete: see SVNWeb link above for full details)
DateByDescription
29 Nov 2016 18:46:22
Original commit files touched by this commit  0.9.10_1
Revision:427389
mat search for other commits by this committer
Mark some ports as not openssl-devel ready.

Sponsored by:	Absolight
21 Oct 2016 15:21:13
Original commit files touched by this commit  0.9.10_1
Revision:424427
mat search for other commits by this committer
Use USES=pathfix where applicable.

PR:		213195
Submitted by:	mat
Exp-run by:	antoine
Sponsored by:	Absolight
Differential Revision:	https://reviews.freebsd.org/D8093
26 Jun 2016 22:44:34
Original commit files touched by this commit  0.9.10_1
Revision:417621
woodsb02 search for other commits by this committer
net/libvncserver:
- Bump PORTREVISION post r417620 since new option was added

Reviewed by:	mat (mentor)
Approved by:	adamw (mentor)
Differential Revision:	https://reviews.freebsd.org/D6975
26 Jun 2016 22:25:52
Original commit files touched by this commit  0.9.10
Revision:417620
woodsb02 search for other commits by this committer
net/libvncserver: Fix build with libva
- Add new option to select whether to compile with VAAPI support,
  so that if multimedia/libva is already installed on the system
  during the build process, it is not linked to unless desired.
- Add patch to allow h.264 support to build using libva deprecated API

PR:		210533
Submitted by:	cpm
Reported by:	Walter Schwarzenfeld <w.schwarzenfeld@utanet.at>
Approved by:	adamw (mentor)
Differential Revision:	https://reviews.freebsd.org/D6974
24 Jun 2016 09:47:29
Original commit files touched by this commit  0.9.10
Revision:417416
woodsb02 search for other commits by this committer
net/libvncserver: Update to 0.9.10
- Change from SF to GITHUB, as old WWW redirects there
- Add USES=autoreconf pkgconfig as distfile no longer contains configure
- Remove CONFIGURE_ARGS=--without-x as it is ignored (no longer supported)
- Convert OPENSSL and GNUTLS to OPTIONS_SINGLE, as build fails with neither
- Add GNUTLS_IMPLIES=GCRYPT as build fails with GNUTLS but not GCRYPT
- Add LIB_DEPENDS=libgpg-error.so as reported by new stage-qa script
- Tidy up patches for new release, ensure pathfix applies to Makefile.am

Reported by:	dutchman01@quicknet.nl
Reviewed by:	adamw (mentor)
Approved by:	mat (mentor)
Relnotes:	https://github.com/LibVNC/libvncserver/releases/tag/LibVNCServer-0.9.10
Differential Revision:	https://reviews.freebsd.org/D6946
01 Apr 2016 14:16:20
Original commit files touched by this commit  0.9.9_12
Revision:412348 This port version is marked as vulnerable.
mat search for other commits by this committer
Remove ${PORTSDIR}/ from dependencies, categories m, n, o, and p.

With hat:	portmgr
Sponsored by:	Absolight
27 Mar 2016 14:58:00
Original commit files touched by this commit  0.9.9_12
Revision:411990 This port version is marked as vulnerable.
tijl search for other commits by this committer
- Update security/gnutls to 3.4.10.
- Rename the LIBDANE option DANE because that's the name of the protocol
  supported by libgnutls-dane and gnutls-cli.  Also clarify the option
  description.
- Add an IDN option.
- libgnutls-openssl has been removed in 3.4.  Some ports used this library
  in their LIB_DEPENDS but no port actually required it.
- Some old API functions have been removed.  Ports that used these have been
  updated or patched to use the new API.
- Add a patch to print/cups to prevent overlinking of libgnutls.so.
- Bump PORTREVISION on dependent ports.

net-im/jabber: This port used the old API to give users fine grained
control over which crypto algorithms were used via a configuration file.
It's not immediately obvious how to port this to the new API so the port
always uses the defaults now.

www/hydra: Mark BROKEN.  This uses more removed calls than the other ports,
is said to be alpha quality and not fully functional and has been abandoned
10 years ago.

PR:		207768
Exp-run by:	antoine
Approved by:	portmgr (antoine)
22 Jun 2015 18:33:22
Original commit files touched by this commit  0.9.9_11
Revision:390310 This port version is marked as vulnerable.
antoine search for other commits by this committer
Convert to USES=jpeg
02 Jan 2015 18:46:34
Original commit files touched by this commit  0.9.9_11
Revision:376062 This port version is marked as vulnerable.
pi search for other commits by this committer
security/libgcrypt: 1.6.1 -> 1.6.2, bump depends

Changes:
- src/sexp.c (do_vsexp_sscan): Return error for invalid args.
- cipher/md.c (_gcry_md_info): Fix a segv in case of calling
  with wrong parameters.
- cipher/primegen.c (_gcry_generate_elg_prime): Change to return an
  error code, possible NULL deref in call to prime generator.
- cipher/dsa.c (generate): Take care of new return code.
- cipher/elgamal.c (generate): Change to return an error code.  Take
	care of _gcry_generate_elg_prime return code.
- ecc: Support the non-standard 0x40 compression flag for EdDSA.
- mpi: Extend the internal mpi_get_buffer.
- mpi: Fix regression for powerpc-apple-darwin detection.
- Fix bug inhibiting the use of the sentinel attribute in src/gcrypt.h.in
(Only the first 15 lines of the commit message are shown above View all of this commit message)
25 Dec 2014 20:54:43
Original commit files touched by this commit  0.9.9_10
Revision:375598 This port version is marked as vulnerable.
bapt search for other commits by this committer
Bump portrevision after png update
25 Dec 2014 19:04:27
Original commit files touched by this commit  0.9.9_9
Revision:375594 This port version is marked as vulnerable.
antoine search for other commits by this committer
Change libpng15.so to libpng.so in LIB_DEPENDS to prepare the upgrade
22 Nov 2014 14:43:24
Original commit files touched by this commit  0.9.9_9
Revision:373063 This port version is marked as vulnerable.
antoine search for other commits by this committer
Cleanup plist
05 Aug 2014 22:13:29
Original commit files touched by this commit  0.9.9_9
Revision:364143 This port version is marked as vulnerable.
tijl search for other commits by this committer
Bump PORTREVISION on more ports that depend on libgcrypt after the update
in r363436 and remove the UPDATING entry because it did not guarantee
that all ports were updated nor that they were updated in the right order.
Also remove libgcrypt.la again.

PR:		192342
Approved by:	portmgr (implicit, bump unstaged ports)
27 Jul 2014 01:08:31
Original commit files touched by this commit  0.9.9_8
Revision:363005 This port version is marked as vulnerable.
marino search for other commits by this committer
net/libvncserver: fix compile warning

PR:		191527
Submitted by:	Duane
23 Jul 2014 09:54:02
Original commit files touched by this commit  0.9.9_7
Revision:362645 This port version is marked as vulnerable.
tijl search for other commits by this committer
- Replace security/gnutls with security/gnutls3 and update to 3.2.15
- Bump PORTREVISION on all ports that depend on security/gnutls and
  adjust all ports that depend on security/gnutls3
- Update mail/anubis to version 4.2 which supports gnutls 3.x
- Update mail/libvmime to a development snapshot (recommended by upstream
  developers)

PR:		191274
Exp-run by:	antoine
Approved by:	portmgr (antoine)
10 Jul 2014 13:01:01
Original commit files touched by this commit  0.9.9_6
Revision:361448 This port version is marked as vulnerable.
tijl search for other commits by this committer
- Add USES=libtool and INSTALL_TARGET=install-strip
- Use better option helper
- Remove use of PTHREAD_LIBS
16 Dec 2013 17:26:49
Original commit files touched by this commit  0.9.9_5
Revision:336648 This port version is marked as vulnerable.
bapt search for other commits by this committer
Drop maintainership
18 Oct 2013 23:27:11
Original commit files touched by this commit  0.9.9_5
Revision:330792 This port version is marked as vulnerable.
bapt search for other commits by this committer
Fix bad usage of options helpers
18 Oct 2013 23:26:07
Original commit files touched by this commit  0.9.9_5
Revision:330791 This port version is marked as vulnerable.
bapt search for other commits by this committer
Use OPTIONS helper and remove now useless bsd.port.options.mk inclusion
23 Sep 2013 06:14:29
Original commit files touched by this commit  0.9.9_5
Revision:327929 This port version is marked as vulnerable.
bapt search for other commits by this committer
Use stage
Modernize LIB_DEPENDS
20 Sep 2013 22:10:25
Original commit files touched by this commit  0.9.9_5
Revision:327755 This port version is marked as vulnerable.
bapt search for other commits by this committer
Add NO_STAGE all over the place in preparation for the staging support (cat:
net)
14 Jun 2013 14:11:51
Original commit files touched by this commit  0.9.9_5
Revision:320925 This port version is marked as vulnerable.
bapt search for other commits by this committer
Fix typo

Reported by:	wg
14 Jun 2013 14:05:59
Original commit files touched by this commit  0.9.9_5
Revision:320923 This port version is marked as vulnerable.
bapt search for other commits by this committer
Use new options helpers
03 May 2013 16:36:41
Original commit files touched by this commit  0.9.9_5
Revision:317220 This port version is marked as vulnerable.
ehaupt search for other commits by this committer
Chase security/libgcrypt update
23 Mar 2013 19:25:01
Original commit files touched by this commit  0.9.9_4
Revision:315074 This port version is marked as vulnerable.
bapt search for other commits by this committer
Add an ipv6 option
Fix openssl option

PR:		ports/175130
Submitted by:	Dmitry Kazarov <d.y.kazarov@mail.ru>
19 Mar 2013 13:04:31
Original commit files touched by this commit  0.9.9_3
Revision:314640 This port version is marked as vulnerable.
eadler search for other commits by this committer
This changes almost all the "gnomehack" only USE_GNOME cases to USES= pathfix.

If a port used other USE_GNOME items it was untouched.
The ports that used other USES were fixed by hand.

PR:		ports/177081
Reviewed by:	bapt
Approved by:	portmgr (miwi)
05 Feb 2013 16:17:07
Original commit files touched by this commit  0.9.9_3
Revision:311722 This port version is marked as vulnerable.
novel search for other commits by this committer
- Add UPDATING entry for gnutls update
- Chase shlib version bump for dependant ports
31 Dec 2012 12:41:55
Original commit files touched by this commit  0.9.9_2
Revision:309730 This port version is marked as vulnerable.
bapt search for other commits by this committer
Trim header
Remove shlib numbers
08 Jun 2012 09:18:47
Original commit files touched by this commit  0.9.9_2
 This port version is marked as vulnerable.
bapt search for other commits by this committer
Fix lookup of png library

Submitted by:   kwm
08 Jun 2012 04:56:07
Original commit files touched by this commit  0.9.9_2
 This port version is marked as vulnerable.
bapt search for other commits by this committer
Fix another typo

/me needs a coffee

Reported by:    osa
08 Jun 2012 04:47:48
Original commit files touched by this commit  0.9.9_2
 This port version is marked as vulnerable.
bapt search for other commits by this committer
Fix 2 typos
08 Jun 2012 04:11:52
Original commit files touched by this commit  0.9.9_2
 This port version is marked as vulnerable.
bapt search for other commits by this committer
Add png dependency if present of the system it is linked to.
Do not optionify it has it is recommanded to get the support for png

PR:             ports/168790
Submitted by:   Greg Lewis <glewis@misty.eyesbeyond.com>
06 Jun 2012 23:20:31
Original commit files touched by this commit  0.9.9_1
 This port version is marked as vulnerable.
flo search for other commits by this committer
Incorporate commit 66282f58000c8863e104666c30cb67b1d5cbdee3 from upstream.

  libvncserver/sockets.c: do not segfault when listenSock/listen6Sock == -1

Approved by:    bapt (maintainer)
02 Jun 2012 17:01:05
Original commit files touched by this commit  0.9.9
 This port version is marked as vulnerable.
bapt search for other commits by this committer
Convert to new options framework
05 May 2012 18:57:50
Original commit files touched by this commit  0.9.9
 This port version is marked as vulnerable.
bapt search for other commits by this committer
update to 0.9.9
Add new options for OPENSSL
activate OPENSSL by default
13 Nov 2011 08:58:06
Original commit files touched by this commit  0.9.8.2
 This port version is marked as vulnerable.
bapt search for other commits by this committer
- update to 0.9.8.2

Feature safe:   yes
14 Oct 2011 08:20:09
Original commit files touched by this commit  0.9.8.1
 This port version is marked as vulnerable.
bapt search for other commits by this committer
- Upgrade to 0.9.8.1
- Fix some problem detecting gettimeofday [1]

PR:             ports/158748 [1]
Submitted by:   Larry Rosenman <ler@lerctr.org> [1]
Patch by:       Ryan Steinmetz <rpsfa@rit.edu> [1]
23 Sep 2011 22:26:39
Original commit files touched by this commit  0.9.8
 This port version is marked as vulnerable.
amdmi3 search for other commits by this committer
- Add LDFLAGS to CONFIGURE_ENV and MAKE_ENV (as it was done with LDFLAGS)
- Fix all ports that add {CPP,LD}FLAGS to *_ENV to modify flags instead

PR:             157936
Submitted by:   myself
Exp-runs by:    pav
Approved by:    pav
31 Aug 2011 05:21:54
Original commit files touched by this commit  0.9.8
 This port version is marked as vulnerable.
bapt search for other commits by this committer
Fix the library version number for gcrypt/gnutls

Submitted by:   Ilias-Dimitrios Vrachnis <vrachil@gmail.com> (by mail)
28 Aug 2011 19:16:00
Original commit files touched by this commit  0.9.8
 This port version is marked as vulnerable.
bapt search for other commits by this committer
optionsify gnutls and gcrypt support
Remove CPPFLAGS and LDFLAGS from CONFIGURE_ENV

PR:             ports/160245
Submitted by:   Mikhail T. <m.tsatsenko@gmail.com>
11 Aug 2011 19:20:17
Original commit files touched by this commit  0.9.8
  Sanity Test Failure This port version is marked as vulnerable.
kwm search for other commits by this committer
Remove USE_GNOME=gnometarget from ports. It has been a empty keyword since
mid 2008.

PR:             ports/159624
Submitted by:   Ruslan Mahmatkhanov <cvs-src@yandex.ru>
04 Apr 2011 07:08:51
Original commit files touched by this commit  0.9.8
 This port version is marked as vulnerable.
bapt search for other commits by this committer
- upgrade to 0.9.8
- add license
- take maintainership
20 Mar 2011 12:54:45
Original commit files touched by this commit  0.9.7_2
 This port version is marked as vulnerable.
miwi search for other commits by this committer
- Get Rid MD5 support
05 Feb 2010 11:46:55
Original commit files touched by this commit  0.9.7_2
 This port version is marked as vulnerable.
dinoex search for other commits by this committer
- update to jpeg-8
28 Aug 2009 17:37:26
Original commit files touched by this commit  0.9.7_1
 This port version is marked as vulnerable.
linimon search for other commits by this committer
Reset chinsan@FreeBSD.org due to numerous maintainer-timeouts and no
response to email.

Hat:            portmgr
18 Jul 2009 11:11:29
Original commit files touched by this commit  0.9.7_1
 This port version is marked as vulnerable.
dinoex search for other commits by this committer
- update to jpeg7
Tested by:      pav on pointyhat
01 Feb 2009 07:36:43
Original commit files touched by this commit  0.9.7
 This port version is marked as vulnerable.
chinsan search for other commits by this committer
- Update to 0.9.7
- Use SF macro
18 May 2008 19:21:51
Original commit files touched by this commit  0.9.1
 This port version is marked as vulnerable.
chinsan search for other commits by this committer
- Update to 0.9.1.
- Take maintainership.
11 Sep 2006 21:56:58
Original commit files touched by this commit  0.8.2
 This port version is marked as vulnerable.
miwi search for other commits by this committer
- Update to 0.8.2

PR:             ports/103147
Submitted by:   KATO Tsuguru <tkato432(at)yahoo.com>
24 May 2006 01:19:31
Original commit files touched by this commit  0.8
 This port version is marked as vulnerable.
mnag search for other commits by this committer
- Update to 0.8
- Reset maintainer

PR:             96925
Submitted by:   Martin Wilke <freebsd___unixfreunde.de>
Approved by:    maintainer
11 May 2006 22:49:56
Original commit files touched by this commit  0.7.1
 This port version is marked as vulnerable.
edwin search for other commits by this committer
Remove USE_REINPLACE from all categories starting with N
22 Jan 2006 21:24:05
Original commit files touched by this commit  0.7.1
 This port version is marked as vulnerable.
edwin search for other commits by this committer
SHA256ify

Approved by: krion@
15 Jun 2005 20:26:35
Original commit files touched by this commit  0.7.1
 This port version is marked as vulnerable.
pav search for other commits by this committer
- Update to 0.7.1

PR:             ports/82258
Submitted by:   Andrew Turner <andrew+ports@fubar.geek.nz> (maitnainer)
02 Dec 2004 12:19:07
Original commit files touched by this commit  0.6.2
 This port version is marked as vulnerable.
vs search for other commits by this committer
- Add optional WITHOUT_X11-build
- Assign maintainership to submitter

PR:             ports/74313
Submitted by:   Andrew Turner
04 Nov 2004 22:28:58
Original commit files touched by this commit  0.6.2
 This port version is marked as vulnerable.
pav search for other commits by this committer
- Update to 0.6.2

PR:             ports/73540
Submitted by:   Craig Rodrigues <rodrigc@crodrigues.org>
09 Feb 2004 02:55:41
Original commit files touched by this commit  0.6
 This port version is marked as vulnerable.
ijliao search for other commits by this committer
add libvncserver 0.6
Provide an easy API to write one's own vnc server

Number of commits found: 56

Login
User Login
Create account

Servers and bandwidth provided by
New York Internet, SuperNews, and RootBSD

This site
What is FreshPorts?
About the authors
Issues
FAQ
How big is it?
The latest upgrade!
Privacy
Forums
Blog
Contact

Search
Enter Keywords:
 
more...

Latest Vulnerabilities
chromiumDec 05
ImageMagickDec 04
ImageMagick-nox11Dec 04
ImageMagick7Dec 04
ImageMagick7Dec 04
ImageMagick7-nox11Dec 04
ImageMagick7-nox11Dec 04
py-cryptographyDec 04
py-pillowDec 04
py3-pillowDec 04
qemuDec 04
qemu-develDec 04
qemu-sbrunoDec 04
xen-kernelDec 04
xen-kernelDec 04

35 vulnerabilities affecting 75 ports have been reported in the past 14 days

* - modified, not new

All vulnerabilities


Ports
Home
Categories
Deleted ports
Sanity Test Failures
Newsfeeds

Statistics
Graphs
NEW Graphs (Javascript)
Traffic

Calculated hourly:
Port count 26935
Broken 313
Deprecated 149
Ignore 578
Forbidden 1
Restricted 214
No CDROM 82
Vulnerable 59
Expired 9
Set to expire 128
Interactive 0
new 24 hours 11
new 48 hours19
new 7 days60
new fortnight114
new month275

Servers and bandwidth provided by
New York Internet, SuperNews, and RootBSD
Valid HTML, CSS, and RSS.
Copyright © 2000-2014 Dan Langille. All rights reserved.