FreshPorts -- The Place For Ports If you buy from Amazon USA, please support us by using this link.
Follow us
Blog
Twitter

I am looking for an LTO tape library. Do you have one to spare?
Website Feedback
 New Topic  |  Go to Top  |  Go to Topic  |  Search  |  Log In   Newer Topic  |  Older Topic 
 Site Access
Author: Vassilis 
Date:   31-08-05 14:18

I have a problem with accesing your site with any browser except links! I enter the www.freshports.org in the address field and then I get a "Forbidden - You don't have permission to access / on this server".

Could you tell me why is this happening

Thanx.

Vassilis

Reply To This Message
 
 Re: Site Access
Author: Dan 
Date:   31-08-05 14:27

I suggest it's something at your location, and not related to the website at all. I'm using Opera. It's fine. I also tried IE and Firefox.

If you are using a proxy, look at that. Do others at your location have the same problem?

Reply To This Message
 
 Re: Site Access
Author: Vassilis 
Date:   31-08-05 14:44

Every computer from this IP (I have a shared ADSL connection) cannot connect to the site using FF, Mozila, Opera, though they used to work in the past. I'm currently using links. So it is probably my location's problem. I'm using no proxy.

Reply To This Message
 
 Re: Site Access
Author: Vassilis 
Date:   31-08-05 14:56

Yes other computers from the same IP have the same problem. No browser other than links is allowed to enter your site, although in the pasth no such problem appeared. I use no proxy and the problem in pratform-independent! So probably it's my location's problem. What can I do about it?

Reply To This Message
 
 Re: Site Access
Author: Dan 
Date:   31-08-05 14:57

The hostname of the IP address that you are coming from suggests a proxy is in use.

Reply To This Message
 
 Re: Site Access
Author: Dan 
Date:   31-08-05 15:31

I suggest that if things used to work, and now they do not work, then something has changed.

I'm pretty sure it's not something at the web server. If other locations reported the same problem, then I'd suggest it's a problem at my web server.

Reply To This Message
 
 Re: Site Access
Author: Dan 
Date:   31-08-05 15:43

Can you point me to a date/time that you had this problem?

Then I can check the logs and see what is happening.

Looking at today, the only action from your IP address is via Links. Try another browser.

Reply To This Message
 
 Re: Site Access
Author: Vassilis 
Date:   31-08-05 16:25

Sorry for the multiple answers, links is behaviour some times gets on my nerves cause I get no sign that my post is submitted. I just now tried with FF deer park and I got the forbidden thing. My browser's connection settings say direct connection to the internet. In the past I had a local proxy server working but I haven't been using it for months. I don't quite recall when this behaviour appeared, but it's been a long time ago (a couple of month or three maybe) but I switched using links (just for freshports!) and I didn't want to bother you with my situation, cause I also believe it is not your server's fault. Anyway, it looks like I'm gonna use links for some time more :)

Reply To This Message
 
 Re: Site Access
Author: Dan 
Date:   31-08-05 16:37

I suspect this may be you, but I cannot be sure, as it came from a different IP address than your Links connections:

"GET / HTTP/1.1" 403 285 "-" "Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b4) Gecko/20050827 Firefox/1.0+"

Try accessing this URL: http://www.freshports.org/tmp/things.txt

Reply To This Message
 
 Re: Site Access
Author: Vassilis 
Date:   31-08-05 17:26

I use the nightly build of firefox so it could be me, but many my be using them because of the firefox testing. I tried to access the URL you gave me and I got a:
You don't have permission to access /tmp/things.txt on this server.

Reply To This Message
 
 Re: Site Access
Author: Dan 
Date:   31-08-05 17:33

Excellant. I know what the problem is.

The IP address you come from when using Links is not the same IP address when you use Firefox.

The IP address for Firefox is banned. There was too much referrer spam coming from that address.

Reply To This Message
 
 Re: Site Access
Author: Vassilis 
Date:   31-08-05 17:45

Oh I got it too now. When I used links to set up my box I used my ISP's proxy server. So you get my real IP from FF and my ISP's proxy IP from links. But why was I banned? What do you mean by "too much referrer spam"? I haven't done anything wrong, I love this site :)

Reply To This Message
 
 Re: Site Access
Author: Dan 
Date:   05-09-05 19:55

Vassilis wrote:

> Oh I got it too now. When I used links to set up my box I used
> my ISP's proxy server. So you get my real IP from FF and my
> ISP's proxy IP from links. But why was I banned?

You weren't banned. Your IP address was.

> What do you
> mean by "too much referrer spam"?

Please read http://en.wikipedia.org/wiki/Referer_spam

> I haven't done anything
> wrong, I love this site :)

I don't think it was you.

Reply To This Message
 Forum List  |  Threaded View   Newer Topic  |  Older Topic 


 Forum List  |  Need a Login? Register Here 
 User Login
 User Name:
 Password:
 Remember my login:
   
 Forgot Your Password?
Enter your email address or user name below and a new password will be sent to the email address associated with your profile.


Servers and bandwidth provided by
New York Internet, SuperNews, and RootBSD
Valid HTML, CSS, and RSS.
Copyright © 2000-2014 Dan Langille. All rights reserved.