FreshPorts -- The Place For Ports If you buy from Amazon USA, please support us by using this link.
Follow us

Please give me your LTO-4 or better tape library and I'll put it to good use.
Help with ports
 New Topic  |  Go to Top  |  Go to Topic  |  Search  |  Log In   Newer Topic  |  Older Topic 
 /emulators/virtualbox-ose Serial port shenanigans?
Author: Tsaukpaetra 
Date:   28-10-14 02:00

So I have battled my way through various forum posts and sites around the internet, and I think I have whittled my issue down to something weird in VirtualBox.
Basically, I am trying to pass a serial port into a VM for the purposes of running a fax modem.
The modem appears on the FreeBSD host as /dev/cuau0, and I can use Minicom to open it and perform various AT commands at the host level.
So, I have set a Windows 2012 VM to put the port as Com1 using the Serial Device /dev/cuau0.
The problem is, communication is highly erratic inside the Guest, most characters not coming or going correctly, even under a simple HyperTerminal session. It is almost like the CTS pin is permanently active but the actual device is not really ready for data.

Is this a known issue?
Using VirtualBox 4.3.18_OSE on FreeBSD 9.2

Apparently the users and Oracle are pointing the finger at the oh-so-highly-customized-we-dont-know-what-they-did-to-it FreeBSD version of virtualbox, and will no lift a finger to help diagnose the issue.

Reply To This Message
 Forum List  |  Threaded View   Newer Topic  |  Older Topic 

 Forum List  |  Need a Login? Register Here 
 User Login
 User Name:
 Remember my login:
 Forgot Your Password?
Enter your email address or user name below and a new password will be sent to the email address associated with your profile.

Servers and bandwidth provided by
New York Internet, SuperNews, and RootBSD
Valid HTML, CSS, and RSS.
Copyright © 2000-2014 Dan Langille. All rights reserved.