FreshPorts -- The Place For Ports If you buy from Amazon USA, please support us by using this link.
Follow us
Blog
Twitter

Port details
qpdfview Tabbed DjVu/PDF/PS document viewer
0.4.16_4 print on this many watch lists=1 search for ports that depend on this port Find issues related to this port Report an issue related to this port
Maintainer: vg@FreeBSD.org search for ports maintained by this maintainer
Port Added: 05 Aug 2012 20:38:30
License: GPLv2
qpdfview is a tabbed document viewer.  It uses Poppler for PDF
support, libspectre for PS support, DjVuLibre for DjVu support,
CUPS for printing support and the Qt toolkit for its interface.

WWW: https://launchpad.net/qpdfview
SVNWeb : Homepage : PortsMon

To install the port: cd /usr/ports/print/qpdfview/ && make install clean
To add the package: pkg install qpdfview

PKGNAME: qpdfview


NOTE: FreshPorts displays only information on required and default dependencies. Optional dependencies are not covered.

Build dependencies:
  1. update-desktop-database : devel/desktop-file-utils
  2. pkgconf : devel/pkgconf
  3. libQtDBus.so : devel/dbus-qt4
  4. libQtGui.so : x11-toolkits/qt4-gui
  5. lrelease-qt4 : devel/qt4-linguisttools
  6. moc-qt4 : devel/qt4-moc
  7. qmake-qt4 : devel/qmake4
  8. rcc : devel/qt4-rcc
  9. libQtSql.so : databases/qt4-sql
  10. libqsqlite.so : databases/qt4-sqlite3-plugin
  11. libQtSvg.so : graphics/qt4-svg
  12. libQtXml.so : textproc/qt4-xml
Runtime dependencies:
  1. update-desktop-database : devel/desktop-file-utils
  2. libQtDBus.so : devel/dbus-qt4
  3. libQtGui.so : x11-toolkits/qt4-gui
  4. lrelease-qt4 : devel/qt4-linguisttools
  5. libQtSql.so : databases/qt4-sql
  6. libqsqlite.so : databases/qt4-sqlite3-plugin
  7. libQtSvg.so : graphics/qt4-svg
  8. libQtXml.so : textproc/qt4-xml
Library dependencies:
  1. libcups.so : print/cups
  2. libpoppler-qt4.so : graphics/poppler-qt4
  3. libspectre.so : print/libspectre
There are no ports dependent upon this port

Configuration Options
===> The following configuration options are available for qpdfview-0.4.16_4:
     CUPS=on: CUPS printing system support
====> Additional documents support: you have to choose at least one of them
     DJVU=off: DjVu document support
     PS=on: PostScript document support
====> Options available for the single TOOLKITS: you have to select exactly one of them
     QT4=on: Qt 4 toolkit support
     QT5=off: Qt 5 toolkit support
===> Use 'make config' to modify these settings

USES:
desktop-file-utils pkgconfig qmake qmake:_env

Master Sites:
  1. http://distcache.FreeBSD.org/ports-distfiles/
  2. https://launchpad.net/0.4.16/trunk/0.4.16/+download/
  3. https://launchpadlibrarian.net/226592308/

Number of commits found: 27

Commit History - (may be incomplete: see SVNWeb link above for full details)
DateByDescription
01 Apr 2016 14:16:20
Original commit files touched by this commit  0.4.16_4
Revision:412348
mat search for other commits by this committer
Remove ${PORTSDIR}/ from dependencies, categories m, n, o, and p.

With hat:	portmgr
Sponsored by:	Absolight
27 Mar 2016 14:58:00
Original commit files touched by this commit  0.4.16_4
Revision:411990
tijl search for other commits by this committer
- Update security/gnutls to 3.4.10.
- Rename the LIBDANE option DANE because that's the name of the protocol
  supported by libgnutls-dane and gnutls-cli.  Also clarify the option
  description.
- Add an IDN option.
- libgnutls-openssl has been removed in 3.4.  Some ports used this library
  in their LIB_DEPENDS but no port actually required it.
- Some old API functions have been removed.  Ports that used these have been
  updated or patched to use the new API.
- Add a patch to print/cups to prevent overlinking of libgnutls.so.
- Bump PORTREVISION on dependent ports.

net-im/jabber: This port used the old API to give users fine grained
control over which crypto algorithms were used via a configuration file.
It's not immediately obvious how to port this to the new API so the port
always uses the defaults now.

www/hydra: Mark BROKEN.  This uses more removed calls than the other ports,
is said to be alpha quality and not fully functional and has been abandoned
10 years ago.

PR:		207768
Exp-run by:	antoine
Approved by:	portmgr (antoine)
11 Mar 2016 11:53:42
Original commit files touched by this commit  0.4.16_3
Revision:410825
tijl search for other commits by this committer
Combine print/cups-base, print/cups-client and print/cups-image into
print/cups and update it to 2.1.3.  Also remove print/cups-pstoraster,
improve print/cups-filters, print/foomatic-* and update print/hplip to
3.16.2.

Long description:

First some background.  When you hand a file to cups it sets up a chain of
filter programs that converts the file to something a printer understands.
Each filter has a cost associated with it and cups tries to find the
cheapest chain.  Costs used to be configured in such a way that files were
first converted to PostScript.  This could then be manipulated further (e.g.
putting multiple pages on one sheet) before finally being sent to a
PostScript printer or another filter like pstoraster which produces a raster
format understood by non-PostScript printer drivers.  Nowadays most filters
(Only the first 15 lines of the commit message are shown above View all of this commit message)
21 Jan 2016 19:40:10
Original commit files touched by this commit  0.4.16_2
Revision:406872
kwm search for other commits by this committer
Update poppler to 0.40.0. [1]

Add patches to py-poppler [2] and rubygem-poppler [3] to fix the build
of these ports with poppler 0.39+.

PR:		206293 [1]
Submitted by:	olivierd@ [1]
Obtained from:	ubuntu [2], rubygem-poppler upstream [3]
07 Dec 2015 18:09:34
Original commit files touched by this commit  0.4.16_1
Revision:403217
olivierd search for other commits by this committer
- Fix build, when QT5 option is set
- Bump PORTREVISION

PR:		204947
Submitted by:	myself
Approved by:	vg@ (maintainer)
23 Nov 2015 10:41:13
Original commit files touched by this commit  0.4.16
Revision:402268
madpilot search for other commits by this committer
Fix build by adding two missed dependencies.

Reported by:	antoine (during exp-run for PR 204672)
Approved by:	portmgr ("just fix it" blanket)
19 Nov 2015 05:02:25
Original commit files touched by this commit  0.4.16
Revision:401914
olivierd search for other commits by this committer
- Update to 0.4.16
- Add support of Qt4 (set by default) and Qt5

PR:		204563
Submitted by:	myself
Approved by:	vg@ (maintainer)
02 Aug 2015 16:06:17
Original commit files touched by this commit  0.4.14_1
Revision:393431
kwm search for other commits by this committer
Update poppler to 0.34.0. [1]

Chase all users of shlib version change of libpoppler.so.

PR:		201477 [1]
Submitted by:	olivierd@ [1]
21 Jul 2015 10:03:46
Original commit files touched by this commit  0.4.14
Revision:392617
vg search for other commits by this committer
- Changed qt4-linguist to qt4-linguisttools

PR:		ports/201697
Submitted by:	Andriy Voskoboinyk <s3erios@gmail.com>
19 May 2015 08:58:33
Original commit files touched by this commit  0.4.14
Revision:386752
vg search for other commits by this committer
- Up to 0.4.14

PR:	ports/200279
Submitted by:	pi
03 Feb 2015 12:28:24
Original commit files touched by this commit  0.4.3_4
Revision:378348
kwm search for other commits by this committer
Update poppler to 0.30.0 [1].

Make sure we use openjpeg1 in poppler, while openjpeg2 support
was added there still bugs in openjpeg2 that need to be fixed.
Add patches to inkscape for API changes in poppler 0.29.0 [2].

PR:		196599 [1]
Submitted by:	olivierd@ [1]
Exp-run by:	antoine@
Obtained from:	upstream [2]
25 Nov 2014 12:55:54
Original commit files touched by this commit  0.4.3_3
Revision:373404
makc search for other commits by this committer
Bump PORTREVISION after graphics/poppler update to 0.26.3
13 Nov 2014 07:41:18
Original commit files touched by this commit  0.4.3_2
Revision:372510
antoine search for other commits by this committer
Cleanup plist
05 Oct 2014 21:30:26
Original commit files touched by this commit  0.4.3_2
Revision:370129
tijl search for other commits by this committer
graphics/djvulibre:
- Add USES=libtool and bump dependent ports
- Remove threading related patches
27 Dec 2013 16:54:22
Original commit files touched by this commit  0.4.3_1
Revision:337749
kwm search for other commits by this committer
Update poppler to 0.24.4.

Update comment.
Use new LIB_DEPENDS syntax, use USES=pathfix.
Stagify.

Bump portrevision of all affected ports, and Update poppler* LIB_DEPENDS to
new syntax.
25 Nov 2013 14:38:47
Original commit files touched by this commit  0.4.3
Revision:334853
makc search for other commits by this committer
- Convert to USES=qmake
- Use options helpers
- Add stage support
- Update port comment/description
- Fix PDF option, add CUPS option

Approved  by:	vg (maintainer)
22 Oct 2013 13:59:54
Original commit files touched by this commit  0.4.3
Revision:331273
amdmi3 search for other commits by this committer
- Remove manual creation and removal of share/applications, as it's now in the
mtree (categories starting with [np])

Approved by:	portmgr (bdrewery)
20 Sep 2013 22:44:00
Original commit files touched by this commit  0.4.3
Revision:327765
bapt search for other commits by this committer
Add NO_STAGE all over the place in preparation for the staging support (cat:
print)
12 Sep 2013 00:21:11
Original commit files touched by this commit  0.4.3
Revision:327018
marino search for other commits by this committer
Add explicit dependency on pkgconf (27 ports)
22 Jul 2013 14:34:23
Original commit files touched by this commit  0.4.3
Revision:323455
vg search for other commits by this committer
 - Changed my email
 - Trim Makefile headers and positions name and surname within

Approved by:	eadler, rm (mentors)
02 Jun 2013 16:41:27
Original commit files touched by this commit  0.4.3
Revision:319685
pawel search for other commits by this committer
Update to version 0.4.3

PR:		ports/179073
Submitted by:	Veniamin Gvozdikov <g.veniamin@googlemail.com> (maintainer)
18 May 2013 20:01:36
Original commit files touched by this commit  0.4_2
Revision:318445
rakuco search for other commits by this committer
Adjust Qt dependencies to fix a bug which prevented images from being shown.

PR:		ports/178558
Submitted by:	Veniamin Gvozdikov <g.veniamin@googlemail.com> (maintainer)
21 Mar 2013 05:27:16
Original commit files touched by this commit  0.4_1
Revision:314805
mezz search for other commits by this committer
- Update poppler to 0.22.2.
- Bump the rest ports that depend on the poppler and poppler-qt because of
  shared library version have been changed.
- Add a note in the UPDATING for require to rebuild all ports that depend
  on poppler.

Submitted by:	kwm (poppler* part)
19 Feb 2013 16:43:11
Original commit files touched by this commit  0.4
Revision:312588
pawel search for other commits by this committer
- Update to version 0.4
- Add optional support for DjVu and PostScript

While here:
- Respect CFLAGS, CXXFLAGS
- Fix WWW line, convert tab -> space

PR:		ports/176244
Submitted by:	Veniamin Gvozdikov <g.veniamin@googlemail.com> (maintainer)
14 Dec 2012 19:43:35
Original commit files touched by this commit  0.3.7
Revision:308924
jgh search for other commits by this committer
- update to 0.3.7

PR:		174378
Submitted by:	maintainer, g.veniamin@googlemail.com
20 Sep 2012 00:00:31
Original commit files touched by this commit  0.3.1
Revision:304554
makc search for other commits by this committer
Convert remaining ports to USE_QT4
05 Aug 2012 20:38:11
Original commit files touched by this commit  0.3.1
bdrewery search for other commits by this committer
qpdfview is a tabbed PDF viewer using the poppler library.

PR:		ports/170330
Submitted by:	Veniamin Gvozdikov <g.veniamin@googlemail.com>
Approved by:	eadler (mentor)

Number of commits found: 27

Login
User Login
Create account

Servers and bandwidth provided by
New York Internet, SuperNews, and RootBSD

This site
What is FreshPorts?
About the authors
Issues
FAQ
How big is it?
The latest upgrade!
Privacy
Forums
Blog
Contact

Search
Enter Keywords:
 
more...

Latest Vulnerabilities
logstashApr 28
subversionApr 28
subversion18Apr 28
ntpApr 27
ntp-develApr 27
firefoxApr 26
firefox-esrApr 26
libxulApr 26
linux-firefoxApr 26
linux-seamonkeyApr 26
linux-thunderbirdApr 26
seamonkeyApr 26
thunderbirdApr 26
phpmyfaqApr 23
libtasn1Apr 21

16 vulnerabilities affecting 44 ports have been reported in the past 14 days

* - modified, not new

All vulnerabilities


Ports
Home
Categories
Deleted ports
Sanity Test Failures
Newsfeeds

Statistics
Graphs
NEW Graphs (Javascript)
Traffic

Calculated hourly:
Port count 25985
Broken 286
Deprecated 60
Ignore 552
Forbidden 0
Restricted 203
No CDROM 86
Vulnerable 54
Expired 23
Set to expire 47
Interactive 0
new 24 hours 5
new 48 hours7
new 7 days25
new fortnight56
new month139

Servers and bandwidth provided by
New York Internet, SuperNews, and RootBSD
Valid HTML, CSS, and RSS.
Copyright © 2000-2014 Dan Langille. All rights reserved.