FreshPorts -- The Place For Ports If you buy from Amazon USA, please support us by using this link.
Follow us
Blog
Twitter

Port details
gnutls GNU Transport Layer Security library
3.5.9 security on this many watch lists=220 search for ports that depend on this port An older version of this port was marked as vulnerable. Find issues related to this port Report an issue related to this port
Maintainer: tijl@FreeBSD.org search for ports maintained by this maintainer
Port Added: 07 Jan 2003 14:04:11
Also Listed In: net
License: GPLv3 LGPL21
GnuTLS is a secure communications library implementing the SSL, TLS and DTLS
protocols and technologies around them.  It provides a simple C language
application programming interface (API) to access the secure communications
protocols as well as APIs to parse and write X.509, PKCS #12, OpenPGP and
other required structures.  It is aimed to be portable and efficient with
focus on security and interoperability.

WWW: http://www.gnutls.org/
SVNWeb : Homepage : PortsMon

To install the port: cd /usr/ports/security/gnutls/ && make install clean
To add the package: pkg install gnutls

PKGNAME: gnutls

ONLY_FOR_ARCHS: nil

NOT_FOR_ARCHS: nil

distinfo:

TIMESTAMP = 1486998078
SHA256 (gnutls-3.5.9.tar.xz) = 82b10f0c4ef18f4e64ad8cef5dbaf14be732f5095a41cf366b4ecb4050382951
SIZE (gnutls-3.5.9.tar.xz) = 7166932


NOTE: FreshPorts displays only information on required and default dependencies. Optional dependencies are not covered.

Build dependencies:
  1. ca-root-nss.crt : security/ca_root_nss
  2. gmake : devel/gmake
  3. pkgconf>=0.9.10 : devel/pkgconf
  4. msgfmt : devel/gettext-tools
Runtime dependencies:
  1. ca-root-nss.crt : security/ca_root_nss
  2. indexinfo : print/indexinfo
Library dependencies:
  1. libgmp.so : math/gmp
  2. libnettle.so : security/nettle
  3. libtasn1.so : security/libtasn1
  4. libunistring.so : devel/libunistring
  5. libidn.so : dns/libidn
  6. libp11-kit.so : security/p11-kit
  7. libtspi.so : security/trousers
  8. libiconv.so : converters/libiconv
  9. libintl.so : devel/gettext-runtime

This port is required by:

for Build for Libraries
  1. audio/ario
  2. audio/pianobar
  3. audio/tomahawk
  4. deskutils/fusenshi
  5. deskutils/taskd
  6. deskutils/taskwarrior
  7. devel/gwenhywfar
  8. Expand this list (130 items)
  9. devel/gwenhywfar-fox16
  10. devel/gwenhywfar-gtk2
  11. devel/gwenhywfar-qt4
  12. devel/gwenhywfar-qt5
  13. devel/librelp
  14. devel/libvirt
  15. devel/opendht
  16. dns/knot-resolver
  17. dns/knot2
  18. editors/abiword
  19. editors/emacs
  20. editors/emacs-devel
  21. editors/emacs-nox11
  22. emulators/qemu
  23. emulators/qemu-devel
  24. emulators/qemu-sbruno
  25. emulators/wine
  26. emulators/wine-devel
  27. emulators/wine-staging
  28. finance/aqbanking
  29. ftp/filezilla
  30. ftp/wput
  31. ftp/wzdftpd
  32. games/pokerth
  33. irc/bitlbee
  34. irc/ctrlproxy
  35. irc/weechat
  36. irc/weechat-devel*
  37. japanese/jd
  38. lang/gnustep-base
  39. mail/anubis
  40. mail/claws-mail
  41. mail/libvmime
  42. mail/mailutils
  43. mail/xfce4-mailwatch-plugin
  44. multimedia/ffmpeg
  45. multimedia/ffmpeg-011*
  46. multimedia/ffmpeg-devel*
  47. multimedia/ffmpeg1*
  48. multimedia/ffmpeg2*
  49. multimedia/ffmpeg23*
  50. multimedia/ffmpeg24*
  51. multimedia/ffmpeg25*
  52. multimedia/ffmpeg26*
  53. multimedia/kodi
  54. multimedia/libav
  55. multimedia/mencoder
  56. multimedia/mplayer
  57. multimedia/vlc
  58. multimedia/vlc-qt4
  59. net/csync2
  60. net/freediameter
  61. net/glib-networking
  62. net/gtk-vnc
  63. net/morebalance
  64. net/net6
  65. net/ocserv
  66. net/pacemaker
  67. net/remmina-plugin-vnc
  68. net/samba4*
  69. net/samba41*
  70. net/samba42
  71. net/samba43
  72. net/samba44
  73. net/sixxs-aiccu
  74. net/tigervnc
  75. net/tigervnc-devel
  76. net/tshark
  77. net/tshark-lite
  78. net/uget
  79. net/vino
  80. net/wireshark
  81. net/wireshark-lite
  82. net/yaz
  83. net-im/gloox
  84. net-im/jabber
  85. net-im/loudmouth
  86. net-im/qutim-plugin-jabber*
  87. net-im/ring-daemon
  88. net-mgmt/riemann-c-client
  89. net-p2p/gnunet
  90. net-p2p/gtk-gnutella
  91. net-p2p/ncdc
  92. news/pan
  93. polish/ekg2
  94. polish/libgadu
  95. print/cups
  96. print/cups-base*
  97. print/cups-client*
  98. print/cups-image*
  99. security/gnomint
  100. security/gnupg
  101. security/greenbone-security-assistant
  102. security/gsasl
  103. security/hs-gnutls
  104. security/libprelude
  105. security/openconnect-gui
  106. security/openvas-cli
  107. security/openvas-libnasl*
  108. security/openvas-libraries
  109. security/openvas-manager
  110. security/openvas-plugins*
  111. security/prelude-lml*
  112. security/prelude-manager*
  113. security/py-gnutls
  114. security/shishi
  115. sysutils/heartbeat
  116. sysutils/rsyslog5-gnutls*
  117. sysutils/rsyslog6-devel-gnutls*
  118. sysutils/rsyslog6-gnutls*
  119. textproc/iksemel
  120. www/gurlchecker
  121. www/hydra*
  122. www/kazehakase*
  123. www/libepc
  124. www/mod_gnutls*
  125. www/ocaml-net
  126. www/wwwoffle
  127. www/xombrero
  128. www/xxxterm*
  129. x11/roxterm
  130. x11/sakura
  131. x11-toolkits/vte3
  132. Collapse this list.
for Run * - deleted ports are only shown under the This port is required by section. It was harder to do for the Required section. Perhaps later...
Configuration Options
===> The following configuration options are available for gnutls-3.5.9:
     DANE=off: Certificate verification via DNSSEC
     EXAMPLES=on: Build and/or install examples
     IDN=on: International Domain Names support
     NLS=on: Native Language Support
     P11KIT=on: PKCS#11 and p11-kit support
     TPM=on: Trusted Platform Module support
     ZLIB=on: zlib compression support
===> Use 'make config' to modify these settings

USES:
compiler cpe gmake iconv libtool localbase makeinfo  pathfix pkgconfig tar:xz gettext

Master Sites:
  1. ftp://ftp.crysys.hu/pub/gnupg/gnutls/v3.5/
  2. ftp://ftp.franken.de/pub/crypt/mirror/ftp.gnupg.org/gcrypt/gnutls/v3.5/
  3. ftp://ftp.freenet.de/pub/ftp.gnupg.org/gcrypt/gnutls/v3.5/
  4. ftp://ftp.gnupg.org/gcrypt/gnutls/v3.5/
  5. ftp://ftp.sunet.se/pub/security/gnupg/gnutls/v3.5/
  6. ftp://mirror.switch.ch/mirror/gnupg/gnutls/v3.5/
  7. http://artfiles.org/gnupg.org/gnutls/v3.5/
  8. http://ftp.heanet.ie/mirrors/ftp.gnupg.org/gcrypt/gnutls/v3.5/
  9. http://gd.tuwien.ac.at/privacy/gnupg/gnutls/v3.5/
  10. http://mirror.tje.me.uk/pub/mirrors/ftp.gnupg.org/gnutls/v3.5/
  11. http://mirrors.dotsrc.org/gcrypt/gnutls/v3.5/
  12. http://www.mirrorservice.org/sites/ftp.gnupg.org/gcrypt/gnutls/v3.5/
  13. https://gnupg.org/ftp/gcrypt/gnutls/v3.5/
Notes from UPDATING
These upgrade notes are taken from /usr/ports/UPDATING
  • 2013-02-05
    Affects: users of security/gnutls and any port that depends on it
    Author: novel@FreeBSD.org
    Reason: 
      gnutls has been updated to 2.12.23 and all shared libraries versions have
      been bumped. So you need to rebuild all applications that depend on
      gnutls.
    
      If you use portmaster:
            portmaster -r gnutls
      If you use portupgrade:
            portupgrade -fr security/gnutls
      If you use pkgng with binary packages:
            pkg install -fR security/gnutls
    
    
  • 2011-06-05
    Affects: users of security/gnutls and any port that depends on it
    Author: novel@FreeBSD.org
    Reason: 
      gnutls has been updated to 2.12.6.1 and all shared libraries versions have
      been bumped. So you need to rebuild all applications that depend on
      gnutls. Do something like:
    
    	portupgrade -rf gnutls
    	portmaster -r gnutls
    
    
  • 2009-08-18
    Affects: users of security/gnutls and any port that depends on it
    Author: novel@FreeBSD.org
    Reason: 
      GnuTLS has been updated to 2.8.3 and all shared libraries versions have
      been bumped.  So you need to rebuild all applications that depend on
      gnutls.  Do something like:
    
    	portupgrade -rf gnutls
    
    
  • 2008-03-03
    Affects: users of security/gnutls and any port that depends on it
    Author: novel@FreeBSD.org
    Reason: 
      gnutls has been updated to 2.2.2 and all shared libraries versions have
      been bumped.  So you need to rebuild all applications that depend on
      gnutls. Do something like:
    
    	portupgrade -rf gnutls
    
    
Port Moves
  • port moved here from security/gnutls3 on 2014-07-22
    REASON: Moved to replace GnuTLS 2.x port

Number of commits found: 162 (showing only 100 on this page)

1 | 2  »  

Commit History - (may be incomplete: see SVNWeb link above for full details)
DateByDescription
20 Feb 2017 14:34:09
Original commit files touched by this commit  3.5.9
Revision:434443
tijl search for other commits by this committer
Update to 3.5.9.  Disable use of libidn2 for now because it does not provide
a pkgconfig file.

PR:		217073
Exp-run by:	antoine
16 Jan 2017 10:19:01
Original commit files touched by this commit  3.5.8
Revision:431622
tijl search for other commits by this committer
Make atomic operations explicit to support old gcc.

PR:		216122
14 Jan 2017 20:51:33
Original commit files touched by this commit  3.5.8
Revision:431494
jbeich search for other commits by this committer
security/gnutls: unbreak aarch64 after r431214

lib/accelerated/aarch64/elf/aes-aarch64.s.tmp.S:5:1: error: unknown directive
.arch armv8-a+crypto
^
lib/accelerated/aarch64/elf/aes-aarch64.s.tmp.S:49:2: error: instruction
requires: crypto
 aese v6.16b,v0.16b
 ^

PR:		216045
Approved by:	tijl (maintainer)
11 Jan 2017 22:27:50
Original commit files touched by this commit  3.5.8
Revision:431214
tijl search for other commits by this committer
Update to 3.5.8.

PR:		215909
Submitted by:	brnrd
Exp-run by:	antoine
MFH:		2017Q1
Security:	0c5369fc-d671-11e6-a9a5-b499baebfeaf
09 Dec 2016 10:26:28
Original commit files touched by this commit  3.4.17
Revision:428176 This port version is marked as vulnerable.
tijl search for other commits by this committer
Update to 3.4.17 and pass the right dlopen path for libtspi to configure.
17 Oct 2016 18:25:17
Original commit files touched by this commit  3.4.16
Revision:424141 This port version is marked as vulnerable.
tijl search for other commits by this committer
Update to 3.4.16.
05 Oct 2016 13:55:41
Original commit files touched by this commit  3.4.15
Revision:423344 This port version is marked as vulnerable.
jrm search for other commits by this committer
Add math/gmp to LIB_DEPENDS

Q/A warned that bin/certtool was linked to lib/libgmps.so.10

Approved by:	swills (mentor) tijl (maintainer)
Differential Revision:	https://reviews.freebsd.org/D8153
09 Sep 2016 19:42:46
Original commit files touched by this commit  3.4.15
Revision:421635 This port version is marked as vulnerable.
amdmi3 search for other commits by this committer
Most commonly used build systems support silent builds, when they
hide actual commands executed and only show short summary line (like
"CC foo.c"). CMake and ninja enable this by default, some autotools
using ports do as well. This is unacceptable because we need complete
build logs at any time, so we now switch to verbose build logs
unconditionally. Note that this change deliberately affects ALL
builds and not only package builds on cluster, because we need to
be sure that user experiencing failure can always provide informative
build log regardless of settings and without rerunning the build.

Change summary:

- Always do verbose builds for cmake, ninja and GNU configure (the
  latter includes check if --disable-silent-rules is actually supported
  by the configure script; there are isolated cases when it's not true)
(Only the first 15 lines of the commit message are shown above View all of this commit message)
09 Sep 2016 13:22:29
Original commit files touched by this commit  3.4.15
Revision:421616 This port version is marked as vulnerable.
tijl search for other commits by this committer
Update to 3.4.15.

MFH:		2016Q3
Security:	https://gnutls.org/security.html#GNUTLS-SA-2016-3
08 Jul 2016 15:36:15
Original commit files touched by this commit  3.4.14
Revision:418229 This port version is marked as vulnerable.
tijl search for other commits by this committer
Update to 3.4.14.
07 Jun 2016 16:26:30
Original commit files touched by this commit  3.4.13
Revision:416513 This port version is marked as vulnerable.
tijl search for other commits by this committer
Update to 3.4.13.
30 May 2016 18:55:21
Original commit files touched by this commit  3.4.12
Revision:416171 This port version is marked as vulnerable.
tijl search for other commits by this committer
Update to 3.4.12.

libpkcs11mock1.so is commented out in pkg-plist because it is part of the
testsuite and shouldn't be installed.  This has been fixed upstream.
12 Apr 2016 10:18:35
Original commit files touched by this commit  3.4.11
Revision:413108 This port version is marked as vulnerable.
tijl search for other commits by this committer
Update to 3.4.11.
01 Apr 2016 14:25:18
Original commit files touched by this commit  3.4.10
Revision:412349 This port version is marked as vulnerable.
mat search for other commits by this committer
Remove ${PORTSDIR}/ from dependencies, categories r, s, t, and u.

With hat:	portmgr
Sponsored by:	Absolight
27 Mar 2016 14:58:00
Original commit files touched by this commit  3.4.10
Revision:411990 This port version is marked as vulnerable.
tijl search for other commits by this committer
- Update security/gnutls to 3.4.10.
- Rename the LIBDANE option DANE because that's the name of the protocol
  supported by libgnutls-dane and gnutls-cli.  Also clarify the option
  description.
- Add an IDN option.
- libgnutls-openssl has been removed in 3.4.  Some ports used this library
  in their LIB_DEPENDS but no port actually required it.
- Some old API functions have been removed.  Ports that used these have been
  updated or patched to use the new API.
- Add a patch to print/cups to prevent overlinking of libgnutls.so.
- Bump PORTREVISION on dependent ports.

net-im/jabber: This port used the old API to give users fine grained
control over which crypto algorithms were used via a configuration file.
It's not immediately obvious how to port this to the new API so the port
always uses the defaults now.

www/hydra: Mark BROKEN.  This uses more removed calls than the other ports,
is said to be alpha quality and not fully functional and has been abandoned
10 years ago.

PR:		207768
Exp-run by:	antoine
Approved by:	portmgr (antoine)
21 Mar 2016 12:03:40
Original commit files touched by this commit  3.3.17.1_3
Revision:411557 This port version is marked as vulnerable.
tijl search for other commits by this committer
- Take maintainer.
- Fix a build problem with upcoming libc++.

PR:		207768, 208175
Approved by:	bdrewery (maintainer)
15 Mar 2016 06:21:32
Original commit files touched by this commit  3.3.17.1_3
Revision:411143 This port version is marked as vulnerable.
ohauer search for other commits by this committer
- bump PORTREVISION on ports depending on unbound

PR:		207948
Submitted by:	jaap@NLnetLabs.nl (maintainer)
04 Feb 2016 15:58:30
Original commit files touched by this commit  3.3.17.1_2
Revision:408047 This port version is marked as vulnerable.
erwin search for other commits by this committer
- Update unbound to 1.5.7
- Bump PORTREVISIOn on dependent ports

Some Upgrade Notes:

This release fixes a validation failure for nodata with wildcards and
emptynonterminals. Fixes OpenSSL Library compability. Fixes correct
response for malformed EDNS queries. For crypto in libunbound there is
libnettle support.

Qname minimisation is implemented. Use qname-minimisation: yes to
enable it. This version sends the full query name when an error is
found for intermediate names. It should therefore not fail for names
on nonconformant servers. It combines well with
harden-below-nxdomain: yes because those nxdomains are probed by the
(Only the first 15 lines of the commit message are shown above View all of this commit message)
23 Jan 2016 21:14:18
Original commit files touched by this commit  3.3.17.1_1
Revision:407058 This port version is marked as vulnerable.
johans search for other commits by this committer
Bump versions to chase Nettle shared library update
14 Aug 2015 20:38:39
Original commit files touched by this commit  3.3.17.1
Revision:394256 This port version is marked as vulnerable.
feld search for other commits by this committer
Update MASTER_SITES to fix fetching problem due to abnormal version number

PR:		202332
14 Aug 2015 16:39:59
Original commit files touched by this commit  3.3.17.1
Revision:394234 This port version is marked as vulnerable.
feld search for other commits by this committer
- Update to 3.3.17.1

MFH:		2015Q3
Relnotes:	http://permalink.gmane.org/gmane.comp.encryption.gpg.gnutls.devel/8268
Security:	ec6a2a1e-429d-11e5-9daa-14dae9d210b8
27 Jul 2015 18:59:30
Original commit files touched by this commit  3.3.16
Revision:393006 This port version is marked as vulnerable.
bdrewery search for other commits by this committer
- Update to 3.3.16

Changes: http://permalink.gmane.org/gmane.comp.encryption.gpg.gnutls.devel/8235
22 May 2015 16:16:35
Original commit files touched by this commit  3.3.15
Revision:387031 This port version is marked as vulnerable.
delphij search for other commits by this committer
Fix plist when LIBDANE is defined (PORTREVISION not bumped
because package wouldn't be successful in the case).

Pointy hat to:	delphij
Reported by:	sunpoet
MFH:		2015Q2
22 May 2015 15:46:09
Original commit files touched by this commit  3.3.15
Revision:387029 This port version is marked as vulnerable.
delphij search for other commits by this committer
Update to 3.3.15.

PR:		198875
Approved by:	maintainer
05 May 2015 19:03:01
Original commit files touched by this commit  3.2.21_1
Revision:385483 This port version is marked as vulnerable.
bdrewery search for other commits by this committer
GnuTLS tries to use /usr/local/share/certs/ca-root-nss.crt. Instead of
maybe using it if it is already installed or if the P11KIT option is selected
(which depends on ca_root_nss), just always depend on ca_root_nss.

Reported by:	Tatsuki Makino
19 Mar 2015 15:55:16
Original commit files touched by this commit  3.2.21
Revision:381607 This port version is marked as vulnerable.
bdrewery search for other commits by this committer
Add CPE information.

PR:		153859
Submitted by:	shun <shun.fbsd.pr@dropcut.net>
01 Jan 2015 12:39:07
Original commit files touched by this commit  3.2.21
Revision:375918 This port version is marked as vulnerable.
tijl search for other commits by this committer
Update gnutls to 3.2.21

PR:		196400
Approved by:	bdrewery (maintainer)
28 Oct 2014 01:13:34
Original commit files touched by this commit  3.2.19_1
Revision:371615 This port version is marked as vulnerable.
amdmi3 search for other commits by this committer
- Fix plist for LIBDANE option

Approved by:	portmgr blanket
15 Oct 2014 19:22:22
Original commit files touched by this commit  3.2.19
Revision:370946 This port version is marked as vulnerable.
bdrewery search for other commits by this committer
Fix build on systems without stdnoreturn.h

Reported by:	many
15 Oct 2014 15:38:47
Original commit files touched by this commit  3.2.19
Revision:370929 This port version is marked as vulnerable.
bdrewery search for other commits by this committer
- Update to 3.2.19
02 Oct 2014 18:40:12
Original commit files touched by this commit  3.2.18
Revision:369848 This port version is marked as vulnerable.
bdrewery search for other commits by this committer
Update to 3.2.18
30 Aug 2014 18:18:14
Original commit files touched by this commit  3.2.16_5
Revision:366659 This port version is marked as vulnerable.
tijl search for other commits by this committer
dns/libidn:
- Add USES=libtool and bump dependent ports
- Add INSTALL_TARGET=install-strip
- Always install libidn-components.png because it is used by libidn.info
- Add -lintl to Libs.private instead of Libs in libidn.pc
22 Aug 2014 09:06:35
Original commit files touched by this commit  3.2.16_4
Revision:365620 This port version is marked as vulnerable.
amdmi3 search for other commits by this committer
- Switch dns/unbound to USES=libtool, drop .la files
- Bump dependent ports as .so version has changed
- While here, add LICENSE_FILE to dns/getdns

Approved by:	portmgr blanket
29 Jul 2014 09:14:01
Original commit files touched by this commit  3.2.16_3
Revision:363301 This port version is marked as vulnerable.
koobs search for other commits by this committer
security/gnutls: Support OPTIONal library dependencies

Factor out libidn, libp11-kit and libtspi into OPTIONal library
dependencies, with the CRYWRAP, P11KIT and TPM options respectively, as per
the upstream documentation [1].

Make ZLIB an OPTION because we can, and the choice to customise
compression support in security software (especially lately) may be
very useful for some consumers.

Add CRYWRAP, P11KIT, TPM and ZLIB to OPTIONS_DEFAULT to retain current
default functionality.

[1] http://gnutls.org/manual/html_node/Downloading-and-installing.html

Inspired by:	Recent gnutls 2 -> 3 change, fan of minimal dependencies

PR:		192090
Submitted by:	koobs
Approved by:	maintainer
28 Jul 2014 06:43:09
Original commit files touched by this commit  3.2.16_2
Revision:363113 This port version is marked as vulnerable.
novel search for other commits by this committer
- Update security/libtasn1 to 4.0
- Add USES= libtool and set INSTALL_TARGET to install-strip
- Drop useless bsd.port.options.mk include
- Bump PORTREVISION of ports that depend on libtasn1 as
  shlib version has changed
- Add an UPDATING entry for that

Exp-run by:	antoine
24 Jul 2014 20:38:05
Original commit files touched by this commit  3.2.16_1
Revision:362847 This port version is marked as vulnerable.
bdrewery search for other commits by this committer
- Fix plist

Reported by:	many
24 Jul 2014 19:43:59
Original commit files touched by this commit  3.2.16
Revision:362840 This port version is marked as vulnerable.
bdrewery search for other commits by this committer
Update to 3.2.16
23 Jul 2014 09:54:02
Original commit files touched by this commit  3.2.15
Revision:362645 This port version is marked as vulnerable.
tijl search for other commits by this committer
- Replace security/gnutls with security/gnutls3 and update to 3.2.15
- Bump PORTREVISION on all ports that depend on security/gnutls and
  adjust all ports that depend on security/gnutls3
- Update mail/anubis to version 4.2 which supports gnutls 3.x
- Update mail/libvmime to a development snapshot (recommended by upstream
  developers)

PR:		191274
Exp-run by:	antoine
Approved by:	portmgr (antoine)
15 Jul 2014 16:57:39
Original commit files touched by this commit  2.12.23_6
Revision:361977 This port version is marked as vulnerable.
adamw search for other commits by this committer
Add DOCS to OPTIONS_DEFINE to ports that check for PORT_OPTIONS:MDOCS.
04 Jun 2014 18:51:20
Original commit files touched by this commit  2.12.23_6
Revision:356535 This port version is marked as vulnerable.
cy search for other commits by this committer
Patch CVE-2014-3466 to prevent memory corruption due to server hello parsing.

Obtained from: 
https://gitorious.org/gnutls/gnutls/commit/688ea6428a432c39203d00acd1af0e7684e5ddfd
Security:       CVE-2014-3466, 9733c480-ebff-11e3-970b-206a8a720317
30 Apr 2014 18:20:12
Original commit files touched by this commit  2.12.23_5
Revision:352695 This port version is marked as vulnerable.
tijl search for other commits by this committer
- New LIB_DEPENDS syntax.
- USES=libtool:keepla tar:bzip2.
- Remove -fPIC flag.  Leftover from an old version.
04 Mar 2014 22:46:56
Original commit files touched by this commit  2.12.23_4
Revision:347078 This port version is marked as vulnerable.
bdrewery search for other commits by this committer
- Add fixes for:
  CVE-2014-0092 - Certificate verification issue
  CVE-2014-1959 - Certificate verification issue

  All users are recommended to upgrade ASAP.

Security:	f645aa90-a3e8-11e3-a422-3c970e169bc2
22 Jan 2014 07:06:18
Original commit files touched by this commit  2.12.23_3
Revision:340681 This port version is marked as vulnerable.
novel search for other commits by this committer
Add an additional mirror to MASTER_SITES.

PR:		185901
Submitted by:	Bruno Machado <bruno@bsd.com.br>
21 Jan 2014 23:40:23
Original commit files touched by this commit  2.12.23_3
Revision:340674 This port version is marked as vulnerable.
bapt search for other commits by this committer
Fix properties on pkg-plist
13 Jan 2014 11:31:03
Original commit files touched by this commit  2.12.23_3
Revision:339583 This port version is marked as vulnerable.
novel search for other commits by this committer
Fix build with perl 5.18.

PR:		185595
Reviewed by:	marino
Obtained from:	Debian
10 Jan 2014 20:33:45
Original commit files touched by this commit  2.12.23_3
Revision:339382 This port version is marked as vulnerable.
marino search for other commits by this committer
security/gnutls: Fix hardcoded perl paths

Perl was recently added as a build tool for gnutls, and immediately the
port fails to build on systems that do not have the /usr/bin/perl
symlink.  The cause is harded perl path of "/usr/bin/perl".  Shebangfix
will fix a couple of these, REINPLACE_CMD will fix the other.  Committed
under the new "Just fix it" blanket, but it was tested in redports.
08 Jan 2014 11:18:44
Original commit files touched by this commit  2.12.23_3
Revision:339094 This port version is marked as vulnerable.
novel search for other commits by this committer
- Fix possbile DoS in TLS record decoding [1]
- Fix installation without NLS [2]
- Require gmake and perl for build because in some
  occasions it will rebuild the documentation that
  works in a proper way with gmake only and needs perl
- Bump PORTREVISION

Security:	CVE-2013-2116
Reported by:	mat [2]
06 Jan 2014 10:59:38
Original commit files touched by this commit  2.12.23_2
Revision:338855 This port version is marked as vulnerable.
novel search for other commits by this committer
- Support stagedir
- Add LICENSE
- Fix pkg-descr formatting

PR:		185409
Submitted by:	Takefu <takefu@airport.fm>
03 Nov 2013 09:22:00
Original commit files touched by this commit  2.12.23_2
Revision:332596 This port version is marked as vulnerable.
novel search for other commits by this committer
- Chase security/libtasn1 update
- Add UPDATING entry
20 Sep 2013 22:55:26
Original commit files touched by this commit  2.12.23_1
Revision:327769 This port version is marked as vulnerable.
bapt search for other commits by this committer
Add NO_STAGE all over the place in preparation for the staging support (cat:
security)
14 Aug 2013 22:35:54
Original commit files touched by this commit  2.12.23_1
Revision:324744  Sanity Test Failure This port version is marked as vulnerable.
ak search for other commits by this committer
- Remove MAKE_JOBS_SAFE variable

Approved by:	portmgr (bdrewery)
27 Apr 2013 18:25:25
Original commit files touched by this commit  2.12.23_1
Revision:316683 This port version is marked as vulnerable.
mva search for other commits by this committer
- Convert USE_ICONV=yes to USES=iconv
- Change USE_GNOME=pkgconfig|gnomehack to USES=pathfix|pkgconfig and
  USE_GETTEXT=yes to USES=gettext while here
26 Apr 2013 10:44:29
Original commit files touched by this commit  2.12.23_1
Revision:316596 This port version is marked as vulnerable.
ak search for other commits by this committer
- Convert USE_GETTEXT to USES (part 4)

Approved by:	portmgr (bapt)
23 Apr 2013 14:20:28
Original commit files touched by this commit  2.12.23_1
Revision:316355 This port version is marked as vulnerable.
bapt search for other commits by this committer
Finish converting the whole ports tree to USES=pkgconfig
08 Feb 2013 07:40:36
Original commit files touched by this commit  2.12.23_1
Revision:311914 This port version is marked as vulnerable.
miwi search for other commits by this committer
- Remove empyt dirs
06 Feb 2013 17:30:08
Original commit files touched by this commit  2.12.23_1
Revision:311783 This port version is marked as vulnerable.
novel search for other commits by this committer
- Add UPDATING entry for libtasn1 update
- Bump PORTREVISIONs for dependant ports
05 Feb 2013 16:14:59
Original commit files touched by this commit  2.12.23
Revision:311721 This port version is marked as vulnerable.
novel search for other commits by this committer
Update to 2.12.23.

Security:	http://www.gnutls.org/security.html#GNUTLS-SA-2013-1
15 Aug 2012 13:57:01
Original commit files touched by this commit  2.12.18_1
 This port version is marked as vulnerable.
novel search for other commits by this committer
- Drop automatic dependency detection [1]
- Do not link to -lphread directly [2]
- Use USE_PKGCONFIG [2]
- Pet portlint by removing ABI number references [2]
- Drop no longer actual --with-lzo=no switch, lzo support
  is disabled by default anyway [2]
- Bump PORTREVISION

PR:		170390 [2]
Submitted by:	Jason E. Hale [2], A.J. Kehoe IV (Nanoman) [1]
10 Apr 2012 11:06:28
Original commit files touched by this commit  2.12.18
 This port version is marked as vulnerable.
novel search for other commits by this committer
Respect NOPORTEXAMPLES.

PR:             166693
Submitted by:   scheidell, crees
25 Mar 2012 15:24:24
Original commit files touched by this commit  2.12.18
 This port version is marked as vulnerable.
novel search for other commits by this committer
Update to 2.12.18. This update includes a dirty hack to prevent shared
library bump which is necessary because of not properly set LIBTOOLFILES.
This would be properly fixed after ports slush is over.

PR:             166307
Submitted by:   delphij
Security:       CVE-2012-1569, CVE-2012-1573
Feature safe:   yes
12 Jan 2012 02:45:34
Original commit files touched by this commit  2.12.16
 This port version is marked as vulnerable.
novel search for other commits by this committer
Update to 2.12.16.
09 Nov 2011 15:26:04
Original commit files touched by this commit  2.12.14
 This port version is marked as vulnerable.
miwi search for other commits by this committer
- Remove WITH_FBSD10_FIX, is no longer needed
09 Nov 2011 05:51:21
Original commit files touched by this commit  2.12.14
 This port version is marked as vulnerable.
novel search for other commits by this committer
Update to 2.12.14.
29 Oct 2011 07:20:16
Original commit files touched by this commit  2.12.12
 This port version is marked as vulnerable.
miwi search for other commits by this committer
- Fix build on FreeBSD 10

Reported by:    pointyhat
23 Oct 2011 21:02:42
Original commit files touched by this commit  2.12.12
 This port version is marked as vulnerable.
novel search for other commits by this committer
Update to 2.12.12.
23 Sep 2011 22:26:39
Original commit files touched by this commit  2.12.11
 This port version is marked as vulnerable.
amdmi3 search for other commits by this committer
- Add LDFLAGS to CONFIGURE_ENV and MAKE_ENV (as it was done with LDFLAGS)
- Fix all ports that add {CPP,LD}FLAGS to *_ENV to modify flags instead

PR:             157936
Submitted by:   myself
Exp-runs by:    pav
Approved by:    pav
18 Sep 2011 23:53:46
Original commit files touched by this commit  2.12.11
 This port version is marked as vulnerable.
novel search for other commits by this committer
Update to 2.12.11.
16 Sep 2011 02:29:19
Original commit files touched by this commit  2.12.10
 This port version is marked as vulnerable.
novel search for other commits by this committer
Update to 2.12.10.
21 Aug 2011 17:11:24
Original commit files touched by this commit  2.12.9
 This port version is marked as vulnerable.
novel search for other commits by this committer
Update to 2.12.9.
14 Jul 2011 08:05:49
Original commit files touched by this commit  2.12.7_2
 This port version is marked as vulnerable.
novel search for other commits by this committer
- Switch to nettle as crypto library as it's primary library
  supported by upstream and additionally there are some
  inconsistences with libgcrypt 1.5.x.
- Bump PORTREVISION
03 Jul 2011 11:40:49
Original commit files touched by this commit  2.12.7_1
 This port version is marked as vulnerable.
swills search for other commits by this committer
- Chase the libgcrypt shared lib version
22 Jun 2011 16:15:01
Original commit files touched by this commit  2.12.7
 This port version is marked as vulnerable.
novel search for other commits by this committer
Update to 2.12.7.
06 Jun 2011 20:39:53
Original commit files touched by this commit  2.12.6.1_1
 This port version is marked as vulnerable.
pav search for other commits by this committer
- Bump PORTREVISION for the .pc fix
06 Jun 2011 12:07:37
Original commit files touched by this commit  2.12.6.1
 This port version is marked as vulnerable.
novel search for other commits by this committer
Proper fix for gnutls.pc generation by ripping out 'zlib' part
from configure as it was originally submitted by Fumiyuki Shimizu in
ports/157647.

Pointy hat to:          novel
06 Jun 2011 08:15:35
Original commit files touched by this commit  2.12.6.1
 This port version is marked as vulnerable.
novel search for other commits by this committer
Fix gnutls.pc file by stripping 'zlib' from Requires.private.

PR:             157647 (based on)
Submitted by:   Fumiyuki Shimizu
05 Jun 2011 18:34:23
Original commit files touched by this commit  2.12.6.1
 This port version is marked as vulnerable.
novel search for other commits by this committer
Update to 2.12.6.1.
04 Dec 2010 07:34:27
Original commit files touched by this commit  2.8.6_2
 This port version is marked as vulnerable.
ade search for other commits by this committer
Sync to new bsd.autotools.mk
27 Jul 2010 01:25:20
Original commit files touched by this commit  2.8.6_2
 This port version is marked as vulnerable.
wxs search for other commits by this committer
Chase security/libgcrypt shlib bump.

PR:             ports/148755
Submitted by:   Hirohisa Yamaguchi <umq@ueo.co.jp>
31 May 2010 02:01:56
Original commit files touched by this commit  2.8.6_1
 This port version is marked as vulnerable.
ade search for other commits by this committer
Bounce PORTREVISION for gettext-related ports.  Have fun, ya'll.
03 May 2010 18:36:33
Original commit files touched by this commit  2.8.6
 This port version is marked as vulnerable.
novel search for other commits by this committer
Update to 2.8.6.
21 Nov 2009 07:33:19
Original commit files touched by this commit  2.8.3
 This port version is marked as vulnerable.
novel search for other commits by this committer
Introduce WITH_CAMELLIA knob to enable camellia ciphers (off by default).

PR:             138721
Submitted by:   Ivan Sy Jr <ivan_jr@yahoo.com>
16 Aug 2009 18:01:50
Original commit files touched by this commit  2.8.3
 This port version is marked as vulnerable.
novel search for other commits by this committer
Update to 2.8.3.
02 Aug 2009 19:36:34
Original commit files touched by this commit  2.6.5
 This port version is marked as vulnerable.
mezz search for other commits by this committer
-Repocopy devel/libtool15 -> libtool22 and libltdl15 -> libltdl22.
-Update libtool and libltdl to 2.2.6a.
-Remove devel/libtool15 and devel/libltdl15.
-Fix ports build with libtool22/libltdl22.
-Bump ports that depend on libltdl22 due to shared library version change.
-Explain what to do update in the UPDATING.

It has been tested with GNOME2, XFCE4, KDE3, KDE4 and other many wm/desktop
and applications in the runtime.

With help:      marcus and kwm
Pointyhat-exp:  a few times by pav
Tested by:      pgollucci, "Romain Tartière" <romain@blogreen.org>, and
                a few MarcusCom CVS users. Also, I might have missed a few.
Repocopy by:    marcus
Approved by:    portmgr
10 May 2009 00:35:37
Original commit files touched by this commit  2.6.5
 This port version is marked as vulnerable.
novel search for other commits by this committer
Update to 2.6.5.
24 Mar 2009 17:23:40
Original commit files touched by this commit  2.6.4
 This port version is marked as vulnerable.
novel search for other commits by this committer
Mark MAKE_JOBS_SAFE for SMP compilation.

PR:             133001
Submitted by:   mm
14 Mar 2009 05:51:34
Original commit files touched by this commit  2.6.4
 This port version is marked as vulnerable.
novel search for other commits by this committer
Clean out MASTER_SITES.

Reported by:    Atom Powers <apowers@digipen.edu>
12 Feb 2009 18:47:25
Original commit files touched by this commit  2.6.4
 This port version is marked as vulnerable.
novel search for other commits by this committer
Update to 2.6.4.
18 Jan 2009 17:04:08
Original commit files touched by this commit  2.6.3_1
 This port version is marked as vulnerable.
novel search for other commits by this committer
Chase libtasn1 shared library version bump.
06 Jan 2009 17:59:31
Original commit files touched by this commit  2.6.3
 This port version is marked as vulnerable.
pav search for other commits by this committer
- Remove conditional checks for FreeBSD 5.x and older
06 Jan 2009 17:55:54
Original commit files touched by this commit  2.6.3
 This port version is marked as vulnerable.
novel search for other commits by this committer
- Update to 2.6.3
- Remove WITH_OPENCDK knob since it's not relevant anymore
- Add WITH_LZO knob

PR:             127330 (partially)
Submitted by:   Yarema <yds@CoolRat.org>
06 Jan 2009 13:01:11
Original commit files touched by this commit  2.4.2_2
 This port version is marked as vulnerable.
rafan search for other commits by this committer
- Bump PORTREVISION due to share library version bump in security/libgcrypt

PR:              ports/127478
19 Nov 2008 10:36:46
Original commit files touched by this commit  2.4.2_1
 This port version is marked as vulnerable.
pav search for other commits by this committer
- Fix the patch for CVE-2008-4989 not to cause segfaults on runtime anymore

PR:             ports/128868
Obtained from:  vendor
16 Nov 2008 08:47:08
Original commit files touched by this commit  2.4.2
 This port version is marked as vulnerable.
novel search for other commits by this committer
- Update to 2.4.2
- Fix CVE-2008-4989

PR:             128868
Submitted by:   Eygene Ryabinkin <rea-fbsd@codelabs.ru>
21 Aug 2008 06:18:49
Original commit files touched by this commit  2.4.1_1
 This port version is marked as vulnerable.
rafan search for other commits by this committer
Update CONFIGURE_ARGS for how we pass CONFIGURE_TARGET to configure script.
Specifically, newer autoconf (> 2.13) has different semantic of the
configure target. In short, one should use --build=CONFIGURE_TARGET
instead of CONFIGURE_TARGET directly. Otherwise, you will get a warning
and the old semantic may be removed in later autoconf releases.

To workaround this issue, many ports hack the CONFIGURE_TARGET variable
so that it contains the ``--build='' prefix.

To solve this issue, under the fact that some ports still have
configure script generated by the old autoconf, we use runtime detection
in the do-configure target so that the proper argument can be used.

Changes to Mk/*:
 - Add runtime detection magic in bsd.port.mk
(Only the first 15 lines of the commit message are shown above View all of this commit message)
30 Jul 2008 08:54:58
Original commit files touched by this commit  2.4.1_1
 This port version is marked as vulnerable.
delphij search for other commits by this committer
Forced commit to mention that last commit was:

Approved by:    portmgr (pav)
30 Jul 2008 08:52:37
Original commit files touched by this commit  2.4.1_1
 This port version is marked as vulnerable.
delphij search for other commits by this committer
Fix broken header installed by gnutls: it would silently break ports
that makes use of gnutls_certificate_print_formats_t enum.
25 Jul 2008 14:34:52
Original commit files touched by this commit  2.4.1
 This port version is marked as vulnerable.
pav search for other commits by this committer
- Remove USE_GCC where it can be satisfied with base compiler on following
  FreeBSD versions: 5.3 and up, 6.x, 7.x, 8-CURRENT
01 Jul 2008 06:50:08
Original commit files touched by this commit  2.4.1
 This port version is marked as vulnerable.
novel search for other commits by this committer
Update to 2.4.1.
23 Jun 2008 16:50:25
Original commit files touched by this commit  2.4.0
 This port version is marked as vulnerable.
novel search for other commits by this committer
Update to 2.4.0.

Unlike previous major version bumps, this time ABI hasn't changed, so
the shared libraries' versions stayed the same. Therefore, this update
doesn't requite any special handling.
15 Jun 2008 04:53:15
Original commit files touched by this commit  2.2.5_1
 This port version is marked as vulnerable.
novel search for other commits by this committer
Add WITHOUT_OPENCDK and WITHOUT_LIBTASN1 knobs to respect if the
user wishes to build gnutls with the included versions instead of
the ones from ports.

PR:             121357
Submitted by:   Naram Qashat <cyberbotx@cyberbotx.com>

Number of commits found: 162 (showing only 100 on this page)

1 | 2  »  

Login
User Login
Create account

Servers and bandwidth provided by
New York Internet, SuperNews, and RootBSD

This site
What is FreshPorts?
About the authors
Issues
FAQ
How big is it?
The latest upgrade!
Privacy
Forums
Blog
Contact

Search
Enter Keywords:
 
more...

Latest Vulnerabilities
musicpdFeb 26
curlFeb 22
linux-c6-openssl*Feb 22
linux-c6-openssl*Feb 22
linux-c7-openssl*Feb 22
linux-c7-openssl*Feb 22
openssl*Feb 22
openssl*Feb 22
openssl-devel*Feb 22
openssl-devel*Feb 22
xen-toolsFeb 22
fbsdmonFeb 21
libevent*Feb 20
wavpackFeb 18
openssl-develFeb 16

12 vulnerabilities affecting 25 ports have been reported in the past 14 days

* - modified, not new

All vulnerabilities


Ports
Home
Categories
Deleted ports
Sanity Test Failures
Newsfeeds

Statistics
Graphs
NEW Graphs (Javascript)
Traffic

Calculated hourly:
Port count 28211
Broken 280
Deprecated 110
Ignore 546
Forbidden 1
Restricted 205
No CDROM 83
Vulnerable 85
Expired 13
Set to expire 100
Interactive 0
new 24 hours 2
new 48 hours5
new 7 days36
new fortnight232
new month385

Servers and bandwidth provided by
New York Internet, SuperNews, and RootBSD
Valid HTML, CSS, and RSS.
Copyright © 2000-2014 Dan Langille. All rights reserved.