FreshPorts -- The Place For Ports If you buy from Amazon USA, please support us by using this link.
Follow us
Blog
Twitter

Port details
libressl-devel Free version of the SSL/TLS protocol forked from OpenSSL
2.5.4 security on this many watch lists=2 search for ports that depend on this port An older version of this port was marked as vulnerable. Find issues related to this port Report an issue related to this port
Maintainer: brnrd@FreeBSD.org search for ports maintained by this maintainer
Port Added: 04 Jan 2016 13:54:48
Also Listed In: devel
License: BSD4CLAUSE
LibreSSL is an open-source implementation of the Secure Sockets Layer (SSL) and
Transport Layer Security (TLS) protocols. It was forked from the OpenSSL
cryptographic software library in April 2014 as a response by OpenBSD
developers to the Heartbleed security vulnerability in OpenSSL,
with the aim of refactoring the OpenSSL code so as to provide a more secure
implementation.

LibreSSL was forked from the OpenSSL library starting with the 1.0.1g branch
and will follow the security guidelines used elsewhere in the OpenBSD project.

WWW: http://www.libressl.org/
SVNWeb : Homepage : PortsMon

To install the port: cd /usr/ports/security/libressl-devel/ && make install clean
To add the package: pkg install libressl-devel

PKGNAME: libressl-devel

ONLY_FOR_ARCHS: nil

NOT_FOR_ARCHS: nil

distinfo:

TIMESTAMP = 1493799912
SHA256 (libressl-2.5.4.tar.gz) = 107a5b522fbb8318d4c3be668075e5e607296f0a9255d71674caa94571336efa
SIZE (libressl-2.5.4.tar.gz) = 3286042


NOTE: FreshPorts displays only information on required and default dependencies. Optional dependencies are not covered.

Build dependencies:
  1. pkgconf>=1.3.0_1 : devel/pkgconf
There are no ports dependent upon this port

Configuration Options
===> The following configuration options are available for libressl-devel-2.5.4:
     MAN3=on: Install API manpages (section 3)
     NC=on: Install TLS-enabled netcat
===> Use 'make config' to modify these settings

USES:
cpe libtool pathfix pkgconfig

pkg-mesage:
****************************************************************************

In version 2.4.0, the OPENSSL_VERSION_NUMBER patch has been removed.

Before, the version for the FreeBSD ports was locked to the time of forking,
which was 1.0.1f (0x1000107fL). Now the version is unmodified (0x20000000L).

Ports that check e.g. >= 0x10002000 to determine features added in OpenSSL
1.0.2 are likely to fail during build. Fixes for ports known to fail this
way are collected in:

   https://wiki.freebsd.org/LibreSSL/Ports#OPENSSL_VERSION_NUMBER

****************************************************************************

Master Sites:
  1. https://ftp.OpenBSD.org/pub/OpenBSD/LibreSSL/
  2. https://ftp.eu.openbsd.org/pub/OpenBSD/LibreSSL/
  3. https://ftp3.usa.openbsd.org/pub/OpenBSD/LibreSSL/
  4. https://mirror.aarnet.edu.au/pub/OpenBSD/LibreSSL/
  5. https://mirrors.evowise.com/pub/OpenBSD/LibreSSL/
  6. https://openbsd.hk/pub/OpenBSD/LibreSSL/

Number of commits found: 22

Commit History - (may be incomplete: see SVNWeb link above for full details)
DateByDescription
03 May 2017 08:58:59
Original commit files touched by this commit  2.5.4
Revision:440005
brnrd search for other commits by this committer
security/libressl-devel: Update to 2.5.4

 - Security update to 2.5.4
 - Remove CVE-2017-8301 patch (included in 2.5.4)
 - Remove nc.1 install target (included in 2.5.4)

Security:	24673ed7-2bf3-11e7-b291-b499baebfeaf

MFH:		2017Q2
29 Apr 2017 17:32:15
Original commit files touched by this commit  2.5.3_1
Revision:439764
brnrd search for other commits by this committer
security/libressl: Fix vulnerability

Obtained from:	OpenBSD
MFH:		2017Q2
Security:	24673ed7-2bf3-11e7-b291-b499baebfeaf
Security:	CVE-2017-8301
11 Apr 2017 18:38:11
Original commit files touched by this commit  2.5.3
Revision:438302 This port version is marked as vulnerable.
brnrd search for other commits by this committer
security/libressl-devel: Update to 2.5.3

  - Update to 2.5.3
  - Use configure --enable-nc
  - Remove duplicate MAN3 handling post-install
  - Fix plist for man3 changes
26 Mar 2017 18:01:27
Original commit files touched by this commit  2.5.2
Revision:436975 This port version is marked as vulnerable.
brnrd search for other commits by this committer
security/libressl-devel: Update to 2.5.1

  - Update to 2.5.1 [1]

[1] Release Notes:
https://ftp.openbsd.org/pub/OpenBSD/LibreSSL/libressl-2.5.2-relnotes.txt
01 Feb 2017 18:08:19
Original commit files touched by this commit  2.5.1
Revision:433061 This port version is marked as vulnerable.
brnrd search for other commits by this committer
security/libressl-devel: Fix libcrypto.so version

Submitted by:	216703
Reported by:	OlivierW
01 Feb 2017 13:59:10
Original commit files touched by this commit  2.5.1
Revision:433035 This port version is marked as vulnerable.
brnrd search for other commits by this committer
security/libressl-devel: Update to 2.5.1

  - Update to 2.5.1 (tarball `signify` checked)
  - Fix ocspcheck build (sockaddr_in, EAI_NODATA)
  - Fix Undefined symbol "SSL_CIPHER_get_value" [216680]
  - Remove patch (fixed upstream)
  - Align with MAN3 option from security/libressl

PR:		216680
11 Jan 2017 11:53:40
Original commit files touched by this commit  2.5.0_1
Revision:431176
brnrd search for other commits by this committer
security/libressl-devel: Fix ECDSA P-256 timing attack vuln

  - Add patch from LibreSSL github

MFH:		2017Q1
Security:	7caebe30-d7f1-11e6-a9a5-b499baebfeaf
Security:	CVE-2016-7056
02 Dec 2016 11:58:22
Original commit files touched by this commit  2.5.0
Revision:427552 This port version is marked as vulnerable.
mat search for other commits by this committer
Do not use post-stage.  Use post-install instead.

The only reason to use post-stage is because the port needs to do
"things" at a later time, like some plist manipulation.
While there, fold post-install in do-install targets when they are
defined.

PR:		214780
Submitted by:	mat
Exp-run by:	antoine
Sponsored by:	Absolight
30 Oct 2016 14:56:57
Original commit files touched by this commit  2.5.0
Revision:424947 This port version is marked as vulnerable.
brnrd search for other commits by this committer
security/libressl: Switch to CONFLICTS_INSTALL

  - There's no conflict at build time

PR:		213691
21 Oct 2016 12:51:41
Original commit files touched by this commit  2.5.0
Revision:424411  Sanity Test Failure This port version is marked as vulnerable.
mat search for other commits by this committer
${RM} already has -f.

PR:		213570
Submitted by:	mat
Exp-run by:	antoine
Sponsored by:	Absolight
27 Sep 2016 21:31:33
Original commit files touched by this commit  2.5.0
Revision:422832 This port version is marked as vulnerable.
brnrd search for other commits by this committer
security/libressl-devel: Update to 2.5.0

  - Update to 2.5.0
  - Fixes CVE-2016-6304
  - Fix plist issues
  - Switch post-install to post-stage

Security:	337d8-83ed-11e6-bf52-b499baebfeaf
03 Aug 2016 19:30:57
Original commit files touched by this commit  2.4.2
Revision:419543 This port version is marked as vulnerable.
brnrd search for other commits by this committer
security/libressl-devel: Update to 2.4.2

  - Bugfix update
  - ABI is now stable

Release notes:
  - http://ftp.openbsd.org/pub/OpenBSD/LibreSSL/libressl-2.4.2-relnotes.txt
16 Jun 2016 13:22:59
Original commit files touched by this commit  2.4.1
Revision:416965 This port version is marked as vulnerable.
mat search for other commits by this committer
Add DEFAULT_VERSIONS=ssl=XXX

Move the openssl detection routine to bsd.default-version.mk.
Add warnings telling people to not use WITH_OPENSSL_PORT or
WITH_OPENSSL_BASE.

To ease maintainability, change the way the different ssl libraries
version numbers are checked.

PR:		210149
Submitted by:	mat
Exp-run by:	antoine
Sponsored by:	The FreeBSD Foundation, Absolight
Differential Revision:	https://reviews.freebsd.org/D6577
09 Jun 2016 20:38:45
Original commit files touched by this commit  2.4.1
Revision:416627 This port version is marked as vulnerable.
brnrd search for other commits by this committer
security/libressl-devel: Update to 2.4.1

Security:	CVE-2016-2178
Sponsored by:	BSDCan DevSummit
01 Jun 2016 17:27:34
Original commit files touched by this commit  2.4.0
Revision:416252 This port version is marked as vulnerable.
brnrd search for other commits by this committer
security/libressl-devel: Update to 2.4.0

  - Update to latest "unstable" release
  - Remove OPENSSL_VERSION_NUMBER patch
  - Update shlib-versions
  - Add UPDATING entry
03 May 2016 21:13:14
Original commit files touched by this commit  2.3.4
Revision:414559 This port version is marked as vulnerable.
brnrd search for other commits by this committer
security/libressl-devel: Security update to 2.3.4

  - Update to 2.3.4
  - Fixes for 4 vulnerabilities

Security:	01d729ca-1143-11e6-b55e-b499baebfeaf
Reviewed by:	feld (mentor, ports-secteam)
Approved by: 	feld (mentor, ports-secteam)
Differential Revision:	D6187
27 Mar 2016 15:06:07
Original commit files touched by this commit  2.3.3
Revision:411992 This port version is marked as vulnerable.
brnrd search for other commits by this committer
security/libressl-devel: Update to 2.3.3

Reviewed by:	feld (mentor)
Approved by:	feld (mentor)
Differential Revision:	D5721
06 Mar 2016 20:06:41
Original commit files touched by this commit  2.3.2
Revision:410481 This port version is marked as vulnerable.
brnrd search for other commits by this committer
security/libressl*: Register conflict with security/openssl-devel

 - Add conflict for security/openssl-devel
 - Sort conflicts alphabetically

Reviewed by:	feld (mentor), koobs (mentor)
Approved by:	feld (mentor)
Differential Revision:	D5539
31 Jan 2016 11:51:36
Original commit files touched by this commit  2.3.2
Revision:407614 This port version is marked as vulnerable.
brnrd search for other commits by this committer
security/libressl-devel: Update to 2.3.2

  - Update to version 2.3.2 [1]
  - Remove patches (upstreamed)
  - Bump shlib versions
  - Fix plist issues
  - Remove CA root cert that is installed by default

Changes:

  ftp://ftp.openbsd.org/pub/OpenBSD/LibreSSL/libressl-2.3.2-relnotes.txt [1]

Reviewed by:	koobs (mentor), feld (mentor), miwi (portmgr)
Approved by:	koobs (mentor), miwi (portmgr)
Differential Revision:	D5116
05 Jan 2016 09:19:44
Original commit files touched by this commit  2.3.1
Revision:405278 This port version is marked as vulnerable.
brnrd search for other commits by this committer
security/libressl-devel: Add next-stable LibreSSL 2.3 port

  - Add security/libressl-devel for version 2.3.1
  - Repository copy of security/libressl [1]
  - Including corrections for CVE-2015-3194/3195
  - Add support for multiple versions to bsd.openssl.mk
  - Add option to optionally install API man-pages [2]
  - Disable silent rules output

Changes:

  - ftp://ftp.openbsd.org/pub/OpenBSD/LibreSSL/libressl-2.3.0-relnotes.txt
  - ftp://ftp.openbsd.org/pub/OpenBSD/LibreSSL/libressl-2.3.1-relnotes.txt

PR:		201462 [2]
Submitted by: 	adamw [2]
Requested by:	junovitch [1]
Reviewed by:	vsevolod (mentor, maintainer), koobs (mentor), feld (mentor)
Approved by:	koobs (mentor), feld (mentor), mat [1] (portmgr)
Differential Revision:	https://reviews.freebsd.org/D3585
05 Jan 2016 09:10:32
Original commit files touched by this commit  2.3.1
Revision:405277 This port version is marked as vulnerable.
brnrd search for other commits by this committer
security/libressl-devel: Revert non-repocopied commit

Approved by:	mat (portmgr)
04 Jan 2016 13:54:38
Original commit files touched by this commit  2.3.1
Revision:405241 This port version is marked as vulnerable.
brnrd search for other commits by this committer
security/libressl-devel: Add next-stable LibreSSL 2.3 port

  - Add security/libressl-devel for version 2.3.1
  - Including corrections for CVE-2015-3194/3195
  - Add support for multiple versions to bsd.openssl.mk
  - Add option to optionally install API man-pages (201462)
  - Disable silent rules output

Changes:

  - ftp://ftp.openbsd.org/pub/OpenBSD/LibreSSL/libressl-2.3.0-relnotes.txt
  - ftp://ftp.openbsd.org/pub/OpenBSD/LibreSSL/libressl-2.3.1-relnotes.txt

PR:		201462
Submitted by: 	adamw (201462)
Reviewed by:	vsevolod (mentor, maintainer), koobs (mentor), feld (mentor)
Approved by:	koobs (mentor), feld (mentor)
Differential Revision:	https://reviews.freebsd.org/D3585

Number of commits found: 22

Login
User Login
Create account

Servers and bandwidth provided by
New York Internet, SuperNews, and RootBSD

This site
What is FreshPorts?
About the authors
Issues
FAQ
How big is it?
The latest upgrade!
Privacy
Forums
Blog
Contact

Search
Enter Keywords:
 
more...

Latest Vulnerabilities
eximJun 21
openvpnJun 21
openvpn-mbedtlsJun 21
pear-Horde_ImageJun 21
pear-Horde_ImageJun 21
apache22Jun 20
apache24Jun 20
chromiumJun 16
curlJun 15
linux-flashplayerJun 15
p5-RT-Authen-ExternalAuthJun 15
rt42Jun 15
rt44Jun 15
firefoxJun 13
firefox-esrJun 13

13 vulnerabilities affecting 73 ports have been reported in the past 14 days

* - modified, not new

All vulnerabilities


Ports
Home
Categories
Deleted ports
Sanity Test Failures
Newsfeeds

Statistics
Graphs
NEW Graphs (Javascript)
Traffic

Calculated hourly:
Port count 30410
Broken 167
Deprecated 83
Ignore 460
Forbidden 0
Restricted 207
No CDROM 84
Vulnerable 153
Expired 37
Set to expire 79
Interactive 0
new 24 hours 5
new 48 hours12
new 7 days40
new fortnight312
new month532

Servers and bandwidth provided by
New York Internet, SuperNews, and RootBSD
Valid HTML, CSS, and RSS.
Copyright © 2000-2017 Dan Langille. All rights reserved.