FreshPorts -- The Place For Ports If you buy from Amazon USA, please support us by using this link.
Follow us
Blog
Twitter

Please give me your LTO-4 or better tape library and I'll put it to good use.
Port details
rubygem-metasploit_data_models Database layer for Metasploit
0.24.0,2 security on this many watch lists=1 search for ports that depend on this port Find issues related to this port Report an issue related to this port
Maintainer: antoine@FreeBSD.org search for ports maintained by this maintainer
Port Added: 14 Jun 2013 20:40:22
Also Listed In: rubygems
License: BSD3CLAUSE
MetasploitDataModels exists to do several key things:
- Allow code sharing between Metasploit Framework (MSF) and the commercial
versions of Metasploit (Community, Express, Pro -- usually referred to
collectively as "Pro")
- Give developers a lightweight entry point to MSF's backend for use in
developing tools that gather data intended for later use with Metasploit
(e.g. specialized scanners)
- Make it easy to keep commercial stuff private while increasing the
functionality of the open-source tools we provide to the community

WWW: https://github.com/rapid7/metasploit_data_models
SVNWeb : Homepage : Distfiles Availability : PortsMon

NOTE: FreshPorts displays only information on required and default dependencies. Optional dependencies are not covered.

Build dependencies:
  1. gem21 : devel/ruby-gems
  2. ruby21 : lang/ruby21
Runtime dependencies:
  1. rubygem-activerecord>=3.2.13 : databases/rubygem-activerecord
  2. rubygem-activesupport>=0 : devel/rubygem-activesupport
  3. rubygem-arel-helpers>=0 : databases/rubygem-arel-helpers
  4. rubygem-metasploit-concern>=0.4.0 : security/rubygem-metasploit-concern
  5. rubygem-metasploit-model>=0.29.0 : security/rubygem-metasploit-model
  6. rubygem-pg>=0 : databases/rubygem-pg
  7. rubygem-railties>=3.0.0 : www/rubygem-railties
  8. rubygem-recog>=1.0 : security/rubygem-recog
  9. gem21 : devel/ruby-gems
  10. ruby21 : lang/ruby21
Patch dependencies:
  1. gem21 : devel/ruby-gems
  2. ruby21 : lang/ruby21
Extract dependencies:
  1. ruby21 : lang/ruby21

This port is required by:

for Run * - deleted ports are only shown under the This port is required by section. It was harder to do for the Required section. Perhaps later...

To install the port: cd /usr/ports/security/rubygem-metasploit_data_models/ && make install clean
To add the package: pkg install security/rubygem-metasploit_data_models


Configuration Options
     No options to configure

Master Sites:
  1. http://distcache.FreeBSD.org/ports-distfiles/rubygem/
  2. http://production.cf.rubygems.org/gems/
  3. http://production.s3.rubygems.org/gems/

Number of commits found: 13

Commit History - (may be incomplete: see SVNWeb link above for full details)
DateByDescription
23 May 2015 16:32:23
Original commit files touched by this commit  0.24.0,2
Revision:387176
antoine search for other commits by this committer
Update security/metasploit to 4.11.2
08 Mar 2015 15:38:18
Original commit files touched by this commit  0.22.6,2
Revision:380775
antoine search for other commits by this committer
Update:
- metasploit to 4.11.1
- rubygem-metasploit-credential to 0.13.17
- rubygem-metasploit_data_models to 0.22.6
- rubygem-meterpreter_bins to 0.0.13
- rubygem-recog to 1.0.7
05 Dec 2014 11:02:50
Original commit files touched by this commit  0.21.2,2
Revision:374007
antoine search for other commits by this committer
Update security/metasploit to 4.10.2
Add new ports needed by this version:
security/rubygem-metasploit-concern
security/rubygem-metasploit-credential
security/rubygem-metasploit-model
security/rubygem-meterpreter_bins
security/rubygem-recog
27 Sep 2014 21:17:17
Original commit files touched by this commit  0.17.0,2
Revision:369428
antoine search for other commits by this committer
Move back to version 0.17.0 and take maintainership, new versions do not
work with the version of metasploit currently in the tree
27 Sep 2014 21:01:25
Original commit files touched by this commit  0.20.1,1
Revision:369426
swills search for other commits by this committer
security/rubygem-metasploit_data_models: update to 0.20.1

PR:		193818
Submitted by:	JR Aquino <tanawts@gmail.com> (maintainer)
13 Aug 2014 15:44:12
Original commit files touched by this commit  0.17.0,1
Revision:364792
antoine search for other commits by this committer
Revert r359770:
- it's broken, missing depends
- it doesn't work with metasploit 4.9.3 in the tree

Pointy hat:	committer and maintainer
29 Jun 2014 14:54:03
Original commit files touched by this commit  0.17.5
Revision:359770
rakuco search for other commits by this committer
Update to 0.17.5.

PR:		191466
Submitted by:	tanawts@gmail.com (maintainer)
11 May 2014 08:24:41
Original commit files touched by this commit  0.17.0
Revision:353655
antoine search for other commits by this committer
Update metasploit to 4.9.2 and rubygem-metasploit_data_models to 0.17.0

PR:		ports/189046
Approved by:	maintainer timeout (2 weeks)
24 Jan 2014 14:53:04
Original commit files touched by this commit  0.16.4
Revision:340904
miwi search for other commits by this committer
- Stage Safe
19 Dec 2013 16:53:08
Original commit files touched by this commit  0.16.4
Revision:336936
swills search for other commits by this committer
- Update to 0.16.4

PR:		ports/180540
Submitted by:	myself
Approved by:	maintainer timeout (tanawts@gmail.com, >5 months)
20 Sep 2013 22:55:26
Original commit files touched by this commit  0.16.1
Revision:327769
bapt search for other commits by this committer
Add NO_STAGE all over the place in preparation for the staging support (cat:
security)
12 Jul 2013 19:48:55
Original commit files touched by this commit  0.16.1
Revision:322864
swills search for other commits by this committer
- Update to 0.16.1

PR:		ports/179875
Approved by:	Jr Aquino <tanawts@gmail.com> (maintainer)
14 Jun 2013 20:40:10
Original commit files touched by this commit  0.15.1
Revision:320962
antoine search for other commits by this committer
- Update metasploit to 4.6.2
- Update the list of scripts
- SVN is discontinued
- new DB option for database support

PR:		ports/179159
Approved by:	maintainer timeout (15 days)

Number of commits found: 13

Login
User Login
Create account

Servers and bandwidth provided by
New York Internet, SuperNews, and RootBSD

This site
What is FreshPorts?
About the authors
FAQ
How big is it?
The latest upgrade!
Privacy
Forums
Blog
Contact

Search
Enter Keywords:
 
more...

Latest Vulnerabilities
libidn*Aug 03
chicken*Jul 31
net-snmpJul 31
net-snmpJul 31
bind910Jul 28
bind99Jul 28
logstashJul 27
openssh-portableJul 27
chromiumJul 25
wordpress*Jul 24
wordpress*Jul 24
wordpress*Jul 24
wordpress*Jul 24
wordpress-zh_TW*Jul 24
opensaml2Jul 23

14 vulnerabilities affecting 25 ports have been reported in the past 14 days

* - modified, not new

All vulnerabilities


Ports
Home
Categories
Deleted ports
Sanity Test Failures
Newsfeeds

Statistics
Graphs
NEW Graphs (Javascript)
Traffic

Calculated hourly:
Port count 25081
Broken 197
Deprecated 106
Ignore 498
Forbidden 1
Restricted 204
No CDROM 94
Vulnerable 44
Expired 1
Set to expire 94
Interactive 0
new 24 hours 0
new 48 hours1
new 7 days17
new fortnight53
new month157

Servers and bandwidth provided by
New York Internet, SuperNews, and RootBSD
Valid HTML, CSS, and RSS.
Copyright © 2000-2014 Dan Langille. All rights reserved.