FreshPorts - VuXML

This page displays vulnerability information about FreeBSD Ports.

The last vuln.xml file processed by FreshPorts is:

Revision:  374826
Date:      2014-12-16
Time:      22:06:31Z
Committer: cs

List all Vulnerabilities, by package

List all Vulnerabilities, by date

These are the vulnerabilities relating to the commit you have selected:

VuXML IDDescription
a264b1b0-5726-11e2-9483-14dae938ec40moinmoin -- Multiple vulnerabilities

MoinMoin developers report the following vulnerabilities as fixed in version 1.9.6:

  • remote code execution vulnerability in twikidraw/anywikidraw action,
  • path traversal vulnerability in AttachFile action,
  • XSS issue, escape page name in rss link.

CVE entries at MITRE furher clarify:

Multiple unrestricted file upload vulnerabilities in the (1) twikidraw (action/twikidraw.py) and (2) anywikidraw (action/anywikidraw.py) actions in MoinMoin before 1.9.6 allow remote authenticated users with write permissions to execute arbitrary code by uploading a file with an executable extension, then accessing it via a direct request to the file in an unspecified directory, as exploited in the wild in July 2012.

Directory traversal vulnerability in the _do_attachment_move function in the AttachFile action (action/AttachFile.py) in MoinMoin 1.9.3 through 1.9.5 allows remote attackers to overwrite arbitrary files via a .. (dot dot) in a file name.

Cross-site scripting (XSS) vulnerability in the rsslink function in theme/__init__.py in MoinMoin 1.9.5 allows remote attackers to inject arbitrary web script or HTML via the page name in a rss link.


Discovery 2012-12-29
Entry 2013-01-05
Modified 2013-01-06
moinmoin
lt 1.9.6

http://hg.moinmo.in/moin/1.9/raw-file/1.9.6/docs/CHANGES
http://www.debian.org/security/2012/dsa-2593
a264b1b0-5726-11e2-9483-14dae938ec40moinmoin -- Multiple vulnerabilities

MoinMoin developers report the following vulnerabilities as fixed in version 1.9.6:

  • remote code execution vulnerability in twikidraw/anywikidraw action,
  • path traversal vulnerability in AttachFile action,
  • XSS issue, escape page name in rss link.

CVE entries at MITRE furher clarify:

Multiple unrestricted file upload vulnerabilities in the (1) twikidraw (action/twikidraw.py) and (2) anywikidraw (action/anywikidraw.py) actions in MoinMoin before 1.9.6 allow remote authenticated users with write permissions to execute arbitrary code by uploading a file with an executable extension, then accessing it via a direct request to the file in an unspecified directory, as exploited in the wild in July 2012.

Directory traversal vulnerability in the _do_attachment_move function in the AttachFile action (action/AttachFile.py) in MoinMoin 1.9.3 through 1.9.5 allows remote attackers to overwrite arbitrary files via a .. (dot dot) in a file name.

Cross-site scripting (XSS) vulnerability in the rsslink function in theme/__init__.py in MoinMoin 1.9.5 allows remote attackers to inject arbitrary web script or HTML via the page name in a rss link.


Discovery 2012-12-29
Entry 2013-01-05
Modified 2013-01-06
moinmoin
lt 1.9.6

http://hg.moinmo.in/moin/1.9/raw-file/1.9.6/docs/CHANGES
http://www.debian.org/security/2012/dsa-2593
a264b1b0-5726-11e2-9483-14dae938ec40moinmoin -- Multiple vulnerabilities

MoinMoin developers report the following vulnerabilities as fixed in version 1.9.6:

  • remote code execution vulnerability in twikidraw/anywikidraw action,
  • path traversal vulnerability in AttachFile action,
  • XSS issue, escape page name in rss link.

CVE entries at MITRE furher clarify:

Multiple unrestricted file upload vulnerabilities in the (1) twikidraw (action/twikidraw.py) and (2) anywikidraw (action/anywikidraw.py) actions in MoinMoin before 1.9.6 allow remote authenticated users with write permissions to execute arbitrary code by uploading a file with an executable extension, then accessing it via a direct request to the file in an unspecified directory, as exploited in the wild in July 2012.

Directory traversal vulnerability in the _do_attachment_move function in the AttachFile action (action/AttachFile.py) in MoinMoin 1.9.3 through 1.9.5 allows remote attackers to overwrite arbitrary files via a .. (dot dot) in a file name.

Cross-site scripting (XSS) vulnerability in the rsslink function in theme/__init__.py in MoinMoin 1.9.5 allows remote attackers to inject arbitrary web script or HTML via the page name in a rss link.


Discovery 2012-12-29
Entry 2013-01-05
Modified 2013-01-06
moinmoin
lt 1.9.6

http://hg.moinmo.in/moin/1.9/raw-file/1.9.6/docs/CHANGES
http://www.debian.org/security/2012/dsa-2593
4f99e2ef-f725-11e1-8bd8-0022156e8794moinmoin -- wrong processing of group membership

MoinMoin developers report:

If you have group NAMES containing "All" or "Known" or "Trusted", they behaved wrong until now (they erroneously included All/Known/Trusted users even if you did not list them as members), but will start working correctly with this changeset.

E.g. AllFriendsGroup:

  • JoeDoe

AllFriendsGroup will now (correctly) include only JoeDoe. It (erroneously) contained all users (including JoeDoe) before.

E.g. MyTrustedFriendsGroup:

  • JoeDoe

MyTrustedFriendsGroup will now (correctly) include only JoeDoe. It (erroneously) contained all trusted users and JoeDoe before.


Discovery 2012-09-03
Entry 2012-09-05
Modified 2012-09-11
moinmoin
ge 1.9 lt 1.9.5

CVE-2012-4404
http://hg.moinmo.in/moin/1.9/rev/7b9f39289e16
4f99e2ef-f725-11e1-8bd8-0022156e8794moinmoin -- wrong processing of group membership

MoinMoin developers report:

If you have group NAMES containing "All" or "Known" or "Trusted", they behaved wrong until now (they erroneously included All/Known/Trusted users even if you did not list them as members), but will start working correctly with this changeset.

E.g. AllFriendsGroup:

  • JoeDoe

AllFriendsGroup will now (correctly) include only JoeDoe. It (erroneously) contained all users (including JoeDoe) before.

E.g. MyTrustedFriendsGroup:

  • JoeDoe

MyTrustedFriendsGroup will now (correctly) include only JoeDoe. It (erroneously) contained all trusted users and JoeDoe before.


Discovery 2012-09-03
Entry 2012-09-05
Modified 2012-09-11
moinmoin
ge 1.9 lt 1.9.5

CVE-2012-4404
http://hg.moinmo.in/moin/1.9/rev/7b9f39289e16
a264b1b0-5726-11e2-9483-14dae938ec40moinmoin -- Multiple vulnerabilities

MoinMoin developers report the following vulnerabilities as fixed in version 1.9.6:

  • remote code execution vulnerability in twikidraw/anywikidraw action,
  • path traversal vulnerability in AttachFile action,
  • XSS issue, escape page name in rss link.

CVE entries at MITRE furher clarify:

Multiple unrestricted file upload vulnerabilities in the (1) twikidraw (action/twikidraw.py) and (2) anywikidraw (action/anywikidraw.py) actions in MoinMoin before 1.9.6 allow remote authenticated users with write permissions to execute arbitrary code by uploading a file with an executable extension, then accessing it via a direct request to the file in an unspecified directory, as exploited in the wild in July 2012.

Directory traversal vulnerability in the _do_attachment_move function in the AttachFile action (action/AttachFile.py) in MoinMoin 1.9.3 through 1.9.5 allows remote attackers to overwrite arbitrary files via a .. (dot dot) in a file name.

Cross-site scripting (XSS) vulnerability in the rsslink function in theme/__init__.py in MoinMoin 1.9.5 allows remote attackers to inject arbitrary web script or HTML via the page name in a rss link.


Discovery 2012-12-29
Entry 2013-01-05
Modified 2013-01-06
moinmoin
lt 1.9.6

http://hg.moinmo.in/moin/1.9/raw-file/1.9.6/docs/CHANGES
http://www.debian.org/security/2012/dsa-2593