FreshPorts -- The Place For Ports If you buy from Amazon USA, please support us by using this link.
Follow us
Blog
Twitter

Please give me your LTO-4 or better tape library and I'll put it to good use.
Port details
mod_wsgi2 Python WSGI adapter module for Apache
2.8_3 www Deleted on this many watch lists=0 search for ports that depend on this port Find issues related to this port Report an issue related to this port
Deprecated DEPRECATED: No longer supported, please use www/mod_wsgi3 instead
Expired This port expired on: 2014-06-30
Maintainer: douglas@douglasthrift.net search for ports maintained by this maintainer
Port Added: 24 Nov 2013 23:33:27
Also Listed In: python
License: APACHE20
The mod_wsgi adapter is an Apache module that provides a WSGI compliant
interface for hosting Python based web applications within Apache. The
adapter is written completely in C code against the Apache C runtime and
for hosting WSGI applications within Apache has a lower overhead than using
existing WSGI adapters for mod_python or CGI.

WWW: http://www.modwsgi.org/
SVNWeb : Homepage : Distfiles Availability : PortsMon

NOTE: FreshPorts displays only information on required and default dependencies. Optional dependencies are not covered.

Build dependencies:
  1. python2.7 : lang/python27
  2. python2 : lang/python2
  3. apxs : www/apache22
Runtime dependencies:
  1. python2.7 : lang/python27
  2. python2 : lang/python2
  3. apxs : www/apache22
There are no ports dependent upon this port

No installation instructions: this port has been deleted.

The package name of this deleted port was: ap22-mod_wsgi2


Configuration Options
     No options to configure

Master Sites:
  1. http://ftp.FreeBSD.org/pub/FreeBSD/ports/distfiles/
  2. http://modwsgi.googlecode.com/files/
Port Moves
  • port moved here from www/mod_wsgi on 2013-11-24
    REASON: Rename to match version

Number of commits found: 8

Commit History - (may be incomplete: see SVNWeb link above for full details)
DateByDescription
30 Jun 2014 08:37:50
Original commit files touched by this commit  2.8_3
Revision:359811
rene search for other commits by this committer
Remove expired ports:
2014-06-30 www/trac-TracDuplicates: Broken for more than 5 months
2014-06-30 mail/hotwayd: Protocol changed, software unusable
2014-06-30 mail/ilohamail-devel: Upstream disappeared
2014-06-30 games/tyrquake: Broken for more than 5 months
2014-06-30 net/gkrellmqst: GKrellM 1.X is no longer being developed, consider
using 2.X.
2014-06-30 security/p5-Jifty-Plugin-OpenID: Broken for more than 5 months
2014-06-30 games/sumwars: Broken for more than 5 months
2014-06-30 audio/ruby-esound: Broken for more than 5 months
2014-06-30 x11-toolkits/py-pyqwt: Broken for more than 5 months
2014-06-30 net-im/ysm: Broken for more than 5 months
2014-06-30 net-mgmt/send: Broken for more than 5 months
2014-06-30 net/p5-Jifty-Plugin-Authentication-Ldap: Broken for more than 5
months
2014-06-30 net-p2p/bittyrant: Broken for more than 5 months
2014-06-30 sysutils/gkrellm: GKrellM 1.X is no longer being developed, consider
using 2.X.
2014-06-30 audio/gkrellmms: GKrellM 1.X is no longer being developed, consider
using 2.X.
2014-06-30 audio/gkrellmvolume: GKrellM 1.X is no longer being developed,
consider using 2.X.
2014-06-30 misc/gkrellmlaunch: GKrellM 1.X is no longer being developed,
consider using 2.X.
2014-06-30 misc/gkrellmfmonitor: GKrellM 1.X is no longer being developed,
consider using 2.X.
2014-06-30 misc/gkrellshoot: GKrellM 1.X is no longer being developed, consider
using 2.X.
2014-06-30 polish/sms2: sms2 is no longer being developed, consider using
alternative software.
2014-06-30 x11-toolkits/py-wmdockapps: Crufty and nothing depends on this
2014-06-30 audio/tagger: Ancient, unmaintained
2014-06-30 www/mod_wsgi2: No longer supported, please use www/mod_wsgi3 instead
2014-06-30 security/botan: Botan 1.8 have known bugs and is no longer supported
upstream, migrate to security/botan110
19 May 2014 05:02:36
Original commit files touched by this commit  2.8_3
Revision:354493
ohauer search for other commits by this committer
- deprecate mod_wsgi2, no longer supported upstream
  www/mod_wsgi3 should be used instead.
- set EXPIRATION_DATE=2014-06-30
- bump mod_wsgi2 PORTREVISION to notify users
- s/CONFLICTS/CONFLICTS_INSTALL/

Approved by:	Douglas Thrift <douglas@douglasthrift.net> (maintainer, per PM)
14 Feb 2014 20:24:25
Original commit files touched by this commit  2.8_2
Revision:344312
swills search for other commits by this committer
- Remove unneeded post-install
14 Feb 2014 19:31:07
Original commit files touched by this commit  2.8_2
Revision:344298
swills search for other commits by this committer
- Calling apxs when building packages breaks staging checks, so only do it if
  PACKAGE_BUILDING is not set.

PR:		ports/186749
Submitted by:	swills (myself)
Approved by:	Douglas Thrift <douglas@douglasthrift.net> (maintainer)
21 Jan 2014 23:40:23
Original commit files touched by this commit  2.8_2
Revision:340674
bapt search for other commits by this committer
Fix properties on pkg-plist
13 Jan 2014 21:00:04
Original commit files touched by this commit  2.8_2
Revision:339634
rene search for other commits by this committer
Python cleanup:
- USE_PYTHON* = 2.X -> USE_PYTHON* = 2
- USE_PYTHON* = 2.X+ -> USE_PYTHON* = yes
Reviewed by:	python (mva, rm)
Approved by:	portmgr-lurkers (mat)
30 Dec 2013 20:55:19
Original commit files touched by this commit  2.8_2
Revision:338168
ohauer search for other commits by this committer
- rename AL2 to APACHE20 in Mk/bsd.licenses.db.mk
- svn move Templates/Licenses/AL2 Templates/Licenses/APACHE20
- add APACHE10 and APACHE11 to Mk/bsd.licenses.db.mk
- add entry in UPDATING
- bulk change all ports AL2 => APACHE20

- math/openfst/pkg-plist: remove share/licenses/openfst-1.3.4

PR:		ports/184785
Submitted by:	ohauer
Reviewed by:	tabthorpe
Approved by:	portmgr (tabthorpe@)
24 Nov 2013 23:33:16
Original commit files touched by this commit  2.8_2
Revision:334797
ohauer search for other commits by this committer
- svn mv www/mod_wsgi www/mod_wsgi2 [1]
- update ports to reflect new location
- fix mod_wsgi3 build with python3

PR:		184065 [1]
PR		183353 [2]
Submitted by:	Douglas William Thrift <douglas@douglasthrift.net> (maintainer)

Number of commits found: 8

Login
User Login
Create account

Servers and bandwidth provided by
New York Internet, SuperNews, and RootBSD

This site
What is FreshPorts?
About the authors
FAQ
How big is it?
The latest upgrade!
Privacy
Forums
Blog
Contact

Search
Enter Keywords:
 
more...

Latest Vulnerabilities
bind910Jul 28
bind99Jul 28
logstashJul 27
openssh-portableJul 27
chromiumJul 25
wordpress*Jul 24
wordpress*Jul 24
wordpress*Jul 24
wordpress*Jul 24
wordpress-zh_TW*Jul 24
libidnJul 23
opensaml2Jul 23
shibboleth2-spJul 23
soxJul 23
soxJul 23

32 vulnerabilities affecting 83 ports have been reported in the past 14 days

* - modified, not new

All vulnerabilities


Ports
Home
Categories
Deleted ports
Sanity Test Failures
Newsfeeds

Statistics
Graphs
NEW Graphs (Javascript)
Traffic

Calculated hourly:
Port count 25087
Broken 201
Deprecated 106
Ignore 500
Forbidden 1
Restricted 204
No CDROM 94
Vulnerable 44
Expired 0
Set to expire 94
Interactive 0
new 24 hours 5
new 48 hours13
new 7 days37
new fortnight75
new month197

Servers and bandwidth provided by
New York Internet, SuperNews, and RootBSD
Valid HTML, CSS, and RSS.
Copyright © 2000-2014 Dan Langille. All rights reserved.