notbugAs an Amazon Associate I earn from qualifying purchases.
Want a good read? Try FreeBSD Mastery: Jails (IT Mastery Book 15)

Current status

The server has been repaired, with a new power supply, for $23. I am waiting for lower COVID rates before visiting the datacenter to return it.
non port: Mk/bsd.wx.mk
SVNWeb

Number of commits found: 45

Tue, 6 Apr 2021
[ 14:27 mat (Mathieu Arnold) ]    commit hash:5d33e045968104ac678d8b4b4ec1e8956bbf68e0  5d33e04 (Only the first 10 of 224 ports in this commit are shown above. View all ports for this commit)
framework: Remove $FreeBSD$

Where appropriate fiddle with a few other things.
Sat, 15 Aug 2020
[ 13:30 antoine ] Original commit   Revision:544942
Finish py-wxPython28 removal and unbreak INDEX
Sat, 29 Feb 2020
[ 18:24 lbartoletti ] Original commit   Revision:527449(Only the first 10 of 30 ports in this commit are shown above. View all ports for this commit)
x11-toolkits/py-wxPython40: GUI toolkit for the Python programming language

py-wxPython40 aka Phoenix is a reborn of wxPython and in particular it allows to
use wxWidgets with Python3.


  - Add x11-toolkits/py-wxPython40
  - Replace wxPython30 by wxPython40 when python wxWidgets is required
  - Fix cad/kicad and cad/kicad-devel to use wxPython40 "Phoenix"
  - Update comms/congruity, graphics/py-mayavi from wx 2.8 to 3.0
  - While I'm here fix portlint per emulators/playonbsd
  - Remove RUN_DEPENDS from USE_WX per graphics/djvusmooth
  - Bump portversion
  - Fix unicode on x11-toolkits/wxgtk30 and take Maintainer'ship

PR:     241893
Reviewed by:	koobs, tcberner
Approved by:	tcberner (mentor)
Differential Revision:  https://reviews.freebsd.org/D21915
Exp-run by:     antoine
Wed, 27 Feb 2019
[ 12:06 danfe ] Original commit   Revision:494048
Fix several grammar mistakes and improve formatting (cosmetic changes).
Tue, 26 Feb 2019
[ 09:44 bapt ] Original commit   Revision:493959
Fix typo
[ 09:33 bapt ] Original commit   Revision:493956
Finish properly registring properly wxGTK 3.1 into the framework

PR:		236045
Mon, 25 Feb 2019
[ 16:40 cmt ] Original commit   Revision:493882
update wxPython canary file location

ports r493853 switched wxGTK3.0 to GTK3, but missed the location of the
file used for depending on wxPython.

Approved by:	fixit portmgr blanket
[ 12:51 bapt ] Original commit   Revision:493854
Hook wxgtk31 to the build to the framework
[ 12:47 bapt ] Original commit   Revision:493853(Only the first 10 of 66 ports in this commit are shown above. View all ports for this commit)
wxGTK3.0: switch to gtk3 and webkit2

Discussed with:	portmgr
Sun, 12 Feb 2017
[ 20:39 rene ] Original commit   Revision:433963
Reset maintainers of Mk/bsd.sdl.mk and Mk/bsd.wx.mk, their commit bits
were taken in for safekeeping.
Sun, 27 Mar 2016
[ 01:23 bapt ] Original commit   Revision:411970(Only the first 10 of 85 ports in this commit are shown above. View all ports for this commit)
Remove the now unneeded ${PORTSDIR} from dependency definition in
The infrastructure Makefiles

PR:		206569
Exp run by:	antoine
Differential Revision:	D5047
Thu, 15 Oct 2015
[ 07:36 bapt ] Original commit   Revision:399326(Only the first 10 of 67 ports in this commit are shown above. View all ports for this commit)
Readd PORTSDIR for now we will only start removing them after 2016Q1 is branched

This gives more time for tools to get updated, available in packages etc before
bothering users
Wed, 14 Oct 2015
[ 16:49 bapt ] Original commit   Revision:399278(Only the first 10 of 67 ports in this commit are shown above. View all ports for this commit)
Drop the necessity to add ${PORTSDIR} to dependency line

Modify make describe to automatically prepend ${PORTSDIR} if the path for the
port is not absolute

Checked with poudriere, portmaster, portupgrade

PR:		203685
Exp-run by:	antoine
Differential Revision:	https://reviews.freebsd.org/D3866
Wed, 16 Sep 2015
[ 19:51 bapt ] Original commit   Revision:397077(Only the first 10 of 73 ports in this commit are shown above. View all ports for this commit)
Remove ansi version fo wxGTK 2.8 and only keep the unicode version

All applications in the ports tree works correctly with unicode version of wxGTK

Newer version of wxGTK are unicode only (3.0+)

Note that now WX_UNICODE macro is noop
Sat, 5 Jul 2014
[ 18:38 wg ] Original commit   Revision:360795
Mk/bsd.wx.mk: add wxPython 3.0 support

Approved by:	portmgr (bapt)
Wed, 18 Jun 2014
[ 09:41 bapt ] Original commit   Revision:358236
tabspace: 8
Mon, 5 May 2014
[ 12:04 marino ] Original commit   Revision:352997
Mk/bsd.wx.mk: fixed a :U straggler
[ 09:45 bapt ] Original commit   Revision:352986(Only the first 10 of 293 ports in this commit are shown above. View all ports for this commit)
Convert all :U to :tu and :L to :tl

Since FreeBSD 8.4 and FreeBSD 9.1 make(1) do support :tu and :tl as a
replacement for :U and :L (which has been marked as deprecated)

bmake which is the default on FreeBSD 10+ only support by default
:tu/:tl a hack has been added at the time to support :U and :L to ease
migration. This hack is now not necessary anymore

Note that this makes the ports tree incompatible with make(1) from
FreeBSD 8.3 or earlier

With hat:	portmgr
Mon, 24 Mar 2014
[ 15:53 bapt ] Original commit   Revision:349022
Convert wxsvg to use wxGTK 3.0
Remove the component part from bsd.wx.mk as only dvdstyler uses it
Make dvdstyle use wxGTK 3.0
[ 14:09 bapt ] Original commit   Revision:349003
wxGTK 2.9 was a development version now that wxGTK 3.0 is out remove it
[ 13:30 bapt ] Original commit   Revision:348997
wxGTK 2.6 is EOLed upstream, all ports have switch to at least wxGTK 2.8
[ 09:45 bapt ] Original commit   Revision:348927
Use modern LIB_DEPENDS
Wed, 22 Jan 2014
[ 13:46 gahr ] Original commit   Revision:340709(Only the first 10 of 12 ports in this commit are shown above. View all ports for this commit)
New port: x11-toolkits/wxgtk30 -- Series 3.0 of the wxWidgets toolkit

PR:		181329 (based on)
Submitted by:	Rainer Hurling <rhurlin@gwdg.de>
Thu, 19 Sep 2013
[ 09:58 gahr ] Original commit   Revision:327608
- Revert file erroneously included in my previous commit

Reported by:	bapt
[ 09:49 gahr ] Original commit   Revision:327607
- Implement USES+=tcl and USES+=tk
- Use bsd.default-versions.mk to specify the default Tcl/Tk version (8.6)
- Add warnings about the now deprecated use of USE_TCL, USE_TK, ...

  Notes:

  * USES+=tcl and USES+=tk take the following optional arguments

    - either a version in the form of XY or XY+, or 'wrapper' to depend on
      lang/tcl-wrapper or x11-toolkits/tk-wrapper

    - either 'build' (bring in build depend) or 'run' (bring in run depend)

  * it is an error to specify both 'tcl' and 'tk' in USES.

  * The functionality currently implemented via INVALID_TCL_VER and
    INVALID_TK_VER is not yet available.

Approved by:	bapt (portmgr)
Fri, 26 Oct 2012
[ 06:23 bapt ] Original commit   Revision:306418
Not supported upstream anymore, consider using more recent versions

Approved by:	fjoe (maintainer)
Feature safe:	yes
Wed, 23 May 2012
[ 08:17 miwi ] Original commit (Only the first 10 of 33 ports in this commit are shown above. View all ports for this commit)
- Remove emacs mode, -*- mode: ...; -*- [1]
- Comments for BUILD_ and RUN_DEPENDS fail to mention alternate means to specify
dependencie [2]
- Fix make reinstall [3]
- Trivial comment change for PORTDATA [4]

PR:             151954 [1]
                161314 [2]
                167085 [3]
                167465 [4]
Submitted by:   Anonymous <swell.k@gmail.com> [1]
                dougb@ and Chris Rees <utisoft@gmail.com> [2]
                Garrett Cooper <yanegomi@gmail.com> [3]
                "Bryan Drewery" <bryan@shatow.net> [4]
Tested via:     phw
Sun, 11 Dec 2011
[ 18:49 pav ] Original commit 
- Add support for wx 2.9 while not making it default

PR:             ports/163006
Submitted by:   fjoe
Feature safe:   yes
Sun, 4 Dec 2011
[ 18:26 pav ] Original commit 
- Revert addition of 2.9 temporarily, individual ports need to be fixed for
  compatibility first

Feature safe:   yes
Fri, 2 Dec 2011
[ 08:18 pav ] Original commit 
- Add support for wx 2.9
- Reassign to a new maintainer

PR:             ports/163006
Submitted by:   fjoe
Feature safe:   yes
Sun, 15 Aug 2010
[ 19:39 nox ] Original commit 
- Update graphics/wxsvg to 1.0.5 and wx 2.8 which thus needs an Mk/bsd.wx.mk
  change.
- Update multimedia/dvdstyler to 1.8.1 which seems to be the only port in
  the tree using wxsvg.

Approved by:    kwm (for -multimedia), portmgr (pav, for Mk/bsd.wx.mk)
Sat, 13 Jun 2009
[ 16:35 erwin ] Original commit 
Remove wxmozilla option as it depends on a port that expired in January.
Sat, 19 Apr 2008
[ 17:56 miwi ] Original commit (Only the first 10 of 2842 ports in this commit are shown above. View all ports for this commit)
- Remove unneeded dependency from gtk12/gtk20 [1]
- Remove USE_XLIB/USE_X_PREFIX/USE_XPM in favor of USE_XORG
- Remove X11BASE support in favor of LOCALBASE or PREFIX
- Use USE_LDCONFIG instead of INSTALLS_SHLIB
- Remove unneeded USE_GCC 3.4+

Thanks to all Helpers:
        Dmitry Marakasov, Chess Griffin, beech@, dinoex, rafan, gahr,
        ehaupt, nox, itetcu, flz, pav

PR:             116263
Tested on:      pointyhat
Approved by:    portmgr (pav)
Fri, 19 Oct 2007
[ 02:21 alepulver ] Original commit 
- Remove Unicode checks for FreeBSD < 5.x (unsupported).

PR:             ports/116891
Submitted by:   edwin
Sat, 29 Sep 2007
[ 17:54 alepulver ] Original commit 
- Complete repocopy of x11-toolkits/py-wxPython28,
  x11-toolkits/py-wxPython28-common and x11-toolkits/py-wxPython28-unicode,
  applying the corresponding patches.
- Add PYDISTUTILS_NOEGGINFO to fix plist issues [1].
- Integrate with bsd.wx.mk: the noticeable difference is that ports using
  USE_WX=2.6+ and WX_COMPS=python will be built from now on with wxWidgets
  2.8, which was previously restricted for these ports because of the lack of
  the "python" component for version 2.6 [1].

PR:             ports/115349, ports/115350, ports/115351
Submitted by:   Neal Nelson <neal@nelson.name>
Reworked by:    alepulver (myself) [1]
Thu, 4 Jan 2007
[ 13:02 alepulver ] Original commit 
- Fix WANT_WX (broken since autodetection commit).

Reported by:    Mike Harding <mvh@ix.netcom.com>
Mon, 1 Jan 2007
[ 16:39 alepulver ] Original commit 
- Change WxWidgets to wxWidgets to match real application name.

Reported by:    pav
[ 01:04 alepulver ] Original commit 
- Remove _WX_ILLEGAL_VERS_* and introduce a new way of handling it.
- Do not add invalid dependencies in addition to setting IGNORE.
Sun, 31 Dec 2006
[ 17:57 alepulver ] Original commit 
- Fix autodetection.

Reported by:    pav
[ 14:27 pav ] Original commit 
- Re-add _WX_ILLEGAL_VERS_* handling removed in previous commit
[ 04:34 alepulver ] Original commit 
- Update comments for 2.8 version (section about available components).
- Add autodetection of installed versions to use if the user/port has not
  expressed any preference (done using own WANT_WX framework by itself).
- Remove _WX_ILLEGAL_VERS_* added in the last update to 2.8. The reason is
  that each port should choose the version it can use, that includes taking
  into account available components (also this brings much more chicken and
  egg problems so the code could get really messy).
- Correctly indent the first .for loop to initialize component information.
Sun, 3 Dec 2006
[ 18:04 pav ] Original commit 
- Skip versions for which requested component is not available. Fixes ports
  that define

  USE_WX=       2.4+
  WX_COMPS=     python
[ 15:24 fjoe ] Original commit 
- Add support for wxgtk2 2.8.
- Fix path to wxsvg.
Mon, 13 Nov 2006
[ 21:15 alepulver ] Original commit 
- Some comment fixes.
- Change dependency type separator from "_" to ":".
- Add WX_PREMK, WANT_UNICODE, WITHOUT_UNICODE, WXRC_CMD.
- Fix dependencies when using multiple components.
Wed, 5 Jul 2006
[ 02:13 linimon ] Original commit 
Add common code to support for WxWidgets based ports.

PR:             ports/89398
Submitted by:   alepulver

Number of commits found: 45