notbugAs an Amazon Associate I earn from qualifying purchases.
Want a good read? Try FreeBSD Mastery: Jails (IT Mastery Book 15)
Ukraine
non port: databases/postgresql90-server/files/patch-contrib-uuid
SVNWeb

Number of commits found: 4

Fri, 1 Jul 2016
[ 17:45 matthew search for other commits by this committer ] Original commit   Revision:417899 (Only the first 10 of 47 ports in this commit are shown above. View all ports for this commit)
Delete the now expired postgresql90 ports.  Upstream support for
postgresql-9.0.x was declared EoL in September 2015.

Summary:
Remove 9.0 from the list of postgresql versions available in ports

Disconnect postgresql90 ports from the build

Remove postgresql90-pgtcl port

Remove postgresql90-client port

Move the master postgreslXY-plperl makefile to postgresql95-plperl/Makefile.

Adjust include lines in other postgresqlXY-plperl ports
(Only the first 15 lines of the commit message are shown above View all of this commit message)
Wed, 30 Jul 2014
[ 18:21 crees search for other commits by this committer ] Original commit   Revision:363500 (Only the first 10 of 20 ports in this commit are shown above. View all ports for this commit)
Update to the latest snapshots.

uuid-ossp patch has been outdated with irrelevant changes (for us),
so massage back in.

In head of postgresql, this is handled properly, so eventually the ossp patches
can go.
Fri, 21 Mar 2014
[ 08:15 girgen search for other commits by this committer ] Original commit   Revision:348732
Fix mistake with ossp-uuid: don't use --with-ossp-uuid, since it will need
the ossp library present, and then we never use it.
Thu, 20 Mar 2014
[ 13:43 girgen search for other commits by this committer ] Original commit   Revision:348685 (Only the first 10 of 25 ports in this commit are shown above. View all ports for this commit)
The PostgreSQL Global Development Group has released an update to all supported
version of the database system, including versions 9.3.4, 9.2.8, 9.1.13,
9.0.17, and 8.4.21. This minor release fixes a data corruption issue with
replication and crash recovery in version 9.3, as well as several other minor
issues in all versions.  All users of version 9.3 are urged to update their
installations at the next possible downtime.  Users of older versions should
update at their convenience.

The data corruption issue in PostgreSQL 9.3 affects binary replication
standbys, servers being recovered from point-in-time-recovery backup, and
standalone servers which recover from a system crash. The bug causes
unrecoverable index corruption during recovery due to incorrect replay of row
locking operations.  This can then cause query results to be inconsistent
depending on whether or not an index is used, and eventually lead to primary
key violations and similar issues.  For this reason, users are encouraged to
(Only the first 15 lines of the commit message are shown above View all of this commit message)

Number of commits found: 4