notbugAs an Amazon Associate I earn from qualifying purchases.
Want a good read? Try FreeBSD Mastery: Jails (IT Mastery Book 15)
Port details
puppetdb-terminus4 PuppetDB storeconfigs backend terminus module
4.4.0 databases Deleted on this many watch lists=0 search for ports that depend on this port Find issues related to this port Report an issue related to this port 4.4.0Version of this port present on the latest quarterly branch.
Deprecated DEPRECATED: Puppet 4 has reached EOL
Expired This port expired on: 2019-02-28
Maintainer: puppet@FreeBSD.org search for ports maintained by this maintainer
Port Added: 2016-03-26 18:06:41
Last Update: 2019-03-03 11:43:52
SVN Revision: 494498
Also Listed In: ruby
License: APACHE20
Description:
SVNWeb : Homepage
pkg-plist: as obtained via: make generate-plist
Expand this list (19 items)
  1. /usr/local/share/licenses/puppetdb-terminus4-4.4.0/catalog.mk
  2. /usr/local/share/licenses/puppetdb-terminus4-4.4.0/LICENSE
  3. /usr/local/share/licenses/puppetdb-terminus4-4.4.0/APACHE20
  4. lib/ruby/site_ruby/2.4/puppet/face/node/deactivate.rb
  5. lib/ruby/site_ruby/2.4/puppet/face/node/status.rb
  6. lib/ruby/site_ruby/2.4/puppet/functions/puppetdb_query.rb
  7. lib/ruby/site_ruby/2.4/puppet/indirector/catalog/puppetdb.rb
  8. lib/ruby/site_ruby/2.4/puppet/indirector/facts/puppetdb.rb
  9. lib/ruby/site_ruby/2.4/puppet/indirector/facts/puppetdb_apply.rb
  10. lib/ruby/site_ruby/2.4/puppet/indirector/node/puppetdb.rb
  11. lib/ruby/site_ruby/2.4/puppet/indirector/resource/puppetdb.rb
  12. lib/ruby/site_ruby/2.4/puppet/reports/puppetdb.rb
  13. lib/ruby/site_ruby/2.4/puppet/util/puppetdb.rb
  14. lib/ruby/site_ruby/2.4/puppet/util/puppetdb/atom.rb
  15. lib/ruby/site_ruby/2.4/puppet/util/puppetdb/char_encoding.rb
  16. lib/ruby/site_ruby/2.4/puppet/util/puppetdb/command.rb
  17. lib/ruby/site_ruby/2.4/puppet/util/puppetdb/command_names.rb
  18. lib/ruby/site_ruby/2.4/puppet/util/puppetdb/config.rb
  19. lib/ruby/site_ruby/2.4/puppet/util/puppetdb/http.rb
Collapse this list.
Dependency lines:
  • puppetdb-terminus4>0:databases/puppetdb-terminus4
Conflicts:
CONFLICTS_INSTALL:
  • puppetdb-terminus5-*
  • puppetdb-terminus6-*
Conflicts Matches:
There are no Conflicts Matches for this port. This is usually an error.
No installation instructions: this port has been deleted.
The package name of this deleted port was:
PKGNAME: puppetdb-terminus4
Flavors: there is no flavor information for this port.
distinfo:

Dependencies
NOTE: FreshPorts displays only information on required and default dependencies. Optional dependencies are not covered.
Build dependencies:
  1. puppet4>=0 : sysutils/puppet4
  2. ruby24 : lang/ruby24
  3. gmake : devel/gmake
Runtime dependencies:
  1. ruby24 : lang/ruby24
Patch dependencies:
  1. ruby24 : lang/ruby24
Extract dependencies:
  1. ruby24 : lang/ruby24
There are no ports dependent upon this port

Configuration Options

USES:

Master Sites:
  1. http://downloads.puppetlabs.com/puppetdb/
Port Moves

Number of commits found: 9

Commit History - (may be incomplete: see SVNWeb link above for full details)
DateByDescription
03 Mar 2019 11:43:52
Original commit files touched by this commit  4.4.0
Revision:494498
rene search for other commits by this committer
Remove expired ports:
2019-02-28 devel/uboot-mkimage: Use sysutils/u-boot-tools
2019-02-28 graphics/clutter-gtk: 0.10.x is unmaintained upstream and unused in
the ports tree
2019-02-28 databases/puppetdb4: Puppet 4 has reached EOL
2019-02-28 sysutils/puppet4: Puppet 4 has reached EOL
2019-02-28 sysutils/puppetserver: Puppet 4 has reached EOL
2019-02-28 www/qupzilla-qt5: Project continues as www/falkon
2019-02-28 databases/puppetdb-terminus4: Puppet 4 has reached EOL
2019-03-01 sysutils/bacula-client: Unsupported. Please migrate to bacula9-server
2019-03-01 net-mgmt/nagios-check_bacula: Unsupported. Please migrate to
bacula9-server
2019-03-01 security/kc: Versions 2.4.x use incompatible database format
2019-03-01 sysutils/bacula-server: Unsupported. Please migrate to bacula9-server
2019-03-01 sysutils/bacula-docs: Unsupported. Please migrate to bacula9-docs
2019-03-01 sysutils/bacula-client-static: Unsupported. Please migrate to
bacula9-server
2019-03-01 sysutils/bacula-bat: Unsupported. Please migrate to bacula9-server
25 Jan 2019 18:08:56
Original commit files touched by this commit  4.4.0
Revision:491169
romain search for other commits by this committer
Deprecate and add expiration date to Puppet 4 ports

Puppet 4 was part of Puppet Enterprise 2016.4.15 (LTS) [1], which has reached
EOL in december 2018 [2].

Users of this version of the Puppet ecosystem are encouraged to update to
Puppet 5 (sysutils/puppet5) or Puppet 6 (sysutils/puppet6).

References:
  1.
https://puppet.com/docs/pe/2019.0/component_versions_in_recent_pe_releases.html
  2. https://puppet.com/misc/puppet-enterprise-lifecycle

With hat:	puppet
27 Sep 2018 08:06:17
Original commit files touched by this commit  4.4.0
Revision:480788
romain search for other commits by this committer
New port: databases/puppetdb6

Release notes:
https://puppet.com/docs/puppetdb/6.0/release_notes.html

With hat:	puppet
12 Aug 2017 14:19:04
Original commit files touched by this commit  4.4.0
Revision:447833
romain search for other commits by this committer
New port databases/puppetdb-terminus5

Copy databases/puppetdb-terminus4 to databases/puppetdb-terminus5 and update.

While here, update/Fix conflicts with databases/puppetdb-terminus[34].
20 Jul 2017 15:30:52
Original commit files touched by this commit  4.4.0
Revision:446262
romain search for other commits by this committer
Pass maintainership to puppet@

puppet@ is basically aliased to the previous maintainers in order to ease-up
updating Puppet-related ports.  The changes where approved by e-mail.
02 May 2017 19:02:16
Original commit files touched by this commit  4.4.0
Revision:439967
miwi search for other commits by this committer
- Update to 4.4.0

PR:		218867
Submitted by:	maintainer
09 Jun 2016 11:06:28
Original commit files touched by this commit  4.0.0
Revision:416588
romain search for other commits by this committer
New ports for PuppetDB 3.x

  - databases/puppetdb3 [1]
  - databases/puppetdb-terminus3 [2]

Also add conflicts with the puppetdb 2.x and 4.x ports.

PR:		204074 [1], 206594 [2]
Submitted by:	freebsd@zleslie.info [1, 2]
01 Apr 2016 14:00:57
Original commit files touched by this commit  4.0.0
Revision:412346
mat search for other commits by this committer
Remove ${PORTSDIR}/ from dependencies, categories d, e, f, and g.

With hat:	portmgr
Sponsored by:	Absolight
26 Mar 2016 18:06:28
Original commit files touched by this commit  4.0.0
Revision:411954
tj search for other commits by this committer
New ports for PuppetDB 4.0
	databases/puppetdb4
	databases/puppetdb-terminus4

WWW: https://forge.puppetlabs.com/puppetlabs/puppetdb

Also add conflicts with the puppetdb 2.x ports.

Number of commits found: 9

Login
User Login
Create account

Servers and bandwidth provided by
New York Internet, iXsystems, and RootBSD

This site
What is FreshPorts?
About the authors
Issues
FAQ
How big is it?
The latest upgrade!
Privacy
Forums
Blog
Contact

Search
Enter Keywords:
 
more...

Latest Vulnerabilities
drm-current-kmodNov 20
drm-devel-kmodNov 20
drm-fbsd12.0-kmodNov 20
squidNov 19
libidn2Nov 18
gcpioNov 15
libmadNov 13
chromiumNov 12
wordpressNov 12
wordpressNov 12
wordpressNov 12
wordpressNov 12
wordpressNov 12
nexus2-ossNov 07
php71Nov 06

9 vulnerabilities affecting 115 ports have been reported in the past 14 days

* - modified, not new

All vulnerabilities

Last updated:
2019-11-20 10:58:20


Ports
Home
Categories
Deleted ports
Sanity Test Failures
Newsfeeds

Statistics
Graphs
NEW Graphs (Javascript)
Traffic

Calculated hourly:
Port count 38085
Broken 776
Deprecated 102
Ignore 1046
Forbidden 3
Restricted 157
No CDROM 72
Vulnerable 33
Expired 7
Set to expire 72
Interactive 0
new 24 hours 3
new 48 hours7
new 7 days26
new fortnight63
new month132

Servers and bandwidth provided by
New York Internet, iXsystems, and RootBSD
Valid HTML, CSS, and RSS.
Copyright © 2000-2019 Dan Langille. All rights reserved.