notbugAs an Amazon Associate I earn from qualifying purchases.
Want a good read? Try FreeBSD Mastery: Jails (IT Mastery Book 15)
Ukraine
NOTE: There is a known problem on production with searching pkg-plist - it returns no results. This problem is not present on stage.freshports.org
Port details
qt5-sqldrivers-ibase Qt InterBase/Firebird database plugin (KDE patched)
5.15.5p165 databases on this many watch lists=0 search for ports that depend on this port Find issues related to this port Report an issue related to this port View this port on Repology. pkg-fallout Version of this port present on the latest quarterly branch.
Maintainer: kde@FreeBSD.org search for ports maintained by this maintainer
Port Added: 2014-03-03 16:50:50
Last Update: 2022-07-04 07:31:38
Commit Hash: 787e501
License: LGPL21
Description:
cgit ¦ Codeberg ¦ GitHub ¦ GitLab ¦ SVNWeb
pkg-plist: as obtained via: make generate-plist
Expand this list (6 items)
Collapse this list.
  1. lib/cmake/Qt5Sql/Qt5Sql_QIBaseDriverPlugin.cmake
  2. lib/qt5/plugins/sqldrivers/libqsqlibase.so
  3. @comment lib/qt5/plugins/sqldrivers/libqsqlibase.so.debug
  4. /usr/local/share/licenses/qt5-sqldrivers-ibase-5.15.5p165/catalog.mk
  5. /usr/local/share/licenses/qt5-sqldrivers-ibase-5.15.5p165/LICENSE
  6. /usr/local/share/licenses/qt5-sqldrivers-ibase-5.15.5p165/LGPL21
Collapse this list.
Dependency lines:
  • qt5-sqldrivers-ibase>0:databases/qt5-sqldrivers-ibase
To install the port:
cd /usr/ports/databases/qt5-sqldrivers-ibase/ && make install clean
To add the package, run one of these commands:
  • pkg install databases/qt5-sqldrivers-ibase
  • pkg install qt5-sqldrivers-ibase
NOTE: If this package has multiple flavors (see below), then use one of them instead of the name specified above.
PKGNAME: qt5-sqldrivers-ibase
Flavors: there is no flavor information for this port.
ONLY_FOR_ARCHS: i386 amd64
distinfo:

Packages (timestamps in pop-ups are UTC):
qt5-sqldrivers-ibase
ABIlatestquarterly
FreeBSD:11:aarch64pkg-falloutpkg-fallout
FreeBSD:11:amd645.15.2_15.15.2_1
FreeBSD:11:armv6pkg-falloutpkg-fallout
FreeBSD:11:i3865.15.2_15.15.2_1
FreeBSD:11:mipspkg-falloutpkg-fallout
FreeBSD:11:mips64pkg-falloutpkg-fallout
FreeBSD:12:aarch64pkg-falloutpkg-fallout
FreeBSD:12:amd645.15.5p1655.15.5p165
FreeBSD:12:armv6pkg-falloutpkg-fallout
FreeBSD:12:armv7pkg-falloutpkg-fallout
FreeBSD:12:i3865.15.5p1655.15.5p165
FreeBSD:12:mipspkg-falloutpkg-fallout
FreeBSD:12:mips64pkg-falloutpkg-fallout
FreeBSD:12:powerpc64pkg-falloutpkg-fallout
FreeBSD:13:aarch64pkg-falloutpkg-fallout
FreeBSD:13:amd64pkg-falloutpkg-fallout
FreeBSD:13:armv6pkg-falloutpkg-fallout
FreeBSD:13:armv7pkg-falloutpkg-fallout
FreeBSD:13:i386pkg-falloutpkg-fallout
FreeBSD:13:mipspkg-falloutpkg-fallout
FreeBSD:13:mips64pkg-falloutpkg-fallout
FreeBSD:13:powerpc64pkg-falloutpkg-fallout
FreeBSD:13:riscv64pkg-falloutpkg-fallout
FreeBSD:14:aarch64pkg-falloutpkg-fallout
FreeBSD:14:amd645.15.5p165pkg-fallout
FreeBSD:14:armv6pkg-falloutpkg-fallout
FreeBSD:14:armv7pkg-falloutpkg-fallout
FreeBSD:14:i3865.15.5p165pkg-fallout
FreeBSD:14:mipspkg-falloutpkg-fallout
FreeBSD:14:mips64pkg-falloutpkg-fallout
FreeBSD:14:powerpc64pkg-falloutpkg-fallout
FreeBSD:14:riscv64pkg-falloutpkg-fallout
 

Dependencies
NOTE: FreshPorts displays only information on required and default dependencies. Optional dependencies are not covered.
Build dependencies:
  1. pkgconf>=1.3.0_1 : devel/pkgconf
  2. qt5-buildtools>=5.15 : devel/qt5-buildtools
  3. qt5-qmake>=5.15 : devel/qt5-qmake
Library dependencies:
  1. libfbclient.so : databases/firebird25-client
  2. libQt5Core.so : devel/qt5-core
  3. libQt5Sql.so : databases/qt5-sql
Patch dependencies:
  1. perl5>=5.32.r0<5.33 : lang/perl5.32
This port is required by:
for Run
  1. devel/qt5

Configuration Options:
Options name:

USES:

FreshPorts was unable to extract/find any pkg message

Master Sites:
Expand this list (5 items)
Collapse this list.
  1. http://distcache.FreeBSD.org/local-distfiles/kde/KDE/Qt/5.15.5/
  2. http://distcache.eu.FreeBSD.org/local-distfiles/kde/KDE/Qt/5.15.5/
  3. http://distcache.us-east.FreeBSD.org/local-distfiles/kde/KDE/Qt/5.15.5/
  4. http://distcache.us-west.FreeBSD.org/local-distfiles/kde/KDE/Qt/5.15.5/
Collapse this list.

Number of commits found: 12

Commit History - (may be incomplete: for full details, see links to repositories near top of page)
CommitCreditsLog message
5.15.5p165
04 Jul 2022 07:31:38
commit hash:787e501e3d8fdc162dc019f352b280298b192b0acommit hash:787e501e3d8fdc162dc019f352b280298b192b0acommit hash:787e501e3d8fdc162dc019f352b280298b192b0acommit hash:787e501e3d8fdc162dc019f352b280298b192b0a files touched by this commit
Tobias C. Berner (tcberner) search for other commits by this committer
qt5: Update Qt to 5.15.5 (KDE patched)

- update patch-collection diff to be at the highest patch-level
- update patch-collection diff to be against 5.15.5 instead of 5.15.2
- update devel/qt5-script to 5.15.10
- libressl support by Felix Palmen <felix@palmen-it.de>

PR:			264944
Exp-run by:		antoine
Differential Revision:	https://reviews.freebsd.org/D35619
5.15.2p263
02 Jan 2022 08:47:54
commit hash:6b3bece75ad5a3d03e2751e5cdf78ae8aeb0abf9commit hash:6b3bece75ad5a3d03e2751e5cdf78ae8aeb0abf9commit hash:6b3bece75ad5a3d03e2751e5cdf78ae8aeb0abf9commit hash:6b3bece75ad5a3d03e2751e5cdf78ae8aeb0abf9 files touched by this commit
Tobias C. Berner (tcberner) search for other commits by this committer
Qt: Switch Qt5 to use KDE's Qt patch collection

From [1]
    What's this?

	This is a set of git repositories based on the last public
	commits available for Qt 5.15 branches with a curated collection
	of patches on top to ensure open source products can be used
	comfortably until users transition to their Qt 6-based ports.

    Which patches does it include?

	This collection of patches includes patches that fix at least
	one of the following:
(Only the first 15 lines of the commit message are shown above View all of this commit message)
5.15.2_1
22 May 2021 18:43:39
commit hash:b4733228bece6783f2d6e8a2db8b0b502a7f63aecommit hash:b4733228bece6783f2d6e8a2db8b0b502a7f63aecommit hash:b4733228bece6783f2d6e8a2db8b0b502a7f63aecommit hash:b4733228bece6783f2d6e8a2db8b0b502a7f63ae files touched by this commit
Jose Alonso Cardenas Marquez (acm) search for other commits by this committer
databases/firebird25-*: Bump PORTREVISION of dependant ports
5.15.2
07 Apr 2021 08:09:01
commit hash:cf118ccf875508b9a1c570044c93cfcc82bd455ccommit hash:cf118ccf875508b9a1c570044c93cfcc82bd455ccommit hash:cf118ccf875508b9a1c570044c93cfcc82bd455ccommit hash:cf118ccf875508b9a1c570044c93cfcc82bd455c files touched by this commit
Mathieu Arnold (mat) search for other commits by this committer
One more small cleanup, forgotten yesterday.
Reported by:	lwhsu
5.15.2
06 Apr 2021 14:31:07
commit hash:305f148f482daf30dcf728039d03d019f88344ebcommit hash:305f148f482daf30dcf728039d03d019f88344ebcommit hash:305f148f482daf30dcf728039d03d019f88344ebcommit hash:305f148f482daf30dcf728039d03d019f88344eb files touched by this commit
Mathieu Arnold (mat) search for other commits by this committer
Remove # $FreeBSD$ from Makefiles.
5.12.1
12 Feb 2019 17:43:00
Revision:492793Original commit files touched by this commit
tcberner search for other commits by this committer
Update Qt5 to 5.12.1

Release announcement:
  https://blog.qt.io/blog/2019/02/01/qt-5-12-1-released/
Changelog:
  https://wiki.qt.io/Qt_5.12.1_Change_Files

- A change was required to qt-dist.mk to always pass LOCALBASE to qmake,
  as Qt5 has been installed to a prefix for some time now, there should
  not be any harm in that, with respect to it picking up installed versions
  of itself during build.

PR:		235622
Exp-run by:	antoine
5.12.0_1
16 Jan 2019 11:13:45
Revision:490472Original commit files touched by this commit
tijl search for other commits by this committer
Fix Qt5 symbol version scripts to put the catch-all clause first.  When
a symbol matches multiple clauses the last one takes precedence.  If the
catch-all is last it captures everything.  In the case of Qt5 libraries
this caused all symbols to have a Qt_5 label while some should have
Qt_5_PRIVATE_API.  This only affects lld because GNU ld always gives the
catch-all lowest priority.

Older versions of Qt5Webengine exported some memory allocation symbols from
the bundled Chromium.  Version 5.9 stopped exporting these [1] but the
symbols were kept as weak wrappers for the standard allocation functions to
maintain binary compatibility. [2][3]  The problem is that the call to the
standard function in these weak wrappers is only resolved to the standard
function if there's a call to this standard function in other parts of
Qt5Webengine, because only then is there a non-weak symbol that takes
precedence over the weak one.  If there's no such non-weak symbol the call
(Only the first 15 lines of the commit message are shown above View all of this commit message)
5.10.1
18 May 2018 12:27:44
Revision:470288Original commit files touched by this commit
rakuco search for other commits by this committer
Update the Qt5 ports to 5.10.1.

The work was done by tcberner and myself, with thanks to antoine for the
exp-run.

Not a lot to report compared to other Qt5 updates:
* net/qt5-network is still broken with LibreSSL. I said this in a commit
  message ages ago but it bears repeating: upstream is open to adding support
  for LibreSSL, but someone needs to step up to maintain it upstream, otherwise
  things will continue to be broken all the time.
* www/qt5-webengine is a huge monster that is terrible to update, just like
  www/chromium itself is. We (kde@) have decided to keep using the 5.9 series
  for the time being, as it should be compatible with the rest of Qt anyway. It
  was updated to 5.9.5, the latest 5.9 release at the time of writing.

PR:		228213
5.9.4_1
25 Apr 2018 18:40:14
Revision:468288Original commit files touched by this commit
acm search for other commits by this committer
- Bump PORTREVISION. databases/firebird25-* ports were updated
5.9.4
02 Mar 2018 13:27:13
Revision:463396Original commit files touched by this commit
adridg search for other commits by this committer
Disable Qt5 sqldrivers-ibase on not-(i386|amd64)

This is basically r463394, repeated for Qt5

Approved by:	tcberner (mentor, implicit)
5.5.1
25 Apr 2016 16:14:02
Revision:414015Original commit files touched by this commit
mat search for other commits by this committer
Remove USE_FIREBIRD from bsd.databases.mk, replaced by USES=firebird.

Also:
- replace USE_FIREBIRD by USES=firebird.
- convert ports depending on databases/firebird25-client directly to
USES=firebird.

PR:		208971
Submitted by:	mat
Exp-run by:	antoine
With hat:	portmgr
Sponsored by:	Absolight
Differential Revision:	https://reviews.freebsd.org/D5951
5.2.1
03 Mar 2014 16:50:33
Revision:346930Original commit files touched by this commit
makc search for other commits by this committer
KDE/FreeBSD team is happy to present Qt 5 in ports!

Alberto Villa (avilla@) has done all the hard work to create Qt 5 ports.
Trivial update from 5.2.0-beta1 to 5.2.1 by me.

Special thanks for Adriaan de Groot <groot@kde.org> for his assistance for
Qt-5.2.0 update.

Approved by:	portmgr (bapt) (for Mk/bsd.port.mk)

Number of commits found: 12