notbugAs an Amazon Associate I earn from qualifying purchases.
Want a good read? Try FreeBSD Mastery: Jails (IT Mastery Book 15)

/commits.php is going away

I'm proposing to take /commits.php away - it mainly duplicates the home page. Details in this GitHub issue.
non port: devel/gitaly/files/patch-ruby_Gemfile
SVNWeb

Number of commits found: 45

Tue, 5 Oct 2021
[ 07:40 mfechner (Matthias Fechner) ]    commit hash:7dcb3ca59065e8f1c74bbed2f64f3bc8100bbc18  7dcb3ca5 
www/gitlab-ce: Revert unapproved modification that broke gitlab
Mon, 27 Sep 2021
[ 15:56 sunpoet (Po-Chuan Hsieh) ]    commit hash:f256db7c994a5a0bf6ca28a901c1d2852211a81b  f256db7 
devel/gitaly: Fix Gemfile for rubygem-activesupport61 6.1.4.1 update

- Bump PORTREVISION for package change
Tue, 31 Aug 2021
[ 21:20 mfechner (Matthias Fechner) ]    commit hash:4edd9ea5d5ced64dbefab85fab25db83f914968f  4edd9ea 
www/gitlab-ce: Security update to 14.2.2

Changelog:
https://about.gitlab.com/releases/2021/08/31/security-release-gitlab-14-2-2-released/

Security:	6c22bb39-0a9a-11ec-a265-001b217b3468
[ 09:54 mfechner (Matthias Fechner) ]    commit hash:422f21b3fbf63cb6466507341f560a678f250918  422f21b 
devel/gitaly: Update to 14.2.1

Required for gitlab-ce 14.2.
Sat, 24 Jul 2021
[ 07:08 mfechner (Matthias Fechner) ]    commit hash:2f2022c478764731a1395596b1d3cae11b0335d5  2f2022c 
devel/gitaly: Udpate to 14.1.0

Required for gitlab 14.1.
Sat, 3 Jul 2021
[ 06:03 mfechner (Matthias Fechner) ]    commit hash:6ff0c4449f9581f7a294c907acf47d0b5a0e7a62  6ff0c444 
devel/gitaly: Update to 14.0.0.

Required for gitlab-ce 14.0.0.
Sat, 29 May 2021
[ 16:23 mfechner (Matthias Fechner) ]    commit hash:8eb73b9fc99fa8e67b569a09c6a7ff4ebb0fe263  8eb73b9 
devel/gitaly: Update to 13.12.0.

Required for gitlab-ce 13.12.
Fri, 23 Apr 2021
[ 19:06 mfechner (Matthias Fechner) ]    commit hash:a39d3cd20cde6d947125e8db641c73dd0a554f49  a39d3cd 
devel/gitaly: Update to 13.11.1.

This update is required for gitlab-ce 13.11 upgrade.
Tue, 6 Apr 2021
[ 07:51 mfechner (Matthias Fechner) ]    commit hash:4376e187f101ba09810e3d3b9c7b6beef1bc3efc  4376e18 
Update to 13.10.1 which is required for gitlab-ce 13.10.
Mon, 8 Mar 2021
[ 11:18 mfechner ] Original commit   Revision:567835
Make sure we use google-protobug version that does not segfault.

Is also reported upstream:
https://gitlab.com/gitlab-org/gitaly/-/merge_requests/3233
Wed, 3 Mar 2021
[ 09:26 mfechner ] Original commit   Revision:567035
Update to 13.9.1 which is required for gitlab-ce upgrade.
Wed, 27 Jan 2021
[ 12:34 mfechner ] Original commit   Revision:563050
Update to 13.8.0 which is required for gitlab-ce 13.8.
Sat, 12 Dec 2020
[ 08:35 mfechner ] Original commit   Revision:557804
Bugfix update to gitlab-ce 13.6.3.
Changelog:
https://about.gitlab.com/releases/2020/12/10/gitlab-13-6-3-released/
Sat, 28 Nov 2020
[ 14:58 mfechner ] Original commit   Revision:556496
Update to 13.6.0 which is required for gitlab-ce 13.6.
Fri, 23 Oct 2020
[ 04:45 mfechner ] Original commit   Revision:553069
Upgrade to 13.5.0 which is required fAOEr gitlab-ce 13.5.
Fri, 9 Oct 2020
[ 07:52 mfechner ] Original commit   Revision:551751
Bugfix update of www/gitlab-ce to 13.4.3.
Sat, 26 Sep 2020
[ 07:25 mfechner ] Original commit   Revision:550112
Update to gitaly 13.4 which is required for gitlab-ce 13.4.
This commit also includes the MR to be able to compile against to standard
libgit2 port:
https://gitlab.com/gitlab-org/gitaly/-/merge_requests/2600
Tue, 25 Aug 2020
[ 13:01 mfechner ] Original commit   Revision:546168
Upgrade to 13.3.0 which is required for gitlab 13.3.
Thu, 4 Jun 2020
[ 19:59 mfechner ] Original commit   Revision:537948
Update to 13.0.5 which is required for gitlab-ce 13.0.
Wed, 20 May 2020
[ 06:06 mfechner ] Original commit   Revision:535975
Update to 12.10.6 which is required for gitlab-ce 12.10.6 upgrade.
Sun, 19 Apr 2020
[ 03:55 tobik ] Original commit   Revision:532068 (Only the first 10 of 59 ports in this commit are shown above. View all ports for this commit)
devel/libgit2: Update to 1.0.0

Changes:	https://github.com/libgit2/libgit2/releases/tag/v1.0.0
ABI:		https://abi-laboratory.pro/tracker/timeline/libgit2
Approved by:	mfechner (maintainer)
Differential Revision:	https://reviews.freebsd.org/D24471
Sat, 28 Mar 2020
[ 22:31 mfechner ] Original commit   Revision:529764
Fix Gemfile for rubygem-rails60 6.0.2.2 update.
[ 09:05 mfechner ] Original commit   Revision:529321
Update to 12.9.1 which is required for gitlab-ce 12.9 upgrade.
Tue, 25 Feb 2020
[ 15:46 mfechner ] Original commit   Revision:527085
Udate to 12.8.1 which is required for gitlab-ce 12.8 upgrade.
Sun, 2 Feb 2020
[ 08:30 mfechner ] Original commit   Revision:524829
Update to 1.83.0 which is required for gitlab-ce 12.7.
Sat, 23 Nov 2019
[ 08:51 mfechner ] Original commit   Revision:518202
Update to 1.72.0 which is required for gitlab-ce 12.5.
Mon, 9 Sep 2019
[ 10:26 mfechner ] Original commit   Revision:511617
devel/gitaly: upgrade to 1.59.2 which is required for gitlab-ce 12.2.
Fri, 30 Aug 2019
[ 07:37 mfechner ] Original commit   Revision:510251
devel/gitaly: update to 1.53.3 which is required for gitlab-ce 12.1.
Sun, 7 Jul 2019
[ 09:38 mfechner ] Original commit   Revision:506116
Upgrade to 1.47.0 which is required for gitlab-ce 12.0.x.
Tue, 28 May 2019
[ 10:42 mfechner ] Original commit   Revision:502879
Upgrade to 1.42.0 which is required by gitlab-ce 11.11 upgrade.
Tue, 23 Apr 2019
[ 08:06 mfechner ] Original commit   Revision:499728
Upgrade to 1.33.0 which is required for Gitlab 11.10 upgrade.
Sat, 23 Mar 2019
[ 17:44 mfechner ] Original commit   Revision:496673
Upgrade to 1.27.0 which is required for gitlab 11.9.
Sat, 2 Mar 2019
[ 11:51 mfechner ] Original commit   Revision:494393
Upgrade to 1.20.0 which is required for gitlab-ce 11.8 upgrade.
Thu, 31 Jan 2019
[ 14:22 mfechner ] Original commit   Revision:491730
Upgrade to 1.12.1 which is required for gitlab-ce 11.7 upgrade.
Sun, 23 Dec 2018
[ 12:41 mfechner ] Original commit   Revision:488208
Upgrade to 1.7.1 which is required for gitlab-ce 11.6.

Approved by:	mentors (implicit)
Fri, 23 Nov 2018
[ 15:01 mfechner ] Original commit   Revision:485670
Upgrade to 0.129.0 which is required for gitlab-ce 11.5.

Approved by:	mentors (implicit)
Tue, 30 Oct 2018
[ 16:13 mfechner ] Original commit   Revision:483497
Upgrade to version 0.125.1 which is required for www/gitlab-ce 11.4.x.

Approved by:	mentors (implicit)
Sun, 23 Sep 2018
[ 18:13 mfechner ] Original commit   Revision:480516
Update devel/gitaly to 0.120.0 which is required for gitlab 11.3.

Approved by:	mentors (implicit)
Thu, 6 Sep 2018
[ 19:06 mfechner ] Original commit   Revision:479139
Update devel/gitaly to 0.117.2 which is required for gitlab-ce 11.2.x.

Approved by:	mentors (implicit)
Thu, 26 Jul 2018
[ 13:44 mfechner ] Original commit   Revision:475371
Update to 0.111.2 which is required for gitlab 11.1.1.

Approved by:	mentors (implicit)
Wed, 4 Jul 2018
[ 17:30 mfechner ] Original commit   Revision:473905
Update to 0.105.0 which is required for gitlab 11.0.2.

Reviewed by:	swills (mentor)
Approved by:	swills (mentor)
Differential Revision:	https://reviews.freebsd.org/D16127
Thu, 21 Jun 2018
[ 15:32 mfechner ] Original commit   Revision:472977
Update gitaly to 0.100.0 required for gitlab 10.8.

Reviewed by:	mat, swills (mentor)
Approved by:	swills (mentor)
Differential Revision:	https://reviews.freebsd.org/D15947
Thu, 31 May 2018
[ 13:48 mfechner ] Original commit   Revision:471208
Applied security upgrade to gitlab 10.7.5.
Fixed bug with wrong path for gitlab-workhouse that should fix artifacts
(reported by Felix <mail@felix.flornet.de>). This was fix upstream but is not
included in this version yet:
https://gitlab.com/gitlab-org/gitlab-ce/issues/46763
Update net/rubygem-grpc to 1.11.1 which is required for gitlab 10.7.5.
Sync dep net/rubygem-grpc with gitlab which uses now 1.11.1.
Added gitlab-pages again to dependencies as the new version builds again.

Reported by:	Felix <mail@felix.flornet.de>
Reviewed by:	swills (mentor)
Approved by:	swills (mentor)
Differential Revision:	https://reviews.freebsd.org/D15631
Mon, 14 May 2018
[ 17:58 mfechner ] Original commit   Revision:469938
Upgrade devel/gitaly to 0.96.1 required for gitlab 10.7.x.

Reviewed by:	tz (mentor)
Approved by:	tz (mentor)
Differential Revision:	https://reviews.freebsd.org/D15323
Thu, 5 Apr 2018
[ 16:21 mfechner ] Original commit   Revision:466567
Update to version 0.82.0 which is required for gitlab 10.5.x.

Reviewed by:	mat, tz (mentor)
Approved by:	tz (mentor)
Differential Revision:	https://reviews.freebsd.org/D14867

Number of commits found: 45