notbugAs an Amazon Associate I earn from qualifying purchases.
Want a good read? Try FreeBSD Mastery: Jails (IT Mastery Book 15)
Want a good monitor light? See my photosAll times are UTC
Ukraine
This referral link gives you 10% off a Fastmail.com account and gives me a discount on my Fastmail account.
New feature planned: get notified when the package is available. Now is the time to contribute ideas/suggestions.
non port: devel/pecl-memoize/Makefile

Number of commits found: 13

Thursday, 6 Dec 2018
11:22 rene search for other commits by this committer
Remove version 7.0 from the IGNORE_WITH_PHP list.
Original commitRevision:486751 
Sunday, 2 Dec 2018
17:43 antoine search for other commits by this committer
Deprecate ports depending on php 5.6
Original commitRevision:486473 
Monday, 8 Oct 2018
15:08 antoine search for other commits by this committer
Fix some PKGNAME collisions
Original commitRevision:481545 
Thursday, 14 Dec 2017
13:57 tz search for other commits by this committer
Add missing IGNORE_WITH_PHP for various pecl-ports.

After testing every pecl-* port with PHP 5.6, 7.0, 7.1 and 7.2
i set the IGNORE_WITH_PHP accordingly to the fallout.

PR:          222165
Reported by: brnd
Approved by: portmgr (blanket)
Differential Revision: https://reviews.freebsd.org/D13476
Original commitRevision:456296 
Monday, 10 Apr 2017
15:08 mat search for other commits by this committer
Convert all PECL ports to USES=php:pecl.

Sponsored by:	Absolight
Differential Revision:	https://reviews.freebsd.org/D10281
Original commitRevision:438175 
Monday, 15 Aug 2016
15:28 mat search for other commits by this committer
Remove www/pecl-APC, it doesn't work with PHP 5.5+.

PR:		211344
Submitted by:	rene
Sponsored by:	Absolight
Original commitRevision:420242 
Wednesday, 3 Aug 2016
12:47 mat search for other commits by this committer
Don't use extension.ini any more, and have each extension install in its
file, so the order remains the same.

Every PHP (or Zend) extension now installs its own .ini file in
/usr/local/etc/php.  A PHP extension will be automatically activated
when installed.  The order into which extensions are loaded is
automatically guessed.  In some very rare cases, the guess will be
wrong, and PHP_MOD_PRIO will need to be set.  Refer to the USES=php
section of the Porter's Handbook for more information.

Convert ports touching etc/php/extensions.ini manually, or telling the
OP to do it.

And finally, bump PORTREVISION for all php extensions.

PR:		210697
Submitted by:	mat
Sponsored by:	Absolight
Differential Revision:	https://reviews.freebsd.org/D7022
Original commitRevision:419514 
Wednesday, 29 Jun 2016
13:51 mat search for other commits by this committer
Missed a few opt_USE=php=foo when building extensions.

Sponsored by:	Absolight
Original commitRevision:417765 
Tuesday, 28 Jun 2016
14:00 mat search for other commits by this committer
Convert USE_PHP*=yes into USES=php*

PR:		210529
Submitted by:	mat
Exp-run by:	antoine
Sponsored by:	Absolight
Differential Revision:	https://reviews.freebsd.org/D6936
Original commitRevision:417719 
Friday, 1 Apr 2016
14:00 mat search for other commits by this committer
Remove ${PORTSDIR}/ from dependencies, categories d, e, f, and g.

With hat:	portmgr
Sponsored by:	Absolight
Original commitRevision:412346 
Thursday, 18 Feb 2016
14:47 miwi search for other commits by this committer
- Ignore php70
- While here remove old php gruft
Original commitRevision:409110 
Thursday, 11 Dec 2014
05:26 koobs search for other commits by this committer
databases/libmemcached: Update to 1.0.18 and much more

- Update to 1.0.18 and pkg-plist accordingly
- Add LICENSE (BSD3CLAUSE) and LICENSE_FILE
- Add TEST_DEPENDS and regression-test target
- Perl is not required, remove USE_PERL and from USES
- Split LDFLAGS from CONFIGURE_ENV, they're already set there
- Add libmemcachedprotocol to CONFIGURE_ARGS (Now default: off)
- Add OPTIONS for hash functions, debug and dtrace
- pkg-descr: Update WWW: URL
- Add patches for:
  * alloca.h include not found on FreeBSD
  * cinttypes include location
  * clang compatibility
- Strip shared libraries manually since upstream install-strip target is
  fail

Changes:

  https://launchpad.net/libmemcached/+announcements

[1] https://bugs.launchpad.net/libmemcached/+bug/1245562
[2] https://bugs.launchpad.net/libmemcached/+bug/1400560

Approved by:	Mikhail Tsatsenko <m.tsatsenko@gmail.com> (maintainer, via email)
Original commitRevision:374511 
Saturday, 24 May 2014
20:55 sunpoet search for other commits by this committer
- Add pecl-memoize 0.2.0
- While I'm here:
  - Convert to new options helper
  - Use USE_PHP=apc

php-memoize is a PHP extension which transparently caches PHP functions, much
like Perl's Memoize module.

It comes with the following storage modules which can be enabled at compile
time:

- memory: Simple per-request module with no dependencies.
          Since this is a per-request cache, neither TTLs specified in the
          `memoize()` call or `memoize.default_ttl` are used.
- memcached: Uses libmemcached or the memcached PHP extension
- apc: Uses the APC PHP extension

WWW: http://pecl.php.net/package/memoize

PR:		ports/190098
Submitted by:	Gasol Wu <gasol.wu@gmail.com>
Original commitRevision:355087 

Number of commits found: 13