notbugAs an Amazon Associate I earn from qualifying purchases.
Want a good read? Try FreeBSD Mastery: Jails (IT Mastery Book 15)
Want a good monitor light? See my photosAll times are UTC
Ukraine
This referral link gives you 10% off a Fastmail.com account and gives me a discount on my Fastmail account.

Get notified when packages are built

A new feature has been added. FreshPorts already tracks package built by the FreeBSD project. This information is displayed on each port page. You can now get an email when FreshPorts notices a new package is available for something on one of your watch lists. However, you must opt into that. Click on Report Subscriptions on the right, and New Package Notification box, and click on Update.

Finally, under Watch Lists, click on ABI Package Subscriptions to select your ABI (e.g. FreeBSD:14:amd64) & package set (latest/quarterly) combination for a given watch list. This is what FreshPorts will look for.

non port: graphics/colord/distinfo

Number of commits found: 8

Sunday, 28 Jan 2024
16:07 Gleb Popov (arrowd) search for other commits by this committer Author: Olivier Duchateau
graphics/colord: Update to 1.4.7

PR:		276684
commit hash: 522d686604a5b6f9a880cdb66c60a13ae14d17eb commit hash: 522d686604a5b6f9a880cdb66c60a13ae14d17eb commit hash: 522d686604a5b6f9a880cdb66c60a13ae14d17eb commit hash: 522d686604a5b6f9a880cdb66c60a13ae14d17eb 522d686
Monday, 19 Dec 2022
19:43 Adam Weinberger (adamw) search for other commits by this committer Author: Sean Champ
graphics/colord: Update to 1.4.6

This update adds many options including COMPLETIONS, DOCS, MANPAGES,
SANE, and an argyllcms SENSOR option.

Significantly, it removes the docbook-utils dependency, which brought
the entire LaTeX system with it. This unfortunate dependency added
literally hours to the build time of colord and everything which
required it (in particular, gtk30 and the entire GNOME DE).

The comical part is that docbook-utils haven't actually been used by
colord in nearly 5 years; our port was simply never updated to remove
that dependency. Mercifully, this is now fixed.

Many thanks to Antoine for running multiple exp-runs caused by me not
having my act together.

PR:		267239
commit hash: 0ceac973c8f6b5ae95c14ed9ed192c3f319e4cf3 commit hash: 0ceac973c8f6b5ae95c14ed9ed192c3f319e4cf3 commit hash: 0ceac973c8f6b5ae95c14ed9ed192c3f319e4cf3 commit hash: 0ceac973c8f6b5ae95c14ed9ed192c3f319e4cf3 0ceac97
Sunday, 30 Sep 2018
11:58 kwm search for other commits by this committer
The FreeBSD GNOME team proudly presents GNOME 3.28 for FreeBSD.

The offical GNOME 3.28 release notes can be found at
https://help.gnome.org/misc/release-notes/3.28/

Thanks to Antoine Brodin for running the exp-runs.

PR:		229761
Original commitRevision:480951 
Friday, 9 Dec 2016
20:02 bsam search for other commits by this committer
graphics/colord: Update to version 1.2.12, plus:
. add LICENSE (GPLv2);
. incorporate USES+=localbase;
. . build and install libcolordcompat [*].

[*] Argyllcms uses libcolordcompat to manage colors.
Here is the output of "dispwin -D1" command without and with libcolordcompat:
===
Got EDID for display
using ucmm for profile installation
---
Got EDID for display
using colord for profile installation
===
So, Argyll uses colord only when libcolordcompat is installed.

PR:		214728
Submitted by:	bsam (me)
Approved by:	kwm (maintainer timeout, 2 weeks+)
Original commitRevision:428238 
Wednesday, 5 Aug 2015
19:13 kwm search for other commits by this committer
The FreeBSD GNOME team proudly presents GNOME 3.16 for FreeBSD.

The offical GNOME 3.16 release notes can be found at
https://help.gnome.org/misc/release-notes/3.16/

Upgrade instructions for port users:

Delete the old tracker package with:
# pkg delete -f tracker
And user port upgrade tool of choice to upgrade.

Thanks to Antoine Brodin for running the exp-runs.

This release was made possible by the following people:
  Gustau Perez
  Ting-Wei_Lan

PR:		201980
Original commitRevision:393607 
Wednesday, 19 Nov 2014
11:49 kwm search for other commits by this committer
The FreeBSD GNOME team proudly presents GNOME 3.14 and Cinnamon 2.2.
Gnome 3.14.1 and Cinnamon 2.2.16 are supported on FreeBSD 9.3-RELEASE and up.

This commit removes the old GNOME 2 desktop, bindings and some ports that
can't be compiled. A few ports where updated to more recent versions to
allow them to compile with this update.

Apart from updating ports to newer versions

GDM is more integrated with gnome-shell now, and handles several things for
the GNOME desktop such as screen locking. If you want to use GNOME 3 via
startx, you will have to add your own lock screen/screensaver. For example
xscreensaver
can be used for sessions started without GDM.

Shell Extensions can be installed via https://extensions.gnome.org/ , we have
ported a few that can't be installed via this way.
The old gnome-utils and gnome-games ports where split up into single ports
and where converted to meta-ports.
gnome-terminal requires a UTF-8 locale to run, gdm handles this already, but
if you use startx you need to do this yourself.

Upgrade instructions:

Delete the old and conflicting packages:
# pkg delete clutter gnome-utils gnome-panel gnome-keyring vala-vapigen \
    guile gcalctool gnome-media libgnomekbd
# pkg delete gnome-screensaver gnome-applets bug-buddy evolution-exchange \
    evolution-webcal gnome-system-tools seahorse-plugins gnome-control-center

For package users the following lines will be enough:
# pkg upgrade
# pkg install gnome3

For ports users should do the following:
# portmaster -a
# portmaster x11/gnome3

We are currently aware of two issues. The first issue is a bug in the
file monitoring code in the glib20 port. This bug causes glib programs
to crash when files in a monitored directory are added or removed.
Upstream is aware of the problem, but since the problem is quite complex
there is no solution yet. This problem isn't restricted to BSD.

The second issue is that on certain video cards totem will display a
purple/pink overlay on the video. It not clear yet where the issues
comes from.

Major thanks goes to Gustau Perez for being a driving force behind getting
GNOME 3 up to speed again. Also thanks to Antoine Brodin for running the
exp-runs.

This update was also made possible by:
	Joe Maloney
	Kris Moore
	Beeblebrox
	Ryan Lortie
	Antoine Jacoutot
	and everyone I missed
Original commitRevision:372768 
Wednesday, 31 Jul 2013
11:57 kwm search for other commits by this committer
The FreeBSD GNOME team presents a Glib and Gtk+ 3 update.

This update updates Glib20 to 2.36 and Gtk+ 3.8

* The gio-fam-backend port that used gamin for the GFileMonitor API is gone.
  It is replaced by a GIO kqueue implementation developed as part of a NetBSD
  GSoC 2011 project by Dimitry Matveev.
* Fix a bug in the glib20 Makefile so it includes -lintl in the glib-2.0
  pkgconfig file [1]. This broke static linking and newer binutils.
* Add introspection USE_GNOME component which sets GI_SCANNER_DISABLE_CACHE to
  prevent creation of /  root/.cache dir. Defaults to build & run depend,
  but :build and :run switches available.
* New x11-toolkits/pangox-compat port and companion USE_GNOME component for
  pangox support which was removed from the pango port. Add it to ports still
  using pangox API.

Exp-run by:	bapt@
PR:		ports/178958 [1]
Submitted by:	emaste@ [1]
Original commitRevision:324037 
Friday, 8 Mar 2013
10:51 kwm search for other commits by this committer
* Update the glib to 2.34.3 and gtk20 to 2.24.17 and gtk30 to 3.6.4 which
  are the latest stable releases.
* Update vala to the newest stable release 0.18.1, also update a few ports
  in the gtk/gnome stack.
* The c++ bindings ports for glib, atk, gconf, etc, have now USE_GNOME toggles.
* Remove pkg-config run depends from glib20 and freetype2. This doesn't
  eliminate pkg-config run dependency completely, a second phase is needed
  and is planned.
* Support for .:run. and .:build. for USE_GNOME components was added.
  Currently only libxml2 and libxslt support this mechanism.
* Updates of the telepathy stack and empathy.
* Trim makefile headers, convert ports to new options, trim off library
  versions for some ports.
* Fix other ports so they build with the new glib version.

Thanks to miwi and crees for helping out with some exp-runs.
Approved by:	portmgr (miwi & bapt)
Obtained from:	gnome team repo
Original commitRevision:313633 

Number of commits found: 8