notbugAs an Amazon Associate I earn from qualifying purchases.
Want a good read? Try FreeBSD Mastery: Jails (IT Mastery Book 15)
Port details
openldap22-sasl-server Open source LDAP server implementation with SASL2 support
2.2.30 net Deleted on this many watch lists=5 search for ports that depend on this port This port version is marked as vulnerable. Find issues related to this port Report an issue related to this port View this port on Repology. pkg-fallout 2.2.30Version of this port present on the latest quarterly branch. NOTE: Slave port - quarterly revision is most likely wrong.
Deprecated DEPRECATED: OpenLDAP 2.2.x series are no longer maintained by developers. Use 2.3.x instead.
Maintainer: delphij@FreeBSD.org search for ports maintained by this maintainer
Port Added: 2004-05-02 00:02:33
Last Update: 2007-02-07 17:41:03
SVN Revision: UNKNOWN
People watching this port, also watch:: openssl, p5-Mail-Tools, cyrus-sasl
Also Listed In: databases
License: not specified in port
Description:
SVNWeb : git : Homepage
pkg-plist: as obtained via: make generate-plist
There is no configure plist information for this port.
Dependency lines:
  • openldap-sasl-server>0:net/openldap22-sasl-server
No installation instructions: this port has been deleted.
The package name of this deleted port was: openldap22-sasl-server
PKGNAME: openldap-sasl-server
Flavors: there is no flavor information for this port.
distinfo:
There is no distinfo for this port.
No package information for this port in our database

Master port: net/openldap22-server

Dependencies
NOTE: FreshPorts displays only information on required and default dependencies. Optional dependencies are not covered.
Library dependencies:
  1. sasl2.2 : security/cyrus-sasl2
  2. db-4.2.2 : databases/db42
  3. ldap-2.2.7 : net/openldap22-client
There are no ports dependent upon this port

Configuration Options:
Options name:
Master Sites:
Expand this list (14 items)
Collapse this list.
  1. ftp://ftp.FreeBSD.org/pub/FreeBSD/ports/distfiles/
  2. ftp://ftp.OpenLDAP.org/pub/OpenLDAP/openldap-release/
  3. ftp://ftp.dti.ad.jp/pub/net/OpenLDAP/openldap-release/
  4. ftp://ftp.holywar.net/pub/OpenLDAP/openldap-release/
  5. ftp://ftp.linux.pt/pub/mirrors/OpenLDAP/openldap-release/
  6. ftp://ftp.matrix.com.br/pub/openldap/openldap-release/
  7. ftp://ftp.nl.uu.net/pub/unix/db/openldap/openldap-release/
  8. ftp://ftp.ntua.gr/mirror/OpenLDAP/openldap-release/
  9. ftp://ftp.plig.org/pub/OpenLDAP/openldap-release/
  10. ftp://ftp.rediris.es/mirror/OpenLDAP/openldap-release/
  11. ftp://ftp.u-aizu.ac.jp/pub/net/openldap/openldap-release/
  12. ftp://ftp.ucr.ac.cr/pub/Unix/openldap/openldap-release/
  13. ftp://gd.tuwien.ac.at/infosys/network/OpenLDAP/openldap-release/
  14. ftp://sunsite.cnlab-switch.ch/mirror/OpenLDAP/openldap-release/
Collapse this list.

Number of commits found: 4

Commit History - (may be incomplete: see SVNWeb link above for full details)
This is a slave port. You may also want to view the commits to the master port: net/openldap22-server
DateByDescription
07 Feb 2007 17:41:03
Original commit files touched by this commit   2.2.30 This port version is marked as vulnerable.
delphij search for other commits by this committer
Remove OpenLDAP 2.2.x.  They are abandoned by developers and users
should use 2.3.x for production.

net/openldap22-client: OpenLDAP 2.2.x series are no longer maintained by
developers.  Use 2.3.x instead.
net/openldap22-sasl-client: OpenLDAP 2.2.x series are no longer maintained by
developers.  Use 2.3.x instead.
net/openldap22-sasl-server: OpenLDAP 2.2.x series are no longer maintained by
developers.  Use 2.3.x instead.
net/openldap22-server: OpenLDAP 2.2.x series are no longer maintained by
developers.  Use 2.3.x instead.
29 May 2006 06:35:13
Original commit files touched by this commit   2.2.30 This port version is marked as vulnerable.
delphij search for other commits by this committer
Fix wrong PKGNAME and COMMENT when WITH_SASL is defined.

Please note that the openldap 2.2.x series is now considered obsolete
and is no longer maintained.  Therefore, updates to this port would
be more conservative and less effort would be taken here in the future.

Current OpenLDAP users are encouraged to upgrade to 2.3.x.

Submitted by:   Gyorgy TEUBEL <tgyurci freemail hu> (with changes)
PR:             ports/91902
15 Aug 2004 18:18:46
Original commit files touched by this commit   2.2.15 This port version is marked as vulnerable.
eik search for other commits by this committer
update to 2.2.15

- new switch WITH_DYNAMIC_BACKENDS
- WITH_ODBC has to be specified, even when WITH_ODBC_TYPE is set
- 5.x users: when you need to start the daemon early, build with
  WITH_RCORDER=yes to put the start script into /etc/rc.d
02 May 2004 00:01:52
Original commit files touched by this commit   2.2.10 This port version is marked as vulnerable.
eik search for other commits by this committer
Add OpenLDAP slave ports with SASL support for package users.

See
  <http://www.openldap.org/doc/admin21/sasl.html>
  <http://www.openldap.org/doc/admin22/sasl.html>

Number of commits found: 4