notbugAs an Amazon Associate I earn from qualifying purchases.
Want a good read? Try FreeBSD Mastery: Jails (IT Mastery Book 15)
Want a good monitor light? See my photosAll times are UTC
Ukraine
non port: print/libijs/Makefile

Number of commits found: 28

Sunday, 25 Feb 2024
11:38 Muhammad Moinur Rahman (bofh) search for other commits by this committer
print/libijs: Moved man to share/man

Approved by:    portmgr (blanket)
commit hash: 7ff0aad767035d57fb6f16f50459212078f799ee commit hash: 7ff0aad767035d57fb6f16f50459212078f799ee commit hash: 7ff0aad767035d57fb6f16f50459212078f799ee commit hash: 7ff0aad767035d57fb6f16f50459212078f799ee 7ff0aad
Wednesday, 7 Sep 2022
21:10 Stefan Eßer (se) search for other commits by this committer
Add WWW entries to port Makefiles

It has been common practice to have one or more URLs at the end of the
ports' pkg-descr files, one per line and prefixed with "WWW:". These
URLs should point at a project website or other relevant resources.

Access to these URLs required processing of the pkg-descr files, and
they have often become stale over time. If more than one such URL was
present in a pkg-descr file, only the first one was tarnsfered into
the port INDEX, but for many ports only the last line did contain the
port specific URL to further information.

There have been several proposals to make a project URL available as
a macro in the ports' Makefiles, over time.

This commit implements such a proposal and moves one of the WWW: entries
of each pkg-descr file into the respective port's Makefile. A heuristic
attempts to identify the most relevant URL in case there is more than
one WWW: entry in some pkg-descr file. URLs that are not moved into the
Makefile are prefixed with "See also:" instead of "WWW:" in the pkg-descr
files in order to preserve them.

There are 1256 ports that had no WWW: entries in pkg-descr files. These
ports will not be touched in this commit.

The portlint port has been adjusted to expect a WWW entry in each port
Makefile, and to flag any remaining "WWW:" lines in pkg-descr files as
deprecated.

Approved by:		portmgr (tcberner)
commit hash: b7f05445c00f2625aa19b4154ebcbce5ed2daa52 commit hash: b7f05445c00f2625aa19b4154ebcbce5ed2daa52 commit hash: b7f05445c00f2625aa19b4154ebcbce5ed2daa52 commit hash: b7f05445c00f2625aa19b4154ebcbce5ed2daa52 b7f0544
Wednesday, 7 Apr 2021
08:09 Mathieu Arnold (mat) search for other commits by this committer
One more small cleanup, forgotten yesterday.
Reported by:	lwhsu
commit hash: cf118ccf875508b9a1c570044c93cfcc82bd455c commit hash: cf118ccf875508b9a1c570044c93cfcc82bd455c commit hash: cf118ccf875508b9a1c570044c93cfcc82bd455c commit hash: cf118ccf875508b9a1c570044c93cfcc82bd455c cf118cc
Tuesday, 6 Apr 2021
14:31 Mathieu Arnold (mat) search for other commits by this committer
Remove # $FreeBSD$ from Makefiles.
commit hash: 305f148f482daf30dcf728039d03d019f88344eb commit hash: 305f148f482daf30dcf728039d03d019f88344eb commit hash: 305f148f482daf30dcf728039d03d019f88344eb commit hash: 305f148f482daf30dcf728039d03d019f88344eb 305f148
Friday, 21 Oct 2016
15:21 mat search for other commits by this committer
Use USES=pathfix where applicable.

PR:		213195
Submitted by:	mat
Exp-run by:	antoine
Sponsored by:	Absolight
Differential Revision:	https://reviews.freebsd.org/D8093
Original commitRevision:424427 
Saturday, 22 Aug 2015
17:48 hrs search for other commits by this committer
- Split ghostscript into X11-independent and -dependent parts:

 * print/ghostscript{7,8,9,9-agpl}-base

   Installs Ghostscript binary, libgs, and related files.
   These ports do not depend on X11 libraries (i.e. x11* devices
   are not available).  USES=ghostscript will set dependency on
   one of them depending on GHOSTSCRIPT_DEFAULT.

   The default device is set to "display" or "bbox".

 * print/ghostscript{7,8,9,9-agpl}-x11

   Installs a shared library which provides X11 support to
   the installed Ghostscript binaries.  x11* devices will be
   enabled when the library is available.

   This depends on *-base (RUN_DEPENDS).  USES=ghostscript:x11
   will set dependency on one of them.

- Fix integer overflow reported as CVE-2015-3228.

- Update Uses/ghostscript.mk:

 * Add x11 keyword.  nox11 keyword is now obsolete.

 * Use packagename in *_DEPENDS line to prevent relationship between
   -base and -x11 packages from being broken.

- Fix x11/nox11 keyword and bump PORTREVISION in ports using
  USES=ghostscript to update dependency of pre-compiled packages.
Original commitRevision:395047 
Sunday, 10 May 2015
04:27 amdmi3 search for other commits by this committer
- Add LICENSE
- Strip library
Original commitRevision:385922 
Thursday, 18 Sep 2014
16:41 amdmi3 search for other commits by this committer
- Drop .la files, no dependees require them

Approved by:	portmgr blanket
Original commitRevision:368500 
Thursday, 24 Apr 2014
18:42 tijl search for other commits by this committer
Convert to USES=libtool tar:bzip2.
Original commitRevision:352049 
Saturday, 1 Feb 2014
15:39 miwi search for other commits by this committer
- Stage support
- Convert to uses
Original commitRevision:342174 
Friday, 20 Sep 2013
22:44 bapt search for other commits by this committer
Add NO_STAGE all over the place in preparation for the staging support (cat:
print)
Original commitRevision:327765 
Tuesday, 23 Apr 2013
14:20 bapt search for other commits by this committer
Finish converting the whole ports tree to USES=pkgconfig
Original commitRevision:316355 
Thursday, 26 Jul 2012
05:40 bapt search for other commits by this committer
new devel/pkgconf added to replace devel/pkg-config. new version of pkg-config
are no more self hosting so we are stuck with 0.25 version while pkgconf provide
the same set of features as 0.27 and a compatible frontend. A symlink to
pkg-config has been added for convenience and compatibility

This also introduces a new macro to use pkgconf in your ports:
USE_PKGCONFIG

it can take the following arguments:
 - yes (meaning build only dep)
 - build (meaning build only dep)
 - run (meaning run only dep)
 - both (meaning run and build dep)

From now USE_GNOME= pkgconfig is deprecated in favour of USE_PKGCONFIG
The old gnome macro has been modified to use pkgconf but still the sameway: run
and build dep to avoid large breakage.

While here fix some ports relying on pkg-config but not specifying it, fix some
ports broken because testing wrong .pc files, and fix ports using pkg-config
--version to determine pkg-config version instead of
pkg-config --modversion pkg-config like recommanded by pkg-config

With Hat:	portmgr
Exp-runs by:	bapt (pointhat-west), beat (pointyhat)
Original commit
Monday, 23 Jul 2012
01:33 dougb search for other commits by this committer
For ports maintained by ports@ where pkgconfig is one of the USE_GNOME deps
convert it to BUILD_DEPENDS. This avoids the problem of the bogus run dep
added by bsd.gnome.mk.
Original commit
Thursday, 11 Aug 2011
19:20 kwm search for other commits by this committer
Remove USE_GNOME=gnometarget from ports. It has been a empty keyword since
mid 2008.

PR:             ports/159624
Submitted by:   Ruslan Mahmatkhanov <cvs-src@yandex.ru>
Original commit
Tuesday, 2 Aug 2011
16:22 bapt search for other commits by this committer
Fix master_site
Original commit
Saturday, 4 Dec 2010
07:34 ade search for other commits by this committer
Sync to new bsd.autotools.mk
Original commit
Sunday, 2 Aug 2009
19:36 mezz search for other commits by this committer
-Repocopy devel/libtool15 -> libtool22 and libltdl15 -> libltdl22.
-Update libtool and libltdl to 2.2.6a.
-Remove devel/libtool15 and devel/libltdl15.
-Fix ports build with libtool22/libltdl22.
-Bump ports that depend on libltdl22 due to shared library version change.
-Explain what to do update in the UPDATING.

It has been tested with GNOME2, XFCE4, KDE3, KDE4 and other many wm/desktop
and applications in the runtime.

With help:      marcus and kwm
Pointyhat-exp:  a few times by pav
Tested by:      pgollucci, "Romain Tartière" <romain@blogreen.org>, and
                a few MarcusCom CVS users. Also, I might have missed a few.
Repocopy by:    marcus
Approved by:    portmgr
Original commit
Tuesday, 15 Aug 2006
00:56 clsung search for other commits by this committer
- s,INSTALLS_SHLIB,USE_LDCONFIG,g
- these include misc/ multimedia/ net/ net-mgmt/ net-im/
  net-p2p/ palm/ print/ science/ maintained by ports@

PR:             ports/101916
Submitted by:   Gea-Suan Lin <gslin_AT_gslin dot org>
Original commit
Thursday, 23 Feb 2006
10:40 ade search for other commits by this committer
Conversion to a single libtool environment.

Approved by:    portmgr (kris)
Original commit
Tuesday, 15 Nov 2005
06:52 ade search for other commits by this committer
Mass-conversion to the USE_AUTOTOOLS New World Order.  The code present
in bsd.autotools.mk essentially makes this a no-op given that all the
old variables set a USE_AUTOTOOLS_COMPAT variable, which is parsed in
exactly the same way as USE_AUTOTOOLS itself.

Moreover, USE_AUTOTOOLS has already been extensively tested by the GNOME
team -- all GNOME 2.12.x ports use it.

Preliminary documentation can be found at:
        http://people.FreeBSD.org/~ade/autotools.txt

which is in the process of being SGMLized before introduction into the
Porters Handbook.

Light blue touch-paper.  Run.
Original commit
Friday, 3 Jun 2005
20:18 oliver search for other commits by this committer
change the libtool version to use from 1.3 to 1.5
Original commit
Friday, 9 Jul 2004
17:43 marcus search for other commits by this committer
Apply a big libtool patch to allow porters to use the libtool installed by
the libtoolX ports instead of the one included with each port.  Ports that
set USE_LIBTOOL_VER=X will now use the ports version of libtool instead of
the included version.  To restore previous behavior, use the new macro,
USE_INC_LIBTOOL_VER.  Both macros accept the same argument: a libtool version.

For example, to use the ports version of libtool-1.5, add the following to
your Makefile:

USE_LIBTOOL_VER=        15

To use the included version of libtool with extra hacks provided by
libtool-1.5, add the following to your Makefile:

USE_INC_LIBTOOL_VER=    15

With this change, ports that had to add additional libtool hacks to prevent
.la files from being installed or to fix certain threading issues can now
delete those hacks (after appropriate testing, of course).

PR:             63944
Based on work by:eik and marcus
Approved by:    ade (autotools maintainer)
Tested by:      kris on pointyhat
Bound to be hidden problems:    You bet
Original commit
Sunday, 14 Mar 2004
06:17 ade search for other commits by this committer
Whoa there, boy, that's a mighty big commit y'all have there...

Begin autotools sanitization sequence by requiring ports to explicitly
specify which version of {libtool,autoconf,automake} they need, erasing
the concept of a "system default".

For ports-in-waiting:

        USE_LIBTOOL=YES         ->      USE_LIBTOOL_VER=13
        USE_AUTOCONF=YES        ->      USE_AUTOCONF_VER=213
        USE_AUTOMAKE=YES        ->      USE_AUTOMAKE_VER=14

Ports attempting to use the old style system after June 1st 2004 will be
sorely disappointed.
Original commit
Saturday, 13 Mar 2004
19:46 krion search for other commits by this committer
- Update to version 0.35

PR:             ports/64217
Submitted by:   Ports Fury
Original commit
Wednesday, 4 Feb 2004
05:10 marcus search for other commits by this committer
Bump PORTREVISION on all ports that depend on gettext to aid with upgrading.

(Part 1)
Original commit
Thursday, 20 Feb 2003
18:55 knu search for other commits by this committer
De-pkg-comment.
Original commit
Tuesday, 7 May 2002
16:56 ijliao search for other commits by this committer
add libijs 0.3.4
C library that supports plugin printer driver for Ghostscript

PR:             37833
Submitted by:   Ports Fury
Original commit

Number of commits found: 28