notbugAs an Amazon Associate I earn from qualifying purchases.
Want a good read? Try FreeBSD Mastery: Jails (IT Mastery Book 15)
Search FreshPorts using Google
not searching src

The FreshPorts Search


Include deleted ports Case sensitive search Sort by:
Include /src tree
Output format:
HTML
Plain Text
Maximum Effort Minimal output
Branch:

Notes

  • Case sensitivity is ignored for "sounds like" and output is ordered by the soundex.
  • When searching on 'Message ID', the type of match is ignored.
  • When searching on 'Commit Message' only 'containing' is used.
  • When searching by 'Under a pathname', your path must start with something like /ports/, /doc/, or /src/. All commits under that point will be returned. The selected match type is ignored and defaults to 'Starts with'.
  • Searching for 'sounds like' is only valid for Committer, Maintainer, Package Name, and Port Name.
Number of commits: 1986 (showing only 100 on this page) 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10 | 11  »  [20]
Sun, 13 Oct 2019
[ 19:52 rakuco ] Original commit 
openshadinglanguage 1.10.7 graphics files touched by this commit Advanced shading language for production GI renderers
Update to 1.10.7.

Bump LLVM dependency to llvm80.

PR:		241071
Submitted by:	Shane <FreeBSD@ShaneWare.Biz> (maintainer)
[ 16:10 rakuco ] Original commit 
py-alot 0.8.1 mail files touched by this commit Terminal MUA using Notmuch mail
Update to 0.8.1.

PR:		240311
Submitted by:	Dhananjay Balan <mail@dbalan.in> (maintainer)
[ 15:08 rakuco ] Original commit 
plasma5-breeze-gtk 5.16.5 x11-themes files touched by this commit Plasma5 Breeze visual style for Gtk
Add USES=gnome.

Fix a DEV_WARNING, we were setting USE_GNOME without setting USES=gnome. This
is part of the patch in bug 240343.

PR:		240343
Submitted by:	Ting-Wei Lan <lantw44@gmail.com>
[ 14:18 rakuco ] Original commit 
libkgeomap 19.08.1_2 astro files touched by this commit KDE library for browsing photos on a map
Drop dependency on graphics/opencv.

The source code does not use OpenCV anywhere, and apparently never has.

PR:		237934
Submitted by:	Hiroo Ono <hiroo.ono+freebsd@gmail.com>
[ 14:04 rakuco ] Original commit 
kopete 19.08.1 net-im files touched by this commit KDE multi-protocol instant messenger
Drop LLD_UNSAFE=yes.

The port is building fine on 12.0 and HEAD without setting this. The port's
build system is still wrong (i.e. the port still builds the same moc-generate
code in duplicate files), but lld seems to handle this case well.

A proper fix was sent upstream in https://phabricator.kde.org/D24609.

I am not bumping PORTREVISION because this only changes build dependencies.

PR:		228640
[ 10:42 rakuco ] Original commit 
kblog 19.08.1_1 net files touched by this commit KDE API for weblogging access
Drop USES_QT=webkit.

The build-time dependency was dropped back in 2016 with commit eb15f65 ("Drop
unnecessary QtWebKitWidgets dependency").
Sat, 12 Oct 2019
[ 20:50 rakuco ] Original commit 
qbs 1.14.0 devel files touched by this commit Qbs Build Suite
Update to 1.14.0.
Sun, 7 Jul 2019
[ 12:33 rakuco ] Original commit 
diff-so-fancy 1.2.6 textproc files touched by this commit Fancier diff output formatter
Update to 1.2.6.
Mon, 1 Apr 2019
[ 17:39 rakuco ] Original commit 
py-kaa-metadata 0.7.7_16 multimedia files touched by this commit Kaa Media Repository - media file metadata parser
MFH: r497494

Fix gexiv dependencies in the port.

The port was erroneously depending on graphics/py-exiv2 while in fact it only
needs exiv2 itself (which was always present anyway because py-exiv2 depends on
it). This port builds a Python module that links against exiv2, so clarify the
situation and stop depending on py-exiv2, which is BROKEN and DEPRECATED.

PR:		236806
Approved by:	J.R. Oldroyd <fbsd@opal.com> (maintainer)

Approved by:	ports-secteam (blanket approval)
[ 17:37 rakuco ] Original commit 
py-kaa-metadata 0.7.7_16 multimedia files touched by this commit Kaa Media Repository - media file metadata parser
Fix gexiv dependencies in the port.

The port was erroneously depending on graphics/py-exiv2 while in fact it only
needs exiv2 itself (which was always present anyway because py-exiv2 depends on
it). This port builds a Python module that links against exiv2, so clarify the
situation and stop depending on py-exiv2, which is BROKEN and DEPRECATED.

PR:		236806
Approved by:	J.R. Oldroyd <fbsd@opal.com> (maintainer)
Sun, 31 Mar 2019
[ 17:11 rakuco ] Original commit 
qt5-webengine 5.12.1_1 www files touched by this commit Qt 5 library to render web content
Update comment.

Printing support was enabled in r475479.
[ 16:35 rakuco ] Original commit 
qt5-webengine 5.12.1_1 www files touched by this commit Qt 5 library to render web content
Remove yet another unneeded patch.

The port built fine with the static_assert on 11.2-i386 and 12.0-amd64.
[ 15:50 rakuco ] Original commit 
qt5-webengine 5.12.1_1 www files touched by this commit Qt 5 library to render web content
Remove another unnecessary patch.

The code built fine without the extra headers on 11.2, 12.0 and HEAD.
[ 13:55 rakuco ] Original commit 
qt5-webengine 5.12.1_1 www files touched by this commit Qt 5 library to render web content
Remove unnecessary patch.

We already use the re2 port, and QtWebEngine's build system takes care of
unbundling Chromium's version (which includes making sure the internal re2
header includes actually point to the system ones).
Sat, 30 Mar 2019
[ 23:23 rakuco ] Original commit 
qt5-webengine 5.12.1_1 www files touched by this commit Qt 5 library to render web content
Use lcms2 from ports rather than Chromium's bundled copy.
[ 22:25 rakuco ] Original commit 
qt5-webengine 5.12.1 www files touched by this commit Qt 5 library to render web content
Remove unused "enable_hidpi" GN argument.

GN reports this variable cannot be changed via an argument. No PORTREVISION
bump, this change has no visible effects.
[ 13:09 rakuco ] Original commit 
dsbmc 0.6.1 sysutils files touched by this commit GTK+ client for DSBMD that lets you mount media, and more
Update to 0.6.1.

PR:		236783
Submitted by:	Marcel Kaiser <mk@nic-nac-project.org> (maintainer)
Fri, 29 Mar 2019
[ 18:44 rakuco ] Original commit 
gwenview 18.12.3_4 graphics files touched by this commit Image viewer and browser for KDE
Backport a few changes to enable exceptions in all files that use libexiv.

This is required after the recent exiv2 update to 0.27, as exiv requires a
build with exceptions enabled, and KDE disables exceptions by default.

This fixes the build with GCC (for some reason, clang doesn't complain that
code that uses exceptions is built with -fno-exceptions).

PR:		236849
Wed, 27 Mar 2019
[ 07:50 rakuco ] Original commit 
tesseract 3.05.02_5 graphics files touched by this commit Commercial quality open source OCR engine
Make sure the port links against libthr.so

This fixes the build in HEAD after lld received support for
--no-allow-shlib-undefined in base r345349.

Upstream looks for libpthread in sem_init(3), which is part of libc on
FreeBSD. Look for a symbol that's in libpthread to make sure we link
against it.

See also: https://github.com/tesseract-ocr/tesseract/issues/2344

PR:		236812
Approved by:	Piotr Kubaj <pkubaj@anongoth.pl> (maintainer)
Mon, 25 Mar 2019
[ 13:00 rakuco ] Original commit 
ilmbase 2.3.0_2 graphics files touched by this commit ILM Base libraries a.k.a. Half, IlmThread, Imath, and Iex
Simplify pthread + libtool workaround.

Improve upon r496818. Instead of setting both MAKE_ENV and patching ilmthread's
Makefile, just make sure PTHREAD_LIBS is set a configuration time. This is what
Debian does, and it achieves the same solution with fewer lines.

While here, add an explanation for why we need this.

PR:		236734
Approved by:	mandree (maintainer)
Thu, 21 Mar 2019
[ 08:16 rakuco ] Original commit 
lyx 2.3.1_3 print files touched by this commit Document processor interfaced with LaTeX (nearly WYSIWYG)
print/lyx: Fix a bad MFH done in r496238.

That commit was only supposed to backport changes to the port's
dependencies and the post-patch target, yet it changed MINOR_VERSION,
WRKSRC and DISTVERSIONSUFFIX, causing make fetch, make checksum and
other targets to fail.

Approved by:	ports-secteam (implicit)
Mon, 18 Mar 2019
[ 21:05 rakuco ] Original commit 
kf5-extra-cmake-modules 5.53.0_2 devel files touched by this commit Extra modules and scripts for CMake
MFH: r496208

Depend on qt5-linguisttools at runtime too.

This fixes bug 236613, which happens when the KWALLET option is disabled. In
this case, we do not pull in devel/qt5-linguisttools even though Falkon's build
system uses e-c-m's ECMPoQmTools.cmake, which requires linguisttools to be
present. As it turns out, we need to run-depend on linguisttools to prevent
this kind of issue anywhere.

PR:		236613
Reviewed by:	tcberner
Differential Revision:	https://reviews.freebsd.org/D19629

Approved by:	ports-secteam (blanket)
[ 21:02 rakuco ] Original commit 
kf5-extra-cmake-modules 5.56.0_1 devel files touched by this commit Extra modules and scripts for CMake
Depend on qt5-linguisttools at runtime too.

This fixes bug 236613, which happens when the KWALLET option is disabled. In
this case, we do not pull in devel/qt5-linguisttools even though Falkon's build
system uses e-c-m's ECMPoQmTools.cmake, which requires linguisttools to be
present. As it turns out, we need to run-depend on linguisttools to prevent
this kind of issue anywhere.

PR:		236613
Reviewed by:	tcberner
Differential Revision:	https://reviews.freebsd.org/D19629
Sun, 17 Mar 2019
[ 19:10 rakuco ] Original commit 
qca 2.1.3_7 devel files touched by this commit Cross-platform crypto API for Qt
Add a TEST option and set TEST_TARGET.

This also allows us to get rid of the sed hack in post-patch now that
patch-git_e854f357 handles the dependency on qt5-network correctly.
[ 18:05 rakuco ] Original commit 
falkon 3.0.1_2 www files touched by this commit Web browser based on Webengine and Qt Framework
Add USES=pkgconfig when GNOMEKEYRING is on.

This is actually required for the BUILD_KEYRING CMake option to have any
effect; in practice this means the GNOMEKEYRING option was not actually working
at all, and produced a package without the gnome-keyring plugin.

Bump PORTREVISION since a package with GNOMEKEYRING on was incorrect.

Reported by:	fluffy
[ 18:00 rakuco ] Original commit 
falkon 3.0.1_1 www files touched by this commit Web browser based on Webengine and Qt Framework
Add USES=gnome when GNOMEKEYRING is on.

This follows the developer warning from bsd.port.mk that USE_GNOME should come
together with USES=gnome.
[ 17:35 rakuco ] Original commit 
qt5 5.12.1_2 devel files touched by this commit Cross-platform application and UI framework (metaport)
Point to Qt's current website in WWW.
[ 17:27 rakuco ] Original commit 
kdeconnect-kde 1.3.3_4 deskutils files touched by this commit Support for KDE to interface between your phone and your computer
plasma5-kinfocenter 5.15.3_1 sysutils files touched by this commit Plasma5 utility providing system information
kf5-frameworks 5.56.0_1 x11 files touched by this commit KF5 frameworks meta port
plasma5-breeze 5.15.3_1 x11-themes files touched by this commit Plasma5 artwork, styles and assets for the Breeze visual style
plasma5-oxygen 5.15.3_1 x11-themes files touched by this commit Plasma5 Oxygen style
Bump PORTREVISION in other ports that depend optionally on x11/kf5-kwayland.

See r496074 for the explanation.
[ 17:12 rakuco ] Original commit 
kf5-plasma-framework 5.56.1_1 x11 files touched by this commit KF5 plugin based UI runtime used to write user interfaces
Revert r496041 and r496054.

The changes were right, but they broke `make configure' in ports that have
USE_KDE=wayland because now both Mk/Uses/qt.mk and Mk/Uses/kde.mk set
wayland_PORT and wayland_LIB, and qt.mk's version overrides kde.mk's. This
means we will end up installing graphics/qt5-wayland rather than
x11/kf5-kwayland:

CMake Error at CMakeLists.txt:27 (find_package):
  Could not find a package configuration file provided by "KF5Wayland"
  (requested version 5.54.0) with any of the following names:

    KF5WaylandConfig.cmake
    kf5wayland-config.cmake

  Add the installation prefix of "KF5Wayland" to CMAKE_PREFIX_PATH or set
  "KF5Wayland_DIR" to a directory containing one of the above files.  If
  "KF5Wayland" provides a separate development package or SDK, be sure it has
  been installed.

Bump PORTREVISION in x11/kf5-plasma-framework, it has an optional dependency on
kf5-kwayland and was thus building fine despite the wrong dependencies.
[ 14:16 rakuco ] Original commit 
falkon 3.0.1_1 www files touched by this commit Web browser based on Webengine and Qt Framework
Remove linguist_build from USE_QT.

This was added in r493225 without a clear explanation. There are no mentions of
linguist in the source code, and testbuilding the port without it also works
fine.

Approved by:	tcberner
Differential Revision:	https://reviews.freebsd.org/D19575
[ 12:24 rakuco ] Original commit 
libdbusmenu-qt 0.9.3.160420160218_9 devel files touched by this commit Qt5 implementation of the DBusMenu protocol
Drop conditional assignment now that this is a simple port after r495956.

Reviewed by:	tcberner
Sat, 16 Mar 2019
[ 15:59 rakuco ] Original commit 
libzip 1.5.2 archivers files touched by this commit C library for reading, creating, and modifying ZIP archives
Update to 1.5.2.

Announcement: https://libzip.org/news/release-1.5.2.html
Sun, 10 Mar 2019
[ 15:22 rakuco ] Original commit 
ark 18.12.3_3 archivers files touched by this commit Archiving tool for KDE
Remove patch that was only supposed to fix the build on FreeBSD <= 10.3.
Sat, 9 Mar 2019
[ 19:23 rakuco ] Original commit 
ark 18.12.3_2 archivers files touched by this commit Archiving tool for KDE
Backport patch to fix creation of .tar archives when ZTD support is enabled.

As the patch says, when ZSTD support is present creating a regular .tar archive
will end up creating a zstd file instead. In my tests, this prevented
adding/remove entries from the archive at all.

MFH:		2019Q1
[ 17:55 rakuco ] Original commit 
ark 18.12.0_2 archivers files touched by this commit Archiving tool for KDE
MFH: r495180

Add USES=shared-mime-info

Starting with version 18.12.0, Ark has included a custom kerfuffle.xml mime
type to support zstd-compressed files (the mimetype was only added to
shared-mime-info starting with version 1.11, which we don't ship yet). We need
to make sure update-mime-database is run, otherwise Ark will still fail to
recognize those archives.

Approved by:	ports-secteam (blanket approval)
[ 17:52 rakuco ] Original commit 
ark 18.12.3_1 archivers files touched by this commit Archiving tool for KDE
Add USES=shared-mime-info

Starting with version 18.12.0, Ark has included a custom kerfuffle.xml mime
type to support zstd-compressed files (the mimetype was only added to
shared-mime-info starting with version 1.11, which we don't ship yet). We need
to make sure update-mime-database is run, otherwise Ark will still fail to
recognize those archives.
Thu, 28 Feb 2019
[ 13:47 rakuco ] Original commit 
qca 2.1.3_6 devel files touched by this commit Cross-platform crypto API for Qt 5
MFH: r494079

Replace OpenSSL 1.1.0 with upstream ones

The patches from bug 228902 and added in r481850 are not entirely compatible
with older OpenSSL versions, to the point that the qca-ossl plugin refuses to
load at all on FreeBSD 11.2, for example (see bug 232784 and its duplicates).

Fix it by replacing our patches with backports from upstream the same way
OpenSUSE does it (the OpenSSL 1.1.0 upstream patch was authored by SUSE):

* Revert an upstream commit made only to the 2.1 branch disabling a few ciphers
  in the unit tests.
* Backport a change to the master branch that never made it to the 2.1 branch
  disabling the ciphers mentioned above as well as a few other ones, so that we
(Only the first 15 lines of the commit message are shown above View all of this commit message)
Wed, 27 Feb 2019
[ 19:22 rakuco ] Original commit 
qca 2.1.3_6 devel files touched by this commit Cross-platform crypto API for Qt
Replace OpenSSL 1.1.0 with upstream ones

The patches from bug 228902 and added in r481850 are not entirely compatible
with older OpenSSL versions, to the point that the qca-ossl plugin refuses to
load at all on FreeBSD 11.2, for example (see bug 232784 and its duplicates).

Fix it by replacing our patches with backports from upstream the same way
OpenSUSE does it (the OpenSSL 1.1.0 upstream patch was authored by SUSE):

* Revert an upstream commit made only to the 2.1 branch disabling a few ciphers
  in the unit tests.
* Backport a change to the master branch that never made it to the 2.1 branch
  disabling the ciphers mentioned above as well as a few other ones, so that we
  can backport the actual change adding support for OpenSSL 1.1.0 more clealy.
* Backport the actual OpenSSL 1.1.0 support commit, with a few conflicts
(Only the first 15 lines of the commit message are shown above View all of this commit message)
Sat, 16 Feb 2019
[ 12:14 rakuco ] Original commit 
diff-so-fancy 1.2.5 textproc files touched by this commit Fancier diff output formatter
Update to 1.2.5

This is the first stable release since 1.2.0. Release notes:
https://github.com/so-fancy/diff-so-fancy/releases/tag/v1.2.5
Fri, 4 Jan 2019
[ 12:19 rakuco ] Original commit 
lyx 2.3.2 print files touched by this commit Document processor interfaced with LaTeX (nearly WYSIWYG)
Update to 2.3.2.

Release announcement: https://www.lyx.org/announce/2_3_2.txt
Mon, 24 Dec 2018
[ 10:51 rakuco ] Original commit 
lyx 2.3.1_1 print files touched by this commit Document processor interfaced with LaTeX (nearly WYSIWYG)
Add USES=compiler:c++11-lang for GCC builds to work

This fixes the build on architectures where GCC is the default compiler.

PR:		234340
Submitted by:	Piotr Kubaj <pkubaj@anongoth.pl>
Fri, 7 Dec 2018
[ 11:52 rakuco ] Original commit 
lyx 2.3.1 print files touched by this commit Document processor interfaced with LaTeX (nearly WYSIWYG)
Update to 2.3.1.

Release announcement: https://www.lyx.org/announce/2_3_1.txt
[ 11:47 rakuco ] Original commit 
lyx 2.3.0_1 print files touched by this commit Document processor interfaced with LaTeX (nearly WYSIWYG)
Set LICENSE_FILE
Mon, 3 Dec 2018
[ 09:21 rakuco ] Original commit 
zeal 0.6.1 devel files touched by this commit Offline documentation browser
Update to 0.6.1.

Release notes: https://github.com/zealdocs/zeal/releases/tag/v0.6.1
Wed, 21 Nov 2018
[ 12:26 rakuco ] Original commit 
alegreya 2.008 x11-fonts files touched by this commit Serif typeface originally intended for literature
Update to 2.008
Mon, 5 Nov 2018
[ 15:18 rakuco ] Original commit 
plasma5-systemsettings 5.12.7_2 sysutils files touched by this commit Plasma5 system settings
Fix plist after r483271 (most likely culprit).
Sat, 14 Jul 2018
[ 22:27 rakuco ] Original commit 
konversation 1.7.5 irc files touched by this commit User friendly IRC client for KDE
Update to 1.7.5.

This is a small bugfix release with a single change fixing the build with Qt
5.11.
Sun, 24 Jun 2018
[ 15:32 rakuco ] Original commit 
doublecmd 0.8.3 x11-fm files touched by this commit Total Commander like file manager for the X Window System
Update to 0.8.3.

While here, add some dependencies that were being pulled in implicitly.

PR:		228739
Submitted by:	Benat Gonzalez Etxepare <bbtruk@users.sourceforge.net>
(maintainer)
[ 12:13 rakuco ] Original commit 
comfortaa-ttf 3.001 x11-fonts files touched by this commit Stylish, modern and free sans-serif true type font
Update to 3.001.

The version hosted in fontlibrary.org hasn't been updated in years, and there
sia new release in... DeviantArt.

Adjust MASTER_SITES, point WWW to the Google Fonts page and start setting
LICENSE_FILE.
[ 12:08 rakuco ] Original commit 
comfortaa-ttf 2.004_3 x11-fonts files touched by this commit Stylish, modern and free sans-serif true type font
Set NO_ARCH=yes
Sat, 23 Jun 2018
[ 20:03 rakuco ] Original commit 
cmake-gui 3.11.4 devel files touched by this commit Qt-based GUI for CMake
Copy devel/cmake patch from r473149.

devel/cmake-gui also needs this in order to build after r473142.

PR:		229255
Reported by:	tcberner
[ 18:51 rakuco ] Original commit 
cmake 3.11.4_1 devel files touched by this commit Cross-platform Makefile generator
Add a patch to unbreak `make configure' with libuv 1.21.0.

r473142 updated libuv and broke CMake. The new release moved internal headers
to the uv/ directory, and CMake needs to be taught about it.

Not bumping PORTREVISION as FindLibUV.cmake is not installed and no builds with
the new libuv could have worked before.

PR:		229255
Thu, 14 Jun 2018
[ 21:18 rakuco ] Original commit 
libzip 1.5.1 archivers files touched by this commit C library for reading, creating, and modifying ZIP archives
Update to 1.5.1.

Upstream has switched to CMake, so follow suit here (and explicitly disable
crypto backends other than OpenSSL for AES support).

The port also depends on Perl for testing, so add the missing dependency.

Based on an initial patch by danfe@.

Submitted by:	danfe (initial version)
Thu, 31 May 2018
[ 17:48 rakuco ] Original commit 
libconfuse 3.2.1_1 devel files touched by this commit Configuration file parsing library
Fix plist after r471139
Fri, 18 May 2018
[ 12:27 rakuco ] Original commit 
qt5-speech 5.10.1 accessibility files touched by this commit Accessibilty features for Qt5
qt5-connectivity 5.10.1 comms files touched by this commit Qt connectivity (Bluetooth/NFC) module
qt5-sensors 5.10.1 comms files touched by this commit Qt sensors module
qt5-serialbus 5.10.1 comms files touched by this commit Qt functions to access industrial bus systems
qt5-serialport 5.10.1 comms files touched by this commit Qt functions to access serial ports
qt5-sql 5.10.1 databases files touched by this commit Qt SQL database integration module
qt5-sqldrivers-ibase 5.10.1 databases files touched by this commit Qt InterBase/Firebird database plugin
qt5-sqldrivers-mysql 5.10.1 databases files touched by this commit Qt MySQL database plugin
qt5 5.10.1_1 devel files touched by this commit Cross-platform application and UI framework (metaport)
qt5-assistant 5.10.1 devel files touched by this commit Qt 5 documentation browser

(Only the first 10 of 69 ports in this commit are shown above. View all ports for this commit)
Update the Qt5 ports to 5.10.1.

The work was done by tcberner and myself, with thanks to antoine for the
exp-run.

Not a lot to report compared to other Qt5 updates:
* net/qt5-network is still broken with LibreSSL. I said this in a commit
  message ages ago but it bears repeating: upstream is open to adding support
  for LibreSSL, but someone needs to step up to maintain it upstream, otherwise
  things will continue to be broken all the time.
* www/qt5-webengine is a huge monster that is terrible to update, just like
  www/chromium itself is. We (kde@) have decided to keep using the 5.9 series
  for the time being, as it should be compatible with the rest of Qt anyway. It
  was updated to 5.9.5, the latest 5.9 release at the time of writing.

PR:		228213
[ 10:19 rakuco ] Original commit 
lyx 2.3.0 print files touched by this commit Document processor interfaced with LaTeX (nearly WYSIWYG)
Add a patch to fix the build on FreeBSD 10.4.

pkg-fallout reports the following error:

    TexRow.cpp:271:6: error: return type 'const TexRow::TextEntry' must match
previous return type 'TexRow::TextEntry' when lambda expression has unspecified
explicit return type
                                            return text_none;
                                            ^
    TexRow.cpp:273:3: error: return type 'const TexRow::TextEntry' must match
previous return type 'TexRow::TextEntry' when lambda expression has unspecified
explicit return type
                    return text_none;
                    ^
    TexRow.cpp:288:6: error: return type 'lyx::TexRow::TextEntry' must match
previous return type 'const TexRow::TextEntry' when lambda expression has
unspecified explicit return type
                                            return last_pos;
                                            ^
    TexRow.cpp:290:6: error: return type 'struct TextEntry' must match previous
return type 'const TexRow::TextEntry' when lambda expression has unspecified
explicit return type
                                            return entry.text;
                                            ^
    TexRow.cpp:293:3: error: return type 'lyx::TexRow::TextEntry' must match
previous return type 'const TexRow::TextEntry' when lambda expression has
unspecified explicit return type
                    return last_pos;
                    ^

Make the lambda return type explicit to work around what looks like a bug on an
old clang version.

Not bumping PORTREVISION, as this shouldn't change the code in FreeBSD versions
with a more recent clang.
Wed, 16 May 2018
[ 20:12 rakuco ] Original commit 
lyx 2.3.0 print files touched by this commit Document processor interfaced with LaTeX (nearly WYSIWYG)
Update to 2.3.0.

Announcement: https://www.lyx.org/announce/2_3_0.txt
[ 19:46 rakuco ] Original commit 
pgmodeler 0.9.0_3 databases files touched by this commit PostgreSQL Database Modeler
Import yet another patch from upstream to fix the build with Qt 5.10.

This has been properly tested now.

PR:		228213
[ 09:11 rakuco ] Original commit 
krusader2 2.7.0 x11-fm files touched by this commit Twin panel file manager for KDE, like midnight or norton commander
Update Krusader to 2.7.0.

This version is based on KDE Frameworks 5. Release notes:
https://krusader.org/release/2.7.0/release_notes.txt

While here, update pkg-message by pointing to Krusader's documentation, as
providing a list of all ports Krusader might use as external dependencies is
too much.

Reviewed by:	tcberner
Differential Revision:	https://reviews.freebsd.org/D15436
[ 07:36 rakuco ] Original commit 
krusader2-kde4 2.4.0.b3_6 x11-fm  Deleted Deprecated Expired files touched by this commit Twin panel file manager for KDE, like midnight or norton commander
Copy x11-fm/krusader2 to x11-fm/krusader-kde4.

Keep a KDE4-based version around for the KDE4 widows as preparation for
updating Krusader to a newer, KF5-based version.

Reviewed by:	tcberner
Differential Revision:	https://reviews.freebsd.org/D15448
Tue, 15 May 2018
[ 18:51 rakuco ] Original commit 
ugene 1.22.0_3 biology files touched by this commit Free, open-source, cross-platform bioinformatics toolkit
Add upstream patch to fix the build with Qt 5.10.

    _tmp/ui/ui_Bowtie2Settings.h:189:35: error: no viable conversion from
'QLatin1String' to 'const QKeySequence'
            gbarCheckBox->setShortcut(QLatin1String(""));
                                      ^~~~~~~~~~~~~~~~~

PR:		228213
[ 18:20 rakuco ] Original commit 
pgmodeler 0.9.0_2 databases files touched by this commit PostgreSQL Database Modeler
Add an upstream patch to fix the build with Qt 5.10.

    src/ui_sqlexecutionwidget.h:186:34: error: no viable conversion from
'QLatin1String' to 'const QKeySequence'
            snippets_tb->setShortcut(QLatin1String("Alt+X"));
                                     ^~~~~~~~~~~~~~~~~~~~~~

PR:		228213
[ 15:13 rakuco ] Original commit 
mgba 0.6.1_2 emulators files touched by this commit Game Boy Advance (GBA) emulator/debugger
Add upstream patch to fix the build with Qt 5.10.

   
/wrkdirs/usr/ports/emulators/mgba/work/mgba-0.6.1/src/platform/qt/MemoryModel.cpp:102:15:
error: no viable overloaded '='
            m_regionName = name;
            ~~~~~~~~~~~~ ^ ~~~~

PR:		228213
[ 15:10 rakuco ] Original commit 
tarsnap-gui 1.0 sysutils files touched by this commit Cross platform GUI for the Tarsnap command line client
Add upstream patch to fix `make configure' with Qt 5.10.

Without this commit, configuring with Qt 5.10 fails with

    Project ERROR: Tarsnap-gui requires Qt 5.2 or higher.

PR:		228213
[ 12:21 rakuco ] Original commit 
libgit2 0.27.0_1 devel files touched by this commit Portable, pure C implementation of the Git core
libgit2-glib 0.26.0 devel files touched by this commit Glib wrapper library around the libgit2 git access library
devel/libgit2-glib: Unbreak with libgit2 0.27.

The fix is two-fold:
* Adjust the path for the sed call in devel/libgit2 so that we leave out
  openssl from libgit2.pc's Requires.private line, otherwise libgit2-glib will
  look for openssl.pc, which does not exist when OpenSSL from base is used.

* Reset libgit2-glib back to 0.26, and import a patch both Arch Linux and
  openSUSE have been carrying to fix the build with libgit2 0.27. PORTEPOCH was
  not set because there is no libgit2-glib 0.27 and no package could have
  possibly been built after r469930.

Approved by:	mfechner, gnome (kwm)
Differential Revision:	https://reviews.freebsd.org/D15437
[ 11:56 rakuco ] Original commit 
qupzilla-qt5 1.8.9_4 www  Deleted Deprecated Expired files touched by this commit Web browser based on WebKit engine and Qt Framework
Add an upstream patch to fix the build with Qt 5.10.

    In file included from webtab/searchtoolbar.cpp:21:
    ../../build/ui_searchtoolbar.h:76:31: error: no viable conversion from
'QLatin1String' to 'const QKeySequence'
            previous->setShortcut(QLatin1String("Ctrl+Shift+G"));

PR:		228213
Mon, 14 May 2018
[ 20:26 rakuco ] Original commit 
fantasque-sans-mono 1.7.2_1 x11-fonts files touched by this commit Programming font, designed with functionality in mind
Set DISTFILES as OPTIONs helpers.

This allows one to only download the tarball corresponding to the chosen
VARIANT option, at the expense of making `make makesum' more cumbersome to
run (so add a comment to remind me of how to do it).

PR:		228206
Submitted by:	tobik
[ 19:31 rakuco ] Original commit 
krusader2 2.4.0.b3_6 x11-fm files touched by this commit Twin panel file manager for KDE, like midnight or norton commander
Update WWW in pkg-descr
[ 10:24 rakuco ] Original commit 
fantasque-sans-mono 1.7.2_1 x11-fonts files touched by this commit Programming font, designed with functionality in mind
Add options to install variants.

Fantasque Sans Mono distribution site has variants aside from the standard
version. Add options to allow installing those variants.

PR:		228206
Submitted by:	Jonathan Chen <jonc@chen.org.nz>
Sat, 12 May 2018
[ 18:04 rakuco ] Original commit 
qt5-network 5.9.4_4 net files touched by this commit Qt network module
Drop some patches for old LibreSSL versions.

The ports tree currently has LibreSSL 2.7.3, so remove some patches added to
support LibreSSL < 2.5 (also, according to brnrd@, they are currently broken).
Cleaning up our existing patches also helps us move to Qt 5.10.

Reviewed by:	tcberner
Differential Revision:	https://reviews.freebsd.org/D15338
Thu, 10 May 2018
[ 13:41 rakuco ] Original commit 
fantasque-sans-mono 1.7.2 x11-fonts files touched by this commit Programming font, designed with functionality in mind
Update to 1.7.2 and set NO_ARCH.

PR:		228110
Submitted by:	m.ne@gmx.net
[ 13:38 rakuco ] Original commit 
vollkorn-ttf 4.105 x11-fonts files touched by this commit Free and healthy typeface for bread and butter use
Update to 4.105.

PR:		228109
Submitted by:	m.ne@gmx.net
Wed, 9 May 2018
[ 08:28 rakuco ] Original commit 
miniupnpc 2.1_1 net files touched by this commit UPnP IGD client lightweight library
Fix plist after r469430.
Tue, 8 May 2018
[ 19:44 rakuco ] Original commit 
vollkorn-ttf 4.015 x11-fonts files touched by this commit Free and healthy typeface for bread and butter use
Update to 4.015.

PR:		228079
Submitted by:	m.ne@gmx.net
[ 19:43 rakuco ] Original commit 
vollkorn-ttf 3.005 x11-fonts files touched by this commit Free and healthy typeface for bread and butter use
Set NO_ARCH

Follow poudriere's advice, the port does not install any architecture-specific
files.
Sun, 29 Apr 2018
[ 17:52 rakuco ] Original commit 
lyx 2.2.4 print files touched by this commit Document processor interfaced with LaTeX (nearly WYSIWYG)
Update to 2.2.4.

Announcement: https://www.lyx.org/announce/2_2_4.txt
Wed, 25 Apr 2018
[ 07:39 rakuco ] Original commit 
vala 0.36.13_1,1 lang files touched by this commit Programming language and compiler that converts Vala code into C code
Fix plist after r468231.
Wed, 14 Mar 2018
[ 11:26 rakuco ] Original commit 
alegreya-sans 2.008,1 x11-fonts files touched by this commit Humanist sans serif font with a calligraphic feeling
Update to 2.008
[ 11:24 rakuco ] Original commit 
alegreya 2.007 x11-fonts files touched by this commit Serif typeface originally intended for literature
Update to 2.007
Mon, 12 Mar 2018
[ 21:53 rakuco ] Original commit 
hack-font 3.003 x11-fonts files touched by this commit Typeface designed for source code
Update to 3.003
Sun, 18 Feb 2018
[ 18:49 rakuco ] Original commit 
multimarkdown 4.7.1 textproc files touched by this commit Extended Markdown processor with more features, written in C
Sort plist
[ 17:40 rakuco ] Original commit 
kdelibs-kde4 4.14.38 x11  Deleted Deprecated Expired files touched by this commit Base set of libraries needed by KDE programs
Update kdelibs to 4.14.38.

According to upstream, which has stopped making new releases of Qt4-based
software, this is the last kdelibs release ever.

Thanks to antoine for the exp-run.

PR:		225991
Differential Revision:	https://reviews.freebsd.org/D14411
[ 17:10 rakuco ] Original commit 
zeal 0.6.0 devel files touched by this commit Offline documentation browser
Update to 0.6.0

Annonuncement:
https://github.com/zealdocs/zeal/releases/tag/v0.6.0
[ 10:06 rakuco ] Original commit 
qt4-mobility 1.2.2_3 multimedia  Deleted Deprecated Expired files touched by this commit Qt APIs for mobile devices and desktop platforms
Fix the build with clang 6.

There's no point in making old, unmaintained code be C++11 compliant, so just
build with -std=gnu++98.

    qvideosurfacegstsink.cpp:345:73: error: constant expression evaluates to
4278190080 which cannot be narrowed to type 'int' [-Wc++11-narrowing]
        { QVideoFrame::Format_RGB32 , 32, 24, 4321, 0x0000FF00, 0x00FF0000,
0xFF000000, 0x00000000 },
                                                                           
^~~~~~~~~~
(and others)
[ 09:55 rakuco ] Original commit 
openscad 2015.03_15 cad files touched by this commit Programmer's solid 3D CAD modeller
py-qt5-serialport 5.9.2_3 comms files touched by this commit Python bindings for the Qt5 toolkit, QtSerialPort module
py-qt4-sql 4.12.1_1,1 databases  Deleted Deprecated Expired files touched by this commit Python bindings for the Qt4 toolkit, QtSql module
py-qt5-sql 5.9.2_3 databases files touched by this commit Python bindings for the Qt5 toolkit, QtSql module
sqliteman 1.2.2_8 databases  Deleted Deprecated Expired files touched by this commit Admin's GUI tool for Sqlite3
tora 2.1.3_12,1 databases  Deleted Deprecated Expired files touched by this commit Toolkit for Oracle
p5-perlqt 4.14.3_2 devel  Deleted files touched by this commit Perl bindings for Qt
py-qt4-assistant 4.12.1_1,1 devel  Deleted Deprecated Expired files touched by this commit Python bindings for the Qt4 toolkit, QtAssistant module
py-qt4-core 4.12.1_4,1 devel  Deleted Deprecated Expired files touched by this commit Python bindings for the Qt4 toolkit, QtCore module
py-qt4-dbus 4.12.1_1,1 devel  Deleted Deprecated Expired files touched by this commit Python bindings for the Qt4 toolkit, QtDBus module

(Only the first 10 of 58 ports in this commit are shown above. View all ports for this commit)
Update QScintilla 2.10.2.

Upstream has renamed its libraries and we no longer need to patch
devel/qscintilla-qt5 to create a library whose name does not conflict with
devel/qscintilla's. However, the library names are different so we need to bump
PORTREVISION in several ports (the SOVERSION has changed too).

Thanks to antoine for the exp-run.

PR:		225928
[ 09:44 rakuco ] Original commit 
qca 2.1.3 devel files touched by this commit Cross-platform crypto API for Qt
Update devel/qca and devel/qca-qt5 to 2.1.3.

Thanks to antoine for the exp-run.

PR:		225929
Sat, 17 Feb 2018
[ 10:34 rakuco ] Original commit 
krename 5.0.0 sysutils files touched by this commit Powerful batch file renamer for KDE
Use a more up-to-date URL in pkg-descr
Fri, 16 Feb 2018
[ 22:50 rakuco ] Original commit 
tora 2.1.3_11,1 databases  Deleted Deprecated Expired files touched by this commit Toolkit for Oracle
Add a patch to fix the build with clang 6.

    toplsqltext.cpp:80:19: error: cannot initialize a member subobject of type
'const char *' with an rvalue of type 'bool'
        { NULL, NULL, false, false}
                      ^~~~~
[ 19:36 rakuco ] Original commit 
krename 5.0.0 sysutils files touched by this commit Powerful batch file renamer for KDE
krename-kde4 4.0.9_12 sysutils  Deleted files touched by this commit Powerful batch file renamer for KDE
Update KRename to 5.0.0 and adopt the port with my kde@ hat

This is the first KF5-based release, so rename the port from
sysutils/krename-kde4 to sysutils/krename.

Announcement:
https://mail.kde.org/pipermail/kde-announce-apps/2018-February/005426.html
Wed, 14 Feb 2018
[ 21:30 rakuco ] Original commit 
py-qt5-serialport 5.9.2_2 comms files touched by this commit Python bindings for the Qt5 toolkit, QtSerialPort module
py-qt5-sql 5.9.2_2 databases files touched by this commit Python bindings for the Qt5 toolkit, QtSql module
py-qt5-core 5.9.2_2 devel files touched by this commit Python bindings for the Qt5 toolkit, QtCore module
py-qt5-dbus 5.9.2_2 devel files touched by this commit Python bindings for the Qt5 toolkit, QtDBus module
py-qt5-designer 5.9.2_2 devel files touched by this commit Python bindings for the Qt5 toolkit, QtDesigner module
py-qt5-help 5.9.2_3 devel files touched by this commit Python bindings for the Qt5 toolkit, QtHelp module
py-qt5-qscintilla2 2.9.1_2 devel files touched by this commit Python bindings for QScintilla2 (PyQt5), QSci module
py-qt5-test 5.9.2_2 devel files touched by this commit Python bindings for the Qt5 toolkit, QtTest module
py-qt5-svg 5.9.2_2 graphics files touched by this commit Python bindings for the Qt5 toolkit, QtSvg module
py-qt5-qml 5.9.2_2 lang files touched by this commit Python bindings for the Qt5 toolkit, QML module

(Only the first 10 of 22 ports in this commit are shown above. View all ports for this commit)
PyQt: Unconditionally install the .pyi files

r460809 started installing .pyi with the %%PYTHON3%% substitution in the
plists. Support for .pyi files was added in Python 3.5, and PyQt's configure.py
only installs the files on Python >= 3.5.

This patch removes the version checks from configure.py (the files are just
unused in earlier Python versions), as it is easier than checking Python 3's
version in each PyQt port's Makefile (or to add the logic to Mk/Uses/pyqt.mk).

PR:		225773
Reviewed by:	tcberner
Differential Revision:	https://reviews.freebsd.org/D14361
Sun, 11 Feb 2018
[ 15:25 rakuco ] Original commit 
rsibreak 0.12.8 x11 files touched by this commit KDE RSI prevention tool
Update to 0.12.8.

Annonuncement:
https://mail.kde.org/pipermail/kde-announce-apps/2018-February/005422.html
Sat, 10 Feb 2018
[ 11:00 rakuco ] Original commit 
p7zip 16.02_1 archivers files touched by this commit File archiver with high compression ratio
p7zip-codec-rar 16.02_1 archivers files touched by this commit RAR decoder codec for p7zip
Add patch for CVE-2018-5996

Insufficient exception handling in the method NCompress::NRar3::CDecoder::Code
of 7-Zip before 18.00 and p7zip can lead to multiple memory corruptions within
the PPMd code, allows remote attackers to cause a denial of service
(segmentation fault) or execute arbitrary code via a crafted RAR archive.

Obtained from:	Debian (link in the patch file)
MFH:		2018Q1
Security:	7a2e0063-0e4e-11e8-94c0-5453ed2e2b49
[ 10:59 rakuco ] Original commit 
p7zip 16.02_1 archivers files touched by this commit File archiver with high compression ratio
Add patch from CVE-2017-17969

Heap-based buffer overflow in 7zip/Compress/ShrinkDecoder.cpp.

Obtained from:	Debian (link in the actual patch)
MFH:		2018Q1
Security:	6d337396-0e4a-11e8-94c0-5453ed2e2b49
Number of commits: 1986 (showing only 100 on this page) 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10 | 11  »  [20]
Login
User Login
Create account

Servers and bandwidth provided by
New York Internet, iXsystems, and RootBSD

This site
What is FreshPorts?
About the authors
Issues
FAQ
How big is it?
The latest upgrade!
Privacy
Forums
Blog
Contact

Search
Enter Keywords:
 
more...

Latest Vulnerabilities
py-pillowOct 15
mod_perl2Oct 09
xpdfOct 06
xpdf3Oct 06
xpdf4Oct 06
unboundOct 03
cactiOct 02
gitlab-ceOct 02
gitlab-ceOct 02
ruby24Oct 02
ruby25Oct 02
mongodb34Sep 30
mongodb34Sep 30
mongodb36Sep 30
mongodb36Sep 30

8 vulnerabilities affecting 24 ports have been reported in the past 14 days

* - modified, not new

All vulnerabilities

Last updated:
2019-10-15 15:43:31


Ports
Home
Categories
Deleted ports
Sanity Test Failures
Newsfeeds

Statistics
Graphs
NEW Graphs (Javascript)
Traffic

Calculated hourly:
Port count 37680
Broken 77
Deprecated 104
Ignore 343
Forbidden 3
Restricted 158
No CDROM 73
Vulnerable 27
Expired 6
Set to expire 75
Interactive 0
new 24 hours 2
new 48 hours9
new 7 days26
new fortnight62
new month230

Servers and bandwidth provided by
New York Internet, iXsystems, and RootBSD
Valid HTML, CSS, and RSS.
Copyright © 2000-2019 Dan Langille. All rights reserved.