FreshPorts - VuXML

This page displays vulnerability information about FreeBSD Ports.

The last vuln.xml file processed by FreshPorts is:

nothing found there

List all Vulnerabilities, by package

List all Vulnerabilities, by date

These are the vulnerabilities relating to the commit you have selected:

VuXML IDDescription
4e8344a3-ca52-11de-8ee8-00215c6a37bbgd -- '_gdGetColors' remote buffer overflow vulnerability

CVE reports:

The _gdGetColors function in gd_gd.c in PHP 5.2.11 and 5.3.0, and the GD Graphics Library 2.x, does not properly verify a certain colorsTotal structure member, which might allow remote attackers to conduct buffer overflow or buffer over-read attacks via a crafted GD file, a different vulnerability than CVE-2009-3293.


Discovery 2009-10-15
Entry 2009-11-05
Modified 2010-06-17
gd
lt 2.0.35_2,1

php5-gd
lt 5.2.11_2

php4-gd
lt 4.4.9_4

36712
CVE-2009-3546
http://secunia.com/advisories/37069
http://secunia.com/advisories/37080