notbugAs an Amazon Associate I earn from qualifying purchases.
Want a good read? Try FreeBSD Mastery: Jails (IT Mastery Book 15)
Want a good monitor light? See my photosAll times are UTC
Ukraine
This referral link gives you 10% off a Fastmail.com account and gives me a discount on my Fastmail account.
New feature planned: get notified when the package is available. Now is the time to contribute ideas/suggestions.
non port: x11/ecore/Makefile

Number of commits found: 38

Tuesday, 11 Mar 2008
21:13 stas search for other commits by this committer
- Update enlightenment-devel and EFL libraries to the latest snapshot
- Deprecate old unsupported apps and modules (entice, devian, eveil, engage)
- Split evas and ecore to separate modules to handle dependencies properly
- Disable PAM in enlightenment-devel as it don't work anyway (requires root
  privilegies)
- Add DBUS support.

Thanks to:      az
Original commit
Saturday, 19 May 2007
20:32 flz search for other commits by this committer
- Welcome X.org 7.2 \o/.
- Set X11BASE to ${LOCALBASE} for recent ${OSVERSION}.
- Bump PORTREVISION for ports intalling files in ${X11BASE}.
Original commit
Saturday, 24 Mar 2007
14:03 pav search for other commits by this committer
- bsd.efl.mk is now in ports/Mk

PR:             ports/100497
Submitted by:   stass
Original commit
Sunday, 11 Mar 2007
11:20 stas search for other commits by this committer
- Don't try to delete unexistent directories.
Original commit
08:51 stas search for other commits by this committer
- Update e17 ports to 20070223 snapshot
- Bump portrevisions on all imlib2-dependend ports as the library soversion
  was bumped [1]
- Disable fade-in effects in x11-fm/evidence permanently, since evas doesn't
  support it anymore. [2]

The patch was tested in the tinderbox.

Approved by:    portmgr (marcus) [1],
                Anders Troback <freebsd@troback.com> (maintainer) [2]
Original commit
Wednesday, 13 Dec 2006
12:41 roam search for other commits by this committer
Update the ftp/curl port to 7.16.0.
Bump PORTREVISION of all dependent ports.
Fix the build errors in the few ports that still use the long deprecated,
and now obsoleted, cURL options.

Thanks to everyone who took the time to look over the patch!

Discussed on:   -ports
Original commit
Thursday, 19 Oct 2006
13:30 stas search for other commits by this committer
- fix depends, ecore doesn't use GNOME dbus library now
- bump portrevision

Reported by:    Volodymyr Kostyrko <arcade@synergetica.dn.ua>
Approved by:    portmgr (erwin)
Original commit
Sunday, 8 Oct 2006
13:48 stas search for other commits by this committer
- Move to LOCALBASE
- Use new EFL framework
- Update all e17 ports to the lates stable cvs snapshot
- Add additional knobs/options to ports makefiles to control the
  feature set
- Add a bunch of new e17 applications/libraries
- Minor improvements/modification.

Approved by:    vanilla (old maintainer), sem (mentor)
Original commit
Thursday, 3 Aug 2006
06:59 vanilla search for other commits by this committer
Fix pkg-plist.

PR:             ports/101277
Submitted by:   erwin@
Pointyhat by:   me
Original commit
Monday, 24 Jul 2006
17:04 vanilla search for other commits by this committer
Upgrade to latest version.
Original commit
Saturday, 15 Jul 2006
01:43 vanilla search for other commits by this committer
Upgrade to latest version..

PR:             ports/100236
Submitted by:   Stanislav Sedov <ssedov at mbsd.msk.ru>
Original commit
Wednesday, 5 Jul 2006
03:12 vanilla search for other commits by this committer
Upgrade to latest version.

PR:             ports/99772
Submitted by:   Stanislav Sedov <ssedov at mbsd.msk.ru>
Original commit
Wednesday, 31 May 2006
12:21 vanilla search for other commits by this committer
Upgrade to latest version.
Original commit
Saturday, 1 Apr 2006
17:26 vanilla search for other commits by this committer
Upgrade to 0.9.9.026.
Original commit
Saturday, 18 Mar 2006
04:25 vanilla search for other commits by this committer
Upgrade to 0.9.9.025.
Original commit
Thursday, 16 Mar 2006
06:47 vanilla search for other commits by this committer
Upgrade to 0.9.9.024.
Original commit
Thursday, 23 Feb 2006
10:40 ade search for other commits by this committer
Conversion to a single libtool environment.

Approved by:    portmgr (kris)
Original commit
Monday, 13 Feb 2006
07:46 vanilla search for other commits by this committer
Add USE_GETOPT_LONG, this will fix building on 4.X.

Submitted by:   kris' notify.
Original commit
Saturday, 14 Jan 2006
18:33 vanilla search for other commits by this committer
1: upgrade to latest version.
2: remove BROKEN on x11-toolkits/ewl.
Original commit
Friday, 2 Dec 2005
07:04 vanilla search for other commits by this committer
Upgrade to latest version.
Original commit
Tuesday, 15 Nov 2005
06:52 ade search for other commits by this committer
Mass-conversion to the USE_AUTOTOOLS New World Order.  The code present
in bsd.autotools.mk essentially makes this a no-op given that all the
old variables set a USE_AUTOTOOLS_COMPAT variable, which is parsed in
exactly the same way as USE_AUTOTOOLS itself.

Moreover, USE_AUTOTOOLS has already been extensively tested by the GNOME
team -- all GNOME 2.12.x ports use it.

Preliminary documentation can be found at:
        http://people.FreeBSD.org/~ade/autotools.txt

which is in the process of being SGMLized before introduction into the
Porters Handbook.

Light blue touch-paper.  Run.
Original commit
Tuesday, 11 Oct 2005
05:40 vanilla search for other commits by this committer
Upgrade to latest version.
Original commit
Wednesday, 5 Oct 2005
08:02 vanilla search for other commits by this committer
Upgrade to latest version.
Original commit
Friday, 23 Sep 2005
23:09 vanilla search for other commits by this committer
Upgrade to latest version.
Original commit
Monday, 1 Aug 2005
16:23 vanilla search for other commits by this committer
Upgrade to lastest version.

ecore -> 0.9.9.013
edb -> 1.0.5.004
edje -> 0.5.0.013
eet -> 0.9.10.013
embryo -> 0.9.1.013
enlightenment-devel -> 0.16.999.013
entice -> 0.9.3.004
epeg -> 0.9.0.004
epsilon -> 0.3.0.004
esmart -> 0.9.0.004
etox -> 0.9.0.004
evas -> 0.9.9.013
ewl -> 0.0.4.004
imlib2 -> 1.2.1.004
imlib2_loaders -> 1.2.1.004
Original commit
Monday, 18 Jul 2005
12:35 vanilla search for other commits by this committer
Upgrade to 0.9.9.011.
Original commit
Sunday, 3 Jul 2005
00:16 vanilla search for other commits by this committer
Add USE_ICONV to Makefile, and it fix the incorrect pkg-plist problem.

Submitted by:   Tom McLaughlin <tmclaugh@sdf.lonestar_dot . org>
Noticed by:     kris@
Original commit
Saturday, 2 Jul 2005
00:58 kris search for other commits by this committer
BROKEN: Incorrect pkg-plist
Original commit
Thursday, 16 Jun 2005
09:53 vanilla search for other commits by this committer
Upgrade to 0.9.9.010.
Original commit
Wednesday, 1 Jun 2005
19:56 oliver search for other commits by this committer
change the libtool version to use from 1.3 to 1.5
Original commit
Friday, 9 Jul 2004
17:43 marcus search for other commits by this committer
Apply a big libtool patch to allow porters to use the libtool installed by
the libtoolX ports instead of the one included with each port.  Ports that
set USE_LIBTOOL_VER=X will now use the ports version of libtool instead of
the included version.  To restore previous behavior, use the new macro,
USE_INC_LIBTOOL_VER.  Both macros accept the same argument: a libtool version.

For example, to use the ports version of libtool-1.5, add the following to
your Makefile:

USE_LIBTOOL_VER=        15

To use the included version of libtool with extra hacks provided by
libtool-1.5, add the following to your Makefile:

USE_INC_LIBTOOL_VER=    15

With this change, ports that had to add additional libtool hacks to prevent
.la files from being installed or to fix certain threading issues can now
delete those hacks (after appropriate testing, of course).

PR:             63944
Based on work by:eik and marcus
Approved by:    ade (autotools maintainer)
Tested by:      kris on pointyhat
Bound to be hidden problems:    You bet
Original commit
Sunday, 14 Mar 2004
06:17 ade search for other commits by this committer
Whoa there, boy, that's a mighty big commit y'all have there...

Begin autotools sanitization sequence by requiring ports to explicitly
specify which version of {libtool,autoconf,automake} they need, erasing
the concept of a "system default".

For ports-in-waiting:

        USE_LIBTOOL=YES         ->      USE_LIBTOOL_VER=13
        USE_AUTOCONF=YES        ->      USE_AUTOCONF_VER=213
        USE_AUTOMAKE=YES        ->      USE_AUTOMAKE_VER=14

Ports attempting to use the old style system after June 1st 2004 will be
sorely disappointed.
Original commit
Thursday, 20 Feb 2003
19:17 knu search for other commits by this committer
De-pkg-comment.
Original commit
Wednesday, 26 Jun 2002
18:56 pat search for other commits by this committer
strip -> ${STRIP_CMD}

PR:             ports/39756
Submitted by:   Scott Flatman <sf@dsinw.com>
Original commit
Tuesday, 4 Jun 2002
01:38 petef search for other commits by this committer
Reset maintainership to ports@.  Thanks for your work on these, Jeremy!

PR:             38874
Submitted by:   Jeremy Norris <ishmael@mchsi.com> (previous maintainer)
Original commit
Monday, 28 Jan 2002
02:08 pat search for other commits by this committer
- Change maintainer's email address   - Update MASTER_SITES   - Bump shlib
version for x11-toolkits/gevas    
Original commit
Monday, 30 Apr 2001
16:28 kevlo search for other commits by this committer
Upgrade to version 0.02    
Original commit
Saturday, 17 Mar 2001
16:31 vanilla search for other commits by this committer
Ecore is a core event (X11) abstraction library.    
Original commit

Number of commits found: 38