FreshPorts -- The Place For Ports If you buy from Amazon USA, please support us by using this link.
Follow us
Blog
Twitter

I am looking for an LTO tape library. Do you have one to spare?
found something from the cache
non port: head/Mk/bsd.default-versions.mk
SVNWeb

Number of commits found: 23

Mon, 8 Dec 2014
[ 09:57 marino ] Original commit 
374256 Mk/bsd.default-versions.mk
374256 UPDATING
Change PostgreSQL default version from 9.2 to 9.3

An exp-run has been performed on this default version change, and both
pgsql and portmgr are aware of this change.  Note that PR originally
made the jump from 9.0 to 9.3, but a conservative change to 9.2 was
done in May instead.

PR:	187286
Wed, 26 Nov 2014
[ 13:08 mat ] Original commit 
373448 CHANGES
373448 Mk/Uses/perl5.mk
373448 Mk/bsd.default-versions.mk
373448 Mk/bsd.port.mk
373448 UPDATING
373448 archivers/dpkg/Makefile
373448 archivers/p5-Archive-Any-Lite/Makefile
373448 archivers/p5-Archive-Any-Lite/pkg-plist
373448 archivers/p5-Archive-Any-Plugin-Rar/Makefile
373448 archivers/p5-Archive-Any-Plugin-Rar/pkg-plist

(Only the first 10 of 10077 ports in this commit are shown above. View all ports for this commit)
Change the way Perl modules are installed, update the default Perl to 5.18.

Before, we had:

  site_perl :           lib/perl5/site_perl/5.18
  site_perl/perl_arch : lib/perl5/site_perl/5.18/mach
  perl_man3 :           lib/perl5/5.18/man/man3

Now we have:

  site_perl : lib/perl5/site_perl
  site_arch : lib/perl5/site_perl/mach/5.18
  perl_man3 : lib/perl5/site_perl/man/man3

Modules without any .so will be installed at the same place regardless of the
(Only the first 15 lines of the commit message are shown above View all of this commit message)
Thu, 9 Oct 2014
[ 01:08 swills ] Original commit 
370495 Mk/bsd.default-versions.mk
370495 UPDATING
Switch default Ruby to 2.0
Wed, 10 Sep 2014
[ 19:09 gerald ] Original commit 
367883 Mk/bsd.default-versions.mk
367883 lang/gcc/Makefile
367883 lang/gcc/distinfo
367883 lang/gcc/pkg-descr
367883 lang/gcc/pkg-plist
Update the default version of GCC in the Ports Collection from GCC 4.7.4
to GCC 4.8.3.

This entails updating the lang/gcc port as well as changing the default
in Mk/bsd.default-versions.mk, and it replaces the CONFLICT between the
lang/gcc and lang/gcc47 ports by lang/gcc48.

GCC now uses C++ as its implementation language and performs more
aggressive loop analysis which can be disabled via the
-fno-aggressive-loop-optimizations command-line option.

Compilation of extremely large functions has been signficantly improved,
as have interprocedural optimizations.

A new optimization level -Og has been introduced.  It addresses the need
(Only the first 15 lines of the commit message are shown above View all of this commit message)
Sun, 13 Jul 2014
[ 15:51 ohauer ] Original commit 
361689 Mk/bsd.default-versions.mk
361689 UPDATING
- set www/apache24 as the default apache version

requested by bz@ on ports@
Mon, 2 Jun 2014
[ 18:29 antoine ] Original commit 
356242 Mk/bsd.default-versions.mk
Revert r356123
This change was not exp-ran and if breaks a few ports because the python3
metaport and bsd.python.mk do not handle python34 well for now

Discussed with:	mva
With hat:	portmgr
Sun, 1 Jun 2014
[ 14:03 demon ] Original commit 
356123 Mk/bsd.default-versions.mk
Python 3.4 is a latest version of python-3 branch, so use it.
Thu, 29 May 2014
[ 20:45 mat ] Original commit 
355746 Mk/bsd.default-versions.mk
355746 UPDATING
Change postgresql's default version to 9.2.

Requested by:	so many people
Exp-run by:	antoine
Sponsored by:	Absolight
Sun, 11 May 2014
[ 20:46 bapt ] Original commit 
353730 Mk/bsd.database.mk
353730 Mk/bsd.default-versions.mk
353730 UPDATING
Switch firebird to use DEFAULT_VERSIONS macro to set the default
While here drop support for firebird 2.0
Mon, 5 May 2014
[ 09:45 bapt ] Original commit 
352986 CHANGES
352986 Mk/Uses/cmake.mk
352986 Mk/Uses/qmail.mk
352986 Mk/Uses/scons.mk
352986 Mk/bsd.apache.mk
352986 Mk/bsd.autotools.mk
352986 Mk/bsd.database.mk
352986 Mk/bsd.default-versions.mk
352986 Mk/bsd.efl.mk
352986 Mk/bsd.fpc.mk

(Only the first 10 of 293 ports in this commit are shown above. View all ports for this commit)
Convert all :U to :tu and :L to :tl

Since FreeBSD 8.4 and FreeBSD 9.1 make(1) do support :tu and :tl as a
replacement for :U and :L (which has been marked as deprecated)

bmake which is the default on FreeBSD 10+ only support by default
:tu/:tl a hack has been added at the time to support :U and :L to ease
migration. This hack is now not necessary anymore

Note that this makes the ports tree incompatible with make(1) from
FreeBSD 8.3 or earlier

With hat:	portmgr
Wed, 26 Mar 2014
[ 03:32 acm ] Original commit 
349217 Mk/bsd.default-versions.mk
349217 Mk/bsd.fpc.mk
349217 audio/fpc-mad/Makefile
349217 databases/fpc-mysql/pkg-plist
349217 devel/fpc-fcl-db/Makefile
349217 devel/fpc-fcl-db/pkg-plist
349217 devel/fpc-fcl-passrc/pkg-plist
349217 devel/fpc-fcl-web/Makefile
349217 devel/fpc-fcl-web/pkg-plist
349217 ftp/fpc-libcurl/Makefile

(Only the first 10 of 19 ports in this commit are shown above. View all ports for this commit)
- Update to 2.6.4
Mon, 10 Mar 2014
[ 20:41 gerald ] Original commit 
347808 Mk/bsd.default-versions.mk
347808 Mk/bsd.gcc.mk
347808 lang/gcc/Makefile
347808 lang/gcc/distinfo
347808 lang/gcc/files/patch-unwind-ia64.h
347808 lang/gcc/pkg-descr
347808 lang/gcc/pkg-plist
347808 lang/gcc47/Makefile
Update the default version of GCC used in the Ports Collection from
GCC 4.6.4 to GCC 4.7.3.  This entails updating the lang/gcc port as
well as changing the default in Mk/bsd.default-versions.mk.

This adds powerpc64 as a supported architecture (and removes ia64,
though it can be supported by manually installing lang/gcc48).

New binaries %%GNU_HOST%%-gcc-ar47, %%GNU_HOST%%-gcc-nm47, and
%%GNU_HOST%%-gcc-ranlib47 are provided to support link-time
optimization (LTO) which scales significantly better.

And it adds support for indirect functions (IFUNCS), experimental
support for transactional memory in the compiler as well as a supporting
run-time library called libitm, a new string length optimization pass,
and support for atomic operations specifying the C++11/C11 memory model.
(Only the first 15 lines of the commit message are shown above View all of this commit message)
Tue, 25 Feb 2014
[ 00:32 gerald ] Original commit 
345909 Mk/Uses/fortran.mk
345909 Mk/bsd.default-versions.mk
345909 Mk/bsd.gcc.mk
Reword the documentation at the top of this file.

Sort the FPC_DEFAULT and GCC_DEFAULT entries.
Mon, 24 Feb 2014
[ 22:15 gerald ] Original commit 
345903 Mk/bsd.default-versions.mk
345903 Mk/bsd.gcc.mk
Replace all uses of GCC_DEFAULT_VERSION by GCC_DEFAULT, remove the
definition of the former from Mk/bsd.gcc.mk and add the latter --
still set to 4.6 -- to Mk/bsd.default-versions.mk.

Include Mk/bsd.default-versions.mk from Mk/bsd.gcc.mk to tie the
two together.
Tue, 11 Feb 2014
[ 17:12 mat ] Original commit 
343784 Mk/bsd.apache.mk
343784 Mk/bsd.database.mk
343784 Mk/bsd.default-versions.mk
343784 Mk/bsd.fpc.mk
343784 Mk/bsd.php.mk
Use default-versions.mk for Apache, PHP, MySQL And PostgreSQL.

Submitted by:	Allan Jude
Reviewed by:	bdrewery, ohauer (apache), mat
With hat:	portmgr
Sun, 12 Jan 2014
[ 21:16 crees ] Original commit 
339550 Mk/Uses/pgsql.mk
339550 Mk/bsd.database.mk
339550 Mk/bsd.default-versions.mk
Strip postgresql code out of bsd.database.mk, and introduce USES=pgsql.

New syntax:

# Depend on postgresql-client
USES=	pgsql

# Depend on postgresql-client at least 9.2
USES=	pgsql:9.2+

#Depend on postgresql-server at least 9.0
USES=		pgsql:9.0+
WANT_PGSQL=	server

Postgresql now supports DEFAULT_VERSIONS, and please note that the
version syntax now includes dots(!); i.e. before it was 90, now 9.0

Reviewed by:	ade, silence from pgsql@
Fri, 10 Jan 2014
[ 08:25 bapt ] Original commit 
339322 Mk/Uses/lua.mk
339322 Mk/bsd.default-versions.mk
Add a USES=lua (WIP) that only supports lua 5.2
Goal is to slowly port any lua software to lua 5.2 and then remove lua 5.1 along
with bsd.lua.mk
Make version flexible and settable via DEFAULT_VERSIONS to prepare the futur
days of lua
Wed, 23 Oct 2013
[ 10:26 mat ] Original commit 
331361 Mk/bsd.default-versions.mk
331361 UPDATING
Change default perl to lang/perl5.16

PR:		ports/182550
Submitted by:	mat
Approved by:	bdrewery (exp-run)
Sat, 12 Oct 2013
[ 17:17 bdrewery ] Original commit 
330151 Mk/bsd.default-versions.mk
- Fix spelling in comment

Submitted by:	des
With hat:	portmgr
Thu, 3 Oct 2013
[ 09:25 mva ] Original commit 
329164 Mk/bsd.default-versions.mk
329164 Mk/bsd.python.mk
329164 UPDATING
The default versions of lang/python* have been changed to support the
new DEFAULT_VERSIONS variable.

PYTHON_DEFAULT_VERSION, PYTHON2_DEFAULT_VERSION and
PYTHON3_DEFAULT_VERSION are deprecated. If you have set them in your
make.conf, you should change them something like

DEFAULT_VERSIONS=python=2.7 python2=2.7 python3=3.3
Fri, 20 Sep 2013
[ 13:13 sunpoet ] Original commit 
327700 Mk/bsd.default-versions.mk
- Fix typo
Thu, 19 Sep 2013
[ 09:49 gahr ] Original commit 
327607 Mk/Uses/tcl.mk
327607 Mk/Uses/tk.mk
327607 Mk/bsd.default-versions.mk
327607 Mk/bsd.sanity.mk
327607 Mk/bsd.wx.mk
- Implement USES+=tcl and USES+=tk
- Use bsd.default-versions.mk to specify the default Tcl/Tk version (8.6)
- Add warnings about the now deprecated use of USE_TCL, USE_TK, ...

  Notes:

  * USES+=tcl and USES+=tk take the following optional arguments

    - either a version in the form of XY or XY+, or 'wrapper' to depend on
      lang/tcl-wrapper or x11-toolkits/tk-wrapper

    - either 'build' (bring in build depend) or 'run' (bring in run depend)

  * it is an error to specify both 'tcl' and 'tk' in USES.

  * The functionality currently implemented via INVALID_TCL_VER and
    INVALID_TK_VER is not yet available.

Approved by:	bapt (portmgr)
[ 08:16 bapt ] Original commit 
327602 Mk/Uses/perl5.mk
327602 Mk/bsd.default-versions.mk
327602 Mk/bsd.ruby.mk
Introduce the one-true-way to handle multi version ports

This defines a new macros for end users!
DEFAULT_VERSIONS.
This macros is used to end-users to define what version they want to be
the default version for the whole ports tree (for ports allowing that)

Syntax is the following:
DEFAULT_VERSIONS=	perl5=5.18 ruby=2.0

Swith bsd.ruby.mk to use it[1], switch Uses/perl5.mk to use it[2]

If you are maintaining settable multi version port, please change it so
it uses DEFAULT_VERSIONS.

Reviewed by:	ruby (swills) [1], perl (az) [2]
Approved by:	ruby (swills) [1], perl (az) [2]

Number of commits found: 23

Login
User Login
Create account

Servers and bandwidth provided by
New York Internet, SuperNews, and RootBSD

This site
What is FreshPorts?
About the authors
FAQ
How big is it?
The latest upgrade!
Privacy
Forums
Blog
Contact

Search
Enter Keywords:
 
more...

Latest Vulnerabilities
py-django*Jan 24
py-django-devel*Jan 24
libresslJan 22
linux-c6-openssl*Jan 22
mingw32-openssl*Jan 22
openssl*Jan 22
chromiumJan 21
polarsslJan 19
polarssl13Jan 19
samba4Jan 16
samba41Jan 16
unzipJan 16
firefoxJan 14
firefox-esrJan 14
kde4-runtimeJan 14

10 vulnerabilities affecting 35 ports have been reported in the past 14 days

* - modified, not new

All vulnerabilities


Ports
Home
Categories
Deleted ports
Sanity Test Failures
Newsfeeds

Statistics
Graphs
NEW Graphs (Javascript)
Traffic

Calculated hourly:
Port count 24493
Broken 100
Deprecated 39
Ignore 346
Forbidden 1
Restricted 207
No CDROM 93
Vulnerable 17
Expired 0
Set to expire 34
Interactive 0
new 24 hours 4
new 48 hours5
new 7 days22
new fortnight49
new month118

Servers and bandwidth provided by
New York Internet, SuperNews, and RootBSD
Valid HTML, CSS, and RSS.
Copyright © 2000-2014 Dan Langille. All rights reserved.