FreshPorts -- The Place For Ports If you buy from Amazon USA, please support us by using this link.
Follow us
Blog
Twitter

I am looking for an LTO tape library. Do you have one to spare?
Port details
emacs19 19.34b_2 editors Deleted on this many watch lists=1 search for ports that depend on this port This port version is marked as vulnerable.
Deprecated DEPRECATED: emacs19 is obsolete; please use a more recent version
Expired This port expired on: 2007-08-19
GNU editing macros

There is no maintainer for this port.
Any concerns regarding this port should be directed to the FreeBSD Ports mailing list via ports@FreeBSD.org search for ports maintained by this maintainer
Port Added: 19 Apr 2004 12:52:12
License: not specified in port


GNU Emacs is a self-documenting, customizable, extensible real-time
display editor.

Users new to Emacs will be able to use basic features fairly rapidly
by studying the tutorial and using the self-documentation features.
Emacs also has an extensive interactive manual browser.  It is easily
extensible since its editing commands are written in Lisp.

GNU Emacs's many special packages handle mail reading (RMail) and
sending (Mail), outline editing (Outline), compiling (Compile),
running subshells within Emacs windows (Shell), running a Lisp
read-eval-print loop (Lisp-Interaction-Mode), automated psychotherapy
(Doctor :-) and many more.

WWW: http://www.gnu.org/software/emacs/
SVNWeb : Main Web Site : Distfiles Availability : PortsMon

NOTE: FreshPorts displays only required dependencies information. Optional dependencies are not covered.

Required To Build:
  1. x11/xbitmaps
  2. devel/gmake
  3. devel/pkg-config
  4. x11/xorg-libraries
Required To Run:
  1. x11/xbitmaps
  2. devel/pkg-config
  3. x11/xorg-libraries
There are no ports dependent upon this port

No installation instructions: this port has been deleted.

The package name of this deleted port was: emacs


Configuration Options
     No options to configure

Master Sites:
  1. ftp://ftp.FreeBSD.org/pub/FreeBSD/ports/distfiles/
  2. ftp://ftp.chg.ru/pub/gnu/emacs/
  3. ftp://ftp.dti.ad.jp/pub/GNU/emacs/
  4. ftp://ftp.gnu.org/gnu/emacs/
  5. ftp://ftp.informatik.hu-berlin.de/pub/gnu/emacs/
  6. ftp://ftp.informatik.rwth-aachen.de/pub/mirror/ftp.gnu.org/pub/gnu/emacs/
  7. ftp://ftp.kddlabs.co.jp/GNU/emacs/
  8. ftp://ftp.mirrorservice.org/sites/ftp.gnu.org/gnu/emacs/
  9. ftp://ftp.rediris.es/sites/ftp.gnu.org/ftp/gnu/emacs/
  10. ftp://ftp.sunsite.org.uk/package/gnu/emacs/
  11. http://ftp.funet.fi/pub/gnu/prep/emacs/
  12. http://ftp.gnu.org/gnu/emacs/
  13. http://mirrors.usc.edu/pub/gnu/emacs/
  14. http://ring.riken.jp/archives/GNU/emacs/
  15. http://ring.sakura.ad.jp/archives/GNU/emacs/
  16. http://www.gtlib.cc.gatech.edu/pub/gnu/gnu/emacs/

Number of commits found: 14

Commit History - (may be incomplete: see SVNWeb link above for full details)
DateByDescription
14 Oct 2007 10:10:01
Original commit files touched by this commit  19.34b_2
 This port version is marked as vulnerable.
vd search for other commits by this committer
Remove expired Emacs ports and the surrounding expired ports:
2007-08-19 chinese/mule-freewnn: emacs19 and related ports are obsolete; please
use a more recent version
2007-08-19 chinese/xemacs: emacs20 and related ports are obsolete; please use a
more recent version
2007-08-19 converters/mule-ucs-emacs20: emacs20 and related ports are obsolete;
please use a more recent version
2007-08-19 devel/eieio-emacs20: emacs20 and related ports are obsolete; please
use a more recent version
2007-08-19 editors/apel-emacs20: emacs20 and related ports are obsolete; please
use a more recent version
2007-08-19 editors/bitmap-emacs20: emacs20 and related ports are obsolete;
please use a more recent version
2007-08-19 editors/emacs19: emacs19 is obsolete; please use a more recent
version
2007-08-19 editors/emacs20: "editors/emacs is recommended instead for new
installations"
2007-08-19 editors/flim-emacs20: emacs20 and related ports are obsolete; please
use a more recent version
2007-08-19 editors/mule-common: emacs19 and related ports are obsolete; please
use a more recent version
2007-08-19 editors/mule: emacs19 and related ports are obsolete; please use a
more recent version
2007-08-19 editors/semi-emacs20: emacs20 and related ports are obsolete; please
use a more recent version
2007-08-19 editors/speedbar-emacs20: emacs20 and related ports are obsolete;
please use a more recent version
2007-08-19 irc/irchat-pj-emacs20: emacs20 and related ports are obsolete; please
use a more recent version
(Only the first 15 lines of the commit message are shown above View all of this commit message)
19 Jul 2007 09:29:10
Original commit files touched by this commit  19.34b_2
 This port version is marked as vulnerable.
linimon search for other commits by this committer
Start the deorbit burn of emacs19 and dependent files.  They are antiquated.

Discussed with: various emacs maintainers
Hat:            portmgr
19 May 2007 20:32:57
Original commit files touched by this commit  19.34b_2
 This port version is marked as vulnerable.
flz search for other commits by this committer
- Welcome X.org 7.2 \o/.
- Set X11BASE to ${LOCALBASE} for recent ${OSVERSION}.
- Bump PORTREVISION for ports intalling files in ${X11BASE}.
03 May 2007 17:15:47
Original commit files touched by this commit  19.34b_1
 This port version is marked as vulnerable.
nobutaka search for other commits by this committer
Add emacs-22.* to CONFLICTS.

PR:             ports/111814
Submitted by:   NIIMI Satoshi <sa2c@sa2c.net>
22 Jan 2006 01:50:18
Original commit files touched by this commit  19.34b_1
 This port version is marked as vulnerable.
edwin search for other commits by this committer
Replace ugly "@unexec rmdir %D... 2>/dev/null || true" with @dirrmtry

Approved by:    krion@
PR:             ports/88711 (related)
16 Dec 2005 08:09:19
Original commit files touched by this commit  19.34b_1
 This port version is marked as vulnerable.
anray search for other commits by this committer
editors/emacs20 was changed not to conflict with other emacsen.

PR:             ports/90476
Submitted by:   NIIMI Satoshi <sa2c@sa2c.net>
Approved by:    sem(mentor)
04 Dec 2005 21:30:00
Original commit files touched by this commit  19.34b_1
 This port version is marked as vulnerable.
edwin search for other commits by this committer
Unbreak on 6.x by carefully specifying .info files.
24 Nov 2005 02:03:34
Original commit files touched by this commit  19.34b_1
 This port version is marked as vulnerable.
pav search for other commits by this committer
- Add SHA256
29 Jul 2005 11:50:27
Original commit files touched by this commit  19.34b_1
 This port version is marked as vulnerable.
jylefort search for other commits by this committer
Broken on >= 6.0: invalid packing list.

Reported by:    pointyhat via krion
06 May 2005 09:00:43
Original commit files touched by this commit  19.34b_1
 This port version is marked as vulnerable.
jylefort search for other commits by this committer
Add CONFLICTS variable, since this port conflicts with other
emacs/xemacs ports.
12 Apr 2005 03:26:57
Original commit files touched by this commit  19.34b_1
 This port version is marked as vulnerable.
obrien search for other commits by this committer
At Kris's request, back out the MACHINE_ARCH spelling correction until
after 5.4-RELEASE.
11 Apr 2005 08:04:41
Original commit files touched by this commit  19.34b_1
 This port version is marked as vulnerable.
obrien search for other commits by this committer
Assist getting more ports working on AMD64 by obeying the
Ports Collection documentation and use 'ARCH' rather than 'MACHINE_ARCH'.
20 Nov 2004 06:38:10
Original commit files touched by this commit  19.34b_1
 This port version is marked as vulnerable.
linimon search for other commits by this committer
Since neither of these ports works correctly on all architectures, point
prospective users to editors/emacs instead, via the DEPRECATED directive.
However, no expiration date is set at this time.
19 Apr 2004 12:50:31
Original commit files touched by this commit  19.34b_1
 This port version is marked as vulnerable.
kris search for other commits by this committer
Set ONLY_FOR_ARCHS=i386; this either does not compile, or does not run on
non-i386 architectures.  Use a newer version instead.

Number of commits found: 14

Login
User Login
Create account

Servers and bandwidth provided by
New York Internet, SuperNews, and RootBSD

This site
What is FreshPorts?
About the authors
FAQ
How big is it?
The latest upgrade!
Privacy
Forums
Blog
Contact

Search
Enter Keywords:
 
more...

Latest Vulnerabilities
bugzilla40*Apr 18
bugzilla40*Apr 18
bugzilla42*Apr 18
bugzilla42*Apr 18
bugzilla44*Apr 18
bugzilla44*Apr 18
curlApr 11
dbus-glibApr 11
libaudiofileApr 11
linux-f10-curlApr 11
linux-f10-dbus-glibApr 11
linux-f10-libaudiofileApr 11
linux-f10-nas-libsApr 11
linux-f10-openldapApr 11
mingw32-openssl*Apr 11

13 vulnerabilities affecting 18 ports have been reported in the past 14 days

* - modified, not new

All vulnerabilities


Ports
Home
Categories
Deleted ports
Sanity Test Failures
Newsfeeds


Statistics
Graphs
NEW Graphs (Javascript)
Traffic

Calculated hourly:
Port count 24362
Broken 174
Deprecated 85
Ignore 526
Forbidden 4
Restricted 263
No CDROM 108
Vulnerable 30
Expired 8
Set to expire 70
Interactive 22
new 24 hours 3
new 48 hours6
new 7 days17
new fortnight37
new month148

Servers and bandwidth provided by
New York Internet, SuperNews, and RootBSD
Valid HTML, CSS, and RSS.
Copyright © 2000-2014 Dan Langille. All rights reserved.