FreshPorts -- The Place For Ports If you buy from Amazon USA, please support us by using this link.
Follow us
Blog
Twitter

Port details
gitlab Web GUI for managing git repositories
9.3.11 www on this many watch lists=7 search for ports that depend on this port An older version of this port was marked as vulnerable. Find issues related to this port Report an issue related to this port
Maintainer: tz@FreeBSD.org search for ports maintained by this maintainer
Port Added: 31 Mar 2016 19:10:20
Also Listed In: devel
License: MIT
GitLab is version control for your server.

WWW: https://gitlab.com/
SVNWeb : Homepage : PortsMon : pkg-plist

To install the port: cd /usr/ports/www/gitlab/ && make install clean
To add the package: pkg install gitlab

PKGNAME: gitlab

distinfo:

TIMESTAMP = 1505384599
SHA256 (gitlabhq-gitlabhq-v9.3.11_GH0.tar.gz) = 3a3f0ec77f209e8f3296d55e960388b08cb69c762668c40aea92f6f6511e0677
SIZE (gitlabhq-gitlabhq-v9.3.11_GH0.tar.gz) = 31763943


NOTE: FreshPorts displays only information on required and default dependencies. Optional dependencies are not covered.

Build dependencies:
  1. gem : devel/ruby-gems
  2. ruby23 : lang/ruby23
Runtime dependencies:
  1. git>=2.14.1 : devel/git
  2. gitlab-shell>=5.0.4 : devel/gitlab-shell
  3. gitlab-workhorse>=2.0.0 : www/gitlab-workhorse
  4. redis>=2.8.23 : databases/redis
  5. npm>=4.3.0 : www/npm
  6. yarn>=0.17.0 : www/yarn
  7. rubygem-rails4>=4.2.8 : www/rubygem-rails4
  8. rubygem-rails-deprecated_sanitizer>=1.0.3 : devel/rubygem-rails-deprecated_sanitizer
  9. rubygem-responders>=2.0 : www/rubygem-responders
  10. rubygem-sprockets3>=3.7 : devel/rubygem-sprockets3
  11. rubygem-default_value_for>=3.0.1 : devel/rubygem-default_value_for
  12. rubygem-rugged>=0.25.1.1 : devel/rubygem-rugged
  13. rubygem-faraday>=0.11.0 : www/rubygem-faraday
  14. rubygem-devise>=4.2 : devel/rubygem-devise
  15. rubygem-doorkeeper>=4.2 : security/rubygem-doorkeeper
  16. rubygem-doorkeeper-openid_connect>=1.1.0 : security/rubygem-doorkeeper-openid_connect
  17. rubygem-omniauth>=1.4.2 : security/rubygem-omniauth
  18. rubygem-omniauth-auth0>=1.4.1 : net/rubygem-omniauth-auth0
  19. rubygem-omniauth-azure-oauth2>=0.0.6 : net/rubygem-omniauth-azure-oauth2
  20. rubygem-omniauth-cas3>=1.1.4 : security/rubygem-omniauth-cas3
  21. rubygem-omniauth-facebook>=4.0.0 : net/rubygem-omniauth-facebook
  22. rubygem-omniauth-github11>=1.1.1 : net/rubygem-omniauth-github11
  23. rubygem-omniauth-gitlab>=1.0.2 : security/rubygem-omniauth-gitlab
  24. rubygem-omniauth-google-oauth2>=0.4.1 : net/rubygem-omniauth-google-oauth2
  25. rubygem-omniauth-oauth2-generic>=0.2.2 : security/rubygem-omniauth-oauth2-generic
  26. rubygem-omniauth-saml>=1.7.0 : security/rubygem-omniauth-saml
  27. rubygem-omniauth-shibboleth>=1.2.0 : security/rubygem-omniauth-shibboleth
  28. rubygem-omniauth-twitter>=1.2.0 : net/rubygem-omniauth-twitter
  29. rubygem-omniauth_crowd>=2.2.0 : devel/rubygem-omniauth_crowd
  30. rubygem-omniauth-authentiq>=0.3.0 : net/rubygem-omniauth-authentiq
  31. rubygem-rack-oauth2>=1.2.1 : security/rubygem-rack-oauth2
  32. rubygem-jwt>=1.5.6 : www/rubygem-jwt
  33. rubygem-recaptcha>=3.0 : devel/rubygem-recaptcha
  34. rubygem-akismet>=2.0 : devel/rubygem-akismet
  35. rubygem-devise-two-factor>=3.0.0 : security/rubygem-devise-two-factor
  36. rubygem-rqrcode-rails3>=0.1.7 : www/rubygem-rqrcode-rails3
  37. rubygem-attr_encrypted>=3.0.0 : security/rubygem-attr_encrypted
  38. rubygem-u2f0>=0.2.1 : net/rubygem-u2f0
  39. rubygem-validates_hostname>=1.0.6 : dns/rubygem-validates_hostname
  40. rubygem-browser>=2.2 : www/rubygem-browser
  41. rubygem-gitlab_omniauth-ldap1>=1.2.1 : net/rubygem-gitlab_omniauth-ldap1
  42. rubygem-gollum-lib-gitlab>=4.2.0 : www/rubygem-gollum-lib-gitlab
  43. rubygem-gollum-rugged_adapter>=0.4.4 : www/rubygem-gollum-rugged_adapter
  44. rubygem-github-linguist>=4.7.0 : textproc/rubygem-github-linguist
  45. rubygem-grape0>=0.19.0 : devel/rubygem-grape0
  46. rubygem-grape-entity>=0.6.0 : devel/rubygem-grape-entity
  47. rubygem-hashie-forbidden_attributes>=0 : devel/rubygem-hashie-forbidden_attributes
  48. rubygem-rack-cors0>=0.4.0 : www/rubygem-rack-cors0
  49. rubygem-kaminari-rails4>=0.17.0 : www/rubygem-kaminari-rails4
  50. rubygem-hamlit>=2.6.1 : www/rubygem-hamlit
  51. rubygem-carrierwave>=1.0 : www/rubygem-carrierwave
  52. rubygem-dropzonejs-rails>=0.7.1 : www/rubygem-dropzonejs-rails
  53. rubygem-fog-aws0>=0.9 : net/rubygem-fog-aws0
  54. rubygem-fog-core>=1.44 : devel/rubygem-fog-core
  55. rubygem-fog-google>=0.3 : net/rubygem-fog-google
  56. rubygem-fog-local>=0.3 : net/rubygem-fog-local
  57. rubygem-fog-openstack>=0.1 : net/rubygem-fog-openstack
  58. rubygem-fog-rackspace>=0.1.1 : net/rubygem-fog-rackspace
  59. rubygem-fog-aliyun>=0.1.0 : net/rubygem-fog-aliyun
  60. rubygem-google-api-client010>=0.8.6 : devel/rubygem-google-api-client010
  61. rubygem-unf>=0.1.4 : textproc/rubygem-unf
  62. rubygem-seed-fu>=2.3.5 : databases/rubygem-seed-fu
  63. rubygem-html-pipeline1>=1.11.0 : textproc/rubygem-html-pipeline1
  64. rubygem-deckar01-task_list>=2.0.0 : www/rubygem-deckar01-task_list
  65. rubygem-gitlab-markup>=1.5.1 : textproc/rubygem-gitlab-markup
  66. rubygem-redcarpet>=3.4 : textproc/rubygem-redcarpet
  67. rubygem-redcloth>=4.3.2 : www/rubygem-redcloth
  68. rubygem-rdoc>=4.2 : devel/rubygem-rdoc
  69. rubygem-org-ruby>=0.9.12 : textproc/rubygem-org-ruby
  70. rubygem-creole>=0.5.0 : textproc/rubygem-creole
  71. rubygem-wikicloth>=0.8.1 : textproc/rubygem-wikicloth
  72. rubygem-asciidoctor>=1.5.2 : textproc/rubygem-asciidoctor
  73. rubygem-asciidoctor-plantuml>=0.0.7 : textproc/rubygem-asciidoctor-plantuml
  74. rubygem-rouge>=2.0 : textproc/rubygem-rouge
  75. rubygem-truncato>=0.7.9 : textproc/rubygem-truncato
  76. rubygem-nokogiri>=1.8.0 : textproc/rubygem-nokogiri
  77. rubygem-diffy>=3.1.0 : textproc/rubygem-diffy
  78. rubygem-unicorn>=5.1.0 : www/rubygem-unicorn
  79. rubygem-unicorn-worker-killer>=0.4.4 : www/rubygem-unicorn-worker-killer
  80. rubygem-state_machines-activerecord>=0.4.0 : databases/rubygem-state_machines-activerecord
  81. rubygem-after_commit_queue>=1.3.0 : databases/rubygem-after_commit_queue
  82. rubygem-acts-as-taggable-on>=4.0.0 : www/rubygem-acts-as-taggable-on
  83. rubygem-sidekiq>=5.0.0 : devel/rubygem-sidekiq
  84. rubygem-sidekiq-cron>=0.6.0 : devel/rubygem-sidekiq-cron
  85. rubygem-redis-namespace>=1.5.2 : databases/rubygem-redis-namespace
  86. rubygem-sidekiq-limit_fetch>=3.4 : devel/rubygem-sidekiq-limit_fetch
  87. rubygem-rufus-scheduler>=3.4.0 : devel/rubygem-rufus-scheduler
  88. rubygem-httparty>=0.13.3 : www/rubygem-httparty
  89. rubygem-rainbow>=2.1.0 : devel/rubygem-rainbow
  90. rubygem-settingslogic>=2.0.9 : devel/rubygem-settingslogic
  91. rubygem-re2>=1.0 : devel/rubygem-re2
  92. rubygem-version_sorter>=2.1.0 : textproc/rubygem-version_sorter
  93. rubygem-redis-rails>=5.0.1 : www/rubygem-redis-rails
  94. rubygem-redis>=3.2 : databases/rubygem-redis
  95. rubygem-connection_pool>=2.0 : net/rubygem-connection_pool
  96. rubygem-hipchat>=1.5.0 : net-im/rubygem-hipchat
  97. rubygem-jira-ruby>=1.1.2 : devel/rubygem-jira-ruby
  98. rubygem-gitlab-flowdock-git-hook>=1.0.1 : www/rubygem-gitlab-flowdock-git-hook
  99. rubygem-gemnasium-gitlab-service>=0.2 : devel/rubygem-gemnasium-gitlab-service
  100. rubygem-slack-notifier1>=1.5.1 : devel/rubygem-slack-notifier1
  101. rubygem-asana>=0.6.0 : www/rubygem-asana
  102. rubygem-ruby-fogbugz>=0.2.1 : devel/rubygem-ruby-fogbugz
  103. rubygem-kubeclient>=2.2.0 : www/rubygem-kubeclient
  104. rubygem-d3_rails-rails4>=3.5.0 : www/rubygem-d3_rails-rails4
  105. rubygem-underscore-rails>=1.8.0 : www/rubygem-underscore-rails
  106. rubygem-sanitize>=2.0 : textproc/rubygem-sanitize
  107. rubygem-babosa>=1.0.2 : textproc/rubygem-babosa
  108. rubygem-loofah>=2.0.3 : textproc/rubygem-loofah
  109. rubygem-licensee>=8.7 : devel/rubygem-licensee
  110. rubygem-rack-attack>=4.4.1 : www/rubygem-rack-attack
  111. rubygem-ace-rails-ap>=4.1.0 : www/rubygem-ace-rails-ap
  112. rubygem-mousetrap-rails>=1.4.6 : www/rubygem-mousetrap-rails
  113. rubygem-charlock_holmes>=0.7.3 : textproc/rubygem-charlock_holmes
  114. rubygem-oj2>=2.17.4 : devel/rubygem-oj2
  115. rubygem-chronic>=0.10.2 : devel/rubygem-chronic
  116. rubygem-chronic_duration>=0.10.6 : devel/rubygem-chronic_duration
  117. rubygem-webpack-rails>=0.9.10 : www/rubygem-webpack-rails
  118. rubygem-rack-proxy>=0.6.0 : www/rubygem-rack-proxy
  119. rubygem-sass-rails5>=5.0.6 : textproc/rubygem-sass-rails5
  120. rubygem-coffee-rails4>=4.1.0 : devel/rubygem-coffee-rails4
  121. rubygem-uglifier>=2.7.2 : www/rubygem-uglifier
  122. rubygem-addressable>=2.3.8 : www/rubygem-addressable
  123. rubygem-bootstrap-sass>=3.3.0 : www/rubygem-bootstrap-sass
  124. rubygem-font-awesome-rails-rails4>=4.7 : devel/rubygem-font-awesome-rails-rails4
  125. rubygem-gemojione>=3.3 : graphics/rubygem-gemojione
  126. rubygem-gon>=6.1.0 : www/rubygem-gon
  127. rubygem-jquery-atwho-rails>=1.3.2 : www/rubygem-jquery-atwho-rails
  128. rubygem-jquery-rails>=4.1.0 : www/rubygem-jquery-rails
  129. rubygem-request_store>=1.3 : devel/rubygem-request_store
  130. rubygem-select2-rails3>=3.5.9 : www/rubygem-select2-rails3
  131. rubygem-virtus>=1.0.1 : devel/rubygem-virtus
  132. rubygem-net-ssh>=3.0.1 : security/rubygem-net-ssh
  133. rubygem-base32>=0.3.2 : converters/rubygem-base32
  134. rubygem-sentry-raven>=2.4.0 : devel/rubygem-sentry-raven
  135. rubygem-premailer-rails>=1.9.7 : mail/rubygem-premailer-rails
  136. rubygem-ruby_parser>=3.8.4 : devel/rubygem-ruby_parser
  137. rubygem-gettext_i18n_rails>=1.8.0 : devel/rubygem-gettext_i18n_rails
  138. rubygem-gettext_i18n_rails_js>=1.2.0 : devel/rubygem-gettext_i18n_rails_js
  139. rubygem-gettext>=3.2.2 : devel/rubygem-gettext
  140. rubygem-peek>=1.0.1 : devel/rubygem-peek
  141. rubygem-peek-gc>=0.0.2 : devel/rubygem-peek-gc
  142. rubygem-peek-host>=1.0.0 : devel/rubygem-peek-host
  143. rubygem-peek-performance_bar>=1.2.1 : devel/rubygem-peek-performance_bar
  144. rubygem-peek-rblineprof>=0.2.0 : devel/rubygem-peek-rblineprof
  145. rubygem-peek-redis>=1.2.0 : devel/rubygem-peek-redis
  146. rubygem-peek-sidekiq>=1.0.3 : devel/rubygem-peek-sidekiq
  147. rubygem-prometheus-client-mmap>=0.7.0.beta5 : devel/rubygem-prometheus-client-mmap
  148. rubygem-octokit>=4.6.2 : net/rubygem-octokit
  149. rubygem-mail_room>=0.9.1 : mail/rubygem-mail_room
  150. rubygem-email_reply_trimmer>=0.1 : mail/rubygem-email_reply_trimmer
  151. rubygem-html2text>=0 : textproc/rubygem-html2text
  152. rubygem-ruby-prof>=0.16.2 : devel/rubygem-ruby-prof
  153. rubygem-oauth2>=1.3.0 : net/rubygem-oauth2
  154. rubygem-paranoia>=2.2 : databases/rubygem-paranoia
  155. rubygem-health_check>=2.6.0 : devel/rubygem-health_check
  156. rubygem-vmstat>=2.3.0 : sysutils/rubygem-vmstat
  157. rubygem-sys-filesystem>=1.1.6 : sysutils/rubygem-sys-filesystem
  158. rubygem-gitaly>=0.8.0 : net/rubygem-gitaly
  159. rubygem-toml-rb>=0.3.15 : www/rubygem-toml-rb
  160. rubygem-flipper>=0.10.2 : devel/rubygem-flipper
  161. rubygem-flipper-active_record>=0.10.2 : databases/rubygem-flipper-active_record
  162. rubygem-rinku>=1.7.3 : www/rubygem-rinku
  163. rubygem-pg>=0.18.2 : databases/rubygem-pg
  164. rubygem-peek-pg>=1.3.0 : databases/rubygem-peek-pg
  165. ruby23 : lang/ruby23
Patch dependencies:
  1. ruby23 : lang/ruby23
Extract dependencies:
  1. ruby23 : lang/ruby23
There are no ports dependent upon this port

Configuration Options
===> The following configuration options are available for gitlab-9.3.11:
====> Options available for the single DATABASE: you have to select exactly one of them
     PGSQL=on: Default PostgreSQL support (preferred)
     MYSQL=off: Optional MySQL support
===> Use 'make config' to modify these settings

pkg-message:
Gitlab was installed successfully.

You now need to set up the various components of Gitlab, so please
follow the instructions in the guide at:

http://gitlab.toco-domains.de/FreeBSD/GitLab-docu/blob/master/install/9.3-freebsd.md

If you just installed an minor upgrade of GitLab please follow
the instructions in the guide at:

http://gitlab.toco-domains.de/FreeBSD/GitLab-docu/blob/master/update/freebsd_patch_versions.md

If you just installed an major upgrade of GitLab, for example you
switched from 9.2.x to 9.3.x, please follow the instructions in the guide at:

http://gitlab.toco-domains.de/FreeBSD/GitLab-docu/blob/master/update/9.2-to-9.3-freebsd.md

Master Sites:
  1. https://codeload.github.com/gitlabhq/gitlabhq/tar.gz/v9.3.11?dummy=/

Number of commits found: 84

Commit History - (may be incomplete: see SVNWeb link above for full details)
DateByDescription
19 Sep 2017 14:27:21
Original commit files touched by this commit  9.3.11
Revision:450129
tz search for other commits by this committer
www/gitlab: Make Gemfile-handling through options easier

Currently MySQL und PostgreSQL entries were removed from Gemfile
via patch and added back through options.

Now we just remove the entries of the option set to off.

This remove some work and pitfalls from the Gemfile-patch.

Thanks to sunpoet for this suggestion.

Reported by: sunpoet
14 Sep 2017 10:35:30
Original commit files touched by this commit  9.3.11
Revision:449828
tz search for other commits by this committer
www/gitlab: Update from 9.3.10 to 9.3.11

Changelog: https://github.com/gitlabhq/gitlabhq/blob/v9.3.11/CHANGELOG.md

This fixes an XSS security issue. The mentioned security issues in
the gems are already fixed by updates of them gems itself.

Security: CVE-2017-5029
Security: CVE-2016-4738
Security:
https://vuxml.FreeBSD.org/freebsd/6a177c87-9933-11e7-93f7-d43d7e971a1b.html
13 Sep 2017 14:15:08
Original commit files touched by this commit  9.3.10
Revision:449793 This port version is marked as vulnerable.
tz search for other commits by this committer
www/gitlab: Update from 9.2.10 to 9.3.10

Changelog: https://github.com/gitlabhq/gitlabhq/blob/v9.3.10/CHANGELOG.md

We now add full support for gitaly and add the basics for later support
of gitlab-pages.

Reviewed by: Matthias Fechner <idefix@fechner.net>
14 Aug 2017 15:53:22
Original commit files touched by this commit  9.2.10_1
Revision:447947 This port version is marked as vulnerable.
tz search for other commits by this committer
www/gitlab: fix pkg-plist

A %%RUBY_SUFFIX%% got into the plist and makes it invalid

PR:           221523
Submitted by: max@mober.at
MFH:          2017Q3
11 Aug 2017 07:57:01
Original commit files touched by this commit  9.2.10
Revision:447736 This port version is marked as vulnerable.
tz search for other commits by this committer
www/gitlab: Update from 9.2.9 to 9.2.10

This update fixes 2 important security issues

Changelog: https://github.com/gitlabhq/gitlabhq/blob/v9.2.10/CHANGELOG.md

MFH:      2017Q3
Security: CVE-2017-12426
09 Aug 2017 09:35:42
Original commit files touched by this commit  9.2.9_1
Revision:447616 This port version is marked as vulnerable.
tz search for other commits by this committer
www/gitlab: Fix wrong RUN_DEPENDS

Switch from security/rubygem-hashie-forbidden_attributes to
devel/rubygem-hashie-forbidden_attributes.

Pointy hat to myself. I did not notice the overlapping effort
of sunpoet creating the same port and mat removing the
duplicate.
09 Aug 2017 09:15:14
Original commit files touched by this commit  9.2.9
Revision:447612 This port version is marked as vulnerable.
tz search for other commits by this committer
www/gitlab: Update from 9.1.9 to 9.2.9

Changelog: https://github.com/gitlabhq/gitlabhq/blob/v9.2.9/CHANGELOG.md

Submitted by: Matthias Fechner <idefix@fechner.net>, tz
21 Jul 2017 13:23:45
Original commit files touched by this commit  9.1.9
Revision:446314 This port version is marked as vulnerable.
tz search for other commits by this committer
www/gitlab: Update from 9.1.8 to 9.1.9

Changelog: https://github.com/gitlabhq/gitlabhq/blob/v9.1.9/CHANGELOG.md

MFH: 2017Q3
20 Jul 2017 10:42:36
Original commit files touched by this commit  9.1.8
Revision:446257 This port version is marked as vulnerable.
tz search for other commits by this committer
www/gitlab: Update from 9.1.7 to 9.1.8

Changelog: https://github.com/gitlabhq/gitlabhq/blob/v9.1.8/CHANGELOG.md

Security:
https://vuxml.FreeBSD.org/freebsd/92f4191a-6d25-11e7-93f7-d43d7e971a1b.html
Security: CVE-2017-11438
18 Jul 2017 07:57:46
Original commit files touched by this commit  9.1.7_3
Revision:446128 This port version is marked as vulnerable.
mat search for other commits by this committer
Really fix the dependencies.

Sponsored by:	Absolight
17 Jul 2017 10:23:29
Original commit files touched by this commit  9.1.7_3
Revision:446062 This port version is marked as vulnerable.
mat search for other commits by this committer
Fix pkgname.

Pointy hat:	tz
Sponsored by:	Absolight
16 Jul 2017 16:11:11
Original commit files touched by this commit  9.1.7_3
Revision:446031 This port version is marked as vulnerable.
sunpoet search for other commits by this committer
Change RUN_DEPENDS from rubygem-rack-cors to rubygem-rack-cors0

- Bump PORTREVISION for dependency change
15 Jul 2017 17:30:35
Original commit files touched by this commit  9.1.7_2
Revision:445921 This port version is marked as vulnerable.
sunpoet search for other commits by this committer
Change RUN_DEPENDS from rubygem-grape to rubygem-grape0

- Bump PORTREVISION for dependency change
06 Jul 2017 20:57:37
Original commit files touched by this commit  9.1.7_1
Revision:445179 This port version is marked as vulnerable.
sunpoet search for other commits by this committer
Fix gemspec for rubygem-hipchat 1.6.0 update

- Bump PORTREVISION for package change
06 Jul 2017 14:10:14
Original commit files touched by this commit  9.1.7
Revision:445153 This port version is marked as vulnerable.
tz search for other commits by this committer
www/gitlab: Update from 9.0.10 to 9.1.7

Changelog: https://github.com/gitlabhq/gitlabhq/blob/v9.1.7/CHANGELOG.md

Reviewed by: Matthias Fechner <idefix@fechner.net>
05 Jul 2017 08:39:22
Original commit files touched by this commit  9.0.10_2
Revision:445057 This port version is marked as vulnerable.
tz search for other commits by this committer
www/gitlab: Unbreak GitLab after Rails-Update

GitLab currently does not start after an update of
Rails to 4.2.9. Patch this, since its working
fine with the new version.

Submitted by: Matthias Fechner <idefix@fechner.net>
MFH:          2017Q3
29 Jun 2017 08:56:46
Original commit files touched by this commit  9.0.10_1
Revision:444631 This port version is marked as vulnerable.
tz search for other commits by this committer
www/gitlab: Fix broken patch

A duplication slipped into a patch which breaks the build. Fix it.

Submitted by: Matthias Fechner <idefix@fechner.net>
Reported by:  Remko Lodder <remko@FreeBSD.org>
28 Jun 2017 09:16:20
Original commit files touched by this commit  9.0.10
Revision:444556 This port version is marked as vulnerable.
tz search for other commits by this committer
www/gitlab: Update from 8.17.6 to 9.0.10

Changelog: https://github.com/gitlabhq/gitlabhq/blob/v9.0.10/CHANGELOG.md

Reviewed by: Matthias Fechner <idefix@fechner.net>
22 Jun 2017 23:42:04
Original commit files touched by this commit  8.17.6_7
Revision:444148 This port version is marked as vulnerable.
sunpoet search for other commits by this committer
Fix gemspec for rubygem-version_sorter 2.2.0 update

- Bump PORTREVISION for package change
21 Jun 2017 18:52:07
Original commit files touched by this commit  8.17.6_6
Revision:444052 This port version is marked as vulnerable.
sunpoet search for other commits by this committer
Fix gemspec for rubygem-state_machines-activerecord 0.5.0 update

- Bump PORTREVISION for package change
08 Jun 2017 14:08:03
Original commit files touched by this commit  8.17.6_5
Revision:442934 This port version is marked as vulnerable.
sunpoet search for other commits by this committer
Change RUN_DEPENDS from rubygem-gitlab_omniauth-ldap to
rubygem-gitlab_omniauth-ldap1

- Bump PORTREVISION for dependency change
08 Jun 2017 13:32:27
Original commit files touched by this commit  8.17.6_4
Revision:442920 This port version is marked as vulnerable.
sunpoet search for other commits by this committer
Fix gemspec for rubygem-omniauth-google-oauth2 0.5.0 update
29 May 2017 14:25:08
Original commit files touched by this commit  8.17.6_4
Revision:441986 This port version is marked as vulnerable.
tz search for other commits by this committer
www/gitlab: unbreak updates via "rake db:migrate"

The file db/schema.rb needs to be owned by user git
in order to be writable by the update process.

Reported by: Matthias Fechner <idefix@fechner.net>
29 May 2017 08:45:44
Original commit files touched by this commit  8.17.6_3
Revision:441975 This port version is marked as vulnerable.
tz search for other commits by this committer
www/gitlab: remove duplicate rubygem-pg-dependency

Accidently added an dependency to database/rubygem-pg via
patch-Gemfile. Since this dependency is also added by
the PGSQL-option i removed the conflict-causing line
from the patch.

Reported by: Matthias Fechner <idefix@fechner.net>
20 May 2017 21:50:51
Original commit files touched by this commit  8.17.6_2
Revision:441348 This port version is marked as vulnerable.
sunpoet search for other commits by this committer
Change RUN_DEPENDS from rubygem-deckar01-task_list to
rubygem-deckar01-task_list1

- Bump PORTREVISION for dependency change
18 May 2017 14:26:13
Original commit files touched by this commit  8.17.6_1
Revision:441153 This port version is marked as vulnerable.
jrm search for other commits by this committer
www/gitlab: Depend on devel/rubygem-oj2

Approved by:	swills (mentor, implicit), tz (comments in D10743)
17 May 2017 17:16:36
Original commit files touched by this commit  8.17.6_1
Revision:441106 This port version is marked as vulnerable.
sunpoet search for other commits by this committer
Fix gemspec for rubygem-rugged 0.25.1 update

- Bump PORTREVISION for package change
17 May 2017 16:36:34
Original commit files touched by this commit  8.17.6
Revision:441086 This port version is marked as vulnerable.
tz search for other commits by this committer
www/gitlab: Update from 8.16.9 to 8.17.6

Changelog: https://github.com/gitlabhq/gitlabhq/blob/v8.17.6/CHANGELOG.md

Reviewed by: Matthias Fechner <idefix@fechner.net>
16 May 2017 18:19:53
Original commit files touched by this commit  8.16.9_6
Revision:441032 This port version is marked as vulnerable.
sunpoet search for other commits by this committer
Change RUN_DEPENDS from rubygem-sidekiq to rubygem-sidekiq4

- Bump PORTREVISION for dependency change
05 May 2017 15:36:45
Original commit files touched by this commit  8.16.9_5
Revision:440188 This port version is marked as vulnerable.
sunpoet search for other commits by this committer
Fix gemspec for rubygem-gitlab-markup 1.6.0 update

- Bump PORTREVISION for package change
04 May 2017 11:09:50
Original commit files touched by this commit  8.16.9_4
Revision:440099 This port version is marked as vulnerable.
tz search for other commits by this committer
www/gitlab: Fix wrong permissions for /home/git/repositories

Now the dir is owned by user "git" instead of "root" which
allows GitLab to store data. Before this change every user
need to correct the rights by himself.
28 Apr 2017 20:24:59
Original commit files touched by this commit  8.16.9_3
Revision:439633 This port version is marked as vulnerable.
sunpoet search for other commits by this committer
Change RUN_DEPENDS from rubygem-oauth2 to rubygem-oauth212

- Bump PORTREVISION for dependency change
23 Apr 2017 17:10:31
Original commit files touched by this commit  8.16.9_2
Revision:439253 This port version is marked as vulnerable.
sunpoet search for other commits by this committer
Change RUN_DEPENDS

- Use rubygem-omniauth13 (~> 1.3.2)
- Use rubygem-omniauth-github11 (~> 1.1.1)
- Bump PORTREVISION for dependency change
15 Apr 2017 00:48:04
Original commit files touched by this commit  8.16.9_1
Revision:438568 This port version is marked as vulnerable.
sunpoet search for other commits by this committer
Change RUN_DEPENDS from rubygem-sidekiq-cron to rubygem-sidekiq-cron04

- Bump PORTREVISION for dependency change
11 Apr 2017 13:49:37
Original commit files touched by this commit  8.16.9
Revision:438260 This port version is marked as vulnerable.
tz search for other commits by this committer
www/gitlab: Update from 8.16.8 to 8.16.9

Changelog: https://github.com/gitlabhq/gitlabhq/blob/v8.16.9/CHANGELOG.md

Also unbreak it by tighten the requirement of rubygem-rainbow
and relying at rubygem-google-api-client010 instead of updated
rubygem-google-api-client.

Reviewed by: remko, Matthias Fechner <idefix@fechner.net>
03 Apr 2017 12:57:57
Original commit files touched by this commit  8.16.8_2
Revision:437633 This port version is marked as vulnerable.
sunpoet search for other commits by this committer
Change RUN_DEPENDS from rubygem-newrelic_rpm to rubygem-newrelic_rpm3

- Bump PORTREVISION for dependency change
31 Mar 2017 11:27:26
Original commit files touched by this commit  8.16.8_1
Revision:437349 This port version is marked as vulnerable.
tz search for other commits by this committer
www/gitlab: enable GitLab to start on boot

PR:           208793
Submitted by: Laszlo Karolyi <laszlo@karolyi.hu>, Horst Kapfenberger
<horst.kapfenberger@agoracon.at>
30 Mar 2017 14:21:00
Original commit files touched by this commit  8.16.8
Revision:437297 This port version is marked as vulnerable.
tz search for other commits by this committer
www/gitlab: Update from 8.15.8 to 8.16.8

Changelog: https://github.com/gitlabhq/gitlabhq/blob/v8.16.8/CHANGELOG.md
30 Mar 2017 13:05:57
Original commit files touched by this commit  8.15.8_2
Revision:437286 This port version is marked as vulnerable.
swills search for other commits by this committer
www/gitlab: use rubygem-health_check22 to avoid runtime problem
27 Mar 2017 19:16:29
Original commit files touched by this commit  8.15.8_1
Revision:437079 This port version is marked as vulnerable.
sunpoet search for other commits by this committer
Move www/rubygem-jquery-rails4 to www/rubygem-jquery-rails

- Bump PORTREVISION for dependent ports
27 Mar 2017 15:51:56
Original commit files touched by this commit  8.15.8
Revision:437054 This port version is marked as vulnerable.
sunpoet search for other commits by this committer
Remove duplicate CATEGORIES

Approved by:	portmgr (blanket)
27 Mar 2017 15:30:53
Original commit files touched by this commit  8.15.8
Revision:437052 This port version is marked as vulnerable.
tz search for other commits by this committer
www/gitlab: set link to upgrade guide according to new version 8.15
27 Mar 2017 15:13:52
Original commit files touched by this commit  8.15.8
Revision:437051 This port version is marked as vulnerable.
tz search for other commits by this committer
www/gitlab: Update from 8.14.9 to 8.15.8

Changelog: https://github.com/gitlabhq/gitlabhq/blob/v8.15.8/CHANGELOG.md

Also remove CVE patch because its already included in the new version
24 Mar 2017 17:48:21
Original commit files touched by this commit  8.14.9_8
Revision:436846  Sanity Test Failure This port version is marked as vulnerable.
sunpoet search for other commits by this committer
Change RUN_DEPENDS from rubygem-select2-rails to rubygem-select2-rails3

- Bump PORTREVISION for dependency change
21 Mar 2017 16:40:38
Original commit files touched by this commit  8.14.9_7
Revision:436617 This port version is marked as vulnerable.
tz search for other commits by this committer
www/gitlab: fix wrong detection of running Sidekiq

Sidekiq is detected as "not running" because when checking with "ps" it
does not account for column truncation

PR:           209487
Submitted by: Chris Stankevitz <chris-freebsd-bugs@stankevitz.com>
Reported by:  otacilio.neto@bsd.com.br
Reviewed by:  Matthias Fechner <idefix@fechner.net>
21 Mar 2017 02:01:35
Original commit files touched by this commit  8.14.9_6
Revision:436562 This port version is marked as vulnerable.
junovitch search for other commits by this committer
www/gitlab: apply upstream CVE-2017-0882 patch to 8.14.x

Reported by:	Brian Neel <brian@gitlab.com>
Approved by:	ports-secteam (with hat)
Security:	CVE-2017-0882
19 Mar 2017 01:57:22
Original commit files touched by this commit  8.14.9_5
Revision:436471 This port version is marked as vulnerable.
sunpoet search for other commits by this committer
Change RUN_DEPENDS from rubygem-u2f to rubygem-u2f0

- Bump PORTREVISION for dependency change
16 Mar 2017 20:56:18
Original commit files touched by this commit  8.14.9_4
Revision:436308 This port version is marked as vulnerable.
sunpoet search for other commits by this committer
Change RUN_DEPENDS from rubygem-slack-notifier to rubygem-slack-notifier1

- Bump PORTREVISION for dependency change
16 Mar 2017 08:30:06
Original commit files touched by this commit  8.14.9_3
Revision:436266 This port version is marked as vulnerable.
tz search for other commits by this committer
www/gitlab: add public/uploads dir

Without the dir the backup-routine does not work.
This also removes one more error from gitlab:check

Reported by: Chris Stankevitz <chris@stankevitz.com>
14 Mar 2017 16:39:31
Original commit files touched by this commit  8.14.9_2
Revision:436164 This port version is marked as vulnerable.
tz search for other commits by this committer
www/gitlab: Add options for selection between PostgreSQL and MySQL support

Reviewed by: remko
13 Mar 2017 11:07:50
Original commit files touched by this commit  8.14.9_1
Revision:436074 This port version is marked as vulnerable.
tz search for other commits by this committer
www/gitlab: Update from 8.13.12 to 8.14.9

Changelog: https://github.com/gitlabhq/gitlabhq/blob/v8.14.9/CHANGELOG.md
09 Mar 2017 19:16:52
Original commit files touched by this commit  8.13.12_1
Revision:435793 This port version is marked as vulnerable.
sunpoet search for other commits by this committer
Change RUN_DEPENDS from rubygem-fog-aws to rubygem-fog-aws0

- Bump PORTREVISION for dependency change
09 Mar 2017 09:47:11
Original commit files touched by this commit  8.13.12
Revision:435753 This port version is marked as vulnerable.
tz search for other commits by this committer
www/gitlab: Update from 8.12.13 to 8.13.12

Changelog: https://github.com/gitlabhq/gitlabhq/blob/v8.13.12/CHANGELOG.md
08 Mar 2017 16:52:17
Original commit files touched by this commit  8.12.13_1
Revision:435717 This port version is marked as vulnerable.
sunpoet search for other commits by this committer
Update RUN_DEPENDS

- Bump PORTREVISION for dependency change

With hat:	ruby
24 Feb 2017 09:45:07
Original commit files touched by this commit  8.12.13
Revision:434703 This port version is marked as vulnerable.
tz search for other commits by this committer
www/gitlab: Update from 8.11.11 to 8.12.13

Changelog: https://github.com/gitlabhq/gitlabhq/blob/v8.12.13/CHANGELOG
31 Jan 2017 16:33:07
Original commit files touched by this commit  8.11.11_7
Revision:432936 This port version is marked as vulnerable.
tz search for other commits by this committer
www/gitlab: Unbreak GitLab and fix web editing

Switch to rubygem-jquery-ui-rails5-rails4 and
pull in patch for safer ref updates

PR:           215787
Submitted by: swills
23 Dec 2016 12:24:45
Original commit files touched by this commit  8.11.11_6
Revision:429253 This port version is marked as vulnerable.
tz search for other commits by this committer
www/gitlab: Make -authBackend variable

The rc.d script currently has a fixed -authBackend defined which makes
using GitLab under an relative URL impossible.

PR:           210998
Submitted by: Julien Cigar <julien@perdition.city>
Approved by:  mentors (implicit)
23 Dec 2016 12:13:33
Original commit files touched by this commit  8.11.11_5
Revision:429252 This port version is marked as vulnerable.
tz search for other commits by this committer
www/gitlab: Make shipped nginx config files @sample

The shipped nginx config files require the user to change them. But
after an update they are reset to the default-content. Now
mark them as @sample so the will stay intact.

PR:           215510
Submitted by: Martin Waschbusch <martin@waschbuesch.de>
Approved by:  mentors (implicit)
23 Dec 2016 10:49:08
Original commit files touched by this commit  8.11.11_4
Revision:429243 This port version is marked as vulnerable.
tz search for other commits by this committer
www/gitlab: Unbreak after update of www/rubygem-jquery-rails4

PR:          215505
Reported by: Martin Waschbusch <martin@waschbuesch.de>
Approved by: mentors (implicit)
20 Dec 2016 18:36:16
Original commit files touched by this commit  8.11.11_3
Revision:429028 This port version is marked as vulnerable.
sunpoet search for other commits by this committer
- Fix PostgreSQL dependency: use USES=pgsql
- Bump PORTREVISION for dependency change

Differential Revision:	https://reviews.FreeBSD.org/D8719
Approved by:	tz (maintainer)
09 Dec 2016 12:56:50
Original commit files touched by this commit  8.11.11_2
Revision:428190 This port version is marked as vulnerable.
sunpoet search for other commits by this committer
- Fix gemspec for rubygem-httparty 0.14.0 update
- Bump PORTREVISION for dependency change
03 Dec 2016 19:36:55
Original commit files touched by this commit  8.11.11_1
Revision:427738 This port version is marked as vulnerable.
sunpoet search for other commits by this committer
- Add LICENSE_FILE [1]
- Fix gemspec for rubygem-grape 0.18.0 update
- Remove .include <bsd.port.options.mk> [1]
- Bump PORTREVISION for package change

Approved by:	portmgr (blanket) [1]
22 Nov 2016 09:56:06
Original commit files touched by this commit  8.11.11
Revision:426811 This port version is marked as vulnerable.
tz search for other commits by this committer
www/gitlab: Update from 8.10.13 to 8.11.11

Changelog: https://github.com/gitlabhq/gitlabhq/blob/v8.11.11/CHANGELOG

Approved by: mentors (implicit)
03 Nov 2016 16:59:23
Original commit files touched by this commit  8.10.13
Revision:425263 This port version is marked as vulnerable.
tz search for other commits by this committer
www/gitlab: Update from 8.10.12 to 8.10.13

Changes: https://github.com/gitlabhq/gitlabhq/blob/v8.10.13/CHANGELOG

Approved by: junovitch (mentor, implicit)
19 Oct 2016 14:22:31
Original commit files touched by this commit  8.10.12
Revision:424254 This port version is marked as vulnerable.
tz search for other commits by this committer
www/gitlab: Update from 8.9.6 to 8.10.12

Changes: https://github.com/gitlabhq/gitlabhq/blob/v8.10.12/CHANGELOG

Approved by: junovitch (mentor, implicit)
14 Oct 2016 11:13:25
Original commit files touched by this commit  8.9.6_4
Revision:423957 This port version is marked as vulnerable.
tz search for other commits by this committer
www/gitlab: Unbreak after update of databases/rubygem-pg

Approved by: junovitch (mentor, implicit)
13 Oct 2016 12:49:34
Original commit files touched by this commit  8.9.6_3
Revision:423910 This port version is marked as vulnerable.
tz search for other commits by this committer
www/gitlab: Use www/rubygem-turbolinks-classic instead of www/rubygem-turbolinks

This fixes various problems with the issue-pages of GitLab

PR:          213218
Approved by: junovitch (mentor, implicit)
30 Sep 2016 08:59:13
Original commit files touched by this commit  8.9.6_2
Revision:422970 This port version is marked as vulnerable.
tz search for other commits by this committer
www/gitlab: Unbreak after update of www/rubygem-turbolinks

Approved by: junovitch (mentor, implicit)
11 Aug 2016 15:17:21
Original commit files touched by this commit  8.9.6
Revision:420078 This port version is marked as vulnerable.
tz search for other commits by this committer
devel/rubygem-devise: switch to Rails 4 and fix fallout

Remove support of Rails 3 since we are obsoleting this version from the
ports-tree. This fixes the fallout-message to ruby@.

Also DEPRECATE rubygem-devise-rails4 in favor of rubygem-devise
and adjust dependencies of security/rubygem-devise-two-factor and
www/gitlab.

Approved by: pi (mentor)
10 Aug 2016 14:30:22
Original commit files touched by this commit  8.9.6
Revision:420031 This port version is marked as vulnerable.
tz search for other commits by this committer
www/gitlab: Update from 8.8.7 to 8.9.6

Changes: https://github.com/gitlabhq/gitlabhq/blob/v8.9.6/CHANGELOG

Approved by: junovitch (mentor, implicit)
19 Jul 2016 11:04:14
Original commit files touched by this commit  8.8.7
Revision:418767 This port version is marked as vulnerable.
mat search for other commits by this committer
When there is a do-install target, do not use a post-install target, do
everything at once.  Sometime, rename post-install into a options helper
target.

I did not fix ports that were such a mess that I could not figure out
what they really wanted to do.  I also did not change ports that had
some version of an auto-plist code in post-install, for the same reason.

With hat:	portmgr
Sponsored by:	Absolight
08 Jul 2016 13:56:17
Original commit files touched by this commit  8.8.7
Revision:418223 This port version is marked as vulnerable.
tz search for other commits by this committer
www/gitlab: update from 8.8.5 to 8.8.7


8.8.7
  - Fix privilege escalation issue with OAuth external users.
  - Ensure references to private repos aren't shown to logged-out users.

8.8.6
  - Fix visibility of snippets when searching.
  - Update omniauth-saml to 1.6.0

Approved by: junovitch (mentor, implicit)
Security:    CVE-2016-5697
MFH:         2016Q3
04 Jul 2016 13:53:29
Original commit files touched by this commit  8.8.5_1
Revision:418027 This port version is marked as vulnerable.
tz search for other commits by this committer
www/gitlab: fix typo in files/patch-lib_support_nginx_gitlab-ssl

Fix wrong root directory for HTTP error codes 404, 422, 500, 502
and 503 point.

Submitted by: Jose Luis Duran <jlduran@gmail.com>
Approved by:  pi (mentor)
21 Jun 2016 08:36:56
Original commit files touched by this commit  8.8.5
Revision:417194 This port version is marked as vulnerable.
tz search for other commits by this committer
www/gitlab: Update from 8.7.5 to 8.8.5

Changelog: https://github.com/gitlabhq/gitlabhq/blob/8-8-stable/CHANGELOG

PR:          209903
Approved by: swills (mentor)
10 Jun 2016 09:08:02
Original commit files touched by this commit  8.7.5
Revision:416662 This port version is marked as vulnerable.
tz search for other commits by this committer
Change MAINTAINER from ports@toco-domains.de to tz@FreeBSD.org

Approved by:	junovitch (mentor)
18 May 2016 21:59:10
Original commit files touched by this commit  8.7.5
Revision:415465 This port version is marked as vulnerable.
robak search for other commits by this committer
www/gitlab: update 8.7.2 -> 8.7.5

PR:		209609
Submitted by:	Torsten Zuehlsdorff <ports@toco-domains.de> (maintainer)
04 May 2016 20:47:11
Original commit files touched by this commit  8.7.2
Revision:414612 This port version is marked as vulnerable.
pi search for other commits by this committer
www/gitlab: 8.7.1 -> 8.7.2

Changes:
  https://about.gitlab.com/2016/05/03/gitlab-8-dot-7-dot-2-released/

PR:		209265
Submitted by:	Torsten Zuehlsdorff <ports@toco-domains.de> (maintainer)
03 May 2016 13:08:06
Original commit files touched by this commit  8.7.1
Revision:414529 This port version is marked as vulnerable.
pi search for other commits by this committer
www/gitlab: 8.7.0 -> 8.7.1

Changes:
  https://about.gitlab.com/2016/05/02/cve-2016-4340-patches/

PR:		209225
Submitted by:	Torsten Zuehlsdorff <ports@toco-domains.de> (maintainer)
Security:	CVE-2016-4340
29 Apr 2016 14:25:11
Original commit files touched by this commit  8.7.0
Revision:414274 This port version is marked as vulnerable.
pi search for other commits by this committer
www/gitlab: 8.6.6 -> 8.7.0

Changes:
  https://github.com/gitlabhq/gitlabhq/blob/master/CHANGELOG

PR:		209138
Submitted by:	Torsten Zuehlsdorff <ports@toco-domains.de> (maintainer)
19 Apr 2016 21:36:54
Original commit files touched by this commit  8.6.6
Revision:413663 This port version is marked as vulnerable.
robak search for other commits by this committer
www/gitlab: update 8.6.5 -> 8.6.6

- Pet portlint

PR:		208886
Submitted by:	iTorsten Zuhlsdorff <ports@toco-domains.de> (maintainer)
13 Apr 2016 16:46:43
Original commit files touched by this commit  8.6.5
Revision:413219 This port version is marked as vulnerable.
pi search for other commits by this committer
www/gitlab: 8.5.5 -> 8.6.5

PR:		208511
Submitted by:	Torsten Zuehlsdorff <ports@toco-domains.de> (maintainer)
Reviewed by:	xmj, miks.mikelsons@gmail.com
04 Apr 2016 21:34:29
Original commit files touched by this commit  8.5.5
Revision:412530 This port version is marked as vulnerable.
swills search for other commits by this committer
www/gitlab: remove unneeded dependency on ruby
01 Apr 2016 14:33:58
Original commit files touched by this commit  8.5.5
Revision:412351 This port version is marked as vulnerable.
mat search for other commits by this committer
Remove ${PORTSDIR}/ from dependencies, categories v, w, x, y, and z.

With hat:	portmgr
Sponsored by:	Absolight
31 Mar 2016 18:01:42
Original commit files touched by this commit  8.5.5
Revision:412280 This port version is marked as vulnerable.
pi search for other commits by this committer
New port: www/gitlab

GitLab is version control for your server.

WWW: https://gitlab.com/

Submitted by: Torsten Zuehlsdorff <ports@toco-domains.de>
Reviewed by: Yonas Yanfa <yonas@fizk.net>, girgen, pgollucci, mmoll, miwi, xmj,
swills, amdmi3, sunpoet

Number of commits found: 84

Login
User Login
Create account

Servers and bandwidth provided by
New York Internet, SuperNews, and RootBSD

This site
What is FreshPorts?
About the authors
Issues
FAQ
How big is it?
The latest upgrade!
Privacy
Forums
Blog
Contact

Search
Enter Keywords:
 
more...

Latest Vulnerabilities
chromiumSep 22
apache22Sep 19
apache24Sep 19
asterisk11Sep 19
asterisk13Sep 19
firefox*Sep 19
firefox*Sep 19
firefox-esr*Sep 19
firefox-esr*Sep 19
libxul*Sep 19
libxul*Sep 19
linux-firefox*Sep 19
linux-firefox*Sep 19
linux-seamonkey*Sep 19
linux-seamonkey*Sep 19

11 vulnerabilities affecting 79 ports have been reported in the past 14 days

* - modified, not new

All vulnerabilities


Ports
Home
Categories
Deleted ports
Sanity Test Failures
Newsfeeds

Statistics
Graphs
NEW Graphs (Javascript)
Traffic

Calculated hourly:
Port count 31461
Broken 113
Deprecated 74
Ignore 381
Forbidden 0
Restricted 174
No CDROM 78
Vulnerable 48
Expired 18
Set to expire 70
Interactive 0
new 24 hours 0
new 48 hours6
new 7 days136
new fortnight2834
new month4408

Servers and bandwidth provided by
New York Internet, SuperNews, and RootBSD
Valid HTML, CSS, and RSS.
Copyright © 2000-2017 Dan Langille. All rights reserved.