notbugAs an Amazon Associate I earn from qualifying purchases.
Want a good read? Try FreeBSD Mastery: Jails (IT Mastery Book 15)
Want a good monitor light? See my photosAll times are UTC
Ukraine
non port: UPDATING

Number of commits found: 2727 (showing only 100 on this page)

[First Page]  «  3 | 4 | 5 | 6 | 7 | 8 | 9 | 10 | 11 | 12 | 13  »  [Last Page]

Thursday, 2 Mar 2017
18:10 cmt search for other commits by this committer
update thunderbird to 45.7.1

https://www.mozilla.org/en-US/thunderbird/45.7.0/releasenotes/
https://www.mozilla.org/en-US/thunderbird/45.7.1/releasenotes/

After changes in packaging in ports r428672, profiles using lightning
will have to be recreated.

PR:		216584
Approved by:	jbeich (maintainer), rene (mentor, implicit)
MFH:		2017Q1
Security:	e60169c4-aa86-46b0-8ae2-0d81f683df09
e60169c4-aa86-46b0-8ae2-0d81f683df09
Original commitRevision:435290 
Thursday, 23 Feb 2017
05:10 truckman search for other commits by this committer
Add a note to UPDATING to about the shared library version bump of
libmtbl in devel/mtbl r434654.

Sponsored by:	Farsight Security Inc.
Original commitRevision:434656 
Tuesday, 21 Feb 2017
01:27 girgen search for other commits by this committer
Update to 5.2.1

The three elasticsearch beats ports have merged into one single port
systuils/beats that installs all of the above and some more. The reason is to
make the port more maintainable and also that the new heartbeat beat would
conflict with sysutils/heartbeat.

Add heartbeat beat.

Install utilities
  share/beats/import_dashboards
  share/beats/migrate_beat_config_1_x_to_5_0.py

Fix problems with the default configurations [1]

PR:	217081 [1]
Original commitRevision:434496 
Monday, 20 Feb 2017
15:07 sunpoet search for other commits by this committer
Use @FreeBSD.org
Original commitRevision:434445 
02:57 jbeich search for other commits by this committer
devel/libevent2: drop historical suffix after r362796

PR:		216777
Approved by:	mm (maintainer)
Original commitRevision:434427 
Saturday, 18 Feb 2017
19:48 tcberner search for other commits by this committer
Update Qt5 to 5.7.1, and unify the Qt4 and Qt5 ports some more

* Update Qt5 to 5.7.1
* Move Qt4 binaries to lib/qt4/bin
* Move Qt5 libraries to lib/qt5/lib
  By moving the libraries we should finally be able to get rid of the inplace
  upgrade bug (see ports bugs 194088, 195105 and 198720):  when Qt5's libraries
  were lying in /usr/local/lib, which would often get added by pkgconfig to the
  linker paths via dependencies, the already installed libraries were linked
  against, instead of the ones that were being built. This forced us to make
  sure, that -L${WRKSRC}/lib was always coming before -L/usr/local/lib in the
  linker flags. With this change this should no longer be the case.
* Rename some ports to match the rest (foo-qtX -> qtX-foo)
* Depend on new port misc/qtchooser [see UPDATING & CHANGES]

There are several new Qt5 ports which all have been created by Marie Loise
Nolden
<nolden@kde.org>. Thanks again.

PR:		216797
Exp-Run by:	antoine
Reviewed by:	rakuco, mat, groot_kde.org
Approved by:	rakuco (mentor)
Differential Revision:	https://reviews.freebsd.org/D9213
Original commitRevision:434380 
Tuesday, 14 Feb 2017
16:15 sunpoet search for other commits by this committer
Enable BUNDLED_SSL by default only on FreeBSD 10

- Add UPDATING entry
- Bump PORTREVISION for dependency change

PR:		217095
Submitted by:	Bradley T. Hughes <bradleythughes@fastmail.fm> (maintainer)
Original commitRevision:434123 
Monday, 13 Feb 2017
12:49 kwm search for other commits by this committer
Add note about missing libGL after r433892.
Original commitRevision:433986 
Saturday, 11 Feb 2017
19:03 rezny search for other commits by this committer
Add UPDATING entry for Xorg server 1.18.4

Reviewed by:	bapt
Approved by:	swills (mentor)
Differential Revision:	https://reviews.freebsd.org/D9545
Original commitRevision:433902 
Friday, 3 Feb 2017
08:42 brnrd search for other commits by this committer
UPDATING: Add entry for libressl-devel shlib bump
Original commitRevision:433203 
Thursday, 2 Feb 2017
17:50 feld search for other commits by this committer
Add new UPDATING entry with details on newest changes to uwsgi
Original commitRevision:433174 
Monday, 30 Jan 2017
22:29 grembo search for other commits by this committer
Fix 64-bit platform detection for pre C++11 compilers.

In version 3.6.3, Ice started detecting 64 bit platforms by
checking __WORDSIZE. When using C++98/03, __STDC_LIMIT_MACROS isn't
set by default and __WORDSIZE is always set to 32, even if the
required headers weren't included beforehand. Until a proper
fix is available in base (e.g. not setting __WORDSIZE at all if
__STDC_LIMIT_MACROS isn't defined), we detect if C++11 or newer
is used and only rely on __WORDSIZE in this case, otherwise
we fall back to detecting the platform using other macros.

PR:		216609
Reported by:	jbeich
Original commitRevision:432888 
00:09 jhale search for other commits by this committer
- Fix an issue where netcams were not connecting [1]
- When motion was updated to 4.x, it was overlooked that the default
  search path for the configuration files was changed. This was causing
  existing configurations to not be read. Fix the port to install
  default configuration in correct location and add an UPDATING message
  giving users the proper instructions on where to place their existing
  conf files. [2]
- Create an empty ${ETCDIR}/conf.d directory that can optionally be used
  to dump camera configs in instead of creating separate lines for each
  one in motion.conf
- Add some missing PORTDOCS and install with the correct mode
- Make the VIDEO options OPTIONS_RADIO instead of OPTIONS_SINGLE to
  allow for netcam only support (suggested in [2])
- Fix bad logic in configure.ac that was causing V4L to not be dectected
  when the PWCBSD option was enabled

PR:		216189 [1]
Reported by:	Charles P <charlespigott@googlemail.com>
Patched by:	<anthony@ury.org.uk>
Obtained from:	upstream
PR:		216466 [2]
Reported by:	<bakhur@inbox.ru>, tdb@
Pointy hat to:	jhale
MFH:		2017Q1 (blanket)
Original commitRevision:432815 
Friday, 27 Jan 2017
23:37 feld search for other commits by this committer
Add UPDATING entry to notify about uwsgi default socket mode change
Original commitRevision:432604 
Saturday, 21 Jan 2017
17:40 dinoex search for other commits by this committer
- update tinc to 1.0.31
Original commitRevision:432067 
Friday, 20 Jan 2017
18:23 feld search for other commits by this committer
amend 20170120 UPDATING entry regarding mysql56-server
Original commitRevision:431976 
16:24 feld search for other commits by this committer
Add UPDATING entry about recent mysql56-server issue
Original commitRevision:431969 
Tuesday, 17 Jan 2017
15:49 amdmi3 search for other commits by this committer
- Refuse (overridable) to build ports on unsupported system version

Unfortunately, it's not uncommon for FreeBSD users to not update
their systems timely and thus end up using unsupported FreeBSD
release. These users continue to update ports tree as usual and
expect it to work, either unaware of the release EoL, or not clearly
understanding the consequences, which results in unexpected build
failures, bogus bug reports, attempts to bring back removed legacy
support bits and general discontent.

This change introduces system version check which makes ports refuse
to build anything on unsupported system. This makes users aware of
EoL of their system and makes it clear that no port is guaranteed to
build.

The error message tells how to override the check (by defining
ALLOW_UNSUPPORTED_SYSTEM, in which case it's turned into a simple
warning), additionally stressing that this configurartion is not
supported.

Currently outdated are OSVERSION < 1003000 (pre 10.3-RELEASE) and
1100000 <= OSVERSION < 1100122 (from 11-CURRENT'2013 to 11.0-PRERELEASE)

I expect these to be kept up to date with base system lifetimes,
be updated BEFORE removing any support for outdated release from
the tree and also serve as a reference of which OSVERSION checks
may be removed.

Approved by:	portmgr (swills, mat)
Differential Revision:	D9210
Original commitRevision:431746 
Monday, 16 Jan 2017
15:27 olgeni search for other commits by this committer
Upgrade java/wildfly10 to 10.1.0.

- Move installation directory to /usr/local/wildfly10.
- Fix directory permissions and ownership (root:wheel everywhere except config.)
- Remove all @dir entries which are now unnecessary.
- Add upgrade notice to UPDATING.

PR:		212052
Submitted by:	olgeni
Approved by:	maintainer
Original commitRevision:431670 
14:19 dvl search for other commits by this committer
Add more detail about my.cnf changes

Submitted by: Christoph Moench-Tegeder <cmt@burggraben.net>
Original commitRevision:431648 
03:14 dvl search for other commits by this committer
Add patches missing from previous commit.
Add note to pkg-message about my.cnf
Add not to UPGRADING about my.cnf
Bump PORTREVISION

Submitted by: Larry Rosenman <ler@FreeBSD.org>
Original commitRevision:431614 
Monday, 9 Jan 2017
19:23 swills search for other commits by this committer
Switch default Ruby version from 2.2 to 2.3

PR:		215013
Original commitRevision:431022 
Sunday, 1 Jan 2017
18:48 riggs search for other commits by this committer
Reflect changes to OPTIMIZED_CFLAGS handling in multimedia/ffmpeg

PR:		215402
Submitted by:	jbeich
Original commitRevision:430270 
Friday, 30 Dec 2016
18:31 olivierd search for other commits by this committer
- Update to 0.8.2
- Remove unneeded patch
- Add note about the hidden 'MiscSlimTabs' option (it requires Gtk+ > 3.20).

If this option is set, lots of warnings will appear:
  Gtk-WARNING **: Theme parsing error: <data>:2:12: 'min-height' is not a
  valid property name

  Gtk-WARNING **: Theme parsing error: <data>:8:11: 'min-width' is not a
  valid property name
Original commitRevision:430014 
Wednesday, 28 Dec 2016
05:11 avilla search for other commits by this committer
- Document multimedia/mlt split
Original commitRevision:429709 
Tuesday, 27 Dec 2016
23:16 mandree search for other commits by this committer
OpenVPN update to v2.4.0, old version in openvpn23*.

OpenVPN has been updated to v2.4.0.
Changes: <https://github.com/OpenVPN/openvpn/blob/v2.4.0/Changes.rst>

openvpn-polarssl has been renamed to openvpn-mbedtls to match the TLS
library's change of name.

The prior versions of the openvpn ports have been preserved in openvpn23
and openvpn23-polarssl, respectively, and are set to expire 2017-03-31.
Original commitRevision:429678 
Sunday, 18 Dec 2016
16:49 sunpoet search for other commits by this committer
- Document ths change of www/nghttp2
Original commitRevision:428879 
Friday, 16 Dec 2016
13:18 jbeich search for other commits by this committer
Oops, restore Lightning build after r428672

addons.mozilla.org version still cannot be used due to binary components
that aren't provided for any Tier3 platform.
Original commitRevision:428676 
10:57 jbeich search for other commits by this committer
gecko: drop ENIGMAIL, LIGHTNING to simplify updates

ENIGMAIL can still return as www/xpi-enigmail but, alas, xpi-* ports and
their framework are mostly unmaintained.

PR:		209155 (for tracking)
Original commitRevision:428672 
Tuesday, 13 Dec 2016
15:45 amdmi3 search for other commits by this committer
- Add UPDATING entry for devel/skalibs, lang/execline, sysutils/s6 update

PR:		213894, 213897, 213899
Submitted by:	colin@heliocat.net (maintainer)
Original commitRevision:428505 
Thursday, 8 Dec 2016
00:00 adamw search for other commits by this committer
Add an entry to UPDATING about www/node becoming v7, and switching
to www/node6 to stay on that LTS version.

PR:		213948
Submitted by:	maintainer (Bradley T. Hughes)
Original commitRevision:428091 
Friday, 2 Dec 2016
14:58 tj search for other commits by this committer
Update p5-Search-Elasticsearch to 5.01

Changes: https://metacpan.org/changes/distribution/Search-Elasticsearch

This update brings 3 new packages for older Elasticsearch server APIs:

p5-Search-Elasticsearch-Client-0_90 for accessing 0.90 based servers
p5-Search-Elasticsearch-Client-1_0 for accessing 1.X based servers
p5-Search-Elasticsearch-Client-2_0 for accessing 2.X based servers

People accessing older instances of elasticsearch must also install the
appropriate client API package as well.

WWW: https://metacpan.org/release/DRTECH/Search-Elasticsearch-Client-0_90-5.01
WWW: https://metacpan.org/release/DRTECH/Search-Elasticsearch-Client-1_0-5.01
WWW: https://metacpan.org/release/DRTECH/Search-Elasticsearch-Client-2_0-5.01
Original commitRevision:427559 
Saturday, 26 Nov 2016
23:41 jhale search for other commits by this committer
Update security/gpgme-* to 1.8.0

In this version, libgpgme-pthread.so has been removed in favor of just
using libgpgme.so as the thread-safe library. PORTREVISION has been
bumped on all ports depending on security/gpgme so that any that may have
linked to -lgpgme-pthread will link to -lgpgme instead.

The Python module provided by security/py-gpgme has been renamed upstream
from pyme3 to gpg. This removes the conflict with security/py-pyme,
although security/py-gpgme is still the direct replacement of that
module.
Original commitRevision:427185 
Monday, 21 Nov 2016
21:26 antoine search for other commits by this committer
Update to 4.0.7
The following tools are removed from this release: bmp2tiff, gif2tiff,
ras2tiff, rgb2ycbcr and thumbnail.
Original commitRevision:426758 
Wednesday, 16 Nov 2016
07:34 acm search for other commits by this committer
- Add entry about bareos update

Submitted by:	Douglas K. Rand <rand at iteris.com>
Original commitRevision:426218 
Sunday, 13 Nov 2016
12:43 bapt search for other commits by this committer
Replace UPDATING entry by CONFLICTS_BUILD which is designed for that

Reported by:	jbeich
Original commitRevision:426041 
11:13 bapt search for other commits by this committer
Add an updating entry about the mdds0 installation which prevents
building libroeffice 5
Original commitRevision:426034 
06:43 novel search for other commits by this committer
devel/libosinfo: update to 1.0.0 and handle split

libosinfo as of 1.0.0 consists of 3 packages:

 - sysutils/osinfo-db-tools: contains the CLI tools
 - misc/osinfo-db: contains database with OS data
 - devel/libosinfo: the library

This commit does the following:

 - devel:libosinfo: update to 1.0.0
 - sysutils/osinfo-db-tools: add new port version 1.0.0
 - misc/osinfo-db: add new port version 20160728
 - UPDATING: document this split and add a note about
   updating handling because of moved files across the packages
   that could result in a conflict

Differential Revision:	D8455
Original commitRevision:426009 
Saturday, 12 Nov 2016
21:22 hrs search for other commits by this committer
- Fix Berkeley DB dependency.  It now properly uses BDB_LIB specified in
  Mk/Uses/bdb.mk instead of db185 interfaces in libc.
  As a side-effect, this causes a compatibility issue between
  heimdal.db created by kadmin(8) in the base system or one by
  an older security/heimdal.  See UPDATING about this issue.

- Fix readline dependency end eliminate libheimedit.

- Use -lpthread instead of -pthread.

- Use FOO_CONFIGURE_WITH=foo instead of FOO_CONFIGURE_ON=--with-foo.
Original commitRevision:425994 
Saturday, 5 Nov 2016
16:57 hrs search for other commits by this committer
ix Berkeley DB detection at the configuration stage.

PR:	214182
Original commitRevision:425399 
Friday, 4 Nov 2016
19:02 hrs search for other commits by this committer
- Fix a lmissing dependency of mail/mu.
- Add "emacsNN" suffix to the Emacs backend.
Original commitRevision:425349 
Thursday, 3 Nov 2016
15:21 mat search for other commits by this committer
Copy and paste and stupidity.

Reported by:	madpilot
Sponsored by:	Absolight
Original commitRevision:425229 
14:34 mat search for other commits by this committer
Change the default Perl version to 5.24.

We have been stuck with Perl 5.20 for too long.  Now that the main
problem, mod_perl2, has been updated to work with Perl 5.22+, we can go
and live with a modern Perl.

PR:		213810
Submitted by:	mat
Exp-run by:	antoine
Sponsored by:	Absolight
Original commitRevision:425221 
Wednesday, 2 Nov 2016
20:08 brnrd search for other commits by this committer
security/acme-client: Update to 0.1.13

  - Update to 0.1.13
  - Modify all configuration paths from letsencrypt to acme
  - Update periodic script to reflect path changes
  - Update sample scripts to reflect path changes
  - Add warning to pkg-message for changed paths
  - Add UPDATING entry for changed paths
  - Remove warning for old periodic.conf variable names
  - Remove warning for letskencrypt rename
Original commitRevision:425172 
Sunday, 30 Oct 2016
16:19 adamw search for other commits by this committer
Update squirrelmail to 20161030 sources, which most notably brings
much better php70 support. The optional database backend has switched
from PEAR to PDO, so include an UPDATING note about it.
Original commitRevision:424954 
13:39 rakuco search for other commits by this committer
Update to 1.2.15.

While here, set LICENSE_FILE and TEST_TARGET.
Original commitRevision:424943 
Saturday, 29 Oct 2016
17:01 woodsb02 search for other commits by this committer
irc/quassel: split into two ports (client and server)

irc/quassel-core provides the server back-end.
irc/quassel provides the client front-end.
irc/quassel can also be built with the MONO option enabled to also
install the client and server combined into a single monolithic binary.

Submitted by:	Chris Rees <crees@physics.org> (in part)
Approved by:	adamw (mentor, implicit)
Original commitRevision:424921 
Friday, 28 Oct 2016
19:49 brnrd search for other commits by this committer
security/openssl: Bump shared library version

  - Bump shlib version for security/openssl
  - Bump shlib version for security/openssl-devel
  - Add instructions to UPDATING

PR:		209582
Reported by:	Matthew D. Fuller <fullermd@over-yonder.net>
MFH:		2016Q4
Original commitRevision:424878 
Wednesday, 26 Oct 2016
16:52 rm search for other commits by this committer
net-p2p/deluge: split out CLI part

By popular demand split out deluge onto CLI part and GUI part to let users with
headless servers or users who do not want to install all the GTK2 stuff install
just deluge with minimal required dependencies.
deluge-cli port was introduced, that let user to run in CLI mode and to control
the queue via web-interface.

This change requires all the users of net-p2p/deluge to deinstall it first and
then install the required part:
- net-p2p/deluge-cli if GTK2 GUI is not required
- net-p2p/deluge to get the graphical client (net-p2p/deluge-cli will be
installed as a dependency)

Requested by:	many
Original commitRevision:424719 
Tuesday, 18 Oct 2016
16:58 olivierd search for other commits by this committer
- Update to 0.8.0
- Sort USES
- Remove NLS option

Tested by:	Vladimir Omelchuk (PR 209662)
Original commitRevision:424180 
Friday, 14 Oct 2016
19:50 antoine search for other commits by this committer
Change the default version of python3 from 3.4 to 3.5
Thanks to Ruslan Makhmatkhanov for doing all the fixes

PR:		204519
With hat:	portmgr
Original commitRevision:423986 
Tuesday, 11 Oct 2016
07:38 ashish search for other commits by this committer
- Update to 16.09
- Add a note about probable crash during startup, to UPDATING file
Original commitRevision:423747 
Wednesday, 5 Oct 2016
22:50 woodsb02 search for other commits by this committer
Move audio/squeezeboxserver to audio/logitechmediaserver

audio/squeezeboxserver:
- Move to audio/logitechmediaserver
- Update to 7.9.0 pre-release (git commit from 7.9 branch on 2016.09.30)
- Change default install and database locations to suit new PORTNAME
- Remove softsqueeze.sh as it is no longer bundled with the server
- Add /usr/local/etc/newsyslog.conf.d/, don't edit /etc/newsyslog.conf
- Add LICENSE details
- Update maintainer (previous maintainer timeout)
- Use customized perl modules provided in distfile and slimserver-vendor
  GitHub repo, rather than using perl dependencies from ports
- Changed install method to now copy directly to stagedir instead of an
  intermediate step to TMP_SLIMDIR

audio/squeezeboxserver-dynamicplaylist:
- Move to audio/logitechmediaserver-dynamicplaylist
- Update to 2.9.3853
- Fix MASTER_SITES
- Add LICENSE details
- Update maintainer

audio/squeezeboxserver-lazysearch:
- Move to audio/logitechmediaserver-lazysearch
- Add LICENSE details
- Update maintainer

audio/squeezeboxserver-sqlplaylist:
- Move to audio/logitechmediaserver-sqlplaylist
- Update to 2.5.3859
- Fix MASTER_SITES
- Add LICENSE details
- Update maintainer

audio/squeezeboxserver-superdatetime:
- Move to audio/logitechmediaserver-superdatetime
- Add LICENSE details
- Update maintainer

audio/squeezeboxserver-trackstat:
- Move to audio/logitechmediaserver-trackstat
- Update to 3.2.3951
- Fix MASTER_SITES
- Add LICENSE details
- Update maintainer

PR:		180034
PR:		203266
Submitted by:	woodsb02, mark@tranquillussoftware.co.uk (new maintainer)
Reported by:	david@dawninglight.net, amdmi3
Approved by:	markk@knigma.org (maintainer timeout), tdb (maintainer), adamw
(mentor)
Differential Revision:	https://reviews.freebsd.org/D6483
Original commitRevision:423393 
Tuesday, 4 Oct 2016
11:40 gahr search for other commits by this committer
Add some info regarding the upgrade of mail/roundcube-carddav
Original commitRevision:423254 
Tuesday, 27 Sep 2016
18:25 jbeich search for other commits by this committer
emulators/ppsspp: enslave GUI options

Catering package-only users that want Qt4 flavor or just SDL UI.
COMMENT and pkg-descr (both plural) can be improved in future.
Original commitRevision:422825 
18:25 jbeich search for other commits by this committer
sysutils/android-file-transfer: enslave GUI and expose CLI option

Catering package-only users that want Qt4 flavor or just non-GUI parts.
COMMENT and pkg-descr (both plural) can be improved in future.
Original commitRevision:422824 
Thursday, 22 Sep 2016
15:37 matthew search for other commits by this committer
pglogical: update to 1.2.0
pglogical-output: delete; merged into databases/pglogical

The databases/pglogical	  and databases/pglogical-output ports have been
merged into one codebase upstream, and database/pglogical now installs
the pglogical-output.so module.

pkg(8) should handle the merger	correctly; portmaster(1),
portupgrade(1) users are advised to manually delete pglogical-output
before upgrading.
Original commitRevision:422630 
Wednesday, 21 Sep 2016
15:36 amdmi3 search for other commits by this committer
- Update mail/sieve-connect to 0.88
- Fix LICENSE

Changes in v0.88:

* (BREAKING CHANGE) Require TLS verification to work.

* (POSSIBLY BREAKING CHANGE) Remote sieve name should be basename of local.

* Fail early if no CA trust anchors can be found but TLS verification is
 enabled.

* Added `--tlshostname` option to override the hostname used for
 TLS host identity verification

* If not interactive, various warnings in interactive at the
 application-level with the remote server will now trigger a final
 warning before exit and a non-zero exit code.

* Kolab nocaps server compatibility, in the continuing saga of
 "feature-based negotiation, who needs it anyway?"

* build-system fix to better isolate releaser tools from "just make the
 tarball", to let others make the unsigned tarball and compare.

* Interactive command `debug` added when invoked with `--debug` to
 toggle debugging off/on, to reduce self-inflicted log-spam.

* Handle local hostnames which lack real DNS better, avoid an undef
 dereference

Full ChangeLog at:

http://people.spodhuis.org/phil.pennock/software/sieve-connect.ChangeLog.txt

PR:		212466
Submitted by:	alexey@renatasystems.org (maintainer)
Original commitRevision:422568 
Tuesday, 20 Sep 2016
03:41 cy search for other commits by this committer
net/vtun: Document the removal of the VTUN_EXTENDED_MODE build time
option and replacing it with the -e command line option.
Original commitRevision:422482 
Saturday, 17 Sep 2016
09:40 rakuco search for other commits by this committer
Fix typo in the entry from 20160914.
Original commitRevision:422305 
Wednesday, 14 Sep 2016
22:28 osa search for other commits by this committer
www/nginx-devel: Change default log locations to avoid /var/log pollution

The nginx error log default will always be touched regardless of the value
of the error_log directive in nginx.conf.  This is not a bug.  It also
breaks shell tab completion for the sane default of /var/log/nginx.

This change aligns the compiled-in default and the configuration default
of error log to a new default /var/log/nginx directory.

PR:	212416
Original commitRevision:422167 
11:41 olivierd search for other commits by this committer
Update to 0.2.2
Original commitRevision:422126 
Saturday, 10 Sep 2016
16:31 riggs search for other commits by this committer
Document breaking upstream changes in security/letsencrypt.sh

PR:		212485
Submitted by:	sascha@root-login.org (maintainer security/letsencrypt.sh)
Reviewed by:	riggs
Original commitRevision:421709 
Tuesday, 6 Sep 2016
23:18 woodsb02 search for other commits by this committer
math/galculator: Update to 2.1.4

- Follow upstream move from SF to GitHub, and new website hosting
- Add USES=autoreconf libtool as GH tarball only comes with configure.ac
- Add OPTIONS to select GTK3 or GTK2 (GTK3 by default as per upstream)
- Add USE_GNOME=cairo und GTK2_LIB_DEPENDS undeclared dependencies

Changes this release:
  https://github.com/galculator/galculator/blob/v2.1.4/ChangeLog

Reviewed by:	adamw (mentor)
Approved by:	naddy (maintainer), mat (mentor)
Differential Revision:	https://reviews.freebsd.org/D7789
Original commitRevision:421469 
13:57 marino search for other commits by this committer
www/nginx: Change default log locations to avoid /var/log pollution

The nginx error log default will always be touched regardless of the value
of the error_log directive in nginx.conf.  This is not a bug.  It also
breaks shell tab completion for the sane default of /var/log/nginx.

This change aligns the compiled-in default and the configuration default
of error log to a new default /var/log/nginx directory.

PR:		195916
Approved by:	maintainer timeout (15 months)
Original commitRevision:421429 
Monday, 5 Sep 2016
11:15 girgen search for other commits by this committer
Add PostgreSQL-9.6 RC1

Please read the entry from 20160905 in UPDATING:

daemon user has changed to `postgres'
ICU is default on
Original commitRevision:421360 
Thursday, 1 Sep 2016
16:44 danfe search for other commits by this committer
- Mention that ``nvidia'' (or ``nvidia-modeset'' as of recently) can be put
  on ``kld_list'' variable in /etc/rc.conf as well (for later loading)
- Make s/nvidia/nvidia-modeset/ replacement suggestion more accurate because
  ``.ko'' suffix is omitted in syntax for both of those files
- Improve UPDATING wording for corresponding 20160829 entry accordingly
Original commitRevision:421237 
Wednesday, 31 Aug 2016
19:31 danfe search for other commits by this committer
- Append `@FreeBSD.org' to all authors' names that are FreeBSD committers
- Consistently use ``AFFECTS: users of ...'' form and fix one ``Users if''
- Kill EOL whitespace and fix a few noticed spelling mistakes while here
Original commitRevision:421186 
Tuesday, 30 Aug 2016
15:19 cem search for other commits by this committer
nvidia-driver: Add a note about nvidia-modeset.ko for 367.35 update

Add a note in pkg-message and UPDATING.  Correct a pkg-plist sorting mistake
while here.

Reviewed by:	dhw, wblock
Approved by:	brd (previous version)
Differential Revision:	https://reviews.freebsd.org/D7700
Original commitRevision:421117 
Monday, 29 Aug 2016
20:02 feld search for other commits by this committer
Also document the removal of another sshguard feature
Original commitRevision:421096 
19:55 feld search for other commits by this committer
security/sshguard: Unbreak build by making a metaport

security/sshguard no longer provides hosts/TCP Wrappers support by
default as this was removed upstream. It is now a metaport which will
allow you to select a backend. Further details can be found in the
UPDATING entry.
Original commitRevision:421094 
Monday, 15 Aug 2016
14:11 vsevolod search for other commits by this committer
- Update to 1.3.3
- Add notes in UPDATING about fuzzy storage issue
Original commitRevision:420237 
01:40 junovitch search for other commits by this committer
UPDATING: document PowerDNS changes in the 3.x -> 4.x update

PR:		211147 211148
Submitted by:	Ralf van der Enden <tremere@cainites.net> (PowerDNS maintainer)
Original commitRevision:420210 
Thursday, 11 Aug 2016
20:06 brnrd search for other commits by this committer
security/libressl: Update to 2.4.2

  - Update to latest stable version 2.4.2
  - Add UPDATING entry
  - Remove OPENSSL_VERSION_NUMBER patch
  - Change post-install targets to post-stage where possible
  - Bump libcrypto version in version.mk

PR:		211701
Original commitRevision:420102 
16:39 girgen search for other commits by this committer
The PostgreSQL Global Development Group has released an update to all supported
versions of our database system, including 9.5.4, 9.4.9, 9.3.14, 9.2.18 and
9.1.23. This release fixes two security issues. It also patches a number of
other bugs reported over the last three months. Users who rely on security
isolation between database users should update as soon as possible. Other users
should plan to update at the next convenient downtime.

If you are using the ICU patch, please consult UPDATING.

Improve periodic cleanup, suggested by claudius (at) ambtec.de. [1]

PR:		210941 [1]
Security:	CVE-2016-5423, CVE-2016-5424
Original commitRevision:420089 
Wednesday, 27 Jul 2016
19:36 jkim search for other commits by this committer
Belatedly add a note about emulators/virtualbox-ose upgrade.

Requested by:	Kevin Oberman (rkoberman at gmail dot com)
Original commitRevision:419194 
Friday, 22 Jul 2016
19:24 pawel search for other commits by this committer
Add information about games/stonesoup option organization change

PR:		210670
Submitted by:	Nikolai Lifanov
Original commitRevision:418928 
Monday, 18 Jul 2016
15:26 adamw search for other commits by this committer
Update to 7.5. While here, completely rewrite the Makefile. Use sed
instead of hard patches to minimize maintainership, and drastically
simplify the installation process. Add some OPTIONS to handle
dependencies on country lookups.

Previously, the path to the icons was being manually changed from
".../icon" to ".../icons". With this update, the port now installs
into the default location (.../icon). The awstatsicons alias will
need to be manually updated for existing installations; this is
explained in UPDATING.

Also, I am taking this port from the previous maintainer. It has
been over two years since he responded to a PR, and this is the
third in a row that has had no response. Under section 5.5 of the
PHB, I am considering this port to be abandoned. I'd like to thank
Alex for all the time that he did spend maintaining this port.

PR:		210821
Approved by:	maintainer timeout (2 weeks)
Original commitRevision:418707 
Friday, 8 Jul 2016
12:46 cy search for other commits by this committer
Add a note about of GNU Screen 4.4.0 (r417201) that a change to a
data structure responsible for $TERM handling that is it is impossible
to reattach to screen sessions of older versions of screen.
Original commitRevision:418221 
Monday, 4 Jul 2016
15:00 riggs search for other commits by this committer
Document change of default location for my.cnf for databases/mysql57-*

PR:		209579
Submitted by:	mokhi64@gmail.com
Reviewed by:	rootservice@gmail.com
Original commitRevision:418034 
Friday, 1 Jul 2016
16:28 feld search for other commits by this committer
www/node5: Remoe port

Port has expired and upstream has deprecated this version.

PR:		210737
Original commitRevision:417893 
Wednesday, 29 Jun 2016
01:14 junovitch search for other commits by this committer
UPDATING: Normalize entries missing the trailing colon

The entries without a trailing colon seemed to trip up the output of
`pkg updating -d YYYYMMDD' as reported on freebsd-ports@FreeBSD.org.
Normalize the entries to fix this and for general consistency.

Reported by:	David Wolfskill <david@catwhisker.org>
Original commitRevision:417752 
Monday, 27 Jun 2016
17:04 brd search for other commits by this committer
- Upgrade sysutils/rsyslog8 to 8.19.0 and make it the default
- Mark sysutils/rsyslog7 deprecated.

Approved by:	bdrewery (mentor)
Original commitRevision:417672 
Sunday, 26 Jun 2016
20:28 pi search for other commits by this committer
www/calendarserver: 5.1 -> 8.0

Please note that updating from the previous version (5.1) to the current
version (8.0) requires manual steps. Please consult the pkg-message for
details.

This update has changes since 2013, and upstream does not provide
changelogs.

PR:		210264
Submitted by:	Axel Rau <Axel.Rau@Chaos1.DE> (maintainer)
Original commitRevision:417614 
Friday, 24 Jun 2016
14:13 adamw search for other commits by this committer
Switch zsh back to looking for system-wide files under ${PREFIX}/etc,
rather than /etc. Add an option, ETCDIR, to switch it back to /etc.
Also includes a couple whitespace cleanups. PORTREVISION bump, and a
note in UPDATING.

PR:		201866
Original commitRevision:417423 
11:50 vd search for other commits by this committer
Change AUTHOR: entry in UPDATING to committer

Suggested by:	koobs@
Original commitRevision:417417 
Tuesday, 21 Jun 2016
08:21 tz search for other commits by this committer
www/redmine: Update from 2.6.9 to 3.2.3

Changelog: https://www.redmine.org/projects/redmine/wiki/Changelog

A big thanks for the preparation of that update to swills

PR:          209938
Approved by: swills (ruby, mentor)
Original commitRevision:417191 
08:02 vd search for other commits by this committer
ftp/wget: Upgrade from 1.16.3_1 to 1.18

PR:		210421
Submitted by:	Vladimir Krstulja <vlad-fbsd@acheronmedia.com>
Security:	CVE-2016-4971
Original commitRevision:417188 
Sunday, 19 Jun 2016
12:23 rm search for other commits by this committer
Oops, forgot the UPDATING change to follow up r417115

PR:		210376
Submitted by:	Vladimir Krstulja <vlad-fbsd@acheronmedia.com>
Original commitRevision:417116 
Thursday, 16 Jun 2016
13:22 mat search for other commits by this committer
Add DEFAULT_VERSIONS=ssl=XXX

Move the openssl detection routine to bsd.default-version.mk.
Add warnings telling people to not use WITH_OPENSSL_PORT or
WITH_OPENSSL_BASE.

To ease maintainability, change the way the different ssl libraries
version numbers are checked.

PR:		210149
Submitted by:	mat
Exp-run by:	antoine
Sponsored by:	The FreeBSD Foundation, Absolight
Differential Revision:	https://reviews.freebsd.org/D6577
Original commitRevision:416965 
Tuesday, 14 Jun 2016
19:42 amdmi3 search for other commits by this committer
Trim trailing whitespace

Approved by:	portmgr blanket
Original commitRevision:416907 
15:59 adamw search for other commits by this committer
Add a note about the need to enable BUNDLED_SSL in node* when
LibreSSL is the SSL provider.

PR:		209793
Original commitRevision:416895 
Friday, 10 Jun 2016
19:37 hrs search for other commits by this committer
- Use Github to fetch the distfile.
- Split library part of textproc/xmlroff into textproc/libfo.
Original commitRevision:416689 
Thursday, 9 Jun 2016
19:50 bofh search for other commits by this committer
[NEW] databases/postgresql-repmgr2: 2.X version of postgresql-repmgr

- postgresql-repmgr will be updated to 3.X branch

PR:		201962
Submitted by:	olgeni
Original commitRevision:416623 
Sunday, 5 Jun 2016
22:38 junovitch search for other commits by this committer
www/h2o: update 1.7.3 -> 2.0.0

- explicitly set H2O_PERL via rc.d script

Summary of major changes:
- support for Brotli compression
- directives for file-level resource mapping
- addition of the status handler
- reverse proxying using HTTPS

Changes:	https://github.com/h2o/h2o/releases/tag/v2.0.0

PR:		209927
Submitted by:	Dave Cottlehuber <dch@skunkwerks.at> (maintainer)
Original commitRevision:416438 
Friday, 3 Jun 2016
08:41 brnrd search for other commits by this committer
UPDATING: Fix typo in libressl-devel entry

  - The list is in LibreSSL/Ports not OpenSSL
Original commitRevision:416306 
Wednesday, 1 Jun 2016
17:27 brnrd search for other commits by this committer
security/libressl-devel: Update to 2.4.0

  - Update to latest "unstable" release
  - Remove OPENSSL_VERSION_NUMBER patch
  - Update shlib-versions
  - Add UPDATING entry
Original commitRevision:416252 
Friday, 27 May 2016
15:10 adamw search for other commits by this committer
Add instructions for recent changes to opensmtpd extras, requiring
users to separate arguments with quotes, and to place everything into
a chroot.

Many thanks to fluffy for figuring out these solutions.
Original commitRevision:415940 
Thursday, 26 May 2016
07:15 brnrd search for other commits by this committer
mail/opensmtpd: Update to 5.9.2

  - Update to 5.9.2p1
  - Remove usernamelen patch (default 255+1)
  - Fix renamed configure args
  - Add symlink for makemap (now included in smtpctl)
  - Align versioning with other OpenBSD projects
  - Add _smtpq group
  - Add UPDATING entry for existing installs
  - Update pkg-message for existing installs

Reviewed by:	adamw, mat
Approved by:	adamw, maintainer (implicit)
Differential Revision: D6421
Original commitRevision:415877 
Wednesday, 25 May 2016
19:21 pi search for other commits by this committer
devel/qtcreator: 3.6.0 -> 3.6.1

Changes:
 
http://code.qt.io/cgit/qt-creator/qt-creator.git/tree/dist/changes-3.6.1.md?h=3.6
- Please see UPDATING for the separation of devel/qbs from devel/qtcreator

Submitted by:	Ralf Nolden <nolden@kde.org> (kde)
Original commitRevision:415857 

Number of commits found: 2727 (showing only 100 on this page)

[First Page]  «  3 | 4 | 5 | 6 | 7 | 8 | 9 | 10 | 11 | 12 | 13  »  [Last Page]