notbugAs an Amazon Associate I earn from qualifying purchases.
Want a good read? Try FreeBSD Mastery: Jails (IT Mastery Book 15)
Ukraine
NOTE: There is a known problem on production with searching pkg-plist - it returns no results. This problem is not present on stage.freshports.org
Port details on branch 2022Q3
at-spi2-atk Assisted Technology Provider module for GTK+
2.38.0 accessibility on this many watch lists=15 search for ports that depend on this port Find issues related to this port Report an issue related to this port View this port on Repology. pkg-fallout Version of this port present on the latest quarterly branch.
Maintainer: desktop@FreeBSD.org search for ports maintained by this maintainer
Port Added: 2010-05-10 21:19:33
Last Update: 2022-09-07 21:58:51
Commit Hash: fb16dfe
People watching this port, also watch:: libXdamage, desktop-file-utils, colord, glib, libXcomposite
Also Listed In: x11-toolkits
License: LGPL21
Description:
Homepage    cgit ¦ Codeberg ¦ GitHub ¦ GitLab ¦ SVNWeb
pkg-plist: as obtained via: make generate-plist
Expand this list (14 items)
Collapse this list.
  1. @ldconfig
  2. /usr/local/share/licenses/at-spi2-atk-2.38.0/catalog.mk
  3. /usr/local/share/licenses/at-spi2-atk-2.38.0/LICENSE
  4. /usr/local/share/licenses/at-spi2-atk-2.38.0/LGPL21
  5. include/at-spi2-atk/2.0/atk-bridge.h
  6. lib/libatk-bridge-2.0.so
  7. lib/libatk-bridge-2.0.so.0
  8. lib/libatk-bridge-2.0.so.0.0.0
  9. lib/gnome-settings-daemon-3.0/gtk-modules/at-spi2-atk.desktop
  10. lib/gtk-2.0/modules/libatk-bridge.so
  11. libdata/pkgconfig/atk-bridge-2.0.pc
  12. @owner
  13. @group
  14. @mode
Collapse this list.
Dependency lines:
  • at-spi2-atk>0:accessibility/at-spi2-atk
To install the port:
cd /usr/ports/accessibility/at-spi2-atk/ && make install clean
To add the package, run one of these commands:
  • pkg install accessibility/at-spi2-atk
  • pkg install at-spi2-atk
NOTE: If this package has multiple flavors (see below), then use one of them instead of the name specified above.
PKGNAME: at-spi2-atk
Flavors: there is no flavor information for this port.
distinfo:

Packages (timestamps in pop-ups are UTC):
at-spi2-atk
ABIlatestquarterly
FreeBSD:11:aarch642.24.02.34.2
FreeBSD:11:amd642.34.22.34.2
FreeBSD:11:armv62.18.12.34.2
FreeBSD:11:i3862.34.22.34.2
FreeBSD:11:mipspkg-falloutpkg-fallout
FreeBSD:11:mips64pkg-falloutpkg-fallout
FreeBSD:12:aarch642.26.22.38.0
FreeBSD:12:amd642.38.02.38.0
FreeBSD:12:armv62.26.22.34.2
FreeBSD:12:armv72.26.22.34.2
FreeBSD:12:i3862.38.02.38.0
FreeBSD:12:mipspkg-falloutpkg-fallout
FreeBSD:12:mips64pkg-falloutpkg-fallout
FreeBSD:12:powerpc64pkg-fallout2.34.2
FreeBSD:13:aarch642.38.02.38.0
FreeBSD:13:amd642.38.02.38.0
FreeBSD:13:armv62.34.22.34.2
FreeBSD:13:armv72.38.02.38.0
FreeBSD:13:i3862.38.02.38.0
FreeBSD:13:mipspkg-falloutpkg-fallout
FreeBSD:13:mips64pkg-falloutpkg-fallout
FreeBSD:13:powerpc64pkg-fallout2.34.2
FreeBSD:13:riscv64pkg-fallout2.34.2
FreeBSD:14:aarch642.38.0pkg-fallout
FreeBSD:14:amd642.38.0pkg-fallout
FreeBSD:14:armv62.38.0pkg-fallout
FreeBSD:14:armv72.38.0pkg-fallout
FreeBSD:14:i3862.38.0pkg-fallout
FreeBSD:14:mipspkg-falloutpkg-fallout
FreeBSD:14:mips64pkg-falloutpkg-fallout
FreeBSD:14:powerpc642.34.2pkg-fallout
FreeBSD:14:riscv642.34.2pkg-fallout
 

Dependencies
NOTE: FreshPorts displays only information on required and default dependencies. Optional dependencies are not covered.
Build dependencies:
  1. at-spi2-core>=2.17.90 : accessibility/at-spi2-core
  2. intltool-extract : textproc/intltool
  3. meson>=0.57.1_1 : devel/meson
  4. ninja : devel/ninja
  5. pkgconf>=1.3.0_1 : devel/pkgconf
Runtime dependencies:
  1. at-spi2-core>=2.17.90 : accessibility/at-spi2-core
Library dependencies:
  1. libdbus-1.so : devel/dbus
  2. libintl.so : devel/gettext-runtime
  3. libatk-1.0.so : accessibility/atk
  4. libglib-2.0.so : devel/glib20
  5. libintl.so : devel/gettext-runtime
This port is required by:
for Libraries
  1. devel/electron18
  2. devel/electron19
  3. devel/qt6-base
  4. editors/vscode
  5. net-im/signal-desktop
  6. science/zotero
  7. www/chromium
Expand this list (23 items / 16 hidden - sorry, this count includes any deleted ports)
  1. Collapse this list).
  2. www/iridium
  3. www/ungoogled-chromium
  4. x11/cinnamon
  5. x11/gnome-shell
  6. x11-toolkits/gtk30
  7. Collapse this list.

Deleted ports which required this port:

Expand this list of 11 deleted ports
  1. devel/electron11*
  2. devel/electron12*
  3. devel/electron13*
  4. devel/electron17*
  5. devel/electron4*
  6. devel/electron5*
  7. devel/electron6*
  8. devel/electron7*
  9. devel/electron9*
  10. editors/atom*
  11. x11-toolkits/gtkada3*
  12. Collapse this list of deleted ports.
for Run

Deleted ports which required this port:

Expand this list of 1 deleted port
  1. accessibility/at-spi*
  2. Collapse this list of deleted ports.
* - deleted ports are only shown under the This port is required by section. It was harder to do for the Required section. Perhaps later...

Configuration Options:
Options name:

USES:

FreshPorts was unable to extract/find any pkg message

Master Sites:
Expand this list (13 items)
Collapse this list.
  1. ftp://ftp.belnet.be/mirror/ftp.gnome.org/sources/at-spi2-atk/2.38/
  2. ftp://ftp.cse.buffalo.edu/pub/Gnome/sources/at-spi2-atk/2.38/
  3. ftp://ftp.kddlabs.co.jp/pub/GNOME/sources/at-spi2-atk/2.38/
  4. ftp://ftp.mirrorservice.org/sites/ftp.gnome.org/pub/GNOME/sources/at-spi2-atk/2.38/
  5. ftp://ftp.nara.wide.ad.jp/pub/X11/GNOME/sources/at-spi2-atk/2.38/
  6. http://download.gnome.org/sources/at-spi2-atk/2.38/
  7. http://ftp.belnet.be/mirror/ftp.gnome.org/sources/at-spi2-atk/2.38/
  8. http://www.gtlib.gatech.edu/pub/gnome/sources/at-spi2-atk/2.38/
  9. https://download.gnome.org/sources/at-spi2-atk/2.38/
  10. https://fr2.rpmfind.net/linux/gnome.org/sources/at-spi2-atk/2.38/
  11. https://ftp.acc.umu.se/pub/GNOME/sources/at-spi2-atk/2.38/
  12. https://ftp.gnome.org/pub/GNOME/sources/at-spi2-atk/2.38/
  13. https://gitlab.gnome.org/GNOME/at-spi2-atk/-/archive/2.38.0/
Collapse this list.

There are no commits on branch 2022Q3 for this port