notbugAs an Amazon Associate I earn from qualifying purchases.
Want a good read? Try FreeBSD Mastery: Jails (IT Mastery Book 15)
Port details
qt5-serialbus Qt functions to access industrial bus systems
5.13.2 comms on this many watch lists=0 search for ports that depend on this port Find issues related to this port Report an issue related to this port 5.12.2Version of this port present on the latest quarterly branch.
Maintainer: kde@FreeBSD.org search for ports maintained by this maintainer
Port Added: 2016-09-17 09:47:11
Last Update: 2019-11-08 16:59:59
SVN Revision: 517080
License: LGPL21
Description:
SVNWeb : Homepage
pkg-plist: as obtained via: make generate-plist
Expand this list (86 items)
  1. @ldconfig
  2. /usr/local/share/licenses/qt5-serialbus-5.13.2/catalog.mk
  3. /usr/local/share/licenses/qt5-serialbus-5.13.2/LICENSE
  4. /usr/local/share/licenses/qt5-serialbus-5.13.2/LGPL21
  5. lib/qt5/bin/canbusutil
  6. include/qt5/QtSerialBus/5.13.2/QtSerialBus/private/qcanbusdevice_p.h
  7. include/qt5/QtSerialBus/5.13.2/QtSerialBus/private/qcanbusdeviceinfo_p.h
  8. include/qt5/QtSerialBus/5.13.2/QtSerialBus/private/qmodbus_symbols_p.h
  9. include/qt5/QtSerialBus/5.13.2/QtSerialBus/private/qmodbusadu_p.h
  10. include/qt5/QtSerialBus/5.13.2/QtSerialBus/private/qmodbusclient_p.h
  11. include/qt5/QtSerialBus/5.13.2/QtSerialBus/private/qmodbuscommevent_p.h
  12. include/qt5/QtSerialBus/5.13.2/QtSerialBus/private/qmodbusdevice_p.h
  13. include/qt5/QtSerialBus/5.13.2/QtSerialBus/private/qmodbusrtuserialmaster_p.h
  14. include/qt5/QtSerialBus/5.13.2/QtSerialBus/private/qmodbusrtuserialslave_p.h
  15. include/qt5/QtSerialBus/5.13.2/QtSerialBus/private/qmodbusserver_p.h
  16. include/qt5/QtSerialBus/5.13.2/QtSerialBus/private/qmodbustcpclient_p.h
  17. include/qt5/QtSerialBus/5.13.2/QtSerialBus/private/qmodbustcpserver_p.h
  18. include/qt5/QtSerialBus/5.13.2/QtSerialBus/private/qtserialbus-config_p.h
  19. include/qt5/QtSerialBus/QCanBus
  20. include/qt5/QtSerialBus/QCanBusDevice
  21. include/qt5/QtSerialBus/QCanBusDeviceInfo
  22. include/qt5/QtSerialBus/QCanBusFactory
  23. include/qt5/QtSerialBus/QCanBusFactoryV2
  24. include/qt5/QtSerialBus/QCanBusFrame
  25. include/qt5/QtSerialBus/QModbusClient
  26. include/qt5/QtSerialBus/QModbusDataUnit
  27. include/qt5/QtSerialBus/QModbusDataUnitMap
  28. include/qt5/QtSerialBus/QModbusDevice
  29. include/qt5/QtSerialBus/QModbusDeviceIdentification
  30. include/qt5/QtSerialBus/QModbusExceptionResponse
  31. include/qt5/QtSerialBus/QModbusPdu
  32. include/qt5/QtSerialBus/QModbusReply
  33. include/qt5/QtSerialBus/QModbusRequest
  34. include/qt5/QtSerialBus/QModbusResponse
  35. include/qt5/QtSerialBus/QModbusRtuSerialMaster
  36. include/qt5/QtSerialBus/QModbusRtuSerialSlave
  37. include/qt5/QtSerialBus/QModbusServer
  38. include/qt5/QtSerialBus/QModbusTcpClient
  39. include/qt5/QtSerialBus/QModbusTcpConnectionObserver
  40. include/qt5/QtSerialBus/QModbusTcpServer
  41. include/qt5/QtSerialBus/QtSerialBus
  42. include/qt5/QtSerialBus/QtSerialBusDepends
  43. include/qt5/QtSerialBus/QtSerialBusVersion
  44. include/qt5/QtSerialBus/qcanbus.h
  45. include/qt5/QtSerialBus/qcanbusdevice.h
  46. include/qt5/QtSerialBus/qcanbusdeviceinfo.h
  47. include/qt5/QtSerialBus/qcanbusfactory.h
  48. include/qt5/QtSerialBus/qcanbusframe.h
  49. include/qt5/QtSerialBus/qmodbusclient.h
  50. include/qt5/QtSerialBus/qmodbusdataunit.h
  51. include/qt5/QtSerialBus/qmodbusdevice.h
  52. include/qt5/QtSerialBus/qmodbusdeviceidentification.h
  53. include/qt5/QtSerialBus/qmodbuspdu.h
  54. include/qt5/QtSerialBus/qmodbusreply.h
  55. include/qt5/QtSerialBus/qmodbusrtuserialmaster.h
  56. include/qt5/QtSerialBus/qmodbusrtuserialslave.h
  57. include/qt5/QtSerialBus/qmodbusserver.h
  58. include/qt5/QtSerialBus/qmodbustcpclient.h
  59. include/qt5/QtSerialBus/qmodbustcpserver.h
  60. include/qt5/QtSerialBus/qserialbusglobal.h
  61. include/qt5/QtSerialBus/qtserialbus-config.h
  62. include/qt5/QtSerialBus/qtserialbusglobal.h
  63. include/qt5/QtSerialBus/qtserialbusversion.h
  64. lib/cmake/Qt5SerialBus/Qt5SerialBusConfig.cmake
  65. lib/cmake/Qt5SerialBus/Qt5SerialBusConfigVersion.cmake
  66. lib/cmake/Qt5SerialBus/Qt5SerialBus_PassThruCanBusPlugin.cmake
  67. lib/cmake/Qt5SerialBus/Qt5SerialBus_PeakCanBusPlugin.cmake
  68. lib/cmake/Qt5SerialBus/Qt5SerialBus_TinyCanBusPlugin.cmake
  69. lib/cmake/Qt5SerialBus/Qt5SerialBus_VirtualCanBusPlugin.cmake
  70. lib/qt5/libQt5SerialBus.prl
  71. lib/qt5/libQt5SerialBus.so
  72. lib/qt5/libQt5SerialBus.so.5
  73. lib/qt5/libQt5SerialBus.so.5.13
  74. lib/qt5/libQt5SerialBus.so.5.13.2
  75. @comment lib/qt5/libQt5SerialBus.so.5.13.2.debug
  76. lib/qt5/mkspecs/modules/qt_lib_serialbus.pri
  77. lib/qt5/mkspecs/modules/qt_lib_serialbus_private.pri
  78. lib/qt5/plugins/canbus/libqtpassthrucanbus.so
  79. @comment lib/qt5/plugins/canbus/libqtpassthrucanbus.so.debug
  80. lib/qt5/plugins/canbus/libqtpeakcanbus.so
  81. @comment lib/qt5/plugins/canbus/libqtpeakcanbus.so.debug
  82. lib/qt5/plugins/canbus/libqttinycanbus.so
  83. @comment lib/qt5/plugins/canbus/libqttinycanbus.so.debug
  84. lib/qt5/plugins/canbus/libqtvirtualcanbus.so
  85. @comment lib/qt5/plugins/canbus/libqtvirtualcanbus.so.debug
  86. libdata/pkgconfig/Qt5SerialBus.pc
Collapse this list.
Dependency lines:
  • qt5-serialbus>0:comms/qt5-serialbus
To install the port: cd /usr/ports/comms/qt5-serialbus/ && make install clean
To add the package: pkg install qt5-serialbus
PKGNAME: qt5-serialbus
Flavors: there is no flavor information for this port.
distinfo:

Dependencies
NOTE: FreshPorts displays only information on required and default dependencies. Optional dependencies are not covered.
Build dependencies:
  1. moc : devel/qt5-buildtools
  2. qmake : devel/qt5-qmake
Runtime dependencies:
  1. qtchooser : misc/qtchooser
Library dependencies:
  1. libQt5Core.so : devel/qt5-core
  2. libQt5Network.so : net/qt5-network
  3. libQt5SerialPort.so : comms/qt5-serialport
This port is required by:
for Libraries
  1. net/savvycan
for Run
  1. devel/qt5

Configuration Options

USES:

Master Sites:
  1. http://master.qt.io/official_releases/qt/5.13/5.13.2/submodules//
  2. http://qtmirror.ics.com/pub/qtproject/official_releases/qt/5.13/5.13.2/submodules//
  3. http://www.nic.funet.fi/pub/mirrors/download.qt-project.org/official_releases/qt/5.13/5.13.2/submodules//
  4. https://download.qt.io/official_releases/qt/5.13/5.13.2/submodules//
  5. https://ftp.jaist.ac.jp/pub/qtproject/official_releases/qt/5.13/5.13.2/submodules//
  6. https://www.mirrorservice.org/sites/download.qt-project.org/official_releases/qt/5.13/5.13.2/submodules//

Number of commits found: 18

Commit History - (may be incomplete: see SVNWeb link above for full details)
DateByDescription
08 Nov 2019 16:59:59
Original commit files touched by this commit  5.13.2
Revision:517080
tcberner search for other commits by this committer
Update Qt5 to 5.13.2

Announcement:
        https://www.qt.io/blog/qt-5.13.2-released

Thanks to kai@ for updating webengine.

PR:		241649
Exp-run by:	antoine
01 Oct 2019 04:13:31
Original commit files touched by this commit  5.13.0_1
Revision:513447
tcberner search for other commits by this committer
Qt5 update to 5.13.0

For new features, check: https://wiki.qt.io/New_Features_in_Qt_5.13

Thanks to adridg who helped to fix a lot of packages.

Exp-run by:	antoine
PR:		238782
26 Jul 2019 20:46:57
Original commit files touched by this commit  5.12.2_1
Revision:507372
gerald search for other commits by this committer
Bump PORTREVISION for ports depending on the canonical version of GCC
as defined in Mk/bsd.default-versions.mk which has moved from GCC 8.3
to GCC 9.1 under most circumstances now after revision 507371.

This includes ports
 - with USE_GCC=yes or USE_GCC=any,
 - with USES=fortran,
 - using Mk/bsd.octave.mk which in turn features USES=fortran, and
 - with USES=compiler specifying openmp, nestedfct, c11, c++0x, c++11-lang,
   c++11-lib, c++14-lang, c++17-lang, or gcc-c++11-lib
plus, everything INDEX-11 shows with a dependency on lang/gcc9 now.

PR:		238330
12 Feb 2019 17:43:00
Original commit files touched by this commit  5.12.1
Revision:492793
tcberner search for other commits by this committer
Update Qt5 to 5.12.1

Release announcement:
  https://blog.qt.io/blog/2019/02/01/qt-5-12-1-released/
Changelog:
  https://wiki.qt.io/Qt_5.12.1_Change_Files

- A change was required to qt-dist.mk to always pass LOCALBASE to qmake,
  as Qt5 has been installed to a prefix for some time now, there should
  not be any harm in that, with respect to it picking up installed versions
  of itself during build.

PR:		235622
Exp-run by:	antoine
16 Jan 2019 11:13:45
Original commit files touched by this commit  5.12.0_2
Revision:490472
tijl search for other commits by this committer
Fix Qt5 symbol version scripts to put the catch-all clause first.  When
a symbol matches multiple clauses the last one takes precedence.  If the
catch-all is last it captures everything.  In the case of Qt5 libraries
this caused all symbols to have a Qt_5 label while some should have
Qt_5_PRIVATE_API.  This only affects lld because GNU ld always gives the
catch-all lowest priority.

Older versions of Qt5Webengine exported some memory allocation symbols from
the bundled Chromium.  Version 5.9 stopped exporting these [1] but the
symbols were kept as weak wrappers for the standard allocation functions to
maintain binary compatibility. [2][3]  The problem is that the call to the
standard function in these weak wrappers is only resolved to the standard
function if there's a call to this standard function in other parts of
Qt5Webengine, because only then is there a non-weak symbol that takes
precedence over the weak one.  If there's no such non-weak symbol the call
(Only the first 15 lines of the commit message are shown above View all of this commit message)
16 Dec 2018 14:49:16
Original commit files touched by this commit  5.12.0_1
Revision:487594
tcberner search for other commits by this committer
Update Qt5 to 5.12.0

http://blog.qt.io/blog/2018/12/06/qt-5-12-lts-released/

- This breaks support for libressl again. Patches are welcome.

PR:		233705
Exp-run by:	antoine
12 Dec 2018 01:35:36
Original commit files touched by this commit  5.11.2_1
Revision:487272
gerald search for other commits by this committer
Bump PORTREVISION for ports depending on the canonical version of GCC
defined via Mk/bsd.default-versions.mk which has moved from GCC 7.4 t
GCC 8.2 under most circumstances.

This includes ports
 - with USE_GCC=yes or USE_GCC=any,
 - with USES=fortran,
 - using Mk/bsd.octave.mk which in turn features USES=fortran, and
 - with USES=compiler specifying openmp, nestedfct, c11, c++0x, c++11-lang,
   c++11-lib, c++14-lang, c++17-lang, or gcc-c++11-lib
plus, as a double check, everything INDEX-11 showed depending on lang/gcc7.

PR:		231590
09 Sep 2018 11:12:15
Original commit files touched by this commit  5.11.1
Revision:479286
tcberner search for other commits by this committer
Update Qt5 to 5.11.1

Big thanks to
        * brnrd for the libressl patches in net/qt5-network
        * jhale for fixing the bulk load of ports

PR:		230884
Exp-run by:	antoine
29 Jul 2018 22:18:46
Original commit files touched by this commit  5.10.1_1
Revision:475857
gerald search for other commits by this committer
Bump PORTREVISION for ports depending on the canonical version of GCC
in the ports tree (via Mk/bsd.default-versions.mk and lang/gcc) which
has now moved from GCC 6 to GCC 7 by default.

This includes ports
 - featuring USE_GCC=yes or USE_GCC=any,
 - featuring USES=fortran,
 - using Mk/bsd.octave.mk which in turn features USES=fortran, and those
 - with USES=compiler specifying one of openmp, nestedfct, c11, c++0x,
   c++11-lib, c++11-lang, c++14-lang, c++17-lang, or gcc-c++11-lib.

PR:		222542
28 Jun 2018 17:39:55
Original commit files touched by this commit  5.10.1
Revision:473503
tcberner search for other commits by this committer
Replace bsd.qt.mk by Uses/qt.mk and Uses/qt-dist.mk

From now on, ports that depend on Qt4 will have to set
	USES=		qt:4
	USE_QT=		foo bar
ports depending on Qt5 will use
	USES=		qt:5
	USE_QT=		foo bar

PR:		229225
Exp-run by:	antoine
Reviewed by:	mat
Approved by:	portmgr (antoine)
Differential Revision:	-https://reviews.freebsd.org/D15540
18 May 2018 12:27:44
Original commit files touched by this commit  5.10.1
Revision:470288
rakuco search for other commits by this committer
Update the Qt5 ports to 5.10.1.

The work was done by tcberner and myself, with thanks to antoine for the
exp-run.

Not a lot to report compared to other Qt5 updates:
* net/qt5-network is still broken with LibreSSL. I said this in a commit
  message ages ago but it bears repeating: upstream is open to adding support
  for LibreSSL, but someone needs to step up to maintain it upstream, otherwise
  things will continue to be broken all the time.
* www/qt5-webengine is a huge monster that is terrible to update, just like
  www/chromium itself is. We (kde@) have decided to keep using the 5.9 series
  for the time being, as it should be compatible with the rest of Qt anyway. It
  was updated to 5.9.5, the latest 5.9 release at the time of writing.

PR:		228213
29 Mar 2018 19:03:18
Original commit files touched by this commit  5.9.4_1
Revision:465911
tcberner search for other commits by this committer
Fix permissions in installed Qt5 header files

For the qt5-* ports bsd.qt.mk sets EXTRACT_AFTER_ARGS, and
thereby does not get the normal default value of
      --no-same-owner --no-same-permissions
passed when extracting. This lead to for example header files
being installed (i.e. copied), with permissions group write
permissions.

Manually append that to the bsd.qt.mk shenanigans (also do the
same in www/qt5-webchannel, which opts out of the bsd.qt.mk value)

PR:		227027
Reported by:	grarpamp@gmail.com
06 Jan 2018 21:30:33
Original commit files touched by this commit  5.9.3
Revision:458293
rakuco search for other commits by this committer
Update Qt5 ports to 5.9.3.

This took quite a lot of time because Qt's own build system underwent
several changes in 5.8.0 that took a while to adapt to.

And, of course, qt5-webengine is a behemoth that we need to patch like crazy
due to its bundling of Chromium. In fact, most of the Chromium patches in
qt5-webengine have been imported with no changes from www/chromium@433510
("www/chromium: update to 56.0.2924.87").

New port: accessibility/qt5-speech

Bigger changes to Qt5 ports we had to make:
- Qt now allows using a configure.json file to define configuration options
  and specify configuration checks that can be done when qmake is invoked.
(Only the first 15 lines of the commit message are shown above View all of this commit message)
01 Jan 2018 13:13:55
Original commit files touched by this commit  5.7.1_3
Revision:457773
rakuco search for other commits by this committer
Build the entire code instead of just src/serialbus.

The CAN code might not be entirely working on FreeBSD (I have not checked), but
there is no reason not to build it and have it be tested more widely.

Reviewed by:	tcberner, adridg
Differential Revision:	https://reviews.freebsd.org/D13107
10 Sep 2017 20:55:39
Original commit files touched by this commit  5.7.1_2
Revision:449591
gerald search for other commits by this committer
Bump PORTREVISION for ports depending on the canonical version of GCC
(via Mk/bsd.default-versions.mk and lang/gcc) which has moved from
GCC 5.4 to GCC 6.4 under most circumstances.

This includes ports
 - with USE_GCC=yes or USE_GCC=any,
 - with USES=fortran,
 - using Mk/bsd.octave.mk which in turn features USES=fortran, and
 - with USES=compiler specifying openmp, nestedfct, c++11-lib, c++11-lang,
   c++14-lang, c++0x, c11, or gcc-c++11-lib.

PR:		219275
01 Apr 2017 15:23:32
Original commit files touched by this commit  5.7.1_1
Revision:437439
gerald search for other commits by this committer
Bump PORTREVISIONs for ports depending on the canonical version of GCC and
lang/gcc which have moved from GCC 4.9.4 to GCC 5.4 (at least under some
circumstances such as versions of FreeBSD or platforms).

This includes ports
 - with USE_GCC=yes or USE_GCC=any,
 - with USES=fortran,
 - using using Mk/bsd.octave.mk which in turn has USES=fortran, and
 - with USES=compiler specifying openmp, nestedfct, c++11-lib, c++14-lang,
   c++11-lang, c++0x, c11, or gcc-c++11-lib.

PR:		216707
18 Feb 2017 19:48:05
Original commit files touched by this commit  5.7.1
Revision:434380
tcberner search for other commits by this committer
Update Qt5 to 5.7.1, and unify the Qt4 and Qt5 ports some more

* Update Qt5 to 5.7.1
* Move Qt4 binaries to lib/qt4/bin
* Move Qt5 libraries to lib/qt5/lib
  By moving the libraries we should finally be able to get rid of the inplace
  upgrade bug (see ports bugs 194088, 195105 and 198720):  when Qt5's libraries
  were lying in /usr/local/lib, which would often get added by pkgconfig to the
  linker paths via dependencies, the already installed libraries were linked
  against, instead of the ones that were being built. This forced us to make
  sure, that -L${WRKSRC}/lib was always coming before -L/usr/local/lib in the
  linker flags. With this change this should no longer be the case.
* Rename some ports to match the rest (foo-qtX -> qtX-foo)
* Depend on new port misc/qtchooser [see UPDATING & CHANGES]

There are several new Qt5 ports which all have been created by Marie Loise
Nolden
<nolden@kde.org>. Thanks again.

PR:		216797
Exp-Run by:	antoine
Reviewed by:	rakuco, mat, groot_kde.org
Approved by:	rakuco (mentor)
Differential Revision:	https://reviews.freebsd.org/D9213
17 Sep 2016 09:46:54
Original commit files touched by this commit  5.6.1
Revision:422306
rakuco search for other commits by this committer
Update the Qt5 ports to 5.6.1.

This took longer than expected, but there are quite a few changes to the
existing ports and a few new ones.

General upstream changes:
- Starting with Qt 5.6.2, Qt will fail at configuration time if LibreSSL is
  being used. According to the discussion here:
  https://codereview.qt-project.org/#/c/154800/
  The Qt project is not opposed to LibreSSL, but does not want to mix
  support for it into the OpenSSL backend code, especially as they move
  towards supporting OpenSSL 1.1.
  People interested in LibreSSL support are welcome to submit a separate
  backend upstream, but are expected to maintain it. We (kde@) are not
  opposed to carrying some patches authored by others in the future, as long
(Only the first 15 lines of the commit message are shown above View all of this commit message)

Number of commits found: 18

Login
User Login
Create account

Servers and bandwidth provided by
New York Internet, iXsystems, and RootBSD

This site
What is FreshPorts?
About the authors
Issues
FAQ
How big is it?
The latest upgrade!
Privacy
Forums
Blog
Contact

Search
Enter Keywords:
 
more...

Latest Vulnerabilities
gcpioNov 15
libmadNov 13
chromiumNov 12
wordpressNov 12
wordpressNov 12
wordpressNov 12
wordpressNov 12
wordpressNov 12
nexus2-ossNov 07
php71Nov 06
php72Nov 06
php73Nov 06
php74Nov 06
fileNov 02
mariadb101-serverNov 02

8 vulnerabilities affecting 170 ports have been reported in the past 14 days

* - modified, not new

All vulnerabilities

Last updated:
2019-11-15 22:48:54


Ports
Home
Categories
Deleted ports
Sanity Test Failures
Newsfeeds

Statistics
Graphs
NEW Graphs (Javascript)
Traffic

Calculated hourly:
Port count 38069
Broken 778
Deprecated 95
Ignore 1048
Forbidden 3
Restricted 156
No CDROM 72
Vulnerable 33
Expired 7
Set to expire 65
Interactive 0
new 24 hours 0
new 48 hours9
new 7 days33
new fortnight60
new month124

Servers and bandwidth provided by
New York Internet, iXsystems, and RootBSD
Valid HTML, CSS, and RSS.
Copyright © 2000-2019 Dan Langille. All rights reserved.