notbugIf you buy from Amazon USA, please support us by using this link.
Port details
pecl-rrd1 PHP bindings to rrd tool system
1.1.3 databases on this many watch lists=0 search for ports that depend on this port Find issues related to this port Report an issue related to this port
Maintainer: daniel@blodan.se search for ports maintained by this maintainer
Port Added: 07 Sep 2017 14:32:42
Also Listed In: pear
License: PHP301
Procedural and simple OO wrapper for rrdtool - data logging and graphing system
for time series data.

WWW: http://www.pecl.php.net/package/rrd/
SVNWeb : Homepage : PortsMon
There is no configure plist information for this port

To install the port: cd /usr/ports/databases/pecl-rrd1/ && make install clean
To add the package: pkg install php56-pecl-rrd

PKGNAME: php56-pecl-rrd

distinfo:

TIMESTAMP = 1504786291
SHA256 (PECL/rrd-1.1.3.tgz) = 0415ac51e09fe2e7a999d155d10d6af42ddf40ab0b4847a63ed1f9458533858e
SIZE (PECL/rrd-1.1.3.tgz) = 19229


NOTE: FreshPorts displays only information on required and default dependencies. Optional dependencies are not covered.

Build dependencies:
  1. phpize : lang/php56
  2. autoconf>0 : devel/autoconf
  3. pkgconf>=1.3.0_1 : devel/pkgconf
Runtime dependencies:
  1. php.h : lang/php56
Library dependencies:
  1. librrd.so : databases/rrdtool
There are no ports dependent upon this port

Configuration Options
     No options to configure

USES:
php:pecl localbase pkgconfig

Master Sites:
  1. http://pecl.php.net/get/
Notes from UPDATING
These upgrade notes are taken from /usr/ports/UPDATING
  • 2018-03-08
    Affects: */php* */pecl* */pear*
    Author: mat@FreeBSD.org
    Reason: 
      PHP extensions and modules have been flavored.
    
      People using Poudriere 3.2+ and binary packages do not have to do anything if
      they are using PHP applications.
    
      PHP modules and extensions may have change their names from php5- or php7- to
      fully versionned phpXY-.
      PECL extensions and PEAR modules package names have changed from pecl- and
      pear- to phpXX-pecl and phpXX-pear-.
    
      To rename an installed package to match the new naming scheme, for example,
      for the imagick pecl extension, run:
    
        # pkg set -n pecl-imagick:php56-pecl-imagick
    
      For other people, to build the PHP 7.2 version of, for example,
      databases/php-memcached, you need to run:
    
        # make FLAVOR=php72 install
    
    

Number of commits found: 5

Commit History - (may be incomplete: see SVNWeb link above for full details)
DateByDescription
08 Oct 2018 15:08:13
Original commit files touched by this commit  1.1.3
Revision:481545
antoine search for other commits by this committer
Fix some PKGNAME collisions
08 Mar 2018 19:48:41
Original commit files touched by this commit  1.1.3
Revision:463917
mat search for other commits by this committer
Introduce PHP flavors.

  Ports using USES=php:phpize, php:ext, php:zend, and php:pecl are now
  flavored.  They will automatically get flavors (php56, php70, php71, php72)
  depending of the versions they support (set with IGNORE_WITH_PHP).  As a
  consequence, ports using USES=pear and USES=horde are also flavored.

PR:		226242
Submitted by:	mat
Exp-run by:	antoine
Approved by:	portmgr
Sponsored by:	Absolight
Differential Revision:	https://reviews.freebsd.org/D14208
14 Dec 2017 13:57:29
Original commit files touched by this commit  1.1.3
Revision:456296
tz search for other commits by this committer
Add missing IGNORE_WITH_PHP for various pecl-ports.

After testing every pecl-* port with PHP 5.6, 7.0, 7.1 and 7.2
i set the IGNORE_WITH_PHP accordingly to the fallout.

PR:          222165
Reported by: brnd
Approved by: portmgr (blanket)
Differential Revision: https://reviews.freebsd.org/D13476
07 Sep 2017 19:42:25
Original commit files touched by this commit  1.1.3
Revision:449415
antoine search for other commits by this committer
Fix PKGBASE collision with databases/pecl-rrd
07 Sep 2017 14:32:28
Original commit files touched by this commit  1.1.3
Revision:449400
jrm search for other commits by this committer
New port, databases/pecl-rrd1: Copied from databases/pecl-rrd, so that
databases/pecl-rrd can be updated to version 2.0.1.  Separate ports are
needed because databases/pecl-rrd does not support php 5.6 and
databases/pecl-rrd1 does not support php 7.0 and 7.1.

PR:		219939
Submitted by:	daniel@blodan.se (maintainer)

Number of commits found: 5

Login
User Login
Create account

Servers and bandwidth provided by
New York Internet, SuperNews, and RootBSD

This site
What is FreshPorts?
About the authors
Issues
FAQ
How big is it?
The latest upgrade!
Privacy
Forums
Blog
Contact

Search
Enter Keywords:
 
more...

Latest Vulnerabilities
mariadb100-serverOct 20
mariadb101-serverOct 20
mariadb102-serverOct 20
mariadb103-serverOct 20
mariadb55-serverOct 20
mysql55-serverOct 20
mysql56-serverOct 20
mysql57-serverOct 20
mysql80-serverOct 20
percona55-serverOct 20
percona56-serverOct 20
percona57-serverOct 20
ruby23Oct 20
ruby24Oct 20
libsshOct 17

8 vulnerabilities affecting 97 ports have been reported in the past 14 days

* - modified, not new

All vulnerabilities

Last updated:
2018-10-20 16:03:41


Ports
Home
Categories
Deleted ports
Sanity Test Failures
Newsfeeds

Statistics
Graphs
NEW Graphs (Javascript)
Traffic

Calculated hourly:
Port count 35717
Broken 62
Deprecated 522
Ignore 348
Forbidden 3
Restricted 162
No CDROM 74
Vulnerable 44
Expired 4
Set to expire 495
Interactive 0
new 24 hours 7
new 48 hours15
new 7 days52
new fortnight146
new month232

Servers and bandwidth provided by
New York Internet, SuperNews, and RootBSD
Valid HTML, CSS, and RSS.
Copyright © 2000-2018 Dan Langille. All rights reserved.