notbugAs an Amazon Associate I earn from qualifying purchases.
Want a good read? Try FreeBSD Mastery: Jails (IT Mastery Book 15)

Why was the website so slow for so long?

The cause of the slowdown was a change to the ZFS dataset. In conjunction with the database server, very little caching was being done. This combination resulted in increased disk I/O as the system churned through the database. Details in the blog post which outlines the various things which changed. Many graphs.

Port details
rubygem-activerecord-mysql-adapter ActiveRecord adapter for MySQL, based on mysql gem
0.0.1 databases Deleted on this many watch lists=0 search for ports that depend on this port Find issues related to this port Report an issue related to this port 0.0.1Version of this port present on the latest quarterly branch.
Deprecated DEPRECATED: Depends on deprecated databases/rubygem-activerecord
Expired This port expired on: 2017-01-07
Maintainer: ruby@FreeBSD.org search for ports maintained by this maintainer
Port Added: 2013-03-17 20:28:38
Last Update: 2017-01-07 15:39:26
SVN Revision: 430809
Also Listed In: rubygems
License: MIT
Description:
SVNWeb : Homepage

There is no configure plist information for this port.

Dependency lines:
  • rubygem-activerecord-mysql-adapter>0:databases/rubygem-activerecord-mysql-adapter
No installation instructions: this port has been deleted.
The package name of this deleted port was:
PKGNAME: rubygem-activerecord-mysql-adapter
Flavors: there is no flavor information for this port.
distinfo:

Dependencies
NOTE: FreshPorts displays only information on required and default dependencies. Optional dependencies are not covered.
Build dependencies:
  1. ruby22 : lang/ruby22
  2. gem22 : devel/ruby-gems
Runtime dependencies:
  1. rubygem-activerecord>=3.2.9 : databases/rubygem-activerecord
  2. rubygem-activesupport>=3.2.9 : devel/rubygem-activesupport
  3. rubygem-mysql>=2.9.0 : databases/rubygem-mysql
  4. ruby22 : lang/ruby22
  5. gem22 : devel/ruby-gems
Patch dependencies:
  1. ruby22 : lang/ruby22
  2. gem22 : devel/ruby-gems
Extract dependencies:
  1. ruby22 : lang/ruby22
There are no ports dependent upon this port

Configuration Options

USES:

Master Sites:
  1. https://rubygems.global.ssl.fastly.net/gems/
Port Moves
  • port deleted on 2017-01-07
    REASON: Has expired: Depends on deprecated databases/rubygem-activerecord

Number of commits found: 10

Commit History - (may be incomplete: see SVNWeb link above for full details)
DateByDescription
07 Jan 2017 15:39:26
Original commit files touched by this commit  0.0.1
Revision:430809
rene search for other commits by this committer
Remove expired ports:
2017-01-07 databases/rubygem-dm-rails: Depends on deprecated
www/rubygem-actionpack
2017-01-07 databases/rubygem-activerecord: Upstream support ended
2017-01-07 devel/rubygem-activesupport: Upstream support ended
2017-01-07 devel/rubygem-tzinfo03: Use devel/rubygem-tzinfo instead
2017-01-07 devel/rubygem-sprockets22: Use devel/rubygem-sprockets or
devel/rubygem-sprockets3 instead
2017-01-07 devel/rubygem-prototype-rails: Depends on deprecated
www/rubygem-rails
2017-01-07 devel/rubygem-rubigen: Depends on deprecated
devel/rubygem-activesupport
2017-01-07 devel/rubygem-coffee-rails: Depends on deprecated
www/rubygem-railties
2017-01-07 japanese/rubygem-jpmobile: Depends on deprecated rubygem-rails
2017-01-07 mail/rubygem-actionmailer: Upstream support ended
2017-01-07 mail/rubygem-mail25: Use mail/rubygem-mail instead
2017-01-07 security/dradis: Depends on deprecated www/rubygem-rails
2017-01-07 textproc/rubygem-sass-rails: Depends on deprecated
www/rubygem-railties
2017-01-07 www/rubygem-rails: Upstream support ended
2017-01-07 www/rubygem-activeresource: Upstream support ended
2017-01-07 www/rubygem-responders-rails3: Depends on deprecated
www/rubygem-railties
2017-01-07 www/rubygem-jquery-ui-rails: Depends on deprecated
www/rubygem-railties
2017-01-07 www/rubygem-haml-rails: Depends on deprecated www/rubygem-actionpack
2017-01-07 www/rubygem-jquery-rails: Depends on deprecated www/rubygem-railties
2017-01-07 www/rubygem-railties: Upstream support ended
2017-01-07 www/rubygem-actionpack: Upstream support ended
2017-01-07 databases/rubygem-rubyrep: Depends on deprecated
databases/rubygem-activerecord
2017-01-07 databases/rubygem-activerecord-mysql-adapter: Depends on deprecated
databases/rubygem-activerecord
2017-01-07 databases/rubygem-dm-active_model: Depends on deprecated
databases/rubygem-activemodel
06 Dec 2016 23:11:00
Original commit files touched by this commit  0.0.1
Revision:428011
swills search for other commits by this committer
Deprecate ruby@ ports that depend on deprecated rails 3.x

With hat:	ruby@
27 Apr 2016 21:57:32
Original commit files touched by this commit  0.0.1
Revision:414136
swills search for other commits by this committer
Convert USES=gem:autoplist to USES=gem since autoplist is default
27 Apr 2016 16:36:42
Original commit files touched by this commit  0.0.1
Revision:414118
swills search for other commits by this committer
create USES=gem and update rubygem- ports to use it

Note that for now ports still have to have USE_RUBY=yes to use USES=gem

PR:		209041
Differential Revision:	https://reviews.freebsd.org/D6070
01 Apr 2016 14:00:57
Original commit files touched by this commit  0.0.1
Revision:412346
mat search for other commits by this committer
Remove ${PORTSDIR}/ from dependencies, categories d, e, f, and g.

With hat:	portmgr
Sponsored by:	Absolight
27 May 2015 17:52:51
Original commit files touched by this commit  0.0.1
Revision:387639
sunpoet search for other commits by this committer
- Add LICENSE
- Update WWW
10 Jun 2014 07:39:02
Original commit files touched by this commit  0.0.1
Revision:357277
olgeni search for other commits by this committer
Remove indefinite articles and trailing periods from COMMENT, plus
minor COMMENT typos and surrounding whitespace fixes. Categories D-F.

CR:		D196
Approved by:	portmgr (bapt)
30 Oct 2013 02:20:20
Original commit files touched by this commit  0.0.1
Revision:332031
swills search for other commits by this committer
- Add stage support
20 Sep 2013 16:13:49
Original commit files touched by this commit  0.0.1
Revision:327717
bapt search for other commits by this committer
Add NO_STAGE all over the place in preparation for the staging support (cat:
databases)
17 Mar 2013 20:28:22
Original commit files touched by this commit  0.0.1
Revision:314489
zi search for other commits by this committer
New port: databases/rubygem-activerecord-mysql-adapter:

An ActiveRecord adapter for MySQL, based on mysql gem.

WWW: https://rubygems.org/gems/activerecord-mysql-adapter

Number of commits found: 10

Login
User Login
Create account

Servers and bandwidth provided by
New York Internet, iXsystems, and RootBSD

This site
What is FreshPorts?
About the authors
Issues
FAQ
How big is it?
The latest upgrade!
Privacy
Blog
Contact

Search
Enter Keywords:
 
more...

Latest Vulnerabilities
opensmtpd*Feb 27
mbedtlsFeb 24
mbedtlsFeb 24
opensmtpdFeb 24
opensmtpdFeb 24
weechatFeb 21
webkit2-gtk3Feb 19
dovecotFeb 13
gitlab-ceFeb 13
grub2-bhyveFeb 12
libexifFeb 11
linux-flashplayerFeb 11
nginxFeb 09
nginx-develFeb 09
ksh93Feb 07

9 vulnerabilities affecting 34 ports have been reported in the past 14 days

* - modified, not new

All vulnerabilities

Last updated:
2020-02-27 10:24:08


Ports
Home
Categories
Deleted ports
Sanity Test Failures
Newsfeeds

Statistics
Graphs
NEW Graphs (Javascript)
Traffic

Calculated hourly:
Port count 38469
Broken 645
Deprecated 421
Ignore 916
Forbidden 3
Restricted 150
No CDROM 72
Vulnerable 21
Expired 21
Set to expire 393
Interactive 0
new 24 hours 3
new 48 hours6
new 7 days48
new fortnight67
new month184

Servers and bandwidth provided by
New York Internet, iXsystems, and RootBSD
Valid HTML, CSS, and RSS.
Copyright © 2000-2020 Dan Langille. All rights reserved.