notbugIf you buy from Amazon USA, please support us by using this link.
Port details
rubygem-puppetdb_cli PuppetDB CLI Tooling
2.0.0 databases on this many watch lists=0 search for ports that depend on this port Find issues related to this port Report an issue related to this port
Maintainer: puppet@FreeBSD.org search for ports maintained by this maintainer
Port Added: 2019-05-15 06:29:53
Last Update: 2019-05-15 07:29:37
SVN Revision: 501688
Also Listed In: rubygems
License: APACHE20
The PuppetDB CLI project provide Puppet subcommands for querying PuppetDB data,
via `puppet query <query>`, and PuppetDB administrative tasks, `puppet db
<import|export|status>`.

The query subcommand will allow you to query PuppetDB using either the upcoming
PQL syntax of the traditional PuppetDB query syntax (also known as AST).

The db subcommand is a replacement for the older puppetdb <export|import>
commands with faster startup times and much friendlier error messages.

WWW: https://github.com/puppetlabs/puppetdb-cli
SVNWeb : Homepage
    Pseudo-pkg-plist information, but much better, from make generate-plist
    Expand this list (5 items)
  1. bin/puppet-db
  2. bin/puppet-query
  3. /usr/local/share/licenses/rubygem-puppetdb_cli-2.0.0/catalog.mk
  4. /usr/local/share/licenses/rubygem-puppetdb_cli-2.0.0/LICENSE
  5. /usr/local/share/licenses/rubygem-puppetdb_cli-2.0.0/APACHE20
  6. Collapse this list.
Dependency lines:
  • rubygem-puppetdb_cli>0:databases/rubygem-puppetdb_cli

To install the port: cd /usr/ports/databases/rubygem-puppetdb_cli/ && make install clean
To add the package: pkg install rubygem-puppetdb_cli

PKGNAME: rubygem-puppetdb_cli

There is no flavor information for this port.

distinfo:

TIMESTAMP = 1557792857
SHA256 (rubygem/puppetdb_cli-2.0.0.gem) = 4558c01d37cae4c5dd637d1585bd5be373d2e601c998526fc16b9a89768f9444
SIZE (rubygem/puppetdb_cli-2.0.0.gem) = 18432


NOTE: FreshPorts displays only information on required and default dependencies. Optional dependencies are not covered.

Build dependencies:
  1. ruby25 : lang/ruby25
  2. gem25 : devel/ruby-gems
Runtime dependencies:
  1. rubygem-cri>0 : devel/rubygem-cri
  2. rubygem-pl-puppetdb-ruby>0 : databases/rubygem-pl-puppetdb-ruby
  3. ruby25 : lang/ruby25
  4. gem25 : devel/ruby-gems
Patch dependencies:
  1. ruby25 : lang/ruby25
  2. gem25 : devel/ruby-gems
Extract dependencies:
  1. ruby25 : lang/ruby25
There are no ports dependent upon this port

Configuration Options
     No options to configure

USES:
gem

Master Sites:
  1. https://rubygems.org/downloads/
Port Moves

Number of commits found: 1

Commit History - (may be incomplete: see SVNWeb link above for full details)
DateByDescription
15 May 2019 06:29:37
Original commit files touched by this commit  2.0.0
Revision:501688
romain search for other commits by this committer
Update to 2.0.0

puppetdb-cli was rewritten in Ruby, so the port was moved from
databases/puppetdb-cli to databases/rubygem-puppetdb_cli.

With hat:	puppet

Number of commits found: 1

Login
User Login
Create account

Servers and bandwidth provided by
New York Internet, iXsystems, and RootBSD

This site
What is FreshPorts?
About the authors
Issues
FAQ
How big is it?
The latest upgrade!
Privacy
Forums
Blog
Contact

Search
Enter Keywords:
 
more...

Latest Vulnerabilities
firefoxMay 22
firefox-esrMay 22
libxulMay 22
linux-firefoxMay 22
linux-seamonkeyMay 22
linux-thunderbirdMay 22
seamonkeyMay 22
thunderbirdMay 22
waterfoxMay 22
rustMay 15
linux-flashplayerMay 14
samba46May 14
samba47May 14
samba48May 14
php71-exifMay 11

7 vulnerabilities affecting 119 ports have been reported in the past 14 days

* - modified, not new

All vulnerabilities

Last updated:
2019-05-22 12:01:45


Ports
Home
Categories
Deleted ports
Sanity Test Failures
Newsfeeds

Statistics
Graphs
NEW Graphs (Javascript)
Traffic

Calculated hourly:
Port count 36494
Broken 79
Deprecated 117
Ignore 298
Forbidden 3
Restricted 163
No CDROM 74
Vulnerable 32
Expired 34
Set to expire 90
Interactive 0
new 24 hours 4
new 48 hours10
new 7 days55
new fortnight100
new month183

Servers and bandwidth provided by
New York Internet, iXsystems, and RootBSD
Valid HTML, CSS, and RSS.
Copyright © 2000-2019 Dan Langille. All rights reserved.