notbugAs an Amazon Associate I earn from qualifying purchases.
Want a good read? Try FreeBSD Mastery: Jails (IT Mastery Book 15)
Want a good monitor light? See my photosAll times are UTC
Ukraine
This referral link gives you 10% off a Fastmail.com account and gives me a discount on my Fastmail account.
New feature planned: get notified when the package is available. Now is the time to contribute ideas/suggestions.
Port details
linux-libsigc++20 Callback Framework for C++ (linux version)
2.0.17_2 devel Deleted on this many watch lists=1 search for ports that depend on this port Find issues related to this port Report an issue related to this port View this port on Repology. pkg-fallout 2.0.17_2Version of this port present on the latest quarterly branch.
Expired This port expired on: 2013-02-28
Ignore IGNORE: bsd.linux-rpm.mk test failed: default package building at OSVERSION>=800076 was changed to linux-f10 ports, please define OVERRIDE_LINUX_NONBASE_PORTS to build other linux infrastructure ports
Maintainer: emulation@FreeBSD.org search for ports maintained by this maintainer
Port Added: 2007-06-28 17:45:58
Last Update: 2013-05-30 09:11:53
SVN Revision: 319410
People watching this port, also watch:: p5-type1inst, font-misc-meltho, showfont
Also Listed In: linux
License: not specified in port
WWW:
http://libsigc.sourceforge.net/
Description:
Libsigc++ -- The Typesafe Callback Framework for C++ (linux version) This library implements a full callback system for use in widget libraries, abstract interfaces, and general programming. WWW: http://libsigc.sourceforge.net/
Homepage    cgit ¦ GitHub ¦ GitHub ¦ GitLab ¦ SVNWeb

Manual pages:
FreshPorts has no man page information for this port.
pkg-plist: as obtained via: make generate-plist
There is no configure plist information for this port.
Dependency lines:
  • linux-libsigc>0:devel/linux-libsigc++20
No installation instructions:
This port has been deleted.
PKGNAME: linux-libsigc
Flavors: there is no flavor information for this port.
ONLY_FOR_ARCHS: i386 amd64
distinfo:
There is no distinfo for this port.

No package information for this port in our database
Sometimes this happens. Not all ports have packages.
Dependencies
NOTE: FreshPorts displays only information on required and default dependencies. Optional dependencies are not covered.
Runtime dependencies:
  1. fedora-release : emulators/linux_base-f10
There are no ports dependent upon this port

Configuration Options:
No options to configure
Options name:
N/A
FreshPorts was unable to extract/find any pkg message
Master Sites:
Expand this list (7 items)
Collapse this list.
  1. ftp://ftp.FreeBSD.org/pub/FreeBSD/ports/distfiles/rpm/i386/fedora/4/
  2. ftp://ftp.c.saper.info/distfiles/rpm/i386/fedora/4/
  3. http://critical.ch/distfiles/rpm/i386/fedora/4/
  4. http://energy.critical.ch/distfiles/rpm/i386/fedora/4/
  5. http://fneu.fr/distfiles/rpm/i386/fedora/4/
  6. http://snow.critical.ch/distfiles/rpm/i386/fedora/4/
  7. http://www.bluestop.org/distfiles/rpm/i386/fedora/4/
Collapse this list.

Number of commits found: 9

Commit History - (may be incomplete: for full details, see links to repositories near top of page)
CommitCreditsLog message
2.0.17_2
30 May 2013 09:11:53
Revision:319410Original commit files touched by this commit
rene search for other commits by this committer
- Finish removal of support for Linux 2.4 in bsd.linux-apps.mk and
  bsd.linux-rpm.mk.  The default linux version is now Fedora 10.
- Remove now obsolete checks for Linux 2.4 in emulators/linux_base-c6,
  emulators/linux_base-f10, and emulators/linux_dist-gentoo-stage3.
  While there, remove superfluous -p argument from ${MKDIR}.
- Remove now obsolete check for Linux 2.4 or FreeBSD 6 and lower from
  astro/google-earth.
- Remove expired Fedora Core 4 ports which were only used on FreeBSD 7
  and below.
- Update LEGAL and MOVED

PR:		ports/176877
Submitted by:	myself
Approved by:	portmgr (bapt)
Exp-run by:	bapt
2.0.17_2
14 Apr 2012 20:24:51
Original commit files touched by this commit Sanity Test Failure
netchild search for other commits by this committer
Set the expiration date for all ports which depend upon linux_base-fc4 to
the EoL of the last 7.x release. The 7.x branch is the only supported
FreeBSD version not yet at his EoL which needs a linux 2.4 based linuxulator
environment (linux_base-f10 doesn't work there).

I didn't bump the portrevision, this is mostly done as a hint for ports
committers to tell them that at least the emulation@-owned ports need
to stay until then (even the forbidden ones). The dependent ports need to
go at the same time, but are free to be deleted before.

Discussed with: bsam
2.0.17_2
04 Jul 2011 21:52:35
Original commit files touched by this commit
dougb search for other commits by this committer
Assist with de-MD5'ification
2.0.17_2
07 Mar 2011 15:08:26
Original commit files touched by this commit
ehaupt search for other commits by this committer
Unify maintainer address for emulation ports.
(freebsd-emulation@FreeBSD.org -> emulation@FreeBSD.org)

Discussed with: netchild (emulation)
2.0.17_2
03 Mar 2011 09:26:45
Original commit files touched by this commit
ehaupt search for other commits by this committer
Add a more reliable mirrors for fc4 and f10 linux emulation ports.

Triggered by:   distilator
Reviewed by:    netchild (emulation)
2.0.17_2
02 Jun 2009 21:15:40
Original commit files touched by this commit
bsam search for other commits by this committer
. add linux-f10 ports to the rank of CONFLICTS for linux-fc4 ports;
. bump PORTREVISIONs.
2.0.17_1
01 Apr 2009 10:10:16
Original commit files touched by this commit
bsam search for other commits by this committer
Finish repocopies of new linux-f8 infrastructure ports:
. add CONFLICTS to 47 original ports;
. bump PORTREVISIONs for all of them;
. pet portlint for 2-3 ports (misplaced PORTREVISION).
2.0.17
19 Apr 2008 17:56:05
Original commit files touched by this commit Sanity Test Failure
miwi search for other commits by this committer
- Remove unneeded dependency from gtk12/gtk20 [1]
- Remove USE_XLIB/USE_X_PREFIX/USE_XPM in favor of USE_XORG
- Remove X11BASE support in favor of LOCALBASE or PREFIX
- Use USE_LDCONFIG instead of INSTALLS_SHLIB
- Remove unneeded USE_GCC 3.4+

Thanks to all Helpers:
        Dmitry Marakasov, Chess Griffin, beech@, dinoex, rafan, gahr,
        ehaupt, nox, itetcu, flz, pav

PR:             116263
Tested on:      pointyhat
Approved by:    portmgr (pav)
2.0.17
28 Jun 2007 17:44:14
Original commit files touched by this commit
bsam search for other commits by this committer
Libsigc++ -- The Typesafe Callback Framework for C++ (linux version)

This library implements a full callback system for use in widget libraries,
abstract interfaces, and general programming.

WWW: http://libsigc.sourceforge.net/

Number of commits found: 9