notbugAs an Amazon Associate I earn from qualifying purchases.
Want a good read? Try FreeBSD Mastery: Jails (IT Mastery Book 15)

/commits.php is going away

I'm proposing to take /commits.php away - it mainly duplicates the home page. Details in this GitHub issue.
Port details
py-utils General utility modules that simplify common programming in Python
0.4.0 devel Deleted on this many watch lists=3 search for ports that depend on this port Find issues related to this port Report an issue related to this port View this port on Repology. pkg-fallout 0.4.0Version of this port present on the latest quarterly branch.
Deprecated DEPRECATED: Uses deprecated version of python
Expired This port expired on: 2020-12-12
Maintainer: daniel@netwalk.org search for ports maintained by this maintainer
Port Added: 2006-03-20 19:24:20
Last Update: 2020-11-16 18:47:26
SVN Revision: 555508
People watching this port, also watch:: glib, pcre, expat
Also Listed In: python
License: not specified in port
Description:
SVNWeb : git : Homepage
pkg-plist: as obtained via: make generate-plist
There is no configure plist information for this port.
Dependency lines:
  • ${PYTHON_PKGNAMEPREFIX}utils>0:devel/py-utils@${PY_FLAVOR}
No installation instructions: this port has been deleted.
The package name of this deleted port was:
PKGNAME: py27-utils
Package flavors (<flavor>: <package>)
  • py27: py27-utils
distinfo:
Packages (timestamps in pop-ups are UTC):
py27-utils
ABIlatestquarterly
FreeBSD:11:aarch640.4.00.4.0
FreeBSD:11:amd64--
FreeBSD:11:armv60.4.00.4.0
FreeBSD:11:i386--
FreeBSD:11:mips--
FreeBSD:11:mips640.4.00.4.0
FreeBSD:12:aarch640.4.0-
FreeBSD:12:amd64--
FreeBSD:12:armv60.4.00.4.0
FreeBSD:12:armv70.4.00.4.0
FreeBSD:12:i386--
FreeBSD:12:mips--
FreeBSD:12:mips640.4.00.4.0
FreeBSD:12:powerpc64--
FreeBSD:13:aarch64--
FreeBSD:13:amd64--
FreeBSD:13:armv6--
FreeBSD:13:armv7--
FreeBSD:13:i386--
FreeBSD:13:mips--
FreeBSD:13:mips64--
FreeBSD:13:powerpc64--
FreeBSD:14:aarch64--
FreeBSD:14:amd64--
FreeBSD:14:armv6--
FreeBSD:14:armv7--
FreeBSD:14:i386--
FreeBSD:14:mips--
FreeBSD:14:mips64--
FreeBSD:14:powerpc64--
 

Dependencies
NOTE: FreshPorts displays only information on required and default dependencies. Optional dependencies are not covered.
Build dependencies:
  1. py27-setuptools>0 : devel/py-setuptools@py27
  2. python2.7 : lang/python27
Runtime dependencies:
  1. py27-setuptools>0 : devel/py-setuptools@py27
  2. python2.7 : lang/python27
There are no ports dependent upon this port

Configuration Options:
Options name:

USES:

Master Sites:
Expand this list (1 items)
Collapse this list.
  1. http://www.voidspace.org.uk/downloads/
Collapse this list.
Port Moves
  • port deleted on 2020-11-16
    REASON: Removed on maintainers request, uses EOLed python27

Number of commits found: 12

Commit History - (may be incomplete: see SVNWeb link above for full details)
DateByDescription
16 Nov 2020 18:47:26
Original commit files touched by this commit Revision:555508  0.4.0
rhurlin search for other commits by this committer
devel/py-utils: Removed on maintainers request, uses EOLed python27

Port is already deprecated, has no dependents, and sources are older than a
decade.

PR:		249663
Submitted by:	Steve Wills <swills@FreeBSD.org>
Approved by:	arrowd (mentor), Daniel Bretoi <daniel@netwalk.org> (maintainer)
Differential Revision:	https://reviews.freebsd.org/D27233
11 Nov 2020 12:14:55
Original commit files touched by this commit Revision:554889  0.4.0
antoine search for other commits by this committer
Deprecate a few python 2.7 ports
30 Nov 2017 15:50:34
Original commit files touched by this commit Revision:455210  0.4.0  Sanity Test Failure
mat search for other commits by this committer
Convert Python ports to FLAVORS.

  Ports using USE_PYTHON=distutils are now flavored.  They will
  automatically get flavors (py27, py34, py35, py36) depending on what
  versions they support.

  There is also a USE_PYTHON=flavors for ports that do not use distutils
  but need FLAVORS to be set.  A USE_PYTHON=noflavors can be set if
  using distutils but flavors are not wanted.

  A new USE_PYTHON=optsuffix that will add PYTHON_PKGNAMESUFFIX has been
  added to cope with Python ports that did not have the Python
  PKGNAMEPREFIX but are flavored.

  USES=python now also exports a PY_FLAVOR variable that contains the
(Only the first 15 lines of the commit message are shown above View all of this commit message)
20 Oct 2014 16:04:14
Original commit files touched by this commit Revision:371280  0.4.0
mva search for other commits by this committer
- Convert ports of devel/ to USES=python

Approved by:	portmgr (implicit)
07 Mar 2014 16:49:10
Refresh Original commit files touched by this commit Revision:347405  Sanity Test Failure
bapt search for other commits by this committer
Convert d* to USES=zip
15 Feb 2014 22:10:22
Original commit files touched by this commit Revision:344490  0.4.0
antoine search for other commits by this committer
- Stage support
- Use PYDISTUTILS_AUTOPLIST
- Remove infozip dependency
20 Sep 2013 17:13:47
Original commit files touched by this commit Revision:327724  0.4.0
bapt search for other commits by this committer
Add NO_STAGE all over the place in preparation for the staging support (cat:
devel part 3)
07 Feb 2011 22:43:48
Original commit files touched by this commit   0.4.0
mi search for other commits by this committer
Upgrade from 0.3.0 to 0.4.0.

Approved by:    maintainer
Feature safe:   yes
28 Dec 2008 10:54:08
Original commit files touched by this commit   0.3.0
pgollucci search for other commits by this committer
CATEGORIES+=    python   for py- ports missing it

PR:             ports/124921
Approved by:    portmgr (pav)
17 Nov 2008 05:07:14
Original commit files touched by this commit   0.3.0
lwhsu search for other commits by this committer
- Update to 0.3.0
- Take advantage of COPYTREE_SHARE
- the patch file patch-python25 is unnecessary. It's been fixed since ver.
0.3.0.

PR:             ports/128907
Submitted by:   Yi-Jheng Lin <yzlin AT cs.nctu.edu.tw>
Approved by:    Daniel <daniel AT netwalk.org> (maintainer)
30 Jul 2007 09:42:28
Original commit files touched by this commit   0.2.5
alexbl search for other commits by this committer
 - Make Python 2.5.1 the default Python version
 - Add significantly better support in bsd.python.mk for working with
   Python Eggs and the easy_install system

Tested by:      pointyhat runs
Approved by:    pav (portmgr)
Most work by:   perky
Thanks to:      pav
20 Mar 2006 19:22:13
Original commit files touched by this commit   0.2.5
pav search for other commits by this committer
The Voidspace Pythonutils package is a simple way of installing the Voidspace
collection of modules. These are currently:

    ConfigObj 4.1.0 - Easy config file reading/writing
    validate 0.2.1 - Validation and type conversion system
    listquote 1.4.0 - String to list conversion
    StandOut 2.1.0 - Simple logging and output control object
    pathutils 0.2.4 - For working with paths and files
    cgiutils 0.3.5 - CGI helpers
    urlpath 0.1.0 - Functions for handling URLs
    odict 0.2.1 - Ordered Dictionary Class

Several of the Voidspace Projects depend on these modules. They are also useful
in their own right of course. They are primarily general utility modules that
simplify common programming tasks in Python.

WWW: http://www.voidspace.org.uk/python/pythonutils.html

PR:             ports/94657
Submitted by:   Daniel <daniel@netwalk.org>

Number of commits found: 12