notbugAs an Amazon Associate I earn from qualifying purchases.
Want a good read? Try FreeBSD Mastery: Jails (IT Mastery Book 15)

Why was the website so slow for so long?

The cause of the slowdown was a change to the ZFS dataset. In conjunction with the database server, very little caching was being done. This combination resulted in increased disk I/O as the system churned through the database. Details in the blog post which outlines the various things which changed. Many graphs.

Port details
rubygem-devise-rails50 Flexible authentication solution for Rails with Warden
4.5.0 devel Deleted on this many watch lists=0 search for ports that depend on this port Find issues related to this port Report an issue related to this port 4.5.0Version of this port present on the latest quarterly branch.
Deprecated DEPRECATED: Use devel/rubygem-devise (depends on Rails 5.0) instead
Expired This port expired on: 2019-06-30
Maintainer: ruby@FreeBSD.org search for ports maintained by this maintainer
Port Added: 2017-05-25 01:43:44
Last Update: 2019-06-30 12:01:26
SVN Revision: 505416
Also Listed In: rubygems
License: MIT
Description:
SVNWeb : Homepage
pkg-plist: as obtained via: make generate-plist
Expand this list (3 items)
  1. /usr/local/share/licenses/rubygem-devise-rails50-4.5.0/catalog.mk
  2. /usr/local/share/licenses/rubygem-devise-rails50-4.5.0/LICENSE
  3. /usr/local/share/licenses/rubygem-devise-rails50-4.5.0/MIT
Collapse this list.
Dependency lines:
  • rubygem-devise-rails50>0:devel/rubygem-devise-rails50
No installation instructions: this port has been deleted.
The package name of this deleted port was:
PKGNAME: rubygem-devise-rails50
Flavors: there is no flavor information for this port.
distinfo:

Dependencies
NOTE: FreshPorts displays only information on required and default dependencies. Optional dependencies are not covered.
Build dependencies:
  1. ruby25 : lang/ruby25
  2. gem25 : devel/ruby-gems
Runtime dependencies:
  1. rubygem-bcrypt>=3.0 : security/rubygem-bcrypt
  2. rubygem-orm_adapter>=0.1 : devel/rubygem-orm_adapter
  3. rubygem-railties50>=4.1.0 : www/rubygem-railties50
  4. rubygem-responders-rails50>=0 : www/rubygem-responders-rails50
  5. rubygem-warden>=1.2.3 : devel/rubygem-warden
  6. ruby25 : lang/ruby25
  7. gem25 : devel/ruby-gems
Patch dependencies:
  1. ruby25 : lang/ruby25
  2. gem25 : devel/ruby-gems
Extract dependencies:
  1. ruby25 : lang/ruby25
NOTE: dependencies for deleted ports are notoriously suspect
This port is required by:
for Run

    Deleted ports which required this port:

    Expand this list of 1 deleted port
    1. security/rubygem-devise-two-factor-rails50*
    2. Collapse this list of deleted ports.
* - deleted ports are only shown under the This port is required by section. It was harder to do for the Required section. Perhaps later...

Configuration Options

USES:

Master Sites:
  1. https://rubygems.org/downloads/
Port Moves
  • port moved to devel/rubygem-devise on 2019-06-30
    REASON: Has expired: Use devel/rubygem-devise (depends on Rails 5.0) instead

Number of commits found: 9

Commit History - (may be incomplete: see SVNWeb link above for full details)
DateByDescription
30 Jun 2019 11:01:26
Original commit files touched by this commit  4.5.0
Revision:505416
rene search for other commits by this committer
Remove expired ports:
2019-06-30 sysutils/cfengine33: No longer supported upstream
2019-06-30 sysutils/cfengine-masterfiles38: No longer supported upstream
2019-06-30 sysutils/cfengine39: No longer supported upstream
2019-06-30 sysutils/cfengine-masterfiles37: NO longer supported upstream
2019-06-30 sysutils/cfengine37: No longer supported upstream
2019-06-30 net/morebalance: Abandonware and depends on expiring games/libggz
2019-06-30 sysutils/cfengine36: No longer supported upstream
2019-06-30 sysutils/cfengine-masterfiles36: No longer supported upstream
2019-06-30 sysutils/cfengine34: No longer supported upstream
2019-06-30 sysutils/cfengine35: No longer supported upstream
2019-06-30 sysutils/cfengine-masterfiles39: No longer supported upstream
2019-06-30 devel/py-typed-ast12: Use devel/py-typed-ast instead
2019-06-30 devel/rubygem-devise-rails50: Use devel/rubygem-devise (depends on
Rails 5.0) instead
2019-06-30 security/rubygem-devise-two-factor-rails50: Use
security/rubygem-devise-two-factor (depends on Rails 5.0) instead
(Only the first 15 lines of the commit message are shown above View all of this commit message)
22 Jun 2019 21:49:23
Original commit files touched by this commit  4.5.0
Revision:504903
sunpoet search for other commits by this committer
Mark DEPRECATED and set EXPIRATION_DATE to 2019-06-30
16 Aug 2018 23:43:05
Original commit files touched by this commit  4.5.0
Revision:477394
sunpoet search for other commits by this committer
Update to 4.5.0

Changes:	https://github.com/plataformatec/devise/blob/master/CHANGELOG.md
18 Mar 2018 11:27:30
Original commit files touched by this commit  4.4.3
Revision:464899
sunpoet search for other commits by this committer
Update to 4.4.3

Changes:	https://github.com/plataformatec/devise/blob/master/CHANGELOG.md
16 Mar 2018 15:21:29
Original commit files touched by this commit  4.4.2
Revision:464701
sunpoet search for other commits by this committer
Update to 4.4.2

Changes:	https://github.com/plataformatec/devise/blob/master/CHANGELOG.md
24 Jan 2018 18:46:18
Original commit files touched by this commit  4.4.1
Revision:459871
sunpoet search for other commits by this committer
Update to 4.4.1

Changes:	https://github.com/plataformatec/devise/blob/master/CHANGELOG.md
30 Dec 2017 18:17:14
Original commit files touched by this commit  4.4.0
Revision:457619
sunpoet search for other commits by this committer
Update to 4.4.0

Changes:	https://github.com/plataformatec/devise/blob/master/CHANGELOG.md
05 Aug 2017 03:25:17
Original commit files touched by this commit  4.3.0
Revision:447386
jrm search for other commits by this committer
Set ruby@FreeBSD.org as maintainer of these ports, so that ruby team can
more easily contribute to their maintenance.
25 May 2017 01:43:37
Original commit files touched by this commit  4.3.0
Revision:441635
jrm search for other commits by this committer
devel/rubygem-devise-rails50: Create rails version 5.0 port by copying
devel/rubygem-devise-rails5

Approved by:	swills (mentor, implicit)

Number of commits found: 9

Login
User Login
Create account

Servers and bandwidth provided by
New York Internet, iXsystems, and RootBSD

This site
What is FreshPorts?
About the authors
Issues
FAQ
How big is it?
The latest upgrade!
Privacy
Blog
Contact

Search
Enter Keywords:
 
more...

Latest Vulnerabilities
weechatFeb 21
webkit2-gtk3Feb 19
dovecotFeb 13
gitlab-ceFeb 13
grub2-bhyveFeb 12
libexifFeb 11
linux-flashplayerFeb 11
nginxFeb 09
nginx-develFeb 09
ksh93Feb 07
ksh93-develFeb 07
clamavFeb 05
py-django111Feb 04
py-django22Feb 04
py-django30Feb 04

8 vulnerabilities affecting 50 ports have been reported in the past 14 days

* - modified, not new

All vulnerabilities

Last updated:
2020-02-23 08:59:33


Ports
Home
Categories
Deleted ports
Sanity Test Failures
Newsfeeds

Statistics
Graphs
NEW Graphs (Javascript)
Traffic

Calculated hourly:
Port count 38438
Broken 645
Deprecated 418
Ignore 916
Forbidden 3
Restricted 150
No CDROM 72
Vulnerable 23
Expired 4
Set to expire 390
Interactive 0
new 24 hours 3
new 48 hours13
new 7 days25
new fortnight53
new month314

Servers and bandwidth provided by
New York Internet, iXsystems, and RootBSD
Valid HTML, CSS, and RSS.
Copyright © 2000-2020 Dan Langille. All rights reserved.